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1
INTRODUCTION

Welcome to Canvas, a completely integrated environment for illus-
tration, page layout, imaging, presentations, and Web publishing. 

Canvas lets you work with vector objects, images, text, and 
imported graphics without having to switch to other applications. 
Whether you are a beginner or an experienced designer, the tools 
and features in Canvas can make you more productive. 

Canvas provides a complete solution for home, small business, 
school, and corporate users:

• An array of tools for illustration, layout, editing, proofing, 
and final output, so you can take projects from start to fin-
ish in Canvas.

• A dynamic and flexible interface, including a Toolbar you 
can configure with commands, tools, and styles as well as 
customizable keyboard shortcuts; a Docking bar to store 
palettes; a Properties bar for tool settings and object 
manipulation; a Dynamic Help window.

• A cross-platform solution that lets you share Canvas docu-
ments across Mac OS and Windows platforms, and sup-
ports all standard file formats.

About the documentation
Please take a few minutes to read the following information about 
the Canvas documentation.

The Canvas User’s Guide describes the commands, tools, and features 
of Canvas for Mac and Windows operating systems. 

Certain terms and abbreviations are used in this manual to 
describe procedures. In most cases, Canvas works exactly the same 
under Mac OS and Windows. The documentation points out func-
tional differences when necessary. 

Mac refers to the Mac OS X operating system. When a procedure 
applies to Mac OS only, the instructions say “(Mac)”. 

Tip
Throughout this book you’ll find 
tips for working efficiently and 
exploring creative possibilities. 
Items labeled “Important” pro-
vide information to help you avoid 
problems.
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Windows refers to 32-bit Windows, including Windows 2000, ME, 
and XP. When a procedure applies to Windows only, the instruc-
tions say “(Windows)”.

In addition to the Canvas User’s Guide, the Canvas Color Printing Guide 
is also available in PDF format on the Canvas CD. You can find 
this file in the MANUALS folder.

Edition icons
To indicate the items that are only available for the GIS Mapping 
or Scientific Imaging Edition, icons have been added for reference.

Keyboard keys
This manual uses standard names and abbreviations for keyboard 
keys; your keyboard might use different labels.

Icon Meaning

This feature is only available for the GIS Mapping Edition.

This feature is only available for the Scientific Imaging Edition.

Key name Description

Alt The Alternate key, usually labeled “Alt” on Windows key-
boards

Command The key labeled “Command” or marked with a propeller 
symbol on Mac keyboards

Control The key labeled “Control” or “Ctrl” on Mac keyboards

Ctrl The key labeled “Ctrl” on Windows keyboards

Option The key labeled “Option” on Mac keyboards

Shift The key used to type uppercase characters

Enter The key labeled “Enter” on Mac keyboards. This key has a 
different function than the “Return” key.

Return On Mac keyboards, the key labeled “Return.” On Win-
dows keyboards, the key labeled “Return” or “Enter.”
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Choosing commands
When a procedure tells you to choose a command, the instruction 
is written: 

Choose Edit > Paste 

This tells you to open the Edit menu and choose the Paste com-
mand. You can use a keyboard shortcut if the command has one.

Some menu items open a submenu of related commands. When 
the documentation tells you to choose a submenu command, the 
instruction is written: 

Choose Object > Arrange > Bring To Front

This tells you to open the Object menu, choose Arrange to open the 
submenu, and then choose the Bring To Front command.

Choosing commands in the context menu
You can choose commands from a menu that pops up wherever the 
pointer is in Canvas. The commands in the menu are based on 
what you are doing; therefore, the menu is called the context menu.

To choose a command from the context menu, do the following:

Mac Press the Control key and click the mouse at the same time.

Windows Press the secondary (right) mouse button.

Using modifier keys
For some actions, you need to press a keyboard key while you click 
or drag the mouse; e.g., to select several objects, press the Shift key 
while you click each object. This can be written as Shift-click. If you 
press the Command key, for example, while you drag the mouse, 
the action can be written as Command-drag.

When referring to Canvas for Windows, some instructions say to 
“right-click” an object. This means to click the object using the sec-
ondary button, usually the right button, on the mouse.

Getting help and updating Canvas
The following functions are available by opening the Help menu in 
Canvas.
Getting help and updating Canvas 1.3
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Using electronic manual
Canvas includes an electronic version of the User’s Guide that lets 
you refer to the documentation while you work. 

To view Help in Canvas (Mac) Choose Help > Electronic Manual.

To view Help in Canvas (Windows) Press the F1 key to display the 
Electronic Manual or choose Help > Electronic Manual.

When you press F1 and a dialog box is open or a menu item is 
selected, the Electronic Manual displays the appropriate index 
entries for this dialog box or menu item. Otherwise, the Contents 
topic appears. You can also search for topics.

License Manager
The License Manager indicates the status of a Canvas edition (pur-
chased or trial).

Note: You must be connected to the Internet to activate a trial edi-
tion or buy a different edition.

• To use a trial edition: Click the Click to TRY option in the 
manager. The edition will be enabled for a period of 15 days.

To purchase an edition
1 Click the Click to BUY option in the manager. Your browser 
will open to www.deneba.com where you can purchase a new edi-
tion. When you receive the serial number for the new edition, 
open the License Manager and select the edition in the list. 

2 Click the Enter New Key button and type the serial number.

3 Click OK.

Tip
For the latest information on Can-
vas, be sure to view any “Read 
Me” files included with the pro-
gram.
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4 Close the License Manager. 

Canvas auto updates
Canvas has an update feature that automatically checks for and 
installs the latest version of the program from Deneba's Web site. 
You must, however, be connected to the Internet and be using a 
properly registered copy of Canvas.

By default, Canvas checks for program updates whenever the appli-
cation is launched and every twenty-four hours thereafter. You can 
manually check for updates by choosing Help > Check For Updates 
(Mac) or Help > Update Canvas (Windows). You can also disable 
this feature by deselecting the checkbox AutoCheck for updates 
that appears in the Updating Canvas dialog box. 

If a later version of Canvas is available when you launch the appli-
cation, you will have a choice as to whether or not to update your 
copy. Click OK to auto-update your copy of Canvas. After the 
update process is complete, Canvas launches.

If you have not registered your copy of Canvas prior to running the 
Auto-Update feature for the first time, it will guide you through the 
online registration process. You must enter a valid serial number 
for the Auto-Update feature to continue.

Viewing Canvas 9 online
The Canvas Web site hyperlink in the Help menu directs your 
browser to www.canvas9.com.

Canvas looks for an installed browser, launches it, and loads the 
Web site.

Visit the site periodically to find tips to help you get the most out of 
Canvas, as well as check for program updates, technical notes, plug-
ins, user profiles, and contact information. 

Check Document
Select this command to check that your document does not contain 
errors while you are working. When chosen, the Document Verifi-
cation Details dialog box opens. Any errors will be indicated in this 
dialog box. The Verify on save checkbox is selected by default.

Tip
To read about what is con-
tained in the update, click the 
Release Notes button.
Getting help and updating Canvas 1.5
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2
TUTORIALS

This section introduces various Canvas features. A series of lessons 
present procedures and examples for you to follow. We recommend 
that you complete as many lessons as possible if you are a new Can-
vas user.

Canvas, an integrated program with powerful features for illustra-
tion, precision drawing, painting, and image editing, text layout, 
and Web publishing.

By working through the lessons, you’ll gain a basic understanding 
of the program’s capabilities while you learn how to use the Canvas 
interface. You can complete the lessons in order, or skip to the ones 
you feel are most relevant to you.

Before you begin
The tutorial requires that you understand common terms and pro-
cedures for your operating system. You should know how to do the 
following:

• launch applications

• open and save files

• perform basic actions with a mouse, like click and drag

• move, close, and resize windows

• use menu commands

• use the keyboard, including modifier keys

If you are not familiar with these operations, consult your operating 
system documentation or a basic computing reference book for 
instructions.

Canvas basics
Canvas integrates a wide range of features within a single interface. 
Unlike separate image-editing, page layout, and illustration pro-
grams, Canvas lets you use a core set of tools and procedures to 
work with all different types of objects — text, vector, or image. 
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This section introduces basic procedures, including working with 
documents, selecting objects, editing objects, and undoing actions. 
These procedures are used throughout the lessons in this guide. 

Working with documents
Canvas can not only open Canvas files but also a great number of 
file formats, such as JPEG, TIFF, PDF, GIF, etc. Choose File > 
Open to see the compatible formats.

To open existing documents
1 Choose File > Open and the directory dialog box appears. 

2 Browse through the directories to find your file.

3 Highlight or select your file.

4 Click the Open button.

To start a new Canvas document
1 Choose File > New and the New dialog box opens.

2 Select the type of document: Illustration, Publication, Anima-
tion, or Presentation.

3 Choose the Document Size and Document Units.

• Canvas templates: You can also select a template from the Use 
Template menu. Template choices change depending on type of 
document selected.

Selecting tools from the Smart Toolbox
To use a tool, you select it from the Smart Toolbox™, which con-
tains all the Canvas tools used for drawing, text, image-editing, and 
effects. The Toolbox displays 14 tools at a time, while the remain-
ing tools are available from tool palettes that snap out from the 
Toolbox.

• To display the Toolbox: Choose Window > Palettes > Show 
Toolbox.

• To select a tool displayed in the Toolbox: Click the tools icon. 

To select tools from tool palettes
To select a tool that isn’t displayed in the Toolbox, click the icon of 
the tool palette that contains the tool. Click the icon of the tool you 
want to select.

Tip
The Toolbox can be moved 
around the main window. 
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Selecting and moving objects
To select, move, and edit items in Canvas, use one of the Selection 
tools in the Toolbox. The appearance of the pointer changes 
depending on which of the tools has been selected.

Selecting objects is one of the most common operations in Canvas. 
You select objects when you want to apply commands and 
attributes, copy, or edit the objects.

• To select an object: Click the object with one of the Selection 
tools.

• To select more than one object: Shift-click (press Shift while 
clicking) each object, or drag a selection box around the objects 
with the Selection tool.

When you select an object, a rectangle called a bounding box appears 
around the object. To move an object, drag it with the Selection 
tool. To move multiple objects, first select the objects you want to 
move, and then drag one of the objects.

Object types
Canvas has three major types of objects — vector, text, and paint 
objects. 

Vector object An object defined by anchor points and a path. The 
Line, Rectangle, Oval, Arc and similar tools draw vector objects.

Text object An object that contains text.

Paint object An object that contains a raster image. The term is 
synonymous with image object.

Edit modes
You can also use the Selection tool to place objects in edit mode. Edit 
mode lets you modify objects in special ways. 

A Selection tool
B Direct Group Selection tool
C Lasso Selection tool
D Direct Edit Selection tool
E Direct Edit Lasso tool

A bounding box with 
handles surrounding a 
selected object

Drag with the Selection 
tool to make a selection 
box
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Path edit mode Path edit mode is for editing the paths of vector 
objects. In path edit mode you can change the shape of a vector 
object by adding, deleting, and moving anchor points.

Text edit mode Text edit mode is for editing text. In text edit 
mode you can type text, select specific characters to edit, and place 
the insertion point in text. In this mode, the pointer is an I-beam. 
Drag the I-beam over text to select it. Click in a text object to place 
the insertion point (see “Page Layout & typography,” page 7.1).

Paint edit mode Paint edit mode is for painting and editing 
images. In paint edit mode, you can edit the pixels of an image 
using the painting tools and Image menu commands (see “Intro-
duction to image editing,” page 6.1).

• To place a vector object in edit mode: Double-click the vector 
object with the Selection tool or click the object with the Direct Edit 
Selection tool.

• To place a paint object in edit mode: Double-click the paint 
image with the Selection tool.

• To place a text object in edit mode: Double-click the text object 
with the Selection tool or click the text object with the Text tool.

Zooming in and out
You can change the magnification of the viewing area to see spe-
cific objects in detail or view the layout of an entire page. This is 
called zooming your view of the document.

To change the area and view magnification, you can use menu 
commands, the Magnifying Glass tool, and the Zoom controls.

To use menu commands to change views
In the Layout > Views submenu, choose a command to change 
views:

This command Does this

Zoom In Increases screen magnification

Zoom Out Decreases screen magnification

Fit to Selection Adjusts the magnification to the maximum level for the 
selected objects to be visible in the document window

Tip
Although objects seem to change 
size and position on screen when 
you zoom, the objects do not 
change size or position in the doc-
ument.
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To use the Magnifying Glass tool
1 Select the Magnifying Glass tool in the Toolbox. On Mac, 
you can press Tab+Option to temporarily select the tool. On Win-
dows, you can press Ctrl+Spacebar to temporarily select the tool.

2 Click or drag over an area to increase magnification. To 
decrease magnification, press the Shift key as you click or drag.

To use the Zoom controls
You can use the Zoom controls at the bottom left of the document 
window to adjust the view magnification. The Zoom controls dis-
play the current magnification and let you change magnification. 

• To zoom to the next preset magnification level: Click the Zoom-
in or Zoom-out button. The Zoom-in button increases magnifica-
tion. The Zoom-out button decreases magnification.

• To open the preset magnification menu: Click on the menu icon 
and the zoom menu pops open. Select a magnification level.

• To enter any magnification percentage: Type the magnification 
percentage in the Magnification Level field of the Zoom controls.

Scrolling documents
You can use scroll bars or Hand tool to move to areas of a docu-
ment that are not visible in the current view.

Fit to Objects Adjusts the magnification to the maximum level for all 
objects on the current page, sheet, slide or frame to be 
visible in the document window

Fit to Window Adjusts the magnification to make the entire layout area 
fit the current window size

Home View Sets screen magnification to 100 percent, with the lay-
out area in the upper-left corner of the window

New View Lets you save custom view settings with a name that 
will appear in the menu

Zoom Lets you enter a zoom percentage

This command Does this

Magnifying Glass tool

A Zoom out
B Magnification level field
C Zoom menu icon
D Zoom in
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To use the scroll bars
Click a vertical scroll arrow to move the view up or down. Click a 
horizontal scroll arrow to scroll left or right. You can drag the scroll 
box or click the scroll bar.

The position of the scroll box within a scroll bar indicates the loca-
tion of the current view relative to the entire document area.

To scroll with the Hand tool
1 Select the Hand tool in the Toolbox. Or, press and hold 
down the Spacebar to temporarily select the tool.

2 Drag in the document to move the document in the direction 
you drag.

Scroll box

Horizontal scroll bar 

Vertical scroll bar

(Windows) (Mac OS X)

Hand tool

Drag with the Hand tool to 
slide a document in the 
document window
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For more information on Canvas interface features, including the 
Docking bar, Properties bar, Toolbar, Status bar, page controls, 
and the Layout area, see “Overview of the Canvas interface,” 
page 10.2.

Undoing recent actions
Canvas encourages you to experiment with images because you can 
reverse actions by choosing Edit > Undo or Windows > Palettes > 
Undos. You can undo as many actions as your system can store in 
memory. The Undo command reverses actions in the opposite 
order from which you performed them.

Canvas can’t undo actions performed before the last time you 
saved a document. Also, zooming and scrolling can’t be reversed 
with Undo.

You can establish the number of levels of undos in the Configura-
tion Center. Choose Canvas > Configuration Center (Mac) or File > 
Configuration Center (Windows). 

Saving documents
As you work on sample documents while following the lessons, you 
might want to save your work and keep the original files. To do 
this, choose File > Save As.

If you choose File > Save instead of Save As, Canvas replaces the 
original tutorial files with the new document. If this happens, you 
can re-install the original files from the Canvas Installation CD-
ROM.
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CHAPTER

3
DRAWING BASICS IN CANVAS

This lesson introduces you to basic drawing techniques. The follow-
ing exercises are an excellent way to learn the Canvas interface. 
Doing so will familiarize you with drawing lines, rectangles, ovals, 
and arcs, known as vector objects in Canvas. These drawing tech-
niques are used to draw most vector objects, including rounded 
rectangles, polygons, multigons, cubes, concentric circles, and spi-
rals.

Throughout the following exercises, you can use any blank docu-
ment. You’ll experiment with each of the tools. As you draw more 
and more objects, if you need more space, you can open another 
document or select the objects you have already drawn and delete 
them.

Using drawing tools
When a drawing tool is selected, the pointer changes to a crosshair, 
indicating that you are ready to draw. You draw most vector objects 
by dragging in the document window where you want to draw the 
shape.

To create a vector object such as a rectangle, line, oval, or arc, you 
drag the drawing tool from one point to another point. When you 
finish, the object fits inside an invisible box, a bounding box. Remem-
ber, when an object is selected, the bounding box becomes visible.

Use the Properties bar, which is just below the menu bar to see the 
size of the object you are drawing. 

Drawing lines with the Line tool
The Line tool is used to draw straight lines at any angle. This tool 
allows you to choose where to start and end the line.

1 Select the Line tool.

2 Place the pointer where you want the first endpoint of the 
line and drag to the next point. The line automatically extends 
from the first point as you drag. 

Tip
“Dragging” is defined as pressing 
and holding down the mouse but-
ton while you move the mouse, 
and then releasing the button.

Tip
You can toggle on/off the Proper-
ties bar by choosing Window > 
Show/Hide Properties Bar. 
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3 Release the mouse button when the line is as long as you 
want. Note that the line appears with a handle at each end point. 
These handles indicate that the line is selected.

To control the Line tool
You can draw straight horizontal, vertical, or diagonal lines. A 
modifier key may be used to limit the movement of the pointer 
when you drag with the Line tool.

• Press Shift and drag horizontally to create straight hori-
zontal lines. 

• Press Shift and drag vertically to create straight vertical 
lines. 

• Press Shift and drag diagonally to create straight diagonal 
lines.

Drawing rectangles and squares
Use the Rectangle tool to draw rectangles and squares. To draw 
with this tool, drag from one corner to the other corner of the rect-
angle you want to create.

1 Select the Rectangle tool from the Toolbox.

2 Place the pointer where you want one corner of the shape and 
drag the mouse diagonally to the opposite corner. The rectangle 
grows from the first corner as you drag. 

3 Release the mouse button when the rectangle is the correct 
size. 

To draw a line, drag from one 
endpoint to the other

A selected line has handles 
at its endpoints

Handle

Start here

Drag to here

Tip
Make the Line tool snap to 

any 45° angle by pressing the Shift 
key while you drag.

Tip
The rectangle will have a handle at 
each corner and one at each side, 
which indicates that a rectangle is 
selected.
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• To draw squares with the Rectangle tool: Drag diagonally while 
pressing the Shift key.

Drawing ovals and circles
Use the Oval tool to draw ovals and circles. To draw with this tool, 
click and drag from one point to another point. This bounding box 
contains the oval or circle that you’re drawing.

1 Select the Oval tool.

2 Place the pointer where you want to start the oval. Begin to 
drag to the opposite corner to form the oval shape. The oval 
grows diagonally from the first point as you drag. 

3 Release the mouse button when the oval is the size that you 
need. The oval appears with a bounding box and handles at the 
corners and sides of the box to show that the oval is selected.

• To draw a circle : Press the Shift key as you drag the Oval tool 
diagonally. Doing so constrains the object and creates a circle.

Drag from one corner to the 
opposite corner

Start here

Drag to here

A finished rectangle has 
handles on its bounding box

Bounding box

Handle

Start here

Drag to here
Bounding box

Handle

To draw an oval, drag from one corner 
to the opposite corner

A finished oval has handles on 
its bounding box
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• To draw an oval from its center: Select the Circle Radius tool 
and place the pointer where you want the center of the oval. Notice 
that the oval grows from the center as you drag but the center 
doesn’t move. Release the mouse button when the oval is the size 
you need.

Drawing arcs
An arc is a segment of an ellipse or a circle. Use the Arc tool to 
draw arcs. 

1 Select the Arc tool.

2 Place the pointer where you want one end of the arc. Begin to 
drag toward the other end of the arc. Notice that the arc grows 
from the first point as you drag.

3 Release the mouse button when the arc is the length that you 
want. The arc will now have a bounding box and handles at the 
corners and sides. This indicates that the arc is selected. Notice 
that the arc is always one quarter of a complete oval or circle. 
When an arc is selected, two small, round handles allow you to 
adjust the length of the arc. Drag a handle to shorten or lengthen 
the arc. 

Using the EasyShapes tool
Use the EasyShapes™ tool in the Annotations palette to draw any 
one of a multitude of predefined shapes. To draw with this tool, 
drag from one point to another point. The resulting shape will have 
a bounding box around it.

Tip
For Mac, press Option and drag 
the pointer. For Windows, press 
Ctrl and drag the pointer.

Start here

Drag to here

Bounding box

Handle

Drag from one end of the 
segment to the opposite end

A finished arc has handles on 
its bounding box
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To draw EasyShapes
1 Select the EasyShapes tool from the Annotations palette. The 
pop-up EasyShapes palette opens.

2 Select the arrow shape.

3 Place the pointer where you want to start the arrow shape. 
Drag to the opposite corner. Notice that the arrow grows from the 
first point as you drag.

4 Release the mouse button when the arrow is the size that you 
want. The arrow will have a bounding box and handles at the cor-
ners and sides of the box when it is selected. Experiment with the 
arrow shape to create different sized arrows.

Note: You can also create an object shape by entering values in the 
X/Y and width/height fields in the Properties bar and then clicking 
the Create button. By default, the X/Y coordinates are set at 0,0.

• To constrain the proportions of the arrow: Press the Shift key 
while dragging diagonally. 

To change EasyShapes
1 Select the object shape so the Type icon appears in the Prop-
erties bar.

2 Click on the icon to open the Shape popup palette.

3 Select another object shape. The object shape changes imme-
diately.

Drawing options
Modifier keys can assist you in drawing most objects. Remember 
that modifier keys may be combined (pressed at the same time).

EasyShapes tool

Drag from one corner to the 
opposite corner

Start here

Drag to here

A finished EasyShapes object has 
handles on its bounding box

Bounding 

Handle

box
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Try drawing an oval, square, or line outward from the center:

• If you are using Mac, press Option+Shift at the same time 
as you drag the Oval, Rectangle, Line, or EasyShapes tool. 
This allows you to draw an object outward from the center 
and constrains its bounding box to a square.

• If you are using Windows, press Ctrl+Shift at the same 
time as you drag the Oval, Rectangle, or Line or 
EasyShapes tool. This allows you to draw an object out-
ward from the center and constrains its bounding box to a 
square.

Inks
Inks may be either solid colors or multi-colored patterns that can be 
quickly applied to vector, text, and image objects.

Presets palette
The Presets palette contains the inks and other preset attributes 
that can be applied to an object. Open the Presets palette by press-
ing either the pen ink or fill ink icon in the Toolbox. The palette 
floats if it is dragged away from the Toolbox. To begin this exam-
ple, click on the Inks tab and then the color ink type icon.

To apply inks 
1 Using the techniques you learned earlier, draw a rectangle.

2 With the rectangle still selected, open the Presets palette.

Tip
You can also open the Presets pal-
ette by choosing Window > Pal-
ettes > Presets.

Inks tab

Color ink type
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3 When the Presets palette opens, select an ink type (color, gra-
dient, hatch, pattern, texture, or symbol) and then click an ink cell 
to apply the ink you selected to the rectangle.

To apply inks when the Presets palette is floating
1 Open the Presets palette and drag the palette away from the 
Toolbox to “float” it.

2 Select the rectangle.

3 Select an ink type and then click an ink cell to apply the ink 
to the rectangle.

4 Click a blank area of the document to deselect the rectangle.

Strokes
Strokes are outline effects on vector objects; i.e., they affect what the 
border of the shape looks like. There are various types of stroke 
effects, all of which may be modified via the Presets palette.

Presets palette
The Presets palette is used to view and apply strokes to objects, 
select current strokes for new objects. Open the Presets palette by 
pressing the Stroke icon on the Toolbox.

Now that you have become familiar with inks and have learned 
how to apply them to Canvas objects, you can use a similar tech-

Tip
You can also apply ink to an object 
that is not selected. Drag a tile 
onto the deselected object and 
release the mouse button.

Tip
You can also open the Presets pal-
ette by choosing Window > Pal-
ettes > Presets.

Pens tab

Pen stroke types
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nique while working with strokes. A stroke can significantly 
enhance a Canvas design project.

A stroke can be applied using either of the two methods that are 
discussed in the next section.

To apply a stroke from the Toolbox
1 If the line that you created earlier is still available, select it. If 
not, simply draw a new one using the technique that was 
described in the previous section and select it.

2 With the line selected, open the Presets palette by clicking the 
Stroke icon in the Toolbox. Remember, the bounding box will 
appear around the object when it is selected. 

3 With the object selected, scroll through the selection of pen 
stroke types that you can access via the Pens tab of the Presets pal-
ette. 

4 Click a preset pen stroke to select it. Doing so will apply the 
stroke to the object.

To apply strokes when the Presets palette is floating
1 Open the Presets palette by clicking on the Stroke icon and 
drag it away to float the palette. 

2 For this example, click on the Pens tab in the Presets palette.

3 Select the standard pen stroke type.

4 Use the scroll bars to view all of the available strokes and 
select one. Doing so will apply the stroke to the selected object. 
Note that the thickness and endpoint settings of the stroke are vis-
ible in the palette. 

5 Click a blank area of the document or hit the Esc key to dese-
lect it.

You have now applied a stroke to an object. We will show you how 
to edit the stroke later in another section. Remember, you can dock 
the Presets palette by either dragging it to the Docking bar or by 
clicking on the Auto Dock button.

Setting current inks and strokes
In the previous exercises, you applied inks and strokes directly to 
objects. You can change the current ink and stroke when no objects 

Tip
You can also drag and drop a 
stroke from the palette onto a line. 
It takes a little more precision to 
make sure you drop it right on the 
object.
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are selected. Then, when you draw an object, Canvas applies the 
current inks and stroke to the new object.

To set the current pen or fill ink
1 Deselect all objects (in the Status bar at the bottom right of 
the Canvas screen, it should say, “No selection”).

2 Click the Pen ink or Fill ink icon and choose an ink type from 
the Presets palette. Notice that this changes the color of the icon.

3 Select the Oval tool and draw an oval. Canvas applies the cur-
rent ink to the object.

This section introduced you to some of the basic shapes that can be 
quickly created using the various drawing tools found in Canvas. 
As you can see, all of the lines ovals and rectangles can be drawn 
with precision and easily enhanced with color, texture, and other 
design effects. With a few clicks of the mouse you have used the 
EasyShapes tools to create custom designs. Feel free to go back and 
apply some of the strokes to any of these objects. Once you begin to 
experiment you will see that these Canvas tools can be easily used 
in any graphics project.
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CHAPTER

4
DRAWING SIMPLE ILLUSTRATIONS

In this next lesson, you will learn how to create objects and draw-
ings begining with only a blank Canvas document and your imagi-
nation. Follow through with these examples. We recomend that 
when you complete each section that you go back and experiment 
with some of your own ideas.

You will learn how to

• Use the basic Canvas drawing tools

• Use the alignment aids to help you draw

• Use some of the menu commands to edit objects

Creating illustration documents
When creating drawings, especially if they will become technical or 
oversized drawings, you should begin with an Illustration docu-
ment type. Any Canvas document can provide you with equally 
good results; however, an Illustration document is considered to be 
an excellent general purpose beginning for all types of illustration 
or graphic design project.

To create a new Illustration document
1 Choose File > New to open the New dialog box.

2 Select Illustration as the document type.

3 Click OK. Canvas creates a new, untitled Illustration docu-
ment. Now you’re ready to begin drawing.

Tip
The first time you launch Can-
vas, Illustration is selected as 
the document type by default.
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Creating a chair
To create the plan view of a chair, you’ll use the Oval tool as well as 
the Align and Combine palettes.

To create the seat of the chair
1 Select the Oval tool from the Toolbox.

2 Press Shift and drag to create a circle.

3 Using the Oval tool again, draw an oval on top of the circle.

4 Select both objects by pressing Shift and clicking on both 
objects or drawing a selection box around both objects. The Align 
icons appear in the Properties bar. 

Note: You can also open the Align palette by choosing Object > 
Align > Show Palette.

5 Click the first button in the Vertical area and the center align 
button in the Horizontal area. 

To finish the chair’s seat
1 Select both objects by either Shift-clicking each object or 
drawing a selection box with the Selection tool around the 
objects.

2 Choose Effects > Combine. The Combine palette opens.

3 Choose the Crop command in the Combine palette. 

Draw an oval on top of a circle and 
horizontally align their centers

Choose Crop in the Combine 
palette to create the chair’s seat
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To create the back of the chair.
1 Select the Oval tool and draw an oval.

2 With the Oval tool again, press Shift and draw a circle on top 
of the oval.

3 Select both objects. The Align icons appear in the Properties 
bar again.

4 Click the first button in the Vertical area and the center align 
button in the Horizontal area.

To finish the chair’s back, you’ll need to combine the objects.

5 Be sure both objects are still selected and choose the Subtract 
Front command in the Combine palette.

To complete the chair
Once you finish drawing the objects that make up the chair, you 
can use the Align icons to arrange the chair seat and back.

1 Move the chair back above the chair seat and select both 
objects. The Align icons appear in the Properties bar again.

2 Click the first button in the Vertical area and the center align 
button in the Horizontal area.

Now you have a completed plan view of a chair.

Canvas in the office
A flowchart is a document that contains symbols, lines, and other 
objects that visually communicate the "flow" or process whereby a 
problem is solved or a need is fullfilled. The flowchart can rapidly 
illustrate, to all involved in a complex project or procedure, how to 

Draw a circle on top 
of an oval and 
horizontally align 
their centers

Choose Subtract Front 
in the Combine palette 
to create the chair’s 
back

Plan view of a chair
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smoothly identify and handle issues, delegate responsibility and pri-
oritize limited assets.

Canvas contains all of the tools that you will need to quickly create, 
edit, and distribute a flowchart to everyone in your workgroup.  
Remember, as with any Canvas document, a flowchart can be 
printed as a "hard-copy," for use in a manual or other document or 
it can be electronically disseminated as a PDF or HTML docu-
ment. After you create a flowchart, you can learn how to do this by 
reading the section “Designing for the Web,” page 36.1. The ability 
for you to distribute mission-critial information quickly to co-work-
ers will significantly reduce workflow issues.

Creating flowcharts
This lesson will familiarize you with the tools you will use to create 
a flowchart. Apply these techniques to organization charts, seating 
diagrams, and other similar drawings.

To create a flowchart
1 Open the “Flowchart” file in the Tutorial folder.

2 Open the Annotations tools palette and lock it since you will 
need to use it again.

3 Select the EasyShapes tool. From the pop-up palette, select 
the Oval shape and drag the tool at the top of the page to create 
an oval shape (approximately 2.75" x 0.5").

4 Choose Canvas > Configuration Center (Mac) or File > Con-
figuration Center (Windows).

5 Open the Type manager and select the Auto type into object 
option.

6 Select the oval object and type “Start Procedure” and then 
press Esc. The oval object should still be selected.

7 Choose Text > Justification > Center and Text > Justification 
> Vertical Center to properly align the text.

8 Press Esc to select the text object.

9 Then press Option (Mac) or Ctrl (Windows) and click the text 
object to select the oval shape.

10 Click the Pen Ink icon in the Toolbox to open the Presets pal-
ette.

EasyShapes tool

Oval shape
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11 Choose a black ink cell in the palette to apply a black border 
to the oval shape.

12 Then, click the Fill Ink icon in the Toolbox to open the Pre-
sets palette.

13 Choose a blue color tile in the palette to apply a blue fill to 
the selected oval shape.

14 Select the EasyShapes tool again. From the pop-up palette, 
select the diamond shape and create a diamond just below the 
oval.

15 With the diamond shape still selected, type “Decision.” Press 
Esc. The diamond object should still be selected.

16 Choose Text > Justification > Center and Text > Justification 
> Vertical Center to properly align the text.

Next you need to connect the flowchart elements. To do this, you 
can simply draw a line using the techniques described in a previous 
section; however, Canvas contains a more elegant solution — we 
named it for what it does — Smart Lines. These tools are in the Line 
tools palette.

17 Click the Line tool to open the Line tools palette. Lock this 
palette. 

18 Select the Basic Smart Line tool. You will connnect “Start 
Procedure” to “Decision.” 

19 Drag from the bottom center of the “Start Procedure” object 
to the top center of “Decision.” Smart Lines automatically snap to 
the bounding box of the object.

20 Connect “Decision” to “Step 1” by selecting the Kinked 
Smart Lines tool and dragging from the side of “Decision” to the 
top of “Step 1.” 

21 Repeat the procedure to connect “Decision” to “Process 2.”

Pen ink

Fill ink

Basic Smart Line tool

Kinked Smart Line tool
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Now that you have completed this basic flowchart, we suggest that 
you take a minute and experiment with some of the techniques -- 
adding color, strokes, and other effects -- that you became familiar 
with in previous sections.

Maintaining consistency in illustrations
If you need to recreate the same graphic over and over within a doc-
ument or over a series of documents, use Canvas’ Personal Library 
to store your dynamic objects.

Dynamic objects
Dynamic objects are special types of graphics in Canvas that help 
you create illustrations quickly, uniformly, and precisely. Dynamic 
objects are especially useful for technical drawings, diagrams, and 
other frequently used illustrations. An electrical engineer can create 
dynamic objects for gates, resistors, and other circuit components. 
Project managers can build organizational charts with dynamic 
objects for shadowed text boxes.

You can create, delete, and modify individual dynamic objects, and 
also save them as dynamic object sets. Sets may be stored for use in 
special projects and loaded as you need them.

Completed flowchart
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• To open the Personal Library: Choose Window > Palettes > Per-
sonal Library.

Personal Library palette
Two categories of dynamic objects can be stored in the Personal 
Library palette. 

Document tab Dynamic objects stored on this tab are available in 
the current document only.

Application tab Dynamic objects stored on this tab are available in 
all Canvas documents.

To use Dynamic objects
For this lesson, you’ll put the finishing touches on an office layout. 
The document you’ll use contains most of the basic elements of the 
office. Your task is to place and position some of the missing items.

1 Open the “Office” file. Notice that the grid is displayed. 
These settings are saved with the document, so that you have a 
consistent environment that is suited to your project.

2 Open the Personal Library palette.

3 On the Document tab of the Personal Library palette you will 
see previews of several typical office furniture items. Click the pre-
view of the “executive chair” (its name appears at the bottom of 
the palette) and click behind the desk to place it.

4 With the chair still selected, choose Effects > Freeform. The 
handles change to circles on the corners and squares on the sides, 
with a crosshair in the middle; this is “freeform” mode. The cir-
cles rotate the object around the crosshair (centerpoint), while the 
squares skew the object around the centerpoint. The centerpoint 
can also be repositioned.

5 Rotate the chair a little counter-clockwise by dragging any of 
the circle handles in that direction. This is just one way to rotate 
an object quickly in Canvas. To return to normal selection mode, 
click the object again.

6 On the Document tab, select the corner table and click in the 
document to place it in the top corner to the right of the desk. 
Note that the corner table is facing 90° in the wrong direction. 
When you know exactly the amount of rotation you need to apply, 
use the Rotation option in the Properties bar.

Executive chair shown in 
freeform mode
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7 Select the corner table and type 90 in the text field next to the 
rotate icon and press Return or Enter.

You can see how Dynamic objects make it easy to assemble draw-
ings from pre-drawn components. But the real power of a Dynamic 
object is the fact that each placed Dynamic object is “linked” to the 
palette. To see how this works, replace the round-back chair in the 
Document tab with a new style of chair. When you do this, the 
round-back chair that we placed in the office will change.

To replace Dynamic objects
1 Drag the chair that is outside the office layout on top of the 
round-back chair in the Document tab of the Personal Library 
palette.

2 Canvas will ask you if you want to replace the Dynamic 
object. Click Yes. Notice that the round-back chair changes to the 
new type of chair in the document.

Let’s add a final touch. The rug under the office furniture needs a 
border. You can do this very easily by using the Offset Path com-
mand in Canvas.

To offset a path
1 Select the object that represents the rug and choose Effects > 
Offset Path.

2 You are going to make the border 1 inch wide. In the Dis-
tance text field, type “-1”. Click OK. The border appears on the 
inside of the rug. If you had entered “1” in the text box, the bor-
der would have appeared on the outside of the rug.

Finished office planOriginal office layout
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To save your work, use the Save As command and save the docu-
ment with a different name.

Congratulations! You have completed the illustration tutorial!
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CHAPTER

5
INTRODUCTION TO SPRITEEFFECTS

SpriteEffects technology was introduced to allow for the easy cre-
ation and placement of fully-editable transparency effects to text, 
images, and vector objects within Canvas. Remember all 
SpriteEffects can be edited and reapplied at will at any time during 
the design process.

Using SpriteEffects
SpriteEffects breaks down the barrier between traditional object-
oriented editing and image-based effects.

SpriteEffects also allows you to create lenses, which are powerful 
containers for effects. You can use lenses to create magnifying 
glasses and viewing frames in documents.

There are two ways to use SpriteEffects:

• Apply effects directly to objects.

• Apply effects to lens objects.

Applying SpriteEffects
For this lesson, open the “SpriteFX” file.

To apply effects using the SpriteEffects menu
1 Select the cloud located above and to the right of the bicy-
clist.

2 Apply a Gaussian Blur effect by choosing Object > 
SpriteEffects > Add Effect > Blur > Gaussian Blur. The Gaussian 
Blur dialog box will open.

Before After
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3 Select a Radius of 4 by either dragging the slider to the right 
until you’ve reached “4” or by entering the number directly into 
the box. The blur effect has been applied to the cloud.

To apply SpriteEffects using the palette
You’ll apply the same effect to the other cloud using the 
SpriteEffects palette.

1 Open the SpriteEffects palette by choosing Object > 
SpriteEffects > Show Palette (The SpriteEffects palette may be 
opened by choosing Window > Palettes as well)

2 Select the cloud above and to the left of the bicyclist.

3 Click the New SpriteEffects button.

4 Choose Blur > Gaussian Blur from the drop-down menu and 
click OK.

5 Note the Radius has defaulted to 4. Enter a different value if 
you wish. Click OK to accept.

Note: You can also access the SpriteEffects menu and palette in the 
Properties bar.

To apply multiple SpriteEffects
In this example, you’ll apply several affects using the SpriteEffects 
palette.

1 Select the ground shape under the bicyclist

2 Click the New SpriteEffects button

3 Choose Blur > Gaussian Blur and click OK. 

4 Select a radius of 5. Click OK to accept.

5 Click the New SpriteEffects button

6 Choose Noise > Add Noise and click OK

7 Check the preview checkbox.

8 Using the slider, set the amount of noise to 30. Select the 
“Gaussian” radio button, and check “Monochromatic”. Click OK 
to accept these settings.

SpriteEffects palette
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Modifying SpriteEffects
You may edit each effect or change the order in which the 
SpriteEffects are listed in the SpriteEffects palette.

The SpriteEffects palette also allows you to

• Change the settings of each effect

• Change the size of the effect area

• Add or remove an effect that has been assigned to an 
object

• Show or hide any effect that has been assigned to an object

Follow along in the next lesson and experience the powerful capa-
bilities of SpriteEffects for yourself.

To change the order of SpriteEffects
1 Select the ground shape under the bicyclist to which you 
applied multiple SpriteEffects in the previous lesson.

2 In the SpriteEffects palette, select and drag the Gaussian Blur 
effect below the Add Noise effect. Doing so alters the object so 
that Canvas applies the Add Noise effect prior to the Gaussian 
Blur effect.

3 Select and drag the Add Noise effect so that it appears after 
the Gaussian Blur effect to restore your original settings.

To change the settings of SpriteEffects
1 Double-click the Add Noise effect to open the Add Noise set-
tings.

2 Change the Noise Amount to 50 and deselect the “Mono-
chromatic” checkbox.

3 Click OK.

To use selection masks with SpriteEffects
An icon to the left of each effect indicates the state of the selection 
mask for this effect. Click the mask icon to toggle the mask on and 
off .

• When the selection mask is on, the effect is limited to the 
vector graphic.

• When the selection mask is off, the effect spreads through-
out the entire bounding box area.

Effects list

A Show effect
B Mask 

Mask on

Mask off
Using SpriteEffects 5.3



5.4
To show and hide SpriteEffects
1 Click the show effect icon to the left of the Gaussian Blur 
effect. The icon disappears, hiding the SpriteEffects.

2 Click the blank space where the icon was, causing it to reap-
pear and showing the SpriteEffects once more.

Lens effects
Another way to use SpriteEffects is to create a lens object from a vec-
tor or text object. Doing this will apply an effect to a lens. The 
effects appear on objects that are viewed through the lens. Lenses 
can also magnify objects and view objects in other locations. If you 
move the viewpoint of a lens, whatever is behind the viewpoint will 
appear in the lens. If you move the lens, the viewpoint can remain 
fixed or move with the lens.

To create a lens
You can create a lens from any object (except another lens). If you 
want to preserve an object, make a copy and convert the copy to a 
lens. Fill inks are completely removed when vector or text objects 
are converted to lenses. 

1 Open the “Lens” file.

2 If the Toolbox is not already displayed, choose Window > 
Palettes > Show Toolbox

3 Select the Oval tool and draw a circle on the right side of the 
spiral staircase.

4 Choose Object > SpriteEffects > Convert to Lens. The object 
becomes a lens and remains selected.

The stroke on a lens is not affected by the effects applied to the lens. 
The default lens effect is normal (100%) magnification. 

Other ways to create lenses Convert a selected object to a lens by 
selecting the Lens option in the SpriteEffects palette. 

To set the lens magnification
1 Open the SpriteEffects palette if not already open. 

2 In the SpriteEffects palette, change the lens magnification to 
150% or higher.

Vector object used as a frozen lens

Lens options
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To change the viewpoint setting
1 Drag the lens around the document, seeing how the view of 
the lens changes as it moves.

2 Select the Absolute radio button in the Lens area.

3 Drag the lens around the document once more. The image 
within the lens has now fixed on the original position of the lens.

To add other SpriteEffects to lenses
1 From the SpriteEffects palette, click the New Effect button

2 Choose Noise > Add Noise, and click OK.

3 Select a Noise Amount of 50. Make sure “Uniform” is 
selected, Monochromatic is deselected. Click OK.
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CHAPTER

6
INTRODUCTION TO IMAGE EDITING

Canvas has all the features of a dedicated image-editing program. 
You can create image compositions, retouch photos, color correct 
scanned images, or paint your own images. In this lesson, you’ll 
learn

• basic image terminology

• how to place and crop paint objects

• how to change the color mode of a paint object

• how to apply transparency effects

Basic image terminology
Paint objects, also called image, bitmap, or raster objects, are com-
posed of small squares called pixels. 

Every paint object has a specific “resolution,” defined as the num-
ber of pixels per inch (ppi). In general, an image with a high resolu-
tion has more detail, but will also have a large file size. Likewise, a 
low-resolution image contains less data, so it has lower quality but 
also a smaller file size. 

As you get more experienced with images, you’ll learn what resolu-
tion is best suited to your purposes. 

Choosing a resolution
When deciding on a resolution for paint objects, it is important to 
know the medium in which your final project will be displayed. 

• For Web work or for displaying images only on screen, 72 
ppi is the standard. 

• To achieve good results for printing, 150 to 300 ppi is stan-
dard (depending on halftone screen frequency). File sizes 
at high resolution can be quite large. You might find that 
lower resolution is adequate for laser or inkjet output. 

• Very high resolution (above 300 ppi) is needed only for 
images such as fine line art that will be output to film for 
commercial printing. 

For this lesson, we will be working with images at 72 ppi resolution.
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6.2
Defining file types
One of the most confusing things about working with paint objects 
is the great variety of file types. The most common image file types 
are GIF, JPEG, TIFF, PICT, and BMP, as well as EPS (which can 
contain both paint and vector objects). 

• GIF and JPEG: Compressed formats that are used heavily on 
the Internet. The compression levels allow these images to achieve 
small file sizes and as a result they download quickly over the Inter-
net. However, file size compression comes at the expense of image 
and color integrity. 

• TIFF, PICT, BMP and EPS: These files have a lower level or no 
amount of compression. Information for every pixel is recorded, 
and this can result in large files. Because of the higher resolution 
and detail needed for printing, these formats are often used for 
projects that will eventually be printed commercially. 

There are a number of ways in Canvas to place an image file in 
your document. In addition to the File > Place Image command, 
there is also the Image > Import command. 

Finally, you can directly scan into Canvas using any TWAIN com-
patible scanner, or a scanner with a Photoshop™ compatible 
acquire module. 

Creating a duotone vignette
In this lesson, you’ll learn how to create a duotone and make a 
vignette from a photograph. A duotone is a grayscale image usually 
printed with black and an additional color. A vignette is a non-rect-
angular image, usually with a soft edge. 

You will also crop the photograph, change the image mode, and 
apply a vector mask to complete the vignette effect.

To begin, open the “Image1” file in the Tutorial folder. 
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Trimming the image
The photograph in the “Image1” document has a border of black 
pixels. You will use the Trim command to quickly remove the black 
border. 

To trim the paint object
Select the paint object and choose Image > Area > Trim.

Canvas determines the unwanted pixels and crops the image 
accordingly. However, this image still has some areas you might 
want to remove. For this you’ll crop the image. 

Cropping a paint object
There are two crop modes in Canvas. You can use the Crop tool to 
select a rectangular part of a paint object and hide the rest. This is 
called a “soft crop.” Or you can permanently remove extra pixels 
by performing a “hard crop.” 

Performing a hard crop is easy using a shortcut key. Let’s perform a 
hard crop on this paint object. 

To hard crop an image
1 Click the paint object to select it. Selection handles appear.

2 Point to the lower-right corner handle, press and hold down 
the Ctrl key, and drag the handle toward the center of the image 
to crop it. Releasing the mouse button crops the image. 

If you crop too much, choose Edit > Undo. 

Changing the image mode
As we mentioned earlier, there are a number of image file formats. 
There are also a number of image modes, including Black & White, 
Grayscale, Indexed, RGB Color, and CMYK Color. The mode of a 
paint object affects the level of editing that can be performed, the 

Original 

Trimmed

Drag the crop handle Cropped
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6.4
file size of the image, and the file format in which you can save the 
image.

For this lesson, you’ll create a duotone from this image. A duotone 
is an image made up of screens of two basic colors, usually black 
and one other ink. To do this, you must first make a Grayscale 
image and then select which color to blend into the image. 

A traditional “black and white” photograph is actually a grayscale 
image to a computer. The computer uses 256 levels of gray to con-
struct the shadows and other features found in a typical black and 
white image. An image in Black & White mode reduces the number 
of colors in the image to two. Each pixel is either 100% black or 
100% white. Therefore, the Black & White mode is not for black 
and white photos, but rather for single-color illustrations, logos, or 
images. 

You can view the mode and resolution of a paint object by selecting 
it and looking at the right end of the Status bar at the bottom of the 
screen. If you select the image in this lesson you’ll see that it is (72 
dpi) and currently in RGB Color mode. 

To create a duotone
1 Select the paint object.

2 Choose Image > Mode > Grayscale.

Note: You can also select a mode from the Image Mode menu in the 
Properties bar.

3 Canvas asks whether you would like to discard the color 
information from the image. Click OK. The image is now in gray-
scale mode.

4 Choose Image > Mode > Duotone. The Duotone Options dia-
log box appears in which you define your ink colors. 

5 Since only black is in the image, Canvas considers it a mono-
tone image. Select “Duotone” from the Type pop-up menu so you 
can use a second color. 

Tip
If you want to change the inks 
used in a duotone, you must 
select Image > Mode > Duotone 
Inks. This menu item appears 
when a duotone image is select-
ed.
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6 Press the Ink 2 color icon. This opens a color palette.

7 Click the Custom icon in the color palette. The Color Editor 
dialog box opens.

8 Click on the CMYK icon and select CMYK Bars.

9 Define the Ink 2 as follows: C 0, M 87, Y 72, K 0. 

10 Select the Spot Color checkbox and click OK. The defined 
ink appears in the Ink 2 field.

11 Click OK.

The image is now a duotone, using mixtures of black and the color 
you selected. 
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6.6
Applying transparency effects to paint objects
In previous lessons, we applied transparency effects to vector 
objects. You can apply the same types of effects to paint objects. 

You are going to use the Transparency palette this time to create a 
soft-edge vignette from the photograph of leaves. 

To apply a vector mask to a paint object
1 Select the duotone paint object.

2 Choose Image > Mode > Grayscale or use the Mode menu in 
the Properties bar.

3 Canvas asks whether you would like to discard the duotone 
information from the image. Click OK. The image is now a gray-
scale.

4 To use the Transparency palette, select the Opacity slider in 
the Toolbox and drag the slider away. The Transparency palette 
opens. You can also choose Window > Palettes > Transparency.

5 In the Mask pop-up menu, select Elliptical. Vector mask edit-
ing handles appear on the paint object.

6 Drag the handles to adjust the position and size of the vector 
mask.

7 Add a node (a small circle) by right-clicking (Windows) or 
holding the control-key while clicking (Mac) on the horizontal vec-
tor which joins the inner box (the area of 100% opacity) with the 
objects bounding box. An opacity slide appears.

8 Adjust the slide to 0% opacity.

9 Drag the node to adjust the location of 0% opacity until you 
achieve an effect that you like.

If the transparency handles disappear, select the object and click 
Edit in the Transparency palette.

10 When you finish adjusting the mask, press Esc to end edit 
mode.
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Using channel masks
This next example shows you how to create another transparent 
effect in an image. You can do this by painting in a channel mask.

To create transparent edges with a channel mask
Let’s start off with a different image. This time we’ll load a file by 
using the Import command.

1 Choose Image > Import > TIFF.

2 In the directory dialog box, select the file named “Image2.tif” 
in the Tutorial folder. 

3 Click Open.

Note: The Import command lets you perform batch importing of 
image files. Select multiple files and click OK.

Canvas places the image in the center of your screen. To help illus-
trate some of the channel operations, open the Channels palette. 

4 Choose Image > Show Channels.

5 To create a channel mask, press Option (Mac) or Ctrl (Win-
dows) and double-click the new paint object. By doing this, you 
create a channel mask and place the image into edit mode. 

In the Channels palette, you’ll see separate Red, Green, and Blue 
channels, as well as a channel mask in the lower portion of the 
Channels palette.

Node used to set opacity level Completed vignetteHandles appear in edit mode

Channels palette
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6 Select the Airbrush tool from the Painting tools palette. 
When you work with image-editing functions, it is helpful to lock 
this palette. To do this, click the Lock icon.

7 Select black as the foreground color from the Toolbox.

8 Click on the arrow beside the Brush icon in the Properties 
bar. A default set of brushes appears. Select the largest soft-edge 
brush.

9 Paint around the edges of the image.

Note: A paintbrush may be edited by clicking the Brush icon in the 
Properties bar. The popup Brush Options appears. Enter any 
adjustments and start painting. You can also click the Save button 
to add this adjusted brush to the palette. Depending on the type of 
brush that you are using, this feature will allow you to adjust pres-
sure, diameter, and the opacity of the brush stroke. Also, various 
modes — special effects that allow you to create custom mixing and 
painting effects — are available for your use. If you are new to paint-
ing we suggest that you take a minute to explore the paintbrush fea-
ture and see “Painting & image-editing,” page 23.1). 

Because you are painting in the channel mask, the areas you paint 
become transparent. Continue painting until you have achieved an 
effect that you like. Black pixels in a channel mask produce 100% 
transparency in corresponding areas of the masked object. White 
pixels in a channel mask produce 0% transparency in the masked 
object. Gray pixels in a channel mask produce partial transparency 
in the masked object. Darker grays produce greater transparency 
than lighter grays.

10 Press Esc to leave edit mode. You now have a nice airbrush 
effect on your paint object.

Selecting a brush

Tip
If you make a mistake, you can 
undo the most recent actions by 
choosing Edit > Undo or Window 
> Palettes > Undos. You can also 
press Command+Z (Mac) or 
Ctrl+Z (Windows).
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Benefits of transparency
You’ve now seen two ways to enhance photo images. One benefit of 
transparency masking in Canvas is that original images are not 
changed permanently. The original pixels of an image can be easily 
restored if you change your mind. You can remove the channel 
mask from the flower image.

To restore the original image
1 Double-click the flower image to place the paint object in edit 
mode.

2 In the Channels palette, drag the channel mask from the 
lower window to the trash can icon.

3 The original image is now restored. Use the Save As com-
mand to save your work, or close the document without saving 
the changes.

Pixel editing
Canvas has a number of advanced photo-editing features that allow 
you to manipulate images. In the next exercise, you’ll use the Rub-
ber Stamp tool to retouch an image of a landscape. 

Retouching an image
To begin, open the file named “Image3” in the Tutorial folder. An 
image of a landscape is now in your document. You’re going to add 
more clouds to the sky. For retouching an image such as this, use 
the Rubber Stamp tool.

Transparent edges can be “painted” 
in a channel mask. 

You can achieve a variety of effects 
with various painting tools. You can 
also adjust options for most painting 
tools by clicking on the Brush icon in 
the Properties bar.

Rubber Stamp tool
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The Rubber Stamp tool takes an area of pixels starting at a refer-
ence point you select, and replicates the pixels around that point in 
another location you select. This is referred to as cloning.

The Rubber Stamp tool ensures color matching and replicates sub-
tle textures and gradients that exist in an image.

To clone pixels with the Rubber Stamp tool
1 With the Selection tool, double-click the paint object to place 
it in edit mode.

2 Select the Magnifying Glass tool and click to enlarge the sky. 

3 Select the Rubber Stamp tool. 

4 Select a small soft-edge brush from the pop-up Brushes pal-
ette in the Properties bar. 

5 Option+click (Mac) or Alt+click (Windows) an area in the 
clouds to set the reference point for cloning. 

6 Drag the Rubber Stamp tool to clone the area around the ref-
erence point. Continue dragging until you have copied enough of 
the area. 

7 Press Esc to end edit mode. 

8 Use the Zoom bar to set magnification to 100%.

Original landscape Setting the reference point
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The Rubber Stamp tool can remove unwanted scratches, stains, or 
other imperfections found in a photograph. This tool can also be 
used to duplicate objects from within a paint object. 

Creating glowing text 
Follow along in this next example to learn how to make glowing 
text. Keep the document from the previous lesson open. Make cer-
tain that you do not have an object selected by checking the Status 
bar.

1 To change the current text size to 48 point, choose Text > 
Size > 48. 

2 To change the current font, choose Text > Font to open the 
Font submenu. A checkmark appears next to the current font.

3 Choose a new font in the submenu. For this example, we rec-
ommend a thick font, such as Impact.

4 Select the Text tool and type the word “Canvas” in front of 
the hill in the image. 

5 Press Esc to end text edit mode but leave the text object 
selected. To change the color of the text to white, click on the fill 
ink icon in the Toolbox and select the white fill ink.

Final landscape with cloned clouds

Tip
Press Esc to ensure no objects are 
selected.
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Now we want to create the blurry “glow” that will rest behind the 
plain text. To do this we must render the text in order to apply the 
appropriate filter. 

Rendering is the process of taking vector-based art and converting 
it to a paint object. You do not need to create a second text object, 
because Canvas will create a new rendered version of the text and 
place it in front of the original text. 

6 Choose Image > Area > Render to open the Render Image 
dialog box.

• In the Mode pop-up menu select RGB.

• Make sure the Resolution is set to 72 pixels/in.

• Select Anti-Aliasing and choose Fine in the pop-up menu.

• Select the Mask option and choose Visibility.

7 Click OK.

Canvas renders the text according to your specification. By select-
ing a visibility mask, Canvas renders the pixels with a transparent 
background. Now, you’ll blur the rendered object. You can do this 
by using another popular filter, Gaussian Blur. 

8 Double-click the image to put it in image edit mode. 

9 Choose Image > Filter > Blur > Gaussian Blur. 

10 In the Gaussian Blur dialog box, type 2 in the Radius text 
field. You can select the Preview option to see the effect.

11 Click OK to apply the filter. You now have a blurry highlight 
in front of the original text object.

12 Press Esc to exit edit mode and leave the paint object 
selected.

13 Choose Object > Arrange > Shuffle Down to move the high-
light object behind the text object.
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Of course, you could choose to use different ink colors, and even 
separate ink colors for the text and “glow.” The creative avenues 
are endless. And because you used separate objects to achieve this 
effect, you could remove the effect from the text by selecting the 
glow object and then deleting it.

If you want to save your work, use the Save As command to save a 
copy of the document. Otherwise, you can close the document with-
out saving changes.

Text with a glowing highlight
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CHAPTER

7
PAGE LAYOUT & TYPOGRAPHY

Canvas contains all the text editing features that you will need to 
create a professional-level page layout project. The publication envi-
ronment of Canvas provides the comfortable familiarity of a word 
processor. Auto Correct, an interactive spell checker, and complete 
control of document and paragraph formatting are all easily 
accessed via the text settings in the Properties bar or readily accessi-
ble dialog boxes. Your Canvas document can be enhanced with cus-
tom multiple column sections, master pages, and shared layers. 
Also images that are placed inside a Canvas document may be set 
to repel text so that it smoothly flows around placed objects which 
create a visually appealing page design.

Creating a brochure
This tutorial is designed to teach you how to create a brochure 
using page layout and typography features. You will work with a 
Publication document. 

In this tutorial, you will learn about master pages, creating headers 
and footers, placing a graphic, column sections and guides, and 
printing the publication.

In the Canvas tutorial folder, open the “Brochure” document.

Setting up the document
Before you begin this part of the tutorial, you need to become famil-
iar with the setup of this document. This brochure uses left and 
right pages, which are available only when the Facing Pages option 
is selected in the Document Setup manager. You can also set docu-
ment units, paper size, paper orientation, sheet layout, and margins 
in this dialog box. For the purpose of this lesson, make sure the doc-
ument has the following settings.
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7.2
1 Choose Layout > Document Setup to open the Document 
Setup manager.

• Check that the Document Units pop-up menu shows Picas.

• Check that the publication size is US Letter.

• Make sure the page orientation is set to width 51.00 and 
height 66.00 (portrait). If not, click the Orientation button. 

• Check that Paper Color is set to white.

• Check that the margins are set to 6 picas.

2 Click OK when you finish.
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Moving through the document
To help you navigate quickly through the document, Canvas has 
several ways to get from one page to another. The most common 
ways are the Document Layout palette and the page & layer con-
trols. Before you begin working in the document, you might want to 
take some time to get used to different methods of navigation, and 
in the process, see what the entire publication looks like.

To use the Document Layout palette
The easiest way to access the Document Layout palette is to right-
click (Windows) or Control-click (Mac) on a Layer tab at the bottom 
of the document window to open the Layer menu. Select Show Doc-
ument Layout. 

You can also open the Document Layout palette by choosing 
Layout > Document Layout.

Note that the Document Layout palette lists the various objects and 
pages and that each item has been assigned a general identifying 
name. These automatically generated names may be quickly 
changed to aid in identifying special objects by using the Object 
Specs dialog box. To view this interface select a listed object in the 
Document Layout palette — Text, vector, or image — and double-
click. Doing so will bring up the Object Specs dialog box. Enter the 
new name for the object and click the Apply button to apply the 
name to the object. Pages may also be renamed. Double-click on a 
page that is listed in the Document Layout palette. Enter the new 
name when the Options dialog opens and click OK.

To use the page & layer controls
The page and layer controls can be used in addition to the Docu-
ment Layout palette.

• To add pages: Click on the New page icon and the Insert dia-
log box opens. Enter the number of pages (sheets or slides) and 
indicate the placement; i.e., before or after a certain page.

• To add layers to a page: Click on the New layer icon. Another 
layer is added automatically to that page.

• To toggle between pages: Open the Page menu and select the 
page that you want to view. 

A New page icon
B Page menu
C New layer icon
Creating a brochure 7.3



7.4
Modifying master pages
You can use master pages to hold objects that you want to appear 
on all or most of the pages in your document. 

The tutorial has two master pages: left and right. Typical master 
pages include objects like headers and footers. 

Adding headers and footers
In Canvas, headers and footers are special text objects that may 
contain page numbers, total page count, as well as current date and 
time. In this document, you will add headers and footers to the 
master pages.

• To view the master pages : Open the Page menu and select 
Master Page.

To add a header to the left master page
1 Choose Text > Insert > Header. Canvas inserts a header 
object on the left master page and places the insertion point in the 
header. You might want to zoom in to see it clearly.

2 Type “Wide Open Spaces” in the header object.

3 Press Esc to end edit mode.

To add footers to master pages
First, you’ll add a footer to the left master page and insert a page 
number code in the footer.

1 Choose Text > Insert > Footer. Canvas inserts a footer object 
at the bottom of the left master page. The insertion point appears 
in the footer.

2 In the footer, type the word “page” and then type a space fol-
lowing the word.

3 Choose Text > Insert > Page #. Canvas inserts the code $p in 
the footer. This code in the master page footer tells Canvas to 
insert page numbers throughout the document, so you don’t have 
to number pages yourself. 

4 Type a space, then type the word “of” and another space.
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5 Choose Text > Insert > Total Page #. Canvas inserts the code 
$t.

6 Press Esc to end edit mode.

To create the right-page footer 
After you create the left footer, it’s easy to duplicate it and place a 
similar footer on the right master page.

1 With the Selection tool, select the text object and then press 
Option+Shift (Mac) or Ctrl+Shift (Windows) and drag the footer to 
the right. Drop the footer into position at the bottom of the right 
master page. 

This duplicates the left-page footer and places the copy in a straight 
line to the right of the original. 

Now you are going to align the text in the right-page footer to the 
far right.

2 With the footer object on the right master page still selected, 
choose Text > Justification > Right. This aligns the text in the 
footer with the right side of the text box.

Page numbers will appear at the bottom right of right-hand pages in 
the document. Flip through the newsletter to see the page number-
ing on each page and the header on the left pages.

Inserting images
The Place Image command is used to insert images from other doc-
uments into your current working document. You will be inserting 
a graphic on the first page, so select Page 1 from the Page menu.

Placing graphics
1 Choose File > Place Image to open the Place Image dialog 
box.

2 In the Tutorial folder, locate the document named “Hill.tif”. 

3 Select “Hill.tif” and click Place.

4 The Place pointer appears. The Place pointer sets the upper-
left corner of the placed file. Position the Place pointer just below 
the second column of text and click the mouse button. Canvas 
will automatically place the graphic.

Page numbering code

Tip
If it does not appear in the list, 
make sure that “All Documents” 
or “All Files” is selected in the 
Show menu (Mac) or Files of Type 
(Windows) menu respectively.
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7.6
You have now imported a graphic from another Canvas document. 
The Place command can also be used to import graphics from 
many other types of files, including photo CDs and Canvas clip art.

Creating columns of text
Now you are going to add columns of text to page 2. Go to page 2 
by clicking the page 2 icon or Page 2-Page 3 in the Document Lay-
out palette.

To create columns with the Section tool
1 Select the Section tool in the Toolbox.

2 Drag the Section tool from the upper-left corner just below 
the headline “Getting Your Money’s Worth” to the bottom-right 
corner of page 2.

Click to place the top-left corner of the file Photograph placed on page 1 

Place pointer

Section tool

Dragging the Section tool
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3 After you release the mouse button, the Column Guides dia-
log box appears.

4 In the Apply To pop-up menu select Left Page. This places 
this section on page 2 only.

5 Press the three-column button, or type “3” in the “Number of 
Columns” text box.

6 Click OK.

Adjusting column guides
Column height and width can be adjusted by dragging the entire 
section into position. Also, the columns can be individually 
adjusted. You can reposition column guides with the Section tool 
by moving them left, right, up, or down. To adjust the column 
guides, select the Section tool in the Text tool palette. Then either 
drag the entire section to reposition it or just the columns to adjust 
the height or width.

Placing text in a section
After you have created a section, you can select the Text tool and 
click in the section to begin typing, or you can place existing text in 
the section. This lesson demonstrates how to place text in the sec-
tion you created earlier (see “Creating columns of text,” page 7.6).

To place text in a section
1 Select the Text tool and click inside the first column in the 
section under the headline. 

2 Now you are going to import text from another document 
into the columns. Choose File > Place.

Three-column section

Tip
You can also adjust the column 
guides by double-clicking the 
section with the Section tool. 
The Column Guides dialog box 
opens.
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3 Specify Text File in the Show menu (Mac) or TXT (.TXT) in 
the Files of Type menu (Windows).

4 In the Tutorial folder, select the document “Text.txt”.

5 Click Place.

The set of columns should now be filled evenly with text.

Repelling text from objects
You can make text “run” around objects with the Repel feature. Set 
the amount of space between an object and the text it repels. 

An object with a repel setting repels all text; you can move the 
object and it will repel text wherever you place the object in the lay-
out.

You can apply repel settings to objects before any text has been 
placed in a document. You can even apply a repel setting to a text 
object to make it repel other text. 

In this lesson, you are going to repel text around the graphic of sil-
verware at the top of page 2. 

To make an object repel text
1 Select the silverware graphic at the top of the page with the 
Selection tool.

2 Choose Text > Wrap > Repel. The graphic should repel any 
text that surrounds it. Try moving the object around and you will 
see how it repels text wherever it is.
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To adjust the repel settings
You can adjust the values of the repel setting to increase or decrease 
the amount of space between the object and the text.

1 Select the object.

2 Choose Text > Wrap > Repel Options. The Repel Options 
dialog box opens. 

3 Enter repel values for the top, bottom, left, and right of the 
object. e.g., a Top value of 15 will keep text 15 points from the top 
of the object.

Formatting text with the Properties bar
When using various tools to create or select text objects, the text 
formatting options appear in the Properties bar. Format your text 
using the Properties bar options in addition to the Type palette 
(Text > Type) and Text menu commands. The Properties bar also 
displays the paragraph and character styles that you define in the 
Type palette (see “Working with type styles,” page 31.1).

If the Properties bar is not displayed, the text settings will not be 
visible. Make sure the Properties bar is displayed by choosing Win-
dow > Show Properties Bar.

Object with repel setting
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Formatting text characters
The text that appears on the pages in this brochure has been typed 
in the default setting. This can be changed at any time by selecting 
the text, and adjusting the settings; however, for this assignment, 
we are going to add a headline to the top of page 3.

To format text characters
1 Select the Text tool in the Toolbox.

2 Click above the text at the top left-hand corner of page 3.

3 Type “Sentimental Journeys.”

4 You are now going to change the font, so press Esc. The text 
object will still be selected, so you can change all the text in the 
text object. 

5 In the Properties bar, choose an available font from the font 
pop-up menu. The text changes to the selected font.

6 To increase the size of the type, choose a number in the font 
size pop-up menu, or type a value in the text box. Because this is a 
headline, a type size of 36 or 48 points should make the text fit 
across the top of the page. 

7 After you have changed the font and size, drag the headline 
to position it evenly at the top of the page.

Text formatting options
A Font. Select one from the menu. 
The font applies to selected text ob-
jects, highlighted text, or the next text 
you type.
B Size. Select a size or enter one and 
press Enter. The size applies to selected 
text objects, highlighted text, or the next 
text you type.
C Horizontal alignment. Select left, 
center, right, or justify.
D Leading. Select an option or enter 
a value and press Enter.

E Scaling. Specify percentages (hori-
zontal & vertical) by which you want to 
scale the current type size. 
F Text attributes. Use the pop-up 
palettes to apply a text fill ink, text pen 
ink, background ink, and text frame ink. 
For the text stroke and frame stroke, 
you can also assign a pen width. 
G Styles. If you define any paragraph 
or character styles, apply them to text 
by selecting them from the menus.
H Space. Insert spacing before or af-
ter a paragraph by entering values in the 
fields. 

I Vertical alignment. Select top, bot-
tom, center, or justify.
J Text styles. Click buttons to assign 
standard text styles. 
K Tab. Select left, right, center, deci-
mal, or comma from the menu and then 
click in the ruler to set the tab.
L Kerning. Select an option from the 
menu or enter a value and press Enter.
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To add text color
You are now going to change the color of the text in the headline on 
page 3.

1 Select the headline. 

2 Use the Text Fill Ink icon in the Properties bar to select a 
color. The black text changes to the color you choose.

To format paragraphs with the Properties bar
The next step is to format the caption on the bottom of page 3.

1 To change the text alignment to the right, click in the text 
next to the picture at the bottom of the page. 

2 Press the Align Right button in the Properties bar. Canvas 
aligns the text to the right.

Changing text with paragraph styles
You can apply paragraph and character styles using the Properties 
bar. A style is made up of several attributes, such as font, type size, 
leading, and justification.

Canvas stores type styles in individual documents. When you open 
a document, Canvas loads the associated styles so you can apply 
them when needed. You can then access the various styles from the 
Properties bar. 

For the purpose of this exercise, we are going to use styles that have 
already been created. 

Verify that you are on page 4 by choosing Page 4 from the Page 
menu or in the Document Layout palette.

Text Fill Ink icon

Align Right button selected

Right-justified text
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To apply a paragraph style
1 Select the Text tool and click anywhere in the first paragraph 
of text under the number 1.

2 Press the down arrow to the right of the paragraph symbol 
(¶). Choose “Body text 1.” The style of the paragraph where you 
clicked changes to the selected style.

You can try some of the other styles that we have provided by 
selecting additional paragraphs and choosing styles in the Styles 
menu.

You can also use the Type palette to format text. The Type palette 
contains many of the same features as the Properties bar. It is used 
to apply type styles to characters and paragraphs. You can also use 
it for spacing, hyphens, and indents. It is a comprehensive way of 
utilizing the many typography and page layout tools within Canvas.

• To display the Type palette: Choose Text > Type or Window > 
Palettes > Type.

Wrapping text around a circle
Canvas lets you wrap text around vector objects, such as a circle or 
oval. This exercise demonstrates how to use the Path Text tool to 
add text to a circular graphic.

To begin, make sure you are on page 4 in the “Brochure” docu-
ment. To change pages, select a page from the Page menu or click a 
page name in the Document Layout palette.

Before you type the text, you can select the font and type size using 
the Properties bar. First, make sure no text is selected by clicking 
outside the document with the Selection tool or by pressing Esc. 
You can change the default text settings when no text is selected. 

Select the Text tool to display the text settings in the Properties bar.

The graphic needs type that is fairly large and bold. In the Proper-
ties bar, choose a font such as Arial or Helvetica. If the font isn’t 
bold, click the Bold style button. For the type size, choose 36 or 48 
from the size menu to make the text about 1/2 inch high. You can 
use any size from 4 to 128 points by entering the size in the size 
box.

Now that the font and size are set, you can use the Path Text tool to 
add text to the graphic.

Tip
Double-click on the Text tool 
icon to open the Type palette.
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To type text on a circle
1 Select the Path Text tool in the Text tools palette. This tool 
lets you type text around objects. You’ll wrap text around the 
graphic of a solid orange circle and question mark. Notice the 
thin dashed circle around the solid circle. The dashed circle is the 
object (“path”) that the text will follow.

2 Point to the left side of the dashed circle. When the pointer is 
on a path like this, a vertical bar (“I-beam”) pointer appears. Click 
the path when the I-beam is displayed. At the place you click, a 
blinking line (“insertion point”) appears, which indicates you can 
begin typing.

3 Type the phrase “Ask the Experts” (without quotation 
marks). You can backspace to correct typing mistakes. As you 
type, the text follows the path, appearing in the selected font and 
size. The exact position isn’t important at this time.

4 When you finish typing, press the Esc key. Pressing Esc ends 
typing mode and leaves the text object selected.

After you type the text, you can adjust its position. When the text 
object is selected, three small handles (two triangles and a square) 
appear near the beginning of the text. Use the handles to move the 
text around the path, set the distance from the path, and reverse the 
text flow direction.

Path Text tool

Click the Path Text tool to 
place the insertion point on 
the dashed circle.

Type the text and use the 
handles to adjust the 
position.

You can also remove the 
dashed circle.
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Now you’ve seen how easy it is to type text around an object with 
the Path Text tool. For more complex graphics, you can wrap text 
in two directions around a circle. After typing text along the top of 
a circle, you can bind text along the circle’s lower edge with the 
Bind Text command, and then reverse the text direction.

Text inks 
In addition to attributes for text characters, you can apply 
attributes to text objects. You can apply inks, including symbols, 
textures, hatches, and gradients, to the backgrounds of text objects 
and text selections. You can apply strokes to the outlines of text 
objects and outlines around text selections. The easiest way to 
apply these attributes is with the Properties bar.

To apply text inks
You’ve seen how to apply color to text characters; now, you’ll add a 
gradient ink to the background of the text columns on page 4.

1 With the Selection tool, Shift-click each of the two text col-
umns to select all of them. 

2 Press the Background Ink icon in the Properties bar and 
select a gradient ink. You can experiment with different ink types. 
Once you select a background ink that you like, the document is 
complete.

Drag the Alignment handle 
to specify the point where 
you want type to align 

Drag the Baseline Shift 
handle to change the 
elevation of the baseline 
relative to the circle

Background Ink icon
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Next, you can learn about printing your document. Before you 
print, you should save your work by choosing File > Save As and 
typing in a new name for your document. 

You should save your document first as a Canvas document so you 
can always edit the content. Then you can save as or export to 
another format.

Printing publications
After you’ve made changes to the “Brochure” document, you can 
print it to see the results on paper. You can also “proof” a document 
onscreen using the Print Preview feature.

Print Preview lets you see how a document will look when printed. 
It reflects the current print settings and page setup (Mac) or printer 
setup (Windows). These settings include the type of output (com-
posite or color separations), the pages to print, tiling, centering, 
printing blank pages, and printing in color.

In the preview, you can see which objects, layers, and pages will be 
printed and ensure that the layout fits in the printable area of the 
paper. 

To use Print Preview
1 Choose File > Print Preview. In the preview dialog box, you 
can select options to adjust the preview.

2 Click Done if you want to go back to the document.

3 Click Print if you are ready to print the document.

Canvas gives you options for general desktop printing and commer-
cial printing (see “Printing documents,” page 9.10). For commercial 
printing procedures, refer to the Canvas Color Printing Guide.

Congratulations! You have now completed the Page Layout & 
Typography section of the tutorial. 
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CHAPTER

8
WEB PUBLISHING

The integrated illustration and image editing features contained 
inside Canvas creates an ideal enviornment for the creation of Web 
graphics. The exercises in this chapter will show you how easy it is 
to prepare documents and images for Web deployment. At the end 
of this section, you will be able to create Web buttons, animated 
GIF's, hyperlinks, and Web pages. Canvas also contains many 
other advanced Web design tools, like slicing and the HTML 
export of the sliced images as well as Flash and PDF export (see 
“Designing for the Web,” page 36.1).

Creating objects for the Web
The Web Button tool is used to create clickable objects that can eas-
ily be placed inside a document that is destined for Internet or 
Intranet deployment. Web buttons will change their appearance 
when a Web site visitor places the mouse pointer over the button. 
Additionally, the image can be set to change when the button is 
clicked.  Remember, any Canvas object -- text, illustration, or image 
-- can be used as Web button components. You will also see how 
easy it is to place, store, share and reuse a Web button after it has 
been created.

Web buttons
This lesson will show you how to create a clickable Web button and 
place the button on a Web page. 

To begin, open the “Buttons” document in the Tutorial folder. The 
document contains three numbered illustrations. You’ll assemble a 
Web button from the illustrations.

To create Web buttons
1 Select the Web Button tool.

2 Double-click the Web Button tool icon to open the Web But-
tons palette. 

3 Click the arrow at the bottom-left of the palette. This expands 
the palette so you can create buttons.

Tip
Any Canvas document can also be 
quickly converted into a PDF doc-
ument. Once converted to PDF, a 
Canvas project can be electroni-
cally distributed to anyone without 
concerns of cross-platform issues.

Web Button tool
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4 To create a button, you’ll drag three illustrations into the 
Web Buttons palette to establish the three button states. 

• Select the object labeled 1 in the “Buttons” document. 
Drag this illustration and drop it on the “Up” box in the 
Web Buttons palette.

• Select the object labeled 2. Drag this illustration and drop 
it on the “Over” box. 

• Select the object labeled 3. Drag this illustration and drop 
it into the “Down” box.

To preview a Web button
To see the new Web button in action, move the pointer over the 
preview box. When the pointer touches the button, it changes to 
display the “Over” illustration.

Then, press down the mouse button while the pointer is in the pre-
view box. When you do this, the Web button changes to display the 
“Down” illustration.

Web Buttons palette

Drag from (A) to (B) to place button into the 
Web Buttons palette.

To save the set, click the drop-down menu (C) 
and select Save Buttons.
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To store a Web button
After you create and preview the Web button, store the button in 
the Web Buttons palette so you can later place it in Web pages.

1 Drag the button from the preview box up to the box at the 
top of the palette. The button appears in the upper box with any 
other Web buttons that are stored in the palette.

2 Open the drop-down menu and select Save Buttons.

3 If you make a mistake, you can delete a Web button by drag-
ging it to the trash can icon in the palette.

Placing Web buttons
Use the Web Buttons palette to place Web buttons into any Canvas 
documents. Now, you can save the documents as Web pages.

Open the “Webpage” document in the Tutorial folder. This docu-
ment contains illustrations for a Web page.

To place a Web button
1 Open the Web Buttons palette.

2 At the top of the palette, select the button that you have 
stored in the Web Buttons palette.

3 Click to the left of the word, “News”, on the right side of the 
blue graphic in the “Webpage” document. The Web button will 
be automatically placed into your document.

4 Repeat the procedure for the words “Frames” and “Gear”.

5 Use the Selection tool to move the Web buttons or press the 
keyboard arrow keys to “nudge” them into position while they’re 
selected.

To store a button, drag from 
A to B.

To remove a button, drag 
from B to C.
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To test Web buttons
After placing the button into the document, you need to test it to 
see how it will appear on a completed Web page.

1 Click the Start Play Mode button in the Web Buttons palette.

2 Move the mouse over the Web button in the document to see 
how the button changes when you point to it.

3 Click the Web button to see how the button changes when 
you press it.

4 When you finish testing the Web button, click End Play 
Mode in the Web Buttons palette.

Keep this document open so that you can use it in the hyperlink 
and animation lesson.

Creating animated GIFs
Next, let’s create animated GIFs. We begin by assembling images 
in an Animation document and selecting the GIF Animated file 
format in the Save As dialog box. Choose File > Save As.

You need to know that an animation document consists of a series 
of frames, like individual pages. The frames appear in sequence, as 
in a movie or cartoon. Adding objects to the frames will create an 
animation sequence. 
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Animations can be set to play when viewers click them on a Web 
page or automatically when the Web page is loaded in the browser. 
Animations can also be set play once and stop or continuously run.

The next lesson shows you how to easily assemble an animated GIF 
and place it on a Web page.

To create an animated GIF
1 Open the “Animation”document in the Tutorial folder. This 
document contains a series of illustrations that will become the 
frames of an animated GIF.

2 Choose Layout > Document Layout to open the Document 
Layout palette. Use this palette to examine the six frames which 
comprise this Animation Document.

3 “Frame 1” is highlighted. Select “Frame 2,” “Frame 3,” 
“Frame 4,” “Frame 5,” and “Frame 6” respectively. Notice that 
the image changes with each successive frame.

4 Return to “Frame 1” by clicking on “Frame 1” to highlight it.

You are now ready to save the file as an animated GIF.

To save a document as an animated GIF
1 Choose File > Save As to open the directory dialog box. 

2 Select the “GIF Animated” file format and choose OK to 
accept the default file name (Animation.GIF).

3 The Animated GIF Options dialog box opens. Select the foll-
wing options for optimum results:

• Transparent Background

• Interlaced

• Antialiasing

• Differential frames

• Infinite Loop.

Placing animated GIFs 
After you have saved your animated GIF file, you can place the ani-
mation in any Canvas documents you design for the Web.

To place an animated GIF
1 Switch to the “Webpage” document, which should still be 
open.
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2 Select the Animated GIF tool.

3 Click on your document where you would like to place the 
animated GIF

4 Select the file “Animation.GIF” from the directory dialog 
box, then click OK.

Keep the document open for now so you can use it in the next exer-
cise.

Creating hyperlinks on a Web page
A well designed Web site should be a pleasant viewing experience 
for the visitor. To facilitate navigation and allowing speedy and 
seamless access to information is a key ingredient to a well designed 
— and popular — Web site. A hyperlink is one of the key navigation 
tools of a Web page and therefore you should know what they are 
and, more importantly, how to create and add them to your Web 
project.

What is a hyperlink?
In short, a hyperlink quickly "jumps" a visitor to an "address" or 
location of either another Web page or to a section on the same 
viewing page. This allows you, the Web designer, to create Web 
pages that will present additional information in another location 
without being forced to place all of your Web content on a single 
page. 

You can set up hyperlinks to “http” and “ftp” addresses on the 
Internet and to e-mail addresses by using the “mailto” hyperlink. 
You can also make hyperlinks to Web pages that are on a local hard 
disk or company Intranet.

You’ll set up some hyperlinks in the “Webpage” document.

To attach hyperlinks to Canvas objects
For more information regarding hyperlinks and the Link Manager 
palette, see “Designing for the Web” on page 36.1

1 Choose Object > Options > Link Manager. The Link Man-
ager palette appears.

2 With the Selection tool, click the Web button next to the 
word “News.”

Tip
URL is short for Uniform 
Resource Locator.
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3 Select the Pages radio button and select “News” from the list. 
The text appears in the Link field in the Link Manager palette.

4 Enter “News” in the Title field. 

5 Click the Link button. 

6 Now select the Web button next to the word “Gear.”

7 Select the Pages radio button and select “Gear” from the list.

8 Enter “Gear” in the Title field.

9 Click the Link button. The text appears in the Link field in 
the Link Manager palette.

These buttons are now linked to take you to the respective pages 
when clicked.

Attaching hyperlinks to text
You can select any amount of text — from one character to whole 
paragraphs or entire text objects — and use the Link Manager pal-
ette to transform the text selection into a hypertext link.

To create a hypertext link 
1 Choose Object > Options > Link Manager to open the Link 
Manager palette.

2 Open the Page menu and select the “News” page.

3 With the Text tool, select the text at bottom that reads “U.S. 
Tour News.”
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4 In the Link field of the palette, type 
“mailto:news@ustour.com.”

5 Click the Link button to assign this URL to the text selection.

To add style and color to hyperlinked text
At this point, you can add color and formatting styles to the hyper-
linked text. In the Style area, define the text properties for the 
hypertext. 

1 In the Link Manager palette, select a style type as previously 
indicated.

2 Click the “B” button for bold, the “I” button for italic, and 
the “U” button for underline.

3 Select a solid color for the text in the pop-up color palette. By 
default, Canvas makes hypertext dark blue.

4 Click the Link button to assign the URL and the Link Styles 
you selected to the text selection.

You can close the document now. In the next exercise, you’ll work 
with a completed version of this document, which is stored in the 
Tutorial folder.

Saving files for the Web
The easiest way to create Web pages in Canvas is to save a Canvas 
document using the “Save to Web” command.

In this exercise, you’ll save a Canvas document in HTML format 
using the Save to Web command. Then you can view the page in a 
Web browser to see the hyperlinks, Web buttons, and animated 
GIFs.

To begin, open the “Homepage” document. Like the document you 
worked on earlier, this document contains hyperlinks, Web but-

Tip
Select “mailto:” from the palette 
menu.

None assigns no style.

Default uses the browser settings.

Explicit. Use the text format options 
and color pop-out palette to define the 
link. Your settings will override the 
browser settings.

Text styles

Color palette

Click style buttons to apply text styles. 

Select a solid color ink from the color palette.

Tip
Prior to exporting your document 
as an HTML file, we recommend 
that you make certain to save your 
original project as a Canvas file. 
You can then edit the original Can-
vas document if you want to make 
changes at a later date.
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tons, and animated GIFs. You’ll use this document to learn about 
the options for saving Web pages.

To save a Web site using the Web Publishing Wizard.
1 Choose File > Save To Web to open the Web Publishing Wiz-
ard, which is a series of screens to assist you in publishing your 
Web site. Be certain to read the dialog next to each item.

2 In the first screen, select the radio button for “Save the Entire 
Document”. Click Next.

3 In the second screen, select the radio button for “Auto”. Click 
Next.

4 When the third screen appears, select “HTML 4 with Table 
Layout” as the HTML output method and “Finest” for the anti-
aliasing option. Click Next.

5 Click Finish to open the directory dialog box. 

6 Save the file with the file name “homepage.htm” in the Can-
vas Tutorial folder.

Your Web page has been saved. All of the components have been 
preserved within a subfolder of the folder that you selected.

Viewing Web pages
When you create Web pages with Canvas, you can use your Web 
browser to check the pages before posting them to the Internet.
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For this exercise, you are going to open the Web page you saved in 
the previous exercise.

To view a Web page
1 Launch a Web browser.

2 In the browser, choose File > Open File (Mac) or File > Open 
(Windows).

3 Locate and select the file named “Homepage.htm” in the 
Homepage folder. When the file loads, you can view the anima-
tion, test the Web buttons, and hyperlink to the Web site you 
chose to use.

Congratulations! You’ve now learned several techniques to make it 
easier for you to design Web pages using Canvas. For complete 
information on using Canvas to develop a Web site, see “Designing 
for the Web,” page 36.1. 

Tip
We recommend that you use 
Netscape Navigator version 4.0+ 
or Internet Explorer 4.0+ to view 
Web pages created in Canvas.
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CHAPTER

9
DOCUMENT BASICS

Canvas documents are the containers for your work. You can create 
and save vector drawings, text, raster images and effects in Illustra-
tion, Publication, Presentation and Animation documents. 

This chapter describes the basics of working with Canvas docu-
ments, including how to open, save, view, and print them.

Opening Canvas documents
Use the Open command to open Canvas documents. The general 
procedure is the same for opening Canvas documents and any 
other type of file that Canvas supports. 

To open a file
1 Choose File > Open. The Open dialog box appears.

2 Select a file format to display one type of file in the current 
folder.

3 Select the file to open. Canvas displays a preview if the 
selected document contains a preview.

4 Click Open. 

• To open a document you worked with recently: Choose the doc-
ument name from the list of recently opened documents in the File 
menu.

• To start Canvas and open a document simultaneously: Double-
click a Canvas document icon in a folder or directory on your sys-
tem. The program starts and the document opens.

Options for opening Canvas files
When you choose Open, a directory dialog box lets you select a file 
in the scroll list and see a preview. 

You can select “Show All Files” to list all the files in a folder. This is 
different than Selecting “All” in the File Format pop-up menu, 
which lists all files that Canvas can open.

Documents opened recently are 
listed in the File menu.
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If you highlight a QuickTime movie or Sound file in the list, the 
preview area lets you play a movie or sound preview. In addition, 
the button below the preview area lets you manage preview images.

• When the button says Create, click it to make a preview 
for a file that doesn’t have one.

• When the button says Update, the file and its preview are 
not consistent. Click Update to make the preview match 
the file.

If you need additional help working with files, folders, and directo-
ries, refer to your Mac OS or Windows documentation.

You can open more than one document at a time in Canvas. When 
you open a document, Canvas loads the document into your sys-
tem’s memory. You need to have enough memory available to hold 
the document’s contents. Documents that contain many complex 
objects or large high-resolution images require more memory than 
simple documents.

When you work with a document, changes you make to the docu-
ment are not saved until you use the Save or Save As commands.

Substituting fonts when opening documents
If a document you open uses fonts that aren’t available on your sys-
tem, Canvas displays a dialog box before opening the document. 
Use the dialog box to review which fonts are required by the docu-
ment and to select substitute fonts, or you can let Canvas select sub-
stitutes.

1 Select a font listed under Original Font, or Shift-click to select 
multiple fonts. This column lists fonts that are specified in the 
document but are not available.

2 Choose a substitute font in the “With” pop-up menu. The 
name of the font appears in the list under Substitute Font. Canvas 
displays the font name in its corresponding typeface so you can 
preview the font substitution.

3 Select the checkbox to permanently replace the missing fonts 
with the fonts you choose in this dialog box.

4 After you select substitutes for the missing fonts, click OK to 
open the document. To cancel the changes, click Clear Changes 
to let Canvas choose a substitute and open the document.
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Placing documents
Use the Place and Place Image commands to incorporate a docu-
ment stored on disk into an open Canvas document. With the Place 
command, you can insert a Canvas document or a non-Canvas 
illustration document with this command. With the Place Image 
command, you can insert an image document; e.g., you can place a 
document containing your company logo within a document in 
which you are preparing a sales brochure.

The Place commands let you visually set the location and dimen-
sions of the incorporated document. 

When placing Canvas documents, you can control which layers, 
pages, or slides to place, and whether to place them on the current 
layer, page, or slide, or on new ones, depending on the document 
type (Illustration, Publication, Animation, or Presentation).

The Place and Place Image commands are available when a Can-
vas document is open.

To place a file in an open Canvas document
1 Choose File > Place or Place Image. The Place dialog box 
appears.

2 Select the file that you want to place and then click Place. If 
the file has more than one page or layer, the Place Options dialog 
box appears. Configure the options in the dialog box, and then 
click OK (see “Options for placing files,” page 9.4).

Select to permanently replace 
the missing font

Substitute fonts are listed 
here

Select a font for which you want 
to specify a substitute

Choose substitute fonts
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3 Position the Place cursor in the open document where you 
want the top-left corner of the placed file to be.

4 Click to place the file at its original size; Canvas inserts the 
upper-left corner of the file at the point you click. 

• To define the dimensions of the file you’re placing: Drag to cre-
ate a bounding box. Canvas inserts the file and scales it to fit the 
bounding box.

Options for placing files
When you place a file, the Place Options dialog box lets you specify 
how the placed file should be added to the current document.

When you place one Canvas document type (Illustration, Publica-
tion, Animation, or Presentation) into another document type, Can-
vas converts the placed pages, sheets, or slides to the format of the 
current document.

Document pages (and sheets or slides) can be added to the current 
document, along with their layers. 

In the Place Options dialog box, select the following options, and 
then click OK to place the document.

Place on Current Layer Places the file’s objects on the current layer 
of the current page. No pages or layers are created in the current 
document.

Show Place Cursor Select this option if you want to set the position 
or size of placed items on the current page. After you click OK in 
the Place Options dialog box, a place pointer appears. Click to set 
the position of the upper-left corner of the placed items, or drag to 
enclose an area in which you want the placed items to fit.

Add Layers to Current Page Places the document’s layers as new 
layers on the current page in the current document.

Add New Pages Places the document’s pages and layers as new 
pages and layers in the current document. 

Select Click to choose specific pages or layers to place. A dialog 
box lists the available items. Shift-click two items to select a range. 
Command-click (Mac) or Ctrl-click (Windows) to select multiple 
items and toggle selected items. Click OK to close the dialog box.

Place cursor
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Saving Canvas documents
The Save and Save As commands store a document on disk.

• The Save command updates a document file on disk and 
overwrites the previously saved version.

• The Save As command lets you create a new file on disk 
from an open document, save documents as templates, 
and use other graphics and text file formats.

When you use these commands, the default format for storing doc-
uments is the native Canvas format.

To save a new Canvas document
1 Choose File > Save As. The Save As dialog box opens.

2 Select a location to store the document and type a file name.

3 Click Save to store the document on disk.

• To save changes to a document as you work: Choose File > Save 
to update the document file on disk.

• To save a document with a new name or in a new location:

Choose File > Save As. Enter a new name or select a new location in 
the directory dialog box, and then click Save.

Saving selections and layers
Use the Save As command and options in the Save directory dialog 
box to save selections or layers, and create previews.

Save Entire Document The default setting tells Canvas to save a 
complete document.

Save Selection Choose this option after you select the objects in 
the document that you want to save as a new document. If you 
don’t select anything, this option is not available.

Save Layers Select this option to save one or more layers in a new 
document. Then, click Layers to specify which layers to save. This 
option isn’t available if the document has only one layer.

Use Compression Check this box to reduce the size of files saved 
on disk.

Preview Select the this option to save a low resolution preview of 
the document. In applications that support previews, you can see a 
thumbnail image of the document before opening the file.

Tip
To avoid losing your work in the 
event of a power failure or system 
failure, use the Save command fre-
quently as you work to store 
changes on disk. Also use the 
AutoSave feature located in the 
General settings in the Configura-
tion Center (see “General set-
tings,” page 13.2).
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Use Preview Icon (Mac only) Canvas creates a finder icon with a 
preview of the document if you select this option.

Use Extensions (Mac only) Adds a three-character filename exten-
sion. Use this if you use Mac files on Windows systems.

Undoing, redoing, and repeating actions
You can easily correct mistakes, restore your work to an earlier 
state, and repeat commands using the Undo, Redo, and Again com-
mands. The minimum and maximum number of times you can 
undo changes can be changed within the Configuration Center (see 
“Functionality Options,” page 13.5). 

Canvas uses memory to store operations so they can be undone. 
The amount of memory depends on the operation; e.g., undoing a 
filter applied to a 2 MB image requires significantly more memory 
than reversing a change in type size. 

Canvas allocates memory to ensure that you can undo the specified 
minimum number of actions. Canvas tries to set aside enough 
memory so you can undo the specified maximum number of 
actions. It uses this memory if it’s needed for other operations. 
Therefore, you should be able to undo the specified minimum 
number of actions, but you might not be able to undo the specified 
maximum number of actions. The memory allocation ensures that 
you’ll have the most memory available in Canvas.

• To cancel an action: Choose Edit > Undo or press Com-
mand+Z (Mac) or Ctrl+Z (Windows). You can also open the Undos 
palette by choosing Window > Palettes > Undos. In the palette, 
select an action that you want to undo.

Not all actions can be canceled with the Undo command Actions 
that cannot be canceled include scrolling; closing or reverting to an 
earlier version of a document; selecting and deselecting objects; 
deleting settings in palettes; and saving documents.

• To restore actions you canceled using Undo: Choose Edit > 
Redo or select the Redo item in the Undos palette. You can choose 
Edit > Redo multiple times to reinstate canceled actions in reverse 
order.

• To repeat a command or other action: Choose Edit > Again. 
When an action can be repeated, the Again command includes the 
name of the action; e.g., after you rotate an object, the Again com-
mand appears as “Rotate Again.”

Tip
If you undo an action, it will state 
“Redo” in the palette. Select the 
Redo item if you mistakenly undid 
an action.
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Not all actions can be repeated The Again command isn’t avail-
able if the previous action can’t be repeated.

Reverting to the saved version of a document
The Revert command lets you discard changes made to a docu-
ment since it was last saved. This is the same as closing the docu-
ment without saving changes, and then opening the original from 
disk.

Be certain that you want to discard all changes to a document 
before choosing the Revert command, because you cannot use the 
Undo command to restore your work after using the Revert com-
mand. 

Keep in mind that you can use the Save As command to save a doc-
ument with a new name. If you are not certain that you want to dis-
card changes to a document, use Save As to store a new version on 
disk, then open the original document and compare the two.

• To revert to a document’s saved version: Choose File > Revert. 
Before performing the command, Canvas asks you to confirm that 
you want to discard all changes.

Working with document windows
Each document you open appears in its own window. You can work 
with Canvas document windows the same as other windows. You 
can resize a window, expand it to fill the screen, and minimize or 
roll it up. Canvas provides commands to organize and select docu-
ment windows when more than one is open.

Selecting among open documents
When you open several documents at once, only one is active. The 
Window menu displays the names of open Canvas documents. The 
name of the active document has a check mark.

• To change the active window: Choose the document’s name in 
the list at the bottom of the Window menu. You can also click a 
document’s window to make the document active. 

When you open more than one document, information in the Prop-
erties bar and Status bar, such as the pointer’s location, applies to 
the active document. The same is true of floating palettes; palette 
settings apply to the active document and they change when you 
switch documents.
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Arranging windows
When you open more than one document window, you can stack or 
distribute them on screen so they are easier to work with. 

When Canvas arranges document windows, it resizes them if neces-
sary so they fit within the main program window or screen area.

• To arrange windows in rows: Choose Window > Tile Down.

• To arrange windows in columns: Choose Window > Tile Across.

• To arrange windows in a grid (Mac only): Choose Window > 
Tile.

• To stack all windows: Choose Window > Stack.

• To arrange icons of minimized windows (Windows only): Choose 
Window > Arrange Icons.

Viewing and editing document properties
With the Properties command, you can view the properties of docu-
ments. You can view standard data and add your own meta data to 
a document.

To view or edit properties
1 Choose File > Properties to open the Document Properties 
dialog box. This dialog box contains the following tabs: General, 
Statistics, Summary, and Custom.

2 Click a tab to display its options. Use the procedures later in 
this section to edit the options, where applicable, then click OK to 
implement the settings.

Note: The document must be saved for some of its properties to be 
displayed.

Choosing a property
To view or customize a property, select a tab in the dialog box.

General Describes general information about a saved document, 
such as type, location, size, attributes, when it was created, and 
when it was last modified.

For Mac only, the Finder Comments box lets you view the com-
ments that appear in the Finder’s Get Info comment window for 
the document.
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Statistics Displays when the document was created and when it 
was last modified. It also shows the last time the document was 
printed, the name of the person it was last saved by, the number of 
revisions, and the total editing time.

The Statistics box contains information about the document and 
the objects contained in it.

Note: The creation time can be different on the General and Statis-
tics tabs. The Statistics tabs displays the date and time the docu-
ment was created as a new document. The General tab displays the 
time it was first saved.

Summary Lets you customize information about the document. 
You can enter a title, subject, author, manager, and company.

In the Category and Keyword boxes, you can type data to catego-
rize the document. 

The Comments box lets you type comments about the document.

Custom Lets you add custom data to the document. You can 
choose names and data types for these entries, as described next.

To enter custom data
1 Choose a name from the list for the data entry, or to create a 
new data name, type a name in the Name text box. 

Pre-defined data names
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2 Choose a data type from the Type menu. You can choose 
Text, Date, Number, or Yes or No. Then, depending on the type, 
enter a value in the Value box.

• For Text, type any text value. 

• For Date, type a date from 1/1/1601 through 12/31/9999.

• For Number, type a numeric value. 

• For Yes or No, click Yes or No.

3 Click Add to add the data entry to the Properties box.

• To modify a data entry: Click the entry in the Properties box, 
then change the type or value. You cannot change the name of the 
entry. Click Modify to apply the change.

• To delete a data entry: Select the entry in the Properties box 
and then click Delete.

Printing documents
Canvas works with all standard desktop printing devices, including 
PostScript and non-PostScript printers. You can print Canvas docu-
ments using black-and-white or color devices. 

This section focuses on printing to desktop printers. For informa-
tion on installing, setting up and selecting a printer to use, refer to 
your operating system documentation. 

How Canvas prints documents
A few key factors affect how Canvas prints a document. Canvas 
decides which objects to print based on the following:

Document boundary Canvas does not print objects that are outside 
the layout area (the rectangle that represents the document on 
screen). Objects that are partly inside and partly outside the layout 
area will be cropped in the printout.

Visible layers Objects on layers that are not visible are not printed.

Printable layers If a layer’s print option (in the Document Layout 
palette) is off, nothing on the layer is printed.

Printable objects If an object is made non-printable (in the Docu-
ment Layout palette or the Trap tab in Object Specs), the object 
will not print.
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Printable area If you have defined a print area by choosing File > 
Print Area > Set Print Area, then only the area within the print area 
is printed. If you work with complex illustrations, you can elect to 
print only a portion rather than the entire design. You can toggle 
the printable area by selecting its checkbox in the Properties bar. 

• To remove the print area: Choose File > Print Area > Clear 
Print Area.

Using Page Setup
To access the Page Setup dialog box, choose File > Page Setup. The 
page setup affects the document’s layout area in Canvas and the 
way a document is printed. It’s best to set these options when you 
create a document so you can see page breaks correctly on-screen.

Center On Paper Centers a document on the printed page. If 
you’re printing selected objects only, Canvas shifts the selected 
items to the center of the printed media. This option can be useful 
when you have selected objects that you want to print in the center 
of the page, but they are not centered in the document itself.

Fit To Paper Scales a document to fit within the page’s printable 
area. Keep in mind that objects that are outside the layout area, will 
not be printed.

Tile Prints a large document by dividing it among “tiles” of 
printer pages. Type an Overlap value in the text box so part of the 
document repeats at the edge of adjoining tiles; the overlap makes 
it easier to assemble the complete document after printing.

Previewing and printing
Print preview reflects the current print settings and the page setup 
(see “Using Page Setup,” page 9.11). These settings include the type 

Select Canvas from the menu.Page Setup dialog box (Windows)
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of output (composite or color separations), pages to print, tiling, 
centering, printing blank pages, and printing in color.

In the preview, you can see which objects, layers, and pages will be 
printed. You can make sure the layout fits in the printable area of 
the paper. If you choose the Tile option in the Page Setup tab or 
dialog box, the preview shows the tiles as separate pages.

To print preview a document
1 Choose File > Print Preview to check print settings and the 
composition of a document before printing.

2 Click Print to send it to the current printer when you finish 
previewing a document and the settings are correct.

3 Click the zoom buttons to increase or decrease the magnifica-
tion of the preview. Click the arrow buttons to cycle through the 
pages. If you are previewing separations, click the plate buttons to 
cycle through the plates that will be printed for each page.

4 Click Close to return to the document without printing.

Print Preview options
The Print Preview dialog box contains the following options and 
controls.

Options tab On the Options tab, you can choose a printer, print 
range, and number of copies. This tab contains output options 
related to image and text handling. You can also activate print fea-
tures like registration and crop marks, which are located in the 
Additional information area of the tab. 

Separations tab If you plan on sending color work to a service 
bureau or printing shop, color separations will be necessary. Select 
the Print separations checkbox to activate the various options.

Messages tab Any printing related warning or error is indicated 
on this tab; e.g., if the document contains a spot color, the spot color 
is indicated.

Page setup tab This tab contains the same options as the Page 
Setup dialog box (see “Using Page Setup,” page 9.11).

Show rasterized area Select this checkbox to see the objects that 
will be rendered when sent to the printer. This option depends on 
the selection in the Transparency rendering menu (see “Transpar-
ency Rendering,” page 9.15).

Tip
You can also access the Print 
Preview function from the Print 
dialog box. Press the Preview 
button (Mac) or Print Preview 
button (Windows).
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Show overprint/choke/spread These checkboxes are related to the 
trapping technique that you can apply to objects via the Object 
Specs palette (Trap tab). If you have applied any technique, select 
the appropriate checkbox.

Normal display Select this radio button to switch to normal display 
if using wireframe display.

Wireframe display Select this radio button to switch to wireframe 
mode.

To print a document 
1 Choose File > Print. The Print dialog box appears.

2 Enter the number of copies and the pages to print, and then 
select other print options. Click Print (Mac) or OK (Windows). 

Printing options
This section describes the primary options you can use for printing 
documents on desktop printers.

Printing multiple scaled pages In the Thumbnails pop-up menu, 
you can select an option to print multiple document pages on each 
printer page.

Choose 1/Page to print a document at actual size, with one docu-
ment page on each printer page. If the document is larger than the 
printer paper, the document will not be scaled; you can select the 
Tile option to print the document on multiple sheets of paper.

To scale and print multiple document pages on each printer page, 
choose an option to set the number of document pages to print. 
The document pages will be scaled as necessary to fit the printer 
pages. The amount of scaling depends on the size of the document 
pages and the size of the printer pages.

Collate Copies Prints all pages of the document in order based on 
the number of copies requested, rather than printing all copies of 
page 1, all copies of page 2, and so on.

Skip Blank Pages Does not output document pages (or separation 
plates) that are completely blank.

Tip
On Mac OS X, open the options 
menu to view and change the 
print settings.
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Reverse Order Prints from the last page to the first, keeping pages 
in the correct order if the printer stacks pages face-up in the output 
tray.

Print Facing Pages If the document is formatted for spreads, Can-
vas prints facing pages on a single page. This option is available for 
printing Publications only.

Selection Only Prints the currently selected object.

Odd Pages Prints only the odd-numbered pages.

Even Pages Prints only the even-numbered pages.

Color Mode
Choose an option from the Color Mode menu to control color accu-
racy when using a color printer. In general, when you print to a 
color printer, it’s best to choose a color specification that matches 
the colors in the document you’re printing; e.g., choose CMYK if 
your document contains CMYK colors only.

RGB Outputs colors using RGB color specifications. A non-color 
printer will convert the color values to print as shades of gray.

Black & White Prints all colors as black or white.

Colors As Grays Canvas converts color values to shades of gray for 
printing on any printer, including color printers.

CIE L*a*b Uses color calibration to try to match printed colors to 
their appearance on screen. Keep in mind that many on-screen 
hues cannot be reproduced on paper with printing inks. For exam-
ple, colors that look bright and saturated on screen, such as hot 
pink, cyan, and brilliant orange, will appear muted in printed mate-
rials.

CMYK Outputs colors using CMYK color specifications. A non-
color printer will convert the color values to print as shades of gray.

Image compression
In the Image Compression menu, choose a format for output of 
image data to a PostScript device or file. The format you choose 
affects the amount of data transmitted and the size of a PostScript 
file. This setting can affect compatibility with networks and Post-
Script printers.

Tip
Some documents can be larger 
than the paper in your printer. To 
print the entire document, select 
the Tile option in the Page Setup 
dialog box. Canvas will “tile” 
(divide) the document into a series 
of pages matching the paper size 
of your printer.

Tip
Rendered transparency effects are 
also transmitted as image data 
when printing to PostScript print-
ers.
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ASCII Outputs image data as plain text. This is the most compati-
ble format, but it transmits (or saves in files) the largest amount of 
data.

Binary Outputs images as binary data, which might not be com-
patible with all printers and networks. Binary data is half the size of 
ASCII data.

Level 2 ASCII Outputs images in an ASCII format that is compati-
ble with PostScript Level 2 devices. This produces files that are 
approximately 20% smaller than regular ASCII PostScript files.

RLE Outputs images using Run Length Encoding compression. 
This format is compatible with PostScript Level 2 devices. This 
form of compression is most efficient when documents contain 
images that have large areas of flat color. 

JPEG Outputs images using JPEG compression. This format is 
compatible with PostScript Level 2 devices. JPEG compression 
requires more system memory and more processing time at the 
printer than other compression methods. However, this format 
achieves the fastest printing results with continuous-tone (photo-
graphic) images and documents containing transparency effects.

Printing proxies
Print Proxied Images at Full Resolution Prints the high-resolution 
images that are linked to the proxies in the document. Canvas out-
puts the images from the linked files on your computer. If you do 
not select this option, Canvas prints proxy images rather than the 
high-resolution images. This is faster and could be adequate when 
you are proofing other parts of a document.

Transparency Rendering 
Choose an option in the Transparency Rendering menu to specify 
how transparency and SpriteEffects will be rendered (converted to 
pixels for printing).

Smallest Area Renders the area inside the bounding box of all 
transparent objects. This generates the least amount of additional 
data to print transparency effects. Do not choose this option if you 
are printing in color on non-PostScript printers and the document 
has vector and transparent objects that share the same color, 
because these printers will not match the colors precisely. In some 
cases, non-standard PostScript printers might produce a slight pixel 
shift between a transparent and non-transparent area of a vector 
object. If this happens, select Complete Area.

Tip
By default, Canvas uses JPEG 
compression for printing images. 
This can reduce the amount of 
data sent to the printer. If a net-
work print spooler reports errors 
with a JPEG data stream, select 
Images: ASCII or Level 2 ASCII 
and try printing again. The Images 
setting affects printing of images 
and rendered effects only.
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Complete Area Renders the area within the bounding boxes of all 
transparent objects, as well as objects that are overlapped by trans-
parent objects (or intervening objects). This is the best setting to use 
when you print to a non-PostScript printer, such as a Windows GDI 
printer, to avoid color-matching problems

Entire Document Renders all objects in the document as one or 
more images that are sent to the printer. This is equivalent to pro-
cessing the document in an internal RIP (raster image processor) in 
Canvas. This option produces the greatest amount of image data. 
However, this option can be useful if you experience problems pro-
ducing accurate output of transparency or other effects when you 
use a particular printer or printer driver.

Don’t Render Transparent Objects Does not render any transpar-
ency effects in the document. If you select this option, transparency 
(SpriteLayer) and image (SpriteEffects) effects will not be printed; 
transparent objects will be printed as opaque objects. 

The one exception to this rule involves vector objects that have a 
transparency Scope setting of Fill only when printing to a Post-
Script printer, because PostScript can print transparent fill inks in 
vector objects without rendering. For information on the Scope set-
ting, see “To set an object’s transparency scope,” page 35.5.

Printing text with effects
Text Always In Front Because of the way that Canvas renders 
SpriteLayer effects, text that is not in front of all other objects can 
be output as rendered images rather than text. If you want to avoid 
rendering of text for printing, select this option. Canvas will print 
the text objects in front of all other objects.

If you have text that has special effects or is behind transparent 
objects, you should not select this option, so the text will be ren-
dered and printed as it appears in the document.

Closing documents
When you close a document, Canvas removes the document win-
dow from the screen. Closing a document doesn’t save it (Canvas 
will warn you if you try to close a document that has changed).

• To close a Canvas document: Choose File > Close. You can also 
click the Close button in the document’s title bar to close the docu-
ment.

Tip
Select Don’t Render Transparent 
Objects if you need to quickly print 
a proof of a complex document. 
This allows you to check the posi-
tioning of objects without seeing 
the final transparency effects.

Close button 
(Windows)

Close button 
(Mac OS X)
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CHAPTER

10
RUNNING CANVAS

This chapter explains how to start and end a Canvas work session. 
It also provides an overview of the Canvas interface and describes 
the following basic procedures: 

• Selecting tools from the Smart Toolbox™

• Using and arranging palettes

• Using the Properties bar

• Using information displayed in the Status bar

• Undoing, redoing, and repeating actions

Starting and exiting Canvas
To start Canvas, do one of the following:

• Double-click the Canvas program icon if you’ve made a 
shortcut (Windows) or alias (Mac). 

• Double-click a Canvas document to start Canvas and open 
the document.

• Double-click a Canvas template file to start Canvas and 
create a new document based on the template.

Choose Canvas from the Start > Programs menu (Windows).

Note: The first time you launch Canvas, a new Illustration docu-
ment appears as a default. When you start the program after that, 
Canvas creates the same document type that you selected the last 
time in the New Document dialog box. If you double-clicked a doc-
ument to launch Canvas, that document will open the main win-
dow.

• To view start-up screen information: When Canvas is running, 
choose Apple > About Canvas (Mac) or Help > About Canvas (Win-
dows). Do this when you want to check your serial number, version 
number, and other program information.

Checking optional software at start up
Canvas displays a message if it encounters a problem, such as miss-
ing system software components, as it starts. If a message appears, 
click OK to continue loading Canvas.
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Canvas depends on some system software components for import-
ing and exporting certain types of files, managing colors, and work-
ing with some graphics formats. The Canvas installer places some 
software called “extensions” (Mac) or “Dynamic Link Libraries” 
(Windows) on your system, if needed. If Canvas can’t find the 
required component later, it’s possible the file was moved or dis-
abled. 

If you encounter a problem when starting Canvas, refer to the 
“Read Me” file, which includes the most up-to-date information on 
required software.

Quitting Canvas
Choose Canvas > Quit Canvas (Mac) or File > Exit (Windows). If 
you try to quit without saving a document that has changed, Can-
vas asks if you want to save it first. 

Overview of the Canvas interface
Canvas appears nearly identical on screen whether you use the Mac 
OS or Windows operating systems. Some operations differ slightly 
across platforms, but these operations are very familiar to most 
users. 

Canvas has four types of documents: Illustration, Publication, Ani-
mation, and Presentation. These documents share some common 
elements, while some specialized controls apply to particular docu-
ments types.
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Canvas window

Major parts of the Canvas interface are 
shown here. Depending on the Canvas 
customization as well as OS, the inter-
face may vary.

You can hide the Toolbar, Properties 
bar, and Docking bar. You can also 
dock various palettes and customize 
the Toolbar.

In Mac OS, each Canvas document 
appears in its own floating window. 
Each document window has Zoom con-
trols, Document controls, and scroll 
bars. All documents share the Smart 
Toolbox, Properties bar, and Status bar. 

In Windows, you can switch between 
Canvas documents via the Window 
menu. 

A Menu bar
B Toolbar
C Properties bar. This area functions 
as a control center for the complete 
range of Canvas text, painting, or vector 
tools as well as document setup. You can 
toggle this bar on or off (see “Using the 
Properties bar” on page 10.9).
D Dynamic help. Open this window to 
display information for selected tools and 
objects (see “Dynamic Help” on 
page 10.15).
E Docking bar. This bar can be shifted 
to the left, right, or above the layout area.
F Smart Toolbox™. Tool palettes 
snap out to the right. If you use a specific 
tool palette regularly, lock the palette so 
it remains open while you use other tools 
(see “Viewing the Smart Toolbox” on 
page 10.5).

G Zoom controls. Use these controls 
to zoom in and out of a document (see 
“Using the Zoom controls” on 
page 10.19).
H Document controls. Add pages and 
move from one page or layer to another 
(see “Page & layer controls” on 
page 12.7).
I Status bar
J Layout area. This rectangle is the 
main working area for creating illustra-
tions, page layouts, presentations, and 
animations (see “Layout area” on 
page 10.4).
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Layout area
The rectangle centered in the Canvas document window is the Lay-
out area. The white space around the Layout area is known as the 
pasteboard and is additional working space where you can place 
objects before using them in an illustration. Objects on the paste-
board are saved with the document, but they are not printed.

The Layout area represents different things in the different Canvas 
document types.

Illustrations It is one page, called a “sheet,” with layers.

Publications It is one single-sided page or two facing pages with 
layers. 

Presentations It is one “slide” with layers.

Animations It is one frame of an animation. If you select “onion-
skinning”, you can see objects on adjacent frames (see “All about 
onion skinning” on page 36.23).

You can change the color of the Layout area to represent the color 
of tinted paper. Set the Layout area color by choosing Layout > 
Document Setup and then selecting a color from the Paper color 
popup palette.

Document navigation controls
A pop-up menu appears below the document window. Open this 
menu to move through a document.

Layout area

Slide menu

Page menu

Sheet menu Frame menu
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Viewing the Smart Toolbox
In a multi-tasking environment, it can become time-consuming to 
have to constantly re-open a tool palette so you can grab the correct 
tool. 

Select any tool in the Smart Toolbox and its palette, as well as 
related tools, automatically opens and snaps to the right of the 
Toolbox. The tool palette remains in that position until another 
tool is selected.

• To display the Toolbox: If the Toolbox is hidden or closed, 
Choose Window > Palettes > Show Toolbox to display it.

• To dock the Toolbox: Disable the Smart Toolbox option and 
then click the docking button or drag the Toolbox by its title bar to 
the Docking bar.

Note: By default, the Smart Toolbox is active when you launch Can-
vas for the first time. You cannot dock the individual tool palettes 
when this option is enabled. 

To disable the Smart Toolbox option
1 Choose File > Configuration Center (Windows) or Canvas > 
Configuration Center (Mac). 

2 Open the General settings and select Functionality options.

3 Deselect the Smart Toolbox checkbox.

Note: When the Smart Toolbox is disabled, you can dock the indi-
vidual tool palettes. 

If the Smart Toolbox is disabled, on Mac OS systems, you press a 
tool icon to open a tool palette and drag to the tool you want to 
select. On Windows systems, you click or press an icon to open a 
tool palette and then click again on the icon for the tool you want to 
select.

If you’ll often use a specific tool, or related tools found on the same 
palette, you can also lock the palette so it stays “snapped” to the 
Toolbox. 

• To lock a tool palette: Click on the lock icon. When you select 
another tool, its palette snaps to the right of the locked palette. 

When palettes are locked, you can relocate them to another part of 
the layout area. To do so, place the pointer on the palette title bar 
and Shift-drag the palette from the Toolbox. 

Tip
To temporarily retain a drawing 
tool, Shift-click the tool in the 
Toolbox. This function applies not 
only to basic vector tools but also 
to complex drawing tools, and 
path tools.
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Also, if you Ctrl-drag the palette, you can move a group of locked 
palettes or a single locked palette away from the Toolbox. 

• To unlock a locked palette: Click the lock icon.

Using the tools
In the Smart Toolbox, tools are represented by icons in two col-
umns. The tools that aren’t displayed are available on tool palettes 
that snap to the Toolbox when opened. 

• To select a tool displayed in the Toolbox or tool palette: Click 
the tool. The selected tool is shaded, like a recessed button. 

Tool palettes

This diagram identifies the default tool 
palettes in the Toolbox. The available 
tool palettes may change depending on 
your selection in the Personality Man-
ager (see “Personality Manager” on 
page 13.2). Click on a tool icon and its 
respective palette opens (see “Viewing 
the Smart Toolbox,” page 10.5).

A Selection tools
B Line tools
C Rectangle tools
D Path tools
E Annotations tools
F Cutting tools
G Painting tools

H Text tools
I Oval and arc tools
J Dimensioning tools
K Object tools
L Transparency tools
M View tools

Toolbox

Mac

Windows
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To access tool palettes and tools via the Toolbox command
If you are looking for a particular tool and are unsure where it is 
located in the Toolbox, choose Window > Toolbox to see the vari-
ous tool groups. 

• To open a tool palette: Click on the arrow icon and select Show 
Group. The tool palette automatically opens and snaps to the right 
of the Toolbox.

• To access an individual tool: Click on the arrow icon and select 
the particular tool from the menu. The tool will be selected in the 
Toolbox.

Using AutoSnap palettes
Canvas organizes tools, special effects, object attributes, and other 
functions in palettes. Palettes can remain open on screen, and they 
can be docked on the Docking bar. They can also attach together 
due to Canvas’ “snapping” technology for floating palettes, or 
rather AutoSnap™ palettes. 

If you have two or more palettes open, you can position them so 
they attach together. Once attached, you can then move them 
around as a group.

• To tear off a group of palettes: Click on a palette’s title bar and 
hold down the Ctrl key while dragging the palette away. Any pal-
ettes to the right of the selected palette move simultaneously.

• To tear off a single palette : Click on a palette’s title bar and 
hold down the Shift key while dragging the palette away. Only the 
selected palette moves.

To disable the AutoSnap palettes option
1 Choose File > Configuration Center (Windows) or Canvas > 
Configuration Center (Mac). 

2 Open the General settings and select Functionality options. 

3 Deselect the AutoSnap palettes checkbox.

Some palettes have an Apply button that you must press if you 
want to implement the current settings. A palette stays open until 
you click its close box or use a command to close it.

• To roll up a palette so only its title bar is visible: Click on the 
minus button on the palette title bar. 
Using AutoSnap palettes 10.7
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• To dock a palette: Click on the arrow button or drag the palette 
to the docking bar (see “Using the Docking bar,” page 10.13 and 
“Using AutoSnap palettes,” page 10.7). 

• To arrange palettes: Choose Window > Palettes > Clean Up 
Palettes. Canvas moves all open palettes except the ToolBox and 
floating tool palettes to the upper-right corner of the document. 

• To close all palettes: Choose Window > Palettes > Put Away 
Palettes. Canvas closes all open palettes, including the Smart Tool-
box and floating tool palettes.

Palettes submenu
All Canvas palettes are listed in the Window > Palettes menu. To 
display a palette, choose the name of the palette in the submenu. If 
a palette is behind other palettes, it comes to the front. If a palette is 
docked, the palette comes off the Docking bar and opens.

Some palettes are also associated with commands in other menus; 
e.g., the Layout > Document Layout command opens the Docu-
ment Layout palette. The Image > Show Channels/Hide Channels 
commands open and close the Channels palette. 

Palette icons in the Toolbox
The Strokes icon, Dash styles icon, Arrow styles icon, Pen Ink icon, 
and Fill Ink icon provide access to the Presets palette. You can use 
these icons to select preset colors, dashes, arrows, and pen widths. 
To open the Presets palette, click on one of these icons to open the 
palette and then drag it away from the Toolbox. 

Note: When editing an image, the Pen Ink icon is replaced by the 
Brushes icon. 

Procedures for selecting inks and strokes are covered in the chap-
ters “Inks: colors & patterns” on page 15.1, and “Strokes: outline 
effects” on page 16.1. Information on selecting and using brushes is 
in the chapter “Painting & image-editing” on page 23.1.

Using the Toolbar
The Toolbar contains buttons you click to choose commands and 
tools. The Toolbar appears below the menu bar.

Tip
Tool palettes are listed in the 
Windows > Toolbox submenu 
(see “To access tool palettes 
and tools via the Toolbox com-
mand,” page 10.7).

Pen strokes icon

Fill Ink icon

Pen Ink icon

Dash styles icon
Arrow styles icon

Toolbar (Mac OS X)

Toolbar (Windows)
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A standard set of commands appears on the Toolbar when you first 
run Canvas. You can use the Customize command to change the 
buttons on the Toolbar. Add buttons to the Toolbar for commands, 
tools, and custom colors and styles (see “Customizing the keyboard 
and Toolbar,” page 13.24).

• To display the Toolbar: Choose Window > Show Toolbar.

• To hide the Toolbar: Choose Window > Hide Toolbar.

• To select an item on the Toolbar: Click its button.

You can identify Toolbar items by displaying tooltips. Point to an 
icon and a tooltip appears with the name of the command or tool. 

• To display tooltips if they don’t appear: Choose Canvas > Con-
figuration Center (Mac) or File > Configuration Center (Windows). 
Within the General settings, open the Functionality options man-
ager and and select Show information tooltips.

Using the Properties bar
Use the Properties bar to quickly modify the document setup, cre-
ate some vector objects, modify tool settings, apply a filter or effect 
to an object, cache objects, or apply text formatting. 

• To show the Properties bar: Choose Window > Show Properties 
Bar.

• To hide the Properties bar: Choose Window > Hide Properties 
Bar.

Viewing & modifying document setup
You can view the document setup when no item is selected. The 
Properties bar gives you quick access to document controls, such as 
page size, ruler measurements, drawing size, and scale. In addition, 
you can toggle on/off the grids, guides, ruler, page breaks, margins, 
and printable area. 

Changing tool settings
When you select a tool, its settings automatically appear in the 
Properties bar. Use the menus, checkboxes, and scroll boxes to 

Save

Tip
If you hide the Properties bar, you 
won’t be able to display the 
Dynamic Help window.
Using the Properties bar 10.9
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change the tool settings. To modify paintbrush settings or define a 
new brush, see “Selecting brushes and painting options” on 
page 23.13).

Modifying object properties
When an object is selected, the Properties bar automatically dis-
plays the object’s reference point, height, width, rotation, and skew 
settings. You can also change the object’s opacity and transfer 
mode.

In addition, when drawing a vector object, the Properties bar indi-
cates the object’s reference point and shows a live readout of the 
width and height.

To locate the reference point
The reference point is displayed in the Properties bar. It is a point 
on the selected object (or its bounding box) that position data are 
based on. The reference point is also the fixed point used in an 
object’s transformation; e.g., with a rectangle selected, click the 
upper-left corner point. The X/Y boxes show the coordinates of the 
rectangle’s upper-left corner. To move an object, type new coordi-
nates for the reference point. The next two boxes display the 
object’s width and height. Enter new values to resize the object and 
press Enter.

Properties bar with Painting tool selected

Properties bar with Vector tool selected

You can open the Brush Options dialog 
box by clicking on the Brush icon.

Properties bar with paint object selected

Properties bar with vector object selected

Reference point
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• To change an object’s position: Enter values in the X/Y fields 
(reference point) and press Enter.

Note: With an oval or other shape selected, the corner points in the 
box correspond to the corners of the object’s bounding box.

Start and End The first two boxes show the X/Y coordinates of a 
line’s start point. This is only available when a line is selected. The 
second two boxes show the line’s end point. 

Length and Angle The first box indicates the length of the line. 
The second box refers to the angle or slope of the line. Enter new 
values to modify the length or angle of the selected line and press 
Enter. The Start/End values change accordingly.

• To select an object’s X/Y reference point: Select a reference 
point in the bounding box icon beside the X/Y fields.

• To change an object’s dimensions: Enter values in the width 
and height fields and press Enter.

• To scale an object: Click on the scale icon in the Properties bar 
and select either Scale Proportional or Scale Non-Proportional. If 
you select Scale Proportional and enter a value in the width field, 
the height will change accordingly, or vice-versa. The opposite 
occurs if you select the Scale Non-Proportional option.

• To open the SpriteEffects palette: Click on the SpriteEffects 
icon. You can still access this palette by choosing Object > SpriteEf-
fects > Show Palette (see “Using the SpriteEffects palette” on 
page 34.3).

• To apply SpriteEffects: Open the SpriteEffects menu and select 
the effect. You can still apply an effect via the SpriteEffects palette 
or by choosing Object > SpriteEffects > Add Effect (see “Using 
SpriteEffects” on page 34.1).

• To rotate an object: Open the Rotate menu by clicking on the 
Rotate button. Select a rotate option. Then, enter a degree value in 
the Rotate field and press Enter. If rotating an image, you can use 
the Image Hard Rotate options.

• To skew an object: Open the Skew menu by clicking on the 
Skew button. Select a skew option. Then, enter a degree value in 
the Skew field and press Enter.

Tip
To copy an object and paste it in 
the same position on a different 
page, you can do so by copying the 
object and then pressing Shift and 
choosing Edit > Paste. 
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• To change an object’s opacity: Move the opacity slider to the 
right or left depending on the desired transparency. For vector 
objects, you can also choose to apply the effect on the stroke and fill 
or only the fill by clicking on the Transparency button.

• To change an object’s transfer mode: Open the Transfer menu 
and select the desired mode.

• To cache vector objects: Group the selected vector objects. 
Click the Cache Object checkbox. Then, enter a value in the PPI 
field. This feature is useful when working with complex illustra-
tions. The Cache Object option only appears if the vector objects 
are grouped.

• To cache paint objects: Select the paint object and then click 
the Cache Object checkbox. Enter a value in the PPI field. 

Note: When a cached paint object is placed into paint edit mode, it 
returns to the original resolution.

• To cache text objects: Group the selected text objects. Click the 
Cache Object checkbox. Then, enter a value in the PPI field.

• To align objects: Select the objects so that the Align options 
appear on the Properties bar. More than one object must be 
selected.

Modifying images
If a paint object is selected, the following image options appear in 
the Properties bar in addition to the general options (see also “To 
cache paint objects” on page 10.12).

Tip
For text objects, you can change 
the opacity and transfer mode by 
using the Transparency palette 
(Window > Palettes > Transparen-
cy).

Tip
You can even group vector, image, 
and text objects and then cache 
the grouped object.
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• To apply image filters: Click on the arrow icon of the Filters 
menu. Select a filter from the list.

• To apply adjustment commands: Click on the arrow icon of the 
Adjust menu. Select a command from the list.

• To crop or scale a paint object: Click on the Crop & Scale but-
ton to view the default sizes. Choose the Custom option to define a 
special crop size (see “Changing image size” on page 24.5). 

• To export your images: Click on the Export button and select 
an export filter. This menu contains the same options as the 
Image > Export command.

• To change an image’s resolution: Enter a value in the Resolu-
tion field. Select the Preserve data checkbox to prevent resampling 
when the resolution is changed. 

• To change the image mode: Click on the arrow icon of the 
Image Mode menu. Select a mode from the list.

Formatting text
When using various tools to create or select text objects, the text 
formatting options appear in the Properties bar. Format your text 
using the Properties bar options in addition to the Type palette 
(Text > Type) and Text menu settings (see “Formatting text with 
the Properties bar” on page 30.5).

Using the Docking bar
You can use the Docking bar to customize the Canvas interface. By 
default, the Docking bar is displayed near the top of the screen 
below the Properties bar when you launch Canvas for the first time.

• To display the Docking bar: Choose Window > Docking Bar > 
Show Docking Bar. When you display the Docking bar, the palettes 
that were docked the last time it was displayed will remain locked.

• To hide the Docking bar: Choose Window > Docking Bar > 
Hide Docking Bar.

You can move the Docking bar from the top to the right and left 
sides of your workspace. 

Tip
The last five used filters appear at 
the top of the menu on the Proper-
ties bar. If you don’t click on the 
arrow icon to open the menu, the 
last filter used will be applied.
Using the Docking bar 10.13
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• To move the Docking bar: Click and hold the pointer on the 
Docking bar (not on a palette tab). Drag the Docking bar from its 
present position to either the top, left, or right.

The settings for the Docking bar are stored in the CVAppData.Set 
file for both Windows and Mac. 

Docking palettes
When you dock a palette, a tab with the palette’s name appears on 
the Docking bar. The tabs of docked palettes give you quick access 
to tools or features. Docked palettes also leave more screen space.

You can dock most Canvas palettes, including tool palettes (see 
“Tool palettes,” page 10.6). You can dock other palettes from the 
Toolbox, including the Inks, Strokes, Transparency, and Brushes 
palettes. You can also dock command or effects palettes such as 
Align, Blend, Envelope, Object Specs, and Type. Dialog boxes that 
require you to click OK or Cancel before continuing can’t be 
docked.

You can dock as many palettes as you want on the Docking bar, 
depending on the size of your screen (see “To adjust the size of tabs 
on the docking bar,” page 10.15).

• To dock a palette: Drag a palette to the Docking bar and drop 
it when a tab outline appears or click the Docking button located in 
the upper right corner of the palette.

• To dock a tool palette from the Toolbox: First drag the palette 
away from the Toolbox so its title bar appears. Then, drag the tool 
palette onto the Docking bar.

• To change the position of a docked palette: Drag the palette’s 
tab to another position on the Docking bar.

• To remove a docked palette: Drag its tab away from the Dock-
ing bar. 

• To dock all open palettes: Choose Window > Docking Bar > 
Dock All Palettes.

• To dock palettes when closed: Choose Window > Docking Bar 
> Dock Palettes When Closed.

• To arrange docked palettes: Choose Window > Docking Bar > 
Clean Up to arrange the tabs of docked palettes evenly on the 
Docking bar.

Drag a palette to the Docking bar 

Docking button

Tip
To access the Docking bar com-
mands, you can also Control-click 
(Mac) or right-click (Windows) an 
empty area of the Docking bar.
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• To arrange tabs by name: Choose Window > Docking Bar > 
Clean Up By Name to arrange the tabs of docked palettes in alpha-
betical order.

• To adjust the size of tabs on the docking bar: Choose Window > 
Docking Bar > Set Tab Length. A dialog box appears. 

• To display the full name of docked palettes, select Auto. 

• To set a specific tab size, select “No. of Characters” and 
enter the number of characters to display. A smaller num-
ber results in smaller tabs. 

• Click OK.

Using docked palettes
To make a selection from a docked palette, click the palette’s tab on 
the Docking bar. The palette pops open and you can click a tool or 
other item in the palette to select it. When you click in the docu-
ment or the ToolBox, the palette closes again. To close the palette 
without selecting anything, click anywhere outside the palette.

You can use docked palettes as if they are floating, with one excep-
tion: you cannot drag objects into docked palettes. 

Dynamic Help
In addition to the electronic manual, which you access from the 
Help menu, Canvas also includes a Dynamic Help window that is 
located just below the Properties bar. Dynamic Help will display 
information and tips for selected tools and objects, even while per-
forming tasks in edit mode.

Note: By default, the Dynamic Help window is open when you first 
launch Canvas.

• To display the Dynamic Help window: Choose Window > Show 
Dynamic Help.

You can also click on the Question Mark icon that appears when 
the Dynamic Help window is closed.

Tip
Palettes that are docked when 
you quit Canvas will be docked 
the next time you launch Canvas.

Click icon to close the Dynamic Help window

Tip
The Properties bar must also be 
displayed if you want to open the 
Dynamic Help window.
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• To close the Dynamic Help window: Choose Window > Hide 
Dynamic Help.

You can also click on the X icon just above the right side of the open 
Dynamic Help window.

Using the Status bar
The Status bar is at the bottom of the screen (Mac) or the bottom of 
the Canvas window (Windows). The Status bar provides informa-
tion about commands, tools, objects, and program operations.

• To show the Status bar (Mac): Choose Window > Show Status 
Bar.

• To hide the Status bar (Mac): Choose Window > Hide Status 
Bar.

• To set the number of information fields: Point to the Status Bar, 
open the context menu, and choose from the Number of Fields sub-
menu. 

• To add fields: Point to the Status Bar, open the context menu, 
and choose a function in the Add to Right or Add to Left submenu.

• To remove a field: Point to the field, open the context menu, 
and choose Remove.

New fields that you add to the Status Bar are blank until you assign 
a function to each field. If you reduce the number of fields, Canvas 
removes fields from the right end of the status bar.

• To adjust the width of a field: Drag its border right or left.

During certain actions, such as saving a document, Canvas displays 
a progress bar in the Status bar.

Assigning functions to fields
To assign a function to a field in the Status bar, point to the field, 
open the context menu, and choose a function in the Show sub-
menu.

Hintline The Hintline area displays tool names, tips, and status 
messages. When you move the pointer over a tool icon or other 



item, the Message area shows the tool’s name and function. You 
can use this feature to take a tour of the Canvas tools and interface.

Mouse position When you move the pointer, draw, resize, or 
rotate objects, Canvas displays the coordinates of the pointer. 

Object Name & Number Displays the current page number and 
layer number. Symbols indicate layer options, including non-print-
ing, locked, and color override. When an object is selected, the field 
displays the object’s number in the sequence of objects on the layer.

Object Details Displays various details about selected objects, 
such as the position of points on the bounding box of a rectangle (as 
measured from the rulers’ zero point) and the number of points in a 
path object. For other objects, the field displays data such as the 
diameter of ovals and the angle of arcs.

Object Type Displays information about selections. When one 
object is selected, the field displays the type of object selected. 
When multiple objects are selected, the field shows the number of 
objects selected. When you select an object group, the field displays 
“Group of n objects,” with n as the number of objects.

Viewing documents
This section describes how you can adjust your view of a document. 
Viewing options in Canvas let you

• control when Canvas redraws objects

• scroll to any area with the Hand tool or scroll bars

• increase or decrease the view magnification

• restore any view magnification and location

• display wireframe and process-color views

Controlling when Canvas refreshes the display
Canvas refreshes the display, which redraws all visible objects, 
when you scroll or change magnification. When you work with 
complex images, you can interrupt the redraw to save time, then 
refresh the display when you’re ready.

• To interrupt display redraw: Press Command+Period (Mac) or 
Esc (Windows) during normal redraw. 
Viewing documents 10.17
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• To refresh the display: Choose Layout > Display > Refresh. 
You can refresh the display after interrupting screen redraw, or 
when you want to refresh the display.

Scrolling documents
You can use scroll bars or the Hand tool to move to areas of a docu-
ment that aren’t displayed in the document window.

Using scroll bars
Document scroll bars represent the full document area. The posi-
tion of the scroll box within a scroll bar indicates the current view 
area. 

To scroll using scroll bars, do one of the following:

• Click one of the arrows to move in the arrow direction.

• Drag the scroll box toward the part of the document you 
want to see. For example, drag up to see more of the top.

• Click the scroll bar to scroll one screen length toward the 
side of the scroll box that you clicked. For example, click 
to the right of the scroll box to move one screen to the 
right.

Using the Hand tool
Using the Hand tool to scroll a document is like sliding a piece of 
paper on a desktop.

To scroll with the Hand tool
1 Select the Hand tool. The pointer becomes a hand.

2 Drag to make the document follow the pointer; e.g., to move 
a document up so you can see the bottom, drag toward the top of 
the screen.

Changing the view magnification
You can change your view of a document by changing the view 
magnification. Zoom in to enlarge objects or zoom out to see a 
larger area. 

You can zoom with the Magnifying Glass tool, the Zoom bar, and 
Zoom commands. You can use magnification levels from 0.0001 to 
102400 percent. Normal magnification is 100 percent.

Scroll box

Horizontal scroll bar

Vertical scroll bar

Horizontal scroll bar

Scroll box

Vertical scroll bar

Tip
To temporarily switch to the Hand 
tool while using another tool, press 
the Spacebar and drag with the 
Hand pointer.

Tip
Zooming changes the view on 
screen, but doesn’t change the 
actual size of anything in the docu-
ment.
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• To use a command to zoom: Choose Layout > Views > Zoom In 
or Zoom Out. Zoom In increases magnification to the next higher 
preset level; Zoom Out decreases magnification to the next lower 
preset level.

• To enter a zoom percentage: Choose Layout > Views > Zoom, 
or press Command (Mac) or Ctrl (Windows) and the slash key (/). 
Enter a zoom percentage from 0.0001 to 102400 in the dialog box 
and press Enter or click OK.

Using zoom shortcuts
You can use keyboard shortcuts to zoom in and out.

Mac To zoom in, press Command+Spacebar and click or drag a 
box around an area. To zoom out, press Command+Shift and click 
or drag a box around an area.

To zoom in directly, press Command+Option +Plus (+). To zoom 
out directly, press Command+Option+Minus (-).

Windows To zoom in with any tool selected, press Ctrl+Spacebar 
and click or drag a box around an area; to zoom out, press 
Ctrl+Shift+Spacebar and click or drag a box around an area.

To zoom in directly, press Ctrl+Alt+Plus (+). To zoom out, press 
Ctrl+Alt+Minus (-).

Using the Zoom controls
You can use the Zoom controls at the bottom left of the document 
window to adjust the view magnification. The Zoom controls dis-
play the current magnification and let you change magnification. 

• To zoom to the next preset magnification level: Click the Zoom-
in or Zoom-out button. The Zoom-in button increases magnifica-
tion. The Zoom-out button decreases magnification.

• To open the preset magnification menu: Click on the menu icon 
and the zoom menu pops open. Select a magnification level.

• To enter any magnification percentage: Type the magnification 
percentage in the Magnification Level field of the Zoom controls.

Using the magnifying glass
Use the Magnifying Glass tool to zoom in and out from an area that 
you select in the document.

A Zoom out
B Magnification level field
C Zoom menu icon
D Zoom in
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1 Select the Magnifying Glass tool. The pointer becomes a 
magnifying glass with a + sign. 

2 Click the center of the area you want to magnify. Canvas 
zooms to the next preset magnification level and centers the view 
at the point you clicked.

3 To reduce rather than magnify, Shift-click the area you want 
to center on screen at reduced magnification.

• To magnify an area to fill the screen: With the Magnifying Glass 
tool, drag a box around the area you want to magnify.

Using Views commands
You can use Views commands to quickly change your view of the 
current document. Choose the following commands in the Layout 
> Views submenu.

Home view Displays the upper-left corner of the document at nor-
mal (100 percent) magnification. 

Fit to Window Reduces or increases magnification to the maxi-
mum magnification level for the layout area to fill the document 
window.

Fit to Selection Reduces or increases magnification to the maxi-
mum magnification level for the selected objects to be visible in the 
document window.

Fit to Objects Reduces or increases magnification to the maxi-
mum magnification level for all objects on the current page, sheet, 
slide, or frame to be visible in the document window.
.20 RUNNING CANVAS



Using custom views
You can create custom views to save the current magnification level 
and position in the document. 

• To create a custom view: Choose Layout > Views > New View. 
The New View dialog box opens. Enter a name for the view and 
click OK. The new view will appear beneath Home View in the 
Layout > Views submenu. 

A checkmark appears next to the view name when a custom view is 
selected. Canvas assigns shortcut keys (which appear in the menu) 
so you can quickly select the custom views you have created.

• To delete a custom view: Choose Layout > Views > Delete 
View. If only one custom view exists, Canvas deletes it. 

If more than one custom view appears in the Views submenu, the 
Delete Views dialog box opens. Select a view and click OK. Canvas 
removes the selected view from the Views submenu.

Using the Navigator palette 
The Navigator palette provides an overview of a document. You 
can use this floating palette to scroll the document and zoom in and 
out. 

• To display the Navigator palette: Choose Window > Palettes > 
Navigator.

Zooming and scrolling
The Navigator palette shows a reduced-size view of the entire lay-
out area. A red rectangle, the View box, represents the current view 
position in the document. The box is small when you zoom in to 
view details and becomes large (relative to the layout area) as you 
zoom out.

• Scrolling: In the Navigator palette, move the view box to 
change your view of the layout area. Drag the view box to the part 
of the layout area you want to see; e.g.;to see the top of a page, drag 
the view box to the top of the layout area.

• Zooming: You can use the zoom controls to change the magni-
fication level. Type a number in the text box to change the magnifi-
cation level. Type a higher number to zoom in or a lower number 
to zoom out. Normal magnification is 100%.

Layout

View 

Zoom controls Pop-up menu

box

area

Tip
To quickly change the view area, 
click within the Navigator palette. 
The view box moves to where you 
click and the layout area shifts as 
well.
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Click the Zoom-in button on the right to double the magnification 
level. Click the Zoom-out button on the left to reduce magnification 
by half.

These controls are also in the Zoom bar at the bottom of the docu-
ment window (see “Using the Zoom controls,” page 10.19).

View options
You can choose view options from the Navigator palette menu. 
This menu contains the same commands as the Layout > Views 
submenu. You can choose Home View, Zoom In, and Zoom Out, 
custom views that you have saved, and commands that make all 
objects or the entire layout area visible in the window.

Using expressions for numeric values
You can type basic mathematical expressions to specify numeric 
values in Canvas dialog boxes and palettes. You can use addition, 
subtraction, division, and multiplication operators in simple expres-
sions; e.g., you can type a fractional value, such as 2/3, in place of a 
decimal value.

To type an expression
To enter operators in expressions, type a plus sign (+) for addition; 
a minus sign (-) for subtraction; a slash (/) for division; and an aster-
isk (*) for multiplication.

You can type parentheses to nest values and operators in expres-
sions. Do not type an equal sign in an expression.

Canvas calculates the result of a mathematical expression when you 
press Tab or Enter, or click an Apply button, or move to another 
value in a dialog box.

To modify a value
To use an existing value in an expression, click after the number to 
place an insertion point. Then, type the remainder of the expres-
sion; e.g., to make the width of an object 3 times larger, click after 
the existing value and type * 3, and then press Enter. To make the 
value one-third as large, type / 3. 

By entering expressions after existing values in the Transform pal-
ette, you can move objects incrementally; e.g., to move an object 3/
4 inch to the right, type + 3/4 after the X value.
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Specifying measurement units
In most dialog boxes, you can type abbreviations to specify mea-
surement units. You can use this feature to override a document’s 
measurement units or the specific measurement units used in these 
dialog boxes. 

For example, when inches is a document’s unit of measurement, 
you can type 1 cm to specify 1 centimeter. Canvas converts 1 cm 
and displays it as .3937 inches.

The following are the abbreviations you can type to specify a unit of 
measurement.

To use an abbreviation for a measurement unit
In a text box that accepts numerical values, type a value followed 
by the abbreviation for the measurement unit. Canvas converts the 
numerical value to the measurement units you are using in the doc-
ument when you press Tab or Enter, or click an Apply button, or 
click in another edit box.

You can even type a mathematical expression using more than one 
measurement unit; e.g., you can type 1p+1cm.

Abbreviation Unit of measure

in inches 

ft f feet 

y yards 

mi miles 

p picas 

pt points 

mm millimeters 

m meters 

km kilometers 

cm c centimeters 
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Using context-sensitive menus
Canvas has context menus that you can pop up in the drawing area, 
giving you quick access to common commands. The menus are 
context-sensitive; the available commands depend on the current 
operation.

Choose common editing commands, such as Cut, Copy and Paste, 
when an object is selected. Other commands are available when an 
object is in edit mode; e.g., image-editing commands appear in the 
context menu when you edit a paint object. Path-editing commands 
appear when a vector object is in edit mode. 

When no objects are selected, you can choose view commands such 
as Zoom In, Zoom Out, Show Rulers, and Show Guides. If the 
Clipboard contains objects or text, you can choose Paste. You can 
choose Undo after performing an action that can be undone.

Using context menus
To apply a command to an object, select the object first. To use 
other commands, you do not need to select an object before display-
ing the context menu.

Windows Click the right mouse button. A context menu appears. 
Click a command in the menu to choose it.

Mac OS Press Control and click the mouse. A context menu 
appears. Highlight a command in the menu and release the mouse 
button to choose the command.

When you are editing an object, you can point to a specific item to 
display commands for editing that item; e.g., if you point to an 
anchor point on a path, you can choose commands to modify the 
anchor point in the context menu.

For information on specific commands that appear in the context 
menu, refer to the command name in the Index.

Context menu 
for a selected 
paint object
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CHAPTER

11
DOCUMENT SETUP

When you create a new Canvas document, you select a document 
type. Then you specify the document size and other options.

This chapter explains how to create new documents and how to set 
up document rulers, drawing scales, guides, and alignment grids.

Creating new documents
When you want to create a new document, use the New command 
and tell Canvas to create an Illustration, Publication, Presentation, 
or Animation document. 

When you start Canvas the first time, a new Illustration document 
appears. When you start the program after that, Canvas creates the 
same type of document you selected the last time you used the New 
command. If you also selected a template, Canvas uses the same 
template for the document it creates at startup.

If you start Canvas by double-clicking a document icon, Canvas 
opens the document without creating a new document. 

You can create new documents any time, even with other docu-
ments open. The number of documents you can have open at the 
same time is limited only by the amount of memory available on 
your system.

To create a new document
1 Choose File > New. 

2 Select options for the new document (described next)

3 Click OK to create the document.

Options for new documents
In the New dialog box, you can choose a document type, select a 
template, specify document size, and choose measurement units. 
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Choosing a document type
When you create a new document, you can select an Illustration, 
Publication, Presentation, or Animation document. 

New Document dialog box
The items that you define in this dialog box can be modified 
via the Properties bar or Document Setup manager (Layout > 
Document Setup).
A Type of document. Depending on your choice, the dialog 
box may offer more or fewer options; i.e., Publication offers 
Margin settings, rather than a Drawing scale, as well as a layout 
menu.
Facing pages. For a Publication document, select this option to 
specify a document with facing (two-sided) pages. A facing-
pages document has a master page with left and right pages.
GIS Document. Select this checkbox to work with a GIS docu-
ment. Once you click OK, the GIS manager opens in which 
you configure the GIS settings. This option is only for Illustra-
tion documents.
B Use a template instead of choosing a document type and 
defining page size and orientation. Select templates for illustra-
tions, publications, or presentations (see “Using document 
templates” on page 11.3).
C Paper. Define the document size and paper unit. The max-
imum document size is 2000 miles x 2000 miles. Select preset 
sizes, or set the document size to the printer paper, or enter a 
custom size. To set up a custom size, choose Custom and enter 
the width and the height. Select the paper unit from the menu.
D Page orientation. To change the orientation of the docu-
ment, click the  button. This swaps the width and height values.
E Drawing scale. Select one of the preset scale options or 
create a custom scale (see “Setting up rulers and the drawing 
scale,” page 11.7).
F Document units. Choose the measurement units for the 
rulers (see “Setting up rulers and the drawing scale” on 
page 11.7).

Pixel mode. This setting allows you to view graphics at 
72 ppi before they are rendered. 
Save as default. Select this checkbox if you consistently work 
with the same document type and layout.
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Illustration documents 
Illustration documents are general-purpose documents for all types 
of illustrations and graphics. You can specify a custom document 
size, and the document can have multiple pages (called “sheets”), 
with multiple layers on each sheet. 

Use the Page menu at the bottom of the window to move another 
sheet.

Publication documents 
Publication documents are designed for publications printed with 
two-sided (facing) pages, although you can also create a Publication 
that has pages with single sides. You can use master pages to hold 
items that you want to appear throughout the publication. You can 
also use multiple layers on each page.

When the active document is a Publication, you can use the Page 
menu to move among the document’s pages.

Presentation and Animation documents 
Presentation documents are designed for on-screen “slide show” 
presentations. Animation documents are designed for creating ani-
mation files.

In Presentation documents, you can use multiple layers and a mas-
ter slide to hold background elements. You can use more than a 
dozen transition effects, including wipe and dissolve, during slide 
show playback. 

When the active document is a Presentation, you can use the Page 
menu to easily move among the slides.

An Animation document is designed for creating and editing web 
(GIF) animation files. An animation is composed of multiple frames, 
which are equivalent to the image frames of film-based animations. 

You can use “onion-skinning” in an Animation document. When 
you select onion-skinning, frames adjacent to the current frame 
appear in the background. This is helpful for setting up object 
movement in an animation. 

Using document templates
Templates are special Canvas documents that you can use as the 
basis for new documents. When you select a template in the New 
dialog box, Canvas creates a new document containing the graph-
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ics and text in the template and uses the template’s settings for lay-
ers, slides, pages, rulers, grids, guides, views, and default object 
attributes.

How is a template different than a regular Canvas document? 
When you choose a template in the New dialog box, Canvas creates 
a new document based on the template, but doesn’t actually open 
the template file. When you make changes to the new document 
and save it to disk, the changes don’t affect the template.

Canvas treats a template in a similar way when you open one by 
double-clicking its icon or using the Open command. In either case, 
rather than open the actual template document, Canvas makes a 
new document based on the template’s document type and con-
tents.

Templates, like regular Canvas documents, are various types: Illus-
tration, Presentation, Publication, and Animation. In the New dia-
log box, the templates listed in the “Use Template” pop-up menu 
match the document type selected in the “Type of Document” area.

Setting up documents
After you create a document, you can use the Document Setup 
manager in the Configuration Center to change the document type, 
measurement units, size, orientation, and other options (Layout > 
Document Setup).

The Document Setup manager present similar options for each 
type of document, with some specific options for a particular docu-
ment type; e.g., in a Publication document, you can set facing pages 
and page margins. In a Presentation document, you can specify 
screen size.

To set up a document
1 Choose Layout > Document Setup. 

2 The Document Setup manager opens. Select the options you 
want and click OK.

Document Setup options
The following options are available in all document types, except as 
noted.
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Document Units
Choose an option in the Document Units pop-up menu. The unit 
you select will be used in the rulers.

Document Size
You can set the document size to match the paper in your printer, 
or set up a document based on a standard or custom size. The con-
trols for document size are labeled according to the type of docu-
ment (Illustration, Publication, and so on).

To use a standard size, choose an option from the pop-up menu. 
You can choose standard sizes based on the document type.

From Printer To base the dimensions of the layout area on your 
printer’s page size, choose From Printer. The layout area will match 
the settings in the Page Setup dialog box. For more information, 
see “Matching documents to printer pages” on page 11.6.

Custom To specify custom dimensions, choose Custom. Type the 
width in the first box and the height in the second box.

From Screen In Presentations and Animations, you can base the 
size of the layout area on the monitor’s size. To do this, choose 
From Screen.

Orientation 
To change the orientation of the document, click the button in the 
Orientation area. This swaps the width and height values of the 
document.

Margins
To set margin size for two-sided Publications, enter the Inside, Out-
side, Top, and Bottom margins in the text boxes in the Margins 
area. For single-sided Publications, enter Right, Left, Top, and Bot-
tom margins. The margin is measured from the edge of the paper. 
Margins are not available in other document types.

On screen, the document’s margins appear as a dashed line. The 
page boundary appears as a solid line around the edge of the layout 
area. Make sure the margins are not outside the page boundary (see 
“Matching documents to printer pages” on page 11.6).

Page Layout 
To specify multiple pages per sheet in a Publication, choose Tent 
Card or Greeting Card in the Sheet Layout pop-up menu.

Tip
For illustrations larger than the 
current paper size, toggle the 
Breaks option in the Properties 
bar to see or hide page breaks. A 
line around the layout area indi-
cates page boundaries.
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Facing Pages
To create double-sided pages, select Facing Pages. When you select 
this option, a message appears. Click OK to proceed. Once you 
select Facing Pages for a Publication, it cannot be deselected. In 
addition, when Facing Pages is on, the document has a left and a 
right master page that you can apply to its left-hand and right-hand 
pages. This option is available in Publication documents only.

Paper Color Lets you apply a solid color to the document layout 
area. The paper color is for display purposes only and does not 
print. To apply a paper color, select a color from the pop-up palette.

Note: When objects are partially transparent, the paper color is visi-
ble through the objects. However, while the paper color is not visi-
ble through solid objects, in the real world, the colors of objects will 
be affected by the color of the paper they are printed on; e.g., a yel-
low circle printed on blue paper will appear green. This is not 
shown on screen in Canvas when you use the Paper Color option.

Canvas includes the paper color when it renders transparent 
objects, so the paper color affects the rendered image the same as it 
does on screen in Canvas.

Matching documents to printer pages
Selecting “From Printer” in the Document Setup dialog box tells 
Canvas to use the page information from the Page Setup dialog 
box. Canvas sets the orientation and dimensions In the Document 
Setup dialog box to match the selected page size. 

When From Printer is selected and you change the page settings, 
Canvas changes the dimensions of the document to match. You can 
choose File > Page Setup to change the paper size, or its orientation; 
Canvas will update the dimensions of the document and you do not 
have to choose Layout > Document Setup. 

When the document type is Illustration, and you select From 
Printer, the document size is equal to the printable area or page 
boundary of the paper selected in the Page Setup dialog box. For all 
other document types, the document size is equal to the paper size, 
rather than the page boundary. 

Paper

Page boundary

Tip
If working with a large document, 
you can define a printable area 
(see “Printable area” on 
page 9.11). You can then toggle 
the Printable area option in the 
Properties bar. 
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On most printers, the page boundary is smaller than the paper size. 
Illustration documents are sized to the page boundary, so illustra-
tions will fit on the paper without being scaled. You should note 
that the page boundary on many printers is not centered exactly on 
the paper.

Canvas takes scaling into account when it sets the document 
dimensions and you specify a scaling factor in the Page Setup dia-
log box; e.g., if you specify 50% scaling, the document size will be 
twice the page size (or twice the page boundary size in an Illustra-
tion).

When From Printer is selected, Canvas checks the Page Setup 
information each time you open the document. If necessary, it 
adjusts the document’s dimensions to match the page information.

Setting up rulers and the drawing scale
You can set up rulers for a document using various units of mea-
sure and display the rulers at the top and left of the document win-
dow. Rulers help you track the pointer’s movement and let you 
create alignment guides in the layout area.

When you create a new document, you can also set the document’s 
drawing scale. Canvas bases the rulers and all object measurements 
on the drawing scale. Canvas uses scale measurements in the 
Object Specs palette, Properties bar, and in Dimension objects.

• To display and hide rulers: Toggle the Rulers checkbox in the 
Properties bar. The rulers must be displayed if you want to create 
alignment guides in the layout area.

To set up rulers
The rulers can be defined in the New Document dialog box or by 
choosing Layout > Rulers to open the Rulers manager.

1 Choose Layout > Rulers. The Configuration Center opens 
with the Rulers manager displayed (see “Setting preferences,” 
page 13.1).

2 Select a unit of measurement from the menu (A). This unit is 
displayed in the rulers, Object Specs palette, as well as Properties 
bar.

3 Define the drawing scale in the Document scale section (B), if 
necessary. You can use the Pre-defined scales or establish a cus-
tom scale; e.g., if you set the drawing scale to 1 inch = 1 foot, and 

Tip
To see or hide the page boundary, 
you can toggle the Breaks option 
in the Properties bar. Canvas indi-
cates the page boundary by a solid 
line around the border of the page.
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draw a line 1 inch long on screen, Canvas displays the line’s 
length as 1 foot (see “Defining a drawing scale,” page 13.20).

4 Choose the formats (C) for the numbers, angles, and coordi-
nates. For the number format, you can choose from no decimals 
to six decimals, or even use exponentials or fractions.

5 After you configure all ruler settings, click OK.

Using Set Document Scale command
You can use this command to customize a document’s drawing 
scale, which is useful if you are working with objects that have 
known measurements. 

You import a diagram of a door which, in reality, measures 36” in 
width. You can use the Set Document Scale command to set the 
drawing scale so 36 inches (world distance) would equal 1 inch 
(page distance).

To use the Set Document Scale command
1 Choose Layout > Set Document Scale.

2 Click once to establish the scaling start point.

3 Click a final time to set the scaling end point. The Define 
Document Scale dialog box opens. The first value (A) is the dis-
tance that you measured. The unit of measurement corresponds 
to the ruler’s unit of measurement.

4 Enter the custom scale in the bottom field (B) and select the 
unit of measurement from the menu.

5 Click OK.

Adding and modifying units of measurement
You can further customize the rulers by adding units of measure-
ments or modifying the definitions of existing ones.
.8 DOCUMENT SETUP



Note: The Add unit feature is a document-based function; i.e., any 
units that you add pertain to that particular document and will not 
be available when you open another document.

To access these functions, choose File > Configuration Center 
(Windows) or Canvas > Configuration Center (Mac) to open the 
Configuration Center. Under the Measurements manager, click on 
Define unit.

• To delete a unit of measurement: Select the unit in the menu 
and click the Remove button.

To add a unit of measurement
1 Click the Add button. The Add unit dialog box opens.

2 Enter the Unit name, Plural name, as well as Abbreviation.

3 Set up the new unit’s drawing scale by using the Size and 
Subdivisions controls.

4 Click OK to add the unit to the menu.

To modify a unit of measurement
Note: You cannot change the unit name or plural name.

1 Click the Modify button. The Modify unit dialog box opens.
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2 Change the unit’s Abbreviation, if needed.

3 Set up the unit’s new drawing scale by using the Size and 
Subdivisions controls.

4 Click OK to close the dialog box.

Assigning X/Y position to points
If you are trying to recreate a portion of an illustration, you may 
need to move the zero points or assign an X/Y position to a specific 
point in the drawing area.

To assign a position
1 Place the cursor over the intersection of the rulers in the 
upper left corner. The cursor changes to a double-sided arrow-
head.

2 Click and drag the cursor to the location in the Canvas work 
area where you want to assign the X/Y position. The Assign Posi-
tion dialog box appears.

3 Enter the X/Y coordinates in the fields or use the scrollboxes.

4 Press OK. The Rulers shift to reflect the assigned position.

To change rulers

You can change the current document unit and drawing scale by 
using the Units and Drawing Scale menus in the Properties bar. To 
view these items, deselect all objects.
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To use ‘tear-off’ rulers
When rulers are displayed, you can move a copy of a ruler into the 
layout area to measure specific areas of an illustration. When you 
tear off a ruler and move it, Canvas takes a snapshot of the ruler 
and pastes it into the document as a paint object. A tear-off ruler 
isn’t active like the rulers displayed at the window edges. 

• To place a tear-off ruler in a document: Point to the ruler you 
want to tear off, press Option (Mac) or Alt (Windows) and drag a 
copy of the ruler into the document.

Using the alignment grid
You can display a grid of vertical and horizontal lines to aid in posi-
tioning objects in a document. You can also turn on the snap-to-grid 
feature to make Canvas snap objects into alignment with the grid 
when you drag near a grid line.

When snap-to-grid is active, the pointer movements snap to the grid 
according to the settings in the Grids manager.

• To display grids: Select the Grids checkbox in the Properties 
bar. You can also choose Layout > Display > Show Grids.

• To turn off grids: Deselect the Grids checkbox. You can also 
choose Layout > Display > Hide Grids.

• To turn on snap-to-grid: Choose Layout > Snap To > Grid. 
Choose the command again to turn off snap-to-grid.

• To temporarily override the grid constraint: Press Tab as you 
create, resize, or move objects.

To set up the alignment grid
Use these settings to create an alignment grid (see “Grids” on 
page 13.19).

1 Choose Layout > Grids. The Grids manager appears.

2 Enter a value in the Line Distance X: Units text box. 

3 Enter a value in the Line Distance Y: Units text box. 

4 Enter a value in the Snap Factor X: Fields text box. 

5 Enter a value in the Snap Factor Y: Fields text box. 
Using the alignment grid 11.11



11
You can enter decimal or fractional values; Canvas converts frac-
tional values to decimal values; e.g., if the Line Distance is 1 inch, a 
Snap Factor of 1/2 Fields sets snap points every 1/2 inch. 

6 Select Snap to X and Snap to Y to make objects snap to the 
snap points on both sets of grid lines. 

7 Click OK to implement the grid settings.

Using alignment guides
You can create alignment guides and alignment objects. Other 
objects can “snap” to alignment guides and objects.

Alignment guides are horizontal and vertical lines you drag into a 
document from the rulers. When you create alignment guides, Can-
vas places the guides on a guide layer. 

You can also create guide objects from any vector objects. Guide 
objects are placed on a guide layer; e.g., if you draw a rectangle on a 
guide layer, objects can snap to the sides of the rectangle.

Alignment guides and objects normally do not print, because the 
guide layers are set to be non-printing.

• To show or hide guides: Toggle the Guides checkbox in the 
Properties bar. Deselect any objects to view the checkbox. You can 
also choose Layout > Display > Show Guides or Layout > Display > 
Hide Guides.

• To activate snapping to guides: Choose Layout > Snap To > 
Guides. When the snap-to feature is active, objects you move will 
snap to alignment guides and objects on guide layers.

To set up alignment guides
1 Display the rulers by selecting the Rulers checkbox in the 
Properties bar. 

Grid lines

X
Y

Snap points 
set at 1/2 of 
grid spacing

1/2

1/2

1/2 1/2

Illustration area
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2 Point to either ruler and drag a guide into the document area.

• To remove a guide: Drag the guide back to its ruler.

• To move objects touching an alignment guide: Press Option 
(Mac) or Ctrl (Windows) as you drag an alignment guide. This 
method does not apply to alignment objects on a guide layer.

To set up alignment objects
1 Select one or more vector objects.

2 Choose Object > Arrange > Send to Guide Layer. Canvas 
moves the selected objects to the guide layer on the current page. 

The ink and stroke attributes of guide objects are overridden by 
default on guide layers. Guide objects appear with a blue pen ink, a 
1-point stroke, and no fill ink. 

You can edit guide objects without moving them off a guide layer; 
e.g., you can select a guide object, drag its selection handles, use 
freeform mode to transform it, and use edit mode to reshape it.

To position guides numerically
After you place a guide line in a document, you can set its position 
numerically.

1 Double-click an alignment guide to open the Guides dialog 
box. 

2 Select Horizontal or Vertical to set the guide’s orientation. 

3 Enter the Guide position in the text box. Positive values go 
down and to the right from the zero point. Negative values go up 
and to the left.

4 Click OK.

When you enter a value for the position of a guide, you can use the 
current measurement units, or enter a unit abbreviation; e.g., to 
place a vertical guide 3 inches to the right of the zero point, type 
“3in” (without quotes) if the current units are not inches. To set a 
horizontal guide 2 picas above the zero point, type “-2p”.

Tip
If you move an alignment object 
off a guide layer, its original 
attributes reappear.
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12
DOCUMENT LAYOUT

You can use multiple pages and layers in any document as well as 
set up master pages, shared layers, guide layers, and grid layers. 
Layout options also include slide transitions and timing for GIF 
animations (see “Creating slide shows,” page 37.1 and “Working 
with animated GIFs,” page 36.22). 

This chapter describes document layout options and procedures, 
including how to add, delete, and arrange pages and layers, and use 
the Document Layout palette.

About document pages and layers
You can create four types of documents in Canvas: Illustrations, 
Publications, Presentations, and Animations. The common ele-
ments of all document types are pages and layers.

Pages
All Canvas documents can contain multiple pages. Here, “pages” is 
used as a general term for elements that make up a document. 

• Publications can have single or facing pages.

• Illustrations have pages, called “sheets,” which are single-
sided.

• Presentations have pages, called “slides,” which can be dis-
played in sequence as “slide shows.”

• Animations have pages, called “frames,” which form ani-
mation sequences for animated GIF files.

In the Document Layout palette, pages are at the top level of the 
layout hierarchy, followed by layers, groups, and objects. 

The Layout area in Canvas represents a document page. Page and 
layer controls are located below the document window. The current 
page is shown in the Page menu (see “Page & layer controls” on 
page 12.7). 

Layout area
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Layers
A layer is a transparent level that objects are placed on. Pages are 
made of one or more layers. When you place or draw objects on a 
page, you actually place the objects on the page’s layers. 

In the Document Layout palette, a page’s layers are listed after the 
page name. Objects are listed after the layer they are on. A new 
page has one layer (Layer #1). You can add layers to any page, 
including master pages. 

Layers can help you work efficiently. You can organize objects on 
layers, and you can display, print, and save layers individually.

You can save time and resources by sharing layers in a document. 
A shared layer is similar to a master page. As with a master page, 
objects on a shared layer appear on every page where the shared 
layer is applied. You can update multiple pages by editing a shared 
layer.

Master pages
Master pages are special types of pages. The objects on the master 
page’s layers can appear on every page in a document. 

In the Document Layout palette, the master page and its layers are 
listed under each page where the master page is visible. The main 
master page is at the top of the list.

Master pages are available in Publication documents. Similar ele-
ments called “master slides” are available in Presentation docu-
ments, and “master frames” are available in Animation documents.

By selectively hiding layers of the master page, you can control the 
master page appearance throughout a document or on selected 
pages. The master page at the top of the layout list can be locked.

Using the Document Layout palette
The Document Layout palette is the control center for working 
with pages, layers, and objects. The palette is available in all types 
of documents (some options are based on document type). 
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To open the Document Layout palette
Choose Layout > Document Layout. You can also right-click (Win-
dows) or Control-click (Mac) on a Layer tab at the bottom of the 
document window to open the Layer menu. Select Show Document 
Layout. 

The palette shows a list of the pages, layers, and objects in the cur-
rent document. You can use the palette to add, delete, and move 
items and set layout options. You can select, move, copy, and delete 
objects.

The Document Layout palette floats, so you can place it anywhere 
on screen. You can dock the palette on the Docking bar. To expand 
the palette, drag the grow box below the scroll bar.

Setting options in the palette
The Document Layout palette has columns of settings for several 
options: master pages, visibility, locking, printing, layer override 
colors, and animation frame duration.

To display/hide option columns, choose Palette Options in the pal-
ette’s menu. In the dialog box, select the options that you want to 
appear in the Document Layout palette. Some options are not avail-
able in all types of documents.

Options columns
The following are the options you can change by clicking options 
columns in the Document Layout palette. You can also use dialog 

The Document Layout palette lets you 
select and set options for pages, layers, and 
objects

A Layout list
B Options columns
C New page
D New layer
E Search box
F Trash
G Palette menu

Tip
We recommend that you select 
Master Visible to facilitate working 
with master pages.
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boxes to change options (see “Using options dialog boxes,” 
page 12.8).

Master page Click to show or hide the master page on a document 
page. If the master page is hidden, a hollow circle with grey outline 
appears in the column. When the master page is visible, the hollow 
circle has a blue outline. Master pages are not available in Illustra-
tion documents.

You can hide master page layers using the Visible option. Hiding 
all master page layers is the same as hiding the master page.

Visible Click to show or hide a page, layer, or object. Hiding a 
page hides all its layers (unless one is the current layer). When 
something is hidden, a hollow circle appears in the Visible colomn. 
If the object is visible, a blue-filled circle appears in the column.

Locked Click to lock or unlock a page, layer, or object to prevent 
or allow changes. A bullet indicates an item is locked and its con-
tents can’t be selected, moved, edited, or deleted. Grid layers are 
always locked. A padlock icon indicates an item is also password-
protected. 

Printable A bullet indicates an item will print. When no bullet 
appears, the item will not print. If you change this option on a page, 
the setting is applied to all the page’s layers.

Color Override Click in the column to apply an override color to a 
layer. A square with the override color appears in the column. To 
select an override color in the Layer Options dialog box, double-
click the layer name. To hide a layer’s override color, click in the 
column to remove the color square. 

Frame Duration In Animation documents, this column shows the 
duration of a frame in hundredths of a second. To change the 
frame’s duration, double-click the frame name, change the duration 
value in the Frame Options dialog box, and click OK.

Using the layout list
You can use the list in the Document Layout palette to display and 
select pages, layers, and objects. You can expand the list to display 
more detail, or collapse it to display fewer items.

A Master page
B Visible
C Locked
D Printable
E Color override
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The layout list is a hierarchy. Pages are at the top level, followed by 
layers, then group objects, then individual objects. Each level is 
indented to the right from the level above. The master page and its 
layers are listed after a page’s regular layers.

The name of the selected item in the list is shaded. The active layer 
name is bold. Names of master layers, shared layers and objects on 
shared layers are italic.

• To expand or collapse one level in the list: Choose Expand All 
or Collapse All in the palette’s menu. The current level (pages, lay-
ers, or object groups) will expand or collapse. You can also Option-
click (Mac) or Alt-click in the list to do the same thing.

Selecting items
You can select one or more items at once in the layout list. The 
name of a selected item is shaded.

• Selecting a page makes it the current page. The last cur-
rent layer of the current page will be the current layer.

• Selecting a layer makes it the current layer. 

• Selecting an object selects the object in the document.

• Selecting any item that is not visible makes the item visi-
ble.

• To select one item: Click the name of the item in the list

Layout list

Items in a document are listed in a tree 
format in the Document Layout palette.

Mac: Click  to expand the list. Click 
 to collapse it.

Windows: Click a plus to expand the 
list; click a minus to collapse it.

Ctrl-click an item to toggle the state of 
its sub-items. If you Ctrl-click a page, its 
expanded layers will collapse, and its 
collapsed layers will expand.

Document Layout palette (Mac)

Document Layout palette (Windows)

List hierarchy
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• To select multiple items: Click the first item and Shift-click the 
last item. This selects a continuous range of pages, layers, or 
objects. To select or deselect individual items in a selection, press 
Ctrl-click each item.

Searching for items
Canvas can find items in the layout list by searching their names. 
This means you can go to pages and layers, and select objects in a 
document, by typing some or all of the text in an item’s name.

To select an item in the list, type the text to find in the search box 
in the Document Layout palette. When you stop or press Enter, 
Canvas searches the list from the current page. The search includes 
only items that are visible in the list (not collapsed pages).

You can type text lower- or upper-case. If an object in the list is 
named “Rectangle Fill 0c 67m 45y 23k” and you type “23K” Canvas will 
select the object. Default object names are object type and ink val-
ues. Default page and layer names are item type and sequence num-
ber. Double-click on a layer, page, and object in the layout list to 
assign names to these items. Their assigned names will appear in 
the layout list.

Adding, deleting, and moving pages and layers
To change a document’s layout, you can add, delete, as well as 
move pages and layers. You can do this in the Document Layout 
palette, use commands in the Layout menu, or use the Page & 
Layer controls (see “Page & layer controls” on page 12.7). In addi-
tion, you can arrange, copy, and delete objects in the Document 
Layout palette.

To add pages
In the Document Layout palette, click the New Page button. Can-
vas adds a page, sheet, slide, or frame to the end of the document. 
In the list, the item’s name is the next number in sequence.

You can also add pages by choosing Add Page (Sheet/Slide/Frame) 
in the palette’s menu.You can assign a name to the page in the dia-
log box.

To add multiple pages
Commands in the Layout menu let you insert multiple pages into a 
document. 
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1 Choose Insert in the Layout > Pages (Sheets/Slides/Frames) 
submenu. 

2 A dialog box appears. Enter the number of pages you want to 
add, choose a location to insert the new pages, and then click OK.

To add layers
In the Document Layout palette, select a page or layer and click the 
Add Layer button. Canvas adds a new layer to the current page. 
You can also click the New Layer icon at the bottom of the docu-
ment window (see “Page & layer controls” on page 12.7). 

In addition, you can add layers by choosing open the Document 
palette menu and selecting Add Layer. A dialog box lets you 
change the layer’s name and select other options (see “Page and 
layer options” on page 12.8).

Page & layer controls
Canvas features additional page and layer controls that can be used 
in addition to the Document Layout palette. 

• To add pages: Click on the New page icon and the Insert dia-
log box opens. Enter the number of pages (sheets or slides) and 
indicate the placement; i.e., before or after a certain page.

• To add layers to a page: Click on the New layer icon. Another 
layer is added automatically to that page.

• To toggle between pages: Open the Page menu and select the 
page that you want to view. 

• To toggle between layers: Use the Layer controls located to the 
right of the page & layer controls. If your document contains multi-
ple layers, these controls scroll through the various layers.

Arranging items
To move pages, layers, or objects, you can drag them in the layout 
list. If you drag to a collapsed part of the list, the list expands.

Canvas does not rename layers if you change their order or move 
them to other pages in the list. If you change the order of pages, 
Canvas will rename them, unless you have given them unique 
names.

Tip
You can merge layers, which 
moves objects from a source to a 
destination layer and deletes the 
source layer. Click the source layer 
to select it in the layout list. Shift-
click the destination layer. Choose 
Merge Layers in the palette’s 
menu.

A New page icon
B Page menu
C New layer icon

A First layer
B Next layer (left)
C Next layer (right)
D Last layer
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• To copy items: Select one or more items in the palette, and 
then Option-drag (Mac) or Ctrl-drag (Windows) them to a new 
layer.

To delete items
Drag the items from the list to the Trash icon. You can also delete 
items by selecting them in the palette and then choosing Delete in 
the palette’s menu. 

To delete multiple pages
1 Choose Layout > Pages (Sheets/Slides/Frames) > Delete. 

2 In the dialog box, enter the page range to delete and click 
OK.

Page and layer options
In each type of document, you can set options for pages and layers. 
Use the Document Layout palette to set some options (see “Setting 
options in the palette” on page 12.3). Additional options are in dia-
log boxes. 

Using options dialog boxes
In the Document Layout palette, double-click a page, master page, 
or layer to open an Options dialog box. Or, select the item and 
choose Options in the palette’s menu.

In the Options dialog box, select from the following options and 
click OK to apply the settings. Some options, as noted, are not avail-
able for all items or document types.

Naming items
In the text box, type a name for the item. By default, Canvas names 
pages and layers based on their order in the list. 

Destination

Tip
You can set options for multiple 
items by selecting them and 
choosing Options in the palette’s 
menu. Do this to set the duration 
for multiple frames of an anima-
tion, or to apply transitions to mul-
tiple slides.
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Locking items
Select the Locked option to prevent changes to a page’s layers, to 
individual layers, or to individual objects.

Password protection You can select the Password option when 
Locked is selected. When the Password option is used, the assigned 
password must be entered to unlock or change the page. To assign 
a password, select the Password option and type at least three char-
acters in the text box. After you click OK, enter the password in the 
confirmation dialog box that appears and click OK.

Note: A locked page can be changed in some ways. If a master page 
is visible, changes to the master page will appear on the locked 
page. Also, a locked page does not prevent a document from being 
deleted. If a locked page is copied, the copy is also locked.

Hiding items
The Visible option can be changed only in the Document Layout 
palette list. In Options dialog boxes, the Visible option is not avail-
able because a current item can’t be hidden.

Layer colors
Grayed Select Grayed to make solid color inks of objects on the 
layer appear to be grayed (desaturated).

Select Color Override to apply a color to a layer. Select White Fill to 
apply a white fill ink to vector objects and text objects on a layer 
that has a color override.

When you apply a color override to a layer, you temporarily assign 
a color to vector and text objects on the layers you specify. A color 
override does not affect paint objects. When you turn off the Color 
Override option, all affected objects revert to their original colors.

The White Fill option lets you control how override colors appear 
on vector objects. This option doesn’t change how override colors 
appear on text.

When White Fill is selected, Canvas applies the override color to 
the pen ink of vector objects and applies white as the fill ink; i.e., the 
override color becomes the color of the stroke of vector objects, 
while the inside of the object remains white. When White Fill is not 
selected, Canvas applies the override color as both pen and fill inks. 

If you use the White Fill option, objects without a visible stroke are 
not visible against the white layout area.
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Sharing layers
Sharing a layer means linking a layer to more than one page in a 
document. Since the shared layers are linked, if you modify one 
layer, all the linked layers will change. Therefore, shared layers can 
be used like additional master pages. 

The names of shared layers and objects on them are indicated in 
italic type in the Document Layout palette.

To share a layer
1 Select the layer you want to share in the Document Layout 
palette.

2 Choose Share Layer in the palette’s menu. A dialog box 
appears.

3 Select the pages in the list that you want to share the layer 
and click Select. The shared layer name appears in the list of lay-
ers for each page you selected.

Note: The name and content of the dialog box changes according to 
the document you are creating; i.e., pages, sheets, frames, or slides.

To unshare a layer
Unsharing a layer converts it from a shared layer into a regular, 
non-linked layer on one page or throughout a document.

1 Select the layer you want to unshare. 

2 Choose Unshare Layer in the palette’s menu.

3 In the message box that appears, click either Yes or No as 
explained below:

Yes Unshares all instances of the shared layer in the document. 
Canvas unlinks the layers and creates a copy of the layer on each 
page.

No Unshares the layer on the currently selected page only. The 
rest of the layers remain shared.

Using master pages 
Master pages (slides/frames) hold common elements that you want 
to appear on most pages. Objects on the master page’s layers 
appear on pages where the Master Page option is selected. 

Illustration documents do not use master pages.

Tip
You can share a layer by pressing 
Shift and dragging the layer to 
another page (except the master 
page). Repeat to add the shared 
layer to other pages.
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You can unlink a master page. This lets you edit the page’s contents 
like you would any layer that isn’t shared, without changing the 
appearance of the master page on other pages. Canvas also lets you 
re-link a master page.

To unlink a master page
1 Select the page where you want to unlink the master page. 
(Do not select the master page item or a layer).

2 Choose Unlink Master in the palette’s menu. The layers of 
the master page become regular layers of the current page.

To link a master page
1 Select the page to which you want to link the master page.

2 Choose Link Master in the palette’s menu. Canvas links the 
master page to the current page. Other elements on the page are 
not affected.

Dispersing objects
You can use the Disperse command to quickly move objects to 
pages throughout a document. This is useful for creating frames 
and slides. For example, you can select a series of graphics, and use 
Disperse to place one graphic on each frame in an Animation docu-
ment. You can spread objects over existing pages or Canvas will 
create pages for the objects. Dispersed objects are placed on a new 
layer on each page.

To disperse objects
1 Select the objects to disperse. The objects should be on the 
same layer and should not be grouped.

2 Choose Object > Arrange > Disperse. In the dialog box, select 
an option:

• Dynamic: Canvas will create pages to hold the selected objects.

• Selected: Click Select to display a list of pages. Shift-click pages 
to select them, and then click Select.

3 In the text box, enter the number of objects to place on each 
page (Canvas divides the number of objects evenly if you select 
pages; remaining objects go on the last selected page). Click OK 
to disperse the selected objects.
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Using guide and grid layers
In addition to general purpose layers, you can use special layers 
designated to contain drawing aids called guides and grids. 

Like other layers, guide layers and grid layers appear in the Docu-
ment Layout palette. You can arrange these layers by dragging 
them in the list to place them in front of or behind other layers.

Guide layers
When the command Layout > Snap To > Guides is selected, objects 
that you draw and move will snap to guides on the guide layer.

Guides that you drag from the rulers, and text sections you draw 
with the Section tool will appear on the current page’s guide layer. 
You can also draw on a guide layer to create “magnetic” guide 
objects. 

To add a guide layer
1 Select the page to which you want to add a guide layer.

2 Choose Add Guide Layer in the Document Layout palette’s 
menu. 

3 The New Guide Layer dialog box appears. Enter a name, and 
select the visible option to display the layer, and click OK. 

By default, objects on guide layers are light blue. By changing the 
guide layer override color, you can make the objects any color. To 
change a guide layer’s name, override color, or other properties, 
double-click the layer and use the Layer Options dialog box, or use 
another method for setting layer options as described in “Page and 
layer options,” page 12.8.

To arrange guide layers
You can move a guide layer to another place within the present 
page or to another page altogether. Select the guide layer and then 
drag the guide layer to its new position.

To copy guide layers
You can copy a guide layer to another place within the present page 
or to another page altogether. Select the guide layer and then 
Option-drag (Mac) or Ctrl-drag (Windows) the guide layer to its 
new position.
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To delete guide layers
Select the guide layer and then drag it to the trash can icon in the 
Document Layout palette. You can also select the guide layer and 
then choose Delete from the palette menu.

Grid layers
Grid layers display gray grids that can help you position objects pre-
cisely. When the command Layout > Snap To > Grid is selected, 
the bounding boxes of objects will snap to the grid.

When you create a grid it appears on a grid layer. Grid layers are 
locked by default. You can configure the current page’s grid using 
the Layout > Grids command.

To add a grid layer
1 Select the page to which you want to add a grid layer.

2 Choose Add Grid Layer in the palette menu. The New Grid 
Layer dialog box appears. Configure the options as desired, and 
then click OK. Canvas adds a new grid layer.

By default, grid layers are gray. To change a grid layer’s name and 
other properties, double-click the grid layer and use the Layer 
Options dialog box, or use another method for setting layer options 
as described in “Page and layer options,” page 12.8.

To arrange grid layers
You can move a grid layer to another place within the present page 
or to another page altogether. Select the grid layer and then drag 
the grid layer to its new position.

To copy grid layers
You can copy a grid layer to another place within the present page 
or to another page altogether. Select the grid layer and then Option-
drag (Mac) or Ctrl-drag (Windows) the grid layer to its new posi-
tion.

To delete grid layers
Select the grid layer and then drag it to the trash can icon in the 
Document Layout palette. You can also select the grid layer and 
then choose Delete from the palette menu.
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Chapter

13
CONFIGURATION & CUSTOMIZATION

You can customize your Canvas work environment to best suit the 
needs of a specific project and maximize your productivity. This 
chapter describes how to set preferences, customize keyboard short-
cuts and the Toolbar, save document templates, and create custom 
sets of Canvas tools.

Setting preferences
The Configuration Center contains the settings options and their 
related managers. 

• To open the Configuration Center: Choose Canvas > Configu-
ration Center (Mac) or File > Configuration Center (Windows).

Configuration Center
The various application and document settings are categorized in 
the left pane of the dialog box.

View controls:
Functionality
Alphabetical
Condensed

Click on an option in the 
list and the related 
manager appears to the 
right. 

Select the Save as default 
checkbox in the upper 
right corner if you want to 
keep the chosen settings.
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View controls
When the Configuration Center is open, you can change the dis-
play by using the View controls located in the upper left corner:

Functionality The settings managers are grouped according to use. 
Five major groups appear in the list; i.e., General, Text, Printing, 
etc. Open a group to see its settings options. 

Alphabetical All the settings options are listed in alphabetical 
order in the left pane. Click on an option to see its related manager.

Condensed The left pane collapses so only the right pane is visi-
ble. You can only see the selected settings managers. Click on the 
Condensed view icon to see the entire dialog box.

To change a preference
When turning on an option, you may also have to enter a value or 
choose a menu option. Remember that an option is on when its 
checkbox is selected. An option is off when its checkbox is dese-
lected. 

1 Open the Configuration Center.

2 Open a category in the left pane and then click on a settings 
option, like Display Options. The related settings manager 
appears in the right pane.

3 Make any adjustments in the settings manager.

4 To implement the current settings, click OK. 

• To save the settings as default: Select the Save as default check-
box.

General settings
The following settings options are listed within the General cate-
gory.

Personality Manager
Use the Personality Manager to select your use of Canvas and color 
output needs. The Toolbox and related tool palettes will be rear-
ranged to suit your needs.

At any time, you can make modifications to the Personality Man-
ager if your needs change.
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• To access the Personality Manager: Choose File > Configura-
tion Center or Canvas > Configuration Center and click the Person-
ality Manager option in the General settings. Make your changes 
and restart the program.

Note: Changes in the Personality Manager affect the Canvas settings 
file.

Color Calibration
Use these options to change color settings within Canvas (see 
“Color management,” page 13.20). 

Display Options
In the Display Options manager, you can configure most of the 
options for screen display. Change display options and set the 
default display options for new documents.

• To open the Display Options manager: Choose Layout > Dis-
play Options. 

• To make the current setup the default for new documents: Select 
“Make default for new documents.” 

Alert and preview options The normal Canvas display shows all 
objects with their inks, strokes, and other attributes as they are in 
the document.

• Gamut Warning: This mode highlights colors that are outside 
the CMYK color gamut. It replaces out-of-gamut colors with a spe-
cial indicator color. Bright greeen is the default indicator color.

• To change the Gamut Warning color: Choose Edit > Calibra-
tion > Gamut Warning. Select a color from the pop-up menu.

• Ink Coverage: This mode shows all areas of the image that 
exceed a specified ink coverage. Bright greeen is the default indica-
tor color.

• To change the ink coverage color or value: Choose Edit > Cali-
bration > Ink Coverage. Select a color from the menu. Enter an 
amount percentage value in the Amount box.

• Wireframe: Wireframe mode shows vector objects without 
their assigned ink or stroke attributes. When Wireframe is selected, 
vector objects are hollow and have 1-point black pen strokes. Text 
characters appear solid black. Paint objects are hollow and only 
their bounding box appears. With this mode, the screen display 
tends to speed up. 

Tip
The items in the Show, Alert, and 
Preview groups can be individually 
toggled on and off by choosing 
Layout > Display. When a special 
display option is active, a check-
mark appears next to the option in 
the menu.
Setting preferences 13.3



13
• Pixel Mode: The Pixel Mode setting allows users to view graph-
ics at 72 ppi before they are rendered. 

When creating Web graphics, the standard resolution is 72 ppi. At 
the same time, all of your images will remain fully editable. Pixel 
Mode also prevents pixel shifting, which sometimes occurs when 
objects are exported to the Web (see “Designing for the Web,” 
page 36.1). 

Cache options Caching in Canvas is a technique that can dramati-
cally increase display speed. When an object is cached, Canvas cre-
ates a low-resolution version of the object to display on screen. This 
can make it much easier to work in documents that contain com-
plex vector objects or high-resolution images, which can signifi-
cantly slow down zooming and scrolling.

When you are not editing cached objects, it usually won’t matter 
that they are displayed at lower resolution. You’ll enjoy signifi-
cantly faster display without losing any capabilities. When you want 
to edit a cached object, Canvas loads the original; you do not need 
to take any special action or uncache the object.

• Draw with Cache: Select this option to display low-resolution 
versions of cached objects for faster display. Cached objects are 
objects that have been cached with either the Cache Object com-
mand or the Auto Cache Images option (see “Auto Cache Images,” 
page 13.4).

When Draw with Cache is not selected, Canvas retains any low-res-
olution previews that it has created in memory, but displays the full 
paths of vector objects and displays paint objects at normal resolu-
tion.

• Auto Cache Images: Select Auto Cache Images to automati-
cally cache paint objects whose resolution is above a threshold that 
you specify.

To set the resolution threshold, enter a value from 72-2540 ppi in 
the first text box. When the resolution of a paint object is equal to 
or greater than the specified resolution, Canvas caches the paint 
object.

Cached paint objects are displayed at low resolution for faster dis-
play. Enter the desired display resolution in the second text box.

• To uncache all paint objects: Deselect Auto Cache Images. A 
message appears. Click Yes to uncache all paint objects. This is 

Tip
If Auto Cache Images is selected, 
but Draw with Cache is not select-
ed, Canvas will cache paint 
objects (if their resolution is above 
the set threshold), but will not dis-
play the low-resolution versions.
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equivalent to using the Uncache Object command on each paint 
object individually.

Note: If you want to uncache paint objects and Auto Cache Images 
is already cleared, use the Uncache Object command instead (see 
“To uncache an object,” page 13.5).

Document Setup
In the Document Setup manager, you can switch the current docu-
ment type, modify document size and orientation, as well as change 
document units and scale.

Note: Although you can switch to another document type in mid-
stream, you should save the current document in its entirety and 
then change the document type. 

Functionality Options
Maximize on Opening Opens documents at full screen size. Other-
wise, documents open at a standard size that fits any monitor, but 
might not fill the screen completely.

Fit to Window Opens documents so the full layout area can be 
seen in the center of the window. When this option is off, docu-
ments open in Home View (100% magnification with the upper-left 
corner of the page in the upper-left corner of the window).

Dither Colors Provides the best onscreen color representation, but 
requires more system memory. If you are using Canvas for Mac 
OS, this option requires 32-bit color capabilities.

Paste as MetaObject When copying from other applications, select 
this option to paste as a metaobject (see “Inserting objects into Can-
vas documents” on page 14.26). Text, however, is pasted as OLE if 

Caching objects

This command can be used to speed 
up the display of complex objects, 
which is useful when a document con-
tains complex objects that you do not 
need to edit often. When you cache an 
object, Canvas stores a low-resolu-
tion preview in memory. The preview 
can be displayed quickly when you 
move the object or change views. You 
can cache any type of object for faster 
display.

To cache an object

1 Select the object to cache.

2 Choose Object > Options > Cache 
Object. A dialog box appears. 

3 Enter a preview resolution value, 
from 2 to 300 pixels per inch, in the text 
box. Lower resolutions produce rough-
er previews.

4 Click OK. Canvas displays a pre-
view of the cached object at the cached 
resolution.

To uncache an object

1 Select a cached object.

2 Choose Object > Options > Un-
cache Object. Canvas returns the ob-
ject to its normal resolution.
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this option is enabled. If you copy both an object and text, they will 
paste as OLE.

Create backup when saving Saves a copy of the current document 
each time you save changes to the document. The backup copy has 
the extension “.bak,” and Canvas saves to this same file each time.

Canvas 6-style object locking When you lock an object or group of 
objects, you can select and copy locked object(s) by clicking on the 
object or group of objects. Copied objects will not be locked.

No Background Updates Prevents Canvas from redrawing open 
Canvas documents when you are working in another application. 
This option lets other applications run faster when Canvas is in the 
background.

Show information tooltips Displays information, tips and shortcuts 
in small boxes that appear when you point at an item, such as a 
tool, button, or object. For example, if you move the pointer over 
the Copy button in the Tool Bar, Canvas displays the command 
name and shortcut. Canvas also displays user comments when you 
point to an object that has comments, and displays information 
when you point to an ink in the Inks palette. For color inks, Canvas 
displays color system information. For example, if you point to a 
CMYK ink, the color values such as “5c 2m 92y 0k” appear in a 
pop-up box. For other inks, Canvas displays the ink name.

Select Across Visible Layers Lets you select objects on all visible 
layers in a document, rather than just the active layer.

Note: If this option is off, you can still select objects on other visible 
layers by pressing Tab and clicking the objects.

Search selection on clicks When this option is on, you can drag a 
selected object from behind another object. If this option is off, you 
can drag only the front object, because dragging deselects a back 
object.

Scale Stroke Weight When you scale an object by dragging its 
selection handles, if the object has a solid pen stroke, Canvas will 
scale the pen weight proportionately with the object.

AutoSave select this checkbox if you want Canvas to automatically 
save a document after a certain period of time. The time periods 
are designated in minutes.
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Freeform Selection Lets you place objects in freeform mode by 
clicking already-selected objects. Otherwise, you must use the 
Effects > Freeform command to put an object in freeform mode.

Number of Undo Levels Enter a number in the Min box to set the 
minimum number of actions that Canvas can reverse. The default 
is three. Enter a number in the Max box to specify the maximum 
number of actions that Canvas reverse. The default is 10.

• To undo an action in Canvas: Choose Edit > Undo or open the 
Undos palette by choosing Window > Palettes > Undos (see “Undo-
ing, redoing, and repeating actions,” page 9.6). 

GIS
Use the settings in the GIS manager when you need to open Shape-
files or configure the drawing area (see “GIS positioning,” 
page 40.1).

Painting
The Painting manager lets you set preferences for displaying and 
editing paint objects and images. 

Brush pointers These options let you change the pointer displayed 
for painting tools. The default pointer is a symbol of the current 
painting tool.

• Standard Pointer: displays the icon for the current painting 
tool. 

• Precise Pointer : displays a crosshair pointer. The intersection 
of the crosshair is the center of the current brush. 

• Brush Size Pointer : displays an outline of the current brush as 
the pointer.

Note: Open the context menu to change the pointer while you edit a 
paint object.

Plug-ins Click the button to set the location of Photoshop-compati-
ble plug-ins for use in Canvas. In the directory dialog box that 
appears, select the folder containing the plug-ins. The path name of 
the folder appears below the Plug-ins button on the Painting tab. 
Installed plug-in filters appear in the Image > Filters submenu.

Don’t Show Plug-in Host Warning Suppresses the message that 
Canvas displays if it tries to load a software plug-in that requires a 
specific host program. Deselect this option if you want Canvas to 
display the message so you can choose whether to load the plug-in.
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Separate Grayscales as Black Select to separate grayscale paint 
objects on the black plate only. Deselect this option for Canvas to 
treat gray color values as RGB colors that will be separated as 
CMYK grays.

Color Channels Makes channel previews in the Image Channels 
palette appear in color rather than shades of gray.

Anti-aliased Clipboard Anti-aliases vector and text objects pasted 
from the Clipboard into a paint object.

Anti-aliased Canvas Objects Anti-aliases Canvas vector and text 
objects drawn in a paint object. For example, if you add text to a 
paint object in edit mode, Canvas rasterizes and anti-aliases the 
text.

Screen Rendering
Vector Quality The options in this menu affect the entire screen 
display in Canvas.

• Draft : provides the fastest screen display by drawing vector 
objects less smoothly. Choosing this option can increase display 
speed by 300%.   

• Normal : provides fast screen display and draws smooth vector 
objects. This is the recommended setting and is selected by default.

• Anti-aliased : significantly smooths all objects on screen, 
including text and vector objects by anti-aliasing their edges. How-
ever, this anti-aliasing slows the display compared to Draft or Nor-
mal settings. The effect of the anti-aliased option is independent of 
the anti-aliased option on the Display tab. If either option is 
selected, text is anti-aliased and vice-versa.

Interpolation When activated, this feature will significantly 
enhance the visual quality of scaled images. Interpolation takes 
place whenever an image needs to be reduced or downsampled. In 
other words, whenever the number of pixels being displayed is less 
than the available number of pixels at the destination. An example 
of downsampling would be when a 300 ppi image is set to be dis-
played at 100%.

Tip
Anti-aliased is especially useful 
when you create screen shots or 
display slide shows on screen.

Interpolation is a mathematical 
procedure which estimates values 
of a function at positions between 
listed or given values.
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• Nearest Neighbor : will remove some pixel information from 
your image; however, if used, this setting will be the fastest.

• Bilinear : will use a bilinear interpolation algorithm during 
downsampling. This setting can be used if you work with line art 
and may be applied to some photographic images.

• Bicubic : is an appropriate setting if you work primarily with 
photographs. 
Note: Due to a blurring effect, we do not recommend the Bicubic 
setting if you work with line art.

• Auto : is the optimal setting for interpolation of a photographic 
image. The Auto setting automatically chooses the best Interpola-
tion option based on the image, its resolution, and current magnifi-
cation.

Pasteboard Color Use the color palette to select a color for the 
pasteboard area.

Object Caching Keeps screen images in memory so the display 
refreshes significantly faster when you move or edit objects. This is 
the recommended option. If you deselect this option, less memory 
(up to 4 MB) is used for screen display, but displaying complex 
images might be very slow.

Transparency lets you control how transparency appears when a 
paint object is in edit mode.

• No Preview : displays a checkerboard pattern to represent 
transparency in an image. This isolates an image from background 
objects, which can be helpful for editing complex compositions.

• Background Preview : displays transparency in an image during 
editing. Objects behind the image are rendered realistically while 
you edit. (If no objects are behind the paint object, the document’s 
white layout area shows through transparent areas.) Objects in 
front of a paint object are hidden during image editing.

• Total Preview : displays both background and foreground 
transparency during image editing. This is the most accurate pre-
view.

Selection
Show originals when dragging and resizing When you drag or resize 
an object, it will follow the pointer and also appear in its original 
position until you release the mouse button.

Tip
Nearest Neighbor setting merely 
gathers pixel data from the “Near-
est Neighbor” of each pixel, there-
fore Interpolation does not actually 
occur.
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• Windows: Selecting this option means that when you drag an 
object, an outline of the object (without pen ink, fill ink, or stroke) 
will follow the pointer. 

• Mac: Selecting this option means you will always see the origi-
nal object when you drag and resize. When dragging, if you pause 
after pressing the mouse button before you begin dragging, you will 
see the object (with ink and stroke attributes) follow the pointer. If 
you begin dragging without pausing, you will see an outline of the 
object (without pen ink, fill ink, or stroke) follow the pointer.

Offset for duplicating objects Tells Canvas how far (in pixels) from 
the original to put object copies when you choose Edit > Duplicate 
or Edit > Paste.

Offset for moving objects You can specify the number of pixels that 
objects move when you use a combination of modifier and arrow 
keys. For example, with the settings shown here (for Windows), 
Ctrl+Right Arrow moves a selected object 50 pixels to the right, 
and Alt+Right Arrow moves it 10 pixels to the right. Canvas for 
Mac OS users can use the Command and Option keys in combina-
tion with arrow keys.

Auto-scroll to selection keeps objects that you move using the 
arrow keys in view by scrolling the document window.

User Info
Specify a name and initials for object comments, which you can 
insert using the Comments command (see “Attaching comments to 
objects,” page 17.40). You can also establish the default directory 
for downloading clipart with the Symbol Library palette.

• Name: Type a name in the text box. When you attach a com-
ment to an object, Canvas associates the name you enter with the 
comment. By default, Canvas uses the name entered when Canvas 
was installed.

• Initials: Type initials in the text box. When you attach com-
ments to an object, Canvas associates these initials with the com-
ment.
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Text settings
Auto Correct
Use these options to specify corrections you want Canvas to make 
as you type.

Two Initial Capitals Corrects a word that you type beginning with 
two capitalized letters.

Capitalize the First Letter of Sentences Capitalizes the first letter 
you type following typical sentence-ending punctuation, such as 
periods, question marks, or exclamation points, even if these marks 
are followed by a quotation mark or parenthesis. Canvas may or 
may not capitalize the first letter following unusual punctuation, 
such as Web site addresses or abbreviations in the middle of sen-
tences, so sentences containing unusual punctuation should be 
checked.

Note: Auto Correct does not capitalize the next word if you insert 
sentence-ending punctuation in existing text.

Capitalize the Names of Days Capitalizes the full name of week-
days; e.g., this option replaces “saturday” with “Saturday.” It does 
not expand abbreviations for day names, such as “wed.” or 
“Thurs.,” unless you add these abbreviations to the replacement 
list.

Correct Accidental Usage of the Caps Lock Key (Windows only) Cor-
rects non-standard word capitalization. If the first letter of a word is 
lowercase and the other letters are uppercase, this changes the first 
letter to uppercase and the rest of the letters to lowercase; e.g., this 
option replaces “rEPEL” with “Repel.” If the first two letters of a 
word are uppercase and the rest are lowercase, this changes the first 
letter to uppercase and the rest of the letters to lowercase; e.g., 
replacing “REpel” with “Repel”.

Replace Text as You Type Replaces text that you type with any 
specified replacement text. Each set of typed text and replacement 
text appears in the scrolling list in the Auto Correct dialog box (see 
“Setting up text replacement,” page 32.9).

Spell Check Dictionary
Use this option to add an unlimited number of words to the per-
sonal dictionary. You can also delete words. By adding words to the 
User Dictionary, you can “teach” Canvas new words and special 
terms, and prevent Canvas from stopping unnecessarily while 
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checking spelling (see “Modifying the User Dictionary,” 
page 32.15).

Type settings
The Type settings in the Configuration Center let you customize 
options for text and typography.

Note: Some options on the Type tab are different for Mac OS and 
Windows versions of Canvas, as noted in this section.

Text Input
When Typing Into Document

• Auto type into object: This option allows you to automatically 
begin typing text characters into a selected object.

• Allow single letter shortcut: If activated, you will be allowed to 
access the vector and image editing tools using simple single-letter 
shortcuts. The list below details the various hotkey commands and 
how they may be applied.

Use these single-letter hotkeys when editing a vector object:

Action Hotkey

Selection Arrow V

Direct Edit Selection Arrow A

Lasso Selection Y

Direct Edit Lasso Selection W

Bézier Tool B

Text Tool T

Tip
Remember that you must be in 
vector edit mode to use the hot-
keys.
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Use the following single-letter hotkeys when editing images:

Oval Tool O

Polygon Tool P

Smooth Polygoon Tool M

Rectangle Tool R

Freehand Tool F

Reshape Tool E

Line Tool L

Push Tool S

Dropper Tool I

Scissor Tool C

Knife Tool K

Set Default Stroke (or) Fill ‘ (accent grave)

Assign Default Stroke (or) Fill D

Swap Fill / Stroke X

Quick Mask - (masks selection to 
the object that is being created)

Q

Tool/Action Hotkey

Wand Tool W

Marque Tool M

Image Lasso Tool L

Remote Move Tool V

Pencil Tool P

Eraser Tool E

Marker Tool H

Paintbrush Tool B

Airbrush Tool A

Action Hotkey

Tip
Remember that you must be in 
image edit mode to use the hot-
keys.
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Use Smart Quotes Select this option if you want Canvas to insert 
true typographical apostrophes (’), single quotation marks (‘’), and 
double quotation marks (“”) when you type these characters with 
the Text tool. Otherwise, these characters appear as straight tick 
marks, or foot (') and inch (") marks. Of course, the actual appear-
ance of the characters depends on the design of the typeface in use.

The character that Canvas inserts when you type a quotation mark 
depends on the position of the insertion point in the text, and its 
position relative to other quotation marks; e.g., Canvas always 
inserts an open quotation mark (“) when you type a quotation mark 
immediately following a space.

Note: Use Smart Quotes has no effect on text that you type with the 
Path Text tool.

Bucket Tool K

Blend Tool G

Blur Tool F

Sharpen Tool Q

Rubber Stamp Tool S

Smudge Tool N

Dodge Tool O

Burn Tool B

Sponge Tool D

Red Eye Reduction Tool R

Swap Fill / Stroke X

Set Default Stroke / Fill ‘ (accent grave)

Switch Channels Ctrl 0 - 9

Tool/Action Hotkey
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Use Greeked text Select this option if you want Canvas to replace 
lines of text characters with gray bars, which speeds up screen 
redraw.

Enter a size in points in the adjacent text box. When this setting is 
selected, Canvas replaces text at the specified size and smaller 
when the display magnification is 100% or less; e.g., if you specify 12 
points, and zoom to 200%, Canvas replaces any text that is 6 points 
or smaller. If you zoom to 50%, Canvas replaces text that is 24 
points or smaller.

Drag & Drop Text Enable this option so you can highlight text and 
drag that text to a new location within the same text object.

Copy & Paste
Smart Copy With this option on, if you copy and paste text that 
begins a paragraph, Canvas pastes the text as a new paragraph 
using the original paragraph settings. With this option off, Canvas 
pastes text into the current paragraph using the existing paragraph 
settings.

Replace Selection Activating this function allows you to automati-
cally replace selected text when you paste into a Canvas document. 
If this option is not activated, text will be pasted into the center of 
your document.

Pasted Text Box Size Enter the point size that you would like your 
text box to be when you paste text into your document. The setting 
that you choose will become the default size for all text boxes that 
will be created when you paste text into your document.

Font History

• Activate font history: Select this option to list the most recently 
used fonts at the top of your Fonts menu.

• # of fonts to keep in history: Select the number of fonts that are 
to be stored in the history.

• Clear font history: Click this button to empty the recent font 
history.

Miscellaneous
Enable two-byte script This option tells Canvas to accommodate 
text characters that require twice as much data (two bytes) as text 
characters in most Western languages. This makes it possible to 
create documents using specialized two-byte fonts, including Chi-

Tip
The Greeked text setting does not 
affect printing. You should set the 
size the same as most body text in 
your documents. This lets you 
view headlines and display type 
normally, while Canvas replaces 
the body text at 100% magnifica-
tion. Then, when you zoom in to 
edit the body text, it will appear 
normally at the higher magnifica-
tion. 
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nese, Korean, and Japanese (see “Tools and options for two-byte 
and vertical text,” page 29.5).

Auto Word Select When you use the I-beam pointer to highlight 
specific text, this option ensures that you select only whole words 
(all characters between blank spaces). As you drag to highlight text, 
Canvas detects when you drag over a space. As you continue to 
drag, Canvas locates the next space and selects the characters in 
between.

Windows-only type preferences
Draw Text as Béziers When using a 256-color display, Windows 
cannot dither colors in text to approximate a non-system color; 
instead, Windows uses the closest solid colors. Turning this option 
on tells Canvas to redraw text as objects, which lets Windows dither 
colors when necessary. This method is resource-intensive and can 
be slow; turn this option on only if you need to see dithered color in 
text on a system with a 256-color display.

Multi-Column Font Menu When activated, you will view all of the 
fonts in your system in a multi-column format. If this feature is not 
activated, then you will view your fonts in a single-column format.

Note: If you elect to use the single-column format, use the navigation 
arrows located at the top and bottom of the list to scroll through the 
fonts list. To see the list of available fonts, choose Text > Font.

Printing settings
The Printing settings let you control the appearance of printed out-
put. These settings affect printed output when you use the Print as: 
Composite setting in the Print dialog box, and do not affect print-
ing when you use the Print as: Separations setting.

Gamut Warning
This mode highlights colors that are outside the CMYK color 
gamut. It replaces out-of-gamut colors with a special indicator color. 
By default, the indicator color is bright green (see “Alert and pre-
view options” on page 13.3).

Ink Coverage
This mode shows all areas of the image that exceed a specified ink 
coverage. By default, the indicator color is bright green (see “Alert 
and preview options” on page 13.3). 
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Output Settings
Resolution Use these settings to control the appearance of printed 
documents.

• Output to maximum resolution : Select this checkbox to print 
documents at the printer’s highest resolution. This setting disables 
image-reduction options and fast-printing features of QuickDraw® 
printers, which require a setting of 72 dpi (see “Output resolution of 
transparency effects,” page 35.21).

If you print documents to a PostScript printer, it’s a good idea to 
select this option; however, if you are using Japanese fonts (two-
byte), you can deselect the Output to maximum resolution check-
box, and then use the menu to select 300 dpi to speed up printing.

When Output to maximum resolution is not selected, you can 
choose the resolution (from 72 to 2,540 dpi) to use in the Resolution 
menu.

Halftone Set the halftone screen frequency and the halftone screen 
angle for composite printing. You can also use the printer’s default 
halftone settings. 

For most desktop publishing purposes, the printer’s default settings 
are probably the best to use. For commercial printing, you might 
need to specify a particular frequency and angle for the best output. 
If you are sending documents to a commercial printer, ask about 
the appropriate halftone screen settings.

• Use printer’s default: Select this option when you often print to 
desktop devices such as laser printers, and the default halftone 
screen frequency and angle are appropriate for your documents.

• Frequency: To specify a halftone screen frequency, deselect the 
Use printer default checkbox, and enter the frequency in lines per 
inch in the text box. A higher frequency requires a higher printer 
resolution to produce the same number of grayscale levels in 
printed halftones.

• Angle: If you want to specify the angle of the screens used for 
halftoning, rather than use the printer’s default setting, deselect the 
Use printer default checkbox, and enter the angle in the Angle 
checkbox.
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Printer Options

• PS L2 (Faster printing of text): Allows you to send a block of 
text to the printer for faster printing of text. If disabled, text is sent 
character by character.

• Screen enhancement feature for true halftones: This option, 
when enabled, always prints halftones at the highest possible LPI. If 
disabled, a halftone is printed at the printer’s resolution.

Document bleed size By default, the bleed size is set to 9 pt (1/8 in). 
Enter a new value in the text field.

Registration Marks
Define the appearance of the registration marks. By default, the fill 
is white and the size is 72 pts (see “Making manual registration 
marks,” page 18.16). 

Measurements
The Measurements settings let you control as well as define the unit 
of measure that is used in the rulers and drawing scale. The Grid 
manager is also located in the Measurements settings section. 

Dash 
If you are applying dashed pen stroke to objects, you can define 
how dashes are handled if an object has corners.

Preserve Corners Select this option to keep the corners intact; i.e., 
dashes will not be applied to the corners of objects.

Continue with Dash Select this option to apply dashes to the cor-
ners of objects.

Define Units
You can further customize the rulers by adding units of measure-
ments, modifying the definitions of existing ones, or deleting them 
(see “Setting up rulers and the drawing scale,” page 11.7).

Note: The Add unit feature is a document-based function; i.e., any 
units that you add pertain to that particular document and will not 
be available when you open another document.
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Grids
Use these settings to create an alignment grid (see “Using the align-
ment grid,” page 11.11).

• Line distance X: This is the distance from one vertical grid 
line to another. 

• Line distance Y: This is the distance from one horizontal grid 
line to another.

• Snap Factor X: This value sets the snap points along the hori-
zontal lines of the grid.

• Snap Factor Y: This value sets the snap points along the verti-
cal lines of the grid. 

• Snap to X/Snap to Y: Select one or both options to make objects 
snap to the snap points on both sets of grid lines.

Ruler
The Ruler manager lets you choose measurement settings, such as 
document units, document scale, numerical format. If you’re accus-
tomed to creating large illustrations, such as billboards or 2-D archi-
tectural drawings, Canvas gives you the freedom to create a 
document in its actual size and draw in real-world units. You no 
longer have to create an illustration in terms of “page distance” (see 
“Defining a drawing scale,” page 13.20).

Select a unit of measurement from the menu (A). This unit is dis-
played in the rulers, Object Specs palette, as well as Properties 
bar.

Define the drawing scale in the Document scale section (B), if nec-
essary. You can use the Pre-defined scales or establish a custom 
scale.

Choose the formats (C) for the numbers, angles, and coordinates. 
For the number format, you can choose from no decimals to six 
decimals, or even use fractions (see “Floating point technology,” 
page 20.2).
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Color management
Canvas uses the Kodak Digital Science Color Management System 
or its own internal color management system to achieve accurate 
color reproduction in printing and display. The active color man-
agement system handles conversions from one color mode to 
another.

The Kodak Color Management System supports ICC (Interna-
tional Color Consortium) profiles. Use ICC profiles to calibrate 
monitors and output devices.

File installation and placement
During installation, several files that are required to use the Kodak 
Color Management System are copied to the system. After installa-
tion, do not move, rename, or delete these files; otherwise, the 
Kodak external tool won’t load.

Mac OS X
Installation places the generic ICC profiles in the ColorSync pro-
files folder (/System/Library/ColorSync/Profiles). By default, Can-
vas installs Kodak’s generic ICC profiles only.

Windows
Installation places various.DLL files throughout the system. It also 
creates a KPCMS folder at the root level of the hard disk if one 
doesn’t exist already. 

On Windows 2000, ME, and XP, Kodak ICC profiles are stored in 
the Color Profiles folder in the Canvas folder. By default, Canvas 
installs Kodak’s generic ICC profiles only.

Defining a drawing scale

The Document scale section has sev-
eral options in the Pre-defined scales 
menu. You can also select Custom 
from the menu and then define your 
scale with the “Page distance = world 
distance” controls. 

If you select “1:1” as the scale, you are 
actually drawing in real-world units; 
i.e., you aren’t drawing “to scale”. 

You can also establish a drawing scale 
by using the Set Document Scale 
command (see “Using Set Document 
Scale command,” page 11.8).

Tip
To install additional ICC profiles, 
refer to your system documenta-
tion.
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Kodak ICC profiles
ICC profiles are used for color management by Canvas and other 
programs. Canvas installs Kodak ICC profiles that are appropriate 
for most monitors and color printers.

To download ICC profiles from the Deneba site
1 Go to www.deneba.com.

2 Click the Downloads link on the navigation bar.

3 On the Downloads page, click the ICC Profiles in the Canvas 
Add-on Files section.

4 Select the Mac or Windows folder, then click profile_index. 
This displays a list of all available ICC profiles. 

5 Scroll through the list (both Mac and Windows devices are 
listed) to find your device name. The profile file name appears 
first on the line for each device. 

6 To download the file, click Back in your browser. Open the 
appropriate device folder and click a file name to download the 
ICC profile file.

To change color settings within Canvas 
1 To change the color management settings, choose Edit > Cal-
ibration > Color Settings. The Configuration Center opens with 
the Color Calibration manager selected. 

2 In the Color Calibration manager, select profiles and other 
options (see “Color Settings options” on page 13.22)

Tip
You can obtain additional ICC pro-
files for specialized devices, such 
as film writers, graphics arts moni-
tors, and prepress proofing devic-
es from the device’s manufacturer.

Color Settings
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3 Click OK to implement the settings.

Color management tips
If you require the highest quality color matching and output, 
becoming familiar with the factors that can cause problematic color 
shifts can help you to avoid unexpected results.

In general, the Kodak color management system handles conver-
sion between color systems, such as RGB and CMYK. The system 
makes the conversion as accurate as possible, taking into account 
the characteristics of the color display and color printing devices. 

If you want to prevent even slight changes in color values, avoid 
conversion from one color system to another. When you paint in an 
image, use the color system that matches the image mode; e.g., use 
RGB colors for RGB Color mode, and CMYK colors for CMYK 
Color mode.

Color Settings options Use

RGB Selects the ICC profile for conversion to and from RGB color space.

CMYK Selects the ICC profile for conversion to and from CMKY color space.

Lab Selects the ICC profile for conversion to and from LAB color space.

Monitor Select a monitor ICC profile that matches your monitor, or use the default profile. To change 
the profile, choose Other. A directory dialog box with two panes appears. In the upper pane, 
available ICC profiles appear. Select a profile; click Open.

Printer Select an ICC profile for your printer or use the default profile. To change the profile, choose 
Other. A directory dialog box with two panes appears. In the upper pane, available ICC profiles 
appear. Select a profile; click Open.

Engine Choose the Kodak Digital Science CMS or the internal Canvas color management system.

Intent Choose a rendering intent:

• Perceptual (Images) maintains relative color values as the values are mapped to the printer 
gamut. This method preserves the relationship among colors, though color values can change.

• Saturation (Graphics) maintains relative saturation values of colors. Colors that are outside 
the printer gamut are converted to the closest colors with the same saturation that are inside 
the printer gamut.

• Relative Colorimetric leaves colors that fall inside the gamut unchanged. This method usu-
ally converts out-of-gamut colors to colors that have the same lightness but fall just inside the 
gamut.

• Absolute Colorimetric disables white-point matching when converting colors. This option is 
not generally recommended.

Simulate print colors on display Select to simulate on the monitor the appearance of the CMYK colors that will be printed.
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If you paint a CMYK color into an RGB Color mode image, Can-
vas converts the CMYK color values to RGB values. When color 
calibration is active, the color management system uses the specifi-
cations of the selected ICC profiles in the conversion process.

Avoid using RGB color in a document that will be printed commer-
cially using process (CMYK) colors. When you specify process col-
ors, it’s best to use a matching system (“Color systems” on 
page 15.7). 

For more information about working with colors and color print-
ing, refer to the Canvas Color Printing Guide.

Preferences for two-byte text entry
The options for the Inline preferences let you specify whether you 
want to always enter two-byte text directly into a document, or use a 
text-entry window when the apparent type size is outside a range 
that you have set. This feature is available only when you are run-
ning system software that supports two-byte fonts, and are using 
two-byte fonts to enter text into a document. This preference does 
not affect printing.

Using a low zoom level can make it difficult to see text as you type. 
By using the text-entry window, you can see and edit text in the win-
dow, regardless of the current view magnification level. 

To set inline text-entry preferences
1 Choose Canvas > Configuration Center (Mac) or File > Con-
figuration Center (Windows). The Configuration Center appears.

2 Open the Inline manager within Text settings.

3 Specify the following options, and then click OK to imple-
ment the current settings:

• If you always want to use a text-entry window, regardless 
of the size of the type, select the Never option.

• If you want a text entry window to appear when you type 
text at some apparent type sizes, select the “For text from” 
option. Type a number from 6 and 255 in each text box. 
These numbers set the range in which the text-entry win-
dow does not appear and you type directly into a docu-
ment. 

A character’s apparent size is the size at which it appears on screen, 
based on the current view magnification level; e.g., 12 point type 

Tip
You must use a printed swatch-
book to view the printed appear-
ance of a color. You should never 
rely entirely on the appearance of 
a color on screen.

Tip
You must first enable two-byte 
script in the Type manager.
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appears to be 12 points at 100%; at 200%, it appears to be 24 points; 
at 50%, it appears to be the size of 6 point type.

Using the text-entry window
If you choose the “For text from” option and type text in a docu-
ment at an apparent point size that is outside the specified range, 
the text-entry window appears at the bottom of the screen. You can 
type and edit text directly in the window. To enter the text into the 
current document, press Return (Mac) or Enter (Windows).

If the apparent size of text changes because you change the view 
magnification, actual point sizes that are beyond the specified “For 
text from” range might not cause the text-entry window to open. In 
this case, you can type the text directly into the document. 

Customizing the keyboard and Toolbar
Via the Customize dialog box, you can assign keyboard shortcuts to 
commands, tools, attributes, object styles, and font styles. You can 
also place buttons for these items on the Toolbar. 

Customize dialog box
Choose Canvas > Customize (Mac) or File > Customize (Windows). 
In the Customize dialog box, choose items to customize (see 
“Choosing a category to customize,” page 13.25).
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Choosing a category to customize
You can choose items to which you want to assign shortcuts or add 
to the Toolbar. The following items are available in the Category 
menu. 

Customize dialog box

Use the options in the Customize dia-
log box to select items, and then cre-
ate keyboard shortcuts and place but-
tons on the Toolbar.

Category. Choose the category of 
items to customize. The contents of 
the scrolling list change according to 
the selected category.

Sub-Category. Only active if Menus is 
selected in the Category menu. The 
commands in the selected menu 
appear in the scrolling list.

Scrolling list. Displays all tools or 
styles in the selected category or sub-
category (for menus). For inks and 
strokes, the list contains the inks or 
strokes you select from the pop-up 
palettes. Select an item in the scrolling 
list to assign a shortcut to it or to place 
a button for it on the Toolbar. The 
selected item is highlighted. 

Current Shortcut Key. Displays the 
current keyboard shortcut for the 
selected item, if a shortcut exists.

Press New Shortcut Key. With an item 
selected in the scrolling list, press the 
keyboard keys you want to assign to 
the item. To use a modifier key, press 
and hold Shift, Ctrl, Option, or Com-
mand (Mac), or Shift, Ctrl, or Alt (Win-
dows). Press a letter, number, or func-
tion key. The new shortcut keys 
appear in the box.

Menu icon. Click Modify to open the 
Modify icon dialog box and customize 
the menu bar icons. Click Restore to 
return the icons to their default 
appearance.

Assign. Click to assign the keystrokes 
in the Press New Shortcut Key box to 
the selected item. 

Remove. Click to remove the current 
shortcut keystrokes from the selected 
item.

Reset All. Click to restore the default 
shortcut keys to all items.

Reset. Click to restore the default 
shortcut keys to the item selected in 
the scrolling list.

Palettes. A pop-up palette appears 
when the Category selection is Inks; 
three palettes appear when the Cate-
gory is Strokes. Select an ink or stroke 
from the palette. The selected item 
appears in the scrolling list and on the 
Toolbar. 

Remove Selection. When the Catego-
ry selection is Inks, Strokes, Object 
Styles, or Font Names and Sizes, click 
the Remove Selection button to 
remove a selected item from the 
scrolling list. This also removes a but-
ton for the item from the Toolbar. 

Save Set. After you customize Canvas, 
you can save the current configuration 
in a file. You can create other custom 

configurations and save these in con-
figuration files. A configuration file 
stores all the current keyboard short-
cut assignments and the setup of but-
tons on the Toolbar.

Click Save Set to create a file of all 
current shortcut keys and Toolbar but-
tons. In the directory dialog box, type a 
name for the file and click Save.

Load Set. Click Load Set to import a 
file of shortcut keys and Toolbar but-
tons. In the directory dialog box, select 
the file to load and click OK. Canvas 
resets the shortcut keys and the Tool-
bar according to the configuration 
stored in the file.

Clear All. Click Clear All to clear all of 
the customized settings in the scroll-
ing list and all buttons on the Toolbar.

Close. Click to close the Customize 
dialog box. Inks or strokes added to 
the scrolling list remain in the list 
when you close the dialog box.

Scrolling list
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Menus If you select this item, you must choose one of the follow-
ing menus from the Sub-Category menu: File, Edit, Text, Object, 
Layout, Effects, Image, and Window.

Tools The names of the tools and their icons appear in the scroll-
ing list. Their respective keyboard shortcuts are also indicated in 
the Current Shortcut Key field.

Inks / Strokes Next to the scrolling list, a pop-up palette displays 
preset inks, or three pop-up palettes display pen strokes, dashes, 
and arrows. Select an ink or stroke from a palette. The item you 
select appears in the scrolling list and as a button on the Toolbar.

• To remove an ink or stroke from the scrolling list: Select it and 
click Remove Selection; if the item is on the Toolbar, this removes 
it from the Toolbar also.

Attribute Styles The names of attribute styles appear in a menu 
below the scrolling list. If no attribute styles have been created in 
Canvas, the menu will be empty (see “Creating attribute styles,” 
page 17.39).

Font Names & Sizes A font size box appears. Select a size and then 
press the Add Size button. The font size appears in the main scroll-
ing list, and a font size button appears on the Toolbar. 

• To choose a font: Select a name from the menu. The font 
appears on the scrolling list, and a font button appears on the Tool-
bar.

To customize keyboard shortcuts
1 Select an item in the scrolling list in the Customize dialog 
box. If the item has a keyboard shortcut, the Current Shortcut 
Key box shows the shortcut keys. 

2 To assign a keyboard shortcut, press the keyboard keys you 
want to use. The keys you type appear in the Press New Shortcut 
Key box. Click Assign to assign the new keys to the item. 

If the keys you type are assigned to another shortcut, the message 
Currently assigned to: appears beneath the Press New Shortcut Key 
box.

Note: Certain keys are restricted, so pressing them will not display 
their values. Other shortcuts are reserved by Canvas, so they can be 
assigned, but not applied to some procedures; e.g., Ctrl+1, Ctrl+2, 
and Ctrl+3 cannot be used in painting.

Modify icon dialog box
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You can’t assign single keys as shortcuts; e.g., you can’t assign “H” 
or “F7” to an item.

• To remove shortcut keys from the selected item: Click Remove.

• To restore the default shortcut keys to all commands: Click 
Reset All.

• To restore the default shortcut keys to one command: Select the 
command in the scrolling list and click Reset. 

To assign shortcuts to inks
Create shortcut keys for specific fill inks and pen inks. 

• To assign a shortcut key to a fill or pen ink: Select the ink in the 
scrolling list in the Customize dialog box. 

1 Type the keyboard keys you want to use. The keys you type 
appear in the Press New Shortcut Key box. 

2 Under the box, select whether you want the ink to be a Fill or 
Pen ink. 

3 Click Assign to assign the new keys to the ink.

To place buttons on the Toolbar
Select an item in the scrolling list. Inks, Strokes, Object Styles, and 
Fonts appear on the Toolbar automatically when you add them to 
the scrolling list. For Menus and Tools, double-click the item in the 
scrolling list to add it to the Toolbar. A button for the selected item 
appears on the Toolbar when it is displayed.

• To remove an Ink, Stroke, Object Style, or Font button: Click the 
Remove Selection button under the scrolling list, or double-click 
the item in the scrolling list. 

• To remove a Menu or Tools button: Double-click the item in the 
scrolling list.

To arrange buttons on the Toolbar
After you place buttons on the Toolbar, you can change their posi-
tion directly on the Toolbar. 

• To move a button: Shift-drag the button to a new location. 

• To remove a button from the Toolbar: Shift-drag the button 
away from the Toolbar.

Toolbar buttons
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• To add a separator between Toolbar buttons: Shift-drag the but-
ton on the right slightly to the right. A separator line appears 
between the button and the one to its left.

Using ink buttons
When you place buttons for inks on the Toolbar, use the buttons to 
apply fill and pen inks or foreground and background colors.

You can apply fill and pen inks to vector objects and text as well as 
select foreground and background colors for painting.

• To apply a fill ink or select a background color for painting: Click 
the ink button on the Toolbar. If no objects are selected, the ink 
becomes the current fill ink or background color.

• To apply a pen ink or select a foreground color for painting: Press 
Option (Mac) or Ctrl (Windows) and click the ink button. If no 
objects are selected, the ink becomes the current pen ink or fore-
ground color.

Saving document templates
You can use a special kind of Canvas document, called a template, 
as the basis for new documents. Canvas includes many ready-made 
templates, and you can create your own template documents. 
Then, when you use the New command, you can select a template 
— either one supplied with Canvas or one you have created — to cre-
ate a new document based on the contents and configuration of the 
template.

A template document stores almost all preferences settings, as well 
as the settings you specify with the Document Setup command, and 
other document setup options, including the following:

• Document type

• Configuration of layers, slides, pages, sheets and frames

• Settings for rulers, grids, guides, and views

• Current inks and strokes settings

• Text styles and default text settings
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Canvas stores some settings with the application and not in particu-
lar documents, so these settings are not included in a template doc-
ument. The settings that aren’t stored in a template include the 
position of palettes on the screen and the current set of external 
tools. 

To save a template document 
1 Choose File > New to create a new Illustration, Presentation, 
Animation, or Publication document.

2 Choose Layout > Document Setup to select measurement 
units, document size and orientation, and, for Publications, the 
margins and column layout.

3 Choose Canvas > Configuration Center to set up preferences 
for the document.

4 Create or import objects that you want to store in the tem-
plate.

5 Choose File > Save As. In the File Format (Mac) or Save as 
type (Windows) menu, select Canvas Template and click Save.

For more information, see “Saving Canvas documents” on 
page 9.5.

Tip
If you create a template with a 
small amount of type, such as for a 
letterhead, convert the type to 
paths so the template can be used 
without particular fonts being 
available.
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CHAPTER

14
FILE & DATA EXCHANGE

Canvas supports many standard formats for exchanging files and 
data with other programs. This chapter explains how to use non-
Canvas file formats, including Web image formats. It includes 
information on exchanging files on the Internet and Object Link-
ing and Embedding.

Exchanging files
Canvas lets you work with many file formats. With a common file 
format, you can bring a file generated in another program into a 
Canvas document, or transfer a Canvas document into another pro-
gram. 

Since the native Canvas format (.CVX) saves all the objects, proper-
ties, and effects that your documents can contain, you should save 
all your documents in this format. Still, you might want to export a 
document in a different format, or import graphics into a Canvas 
document.

When you use a non-Canvas file, you can avoid problems such as 
lost information and printing errors if you know the capabilities 
and limitations of the file format; e.g., some formats support only 
one type of data (vector, raster, or text), while others support multi-
ple types. Image formats support certain image modes.

Importing files
Use the Open, Place, and Place Image commands to import files. 
Choose the format you want to use in the format menus in the 
Open and Place dialog boxes. To import image files, you can also 
use the Image > Import command (see “Importing images” on 
page 14.4).
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To open or place a file
1 Choose File > Open or File > Place or Place Image.

• Open creates a new Canvas document containing the file 
you select.

• Place or Place Image inserts the file in the current Canvas 
document. Place and Place Image are available only if a 
Canvas document is open.

2 Choose a file type in the Show (Mac) or Files of Type (Win-
dows) menu. The file list shows files that match the selected for-
mat. 

• Select All Files (Windows) or All Documents (Mac) to 
show every file in the folder. You can choose All Docu-
ments in the Show menu (Mac) to show all files that Can-
vas can open.

3 In the file list, select a file and click Open or Place. You can 
also double-click a file name. For some file formats, a dialog box 
presents options for opening files. Configure the options and click 
Open or Place.

• If you open the file, Canvas creates a new document.

• If you are placing the file, a Place pointer appears. Click 
where you want to place the top-left corner of the file.

Saving files in other formats
You can use the Save As command to export files in a variety of file 
formats. However, be aware that most file formats do not support 
every Canvas object or effect. For this reason, Canvas asks if you 
are sure when you select other file formats for saving files.

For example, a TIFF file can save only a single raster image; it does 
not support text or vector objects. If you save a Canvas document 
containing vector objects or text in TIFF format, all the objects in 
the document are changed into an image. If you then open the 
TIFF file, its contents appear as one raster image, so you can’t edit 
the original text or reshape the vector objects.

When you save a document in a non-Canvas format, Canvas cre-
ates a new file on disk, but does not close the document or change 
the name of the document in the title bar. If you then try to close 

The Open dialog box provides you 
with a bitmap preview when you 
select certain supported formats.

When selecting any Canvas file, you’ll 
see some file properties beneath the 
bitmap preview.
.2 FILE & DATA EXCHANGE



the Canvas document (without saving it in Canvas format), a mes-
sage asks you to confirm that you want to close the document with-
out saving it.

To save a file
1 Depending on what you want to save, do one of the following:

• To save specific objects, select the objects.

• To save specific layers of a multi-layer document, make 
sure the layers you want to save are visible.

2 Choose File > Save As. A directory dialog box appears. 

3 Select a file format in the menu labeled Format (Mac) or Save 
as type (Windows). If a format or option is not available, be sure it 
is compatible with the document contents.

• On Windows, a message asks you to confirm that you want 
to save in a format other than Canvas. Click Yes to con-
tinue. On Mac OS, this message appears after you click 
Save. Click Save in the message box to continue.

4 Select the Save Entire Document, Save Selection, or Save 
Layers option at the bottom of the dialog box to specify what to 
save. Some options that are available when you save in Canvas 
format are not available when you select other file formats.

5 Type a name for the file, select a location, and click Save. 

If options are available when saving in the selected file format, a 
dialog box appears. Configure the options as you wish and click 
OK. For information on file options, see the sections on specific for-
mats in this chapter.

Rendering images
When you are saving objects and select a file format that supports 
images only, Canvas renders the document or selected objects. Ren-
dering creates an image that can be saved in the selected format. 

The Render Image dialog box has options for rendering (see “Ren-
dering objects and images” on page 23.23 for more information).

Tip
Always save your work as a Can-
vas document, so you can edit 
your work later in Canvas if neces-
sary.
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Importing and exporting images 
Choose Image > Import or Image > Export to work with raster 
image files. These commands are especially useful because you can 
add new file formats by installing Photoshop-compatible plug-in 
modules.

Exporting images
When you use an Export command, you create a file on disk from a 
single selected paint object. Using Export is similar to using Save 
As, except that you must select a paint object before you choose 
Export. 

To export an image
1 Select the paint object to export. Be sure the paint object is 
not in edit mode.

2 Choose Image > Export > file format, where file format is the 
name of a file format in the Export menu.

3 In the directory dialog box, type a file name, select a location 
for the exported file, and then click Save.

If the image mode of the selected paint object is not supported by 
the chosen format, the Render Image dialog box appears. In the 
dialog box, select an image format supported by the file format. If 
an image mode is not available in the Mode menu, the selected file 
format does not support that mode (see “Rendering objects and 
images” on page 23.23 for more information).

Importing images
Choose Image > Import to import images from files on disk. You 
can also acquire images from scanners and digital cameras using 
the TWAIN interface or acquire plug-in modules.

Importing an image places it in the current document as a paint 
object. In most cases, Canvas stacks imported images at the center 
of the current view. 

Note: The Open and Place Image commands work with image files 
also. The Open command opens a file as a new document. The 
Place Image command places a file in the current document. These 
commands will not import an image file as a proxy or import multi-
ple images at once.

Tip
Export is not available if a paint 
object is not selected.
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To acquire one or more image files
1 Choose Image > Import. The Select files to acquire dialog 
box opens. 

2 Select the file format to import. 

3 Navigate to the folder that contains the files. Files that match 
the format you selected will appear in the files list.

4 Select one or more files to import. You can Shift-click to 
select multiple files in the list, and then click Open to import all 
the selected files. Or, you can add files from one or more folders 
to the selected files list, and then click Done to open them.

To acquire an image from a TWAIN device
1 Choose Image > Acquire Plug-ins> TWAIN Acquire.

2 A dialog box appears. Refer to the documentation for the 
device or acquire module for information on options and settings.

Importing images as proxies
You can use the Acquire as Proxy option to import a low-resolution 
proxy, rather than a high-resolution image, from an image file. The 
proxy image will be linked to the original image file.

The Acquire as Proxy option appears in the directory dialog box 
when you import TIFF, JPEG, and CVI files. 

Select the Acquire as Proxy option to place a proxy of the selected 
image file in the document. The proxy image will be linked to the 
image file. By default, the option is selected for the CVI file format 
(see “Image proxies” on page 28.1).

File formats
When you use other file formats that Canvas supports, you can 
select options when you open, place, place image, import, save, or 
export some types of files. The most common file formats and their 
options are described in this section. 

For more information on using file formats, refer to the “Read Me” 
file. New information that is not in the printed or online documen-
tation will be provided in the “Read Me” file distributed with the 
Canvas software.

Tip
Mac users should refer to the Can-
vas “ReadMe” file for Macintosh 
availability.
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Opening PDF files
When opening PDF files, you can select your import options in the 
PDF & PS Import dialog box. 

Default ColorSpace Select RGB or CMYK.

Embedded fonts Select either Substitute or Convert to paths.

Vector precision Select from one to three decimal points for preci-
sion.

• To save the settings as default: Select the Save these settings as 
default checkbox.

Click Default to obtain the default settings.

Saving in PDF format
When saving in PDF - Acrobat® format, you can select screen or 
printer resolution for images saved in the file. Select your export 
options in the PDF Options dialog box that appears before the file 
is saved (see “Exporting as PDF,” page 36.30).

Screen saves images at a maximum 72 pixels per inch (ppi). If nec-
essary, images are downsampled to 72 ppi.

Printer saves images at a maximum 300 ppi. If necessary, images 
are downsampled to 300 ppi. An image’s resolution is not increased 
if it is less than 300 ppi.

Saving in Illustrator format
You can also save files in an Adobe® Illustrator® format by choos-
ing File > Save As and then selecting AI - Adobe Illustrator. The AI 
Export Options dialog box opens as follows.
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Saving CGM files
Computer Graphics Metafile (CGM) format is a standard for 
exchanging 2-D graphics and text. Variations and extensions to the 
“standard” format can create incompatibilities with the Canvas file 
filter. When you save a Canvas document in CGM format, Canvas 
makes the following image color mode conversions:

CGM*PIP Import Filter (Optional for Windows)
The CGM*PIP (Petroleum Industry Profile) Import filter has 
received acclaim from scientists in the petroleum field for its ability 
to successfully work with files from UNIX-based seismic interpreta-
tion applications in a Windows desktop environment.

Canvas image mode CGM image mode

CMYK, Duotone, Grayscale, and 
LAB color 

RGB cell arrays

Black & White CGM versions 1 and 2: RGB cell arrays

CGM version 3: Black & White

Multichannel First channel becomes an RGB cell array; 
other channels ignored

AI Export Options dialog box
A Illustrator Version. Choose the ver-
sion of Illustrator in which you wish to 
save the file.

Object attributes
B Ignore Transparency. If your Can-
vas file contains objects with SpriteLay-
er transparencies, then you will need to 
check this option. If this feature is not 
activated, then all of the objects that 
contain transparency effects (in your 
Canvas file) will be converted into imag-
es. Therefore, you will not be able to 
edit these objects after exporting except 
as bitmapped images.
C Basic Stroke Only. The editing 
tools in Illustrator may not recognize a 
texture, hatch, or gradients for a stroke 
which you have created in your Canvas 

file. Therefore, you may wish to activate 
this option if you excpect to use some of 
the more specialized tools in Illustrator 
after exporting the file. When activated, 
this feature will automatically remove all 
complex strokes from a Canvas file dur-
ing export.
D Resolution. Choose from 72 to 
600 DPI.
E Preview. A document can be saved 
with or without a preview image. The 
choice of “None” can save in the result-
ing file size; however, if “TIFF” is cho-
sen, then open dialog boxes that sup-
port Adobe Illustrator files can display a 
TIFF preview of your Adobe Illustrator 
file.
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The tool was created in response to a specific oil industry need. 
Geologists and earth scientists often have to use seismic files in 
their studies and various reports. The most popular seismic inter-
pretation applications are UNIX-based ones such as Landmark, 
GeoQuest, and Charisma, which all use the standard CGM*PIP 
file format. The CGM*PIP Import filter permits files from these 
UNIX-based seismic interpretation applications to be imported into 
Canvas. Since UNIX-based seismic interpretation applications are 
routinely used in the petroleum industry, earth scientists and data 
specialists around the world quickly embraced the Canvas 
CGM*PIP filter as an invaluable tool. The technology allows for 
significant increases in company productivity and workflow.

The CGM*PIP Import filter is available to regular users who wish 
to upgrade to a “Petroleum Industry” version of Canvas. Contact 
Deneba’s sales department (sales@deneba.com) for pricing and 
availability.

CGM*PIP Import Options
The CGM import data is located at the top of the dialog box.

Note: When importing any CGM file, the CGM*PIP Import 
Options dialog box appears because it overrides the standard CGM 
import filter.

When importing Seismic files directly into Canvas, certain options 
are presented that have an effect of how the filter reads raw data.

PIP Options
Resolution All CGM PIP seismic data are rendered to a bitmap. 
The resolution option specifies the resolution with which the bit-
map is created.

Higher resolution yields more detail to the curves but the file will 
take more time to load.

Transparent Some curves are imported as separate images, 
depending on certain settings in the CGM PIP file. Images cannot 
be seen when they overlap each other. To prevent hidden images, 
check the transparency box when the file is imported. If this box is 
left unchecked, the image will remain opaque. 

Clip Only If Necessary This option eliminates clipping rectangles if 
they do not clip any of the objects assigned to them. Those objects 
are contained entirely within the clipping area and checking this 

CGM 
import 
data

PIP 
Options
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option will allow Canvas to redraw much faster; however, if any 
object stripped of the clipping rectangles is moved outside that 
area, they will not be clipped because the clipping rectangle has 
been removed when setting this option. Be careful with this option 
if you want to move objects in the document.

Interpolation

1 Background: This determines the way the colors of the back-
ground are painted. The following options are available: 

• No Background : Color interpolation for background fill for 
trace groups. Files are imported with the exact spacing of data

• Default: Defined in PIP file

• Always Off: No color interpolation

• Always 1D: Displays the background in baseline direction only

• Always 2D: Displays the lines in biaxial interpolation

2 Wiggle: This option sets the way that Canvas displays the line 
segments, determines the way points are joined together, and fits 
a curve to discrete points as defined by the PIP file. Supported res-
ampling methods are as follows:

• Default: Defined in PIP file

• Linear: Linear interpolation in which adjacent sample points 
are joined by straight lines.  This will display the smoothest connec-
tion between segments.

• Replicate: Repeats the value between samples and displays 
true non-curved lines between segments.

Using AutoCAD DWG format
The AutoCAD DWG import filter lets you import native 
AutoCAD (r14) files into Canvas. This filter fits an AutoCAD draw-
ing to a document size of 8.5 by 11 inches. To use this filter, choose 
File > Open or File > Place and select AutoCAD DWG format in 
the directory dialog box.

Using Drawing Interchange Format (DXF)
Drawing Interchange Format (DXF) is a format developed by 
Autodesk, Inc., for exchanging data with AutoCAD and other 
drawing applications. DXF format provides platform-independent 
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storage of 2D and 3D technical drawings and supports multiple lay-
ers. Canvas supports DXF files containing ASCII data, but does 
not support DXF files that contain data in binary format. 

To save as DXF file
When you save a document in DXF format, Canvas converts the 
following Canvas objects and attributes to DXF objects and 
attributes:

In the DXF export options dialog box, select the platform format to 
use. You can also select options for exporting lines and circles.

To open DXF files
The DXF import filter fits a DXF file to a document size of 8.5 by 
11 inches.

When opening a DXF file, Canvas makes the following conversions 
from DXF objects to Canvas objects: 

Canvas objects / attributes DXF objects / attributes

Paint object Not converted

Pen and fill patterns Solid pens are exported; fills are not 
exported 

Arcs Polylines

Calligraphic pen strokes Fixed-width pen strokes

Continuous dashes Dashes start in each segment

Layer names with spaces or non-upper-
case characters

Spaces removed and characters become 
uppercase

Grayed layers Objects appear in original colors

DXF objects Canvas objects

Blocks Groups

Traces, Solids, and Quadratic polylines Polygons

B-spline Polylines Bézier curve paths

ATTDEF and ATTRIB Text objects
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Canvas doesn’t support 3D objects (3D lines and 3D Face objects in 
DXF files), so these objects are not imported into Canvas.

Using Encapsulated PostScript (EPS)
Encapsulated PostScript (EPS) is a file format used to save individ-
ual PostScript graphics.

To open EPS files
When you open or place an EPS file, a dialog box asks you to 
choose an import method. Choose an option and click OK.

Create EPSF Object Imports the EPS file as an EPS object. This 
object can be rotated or scaled, but you can’t select or edit parts of 
the graphic. Canvas displays a preview image if the file contains a 
preview in a supported format.

Create Canvas Objects Interprets the EPS file’s PostScript code to 
convert the EPS graphic to editable Canvas objects. Raster images 
become Canvas paint objects and vector objects are maintained as 
vector objects. Text is imported as one or more text objects. The 
EPS preview image is not imported. Specialized objects and 
attributes that have no Canvas equivalent might not be imported.

Place EPSF Reference Inserts a link to the EPS file and displays its 
preview image in the Canvas document. This option is useful for 
keeping the size of the Canvas file smaller than if EPS files are 
imported directly into the document. If you use this option, the 
EPS file must be available when you print the Canvas document. If 
the EPS file changes, the Canvas document is updated when you 
print it.

Saving as EPS
To save a file in EPS format, choose File > Save As. In the directory 
dialog box, select EPSF format. Select options in the dialog box 
that appears (described next) and click OK to save the file.

When you save a Canvas document in EPS format, you could lose 
specialized objects and attributes that are not supported in EPS. 
Canvas transparency effects are rendered and stored as images in 
EPS graphics, using the Transparency Rendering option and reso-
lution that you select.
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EPSF Type Choose EPS to create a composite (non-separated) EPS 
file. Choose DCS Version 2 to create a single, pre-separated EPS file 
in DCS version 2.0 format. You can use a DCS file to output color 
separations from programs that support this format.

Current Page Saves the current page, slide, sheet, or frame only. 
To save a range of pages, enter the starting and ending page num-
bers in the From and To boxes.

Preview Select a format to store a preview image in the EPS file. 
Canvas and other programs that support EPS previews will display 
the preview when the EPS file is placed in a document. The image 
format and color mode you select are applied to the preview image 
only.

• Windows: Choose None for no preview, or choose a color 
mode to save a preview image. Preview images are saved in TIFF 
format. A preview will not appear in programs that support only 
WMF or EMF previews.

• Mac OS: Choose None for no preview. Choose a color mode to 
save a preview in TIFF format. Or, choose a PICT option to save a 
preview in PICT format. Use PICT in EPS files for import into 
Word 98 on Mac OS, or any program that doesn’t support TIFF 
previews.

Use Compression Select this option to compress TIFF preview 
images. Some programs can display only non-compressed TIFF 
previews. If TIFF preview images do not appear correctly, try dese-
lecting this option.

Image Compression Select a format for storing raster image data. 
Binary is the most compact non-compressed format. ASCII encodes 
raster data as text, the least compact format. Level 2 ASCII is some-
what more compact than ASCII format. RLE compresses binary 
data and makes the most compact EPS files. To save EPS files for 
Photoshop or Illustrator, use Binary format.

Color Mode for EPS format Select a color mode to apply to colors 
in the EPS file. The available modes correspond to RGB, CMYK, 
Grayscale, and Black & White modes for paint objects. 

• Colors created with RGB, HSL, CMYK, or grayscale val-
ues will be converted to the selected mode in the EPS file. 

• Spot colors defined in Canvas with the Spot Color option 
in the Color manager or a spot color library will be saved 
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in the EPS file as spot colors, and also with color values in 
the selected mode.

If you print color separations from an EPS file in another program, 
you can usually output process and spot color plates, or just process 
color plates, depending on whether you specify spot and process 
separations or process-only separations.

Color Mode for DCS format Select a color mode for the separations 
stored in the EPS file: 

• Select CMYK to separate all colors, including spot colors, 
as process (CMYK) colors. 

• Select CMYK + Spot to separate all colors, except spot col-
ors, as process (CMYK) colors. Spot colors will not be con-
verted to process and will be separated as spot colors.

When you use DCS Format and print color separations, the pro-
gram you use simply outputs the color separation plates as defined 
in the DCS file; it does not apply its separation method or options 
to colors in the file. Therefore, if you want to be able to output pro-
cess and spot color plates, you should select CMYK + Spot Color 
Mode when you use DCS Format to save illustrations in EPS files.

Transparency Rendering Select a method for SpriteLayer and Spri-
teEffects rendering into EPS format. These options are similar to 
the rendering options that are available when you print a docu-
ment.

• To render effects: Choose Smallest Area, Complete Area, or 
Entire Document. 

Smallest Area results in rendering the minimum area necessary to 
show transparency and SpriteEffects. Complete Area renders the 
minimum area, plus any object that touches the rendered area. 
This setting can prevent a slight color shift between rendered and 
non-rendered areas within an object. Entire Document renders 
everything in the document (or selection) as an image to be saved in 
the EPS file.

If you choose Don’t Render Transparent Objects, transparency and 
SpriteEffects won’t be rendered.

Rendering Resolution Select a resolution for rendering effects. In 
general, you should specify a resolution based on the publication 
requirements for images.
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Embed Fonts (Windows only) Select this option to embed fonts in 
the file, so text can appear as intended if the required fonts aren’t 
available.

Use Page Dimensions Select this option to save the full area of the 
document page, sheet, slide, or frame in the EPS file. If this option 
is not selected, the EPS graphic will be only as large as the saved 
objects.

Converting EPS objects
After you import an EPS file, choose options from the context 
menu to convert the object or view information about it. 

You can view linking information if the file was imported as an 
EPSF reference. If the file was imported as an EPSF object, you can 
convert it to an EPSF reference. If it was imported as an EPSF 
object, you can create Canvas objects from it.

• To use EPSF Object commands: Select the EPS graphic and 
Ctrl+click (Mac) or right-click (Windows). In the context menu, 
choose one of the options described below.

Convert EPSF into Canvas Objects If you choose to create Canvas 
objects from an EPSF object, the EPSF object is replaced in the 
document by equivalent Canvas objects. Depending on the con-
tents of the original EPS file, you might not be able to edit some 
objects as you expect after the conversion. For example, you would 
not be able to edit text if the EPS file contained outlines (paths) for 
text characters, rather than the characters themselves; you could 
use path-editing techniques to edit the objects.

Embed EPSF Into Document If an EPS graphic has been imported 
with the Place EPSF Reference option, you can use the context 
menu to convert the graphic from a linked EPS graphic to an EPS 
graphic that is placed in the document. The result is the same as 
importing an EPS file and selecting Create EPSF Object.

EPSF Info… You can get information from an EPS graphic if it was 
imported with the Place EPSF Reference option. Canvas will dis-
play information on the location of the EPS file that is linked into 
the document. If the file can’t be found in its original location, Can-
vas displays a message. To re-link the file, click File, and use the 
directory dialog box to select the EPS file. Then, click OK in the 
message box.
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Saving Web graphics (GIF/JPEG)
For saving graphics in GIF and JPEG formats (the standard Web 
image formats), you have the choice of using the integrated dialog 
box (Web Images) or the individual GIF or JPEG dialog boxes. 

• To export or save as GIF: Choose File > Save As or Image > 
Export and select GIF as the file format. Make your adjustments in 
the GIF Export Options dialog box.

• To export or save as JPEG: Choose File > Save As or Image > 
Export and select JPEG as the file format. Make your adjustments 
in the JPEG Export Options dialog box.

GIF format GIF is the best format for graphics that contain a small 
number of colors, such as vector art with flat colors. GIF format 
supports Black & White, Grayscale, and Indexed color images, with 
1 to 8 bits of color data for a maximum of 256 colors.

JPEG format JPEG format provides compression of high resolu-
tion, full-color (24- bit) RGB images. JPEG is designed for efficient 
storage of continuous-tone images such as photographs. JPEG is an 
abbreviation of Joint Photographic Experts Group, a standards organi-
zation that promoted the format.

To save graphics as Web Images
1 Select the objects to save, or Canvas will save the current doc-
ument page. Choose File > Save As. 

2 In the directory dialog box, select Web Images in the file for-
mat pop-up menu. Type a name for the file and select the save 
location. 

• To save only the selected objects, click Save Selection. 

3 Click Save.

4 Unless you are saving a single paint object, the Render Image 
dialog box appears. Select rendering options and click OK (see 
“Rendering images” on page 14.3).

5 The Export Preview dialog box appears. Select either format 
and use multiple preview panes to compare how the format and 
other settings will affect your images before saving (see “Export 
Preview options” on page 14.16).

6 Click Export to save the file.

Tip
You can use a wizard to save 
graphics for the Web. Select the 
images you want to save, and 
choose File > Save to Web. The 
wizard will help you save images in 
GIF and JPEG formats.
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To export images in GIF or JPEG format
Exporting lets you save selected images, but not entire documents. 
The difference between Save As and Export is that Save As will 
render objects or an entire document to create an image that can be 
saved. Export will save only a single paint object, without render-
ing.

1 Select a paint object to export. 

2 Choose Image > Export > Web Images. 

3 The Export Preview dialog box appears. Select either format 
and use multiple preview panes to compare how the format and 
other settings will affect your images before saving (see “Export 
Preview options” on page 14.16).

4 Click Export to save the file.

5 A directory dialog box appears. Type a name for the file and 
choose a location to save the file, and then click Save.

Export Preview options
The Export Preview dialog box shows one, two, or four previews of 
a graphic image when you choose Save As or Export and select GIF 
or JPEG file format. You can select settings for each preview image 
to compare how the file format, palette options, and other settings 
will affect the image you are saving.

A color tile shows the color you point to in a preview image. Two 
pairs of coordinates are displayed below the preview panes. One 
pair are the X,Y coordinates of the pointer. The other pair are the 
coordinates of the pixel at the upper-left corner of the preview 
panes.

Preview setup
Click a preview button to change the preview setup. You can select 
one preview, two previews (horizontal or vertical), or four previews.

One preview pane is active and has a highlighted border. Click a 
pane to make it active. The settings in the dialog box apply to the 
active preview. The settings in the dialog box can be different for 
each preview. When you select a preview, Canvas updates the dia-
log box to show the settings for the active preview.

All panes show the image at the same view location and zoom level. 
Drag on a preview image to move the view location.
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Use the zoom menu to zoom in or out. Or, click the Magnifying 
Glass button, then click a preview image to zoom in. To zoom out, 
Shift-click a preview image. 

Without selecting the Magnifying Glass button, you can zoom in or 
out by clicking in a preview image. On Mac, press Option or 
Option+Shift and click. On Windows, press Ctrl or Ctrl+Shift and 
click.

Previewing the current settings
Each preview pane shows the original image. To view how the 
selected file format and other settings will affect the image, select 
the Show Preview option above a preview pane. Canvas will apply 
all the settings in the dialog box to the preview image. If you change 
a setting, Canvas will apply the new setting.

Image file information When Show Preview is selected, the esti-
mated file size and the number of colors in the image appear above 
the active preview pane. The first value is the estimated file size in 
kilobytes. The second value is the number of discrete colors that 
will be saved in a GIF file; the value is not shown for JPEG format.

JPEG options
To use JPEG format, select JPEG from the Format menu. Canvas 
applies the JPEG format and settings to the active preview pane.

Quality Enter a percentage value from 1-100%. Higher Quality val-
ues result in less compression and better retention of original image 
quality.
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Smoothing Enter a smoothing value from 1 to 6. JPEG compres-
sion can cause color blocks to appear in an image. Smoothing soft-
ens the image to make color blocks less noticeable. Higher values 
produce more smoothing.

Progressive Select this option to create a JPEG file that Web 
browsers can display at increasing resolution as the image is loaded.

Downsampling This option can help improve compression. Down-
sampling reduces the image resolution by averaging color values 
while preserving luminosity details. Programs displaying the image 
will “upsample” to the original resolution, so greater compression is 
achieved without changing the display resolution of the image.

Optimized This option can help produce smaller file sizes. When 
Optimized is selected, some of the least important color informa-
tion is discarded to produce more efficient compression.

GIF options
To use GIF format, select GIF from the Format menu. Canvas 
applies the GIF format and settings to the active preview pane.

Max colors Use the menu or type in the box to specify the maxi-
mum number of colors to be used in the image. Fewer colors can 
result in a smaller file, but too few colors will degrade an image.

Palette A palette is a set of colors used in an image. To be saved in 
GIF format, an image can contain no more than 256 colors. If the 
image contains more colors, the original colors are mapped to the 
colors in the palette that you choose.

• Adaptive : creates a palette that tries to match as close as possi-
ble all the colors in the image. This option is the best for preserving 
the original color range of an image.

• Web : uses a standard color palette supported by major Web 
browsers. The range of colors in the Web palette, however, can 
cause color shifts in images with many shades of a few colors.

• Uniform : uses a palette of colors that are uniformly distributed 
through the range of possible RGB colors.
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• Exact : creates a palette from the actual colors in the image, if 
the image contains fewer than 256 colors. If the image contains 
more than 256 colors, Canvas uses the Adaptive option.

Note: To apply a custom or system color palette to a paint object 
before saving in GIF format, select the paint object and choose 
Image > Mode > Indexed. In the dialog box, select a palette option 
and click OK. To modify an Indexed mode paint object, choose 
Image > Mode > Color Table. 

Optimized Select this option to merge single pixels into similar col-
ored areas to produce smaller file sizes. However, in images with 
fine lines or detail, this option can reduce image quality. This 
option is less effective when Dither is also selected and an image 
has a limited number of colors.

Dither Select this option if you want Canvas to use dithering to 
simulate a greater range of colors. Dithering can make an image 
appear to have more colors than are in a limited color palette, but it 
can also make an image appear grainy or noisy. To control the 
amount of dithering, enter a percentage from 1 to 100 in the text 
box.

Interlaced Select this checkbox to save the image as an interlaced 
GIF. Interlacing divides the image data for faster initial display in 
Web browsers that support interlaced GIF images; i.e., the image 
appears progressively on the Web page.

Selecting transparent colors
The Dropper tools in the Export Preview dialog box let you make 
colors in a GIF image transparent. Click in the color palette or the 
current preview image to select colors for transparency. When you 
select a color, it becomes highlighted in the grid.

Use the regular dropper to select one transparent color. If you click 
another color, it replaces the current transparent color.

Use the add/subtract dropper to select additional colors to be trans-
parent. Each color you click becomes transparent. To restore a 
transparent color, click it again.

A checkerboard pattern appears in areas of the preview image that 
are transparent.

Color palette The area below the GIF options shows the current 
color palette for the image. The palette changes when you change 
the Palette or Max Color option.
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Saving settings
Save the current options in the Export Preview dialog box and then 
apply the same setup to other images.

To save the current options in the dialog box, choose Save Setting 
in the menu above the current preview pane. Type a name for the 
saved setting and click OK. This setting will be available in the 
menu above each preview pane.

• To use a saved setting: Select the Show Preview option above a 
preview pane and then select the saved setting in the menu.

• To delete a saved setting: Select the setting in the menu, and 
then choose Delete Setting. Canvas will ask you to confirm that you 
want to delete the setting.

Importing Photoshop files
When you open or import a Photoshop file that contains layers or 
paths, the Photoshop Import dialog box appears. Select options to 
specify what to import and then click OK.

Layers 
You can select from three options. 

Load into separate Canvas objects Imports the file’s layers as sepa-
rate objects and stacks them in the document on the current layer. 

Load into separate Canvas layers Places each Photoshop layer on a 
new Canvas layer. 

With either option, layers that have transparency are imported with 
visibility masks. Canvas creates an alpha channel and a channel 
mask for a Photoshop layer mask. Canvas also imports alpha chan-
nels.

Load Merged Result imports the file’s composite image (if it con-
tains one) rather than its layers. Layer masks, alpha channels, and 
transparency effects are not imported. The imported paint object 
has an opaque background. 

Note: If the option “Include composited image with layered files” is 
not selected when a file is saved from Photoshop, Canvas will 
import a black image containing a message that the layered file was 
not saved with a composite image.
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Paths
When the Photoshop file contains paths, you can choose from three 
import options. 

Load All will import a clipping path and other paths as Canvas vec-
tor objects.

Load only clipping path is available if the file contains a clipping 
path. Select this option to import the clipping path (but not other 
paths) as a Canvas clipping path object. The image will be clipped 
by the path in Canvas. 

Ignore paths will import the file without any paths.

QuickTime Movie (Mac)
Apple Computer’s QuickTime technology is included with the Mac 
OS and is required to work with some graphic formats, including 
QuickTime movies and JPEG-compressed files in Canvas.

If you have QuickTime software installed, the QuickTime tool in 
Canvas lets you place and play QuickTime movies. You can also 
save Presentation documents as QuickTime movie files. 

• To open a QuickTime movie file: Choose File > Open, select 
QuickTime™ Movie format, and click Open. Canvas imports the 
movie file into a new document.

• To place a QuickTime movie file in a document: Select the 
QuickTime tool in the Object tools palette. Click in the document 
where you want to place the movie. In the directory dialog box, 
select the movie file and click Open.

You can also use the File > Place command to place a QuickTime 
movie file in the current document.

To play QuickTime movies
Double-click the movie object. The movie controller below the 
movie becomes active. Click the play button ( ) to play the movie.

Playback options
To set playback options for a placed movie, select the movie object, 
then double-click the QuickTime tool. To set default options, dou-
ble-click the QuickTime tool when nothing is selected.

Use the following options in the QuickTime dialog box:

QuickTime tool
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Loop Makes a movie repeat when you play it. To repeat the movie 
from beginning to end, choose Normal. To repeat forward and 
then backward, choose Back and Forth.

Play Selection Only Plays one selected QuickTime object at a time.

Show Controller Displays the QuickTime movie playback controls 
with the movie object.

To create QuickTime movies
Save a Presentation in QuickTime movie format, so the docu-
ment’s slides become the movie’s frames.

Choose File > Save As and select QuickTime™ Movie format. 
Click Save. Select options in the Export Options dialog box and 
click OK.

Seconds Per Frame The playback duration in seconds for each 
slide (frame) in the movie. The actual playback speed may vary 
depending on the system capabilities and movie file compression.

Colors The color depth for the movie file. More colors result in 
larger file sizes. 

Maximize Select an option for compression used in the movie file:

• Animation Quality : makes slide transitions as smooth as possi-
ble at the expense of image resolution.

• Image Quality : uses high image resolution that might slow 
down the animation.

• Compression : keeps the file size to a minimum, at the cost of 
lower image quality.

Playable on non-Apple computers Makes the movie file compatible 
with QuickTime for Windows.

To save files containing movies
If you save a document that contains a QuickTime movie object, 
Canvas updates the link to the movie file. If it can’t find the movie 
file, Canvas asks you to locate the file. In the directory dialog box, 
select the file and click Open. If you can’t locate the file, click Can-
cel to continue saving with only the movie’s “poster” (preview) 
image.
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Using Tag Image File Format (TIFF)
Tag Image File Format is a high resolution, raster image format. 
Canvas supports both RGB and CMYK TIFFs. Although TIFF is a 
common format, many TIFF variations exist. Different resolutions, 
color systems, previews, and compression schemes make the format 
flexible, but can cause compatibility problems. 

When you save TIFF files, you have various options in the Export 
TIFF dialog box. 

TIFF Compression
Various compression options are available, depending on the mode 
of the image you are saving.

Group 3, Group 4, and Huffman are available to compress images 
that are in black-and-white mode. 

RLE and LZW can be applied to all image modes, except CMYK 
Color. 

None Saves an image without compression (the most compatible 
format).

Rows/Strip
Canvas can export TIFFs divided into strips. An image can be 
divided into strips to lower memory requirements for the applica-
tion that is importing the image. Dividing an image into strips can 
increase the image size, especially when compressed, but this 
option is sometimes necessary.

• All image rows in one strip, which is the default setting.

• Buffered (8 KB / strip),  which create strips no larger than 
8 KB or only one row if it is long enough to be larger than 
8 KB.

• One image row per strip.

Saving as SVG
Scalable Vector Graphics (SVG) is a vector graphics language writ-
ten in Extensible Markup Language (XML). This format enables 
two-dimensional images to be displayed in XML pages on the Web. 
With the SVG format, graphics are coded directly into an XML 
document.

Tip
Canvas can read tiled TIFFs. A 
tiled TIFF is an image divided into 
smaller, rectangular portions.
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In contrast to JPEG and GIF images on the Web, which are bit-
mapped and always remain a specified size, SVG images are scal-
able to the size of the viewing window and will adjust in size and 
resolution according to the window in which it is displayed.

To save as SVG
1 Choose File > Save As and select SVG as the file format. 

2 Click Save to open the SVG Options dialog box. 

General options
This dialog box is similar to the HTML Options dialog box (see 
“HTML options,” page 36.26).

Create new folder organizes files by placing them in a new folder 
in the specified location. The name that you enter when you are 
saving a SVG is used for the folder’s name.

Put images in subfolder creates a subfolder for the image files.

Image options The HTML options dialog box offers identical 
choices for image export (see “Image Options,” page 36.26).

Exporting as AVI (Windows)
AVI is the abbreviation of Audio Video Interleave, which is the 
most common format for audio/video data on the Windows system. 
When opened, an AVI file plays in a similar fashion to an animated 
GIF file.

Canvas has the capability of saving certain Canvas files in AVI for-
mat. Canvas documents that contain frames, animations or presen-
tations, can be saved as Audio Video Interleave. Even a document 
with a single frame can be saved in AVI format providing a default 
time for the single frame is set to 1 second. 

When working with Animation documents, you set the timing via 
the Document Layout palette (“Setting options in the palette,” 
page 12.3). If you are creating a Presentation document, use the 
Slide Show palette to control timing (“Slide Show palette,” 
page 37.2).

To export as AVI
1 Create your document in Canvas and choose File > Save As.

2 Select the AVI file format.
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3 Click Save. The Save AVI Options dialog box opens.

Auto Crop This feature optimizes the size of each frame and the 
document. The Auto Crop option will create the minimum size 
needed to accomodate all of the objects in the document.

Antialiasing Objects from the Canvas document will be rendered 
with an overall softened effect.

Quality This option affects the compression of the images. Move 
the slider bar to the right to lower the image quality or to the left to 
increase the compression, thus improving image quality.

Using text files
Text is a standard format for files containing only ASCII (Ameri-
can Standard Code for Information Interchange) encoded charac-
ters.

Text format is available on nearly every computer platform; it’s the 
“plain vanilla” format, the lowest common denominator for words 
and numbers. Text files don’t include proprietary or application-
specific character or formatting codes. Some punctuation marks, 
symbols, and all accented letters are non-ASCII characters that dis-
play incorrectly when used in text files. Still, ASCII text can be 
used to transfer text among a variety of applications, including text 
editors, word processors, and databases. 

When you open a text file, Canvas creates one text object contain-
ing the file’s contents, and assigns the default font and text format-
ting attributes to it. If the file contains more text than can fit in the 
Canvas workspace, Canvas truncates the text object and displays an 
overflow indicator. You can then flow the truncated text into other 
columns.

Using Object Linking and Embedding (Windows)
Object Linking and Embedding (OLE) lets you easily exchange 
graphics among programs. Since Canvas provides full OLE sup-
port, objects you exchange retain their full functionality and are 
editable with all the tools of the original application.

Windows programs provide various levels of OLE support. In OLE 
parlance, Canvas is a fully capable object and container application. 
Briefly, this means Canvas can transfer objects to and from other 
programs through OLE. 
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In the world of OLE, objects created in Canvas are identified as 
“Canvas Drawing” objects. If you use the Insert Object command 
in another application, you should be able to select “Canvas Draw-
ing” as a type of object to insert.

Inserting objects into Canvas documents
You can use three methods to insert objects in a Canvas document: 
the Clipboard, drag-and-drop, and the Insert Object command. 
The objects you insert can be either linked or embedded.

Clipboard When you copy Canvas objects to the Clipboard, Can-
vas places OLE formats, as well as lower-fidelity formats, on the 
Clipboard. When you paste into another program, that program 
receives the highest-fidelity format it can accept. If the other pro-
gram is an OLE container, pasting creates an embedded OLE 
object. 

When pasting into Canvas from other applications, a MetaObject 
container is created. The MetaObject is a Canvas “Container” for a 
system metafile (WMF/EMF). It will draw, print, and act like a nor-
mal Canvas object using the system to render it. This should pre-
serve the fidelity of the metafile. 

The MetaObject container method eliminates problems in scaling, 
positioning, and overall look. OLE and pasting as metafile will 
automatically create a MetaObject. To convert the MetaObject to a 
Canvas object, choose Object > Path > Convert To Paths.

Drag-and-drop In Windows, you can drag objects from Canvas 
documents to almost any destination on the Desktop (including 
local and network folders) to create a “scrap” file containing the 
objects. You can also drag Canvas objects into other documents, 
and drag objects, such as scrap files and other program’s objects, 
directly into Canvas documents. When you drag an object to 
another program, it creates an embedding. 

You can copy an object when you drag it by pressing a modifier 
key. Normally, dragging moves the object. If you want to copy the 
object, rather than move it, Ctrl-drag the object to another docu-
ment. This copies the object and creates an embedding. 

Insert Object Choose Edit > Insert Object to open a dialog box in 
which you can choose any registered OLE object type to insert into 
a document. Create a new object or choose a file as the source of 
the embedded object.
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To embed objects
When you embed an object in another document, use the original 
program’s tools and commands to edit the object.

1 Select the objects you want to embed in another document.

2 Choose Edit > Copy to put the selection on the Clipboard.

3 Switch to the document where you want to embed the selec-
tion and choose Edit > Paste. The object is embedded into the 
document.

To link objects 
If you want an object to be updated when it changes in the original 
document, create a link to the object. The Canvas document from 
which you copy objects to be linked must have been saved before 
you copy the objects.

1 Select the objects to link and choose Edit > Copy. 

2 Switch to the document where you want to paste the linked 
object and choose Edit > Paste Special. In the dialog box, Canvas 
Drawing format is selected. 

3 Click Paste Link to link the object.

To manage linked objects
Use the Links command to check the source file of a linked object 
and repair a broken link if a source file has been moved.

1 Select a linked object in a document.

2 Choose Edit > Links. The Links dialog box displays the link 
type and update method. To change the update method, choose 
the Automatic or Manual option.

3 Use the buttons to update or change the linked object:

• To update the object from its source: Click Update Now.

• To open the source document: Click Open Source.

• To select a different source document: Click Change Source.

• To remove the link so changes to the source do not affect the 
linked object: Click Break Link.

Tip
Not all programs support OLE and 
can create embeddings.

Tip
Not all OLE programs support 
OLE linking.
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Differences between linking and embedding
When you insert an object into a Canvas document, or insert an 
object from Canvas into another program’s document, you create 
an association between the object and its application. Linking and 
embedding create different types of associations.

Linking When you link an object, the object remains in the file 
where it was created. Only a link (reference) to the source object 
winds up in the document, which makes linking an efficient 
method of storing commonly-used objects and files. Linking makes 
a dynamic connection between an object and all documents in 
which it appears. When you edit the object, changes are automati-
cally sent to linked instances of the object in all documents.

Since the object is linked by only a reference to another file, if any 
of the linked files change locations, the link will be disrupted. To 
move linked files without disrupting the references, you must move 
all linked files as well as the entire directory structure so that the rel-
ative locations of the files don’t change.

When you edit a linked object, the object’s application opens in a 
separate window. When you finish editing, close the application to 
return to the document containing the link.

Embedding When you embed an object in a document, the object 
itself (not just a reference) is copied into the document. Therefore, a 
document can be moved to another computer without losing the 
object.
.28 FILE & DATA EXCHANGE
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15
INKS: COLORS & PATTERNS

Inks in Canvas are solid colors, or multicolored patterns that you 
apply to vector and text objects. You can apply inks to the interiors 
and outlines of vector objects and text.

This chapter describes how to create and apply inks, from basic 
solid color inks to custom multicolored inks. It also explains how to 
define inks.

Presets palette
Use the Presets palette to apply inks, select the current inks for new 
objects, load inks, and delete inks. 

• To open the Presets palette: Click on either the Pen Ink icon or 
Fill Ink icon in the Toolbox. Drag the palette away from the Tool-
box to float it. The Presets palette opens with the Inks tab selected. 

Ink types
Six icons are located at the top of the Inks tab, which you click to 
access the available ink types: color, gradient, hatch, texture, sym-
bol, and pattern. The circular icon with a diagonal line represents 
“no ink”.

Color inks Refers to inks using solid colors.

Gradient inks Refers to inks with smooth blends between two or 
more colors.

Hatch inks Refers to inks with line patterns. Hatch inks can incor-
porate other pen and fill inks.

Texture inks Refers to inks with patterns of raster images. Texture 
inks can include other inks as backgrounds.

Symbol inks Refers to inks with patterns of vector objects, image 
objects, or text objects. Symbol inks can include any other ink as a 
background.

Pattern inks Refers to inks that are 72 dpi bitmap representations 
with a fixed size of 8 x 8 pixels.
15.1
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Loading, appending, saving, and clearing inks
The Presets palette menu, located at the bottom-right corner of the 
palette, contains all the commands for you to load, append, save, or 
clear inks.

Load Loads a stored ink palette to replace the current palette. 
Save the current palette if necessary. 

Append Adds inks from a palette file to the inks on the current 
tab.

Note: Canvas won’t load or append inks that don’t correspond to the 
current ink type.

Save Saves the current ink palette as a palette file. Saved ink pal-
ettes can be shared with other Canvas users. 

Clear Removes the inks (except “no ink”) from the current ink pal-
ette. For color inks, Canvas restores black and white (CMYK) inks 
after clearing all the inks.

When you add or delete inks in the palette, the changes are 
recorded in a Canvas Settings file, not in the Canvas document, so 
the palette contents remain the same the next time you use Canvas.

Recently used inksPreset inks 

Palette menu

No inkInk types

Click to 
modify 
selected ink Fill inkPen ink

Commands correspond to the 
name of the current ink type.
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Identifying inks
You can display color names that identify the inks that are stored in 
the Presets palette. This function affects all ink types in the palette. 
If an ink was not given a name, no name will appear. 

You can also differentiate between RGB, CMYK, and spot colors 
when working with color inks by showing color icons.

To identify inks by names
If the color ink type is selected, the inks will indicate RGB, CMYK, 
or grayscale percentages. For gradient, hatch, symbol, pattern, and 
texture inks, a name is displayed. 

• To display ink names: Open the Inks palette menu and choose 
Show Color Names.

• To hide the ink names: Open the Inks palette menu and dese-
lect Show Color Names.

To identify inks with color icons
Color icons help you identify RGB, CMYK, and spot colors when 
working with the color inks.

Note: Selecting Show Color Icons only affects the appearance of the 
color inks in the Presets palette. The other inks are not affected.

• To display color icons: Select the color ink icon and open the 
palette menu. Choose Show Color Icons.

• To hide the color icons: Choose Hide Color Icons in the menu.

The color inks can contain inks defined with RGB, CMYK, gray-
scale, and spot colors. 

• The symbol for RGB color inks has tiny red and blue tri-
angles and a green square. The symbol appears at the 
upper-left of RGB color cells. 

• The symbol for spot color inks is a white triangle. The 
symbol appears at the lower-right of spot color cells. If the 
Show Color Names option is activated, no symbol appears 
for the spot color. 

• No symbol appears on CMYK or Grayscale ink cells.

Note: When working with color inks, if the Inks tab contains only 
CMYK colors, no symbols appear when you choose Show Color 
Icons.

CMYK color 

Spot color 

RGB color 
Presets palette 15.3
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Arranging ink cells
To rearrange ink cells in the Presets palette, drag a cell within the 
palette and drop it where you want to place it.

• To move contiguous ink cells to a new location: Click the first 
ink cell and then Shift+click another cell. Canvas highlights all cells 
between the colors you click. 

• To select non-contiguous cells: Ctrl+click the cells you want to 
select. Drag the selected cells to a new location in the palette.

Attributes palette
Use the Attributes palette and its various ink managers to create 
your own inks. Each ink type has its own manager. Flip open the 
managers to create inks, adjust inks in objects, and change the Pre-
sets palette’s inks.

• To open the Attributes palette: Click the Edit button in the Pre-
sets palette

Another way of opening this palette is by selecting an ink on the 
Presets palette and then clicking the Edit button. The Attributes 
palette opens with the Inks tab selected.

Applying preset inks

The Inks tab has six ink types that you 
can apply as pen or fill inks.

A Pen ink icon. Press to select pen 
inks for object outlines.
B Fill ink icon. Press to select fill inks 
for the insides of objects.
C Ink types. Select the type of ink you 
want to apply.
D Preset inks. Select an ink in the 
grid. Use the scroll bars if all the preset 
inks aren’t visible.
E No ink. Click this icon to apply no 
inks, or to make the current ink for new 
objects “no ink.”
F Recently used inks. Select an ink 
from here as well.

To apply inks to existing objects, 
select the objects and then choose 
pen and fill inks.

To change the inks that Canvas 
applies to new vector and text 
objects, deselect all objects, then 
choose pen and fill inks. The ink 
icons in the toolbox show the cur-
rent inks.

To remove an ink from the palette: 
Drag the ink cell to the trash can.

Since pen inks are applied to the 
strokes of objects, the appearance 
of an object’s pen ink is affected by 
the shape of the object’s stroke (see 
“How inks affect strokes” on 
page 16.1).
.4 INKS: COLORS & PATTERNS



Inks managers
Six icons are located at the top of the Inks managers, which you 
click to access the available ink types and their respective managers: 
color, gradient, hatch, texture, symbol, and pattern. The circular 
icon with a diagonal line represents “no ink”.

Creating color inks
The Color Manager gives you the ability to maintain and manage 
color inks by providing access to RGB, CMYK, and HSL models. A 
Color Spectrum Strip is also available for quick color pickup of any 
color supported by Canvas.

Tip
Each ink type has its own manager 
so you create custom inks and add 
them to the Presets palette.

Preset inksInk manager 
controls

No inkInk types

Click to add 
to Presets

Fill inkPen ink

Color 
systems

If you select color as 
the ink type, you can 
access the RGB, 
CMYK, and HSL color 
systems.

Using the Inks managers

Every ink manager shows a preview of 
the current ink. The preview changes 
as you modify the ink. If an object is 
selected, the ink is applied immediate-
ly. You can also drag the ink from the 
preview box to deselected objects.

To edit an object’s ink, click the pen 
ink icon or fill ink icon. Then select an 
object; its ink becomes the current ink 
in the manager. Modify the ink. 

Click Apply to apply the modified ink 
to the object.

To make a new ink, use the appropri-
ate manager to customize the current 
ink.

Type a name in the text box to name 
it. 

To add an ink to the Presets palette, 
click the Add Preset button.

To make an ink the current ink, dese-
lect any objects and click the pen ink 
icon or fill ink icon. Then select an ink 
in any of the managers.

To apply an ink to a deselected object, 
drag from the preview box to the 
inside or outline of the object.
Attributes palette 15.5
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Color manager controls

The Color Manager’s controls depend 
on the selected color system and 
model. Some controls are common 
among the different color models.

A Current ink.
B Last-applied ink.
C Bars. Use the sliders, or enter val-
ues in the text boxes, to specify color 
values. RGB values go from 0 to 255. 
CMYK values go from 0 to 100%. HSL 
values go from 0 to 360° (hue) and 0 to 
100% (saturation and lightness).
D Spot Color. Select to set up a spot 
color. Type a color name in the text box. 
Spot colors print on separate plates 
when you make color separations.
E Tint Color. Select the color to ap-
ply to the current color. 
F Tint value. Enter the percentage of 
tint to be applied.
G Swatchbook. Shows colors made 
from 0-100% mixtures of two CMYK 
colors. To select a color, click in the 
swatchbook; the color values appear in 
the text boxes.
H Select the two colors for the 
swatchbook. To add a third or fourth 
color, enter percentages in the C M Y K 
text boxes. 
I Color wheel. Click in the wheel or 
drag the selector to pick a color, or en-
ter values in the HSL text boxes.

J Lightness. Drag the slider or enter 
a number in the L text box to set the 
lightness for the entire color wheel.
K Gamut warning. When the current 
color can’t be printed with CMYK inks, 
a warning symbol and color box appear. 

Click the color box to replace the cur-
rent color with the closest color that is 
within the CMYK gamut. 

Gamut warnings appear only in RGB 
and HSL systems.

CMYK Bars CMYK Tints

HSL WheelCMYK Swatch
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Color systems
Use the drop-down menus to access to the various color controls. 
This will allow you to select a color matching system and select col-
ors that are needed for commercial printing.

• To define colors in Canvas: Use CMYK, RGB, and Grayscale 
color systems. 

Colors displayed on a monitor can only approximate the appear-
ance of printed colors. Be sure to discuss color reproduction with 
your commercial printer and obtain accurate proofs for color 
projects.

CMYK colors
The CMYK color system is used in four-color process printing. 
Define colors as mixtures of Cyan (C), Magenta (M), Yellow (Y), 
and Black (K) printing inks; e.g., to create green, mix cyan and yel-
low.

The CMYK system is appropriate for illustrations that will be sepa-
rated for commercial printing. 

RGB colors
The RGB color system is used in computer monitors. Define colors 
as mixtures of Red (R), Green (G), and Blue (B) light; e.g., to create 
purple, mix red and blue.

The RGB system is appropriate for graphics displayed on a moni-
tor, such as presentations and Web pages.

Grayscale colors
The Grayscale model lets you define shades of gray. Grayscale col-
ors are neutral when used with RGB or CMYK colors. In RGB 
Color images, grayscale colors are equal amounts of red, green, and 
blue. In image channels, Grayscale colors are pure gray. In vector 
objects, text, or CMYK Color images, Grayscale colors are percent-
ages of black. In color separations, Grayscale colors appear as per-
centages of black.

HSL
The HSL models let you define RGB colors using Hue (H), Satura-
tion (S), and Lightness (L) values. This way of defining colors is 
familiar to artists. HSL models let you adjust saturation and light-
ness, without changing a basic hue, such as red or green. 

Click on an icon to access the controls 
and color systems.

A CMYK
B RGB / Grayscale
C HSL

Tip
Avoid RGB colors in documents 
intended for commercial printing. 
Canvas will convert RGB colors to 
CMYK colors if you output color 
separations.
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Specifying tints
Specify a tint color and amount in the CMYK or RGB system. Tint-
ing with white screens the original color. The screen percentage is 
100 minus the tint value. For example, 80% white tint results in 20% 
of the original color.

For other tint colors, Canvas multiplies the tint values by the differ-
ence between the original and tint color values, and then adds the 
result to the original color values.

To create new color inks
1 Choose a color system and model from the drop-down menu 
(see “Color systems” on page 15.7.

2 Use the Color manager controls to change the ink’s color val-
ues. 

3 Click the left preview box to restore the original ink.

• To name the ink: Type the name in the text box. 

• To define it as a spot color: Select the Spot Color box.

• To apply the ink to non-selected objects: Drag it from the pre-
view box to the objects. 

• To add the ink to the Presets palette: Click the Add Preset but-
ton on the Attributes palette. The new ink is added to the appropri-
ate ink type; i.e., if you create a Pattern ink, the new ink is added to 
the Pattern type.

Tip
After creating a new ink, make 
sure you click the Add Preset but-
ton on the Attributes palette. 
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Creating blends of color inks
Select two color cells and create a blend of colors to add to the color 
inks tab of the Presets palette.

To blend colors
1 Select the Inks tab of the Presets palette. 

2 Select color as the Ink type.

3 Click the ink cell that is to start the blend, then Ctrl-click the 
cell to end the blend.

4 Open the palette menu and choose Blend. A dialog box 
appears. 

5 Enter the number of steps you want in the blend and then 
click OK. Canvas creates the blend and adds the new cells to the 
color inks at the end.

Accessing the Color Editor
In Canvas, dialog boxes and palettes that let you choose colors have 
a color icon that opens a pop-up color palette.

The Custom icon appears in pop-up color palettes in the following 
dialog boxes and palettes:

Attributes (Inks) Color manager (CMYK Tints & RGB Tints only)

Gradient manager

Hatch manager (pen color pop-up only)

Attributes (Pens) Neon manager

Parallel manager

Layers Layer Options dialog box

Color calibration Gamut Warning dialog box

Image editing Duotone Options dialog box

New Channel dialog box

Channel Options dialog box

Create Image dialog box

Effects Extrude palette

Blended colors

Click to open 
Color Editor 
dialog box
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Click the color icon to open a palette that has the color inks that are 
currently available in the Presets palette. Click the Custom icon to 
open the Color Editor dialog box.

To create a custom color with the Color Editor dialog box
1 Open the Color Editor dialog box. This dialog box is almost 
identical to the Color manager.

2 To use a different color model, click on the color model but-
ton and choose an option in the menu. Depending on the chosen 
option, the Color Editor shows a different set of controls (see 
“Color manager controls” on page 15.6).

3 Use the color controls to create a custom color.

4 To specify that you want the color you define to be a spot 
color, make sure you enter a name in the text box. Then select 
Spot Color.

5 When you have the color you want, click OK. The color 
appears in the color icon.

Color Editor dialog box
A Choose a color model in this pop-
up menu.
B Type a name for the color in this 
text box.
C Use the controls to specify a color. 
The available controls depend on the 
chosen option (B).

D Current selected color that ap-
pears in the color palette icon. Click to 
revert the settings in the dialog box to 
this color.

E Preview of the custom color that 
you are defining.

Spot Color. Select this option to 
define the custom color as a spot 
color.

Important
If you plan to export a document 
to another application in EPS for-
mat and make spot color separa-
tions, be sure the spot color 
names match exactly in both appli-
cations. Any variation will cause 
problems.
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Working with Gradient inks
A gradient is a gradual blending of colors. A gradient ink can blend 
two or more colors in a variety of styles. Like other inks, gradient 
inks can be applied as fill inks or pen inks to vector and text objects.

The appearance of a gradient ink depends on several factors. Gradi-
ents appear smooth on monitors that display millions of colors, but 
can appear coarse and dithered on monitors that display only 256 
colors. The more extreme the difference in colors, the coarser a gra-
dient can appear. When a gradient has large color transitions, it 
appears smoother in an object that is large enough to show all the 
transitions.

• To create and customize gradient inks: Use the Gradient man-
ager in the Attributes palette(see “Gradient manager,” page 15.16).

Applying gradient inks
Canvas gives you the option of applying gradients directly from the 
Presets palette or using the Vector Gradient tool (see “To apply gra-
dients with the Vector Gradient tool,” page 15.12). When a gradient 
ink is applied via the Presets palette, the gradient effect is centered 
within the object. If you want non-centered effects, use the Vector 
Gradient tool.

Note: The Vector Gradient tool can be used on vector or text 
objects.

To apply gradient inks from the Presets palette
Make sure you select either the Pen or Fill ink icon on the Presets 
palette.

• If object is selected, click on the gradient ink cell.

• If object is not selected, click on the gradient ink cell and 
drag the ink to the object.

See “Applying preset inks,” page 15.4, for complete steps about 
applying inks.

Gradient styles 

Style Appearance and edit controls Edit box

Radial Colors sweep in a circle around the center. To move the center point, drag the open 
dot. To set the starting angle, drag the solid dot or enter the angle (0 to 360°) in the 
text box.
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To apply gradients with the Vector Gradient tool

The Vector Gradient tool applies the gradient ink that was used 
last. The ink is applied either as a fill or pen ink according to the 
icon selected in the Presets palette.

There are two factors that affect the appearance of the object after 
using the Gradient Vector tool: 

• style of the gradient ink

• manner of dragging the Vector Gradient tool

When using this tool, you’re not limited to dragging directly inside 
the object(s). Drag inside or outside selected objects to achieve dif-
ferent effects; e.g., if you’re applying a directional gradient, 
“stretch” the gradient by dragging across the object, starting and 
finishing outside the object. This technique places the start and end 
colors farther apart than if you drag a shorter distance within the 
object only.

1 Select the Vector Gradient tool

Directional Linear gradient in which colors blend in the direction you specify. To set the gradient 
orientation, drag the solid dot, or enter an angle from 0 to 360° in the text box.

Shape Gradient conforms to basic object shapes. To move the gradient center, drag the rect-
angle. To resize the center area that contains the end color, drag the solid handle and 
resize the rectangle.

Rectangular Rectangular-shaped gradient. To move the gradient center, drag the rectangle. To 
resize the center area that contains the end color, drag the solid handle and resize the 
rectangle.

Elliptical Elliptical-shaped gradient. To move the gradient center, drag the oval. To resize the 
center area that contains the end color, drag the solid dot and resize the oval.

Style Appearance and edit controls Edit box

Tip
An object or objects must be 
selected to use the Vector Gradi-
ent tool. If more than one object is 
selected, the gradient flows across 
the selected objects as if they were 
one object.
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2 Then drag in the document to position the gradient. As you 
drag, a vector indicates the gradient position. The gradient 
appears on the selected objects.

Modifying gradients
There are various ways of modifying gradient inks: 

• To change the direction or position of the gradient: Use the Gra-
dient manager in the Attributes palette, context menu, or Vector 
Gradient tool (see “Gradient manager,” page 15.16).

• To make color changes: Use the Gradient manager in the 
Attributes palette or click on the individual nodes when the gradi-
ent ink is in edit mode.

To modify a gradient ink with the Gradient manager
1 Open the Gradient manager in the Attributes palette (see 
“Gradient manager,” page 15.16).

2 Select the object. The Gradient manager indicates the ink set-
tings when the object is selected.

3 Click the Edit button in the Gradient manager to put the gra-
dient ink into edit mode. You can now change the direction or 

Vector gradient styles Description

Radial A line that sets the center and angle of the gradient. The place where you begin to drag is the 
center point of the gradient. The vector extends from and rotates around the center point. The 
angle of the line establishes the angle of the gradient. The length of the line does not effect the 
gradient. 

Directional A line that sets the angle and length of the gradient. The place where you begin to drag has the 
start color of the gradient. The vector line extends from and rotates around the start point as you 
drag away from it. The angle of the line establishes the angle. The place where you stop dragging 
sets the end color of the gradient.

Shape A rectangle that sets the size and location of the end color of the gradient. The rectangle con-
tains the end color. Drag diagonally from one corner of the rectangle to another. The rectangle 
expands or contracts as you drag away from or toward the starting point. When you finish drag-
ging, the gradient conforms to the object’s shape.

Rectangular A rectangle that sets the size and shape of the gradient. The rectangle contains the end color of 
the gradient. Drag diagonally from one corner of the rectangle to another. The rectangle expands 
or contracts as you drag away from or toward the starting point.

Elliptical An ellipse that sets the size and shape of the gradient. The ellipse contains the end color of the 
gradient. Drag diagonally from one corner of the ellipse’s bounding box to another. The ellipse 
expands or contracts as you drag away from or toward the starting point.
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position of the gradient. Modifications appear in the object auto-
matically.

• To add the modified gradient ink to the Presets palette: Click 
Add Preset and the ink is added to the gradient inks.

To edit a gradient ink via a context menu
1 Select an object that contains either a gradient fill or pen ink. 

2 Right-click (Windows) or Control-click (Mac) to open the 
menu.

3 Select either Edit Frame Gradient or Edit Fill Gradient 
depending the use of the gradient ink. The gradient ink should 
enter edit mode.

4 Make the desired changes in position and direction. 

5 Right-click (Windows) or Control-click (Mac) on the individ-
ual color nodes to open a color palette. The Gradient manager is 
also available for color changes (see “Gradient manager,” 
page 15.16).

6 Press Esc to exit edit mode.

To edit a gradient ink with the Vector Gradient tool
1 Select an object that contains either a gradient fill or pen ink.

2 Click on the Vector Gradient tool. The gradient ink is in edit 
mode.

3 Make the desired changes in position and direction.

4 Right-click (Windows) or Control-click (Mac) on the individ-
ual color nodes to open a color palette. You can click on the Cus-
tom button to open the Color Editor (see “Color Editor dialog 
box,” page 15.10). The Gradient manager is also available for 
color changes (see “Gradient manager,” page 15.16).

5 Press Esc to exit edit mode.

Gradient editing handles. 
Changes the direction of the 
gradient.

Color node. This control 
feature allows you to adjust 
the colors that are contained 
in the gradient.
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To add color nodes to a gradient ink while in edit mode
Another way to change a gradient ink is to add color nodes to the 
gradient. 

1 Put a gradient ink into edit mode.

2 In between the nodes that are already present, right-click 
(Windows) or Control-click (Mac) to open a color palette. 

3 Select a color or click on the Custom button to access the 
Color Editor (see “Color Editor dialog box,” page 15.10). The new 
node appears with the selected color.

To remove color nodes from a gradient ink while in edit mode
Change the appearance of a gradient ink by removing color nodes.

1 Use one of the previous methods to put a gradient ink into 
edit mode.

2 Select a color node and drag it away from the gradient. The 
color is now removed from the gradient ink.

Creating gradient inks
Use the Gradient manager to create gradient inks and then add 
them to the Presets palette. 
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Gradient manager

To create a gradient ink, choose a gra-
dient style, colors, and other options.

If you have an object selected, the ink 
is automatically applied to the object.

A The gradient color sequence ap-
pears in the bar. Each pointer below the 
bar represents a color and shows the 
color’s relative position in the gradient. 
One pointer is always selected, and the 
pointer’s color appears in the color icon 
(D). 

B The pointers at the ends of the bar 
represent the gradient start and end col-
ors. These pointers can’t be moved or 
deleted, but you can change their colors.
C Click a pointer to select it; a select-
ed pointer appears highlighted. To add 
an intermediate color, double-click in 
the bar and a new pointer appears that 
represents the color of the gradient 
where you clicked.

To adjust color spacing, drag an inter-
mediate pointer. To delete a color, 
drag its pointer to either end of the bar.

D Choose a color for the selected 
pointer from the pop-up palette. To se-
lect a custom color, see “Accessing the 
Color Editor” on page 15.9.

Style. Choose a gradient style from the 
menu (see “Gradient styles,” 
page 15.11). 

E Edit box: Drag handles in the box to 
adjust settings such as gradient shape, 
angle and center. 

F Gradient preview. Shows the cur-
rent gradient. The preview changes as 
you edit the gradient. 

Angle. For Radial and Directional styles, 
enter the angle of the gradient axis, or 
drag the solid dot in the edit box to set 
the angle. 

360º. When Radial is selected, select 
this checkbox to blend the gradient 
through 360 ° around the center. If this 
option isn’t selected, the blend runs 
through 180° in both directions, creat-
ing a mirror image around the blend 
axis. 

In addition, when 360° is selected, a 
button appears. Click the button to 
reverse the gradient direction.

Rainbow. Select this to add all hues on 
the color wheel between the colors you 
set in the gradient. Click a direction 
button to select a clockwise or coun-
terclockwise path around the HSL col-
or wheel, which sets the sequence of 
hues.

Edit. Click this button to place a gradi-
ent into edit mode.

Add Preset. Click this button to add a 
new ink to the Presets palette.
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Working with Hatch inks 
Hatch inks are patterns made of groups of lines. These inks are 
often used in illustrations to distinguish different materials in cross 
sections, machine diagrams, and maps.

Specify the number of line groups as well as the angle, offset, and 
origin of each group. Assign a pen size, color, and dash to each line 
group, and select a fill ink for the background of the hatch ink.

Hatch inks
Click on the Hatch icon to open the hatch inks in the Presets pal-
ette. Use this palette to apply preset hatch inks to objects or store 
customized hatch inks that you create in the Hatch manager (see 
“Hatch manager,” page 15.18).

To apply hatch inks
Make sure you select either the Pen or Fill ink icon on the Presets 
palette.

• If object is selected, click on the hatch ink cell.

• If object is not selected, click on the hatch ink cell and 
drag the ink to the object.

See “Applying preset inks,” page 15.4, for complete steps about 
applying inks.

Creating hatch inks
Use the Hatch manager in the Attributes palette to create hatch 
inks and then add them to the Presets palette.

Tip
If you create a new ink in the 
Hatch manager, click the Add Pre-
set button to add it to the Presets 
palette.
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Modifying hatch inks
When you want to change an existing hatch ink, select the hatch 
ink and click the Edit button to open the Hatch manager in the 
Attributes palette.

To change the background color
1 Click on the fill icon to open the pop-up Presets palette. This 
palette is identical to the Presets palette. Use any ink type that is 
currently available on the palette.

2 Select the new background ink.

3 Click the Add Preset button to add the modified ink to the 
hatch inks in the Presets palette.

To add or modify a line group
If you want to create a hatch ink that has crossing lines, the hatch 
ink will have to contain different layers. If the hatch ink contains 
only one line group, then one layers is sufficient.

• To add a new line group: Click the New button in the Hatch 
manager and then define the line.

• To adjust a line group: Select a layer from the Layer menu in 
the Hatch manager (if the hatch ink contains more than one line 

Hatch manager

When you create a hatch ink, set the 
number of line groups and other 
attributes.

A Preview. Click a line group in the 
preview box to select it. Tiny handles 
appear where the selected group meets 
the edge.
B Pen color. Choose a color for the 
selected line group in the palette. 
Choose a preset color or define a cus-
tom color; see “Accessing the Color Ed-
itor” on page 15.9.
C Fill ink. Select an ink to use as the 
hatch ink background.
D Dash. Choose a dash pattern for 
the selected line group.

Layer. If the hatch ink has different 
layers, choose the layer from this 
menu. 

New. Click this button to add a 
new layer. When a new layer is 
active, you can add another line 
group.

Clear. Click this button to delete 
the current layer.

See “To add or modify a line 
group,” page 15.18 for information 
on setting Pen, Angle, Offset, and 
Origin.
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group), and then make any modifications in the Hatch manager. 
You can even add more line groups by adding layers. 

A line group is selected when selection handles appear where the 
line group touches the Preview window. Once selected, the follow-
ing line group attributes can be modified: 

Working with Symbol inks
Symbol inks are created from text, image, and vector objects. Use 
any of the Canvas drawing tools to create objects for a symbol ink. 
Apply pen and fill inks before bringing the objects into the Symbol 
manager to create a new symbol ink.

You can even combine text, image, and vector objects to create a 
unique symbol ink.

Click on the Symbol ink icon to open the symbol inks. Use the Pre-
sets palette to apply preset symbol inks to objects or store custom-
ized symbol inks that you create in the Symbol manager (see 
“Symbol manager,” page 15.20).

To apply symbol inks
Make sure you select either the Pen or Fill ink icon on the Presets 
palette.

• If object is selected, click on the symbol ink cell.

• If object is not selected, click on the symbol ink cell and 
drag the ink to the object.

Attribute Description

Line group color Click on the pen icon to open the pop-up color palette. Choose a preset color or define a custom color in 
the Color Editor dialog box (see “Color Editor dialog box,” page 15.10).

Pen The width in points (1/72 inch) of each line in the selected line group. If a hatch ink overlaps the edges of 
an object, change the Pen value to make the width of the hatch lines smaller than the pen size of the 
object’s stroke.

Angle The angle in degrees of the selected line group relative to vertical. When you add a line group, the angle is 
initially 0 degrees. 

Offset The horizontal starting position of the line group, measured in points. Increasing this value moves the line 
group to the right.

Origin The vertical starting position of the line group, measured in points from the top of the preview box. Increas-
ing this value moves the line group downward.
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See “Applying preset inks,” page 15.4, for complete steps about 
applying inks.

To create symbol inks
1 Before creating a symbol ink, deselect any objects by pressing 
Esc.

2 Open the Symbol manager and click the Create button. A 
prompt appears when you move the cursor into the layout area.

3 Click on the object that you will use in the symbol ink.

Note: If you want to use more than one object or object type in the 
symbol ink, you must first group the objects.

4 Adjust the settings for the symbol ink in the Symbol manager 
(see “Spacing and position settings,” page 15.20).

5 Click the Add Preset button to add it to the symbol inks in 
the Presets palette.

Tip
If you create a new ink in the Sym-
bol manager, click the Add Preset 
button to add it to the Presets pal-
ette.

Symbol manager

Adjust the position and spacing of the 
objects and apply a backdrop ink.

A Preview. Displays the symbol ink. 
Any changes you make are reflected in 
the Preview area.
B Backdrop. Select an ink in the pop-
up menu. Select any ink, including a col-
or, gradient, hatch, texture, and symbol 
ink. The ink you select appears behind 
the objects in the symbol ink.
C Preview zoom. Click the left button 
to reduce or the right button to enlarge 
the preview.

Spacing and position settings

X Spacing and Y Spacing. Sets the dis-
tance between objects as a percentage 
of the size of the original objects; e.g., a 
spacing value of 100% makes the dis-
tance between the objects equal to 
their size. X is horizontal distance and Y 
is vertical distance.

Stagger. A positive value offsets the 
even-numbered rows of objects hori-
zontally relative to the odd-numbered 
rows. To keep all objects aligned, set 
Stagger to zero. To align alternating 
rows of objects, enter a higher Stag-
ger value. To create a pattern in which 
the objects are spread out and 
objects in alternating rows are aligned 
with the gaps in the rows above, set 
the X Spacing and Stagger values to 
100 percent.

Scale. The percentage of the original 
object size for the symbol ink. A value 
of 100% maintains the original object 
size. To reduce the objects, enter a 
value smaller than 100%. To enlarge 
the objects, enter a value greater than 
100%.

Rotation. The amount of rotation, 
specified in degrees, that Canvas 
applies to the original objects.

Align To Object. Turn on this option to 
keep a symbol ink in the same position 
if the object moves. Turn it off to let 

overlapping objects share a symbol ink 
without a gap.
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Working with Texture inks
A texture ink consists of image objects. Canvas assembles a texture 
ink by repeating the image in rows and columns, as if it were a grid 
of rectangular cells. You can control the spacing and staggering of 
the images in a texture ink.

If you enter spacing values that spread the images apart, you create 
gaps between the image cells. You can also include a background 
ink that will show through the gaps.

Click on the Texture ink icon to open the texture inks. Use the Pre-
sets palette to apply preset texture inks to objects or store custom-
ized texture inks that you create in the Texture manager (see 
“Texture manager,” page 15.22).

To apply texture inks
Make sure you select either the Pen or Fill ink icon on the Presets 
palette.

• If object is selected, click on the texture ink cell.

• If object is not selected, click on the texture ink cell and 
drag the ink to the object.

See “Applying preset inks,” page 15.4, for complete steps about 
applying inks.

To create texture inks
You can create a texture ink from any image object.

1 Before creating a texture ink, deselect any objects by pressing 
Esc.

2 Open the Texture manager and click the Create button. A 
prompt appears when you move the cursor into the layout area.

3 Click on the image object that you will use in the texture ink.

Note: If you want to use text or vector objects in a texture ink, you 
must render them first. Also, if you want to use more than one 
image object, you must select them all or group them and then ren-
der them to create one image object.

4 Adjust the settings for the texture ink in the Texture man-
ager (see “Spacing and position settings,” page 15.22).

5 Click the Add Preset button to add it to the texture inks in 
the Presets palette.

Tip
If you create a new ink in the Sym-
bol manager, click the Add Preset 
button to add it to the Presets pal-
ette.
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Working with Pattern inks
In technical illustrations, pattern inks are often used to provide a 
visual representation of the different components of a project. Can-
vas gives you the ablity to create your own personal set of patterns. 

All pattern inks are bicolor 72 dpi bitmap representations with a 
fixed size of 8 x 8 pixels. Apply pattern inks to text, vector, and 
image objects. 

Click on the Pattern ink icon to open the pattern inks. Use the Pre-
sets to apply preset pattern inks to objects or store customized pat-

Texture manager

When creating a texture ink, you can 
set the spacing and offset of image cells 
and choose a background ink.

A Preview. Displays the texture ink. 
Any changes you make are reflected in 
the Preview area.
B Backdrop. Choose a background 
ink in the pop-up palette. The ink ap-
pears only in gaps between the image 
cells.
C Preview zoom. Click the left button 
to reduce or the right button to enlarge 
the preview.

Spacing and position settings

Spacing. Enter the amount of space 
between cells as a percentage of the 
cell size. X Spacing is the space 
between columns; Y Spacing is the 
space between the rows of cells.

Stagger. Select the horizontal but-
ton (left) or vertical button (right) 
and enter the distance (as a per-
centage of cell size) to shift the cells.

Align To Object. Turn on this option 
to keep a texture in the same posi-
tion if the object moves. Turn it off 
to let overlapping objects share a 
texture without a gap.

The use of patterns in a technical 
illustration
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tern inks that you create in the Pattern manager (see “Pattern 
manager,” page 15.23).

To apply pattern inks
Make sure you select either the Pen or Fill ink icon on the Presets 
palette.

• If object is selected, click on the pattern ink cell.

• If object is not selected, click on the pattern ink cell and 
drag the ink to the object.

See “Applying preset inks,” page 15.4, for complete steps about 
applying inks.

To create or pattern inks
All pattern inks are created or modified in the Pattern manager. 
You can access the Pattern manager via the Attributes palette when 
you click on the pattern ink icon.

Applying inks to objects
You can apply inks to two areas of vector objects and text: Fill inks 
cover the interior of objects and text characters. Pen inks cover the 
strokes of objects and text characters. Objects can have different 
inks for a fill ink and a pen ink; e.g., a gradient fill and a pattern pen 
ink. In addition, you can apply inks to the backgrounds, outlines, 
and frame of text objects .

Tip
If you create a new ink in the Pat-
tern manager, click the Add Preset 
button to add it to the Presets pal-
ette.

Pattern manager
A Pencil tool. Color the cells within 
the Edit box.
B Move tool. Click within the Edit box 
to see other parts of the pattern.
C Switch Background and Fore-
ground colors Click this button to switch 
the colors.
D Edit box. Create and modify pat-
terns in this box. Changes appear in the 
Preview box.
E Preview box. Patterns are displayed 
in this box while being modified.
F Background and Foreground color. 
Choose foreground and background 

colors from a color palette or cre-
ate a custom color (see “Color Ed-
itor dialog box,” page 15.10).
G Grayscale slider. Increase 
grayscale to use more foreground 
or decrease it to use more back-
ground.

Add Preset. Click this button to 
add the new ink to the Presets 
palette.

Tip
If an object has neither a pen ink 
nor a fill ink, the object is not visi-
ble.
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Remember that you don’t apply inks to paint objects. Instead, use 
painting tools to paint in a paint object and give it color (see “Paint-
ing & image-editing,” page 23.1).

Applying fill inks to open and closed paths
Whether a vector object path is open or closed affects the appear-
ance of its fill ink. In a closed path, the ink completely fills the 
object’s interior; in an open path, the ink fills inside the path as if 
the path were closed by a straight segment between its endpoints.

Default and current inks 
By default, Canvas applies white fill ink, black pen ink, and a 1-
point stroke to new vector objects. For new text objects, Canvas 
applies black fill ink, no pen ink, and no stroke to the text charac-
ters. 

The current inks are the inks that Canvas applies to new vector 
objects you draw. The squares in the pen ink and fill ink icons in 
the Toolbox display the current inks. When you apply inks to exist-
ing objects, the current inks do not change.

• To change the current pen or fill ink: Make sure no objects are 
selected in the document, then press the pen ink or fill ink icon to 
select a current ink from one of the Inks palette.

Using the Color Dropper
Use the Color Dropper tool to select and apply colors. The Color 
Dropper tool is located in the Objects tool palette (see “Tool pal-
ettes,” page 10.6). The Color Dropper can select colors from any 
object in a document.

This object has a pen ink and a fill 
ink; both are basic color inks.

Pen ink

Fill ink

This object has a pen ink but no fill 
ink, so the rectangle in back is visible 
through it.

This path has a pen ink and 
no fill ink.

The path above has a pen ink 
and a fill ink.

Current pen ink

Current fill ink

Color Dropper tool
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Colors you select with the Color Dropper become the current fore-
ground or background colors for painting and the current pen inks 
and fill inks for new vector objects.

The Color Dropper has two modes, Object Ink and Pixel Color (see 
“Color Dropper modes” on page 15.25).

Color Dropper modes
Select the Color Dropper tool to view the settings in the Properties 
bar. Select a mode. The mode remains set unless you change the 
setting in the Properties bar.

Object Ink
In vector or text objects, the Color Dropper selects object inks —
color, gradient, symbol, texture, pattern, and hatch inks. It does not 
take into account transfer modes or transparency effects.

If you click an object’s stroke, you select its pen ink; if you click an 
object’s interior, you select its fill ink. In the case of paint objects, 
which do not have inks, the color you click is selected as a color ink. 

For example, if you click a gradient ink with the Color Dropper, it 
selects the gradient ink. 

In paint objects, paint colors are selected, not colors you see due to 
transfer modes, channel masks, or other transparency effects; i.e., if 
you click a black area that is 50% transparent, you select solid black.

Pixel Color
This mode works the same whether you click a paint, vector, or text 
object. The color of the pixel is selected. The Color manager in the 
Attributes palette indicates the color values. 

Color mode Select RGB, CMYK, or Grayscale. The Color Drop-
per converts any color you click to the selected color system. For 
best performance, choose the color system that matches the colors 
you are sampling; however, you may want to select a color system 
that differs from an image. You might do this to see the effect of a 
color conversion, such as RGB to CMYK for printing, for example.

Tip
This tool helps keep color consis-
tency within a document and is 
useful for photo retouching. It can 
also help identify colors from doc-
uments imported into Canvas. 

Object Ink mode Selected ink

Pixel Color mode Selected color
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To select an ink (Object Ink mode)
1 Select the Color Dropper tool.

2 Select Object Ink for the mode in the Properties bar.

3 Do one of the following:

• To set the fill ink: Click an ink to make it the current fill ink. 
You can click a pen ink or a fill ink; in either case, the ink you click 
becomes the current fill ink.

• To set the pen ink: Option-click (Mac) or right-click (Windows) 
an ink to make it the current pen ink. You can click a pen ink or a 
fill ink; in either case, the ink you click becomes the current pen 
ink.

To select a color (Pixel Color mode)
1 Select the Color Dropper tool.

2 Select Pixel Color for the mode in the Properties bar. 

3 Click a color to set the current fill ink color (vector and text 
objects) and background color (image objects). Option-click (Mac) 
or right-click (Windows) to set the current pen ink color (vector 
and text objects) and foreground color (image objects).

To select colors outside Canvas
With the Color Dropper selected, drag from the Canvas window to 
anywhere on screen. As long as you keep the mouse button pressed, 
the Color Dropper remains active; the ink icons in the Toolbox 
show you the colors the tool can select. Release the mouse button to 
select the color under the tip of the pointer.

The color you select becomes the current fill ink and background 
color. You can’t use this method to select the pen color.

To apply colors to vector and text objects
Apply current inks to vector objects and text with the Color Drop-
per. This technique makes it easy to quickly transfer inks from one 
object to another. 

Tip
While editing an image with a 
painting tool, you can quickly 
switch to the Color Dropper. Press 
Option (Mac) or Alt (Windows) to 
display the Color Dropper, and 
click to select a foreground color 
for painting.
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Mac Control-click a vector or text object to apply the current fill 
ink to the object. Control+Option-click to apply the current pen ink 
to the object.

Windows Ctrl-click a vector or text object to apply the current fill 
ink to the object. Ctrl-right-click to apply the current pen ink to the 
object.

Getting inks from vector and text objects
Canvas lets you add inks from vector objects and text objects to the 
Presets palette. If a text object contains both a text fill and a back-
ground fill, only the text fill will be added to the palette. You can 
also add the inks of multiple selected objects; however, the inks 
from group objects and macro objects cannot be added. 

To add inks from objects to the Presets palette
1 Select either the pen ink or fill ink icon on the Presets palette, 
depending on the type of ink you want to add

2 Drag the vector or text object onto the preset inks area of the 
appropriate ink type in the Presets palette; i.e., gradient inks only 
apply to the gradient ink type, hatch inks to the hatch ink type, 
etc.

Replacing ink attributes
Canvas has a quick way to change all instances of a selected ink in a 
single document: the Replace Ink Attributes command. This func-
tion can be applied to pen and fill inks for both vector and text 
objects.

To replace an ink
1 Choose Edit > Replace Ink Attributes. The Replace Ink dia-
log box opens with the document’s currently used inks located at 
the top.

2 Select the ink that you want to replace.

3 Click on the Bucket icon and the Presets palette pops out 
with the six ink types available (see “Applying preset inks” on 
page 15.4).

4 Select a replacement ink from one of the ink types. You can 
even specify “no ink”.

5 Repeat this procedure to replace any other inks.

Tip
The Color Dropper mode does not 
affect the application of colors. 
Also, you cannot apply colors to 
paint objects using the Color 
Dropper tool.
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6 Click OK to close the dialog box.

1 Select an ink at the top of the 
Replace Ink dialog box.

Note: A slash line indicates “no 
ink”.

2 Click the Bucket icon to open 
the Presets palette. 

3 Choose the replacement ink. 
You can use any ink type or even 
“no ink”.

4 Click OK.

Add Presets. Click this button to 
add a used ink to the Presets pal-
ette.

Ink 
types

Inks used in documentBucket icon
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Chapter

16
STROKES: OUTLINE EFFECTS

When you create objects with drawing tools, Canvas applies a 
stroke to the objects according to attributes set in the Presets pal-
ette. A stroke is a line centered on the path of vector objects and the 
outlines of type. You can shape a stroke with standard and calli-
graphic pens, parallel lines, even neon tubes. You can also add 
dashes and arrowheads to strokes.

This chapter explains basic stroke settings, how to customize 
strokes, and how to apply strokes to objects and text.

Types of strokes
Canvas has three basic types of strokes plus arrows and dashes, 
which you can use to create unlimited variations. The following 
types of strokes appear on Pens tab of the Presets palette.

Standard Strokes made of a single line. You can specify the width, 
type of line joins, and shape of end caps. 

Calligraphic Strokes that have a weight, width, and angle.

Parallel Strokes made of two or more lines. You can specify width, 
dashes, colors, and spacing.

Neon Strokes shaded like glowing tubes. You can specify width, 
colors, tube shape, line joins, and end caps.

Arrows and dashes can be applied to strokes for additional effects. 
Click on the Dash tab or Arrows tab in the Presets palette to apply 
these to a stroke.

Arrow You can use preset or custom arrowheads that appear at the 
endpoints of each path segment. 

Dash You can apply preset or custom dash sequences that divide 
solid strokes into solid and blank segments.

How inks affect strokes
You define the colors that apply to strokes separately from the pen 
stroke settings. The pen ink (specified in the Presets palette) and the 
pen stroke settings together produce the appearance of an object’s 
outline. The pen ink is the color (or pattern) that “paints” the 

Pen

Parallel 

Neon

Arrow

Dash
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object’s stroke. Therefore, the object must have a visible pen ink for 
the stroke to be visible. Conversely, the object must have a stroke 
for the pen ink to be visible. 

Some inks can make strokes invisible. If the pen ink is set to “no 
ink,” the stroke won’t be visible. Also, if the pen ink is set to white 
or a color that matches the background, the stroke could disappear 
against the background.

Current stroke
The Strokes icon in the Toolbox shows a sample of the current stroke, 
the stroke that Canvas applies to new vector objects you create. For 
example, if the current pen stroke is 3 points wide, new objects you 
draw will have a 3-pt pen stroke. Canvas does not apply the current 
stroke to text (see “Applying strokes to text,” page 16.2).

To change the current stroke, deselect all objects and apply the 
stroke you want; the stroke icon in the Toolbox shows the new cur-
rent stroke. If you select an object and change its stroke, however, 
the current stroke for new objects does not change. 

When you first install Canvas, the current stroke defaults to a 1-pt 
pen stroke without dashes or arrowheads.

Applying strokes to text
You can apply strokes to text the same as to vector objects, in most 
cases. For information about selecting text objects and text charac-
ters, see “Formatting text,” page 30.1 and “Formatting text with the 
Properties bar,” page 30.5).

When you first type or import text into a document, Canvas applies 
a black 1-point pen stroke to the text, but does not assign a fill ink. 
You can apply pen, parallel, and neon strokes to text. You can also 
apply dashes to text that has a pen or neon stroke. If you select a 
text object, Canvas applies a stroke to all the text it contains. If you 
select specific characters within a text object, Canvas applies the 
stroke to those characters only.

Strokes icon
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Note: The appearance of a parallel stroke applied to text might not 
appear as you expect, especially on characters with hollow centers 
(such as “O” and “P”) and characters with tight corners or paths 
that meet or cross (including “G” and “X”).

Removing a neon or parallel stroke from text (by choosing “no 
stroke”) does not remove the stroke entirely. Instead, the stroke 
reverts to a black 1-pt pen stroke.

Applying preset strokes
Using presets can help you save time and ensure graphic consis-
tency. Presets for standard, callagraphic, parallel, and neon strokes 
are displayed when you select the respective stroke type icon in the 
Presets palette. Also select the Dash or Arrow tab in the Presets pal-
ette to view the presets for these attributes. 

Using the Presets palette
The Presets palette contains preset strokes and attributes that you 
can apply to objects and the current stroke.

Use the Presets palette to apply strokes to objects and save strokes 
in files that you can later load into the palette.

• To open the Presets palette: Click on the Strokes icon in the 
Toolbox to pop open the palette. Drag it away to see the entire pal-
ette. You can also choose Window > Palettes > Presets.

Four icons are located at the top of the Pens tab, which you click to 
access the available stroke types: standard, calligraphic, neon, and 
parallel. The circular icon with a diagonal line represents “no 
stroke”. For dashes and arrows, click on their respective tabs in the 
palette.

Calligraphic pen stroke Neon stroke
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Deleting strokes and stroke attributes
You can remove default and custom presets from the Presets pal-
ette. When you delete a preset, Canvas permanently removes it 
from the palette, unless you save it to disk and load it again; see 
“Saving and loading strokes settings,” page 16.4

• To remove a preset from the Presets palette: Select the stroke 
type or stroke attribute and drag it to the trash can icon. The trash 
can appears only when the Presets palette is floating or docked on 
the Docking bar.

To remove all preset strokes or stroke attributes
1 Select the stroke type or stroke attribute in the Presets pal-
ette. 

2 Open the palette menu and choose Clear Palette Strokes.

Note: If you delete all arrowheads from the palette, dimension 
objects will not have arrows.

Saving and loading strokes settings
You can save preset strokes, arrows, and dashes in files on disk, and 
load the presets into the Presets palette. You can use these strokes 
files to customize the Presets palette for particular projects or types 
of documents, and to exchange custom settings with other Canvas 
users.

Preset pens 

Palette menu

No strokePen stroke 
types

Click to 
modify 
selected pen

Recently used pens
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Commands for saving and loading strokes files are in a pop-up 
menu on the Presets palette. The menu icon appears only when the 
Presets palette is separated from the Toolbox.

To save strokes in a file
Use the following procedure to save the presets from one stroke 
type or stroke attribute in the Presets palette to a file on disk.

1 Open the Presets palette

2 Click the Pens tab and select the stroke type. Or click on the 
Arrow or Dash tab for a stroke attribute. 

3 Open the palette menu and select Save ... Strokes. The menu 
command will reflect the selected stroke type or stroke attribute. 
A directory dialog box opens. 

4 Enter a name for the file, select a location on a disk, and click 
Save.

To load strokes from a file
Use the following procedure to load stroke types or stroke attributes 
that are stored in a file. When you load a file, you can either replace 
the strokes that are presently in the Presets palette or simply 
append the stroke types or stroke attributes to the current ones.

1 Open the Presets palette

2 Click the Pens tab and select the stroke type. Or click on the 
Arrow or Dash tab for a stroke attribute. 

3 Open the palette menu and select Load ... Strokes. The menu 
command will reflect the selected stroke type or stroke attribute. 
A directory dialog box opens. 

4 Navigate to the file and click Open.

To apply preset strokes to objects
Use the following general procedure to apply a preset stroke to one 
or more objects.

1 Select the objects for which you want to change strokes.

2 Press the Strokes icon in the Toolbox to open the Presets pal-
ette. The Pens tab will be selected automatically. 

3 Select the stroke type (standard, calligraphic, neon, or paral-
lel). 
Applying preset strokes 16.5



16
4 Choose a stroke in the preset strokes list. If necessary, use the 
scroll bar or window resize button to view additional strokes. Can-
vas applies the stroke you choose to selected objects.

To make a preset stroke the current stroke
Select a preset stroke as the current stroke to apply to new objects 
you create.

1 Deselect all objects in the current document. To deselect all 
objects, press Enter (Mac) or Esc (Windows) a few times.

2 Press the Strokes icon in the Toolbox to open the Presets pal-
ette. The Pens tab will be selected automatically.

3 Select the stroke type (standard, calligraphic, neon, or paral-
lel).

4 Choose a stroke in the preset strokes list. Use the scroll bar to 
view additional strokes. The Strokes icon in the Toolbox shows 
the current stroke.

Using standard pen strokes
The most common type of stroke is a standard pen stroke, a solid 
line of uniform width. This type of stroke is used for many situa-
tions, such as technical illustrations, flowcharts, callout lines, etc.

By default, the width of pen strokes is measured in points (one 
point is 1/72 inch). Pen stroke widths from 1 to 16 points appear in 
the Pens tab of the Presets palette.

To change the current pen stroke width
1 Deselect all objects. 

2 Open the Presets palette and click on the Pens tab. 

3 Select standard as the stroke type and choose a new pen 
stroke width from the presets list. 

• To change the pen stroke width of specific objects: Select one or 
more objects, then select a new pen stroke from the presets list for 
standard strokes.

To change the ink of a pen stroke
The color of a pen stroke comes from the object’s pen ink. The pen 
ink can any of the available ink types; i.e., gradient, pattern, symbol, 
color, hatch, or texture.
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1 Select one or more objects whose pen ink you want to change.

2 Press the Pen Ink icon in the Toolbox. The Presets palette 
pops open with the Inks tab selected. Drag this palette away from 
the Toolbox to keep the Presets palette open as you work.

3 Select an ink type on the Inks tab; e.g., color, gradient, hatch, 
symbol, pattern, or texture (see “Inks: colors & patterns” on 
page 15.1).

‘Invisible’ inks
A pen ink is one or more colors that Canvas uses to apply color to 
pen strokes. The pen ink can be set to “no ink,” or to a color that 
blends into the background, which renders a pen stroke invisible.

In some situations, you might want to set an object’s pen ink to “no 
ink,” rather than remove the object’s stroke. This can be useful to 
temporarily hide the stroke without removing the dash, arrow, and 
other stroke settings, for example. 

To set an object’s pen ink to “no ink”
This procedure removes the pen ink and makes the stroke invisible. 

1 Select the object and press the Pen Ink icon to open the Pre-
sets palette with the Inks tab selected.

2 Click on the “no ink” icon to the right of the ink types. It is a 
circle crossed by a diagonal line.

Adding preset arrows to pen strokes
You can add preset arrowheads to pen, parallel, and neon strokes. 
You can apply strokes with arrows to lines and open paths, such as 
those created with the Curve tool. Arrowheads can appear at one or 
both endpoints of a path. 

You can also create custom arrowheads that you can add to the pre-
set arrowheads (see “Creating custom arrowheads” on page 16.17).

“No ink” setting
Applying preset strokes 16.7



16
To add arrows to strokes
Use the following procedure to apply preset arrows to objects or the 
current stroke:

1 Depending on how you want arrows to apply, do one of the 
following:

• To add an arrow to the current stroke: Deselect all objects.

• To add arrows to specific objects’ strokes: Select the objects. 

2 Press the Strokes icon in the Toolbox to open the Presets pal-
ette and select the Arrow tab. 

3 The arrow icons at the bottom of the tab let you choose 
between starting, ending, and double-sided arrowheads. 

• To select a starting or ending arrowhead: Click either side of the 
icon. The left or right arrow icon will be highlighted. 

• To select a double-sided arrowhead: Click the round button in 
the middle. Both the left and right arrow icons are highlighted. The 
arrows in the scroll list preview the selected arrowhead.

4 In the scroll list, choose the arrow that you want to apply. The 
arrow applies to selected objects or to the current stroke.

Adding dashes to strokes
You can add a variety of preset dash sequences to pen and neon 
strokes. You can apply a stroke with dashes to most objects, includ-
ing lines, open and closed Bézier curves, polygons, rectangles, 
ovals, and stars.

Parallel line strokes can also include dashes. However, you select 
dashes for parallel lines when you customize the stroke in the Paral-
lel stroke manager in the Attributes palette (see “Customizing par-
allel line strokes” on page 16.15).

To add dashes to pen and neon strokes
1 Depending on how you want dashes to apply, do one of the 
following:

• To apply dashes to the current stroke, deselect all objects.

Starting arrow Ending arrow Double-sided
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• To apply dashes to an object that has a pen or neon stroke, 
select the object.

2 Press the Strokes icon in the Toolbox to open the Presets pal-
ette. Select the Dash tab. 

3 Choose the dash sequence that you want in the list of presets.

Removing arrows, dashes, and strokes
You can remove a selected object’s stroke, or set the current stroke 
to “no stroke,” so you can create objects that have no stroke. An 
object that has no stroke has no visible outline. Objects drawn with 
the Line tool become invisible without a stroke; other objects are 
still visible if they have a visible fill ink. 

You can also remove dashes and arrows from a stroke. Because 
arrows and dashes are attributes of strokes, you can remove them 
without removing the entire stroke. 

Removing arrows, dashes, and strokes involves the same procedure 
as changing from one preset stroke to another.

To remove arrows or dashes
You can use the following procedure to remove arrows from pen, 
parallel, and neon strokes, and to remove dashes from pen and 
neon strokes. For details about removing dashes from parallel 
strokes, see “Customizing parallel line strokes” on page 16.15.

1 Depending on how you want to remove arrows or dashes, do 
one of the following:

• To remove stroke attributes from an object: Select the object. 

• To remove stroke attributes from the current stroke: Deselect all 
objects.

2 Press the Strokes icon in the Toolbox to open the Presets pal-
ette. Choose the Dash or Arrow tab, depending on the attribute 
you want to remove.

3 Choose “no arrow” on the Arrow tab to remove arrows from 
a stroke. Choose “no dash” on the Dash tab to remove dashes.

To use “no stroke” settings
Remove strokes entirely from objects, or use “no stroke” as the cur-
rent setting for new objects.
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1 Depending on how you want to remove strokes, do one of the 
following:

• To remove the stroke from an object: Select the object. 

• To make “no stroke” the current setting: Deselect all objects.

2 Press the Strokes icon in the Toolbox and choose “no stroke” 
on the Pens tab.

Applying tapered ends to standard and neon strokes
This option can be applied to standard pen strokes and neon 
strokes; however, it is best viewed when a pen setting is larger than 
3.00 pt.

To apply tapered ends to strokes
1 Depending on how you want to apply tapered ends, do one of 
the following:

• To add tapered ends to an object: Select the object.

• To add tapered ends to the current stroke: Deselect all objects.

2 Click on the Strokes icon in the Toolbox to open the Presets 
palette. 

3 Click on the Pen tab and select either standard pen stroke or 
neon stroke.

4 Select a preset pen stroke and then click the Edit button to 
open the respective manager in the Attributes palette.

Neon stroke with tapered corners
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Customizing strokes
Each stroke type and stroke attribute (arrows and dashes) in the 
Presets palette has its respective manager in the Attributes palette. 

Use the managers to

• display the strokes settings of selected objects

• create custom pen, parallel, calligraphic, and neon strokes

• create custom arrowheads and dash sequences

• apply custom settings to objects or the current stroke

• store custom strokes as presets in the palette

Using the Attributes palette
You can open the Attributes palette by clicking the Stroke icon in 
the Toolbox to open the Preset palette. Then click the Edit button. 
You can also choose Window > Palettes > Attributes. 

Select the stroke type or stroke attribute that you want to define. Its 
respective manager comes to the front.

• To customize an object’s stroke: Select the object and open the 
Attributes palette. The appropriate manager comes to the front.

In the Neon Stroke 
manager, open the 
Corners menu and 
select Tapered. 
Both ends of the 
stroke will be 
tapered.

Use the Tapered 
End controls in 
the Standard Pen 
Stroke manager.

Select from no 
taper, end-to-end 
taper, left taper, 
and right taper.
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• To use a preset stroke as the basis for a custom setting: Apply 
the preset to an object and then select the object. Open the 
Attributes palette. The stroke settings are indicated in the appropri-
ate manager. You can also simply choose the preset in the scroll list; 
however, this also changes the current stroke or the stroke of any 
selected objects.

If you adjust the settings in a manager, and then select an object, 
the settings will change to reflect the object’s settings. If you don’t 
want to lose custom settings when no objects are selected, add them 
to the Presets palette (see “To add custom settings to the Presets 
palette,” page 16.12.

To add custom settings to the Presets palette
You can add custom strokes, arrows, and dashes to the Presets pal-
ette. When you add custom items, they become presets that you can 
use the same as default preset items. You can apply a customized 
preset to objects or make it the current stroke.

• To add custom settings from the Attributes palette: Click the 
Add Preset button. The new stroke or stroke attribute is added to 
the appropriate stroke type or tab in the Presets palette.

• To add settings from an object to the palette: Select the object. 
The respective stroke type manager or stroke attribute tab opens in 
the Attributes palette. Click the Add Preset button.

When you end a Canvas session, the program stores each stroke 
type’s or stroke attribute’s presets with the program. Because Can-
vas stores the preset strokes and inks, the same presets can always 
be available, whether you work with new documents, documents 
you created, or documents created by another Canvas user.

If you create a custom stroke and want to apply it to more than one 
object, and especially if you want to use it in a later work session, 
you should add the custom settings to the Presets palette.

Customizing standard & calligraphic pen strokes
If you want to create custom standard pen or calligraphic strokes, 
use the respective manager in the Attributes palette. 

Standard pen strokes have a uniform weight, specified offset, and 
may have tapered ends. Calligraphic pen strokes have a separate 
width, weight, and angle setting. For both stroke types, you can 

Click this button to add a stroke or 
stroke attribute to the Presets 
palette. 
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define the line joins (bevel, miter, or round) and end caps (flat, 
round, or square).

For basic information about setting pen size, see “Using standard 
pen strokes” on page 16.6.

To create a standard pen
1 Click on the Pens tab of the Attributes palette.

2 Select the standard pen stroke type to access its respective 
manager. 

3 Use the standard stroke manager controls to define the new 
stroke.

4 Click the Add Preset button to add this new stroke to the Pre-
sets palette.

Tip
You can choose another unit of 
measurement instead of points as 
the pen size unit using the unit 
menu in the Attributes palette.

Standard pen stroke controls

Use these options to define standard 
strokes.

A Weight. Enter the weight of the 
pen stroke. Strokes are normally de-
fined in points but you can select anoth-
er unit of measurement from the menu.
B Tapered End. Select either no 
taper, end-to-end taper, left taper, or 
right taper.
C Offset. Select above path, center of 
path, or below path.

D Cap. Select an endcap: flat, round, 
or square.
E Join. Select a line join style: miter, 
round, or bevel. 

Miter Limit. This setting is measured 
in degrees. The miter limit indicates 
which corners are too tight to miter so 
Canvas will bevel them instead.
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To create a calligraphic pen
The calligraphic manager lets you create a stroke with a custom 
weight, width, and angle.

1 Enter a value in the Weight field or drag the blue arrows in 
the edit box. The Weight refers to the thickness of the stroke.

2 Enter a value in the Width field or drag the red arrow in the 
edit box. The Width refers to the thinnest part of the stroke. The 
Width should differ from the Weight.

3 Enter a value (in degrees) in the Angle field. You can also 
adjust the angle by moving the blue arrows or red arrows in a cir-
cular motion. Typically, the angle is set to 45 degrees. 

4 Select endcaps and line joins for the pen stroke. For an expla-
nation of the various cap and join choices, see “Standard pen 
stroke controls,” page 16.13.

5 Click Add Preset when you are completed.

Choosing line joins and end caps
For standard pen strokes and calligraphic strokes, you can specify 
the type of line joins and end caps. Line joins determine the appear-
ance of two path segments that meet at a corner. End caps specify 
the shape of the endpoints of an open path.

Line joins
Canvas has three types of line joins: miter, round, and bevel. For 
preset pen strokes, Canvas indicates the type of line join in the 
respective manager in the Attributes palette.

Miter Joins path segments with sharp corners that extend to a sin-
gle point. When you choose miter joins, the Miter Limit field is 
enabled. Enter the miter limit in degrees (5, 10, 30, 60, or 90 
degrees). 

The miter limit setting tells Canvas which corners are too tight to 
miter; Canvas bevels these corners instead; i.e., if the miter limit is 
set to 10°, and two path segments join at an angle of 9°, Canvas bev-

Weight

Width

Calligraphic pen stroke
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els the corner rather than creating a miter join. The miter limit lets 
you prevent long, spiked corners that might result as a combination 
of a wide pen size and a small angle.

Round Smooths corners, so the joint is rounded instead of pointed 
or flat. 

Bevel Squares off path segment corners, so that the joint appears 
flat rather than rounded or pointed.

End caps
Canvas has three types of end caps. For preset pen strokes, Canvas 
indicates the type of end cap in the respective manager in the 
Attributes palette..

Flat The end of the stroke is flush and square with the end of an 
open path or dash. By default, end caps use this setting.

Round A semi-circular cap extends half the pen width beyond the 
endpoint of an open path or dash.

Square The stroke tip is square, similar to the Flat option, but 
extends half the line width beyond the endpoint, like the Round 
option.

Customizing parallel line strokes
You can create custom parallel line strokes using the Parallel man-
ager in the Attributes palette. Specify the number of lines, color, 
dash pattern, and pen size of each line, and line spacing.

To create custom parallel line strokes
1 Open the Attributes palette, if necessary. 

2 Click the Pens tab. 

Round joinBevel joinMiter join, miter limit = 2° Miter join, miter limit = 10°

Flush with endpoint

Rounded at endpoint

Square at endpoint
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3 Select the Parallel line as the stroke type. The Parallel man-
ager comes to the front.

Customizing neon strokes
You can create custom neon strokes using the Neon manager in the 
Attributes palette. Specify the width, colors, line joins, and end caps 
as well as create uniform and calligraphic neon strokes.

To create custom neon strokes
1 Open the Attributes palette and select the Pens tab. 

2 Select the Neon pen stroke type.

3 Use the Neon manager to define either a standard pen stroke 
or calligraphic stroke.

4 Select colors for the neon stroke from the pop-up palettes. 
Canvas blends these colors to create the neon effect.

Parallel manager

Use these controls to create parallel 
line pen strokes. 

A Enter the number of parallel lines 
for the stroke. The minimum and maxi-
mum are 2 and 12, respectively.
B Orientation. Specify the placement 
of parallel lines relative to the object’s 
path. Choose Center, Outside, or In-
side. 
C Line Attributes. Use these controls 
to define the appearance of the stroke.

Pen. Select a pen width from the pal-
ette.

Color. Select a color from the palette. 
You can also specify custom pen col-
ors (see“Accessing the Color Editor” 
on page 15.9).

Dash. Select a dash if you want the 
stroke to contain one.

Spacing. Enter a number to specify 
the distance between the selected line 
and the one below it. For Line #1, this 
setting defines the space between this 
line and Line #2.

D Choose a number from the menu 
to edit the line. Line #1 corresponds to 
the bottom line. You can also click a line 
in the edit box to select it. The selected 
line is indicated with handles.
E Equidistant. Turn on this option to 
apply the spacing setting for the select-
ed line to all lines.
F Use pen ink. Turn on this option to 
apply a color to the spaces between the 
parallel lines.
G Identical. Turn on this option to 
give all parallel lines the same appear-
ance (pen width, color, and dash).

Click the Add Preset button when you 
have finished defining the stroke.

Tip
To make the stroke appear round, 
experiment with lighter inside col-
ors and darker outside colors.
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Creating custom arrowheads
You can create arrowheads using the Arrow manager in the 
Attributes palette. These arrowheads can be used as starting, end-
ing, or double-sided arrowheads. Canvas has several preset arrow-
head styles that you can use and edit, or you can use any vector, 
paint, or text object as an arrowhead. 

To create an arrow
1 Click on the Arrow tab of the Attributes palette.

2 Select the arrow type (triangle, pie, diamond, circle, line, or 
custom) so you can access its respective manager. 

3 Use the arrow manager controls to define the new arrow. You 
can even modify the arrow within the edit box.

Neon stroke with square corners Neon stroke with tapered corners Neon stroke with round corners

Neon manager

Use these options to define a Neon 
pen stroke.

A Enter a value in the Weight field. 
The Weight refers to the thickness of 
the stroke.
B Enter a value in the Width field. 
The Width refers to the thinnest part of 
the stroke. For a standard stroke, the 
Width is equal to the Weight. For a cal-
ligraphic effect, the Width should differ 
from the Weight.
C Enter a value (in degrees) in the 
Angle field. For a calligraphic stroke, the 
angle is typically set to 45°. 

D Select the color for the exterior 
portion of the neon stroke.

Partial. Select this checkbox to give 
the stroke a gradient effect.

E Select the color for the interior 
portion of the neon stroke.
F Define the appearance of the 
stroke’s corners: Round, Square, or Ta-
pered.

Click the Add Preset button when you 
have finished defining the stroke.
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4 Click the Add Preset button to add this new arrow to the Pre-
sets palette.

To modify classic arrowheads
Classic arrowheads are triangle, pie, diamond, circle, and line. 
Select one of these from the type menu. Some options in the Arrow 
manager may not apply to the specified arrowhead.

Witness Select this checkbox to add an adjustable witness line to 
the end of the arrowhead.

Hollow Select this checkbox to remove the fill ink from the arrow-
head. 

Full Select this option to draw the complete arrowhead.

Top Select this option to only draw the top of the arrowhead.

Bottom Select this option to only draw the bottom of the arrow-
head.

Creating custom arrows

Use these options to create a custom 
arrow using a selected vector or text 
object.

A Select Custom from the menu.

Note: You can also customize existing 
arrows; however, the Arrow manager 
will have special controls depending 
on the arrow type selected.

B Edit box. Modify the arrowhead in 
this box. 
C Click the Create button and the ob-
ject appears in the edit box.

D Use these controls to select a right 
arrow, left arrow, or double-sided arrow. 
Click in the center for the double-sided 
option.

E Click the Add Preset button to 
add this new arrow to the Presets pal-
ette.
F Drag these control points to re-
size the arrowhead.
G Indicates the horizontal axis of 
the path’s endpoint.
H Indicates the vertical axis of the 
path’s endpoint.

Mimic Pen. Turn Size and Color on 
to apply the pen width and ink to the 
arrow.

Place on Segments. Turn this option 
on to add arrows to each segment of 
an object.

Flip. Click the buttons to flip the 
arrow horizontally and vertically.
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Customizing dashes
Dashes are composed of alternating solid and blank segments. 
Using the Dash manager, you can customize the length of up to 13 
segments to create new, complex dash sequences.

You can design dashes interactively using the edit window. To pre-
cisely set the length of each dash segment, you can also specify an 
exact length. The ruler in the Dash manager displays inches; how-
ever, you can enter dash lengths in any unit of measurement avail-
able.

Dashes in the Presets palette always appear as 1-point wide, black 
and white segments. However, when you apply these dashes to an 
object’s pen, the black segments adopt the color and size of the pen, 
and the white segments become transparent.

To create a dash 
1 Click on the Dash tab of the Attributes palette.

2 Use the dash manager controls to define the new dash. You 
can even modify the dash within the edit box.

3 Click the Add Preset button to add this new dash to the Pre-
sets palette.

Samples of classic arrows
A Triangle
B Pie
C Diamond
D Circle
E Line

Dash stroke
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Creating custom dashes

Use these options to create a custom 
dash for your stroke.

A Dash/Gap controls. Enter the size 
of the dashes and gaps in points.
B Proportional. Tells Canvas to scale 
the length of the segments to match the 
pen width of the object. The length of 
segments in the Dash manager are 
based on a 1-point line. Therefore, if the 
pen width is 6 points and Proportional 
is selected, Canvas multiplies the 
lengths by six.
C Preview box. Displays a sample of 
the dash.
D Use the Magnification controls to 
zoom in and out. To zoom out, click the 

left button. To zoom in, click the right 
button. Select the Magnification 
checkbox to enable the Magnification 
area. 
E To manually change the length of 
a dash, drag a dash editor. The select-
ed dash editor is highlighted. The 
dash/gap length is indicated in the 
Length box. 
F Shows the selected segment’s 
number (its order in the sequence) 
and its color. “Black” indicates it will 
use the pen ink. “White” means the 
segment will be transparent (a gap).
G Click the Add Preset button to 
add this new dash to the Presets pal-
ette.
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Chapter

17
WORKING WITH OBJECTS

This chapter explains how to work with objects in Canvas. It tells 
you how to select objects with selection tools or the Find command. 
It describes common actions, including how to copy, group, lock, 
move, arrange, flip, and align objects, plus effects you can apply to 
all objects, including scaling, rotation, and skew. It also tells you 
how to use the object position data in the Object Specs palette.

Types of objects
An object is a distinct item such as a circle, an image, or a para-
graph of text. There are different types of objects with unique prop-
erties, and some commands apply only to some types of objects. But 
objects in Canvas also share many properties. You can perform 
common operations, including selecting, moving, rotating, copying, 
and deleting, using the same methods for all types of objects.

The following object categories are used in Canvas:

Vector objects Geometric shapes such as lines, circles, rectangles, 
polygons, and smooth curves. Canvas defines them internally by 
formulas, and they print smoothly on all printers.

Paint objects Rectangular containers for pixel-based images, such 
as photos, screen captures, and scanned artwork. Each pixel that 
makes up an image has a color (or grayscale) value. 

Text objects Containers for text that can be formatted at the char-
acter and paragraph levels. Text objects can be empty or contain up 
to a page of text, and they can be linked together.

Group objects Collections of objects that have been united with 
the Group command. A group object can be made from more than 
one type of original object.

Selecting objects 
When you select an object, you distinguish it from other, unselected 
objects, so that when you choose a command or apply a color, Can-
vas knows to apply it to the selected object. In most cases, you select 
objects first, then apply a command or attribute. If you can’t apply 
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an attribute, or a command is not available, check to be sure you 
have correctly selected an object first.

Canvas provides several tools and commands for you to select 
objects. Use the most convenient method for each situation. The 
Selection tools are the primary object-selection tools. You can also 
use the Select All and Find commands to select objects (see “Selec-
tion options,” page 17.2” for a list of Selection tools and com-
mands).

In some cases, you can select parts of objects; e.g., you can select an 
anchor point within a vector object, a word within a text object, and 
an image area within a paint object. Selection techniques for vari-
ous types of objects are described in the drawing, text editing, and 
image editing sections of the manual.

Selection options

• To select all objects: Choose Edit > Select All to select every 
object in a single-layer document. To select all objects on all visible 
layers in a multi-layer document, change the default selection set-
ting in the Configuration Center (see “General settings,” page 13.2).

To select Do this

A single object Click the object with a Selection tool.

Multiple objects Shift-click each object with a Selection tool.

Objects using a selection box Drag a box around the objects with a Selection tool.

All objects touched by a selection box With a selection tool, press Option (Mac) or Ctrl (Windows) and drag out a box 
that touches the objects.

One object within a group object Click the object with the Direct Group Selection tool (hollow arrow).

No objects (deselect all objects) Click a Selection tool in a blank area, or press Enter (Mac) or Esc (Windows).

All objects Choose Edit > Select All.

An object behind another object Tab-click the object’s location until it is selected.

Unfilled object Click the object’s border, or press Tab and click inside the object.

An object on a layer other than the current 
layer, or an object on a master page

Tab-click the object with a Selection tool.

All objects created by a particular tool Select the tool, then choose Edit > Select All.

Objects based on their attributes Choose Edit > Find.
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Selection indicators
Canvas indicates that an object is selected by displaying the object’s 
bounding box. The bounding box is a rectangle with solid squares, 
called handles, at each corner and side midpoint. When an object is 
selected, its bounding box is visible even if it has attributes (the 
same color as the background, for example) that make the object 
itself invisible. Also, a selected object’s bounding box is visible even 
if it’s covered by other objects.

When one object is selected, Canvas displays the object type at the 
right end of the Status bar. When more than one object is selected, 
the Status bar shows the number of selected objects.

Selecting objects with Selection tools
The Selection tool (a filled arrow) selects any object you click. It is 
the default tool when you start Canvas. 

Selection tool Select this tool when you need to Select a single 
object. To select multiple objects, you can Shift-click. 

Direct Edit Selection tool This tool allows you to select all curve- 
edit points of an object in one step. Merely select this tool and then 
click on a vector object to place that object into edit mode.

Direct Group Selection tool Using this tool, you may select individ-
ual objects within a group without the need to ungroup the object.

Lasso Selection tool Select this tool and then encircle or “draw” a 
line around an object or series of objects. Doing this will select all of 
the objects that are touching the selection. You can also use this tool 
to select objects by simply drawing a line through them.

Direct Edit Lasso tool You can quickly edit any path point of an 
object by enclosing it with this tool. This feature places the object or 
objects into edit mode and highlights the edit points that fall inside 
the selection area drawn by the Direct Edit Lasso Tool. Likewise, 
you may also draw a line through an object to allow editing of a 
path point.

• To select one or multiple objects: With the Selection tool, click 
an object. To select multiple objects, Shift-click each object you 
want to select. For Windows only, you can also hold down the right 
mouse button and click multiple objects to select them.

A bounding box with handles 
surrounds a selected object

A Selection tool
B Direct Edit Selection tool
C Direct Group Selection tool
D Lasso Selection tool
E Direct Edit Lasso tool
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With the Selection tool, you can drag a selection box around 
objects to select them. Canvas selects all objects inside the selection 
box.

Editing objects
All types of objects in Canvas can be easily modified. In general, 
you place an object in edit mode to modify it. 

Edit mode lets you use various features to edit each type of object; 
e.g., when a text object is in edit mode, use word-processing features 
to select, cut, copy, paste, and edit text. When a vector object is in 
edit mode, you can modify anchor points and segments to reshape 
its path. When a paint object is in edit mode, you can use painting 
tools and commands to modify the image it contains. 

Some other objects, including spirals, EasyShapes, objects that have 
transparency masks, and SpriteEffects, have special editing modes 
(besides their standard edit modes); e.g., if you place a vector object 
in edit mode, you can edit the object’s path. If the object also has a 
transparency mask, you can edit its path in path edit mode, or use 
the Sprite tool to edit its transparency mask in mask edit mode.

• To place objects in edit mode: Select an object and choose 
Object > Edit > Object to place it in object edit mode or double-
click the object.

• To exit edit mode: Press the Esc key.

Selecting and editing objects with the context menu
Use the context menu to select an object or place an object in edit 
mode. The context menu can make it easier to select and edit 
objects that are covered by other objects. 

• To display the context menu: Either Control-click (Mac) or 
right-click (Windows) the object.

To select objects using the context menu
1 When no objects are selected or in edit mode, point to the 
object you want to select. If the object is hidden behind other 
objects, point to its location. 

2 Choose Select > Object Name in the context menu. Canvas 
selects the object whose name you choose in the Select submenu. 
Choose a vector, text, paint, or group object.
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To edit objects using the context menu
1 When no objects are selected or in edit mode, point to the 
object you want to edit. If the object is hidden behind other 
objects, point to its location. 

2 Choose Edit > Object Name in the context menu. Canvas 
places the object whose name you choose in the Edit submenu 
into edit mode. Choose a vector, text, or paint object.

Selecting objects based on their 
properties

Choose Edit > Find to select objects by 
type and attributes. 

In the Find palette, use the Objects tab 
to set up selection criteria.

A To select objects by type, check 
Type and choose an object type icon in 
the menu. Selecting text or paint objects 
makes Fill, Stroke, and Pen options un-
available.
B To select objects by fill or pen ink, 
check these boxes and choose the inks in 
the menus. Only inks used in the docu-
ment, plus process colors and white, ap-
pear in the menus.

To select objects by stroke, check 
Stroke and choose the stroke in the 
menu. Only strokes used in the docu-
ment appear in the menu.

To select objects by name, select 
Object Name. Type the name in the 
text box. Select Object # and type a 
number in the box to select an object 
by its number.

SpriteLayers: Use this option to select 
objects that have transparency effects.

SpriteEffects: Use this option to select 
objects (including lenses) that have 
SpriteEffects.

Lens Objects: Use this option to select 
objects that have been converted to 
lenses.

Group Level. Select a value from the 
menu if you wish to search in grouped 
objects.

Search all visible layers: To select 
objects in the current layer only, 
uncheck this option.

Add result to selection: Check to select 
additional objects without deselecting 
objects that are already selected.

Use Selected Object’s Attributes: 
When an object is selected, select this 
option to enter the object’s properties 
in the Objects tab.

Grab Attributes: Click to select objects 
based on the current settings.

Using selection sets

Click to expand the palette to 
work with selection sets, which let you 
broaden a search.

C Selection criteria symbols make up 
a selection set. The current selection set 
is boxed. Changing selection options up-
dates this selection set. Click a set to 
make it the current selection set.

Or: Click to create an empty selection 
set.

Copy: Click to duplicate the current 
selection set.

Clear: Click to delete the current selec-
tion set. With only one set, Clear is 
unavailable.
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Copying, cutting, pasting, and deleting objects
Once you select one or more objects, you can perform various basic 
editing functions. The following are the basic editing commands in 
the Edit menu:

Copying objects to the Clipboard
The Clipboard is a part of the system that temporarily stores 
selected objects when you choose the Copy or Cut command. The 
Clipboard stores the results of one editing action (which can 
include multiple objects). Whatever is on the Clipboard is replaced 
by the next selection you place there, including a selection placed 
by using the Cut or Copy command in another application. 

• You can bypass the Clipboard by using the Duplicate com-
mand to quickly copy a selected object in the same docu-
ment without replacing the Clipboard contents.

• Using the Clear command or the Delete keyboard key 
does not replace the contents of the Clipboard.

When you paste objects into other programs, the Clipboard uses a 
format that the receiving program understands. However, special 
types of objects and special object attributes can be lost when past-
ing objects into other applications. If you can’t transfer an object 
successfully using the Clipboard, consider using a compatible file 
format to import the object as a file into other programs.

Command Result

Copy Copies a selection to the Clipboard

Cut Removes a selection and places it on the Clipboard

Clear Removes a selection without changing the Clipboard

Duplicate Copies a selection into the same document without changing 
the Clipboard

Duplicate with 
Transform

Creates copies of objects that have been skewed, rotated, or 
offset.

Paste Places the Clipboard contents into the active document

Paste and Place Places the Clipboard contents into the active document with 
the upper-left corner at the point where you click

Tip
Display the contents of the Clip-
board (Mac only) by choosing 
Window > Palettes > Show Clip-
board. Choose Hide Clipboard to 
close the Clipboard window.
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Using Cut, Copy, and Paste commands
The Cut, Copy, and Paste commands let you make copies of 
objects using the Clipboard. Use Cut or Copy to place objects on 
the Clipboard, and then choose Paste to place copies in the same 
document, other open Canvas documents, and also into other pro-
grams.

You select one or more Canvas objects before choosing Cut or 
Copy. You can select text objects, paint objects, vector objects, spe-
cialized objects such as dimensions, and group objects. When you 
choose Cut or Copy, the selected items appear on the Clipboard. 

• The Cut command removes selections from the docu-
ment.

• The Copy command leaves selections in the document.

Using the Paste command to insert the Clipboard contents into a 
document does not erase the Clipboard. You can use Paste to insert 
the Clipboard contents as many times as you want. The Clipboard 
contents remain intact until you use the Copy or Cut command in 
any application to replace the Clipboard contents with a new selec-
tion.

To paste copied objects
1 Select the objects that you want to copy.

2 Choose Edit > Copy. Canvas puts the selected objects on the 
Clipboard.

3 If you want to paste the copied selection into another docu-
ment, switch to that document. You can switch to an open Canvas 
document by choosing its name at the bottom of the Window 
menu.

4 Choose Edit > Paste. Canvas pastes the Clipboard contents 
into the active document. Pasted objects appear selected in the 
center of the document window.

Options for copying objects
The Copy Options dialog box lets you select formats when you 
copy objects to the Clipboard. This command is useful when you 
want to copy a selection using a format that can be pasted into 
another program

Tip
These options have no effect when 
you paste selections in Canvas.
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You can select the program into which you want to paste objects. 
Canvas selects the best format for copying the selection to the Clip-
board. You can select common programs, such as Microsoft Word, 
Microsoft PowerPoint, and Microsoft Excel.

To use Copy Options
1 Select the items to copy and choose Edit > Copy Special > 
Copy Options.

2 Select options in the dialog box (see “Configuring copy 
options,” page 17.8).

3 Click OK and Canvas will copy the selection to the Clip-
board.

Configuring copy options

In the Copy Options dialog box, select 
a program or configure the options 
yourself.

Preset For. Choose a program name. 
This sets up the dialog box so objects 
will be copied in the best format for 
pasting into the selected program.

If the program you want to use is not 
listed, use the other options to select 
the format for copying objects to the 
Clipboard.

Copy vector object(s). Uses the stan-
dard format to copy objects to the clip-
board in Mac OS (PICT) and Windows 
(WMF). In most cases, this option is 
the same as using the standard Copy 
command. PICT and WMF do not sup-
port transparency; transparent Canvas 
objects are not rendered and will 
appear opaque when pasted into other 
programs.

Copy as Image. Copies objects to the 
Clipboard as rasterized images. Select 
a resolution option, or select Other and 
enter the desired resolution. This 
option preserves transparency effects 

among Canvas objects. However, most 
programs don’t support transparency, 
so Canvas objects pasted into other 
programs won’t appear transparent 
relative to objects in the other pro-
grams.

Anti-Alias Softens the edges of objects 
copied to the Clipboard. Anti-Alias is 
available when you select Copy as 
Image. 

Embed Canvas native data (Mac only). 
Embeds unique Canvas data in 
objects. This ensures that objects keep 
their Canvas properties if they’re past-
ed into another program and then 
pasted back into Canvas.

Embed EPS (Mac only). Copies 
objects to the Clipboard with Post-
Script information. Including Post-
Script information can enhance the 
quality of illustrations.

A Color Mode: Select the color 
mode to be used in the PostScript in-
formation.
B Transparency Rendering: Select a 
method for rendering SpriteLayer ef-
fects.

C Rendering Resolution: Select a 
standard resolution or enter the desired 
resolution in the text box.

Apply settings to normal copy com-
mand Applies the dialog box settings 
to the Copy command. When you 
select this option, you don’t have to 
choose Edit > Copy Special > Copy 
Options to use the same settings again.
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Special copy commands
Several commands let you perform special operations for copying 
objects to the Clipboard. To view these commands, choose Edit > 
Copy Special.

Copy with EPS (Mac)
Use the Copy with EPS command to include EPS information 
when you copy an object to the Clipboard. Including EPS informa-
tion can enhance the quality of illustrations. 

• To use the Copy with EPS command: Select the objects to copy. 
Choose Edit > Copy Special > Copy with EPS.

Copy as Image
When you want to copy an object, and then paste it into a docu-
ment created in another application, use the Copy as Image com-
mand to enhance the printed appearance of the Canvas object you 
intend to paste. This procedure can smooth out jagged edges and 
help maintain the object’s details. 

• To use the Copy as Image command: Select the objects you 
want to copy, and then choose Edit > Copy Special > Copy as 
Image. When you choose Edit > Copy Special > Copy as Image, 
Canvas places the selected objects on the Clipboard. Then use 
another application’s Paste command to place the Clipboard con-
tents into a document. 

Copy at 4X, Copy at 8X
Use the Copy at 4X command or Copy at 8X command to place 
vector objects on the Clipboard as rasterized objects at specific reso-
lution levels. You might want to do this if you are pasting Canvas 
vector objects into another program and the objects appear jagged 
when printed. This can happen when a program prints Canvas vec-
tor objects at the low resolution of the screen display.

The Copy at 4X and Copy at 8X commands place selected objects 
on the Clipboard at specific resolution levels: “4X” indicates resolu-
tion 4 times greater than screen resolution and “8X” indicates reso-
lution 8 times greater than screen resolution. 4X approximates the 
resolution of a 300 dpi printer; 8X approximates the resolution of a 
600 dpi printer. Choose the resolution level based on the printing 
device you are going to use. 

Tip
When copying and pasting within 
Canvas documents, these com-
mands perform the same function 
as the standard Copy command. 
Using these commands is not rec-
ommended for copying paint 
objects, which are already raster-
ized at a specific resolution.
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• To copy vector objects at increased resolution: Select the objects 
to copy and choose Edit > Copy Special > Copy At 4X or Edit > 
Copy Special > Copy at 8X. Canvas places the selected objects on 
the Clipboard. Then paste the Clipboard contents into other appli-
cations. 

Copying selections in objects
Besides using Cut or Copy to place entire objects on the Clipboard, 
use these commands to place selected parts of Canvas objects on 
the Clipboard. 

Cut or copy the following parts of objects:

• text selections made by highlighting text in a text object

• image selections made by defining areas, ranges of colors, 
or loading alpha channels in a paint object

• segment selections made by selecting anchor points of vec-
tor objects in path edit mode

Pasting selections and pasting into objects
When you paste a selection, the result depends on whether an 
object is in edit mode at the time: 

• Pasting with no object in edit mode creates a new, separate 
object containing the selection.

• Pasting with an object in edit mode usually pastes the 
selection into the object.

Using Paste doesn’t erase the
Clipboard; you can choose the
Paste command again to copy
the Clipboard contents as many
times as you want. However,
using the Copy or Cut command
in any application does replace
the Clipboard contents with a
new selection

Using Paste doesn’t erase the
Clipboard

Using Paste doesn’t erase the
Clipboard

A selection copied from an image (left) 
creates a selected object (right) when pasted 
into a document

A text object (bottom) results 
from pasting a copied text 
selection (top)

A selected vector object (top) 
results from pasting copied 
segments of a path

Vector object

Selected segments

Selection rectangle
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For example, if you copy a highlighted text selection, and then 
choose Paste when no object is in edit mode, you create a new text 
object containing only the text you selected. If you choose Paste 
when a text object is in edit mode, the pasted text appears at the 
insertion point in the text object. If you choose Paste when a paint 
object is in edit mode, the selected text appears as a floating image 
selection in the paint object.

Pasting into text You can paste text into a text object in edit mode. 
This lets you insert new text cut or copied from another object, and 
move text from one place to another while editing a text object.

Pasting pixels into images You can paste an image selection into a 
paint object in edit mode. The pixels that you paste become a float-
ing selection in the paint object.

Pasting objects into images You can paste a vector object or text 
into a paint object in edit mode. Canvas converts the object into 
pixels pasted as a floating selection in the paint object; i.e., Canvas 
rasterizes the Clipboard contents and then pastes an image selec-
tion into the paint object.

Pasting and placing objects You can use the Paste and Place com-
mand to copy objects and position the copies anywhere in the docu-
ment. Copy the objects to be pasted. Press Option (Mac) or Ctrl 
(Windows) and choose Edit > Paste and Place. You must press the 
modifier key to make this command appear.

To paste the copy, do one of the following:

• Click to place the copy at full size.

• To set the dimensions of the copy, drag to create a bound-
ign box to contain the selection.

Transferring object attributes
Transfer attributes from one object to other objects using the Paste 
Attributes command. Transferring attributes can help you main-
tain consistency between objects.

You can transfer attributes from a source selection — an object or 
text that has been copied to the Clipboard — to a target selection, 
which is one or more objects selected in the document. Or, you can 
retain the source selection attributes as the current attributes — 
those attributes that you can apply to new objects.

Tip
To copy an object and paste it in 
the same position on a different 
page, you can do so by copying the 
object and then pressing Shift and 
choosing Edit > Paste. 
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Use Paste Attributes to transfer inks and stroke settings, object 
dimensions, effects, and text attributes. 

Depending on the source selection and target selection, choose 
options listed in the Paste Attributes dialog box. 

An option is available if the attribute was copied from the source 
selection and can be applied to the selected target objects. The 
exception to this rule is the Text Style option. The Text Style 
option is available whenever the source selection is text, even if the 
target objects are not. In this case, no Text Style attributes will be 
applied to the target selection, but the Text Style attributes will be 
retained as the current attributes and can be applied to new text 
objects.

To paste attributes
1 Select an object or text whose attributes you want to transfer.

• If you select multiple objects, you can only paste the 
dimensions of a bounding rectangle encompassing all the 
objects.

• If you select a group object, only attributes that apply to 
the entire group, including the bounding box size and 
transformations applied to the group object, will be avail-
able.

• If you select a text object, only the attributes common to 
the entire object will be available.

2 Choose Edit > Copy to place the selection on the Clipboard.

3 Select the one or more target objects to receive the attributes. 
If no objects are selected, the source attributes will be retained as 
the current attributes and can be applied to new objects.

Attributes pasted on text objectText objectVector object
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4 Choose Edit > Paste Attributes. In the Paste Attributes dialog 
box, select the attributes to paste. Options that appear dimmed 
were not available in the source selection or cannot be applied to 
the target selection (see “Paste Attributes options,” page 17.13).

5 Click OK to paste the attributes.

Making multiple copies
Use the Copy and Paste commands to make multiple copies of 
selected objects through the Clipboard. If you want more control 
over placement, number of copies, scaling or rotation, use the 
Duplicate and Replicate commands to make multiple copies.

• With a selection on the Clipboard, choose Paste to insert 
the selection in the center of the active document’s current 
view. Repeat the Paste command to make multiple copies.

• The Duplicate command copies selections immediately 
and lets you space copies evenly. The Replicate command 
lets you scale, rotate, and offset multiple copies.

Paste Attributes options

Pen ink. Transfers the source selec-
tion’s pen ink. You can transfer pen 
inks if the source selection is a vector 
object or text that has a pen ink, and 
the target objects are vector or text 
objects.

Fill ink. Transfers the source selec-
tion’s fill ink. You can transfer fill inks 
if the source selection is a vector 
object or text that has a fill ink, and 
the target objects are vector or text 
objects. 

Stroke. Transfers the source selec-
tion’s stroke, including pen, dash, and 
arrow attributes. You can transfer 
strokes if the source selection is a 
vector object or text that has a stroke, 
and the target objects are vector or 
text objects.

Dimensions. Transfers the dimen-
sions of a rectangle “bounding box” 
that encompasses the source selec-
tion. You can transfer bounding box 

dimensions from any source object to 
any selected objects, but not to text 
selected within a text object. This 
makes all target objects the same size 
as the source.

If the source object has been rotated 
or skewed, you can transfer its origi-
nal dimensions by selecting Dimen-
sions. To transfer its transformed 
dimensions, select Transform.

Transform. Transfers rotation and 
skewing applied to the source selec-
tion’s bounding box. You can transfer 
these effects to any selected objects.

Transparency. Transfers the transpar-
ency effects applied to the source 
selection.

Text Style. Transfers certain text 
attributes from a text source selection 
to a text target selection: font, type 
size, text style (bold, italic, and so on), 
leading, kerning, and justification. 
You can transfer text attributes when 
a particular attribute is uniform in the 

source selection; e.g., if different 
kerning values are applied to charac-
ters in the source text, kerning will 
not be available for transfer to the tar-
get text.

SpriteEffects. Transfers filters and 
adjustments that have been applied 
with the SpriteEffects palette from 
the source to the target objects.
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Duplicating selections
The Duplicate command quickly copies selected objects into the 
same document, without affecting the contents of the Clipboard.

The Duplicate command offsets copies a preset distance horizon-
tally and vertically from the original. You can move the copy (with-
out deselecting it) to adjust the offset distance and direction and 
then repeat the Duplicate command to make more evenly-spaced 
copies.

You can change the Duplicate command’s preset offset values (see 
“Offset for duplicating objects” on page 13.10).

To duplicate and space copies evenly
1 Select one or more vector, text, paint, or group objects to 
copy.

2 Choose Edit > Duplicate. Canvas duplicates the selection and 
offsets the copy a preset distance from the original.

3 The copy must remain selected as you drag it or use the key-
board arrow keys to move it into position. The new position estab-
lishes the offset distance and direction from the original selection. 

4 Choose Edit > Duplicate again. Canvas creates the next copy 
using the offset defined from the original selection to the first 
copy. Repeat this step to create additional evenly-spaced copies.

Duplicated objects are offset a preset amount 
(gray circles). By moving the first copy and 
repeating Duplicate, you can set a custom off-
set distance and direction (light gray circles).

Original 
1

2

3

1

2

3

1st duplicate

Original 

2nd duplicate

Canvas offsets and stacks duplicates, placing 
the newest copy in front of the stack.
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To duplicate selected objects with modifier key
You can duplicate an object by pressing a modifier key as you drag 
the object. When an object is selected, press a modifier key to dupli-
cate and resize it as you drag a handle. In Freeform mode, you can 
press a modifier key to duplicate while rotating or skewing an 
object. 

1 Select the objects you want to duplicate. 

2 Press Option (Mac) or Ctrl (Windows) as you drag the 
objects. 

• To make multiple copies while dragging: Select the objects you 
want to duplicate. Press Option+Command (Mac) or Ctrl+Alt (Win-
dows) as you drag the objects.

To duplicate while resizing
1 Select an object to duplicate. 

2 Begin to drag a handle on the object’s bounding box to the 
size you want the duplicate to be.

3 As you drag, press and hold Option (Mac) or Ctrl (Windows). 
When you release the mouse button and the modifier key, the 
duplicate object appears in front of the original.

To duplicate while rotating or skewing
1 Select an object and choose Effects > Freeform to put the 
object in Freeform mode. 

2 Point to a handle and press Option (Mac) or Ctrl (Windows) 
as you drag the handle. 

• To rotate the object: Drag one of the four corner handles.

• To skew the object horizontally: Drag a horizontal skew handle 
to the left or right.

• To skew vertically: Drag a vertical skew handle up or down. 

The duplicated object rotates or skews depending on which handle 
you drag. You cannot rotate and skew the object at the same time. 
When you release the mouse, the duplicate is in front of the origi-
nal.
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To create multiple duplicates
After you duplicate an object using a modifier key, make more cop-
ies with the same offset distance, angle of rotation, or skew factor.

1 Select the duplicated object.

2 Choose Edit > Duplicate. Canvas creates another duplicate 
and applies the same offset distance, angle of rotation, or skew 
factor.

Scaling, rotating, and offsetting copies
The Replicate command offers powerful capabilities for duplicat-
ing objects. Use the Replicate dialog box to set the number of cop-
ies and to rotate, scale, and position copies with one command.

To replicate a selection
1 Select one or more objects to copy and choose Edit > Repli-
cate. 

2 In the Replicate dialog box, specify the number of copies. 
Enter the scaling, rotation, and offset values you want to apply. 
For information on these settings, see “Options in the Replicate 
dialog box” on page 17.17.

• To preview the replication, click Apply. Canvas draws the 
copies and the dialog box stays open. You can change set-
tings and click Apply to preview the new settings.

• To cancel the replication, click Cancel. Canvas closes the 
Replicate dialog box and erases preview copies.

Duplicate with Transform

You can now create duplicates of 
objects that have been skewed, rotat-
ed, or offset. 

1 Select the original object.

2 Duplicate the object.

3 Select the duplicate and apply a 
transformation, such as rotation, to the 
duplicate object.

4 Choose Edit > Duplicate with 
Transform.

The duplicate object is then duplicat-
ed as well as transformed. 

Remember that each time you choose 
Edit > Duplicate with Transform, the 
duplicate object is duplicated and 
transformed once again; e.g., dupli-
cate an object and then rotate the 
duplicate by 20°. Choose Duplicate 
with Transform and the new duplicate 
is transformed by another 20°.

The multigon above was duplicated 
and then rotated 20°. Each time 
Duplicate with Transform was 
applied, the resulting duplicate 
would rotate an additional 20°. The 
final duplicate had a rotation of 200°.
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3 Click OK to copy the selection and close the Replicate dialog 
box. The original object is deselected and the copies are selected.

To replicate and position objects
You can replicate objects and then strategically position them 
according to specified X/Y coordinates. 

• To replicate and position an object: Select an object and then 
choose Edit > Replicate and Position.

Options in the Replicate dialog 
box 

The Replicate dialog box lets you 
rotate, scale, and duplicate selected 
objects.

Copies. Enter the number of objects 
you want to create.

Rotate. To rotate each copy relative to 
the preceding object, select Rotate. 
Type the rotation amount from (minus) 
-359.0 to 359.0 degrees. The center of 
rotation is shown in the “Around” box 
by a hollow handle; click to select 
another handle as the rotation center.

Scale by. To incrementally change the 
size of each copy, select Scale by. In 
the pop-up menu, choose Percentage, 
Length, or Ratio. In the text boxes, 
enter horizontal and vertical scaling 
factors. 

Percentage scales each copy by the 
specified percentages of the proceed-
ing object’s dimensions. Enter whole 
numbers from 1% to 999%.

Ratio lets you resize copies by fraction-
al amounts. Canvas scales each copy 

to ratios of the previous object’s hori-
zontal and vertical dimensions.

Type ratios with whole numbers from 
1 to 999. The left number represents 
the copy; the right number represents 
the previous object. A 1/1 ratio main-
tains dimensions; 1/2 halves dimen-
sions; 2/1 doubles dimensions. 

Length increases or decreases by a 
fixed amount each copy of the object 
using the values in the horizontal and 
vertical text boxes.

Proportional. If selected, Canvas 
makes the vertical value in the Scale 
by or Offset area equal to the horizon-
tal value.

Offset. Check this option to place cop-
ies a specified distance from the previ-
ous object. In the text boxes, enter the 
horizontal and vertical offset distance. 
Positive numbers offset copies up and 

right; negative numbers offset objects 
down and left.

Object data. Displays the selection’s 
height and width. These values can’t 
be edited.
Making multiple copies 17.17



17
Grouping and ungrouping objects
Use the Group command to unite objects that you want to keep 
together as one unit. You can group individual objects as well as 
already-grouped objects. When you no longer want to keep a group 
together, separate the original objects with the Ungroup command.

Grouping and stacking order
Grouping objects can change the stacking order of the objects rela-
tive to objects outside the group; e.g., you have three overlapping 
objects. If you group the front and back objects, the group moves to 
the back and the middle (not grouped) object becomes the front-
most object.

Replicating & positioning
A Coordinate space. The Canvas ra-
dio button must be selected to position 
objects according to X/Y coordinates. 
To enable the GIS radio button, you 
must first configure your world with the 
GIS palette (see “Using the GIS pal-
ette” on page 40.2).
B Bounding box icon. Canvas per-
forms the positioning according to the 
selected handle. By default, the center 
handle is selected. Select another han-
dle, if necessary.
C Coordinate table. Enter the X/Y 
coordinates in the appropriate fields. 
The # column lists the replicates in se-
quence.

Position original object. If 
selected, the coordinates for 
the first replicate correspond 
to the original object; i.e., the 
original object will move to the 
coordinates entered for repli-
cate #1.

D Menu icon. Click to access 
the Paste and Load commands.

With the Paste command, you 
can paste points that have 
been copied to the Clipboard.

With the Load command, you 
can open .txt files that contain 
points.
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To group objects
1 Select the objects that you want to group. 

2 Choose Object > Group. Canvas replaces the bounding boxes 
of the individual objects with a single bounding box. 

When you apply a command to a group object, the effect in most 
cases is the same as if you applied the command to each object in 
the group individually.

To ungroup objects
1 Select one or more grouped objects that you want to separate.

2 Choose Object > Ungroup. Canvas separates the group and 
leaves the individual objects selected. If any of these objects are 
group objects, ungroup them by choosing Object > Ungroup 
again.

Moving objects
Move objects by dragging them, using the Properties bar, or using 
the keyboard arrow keys. You can also use the Move command to 
specify a position change, and the Object Specs palette to specify 
exact coordinates.

When you drag an object, the Properties bar and Status bar shows 
the change in the object’s X/Y position. 

Make precise positioning easier by turning on the autogrid so that 
objects you drag snap to preset ruler increments. You can also place 
alignment guides that objects will snap to in a document.

• To move an object using the Selection tool: Position the pointer 
on the object and drag. If you drag as soon as you press the mouse, 
an outline of the object follows the pointer. To see the entire object 
as you drag, pause after you press the mouse button, and then drag.

The square is behind the 
triangle, which is behind 
the circle in the stacking 
order

After selecting the square 
and circle and grouping 
them, the group goes 
behind the triangle in the 
stacking order

Tip
After you group objects, you can 
select individual objects in the 
group with the Direct Selection 
tool.
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Press modifier keys as you drag objects to constrain movements 
and perform other functions.

• To move objects using the arrow keys: To move objects left, 
right, up, or down, press the corresponding arrow key. Use the 
modifier keys shown in the following table to move greater dis-
tances.

To move objects a specified distance
Use the Move command to specify distance and direction.

1 Select the objects and then choose Object > Move.

2 In the Move dialog box, enter values in the first or second 
row of text boxes. Use negative numbers to move up and to the 
left. Use positive numbers to move down and to the right.

To Do this

Constrain movement to 45° 
increments

Press Shift while dragging

Copy objects by dragging Mac: Press Option while dragging

Windows: Press Alt while dragging

Leave a trail of object copies Mac: Press Command + Option while 
dragging

Windows: Press Ctrl + Alt while dragging

To move objects Do this

1 pixel to the left, right, up or down Press an arrow key

10 pixels to the left, right, up or down Mac: Press Option and an arrow key

Windows: Press Alt and an arrow key

50 pixels to the left, right, up or down Mac: Press Command and an arrow key

Windows: Press Ctrl and an arrow key

Tip
You can change the default dis-
tances that keyboard keys move 
objects (see “Offset for moving 
objects” on page 13.10).

Tip
You can specify angular move-
ment in 0.01° increments.

Up/down value

Distance value

Left/right value

Angle value
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3 Click Apply to preview or OK to implement the Move set-
tings.

Arranging objects in the stacking order
Each object in a Canvas document is part of a stack of objects on 
the same layer. Each object has a position in the stack. Unless you 
rearrange objects, the newest object, created or pasted, is in front of 
the stack and the oldest object in the back. 

Stacking order affects the appearance of objects when you view and 
print them. Like actual objects placed in a stack, the front object in 
the stack blocks objects behind it. An object’s position in the stack 
also is a factor in alignment and combining operations. 

Commands in the Object > Arrange menu let you change an 
object’s position in the stack. Move objects to the front or back, and 
move objects one level at a time toward the front or back of the 
stack.

• To change an object’s position in the stack: Select the object and 
choose a command in the Object > Arrange menu.

Arranging objects on layers and pages
Commands in the Object > Arrange menu let you move and copy 
selected objects to other layers on the same page and to layers on 
other pages.

To send or copy objects to another location
1 Select the objects, and then do one of the following:

• Choose Object > Arrange > Send to Layers to move 
objects to new locations.

• Choose Object > Arrange > Copy to Layers to copy objects 
to new locations.

Command Result

Bring to Front Moves selected objects to the front of the stack

Send to Back Moves selected objects to the back of the stack

Shuffle Up Moves selected objects one step toward the front 

Shuffle Down Moves selected objects one step toward the back

Tip
The destination layer for the 
objects cannot be locked.
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2 In the Layer Select dialog box, click one or more layers to 
designate them as the destination for the selected objects.

3 Click Select. Canvas copies or moves the selected objects to 
the destination layer or layers.

Locking and unlocking objects
When you want to secure objects from unintentional changes, you 
can lock them. Once an object is locked, it can only be selected by 
Tab-clicking the object. However, if the “Canvas 6-style object lock-
ing” option in the Configuration Center is selected, you can select 
locked objects by clicking on them. Locked objects can be copied, 
but the copies won’t be locked.

To lock or unlock objects:
1 Select the object(s) that you want to lock or unlock. 

2 Choose Object > Lock or Object > Unlock (Unlock All, if no 
objects are selected). 

How commands affect locked objects
If you apply the Align command to several selected objects, and 
one object is locked, the other objects align to the locked object. 

If you group several objects and one of the objects is locked, all the 
objects are positioned behind the locked object in the stacking 
order.

Aligning and distributing objects 
Use the Align menu and Align palette to quickly and precisely posi-
tion objects. The Align menu lets you quickly align selected objects. 
The menu includes these common alignment commands: Top, 
Left, Bottom, Right, Center, Center Vertical, and Center Horizon-
tal. 

To use the Align menu
1 Select two or more objects. 

2 Choose Object > Align and select an alignment option. 

Note: The Align options are also available in the Properties bar 
when multiple objects are selected.

Tip
The Align menu is also in the con-
text menu when multiple objects 
are selected. 
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Using the Align palette
The Align palette provides additional alignment and distribution 
options. 

• To open the palette: Choose Object > Align > Show Palette.

Apply alignment and distribution options to vector objects, group 
objects, paint objects, and text objects. You can align and distribute 
objects in separate or combined operations. As the reference point 
for alignment and distribution, you can choose points on the 
objects or the document. 

Aligning objects When aligning objects, Canvas lines up key points 
on the objects in relation to the reference point you choose. Choose 
left, right, top, bottom, or center alignment.

Distributing objects When distributing objects, Canvas spreads 
them out over a specified area and equalizes the space between the 
key points. Choose left, right, top, bottom, inside, outside, or center 
as methods for distribution; e.g., if you choose left edges for distri-
bution, the left-most point in each object is an equal distance from 
the leftmost point in each of its neighbors. 

If one of the objects you select for alignment is locked, other objects 
align relative to it. When distributing objects, Canvas places all 
objects relative to each other.
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Rotating, skewing, and flipping objects
You can rotate Canvas objects clockwise or counter-clockwise, flip 
them on one or both axes, and skew their bounding boxes. Rotate 
and skew around an object’s center, or move the centerpoint to any 
location.

When you rotate an object, the object’s bounding box also rotates. 
If you drag a selection handle of a rotated object, the bounding box 

Align palette

Choose Object > Align > Show Palette 
to open the palette. Select the objects 
you want to arrange. Click Apply to 
implement the current settings.

Align to: Choose the reference for 
alignment and distribution: 

Each Other: With respect to the other 
selected objects.

Grid: To the nearest grid increment.

Printable Area: With respect to the 
printer page or tile.

Document: To a specified location in 
the document. If you center an object 
in a multi-page illustration, portions 
can appear on multiple tiles.

In the Vertical and Horizontal areas, 
click buttons for alignment and distri-
bution options. Active buttons are 
recessed. 

You can select an alignment or distri-
bution option, but not both, in each 
area. 

A For no change in position, click the 
first button in either the Vertical or Hori-
zontal area.

Vertical Align. (Left to right)

A None
B Top
C Center
D Bottom
E Edge-to-edge

Vertical Distribute. Inside, top, center, 
and bottom.

Horizontal Align. (Left to right)

F Left

G Center
H Right
I Edge-to-edge.

Horizontal Distribute. Inside, left, cen-
ter, and right.

Outside Pen. Check this option to use 
the outside edge of objects’ strokes 
when aligning or distributing objects. 
Otherwise, Canvas uses the center of 
the stroke.

Edge-to-edge alignment (horizontal & 
vertical). When applying either horizon-
tal or vertical edge-to-edge alignment, 
the order of the aligned objects 
depends on the order in which the 
objects were created; i.e., the object 
furthest to the left or at the very top in 
an edge-to-edge alignment was creat-
ed first.

Edge-to-edge aligns objects according 
to their minimal bounding rectangles.

Align to Each Other

Align to 
Page

Align to Grid
Edge-to-Edge (Horizontal)
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changes shape in the rotated orientation, so you can resize an object 
without distorting its basic shape. If you need to, you can also 
return the rotated bounding box to its original orientation by 
choosing Object > Paths > Convert To Paths.

• Removing effects: After you rotate, skew, or flip objects, you 
can return them to their original orientation and shape. Select the 
objects and choose Effects > Remove Effects.

Rotating and skewing in freeform mode
When you put an object in freeform mode, you can rotate and skew 
it by dragging special handles.

• To put an object in freeform mode: Select the object and choose 
Effects > Freeform. Rotation and skewing handles and the object’s 
centerpoint appear. 

You can also put a selected object in freeform mode by clicking it. 
This depends on a setting in the Configuration Center (see “Gen-
eral settings” on page 13.2).

• To end freeform mode: Click away from the object, or press 
Enter (Mac) or Esc (Windows).

Rotating objects in freeform mode
In freeform mode, the circular handles at each corner of the bound-
ing box are rotation handles. The circle and crosshair in the center 
of the object is the point around which the object rotates.

• To rotate an object in freeform mode: Drag one of the four cor-
ner handles. An outline of the object rotates as you drag a handle.

• To set the center of rotation: Drag the centerpoint to a new 
location anywhere on the screen. To make the centerpoint snap to 
one of the handles or the center, press Shift as you drag.

Freeform mode
A Vertical skew handle
B Horizontal skew handle
C Rotation handle
D Rotation center
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Skewing objects in freeform mode
When an object is in freeform mode, slant its shape by dragging the 
horizontal and vertical skew handles. Skewing an object reshapes it 
by changing the relationship of the horizontal and vertical axes to 
the skew centerpoint.

Canvas skews objects around a centerpoint that you can position to 
achieve the desired effect. Drag the centerpoint to any position 
inside or outside the object. The location of the skew centerpoint 
changes the effect of dragging a skew handle on the object. 

To position the centerpoint on one of the freeform handles or in the 
center of the object, Shift-drag the centerpoint to place it.

• To skew an object horizontally: Drag a horizontal skew handle 
to the left or right. 

• To skew vertically: Drag a vertical skew handle up or down.

Rotating objects

The Horizontalize command rotates a 
selected object along a defined hori-
zontal line.

To apply the Horizontalize 
command

1 Select the object.

2 Choose Effects > Horizontalize. The 
cursor changes to a crosshair.

3 Click the crosshair to establish the 
start point of the horizontal line.

4 Click the crosshair again to indicate 
the end point of the horizontal line. The 
Rotate dialog box opens.

5 Select a handle in the bounding box 
icon to define the center of rotation. 

6 Enter the direction and angle of ro-
tation.

7 Click Apply to see the effect and 
then OK to close the dialog box.

Hard rotate for image. Choose this 
option to render and rotate the back-
ground area of the image.

Anti-alias image. Select this option to 
have a smoother, better quality image.

Tip
You can also skew objects by 
clicking the Skew button in the 
Properties bar. Select a skew 
option, then enter a degree value 
in the field, and press Enter.
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Freeform editing of floating image selections
Use the Freeform command to place floating image selections in 
freeform edit mode. When you put an image selection in freeform 
mode, rotate and skew it by dragging special handles. 

To float a copy of a selection
1 With a paint object in edit mode, make a selection with the 
Marquee or Lasso tool. The selection can encompass the entire 
paint object.

2 Do one of the following:

• Choose Image > Select > Float.

• Option-drag (Mac) or Ctrl-drag (Windows) the selection. 
This moves the selection and puts it in freeform mode.

You can also paste an object into an image in edit mode. The object 
pastes into the image as a floating selection.

For more information on image selections, see “Working with 
image selections,” page 26.9.

• To put a floating image selection in freeform mode: While a 
floating image selection is active, choose Effects > Freeform. Han-
dles appear on the corners and sides of the floating selection.

• To move a selection in freeform mode. Place the pointer inside 
of the selection. The pointer becomes an arrow head. Drag to move 
an outline of the selection.

Transformed Dimensions vs. 
Untransformed Dimensions

If you plan on transforming objects, 
you have the option of maintaining 
the object’s original dimensions or 
allowing the object’s dimensions to 
be altered after the transformation.

Click on the Transform icon in the 
Properties bar and select either Trans-
formed Dimensions or Untransformed 
Dimensions.

If you select Transformed Dimensions, 
the object’s original dimensions will 
be retained after being transformed. 

If, however, you select Untransformed 
Dimensions, the object’s dimensions 
will change when the transformation is 
applied.

In the example above, a 2” x 1” rect-
angle is horizontally skewed by 20°. 

When Transformed Dimensions is 
applied, the rectangle maintains its 
original width when horizontally 
skewed.

When Untransformed Dimensions is 
used, the rectangle’s width changes. 

Original Untransformed DimensionsTransformed Dimensions
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Rotating selections in freeform mode
In freeform mode, while the pointer is outside of the selection, the 
pointer is a curved line with an arrow at both ends. This is the rota-
tion pointer.

Drag around the selection in the direction you want it to rotate. An 
outline of the selection rotates as you drag.

Scaling selections in freeform mode
You can scale a floating selection in freeform mode by dragging the 
corner or side handles. 

• To scale a selection: Point to one of the handles at the edges of 
the selection. The pointer changes to a straight line with an arrow at 
each end. Drag any of the handles. The selection scales as you drag.

• If you drag a side handle, the scaling is constrained to the 
direction of the arrows in the pointer – the direction per-
pendicular to the handle side.

• If you drag a corner handle, the scaling is unconstrained 
unless you press the Shift key.

• Press the Command key (Mac) or the Alt key (Windows) 
to mirror the scale on the opposite side of the selection.

Skewing selections in freeform mode
When a selection is in freeform mode, you can slant its shape by 
dragging the side handles with the Ctrl key pressed. Skewing a 
selection reshapes it by changing the relationship of the sides of the 
selection.

Rotation pointer Scale pointer

Tip
Press the Shift key to constrain the 
rotation to 15° increments.
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• To skew a selection: Press the Ctrl key and move the pointer 
over one of the side handles. The pointer changes to an arrow head. 
Drag the handle to skew the selection freely.

• Press the Shift key to constrain the skew along the axis of 
the handle side.

• Press Command (Mac) or Alt (Windows) to have the oppo-
site side of the selection skew to maintain its relationship 
to the side you are skewing around the center of the selec-
tion.

The modifier keys can be combined to produce both skewing 
effects simultaneously.

• To end freeform editing: Double-click inside the selection or 
press Enter twice. The floating selection is still active. Then double-
click outside the paint object or press Enter twice to paste the pixels 
as defined by the floating selection into the image. 

If you do not want to change your original image, press Esc to leave 
freeform mode. Canvas makes no changes to the image.

Rotating objects with the Rotate command
For precise rotations, use the Rotate command to rotate selected 
objects in 0.01° increments around a specified center of rotation. 
This command is useful if you need to rotate multiple objects an 
exact amount.

1 Select the object you want to rotate.

2 Choose Effects > Rotate Right/Left > Other to open the 
Rotate dialog box.

3 In the Rotate dialog box, click the clockwise or counter-clock-
wise button to choose a rotation direction.

4 Enter the rotation angle in degrees in the Angle text box.

Skew pointer

Skew outline

Tip
You can also rotate objects by 
clicking the Rotate button in the 
Properties bar. Select a rotate 
option, then enter a degree value 
in the field, and press Enter.

Center of rotation edit box
Clockwise and counter-clockwise 
rotation buttons
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5 The Center edit box shows the center of rotation as a gray 
handle. To change it, click one of the black handles on the bound-
ing box; the gray handle snaps to the new location.

6 Click Apply to preview the settings, or click OK to implement 
the settings and close the dialog box.

Editing rotated objects 
When you rotate an object, the object’s bounding box also rotates, 
so you can reshape and resize the object in rotated space. If you 
drag a handle, the object’s sides keep their rotated orientation. This 
prevents distortion of the original shape.

Flipping objects
Flip objects horizontally, vertically, and both horizontally and verti-
cally, with the Flip commands. You can flip individual objects, mul-
tiple selected objects, or grouped objects. When you flip a group 
object, objects included in the group flip around the axes of the 
group’s bounding box.

The bounding box of a 
rotated square has the 
same orientation as the 
rotated object...

... so the object maintains 
its rectangular shape, 
shown by the dotted lines, 
when you drag the 
bounding box handles.

If you choose Convert 
to Paths, Canvas re-
orients the bounding 
box of a rotated 
object...

... so the object’s 
rectangular shape 
distorts when you drag 
a handle on the 
bounding box, as 
shown by the dotted 
lines.

Rotated bounding box Unrotated bounding box
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• To flip a selected object from top to bottom: Choose Effects > 
Flip > Vertical. The Vertical command flips the selection’s vertical 
coordinates over its horizontal axis.

• To flip a selected object from left to right: Choose Effects > Flip 
> Horizontal. The Horizontal command flips the selection’s hori-
zontal coordinates over its vertical axis.

• To flip a selection around both axes: Choose Effects > Flip > 
Both Axes. Canvas flips the selection’s horizontal coordinates over 
its vertical axis and its vertical coordinates over its horizontal axis.

Scaling objects
The Scale command provides several options for enlarging or 
reducing objects. Scale by a percentage or ratio, horizontally and 
vertically. You can also scale text and stroke weights when you scale 
objects.

To scale an object
1 Select one or more objects. 

2 Choose Object > Scale to open the Scale dialog box.

3 Select a scaling method in the Scale By menu. The configura-
tion of the dialog box depends on the chosen method.

Flip > Horizontal Flip > Vertical Flip > Both AxesOriginal
Scaling objects 17.31



17
Percentage Specify vertical and horizontal percentages. Scaling an 
object 150% is the same as increasing the object’s size by a factor of 
1.5.

Ratio Specify horizontal and vertical scaling factors as ratios by 
entering numbers in each set of two boxes; e.g., to scale an object to 
one-third its original height, enter “1” in the first text box, and “3” 
in the second.

• To scale an object vertically and horizontally by the same 
amount: Select Proportional.

• To maintain the proportion between an object’s pen size and the 
overall size of the object: Select Scale Pen.

4 If one of the selected objects contains text, select Scale Text 
to change the size of the characters. Otherwise, text remains the 
same size.

5 Click Apply to implement the settings.

6 Click OK to scale the object.

Using the Object Specs palette
The Object Specs palette provides several important features for 
working with objects. It displays data for selected objects and lets 
you modify settings for selected objects. 

Depending on the Scale by method, the Scale 
dialog box may display different options.

Tip
You can also scale an entire docu-
ment when you print it, without 
changing the objects in the docu-
ment, by specifying a scaling factor 
in the Print dialog box.
.32 WORKING WITH OBJECTS



The Object Specs palette contains tabs labeled Data and Trap. 

• To display the Object Specs palette: Choose Object > Object 
Specs. Change coordinates, dimensions, or other settings, and then 
click Apply to implement them. 

To create an object
1 On the Data tab, choose an object type from the Object Type 
palette. You can create rectangles, ovals, arcs, polygons, and lines. 

2 Enter values for the object’s size and position in the text 
boxes. The type of data you can enter depends on the object type. 

3 Click Create to create the object.

Editing object data
Click on the Data tab to view and edit data for selected objects.

The Data tab displays information for a selected object or group 
object. If you select a group object, you can change the group’s size 
and coordinates, but not an individual object within the group.

After you edit the values on the Data tab, click Apply to apply the 
changes to the selected object.

Tab Use

Data Create objects, and edit the size, position, and other data 
for a selected object.

Trap Set printing options, including overprinting and trapping 
for color separations. 

Press to open Object Type palette

Tip
When more than one object is 
selected, the boxes on the Data 
tab are not available. You can’t 
edit the position or dimensions of 
multiple selected objects.
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Data display options
Choose the data to display. Select Height/Width or Top/Bottom for 
all objects except lines. For lines, select Start/End, Delta V/H, or 
Length/Angle.

Height/Width Type values in the text boxes to specify the vertical 
and horizontal dimensions of the object. 

Top/Bottom Type values in the text boxes to specify the position 
of the top, bottom, left, and right edges of the object, relative to the 
document rulers.

Start/End Type values in the text boxes to specify the position of 
the first and last endpoints of a line. 

Data tab settings

This tab includes object size and posi-
tion data and related options. Addition-
al options are shown for text objects. 
The text options let you change the 
shape of a text object or change the 
way text wraps in its bounding box.

A For a selected object, shows the ob-
ject type, usually an icon of the tool that 
created the object. To create an object, 
select oval, rectangle, arc, line, or poly-
gon.
B Select the type of data to display 
(see “Data display options,” 
page 17.34). 

When an object is selected, change the 
values in the text boxes to resize or 
reposition the selected object. If Keep 
Proportions is checked, Canvas main-
tains the proportion of the object if you 
change either the height or width (on 
Mac, the calculation occurs when you 
press the Tab key or click Apply).

C Position data. The type of data that 
appears in the boxes, and their labels, 
depends on the selected data display op-
tion (see “Position data,” page 17.35). 

Area. Shown when Canvas can calcu-
late the area occupied by a selected 
object’s bounding box. When you 
select text, the horizontal insets text 
box replaces the Area text box.

Perim. Shown when Canvas can cal-
culate the perimeter, or distance 
around, a selected object’s bounding 
box. When you select text, the verti-
cal insets text box replaces the Perim 
text box.

Object name. Type a name for the 
object.

Object #. The object number 
assigned by Canvas.

Keep Proportions. Select this option 
to keep an object’s height and width 
proportional when you are editing the 
object’s dimensions.

Apply. Click to apply the current set-
tings. The Apply button changes to 
Create when no object is selected 
and you choose an object type to cre-
ate.

Text object settings

Insets. Change the proportions of a text 
object’s background. Type values, in 
pixels, in the text boxes to specify the 
horizontal and vertical size of the text 
object’s background. 

D Change the shape of the text ob-
ject’s background to a rectangle, round 
rectangle, oval, or diamond. 

Caption. Select or deselect to change 
the way text wraps in its bounding box. 

Text that is not captioned wraps to the 
next line based on the boundaries of 
the text’s bounding box. 

You can’t use the Caption or Insets 
options with text that you created using 
the Path Text tool, or text that you con-
verted to paths. 

Text object settings
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Delta V/H Type values in the text boxes to specify the position of 
the first endpoint, and the distance from the first endpoint to the 
last endpoint of the line.

Length/Angle Type values in the text boxes to specify the position 
of the first endpoint, and the length and angle of the line.

Position data
The type of data that is displayed depends on whether you choose 
Height/Width or Top/Bottom, Start/End, Delta V/H, or Length/
Angle.

Left Type the horizontal distance from the ruler’s zero point to the 
left edge of the object. 

Top Type the vertical distance from the ruler’s zero point to the 
top edge of the object.

Height Type the height of the object, relative to the top edge of the 
object.

Width Type the width of the object, relative to the left edge of the 
object.

Bottom Type the vertical distance from ruler’s zero point to the 
bottom edge of the object.

Right Type the horizontal distance from the ruler’s zero point to 
the right edge of the object.

St V Type a value to position the first endpoint of a line, relative to 
the vertical ruler’s zero point. 

St H Type a value to position the first endpoint of a line, relative 
to the horizontal ruler’s zero point. 

End V Type a value to position the last endpoint of a line, relative 
to the vertical ruler’s zero point. 

End H Type a value to position the last endpoint of a line, relative 
to the horizontal ruler’s zero point. 

Delta V Type a value to position the last endpoint of a line, relative 
(vertically) to the first endpoint of the line.

Delta H Type a value to position the last endpoint of a line, rela-
tive (horizontally) to the first endpoint of the line.

Length Type a value to specify the length of a line.

Angle Type a value to specify the angle of a line.
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X Type a value to position a handle of a polygon, relative to the 
horizontal ruler’s zero point.

Y Type a value to position a handle of a polygon, relative to the 
vertical ruler’s zero point.

Start Type a value to specify the starting point of an arc in 
degrees.

Delta Type a value to specify the length of an arc segment in 
degrees.

Diag Type a value to specify the roundness of the corners of a 
rounded rectangle.

Setting print properties for objects
Click on the Trap tab of the Object Specs palette to view the over-
printing and trapping options for color separations. Click Apply to 
apply the settings to selected objects.

Overprinting in color separations
When you output color separations in Canvas, you can specify that 
an object should overprint, rather than knock out, objects behind it. 

In color separations designed for commercial printing, a front 
object usually knocks out a hole where it overlaps other objects; how-
ever, you can apply the Overprint Object option to an object to pre-
vent it from creating knockouts in objects behind it. This can 
compensate for registration problems on some printing presses.

For example, if you draw a cyan circle on a yellow background, 
Canvas knocks the circle out of the background in color separations 
so cyan and yellow don’t mix in the circle. If you select the circle 
and use the Overprint Object option, the circle prints over a solid 
yellow background, and the cyan in the circle mixes with the back-
ground yellow, resulting in a green circle.

The effect of the Overprint Object option is not visible on screen. 
This effect is visible only in the printed output when you produce 
color separations. Verify the settings for a particular object by view-
ing the Trap tab in the Object Specs palette and then selecting the 
object.

Color mixing as described previously is not the primary reason for 
overprinting. It’s more common for designers to overprint dark 
objects on lighter backgrounds as a way to prevent a gap from 

Overprinting produces a color 
mixture where the orange circle 
overlaps the gray circle. This effect 
isn’t visible on screen.

Without overprinting, the orange 
circle knocks out part of the gray 
circle.

Overprinted object

Knockout
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appearing between the colors if the press registration (alignment) 
isn’t perfect.

To specify overprinting for objects
1 Select the vector or text objects to be overprinted.

2 Select the Overprint Object checkbox on the Trap tab. 

3 Click Apply. The appearance of the selected objects does not 
change on screen, but the objects will be overprinted in color sep-
arations.

• To remove overprinting: Select the objects and deselect the 
Overprint Object checkbox. Then click Apply.

Trapping in color separations
When objects of different colors touch, there is the potential for an 
unsightly gap to appear between the colors if the piece isn’t printed 
precisely aligned, or in register.

Trapping is a technique that purposely distorts the shapes of 
objects in color separations where different colors meet. The slight 
distortion creates tiny areas called traps where colors overlap. The 
trap areas can help avoid the appearance of gaps if the page is 
printed slightly out of register.

Before you use trapping in color separations, determine how likely 
it is that the piece will not be printed in register. Consider how ben-
eficial it will be to distort the shape of some objects to compensate 
for possible misregistration; e.g., trapping type can ruin the appear-
ance of the text, and probably isn’t necessary.

Trapping choices
Canvas lets you specify two types of trapping, Choke and Spread.

Choke trapping is used to make light background colors trap to 
dark foreground objects. Canvas creates a choke trap by slightly 
reducing, (“choking”) the knockout area in the light background 
object; e.g., if a dark blue “A” is printed on a pale yellow back-
ground with choke trapping applied to the “A,” the “A” remains 
exactly the same, but the knockout area in the yellow background 
becomes a slightly smaller “A” shape. The result is that some of the 
yellow overlaps the edges of the dark blue “A.”

Spread trapping is used to make light foreground objects trap into 
dark backgrounds. The trap is created by slightly enlarging the 

Choke trapping reduces the 
background knockout slightly to 
trap into a dark foreground object.

Spread trapping enlarges the stroke
of a foreground object slightly to 
trap into a dark background object
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foreground object without changing the knockout in the back-
ground color; e.g., if a light circle is printed on a dark background 
with spread trapping applied to the circle, the circle expands 
slightly to overlap, or trap into, the circle knockout in the dark 
background.

Trapping limitations
Whenever possible, design illustrations to avoid certain trapping 
problems, and always discuss trapping with your service bureau 
and printer to avoid unnecessary expense and inferior results.

In Canvas, trapping is best applied to vector objects that use a solid 
pen stroke and solid pen ink color. The following limitations apply 
to trapping:

• Canvas will not create a choke trap for text.

• Canvas will not create a choke trap for a vector object that 
has no stroke or has a stroke that is not a solid pen stroke.

• Canvas will not create a choke trap for an object that has a 
gradient pen ink.

• Canvas will not create a spread trap for a paint object.

To specify trapping for objects
1 Select the object you want to trap. In most cases, this will be a 
foreground object that touches a highly contrasting color.

2 Click the Trap tab.

3 Select the Trap Object checkbox, and then click the Choke or 
Spread radio button (see “Choke trapping,” page 17.37 and 
“Spread trapping,” page 17.37).

4 Click Apply to set the trapping option for the selected object. 
No change is apparent in the object on screen, because the trap is 
created only when you print color separations.

• To apply trapping to selected text: You can apply trapping 
options to text that you select within a text object using the Over-
print and Spread options in the Text > Style menu.

• To adjust the trap size: Before printing color separations, spec-
ify the trap size. Select the Separations options in the Print dialog 
box to change the trap size value.
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Creating attribute styles
Illustrators and designers may often find themselves applying the 
same attributes to various vector objects within a layout. An 
attribute style is a set of attributes that you save and then apply to 
other objects. These styles help you maintain consistency and facili-
tate applying attributes. 

Attribute Styles palette
With the Attribute Styles palette, you can create attribute styles and 
edit saved attribute styles and then reapply them to objects, rather 
than editing each individual attribute. You can even share attribute 
styles with others.

• To open the Attribute Styles palette: Choose Window > 
Palettes > Attribute Styles.

To create an attribute style
1 Open the Attribute Styles palette.

2 Select an object on which you want to base a style.

3 Click the Create button. The Define Style dialog box opens.

4 Enter a name for the style.

5 Select all the attributes that will be included in the style.

6 Click OK to save the style.

To apply an attribute style
1 Open the Attribute Styles palette.

2 Select the vector object to which you wish to apply the style.

3 Click on the style name in the palette to apply it.

To save attribute styles
1 Open the palette menu and select Save Styles.

2 Enter a name for the file.

3 Select a folder. 

4 Click Save.

To load or append attribute styles
1 Open the palette menu and select Load or Append Styles.

Menu icon
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2 Navigate to the folder and select the file.

3 Click Open

To modify an attribute style
Note: Press Esc twice to ensure that no object is selected.

1 Select the style in the Attributes palette.

2 Click the Edit icon. The Edit Style dialog box opens.

3 Modify the existing attributes. Selected checkboxes indicate 
an existing attribute.

4 Define and add other attributes by first selecting their check-
boxes and then using the popup palettes.

5 Click OK when finished.

To delete an attribute style
Note: Press Esc twice to ensure that no object is selected.

1 Select the attribute style to be deleted.

2 Click the trash can icon.

Attaching comments to objects
You can attach written notes called comments to any object in a Can-
vas document. This can be useful for individuals and coworkers 
who share documents. Anyone who works on a document can 
attach one or more comments to any object, including paint 
objects, vector objects, and text objects.

When you open a document, you can view all comments attached 
to objects. You can edit comments that you create, but not those 
made by others.

When you select an object that has one or more comments attached 
to it, the object displays yellow selection handles (Windows) or gray 
selection handles (Mac).

Edit icon

Tip
Be sure that Show information 
tooltips is selected in the Func-
tionality Options manager in the 
Configuration Center. 
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You can view comments by pointing to objects. When the pointer is 
on an object, the object’s comments appear in a pop-up window. 

To attach comments
1 To attach a comment to an object, select the object.

2 Choose Object > Options > Comments to display the Com-
ments palette. In the Comments palette, click New. 

3 In the New Comment dialog box, type the comment text. 
When you finish, click OK to attach the comment to the selected 
object. The comment appears in the Comments palette.

4 Click New in the Comments palette to attach additional com-
ments to the selected object.

A comment can contain up to 64 KB of text (about 65,500 charac-
ters). The text appears in a fixed size and typeface.

When you create comments, you can select, copy, cut, and paste 
text using the standard keyboard shortcuts. Spell checking, text for-
matting, and text colors cannot be applied to comments.

Viewing and editing comments
Use the Comments palette to view, edit, and delete comments.

1 Choose Object > Options > Comments to display the Com-
ments palette. All comments attached to objects in a document 
appear in the Comments palette. 

2 Select an author’s name in the menu to display only that 
author’s comments in the list. To show all comments, choose All 
Reviewers.

Object with comments
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The scrolling list displays the first lines and the author’s initials for 
each comment. The initials preceding comments are from the user 
name entered during Canvas installation. You can edit the initials 
in the User Info manager in the Configuration Center.

3 Click a comment to select it. When you select a comment, 
Canvas selects the commented object in the document. Yellow 
(Windows) or gray (Mac) selection handles appear around the 
object to indicate that the object has one or more comments.

4 To view, edit, or remove a selected comment, choose one of 
the following options:

View To view a selected comment, click View. The comment text 
appears in the View Comments dialog box. You can select text and 
copy it to the Clipboard using standard keyboard shortcuts. You 
can edit your own comments in the View Comments dialog box, 
but you can’t edit or remove others’ comments.

The pencil icon at the bottom-left corner of the dialog box indicates 
that you can edit a comment. When you view a comment that you 
can’t edit, a slash appears on the pencil icon.

When you finish viewing a comment, click OK or Cancel to close 
the dialog box. If you changed a comment, click OK to save the 
changes or click Cancel to discard them and close the dialog box.

Remove Select a comment you created. Click Remove to delete 
the comment from the object and the Comments palette.

Comments remain attached to objects until you remove them. 
However, comments are not preserved by operations that convert 
objects to different forms. These operations include Knife, Com-
bine, Extrude, Fractalize, Join, Make Composite, Convert to Paths, 
and Insert Picture.
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Object Properties
For many years, professional engineers and designers have used 
Canvas to create technical schematics, blueprints, and complex 
illustrations. Aerospace, biomedical, and other industries rely on 
the micron-precise measurements and CAD-like tools found within 
our integrated application. While the Canvas tool set and features 
have won praise from the technical illustrator, we have also listened 
to the needs of people involved in the manufacturing end of their 
respective business. 

Canvas now contains the ability to attach specific user-definable 
data to any object. This information is stored with the objects and 
can be viewed or edited from within Canvas. 

Assigning Object Properties
The Object Properties function allows you to assign specific infor-
mation to each component of a complex object. The properties of 
an object can include information that will allow you to efficiently 
track cost, inventory, location, and availability. As a result, those 
who design and manufacture items such as fuel pumps, jet engines 
or other sophisticated components can better manage production 
workflow. 

Attaching information to an object does not affect the size or 
appearance of the item. All data remains attached to the object and 
may be edited at any time within Canvas. Therefore, if the object is 
shared or used in another project, then the properties of that object 
will be carried over into the new project.

The Object Properties function allows for smooth production work-
flow because it:

• Enhances inventory control.

• Targets production costs and expenditures.

• Ensures availability of assembly line components.

• To open the Object Properties palette: Select a Canvas object 
and choose Object > Object Properties. 

If the selected item does not have any properties assigned to it, then 
you will need to double-click inside the Object Properties palette. 
This allows access to the Define Properties dialog box. Once the 
Define Properties dialog box appears, click New (A) so that you can 
begin to define the properties of the object.

Select an object, then double-
click anywhere inside this 
palette.
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Let’s begin by assigning values to components of a valve that will be 
manufactured. 

Note: If the object is grouped, then you will need to ungroup it. This 
allows you to select the various individual items that you wish to 
assign a property to.

Once you complete each label, then click OK (B) to accept your 
entries. When created, all of the labels are listed in the Properties 
Panel. At any time, you can access and edit your entries by clicking 
on any of the properties that are listed in the Properties Panel. 

Label 
In this field, you may enter the name of the property; e.g., Size, 
Weight, Location, Part Number, Tracking Code. 
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You can also attach multiple labels to each object. Doing so allows 
you to identify the object by using one of the assigned labels. 

Next, select an option in the Type menu. This allows you to choose 
the search value for the object.

Type
The Type field has the following options: String, Number, Fixed 
List, Variable List, Boolean, Currency, or Date.

Once you choose a Type from the above options, you must estab-
lish the correct Format. The Format section provides details for 
each of the Type choices and its associated Format options.

Format
Assigning a format depends on which of the previously mentioned 
types were selected.

String - You can place just about anything that you want in this 
field. If a Format field is used, then it is possible to impose limits on 
what is entered, use only numbers, or specify n-number of charac-
ters. The following format modifiers are available for String:

“#” indicates number

“X” indicates character

“?” indicates that you can assign any character

[any other character] indicates that this character will appear in 
the value string at that exact position and exactly as it is entered in 
the format.

An example would be assigning the value of:
“XXXXX XXXXX” to the handle of the object “Water Valve.” 
This value would not apply to “Gas Valve.” 

Using the symbols “####.##” means that “1234.12” is a valid entry; 
however, “1234.123” would not be a valid value for the object. It 
will return incorrect results during a search for an item. If a format 
is not entered, then any string will be accepted.

Type Drop Down Menu
Object Properties 17.45



17
Number This option allows you to enter a numerical value for an 
object. To do so, you must use one of the following formats:

• Whole (e.g., 1)

• Whole with units (e.g., 1 kg)

• Decimal (e.g., 1.5)

• Decimal with Units (e.g., 5.1 kg)

• Fraction (e.g., 1/2)

• Fraction with Units (e.g., 1/2 kg)

To define a unit
1 When the Define Properties dialog box is open, set “Num-
ber” as the type.

2 Set the format to be one of those with units.

3 Enter a number followed by unit as a value; e.g., “100 kg”. 
The unit will become the default for that property. 

This means that if you were to enter the setting of “100 cm”, then 
“cm” will become your default setting. Therefore, when you enter a 
new value for the property in the Object Properties palette, you will 
only have to enter the number for that property. The unit will auto-
matically be appended to reflect the unit “cm.” If you enter both a 
number and a unit and the unit differs from the default, then the 
entry will be rejected.

Note: If you do not specify a default unit for the property, then you 
will need to enter a number and a unit each time that you change 
the value. The advantage of not having a default unit is that you 
can enter a different unit without being constrained by the default 
setting.

Fixed List You can think of this as assigning a key word that can 
be used to search for items. Be certain to separate each word with a 
semicolon (;); e.g., “earth;wind;fire”. After setting this property type, 
you should define a set of items that appear on the list of available 
values for the property. 

Enter the desired values in the Format field; e.g., you may enter val-
ues such as “Earth;Wind;Fire” in the Format field. These entries 
will then appear on the list in the Object Properties palette.

Format field in the Object 
Properties dialog box.
.46 WORKING WITH OBJECTS



Variable List This option is the same as a fixed list except that you 
can enter new values at the time of assignment to the object. 

After you define a set of values, you may want to add a new value to 
the set that appears in the Object Properties menu. To make these 
changes, you need only to enter a value in the Object Properties pal-
ette. 

Boolean This is used when the value will be Yes or No. You may 
change the value to True or False, Positive or Negative, 0 or 1, etc.

Currency There are two format types for the currency property. 
They are Monetary Sign Leads (e.g., USD 100.00) and Monetary 
Sign Follows (e.g., 100.00 USD).

The default setting for the currency property is Monetary Sign 
Leads. This property is set in the same manner as the previously 
described numbers with units. You need only to enter a value and a 
monetary sign in the Value field to have a default monetary sign 
set. The sign that you enter will then become the default setting. It 
will be automatically added each time that you change a value. 

If you enter a value and a monetary sign that differs from the 
default, then the change will be rejected. If the default sign was not 
defined, then you have to enter a number and a monetary sign each 
time that you change the value of the property. An advantage of not 
having a default monetary sign is that you are not constrained to 
the use of the default setting when entering a different sign.

Note: A monetary sign must always be present in the value when 
working with currencies. If there is not a default setting, you must 
enter a number and the monetary sign. 

Date The Date property can be set in any of six different formats. 
They are grouped into two major format types:

You may add values to a Variable 
Option list. To do this, merely click on a 
table that has Variable List assigned as 
a format type, then type in the new 
value.
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• Full Date formats - This setting forces you to set a date 
which consists of a two-digit day, two-digit month, and 
four-digit year; e.g, for February, you must enter “02” 
instead of “2”. Therefore, February 7th, 2001 could be 
entered as 02/07/2001.

• Short Date formats - Using this setting the date will consist 
of either a one-digit or two-digit day and a one-digit or two-
digit month. A two-digit year will always be required. This 
means that zero (‘0’) will not be used as the first number 
for month or day; e.g., February should be represented as 
“2” (not as “02”); however, zero will be accepted as the first 
number of a year. This means that you may enter 2001 as 
“01”. Therefore, February 7th, 2001 could be entered as 2/
7/01.

Each of the previously discussed sets have three separate formats:

month/day/year (represented in the palette as “03/29/1999” and 
“3/29/99” respectively)

day/month/year (represented in the palette as “29/03/1999” and 
“29/3/99” respectively)

year/month/day (represented in the palette as “1999/03/29” and 
“99/3/29” respectively)

Use the forward-slash (/) to separate the month, day, and year; how-
ever, typing the forward-slash is not required; e.g., you may enter a 
the following string of numbers, “03291999,” and Canvas will auto-
matically separate them and create string value “03/29/1999” as 
long as it conforms to the format. However, you should be aware 
that a confusing situation can occur when using short date formats; 
e.g., if you wish to enter a date of January 23rd, 1999, and expect it 
to appear as “1/23/99”, enter at least one forward-slash character in 
the string so that Canvas can resolve the entry. In our example, typ-
ing the entry as “12399” will resolve entry as “12/3/99”. In such a 
case at least one forward-slash character (/) should be typed; e.g., “1/
2399”). Dates not conforming to format rules will be rejected.

Value
Allows you to enter a default value for an object.
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Prompt
A message or other data that is entered here will be displayed when-
ever you place the pointer over the property name in the Object 
Properties palette.

Once you have completed entering all of the properties to the 
object, click OK. When the Object Properties palette is active, all 
assigned properties will appear in the palette whenever you select 
the object.

Common properties
When two or more objects are selected, the list of properties that 
are common for all of those objects is shown. Working with com-
mon properties is similar to working with a list of properties from 
one object.

You can modify, delete, or add new properties; however, changes 
that are made to such a list of properties will be applied to all 
objects, not to only one.

To create common properties for objects
1 Select two or more objects to which you want to assign com-
mon properties. 

• Double-click in the Object Properties palette 

• In the Define Properties dialog box, add, delete, or modify 
the properties. Click OK to accept your changes.

Tip
To use this feature, select the 
Show Information Tooltips check-
box in the Functionality options in 
the Configuration Center.

Selected object properties list
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Each of the selected objects, excluding the properties that are spe-
cific only to it, will also have the common properties that we have 
just defined.

2 You can select an object which has already defined proper-
ties.

• Copy and paste the object into the same document.

• The pasted object will inherit the same list of properties as 
the original object.

The Define Properties dialog box shows the common properties of the two 
selected objects.
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DRAWING BASICS

This chapter describes how to draw and resize vector objects. The 
Canvas drawing tools let you easily draw basic shapes — lines, rect-
angles, ovals, and arcs — and create precise squares, circles, and 
straight lines. Specialized tools let you draw grids, stars, polygons, 
concentric circles, cubes, and spirals. 

Drawing basic shapes
You can use the same basic technique with most Canvas drawing 
tools. See the table titled “Basic drawing procedures” on page 18.2 
for the procedures you use to draw basic shapes. Instructions for 
the tools that let you draw grids, stars, polygons, concentric circles, 
cubes, and spirals appear later in the chapter.

Applying inks and strokes 
When you draw a vector object, Canvas applies the current ink and 
stroke settings to the objects you draw. The inks and stroke icons in 
the Toolbox show a preview of the current settings. Change these 
attributes before or after you draw an object (see “Inks: colors & 
patterns” on page 15.1 and “Strokes: outline effects” on page 16.1).

Selecting tools in the Toolbox
Tools for drawing lines, rectangles, ovals, and arcs are grouped in 
various tool palettes in the Toolbox. The current tool is selected in 
the Toolbox (see “Tool palettes,” page 10.6). 

• To open a tool palette to select another tool: Click the current 
tool icon. 

• To float a tool palette: Press Shift and drag it away from the 
Toolbox (see “Viewing the Smart Toolbox” on page 10.5).

Drawing objects from the center
You can draw many vector objects starting from the object’s center 
by pressing a modifier key as you draw. Position the pointer where 
you want the object’s center to be, press Option (Mac) or Ctrl (Win-
dows) and drag away from the center to draw the object.

A Line
B Rectangles
C Ovals and arcs
D Paths
E Annotations
F Object tools
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When you draw an object from the center, press Shift at the same 
time if you want to also constrain the object’s bounding box to a 
square. Use this technique to draw a perfect square or circle from 
the center outward.

Basic drawing procedures

Drawing arcs by radius and by 3 points
The Arc Radius tool draws an arc based on a center point and 
radius that you set. The Arc 3 Points tool draws an arc through 

Object Tool Procedure

Lines Line tool Drag from the starting point to the 
end point in any direction

Lines at a 45° angle 
(horizontal, vertical, or 
diagonal)

Line tool Press Shift and drag from the start-
ing point to the end point

Rectangles Rectangle tool Drag from one corner to the oppo-
site corner

Squares Rectangle tool Press Shift and drag from one cor-
ner to the opposite corner

Rounded rectangles Rounded 
Rectangle tool

Drag from one corner to the oppo-
site corner

Rounded squares Rounded 
Rectangle tool

Press Shift and drag from one cor-
ner to the opposite corner

Ovals Oval tool Drag from one corner to the oppo-
site corner of the oval’s bounding 
box

Circles Oval tool Press Shift and drag from one cor-
ner to the opposite corner of the 
circle’s bounding box

Arcs Arc tool Drag from one corner to the oppo-
site corner of the arc’s bounding 
box

Circle-segment arcs Arc tool Press Shift and drag from one cor-
ner to the opposite corner of the 
arc’s bounding box
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three points that you set. Both tools draw arcs with the current fill 
ink, pen ink, and stroke.

To edit arcs, see “To change the length of an arc” on page 18.5.

The Arc Radius tool and Arc 3 Points tools are located with the 
Oval and Arc tools.

To draw arcs by 3 points
1 Select the Arc 3 Points tool. Click in the document to set one 
endpoint of the arc. 

2 Move to the second endpoint of the arc. A line extends from 
the first endpoint. Click to set the second endpoint. 

3 Move to a point on the perimeter of the arc. A line indicates 
the chord from the second point, while the arc expands or con-
tracts as you move the pointer. 

4 Click to set the perimeter point and finish the arc.

To draw arcs by radius
1 Select the Arc Radius tool. Click in the document to set the 
center of the arc.

2 Move to one endpoint of the arc. A line extends from the cen-
ter and indicates the arc’s radius. Click to set the endpoint.

3 Move to the second endpoint of the arc. An arc segment 
extends from the first endpoint and indicates the arc’s length. 

4 Click to set the second endpoint and finish the arc.

Drawing circles by radius and by 3 points
The Circle Radius tool draws a circle from a center point and a 
radius that you set. The Circle 3 Points tool draws a circle through 
three points that you set. Both tools draw circles with the current fill 
ink, pen ink, and stroke.

The Circle Radius and Circle 3 Points tools are located with the 
Oval and Arc tools.

First click

Second click

Third click

First click
Second click

Third click

A Oval
B Arc
C Circle 3 Points
D Circle Radius
E Arc 3 Points
F Arc Radius
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To draw circles by 3 points
1 Select the Circle 3 points tool. Click in the document to set a 
first point on the circle’s circumference. 

2 Move to a second point on the circle’s circumference. A line 
indicates the chord from the first point as you move the pointer. 
Click to set the second point.

3 Move to a third point on the circumference. A line indicates 
the chord from the second point, while the circle expands or con-
tracts as you move the pointer.

4 Click to set the third point and complete the circle.

To draw circles by radius
1 Select the Circle Radius tool. Click in the document to set the 
center of the circle.

2 Move to anywhere on the circumference of the circle. A line 
extends from the center and indicates the radius, while the circle 
expands or contracts as you move the pointer. 

3 Click to set the circumference and complete the circle.

Resizing and reshaping vector objects
You can resize and reshape a vector object by changing the size and 
shape of the object’s bounding box. You can also change the length 
of arc segments and the corner radius of rounded rectangles. These 
techniques are described in the following section.

You can also edit most vector objects by changing the anchor 
points and segments that form their paths. For information on 
these editing techniques, see “Editing object paths” on page 19.7.

To resize an object’s bounding box
When you drag a handle on a vector object’s bounding box, you 
change the height or width (or both) of the bounding box. This also 
changes the size (and possibly the shape) of the object; e.g., if you 
select a circle and drag a side handle to make the bounding box 
wider, the circle becomes an oval that is wider than it is tall.

1 Choose a Selection tool at the top-left of the Toolbox. 

• Use the filled arrow to select a single object (including a 
group object).

First click Second click

Third click

First 
click

Second 
click
.4 DRAWING BASICS



• Use the hollow arrow to select an individual object within 
a group object.

2 Click the object to select it. Handles appear on the object’s 
bounding box.

3 Drag a handle, as described below, to resize the object.

Maintaining object proportions
When you resize vector objects and want to maintain the object’s 
height-to-width ratio, you have three options: 

• Press Shift and drag a corner handle to resize the object 
proportionally.

• Use the Scale command and select the Proportional option 
in the Scale dialog box. This keeps the vertical and hori-
zontal scaling factor in the dialog box equal.

• Use the Scale control in the Properties bar. Click the Scale 
button and select Scale Proportional. Then enter a value 
in the width or height field.

• Use the Objects Specs command and select the Keep Pro-
portions option in the Object Specs palette. Canvas keeps 
the object proportional if you change an object dimension 
in the Object Specs palette.

To change the length of an arc
1 Select the arc. Round handles appear near the beginning and 
end of the arc segment.

To change Do this

Height Drag the top or bottom handle

Width Drag a side handle

Height and width Drag a corner handle

Height and width 
proportionally

Press Shift and drag a corner handle

Symmetrically 
(from center)

Press Option (Mac) or Ctrl (Windows) and drag a 
handle

Symmetrically and 
proportionally

Press Option-Shift (Mac) or Ctrl-Shift (Windows) and 
drag a corner handle
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2 To shorten the arc, drag the round handle back over the arc. 
To lengthen the arc, drag the round handle to continue the arc 
segment.

You can also adjust the length of an arc by changing its Start angle 
and  values in the Properties bar or Object Specs palette. 

To change the corner radius of a rounded rectangle
1 Select the rounded rectangle. A round handle appears near 
the lower-right corner of the rectangle.

2 Drag the handle to change the corner diameter. You can also 
adjust the corner radius in the Properties bar or use the Diag set-
ting in the Object Specs palette.

Drawing with Snap options
Snap options can help you draw objects in precise positions relative 
to other objects; e.g., use Snap options to draw lines that are parallel 
or perpendicular to other lines, to draw circles contained inside 
other objects, and to start drawing from the center points of objects. 
You can also draw guide lines that run to a vanishing point for illus-
trating perspective.

Snap options appear in the context menu, in a Snap submenu. You 
can select Snap options when you use the following tools: Line, 
Smart Lines, Oval, Circle 3 Points, Circle Radius, Rectangle, 
Rounded Rectangle, Arc, Arc 3 Points, Arc Radius, Curve, Poly-
gon, Text, Spiral, GridMaker, and Annotations.

Snap options are most useful when you draw with the Line tool. 
You can draw lines to be parallel, tangent, or perpendicular to 

Objects drawn with Snap options

Included Perpendicular Parallel CenterTangent
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other objects. You can also snap lines to start at the center of an 
object, and constrain lines to the interiors of objects.

Snap options (especially the Center and Included options) are also 
useful for drawing ovals, rectangles, and arcs. For these objects, 
some Snap options constrain the first point you draw; other Snap 
options constrain the start and end points when you draw an object.

To use Snap options
1 Select the Line tool or another tool (the available tools are 
listed previously).

2 Point to the object to which you want to snap. (To use the 
Vanishing Point option, skip this step; you do not need to point to 
an object.)

• To draw parallel to a line: Place the pointer anywhere on the 
line. 

• To draw parallel to a rectangle or polygon: Point to the side to 
which you want to draw parallel.

• To draw perpendicular to an object: Point to the side to which 
you want to draw perpendicular.

• To snap to the center of an object: Place the pointer anywhere 
inside the object.

3 Control-click (Mac) or right-click (Windows) to open the con-
text menu and choose an option (described below) in the Snap 
submenu.

4 If you chose Parallel or Perpendicular, a reference line 
appears. Move the mouse and then click to set the reference line. 

• For the Parallel option, a dialog box appears. You can 
accept or change the indicated offset from the object, and 
then click OK to continue.

5 Move the pointer to where you want to start drawing. 
Depending on the tool you are using, either drag to draw an 
object, or click to set the points of the object.

Note: Objects that should be two-dimensional might appear one- 
dimensional if you try to draw using certain Snap options; e.g., if 
you snap a rectangle to a line using the Included option, two oppo-
site corners of the rectangle will snap to the line. If the line is verti-
cal or horizontal, the rectangle will appear as a line.
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Snap submenu options
To choose a Snap option, make sure the pointer is on the object or 
the object side that you want to use as a reference, then open the 
context menu and choose an option in the Snap submenu.

Parallel Lets you set a reference line parallel to a line or the side of 
an object. After selecting this option, move the mouse to position 
the reference line, then click to set it. In the dialog box that appears, 
you can enter the distance you want the reference line to be offset 
from the object. Click OK to continue. Begin drawing and the 
object will snap to the reference line.

Perpendicular Lets you set a reference line perpendicular to a line 
or the side of an object. After selecting this option, move the mouse 
to position the reference line, then click to set it. Begin drawing and 
the object will snap to the reference line.

Tangent Lets you set a reference line tangent to a circle, an oval, or 
an arc. After selecting this option, move the mouse to position the 
reference line, then click to set it. Begin drawing and the object will 
snap to the reference line.

Included Snaps an object’s start and end points to the outline of an 
object or to a line. For example, you can use this option to snap the 
bounding box of a circle to the inside of a rectangle.

Center Snaps the first point you draw to the center of an object or 
a line.

Vanishing Point Snaps the first point of an object to the docu-
ment’s vanishing point. If you draw with the Line tool, the line will 
snap to the vanishing point and run to the location of the pointer 
when you begin dragging.

There is one global vanishing point in a document. The vanishing 
point is used by the commands in the Effects > Perspective sub-
menu as well as the Snap > Vanishing Point command. The default 
vanishing point is at ruler coordinates 0,0. You can use the Effects > 
Perspective > Vanishing Point command to apply perspective to 
selected objects and establish the vanishing point. Using the 1 Side 
and 2 Sides commands will also affect the location of the docu-
ment’s vanishing point.

Drawing by numbers
Several drawing tools give you the option of entering dimensions to 
draw objects precisely. This method can be easier than dragging 

Tip
You can draw perspective lines 
with the Vanishing Point option, 
and make the lines into alignment 
guides with the Object > Make 
Guide command.
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the mouse and watching data in the Properties bar to draw objects 
to precise dimensions.

You can enter dimensions in the Properties bar when you use the 
Oval, Arc, Rectangle, Rounded Rectangle, Line, Annotations, Mul-
tigon, Concentric Circles, and Spiral tools. You can enter the X/Y 
coordinates, width, height, or other values, and then click Create in 
the Properties bar to draw the object. With these tools, you can still 
drag the mouse to draw interactively. 

Note: You can also establish precise dimensions and locations for 
any object in a document with the Data tab in the Object Specs pal-
ette.

To draw objects with the Properties bar
1 Select one of the previously mentioned tools. The related 
value fields appear in the Properties bar.

2 Select a reference point by clicking a handle in the bounding 
box icon; e.g., to center an oval where you clicked in a document, 
for example, click the center handle in the bounding box illustra-
tion.

3 Enter dimensions or other values in the Properties bar (see 
“Using specialized drawing tools,” page 18.10 for the related 
dimensions and values).

Ovals and rectangles Enter height and width values. For rounded 
rectangles, also enter the corner radius.

Lines Enter the distance and angle from the point you clicked to 
the second point. Or, enter the horizontal (X) and vertical (Y) dis-
tance to the second point.

Arcs Enter the width and height, the starting point in degrees, and 
the angular length of the arc.

4 Click Create to draw the object.

Tip
You can also enter values in the 
Properties bar for some Path tools.

Properties bar with Arc tool 
selected.

Click a handle
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Using specialized drawing tools
Several specialized drawing tools let you quickly create complex 
shapes in Canvas. Drawing grids, stars, polygons, concentric circles, 
cubes, and spirals is as easy as drawing rectangles. 

The tools shown in the following table create specialized vector 
objects. 

In most cases, you can treat these vector objects like all others. You 
can move them and resize their bounding boxes. They can be 
rotated, flipped, and scaled. You can apply strokes, pen inks and fill 
inks to them; however, most of these objects are compound objects, 
which means that they are made up of separate objects. Therefore, 
some inks and other effects appear differently when applied to 
these objects than to simple vector objects like rectangles and ovals.

Some of the specialized objects have unique editing features. For 
example, you can twirl the points of a star, star outline, or framed 
star by dragging special handles. You can also specify the number 
of points of a star, the number of rows and columns in a grid, the 
number of rings in concentric circles, and the number of revolu-
tions in a spiral. You can draw a cube with or without a perspective 
effect. Methods for drawing and modifying all of the specialized 
objects appear with the individual tool descriptions on the follow-
ing pages.

You can also convert most specialized vector objects to paths, 
which lets you edit the objects’ anchor points and segments (see 
“Converting objects and text to paths” on page 19.24).

Use this tool to draw this

Concentric Circles Nested circles or ovals

Cube Square and rectangular boxes in isometric views

GridMaker Rows and columns of boxes 

Multigon Stars and complex polygons

Spiral Lines in spiral patterns

Annotations Callouts and charts
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Concentric circles
The Concentric Circles tool draws nested rings of ovals or circles. 
Set the number and spacing of the rings before or after you draw 
concentric circles.

To use the Concentric Circles tool
1 Select the Concentric Circles tool.

2 Drag to draw a bounding box that defines the size of the con-
centric circles object. A rectangular bounding box creates concen-
tric ovals; a square bounding box creates true circles.

3 When you finish, the concentric circles object is selected. 

• To draw true concentric circles: Press Shift to constrain the 
bounding box to a square when you drag the Concentric Circles 
tool.

• To draw from the center: Press Option (Mac) or Ctrl (Windows) 
to draw from the center outward with the Concentric Circles tool. 
Press Shift also to draw perfect circles outward from the center.

To edit Concentric Circles object
You can change the number of rings as well as spacing of an exist-
ing Concentric Circles object.

1 Select the Concentric Circles object. The related values 
appear in the Properties bar.

2 Adjust the settings as described in the next section. Press 
Enter to apply the settings to the object.

To configure the Concentric Circles tool
Before you draw an object, select the Concentric Circles tool to 
make the settings appear in the Properties bar. Use these settings to 
configure the Concentric Circles tool before you draw with it, or to 
change the configuration of an existing Concentric Circles object.

Properties bar with Concentric 
Circles tool selected.

A Enter the number of circles you want in the Concentric 
Circles object.

B Enter the number of points between each circle. Zero will 
evenly space the circles.
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Drawing cubes
The Cube tool draws 2D cubes using the current object attributes.

To draw a cube
1 Select the Cube tool. 

2 Drag to draw the rectangular back face of the cube. To con-
strain the faces of the cube to perfect squares, hold down the Shift 
key while drawing the back face.

3 Release the mouse button when the back face of the cube is 
set as you want; an unanchored cube then follows the pointer.

4 Position the cube so it appears at the length and angle you 
want, and then click to anchor it. 

• To give the cube a perspective effect by enlarging the front face:

Hold down the Command key (Mac) or the Alt key (Windows) 
before you anchor the cube.

To edit cubes
To change the height or width of a cube, click the cube to select it, 
and then drag a corner handle. To reshape a cube by moving a side, 
double-click the cube to place it in edit mode. A black circular han-
dle appears on each of the six faces of the cube. 

When you point to a handle, the outline flashes on the correspond-
ing side of the cube. You can drag the handle to move that side. 
Click outside the cube to leave edit mode.

Drawing spirals
The Spiral tool draws a smooth, spiraling curve. You can set the 
number of spiral turns before or after you draw a Spiral object.

1 Select the Spiral tool.

Drawing the back face 
of the cube

Positioning the front 
face of the cube

Finished cube 
selected

Pointer

A cube in edit mode

Front FaceHandle

Pointer
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2 Drag diagonally to specify the size of the spiral curve. 

• To create a circular spiral: Press Shift and drag.

To configure the Spiral tool
1 Select the Spiral tool. The settings appear in the Properties 
bar.

2 Set the number of spirals and the spiral direction.

• To change the number of spirals in an object: Select the Spiral 
object. In the Properties bar, change the number of spirals and 
press Enter.

Drawing grids
The GridMaker tool draws grids of rows and columns. Set the num-
ber of rows and columns before or after you draw a grid object.

1 Select the GridMaker tool.

2 Drag diagonally to define the grid’s bounding box. 

• To create a square grid: Press Shift and drag.

To configure the GridMaker tool
1 Select the GridMaker tool. The settings appear in the Proper-
ties bar.

2 Set the number of boxes comprising the grid as well as the 
cell size.

• To modify grid object: Select the Grid object to make the set-
tings appear in the Properties bar. Change the number of boxes or 
cell size and press Enter.

Set the number of turns 
(maximum 35) in the spiral

Set the number of columns
Set the number of rows

If you set Boxes Across to 1, the grid has no vertical lines. 
If you set Boxes Down to 1, the grid has no horizontal lines.
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To separate a grid into lines
Adjust the individual lines that comprise a grid by converting it to a 
path and then ungrouping it.

1 Select the Grid object and choose Object > Path > Convert to 
Paths.

2 Choose Object > Ungroup. The grid object separates into 
individual lines.

Drawing with the Multigon tool
Use the Multigon tool to draw all types of multi-sided objects, 
including triangles, hexagons, pentagons, octagons, stars, circular 
starbursts, and similar shapes. To set the number of sides and the 
style of a multigon, configure the Multigon tool before you draw.

• To draw with the Multigon tool: Select the Multigon tool. Drag 
diagonally to define the multigon’s bounding box. To make the 
bounding box square, press Shift and drag.

• To configure the Multigon tool: Select the Multigon tool. The 
settings appear in the Properties bar. Set the multigon style and 
other options (described next) and click OK.

Style Appearance

Frame No interior lines

Framed Star Combination of Frame and Star objects

Spoke No sides connecting the spoke points

Star Points connected by interior lines

Star Outline Multiple points with no interior lines

Wheel Combination of Frame and Spoke objects
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To save custom Multigon settings
Save Multigon settings so you can use them later. In the Properties 
Multigon dialog box, press the triangle at the lower-left to save, 
select, and delete custom multigon styles.

• To save multigon settings: Choose Save Shape. Type a name for 
the shape and click OK. The name appears in the pop-up menu.

• To delete a style: Choose Delete Shape. In the dialog box, 
choose the shape name you want to delete and Click OK. You can’t 
delete any of the built-in styles.

Note: When you save and delete styles, they remain saved or deleted 
whether you click OK or Cancel to close the Multigon dialog box.

To edit Star Multigon objects
You can interactively edit Star Multigons (framed star, star, and 
star outline styles) to adjust the twirl and radius of the object’s 
points. The following procedures do not apply to frames, spokes, or 
wheels.

1 Double-click the Star Multigon to put it in interactive mode. 
An outer handle and inner handle appear on one point of the star.

• To change the length of the star points: Drag the outer handle 
inward or outward from the center of the star.

• To twirl the points: Drag the handle clockwise or counterclock-
wise.

• To change the position of the inner points: Drag the inner han-
dle inward or outward from the center.

Multigon settings

The available options depend on the 
selected multigon style.

A Choose a preset style in the pop-up 
menu.
B For stars, framed stars, and star out-
lines, enter the number of star points 

from 3 to 100. For other styles, enter the 
number of sides from 3 to 100.
C Drag the slider to change the interi-
or area of stars, framed stars, and star 
outlines.
D Turn this option on to smooth the 
object’s angles.

E For stars, enter a value of more or 
less than 0 degrees to bend the points. 
Negative values bend the points counter-
clockwise.
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2 Press Enter (Mac) or Esc (Windows), or double-click outside 
the object to end interactive editing.

Making manual registration marks
Use the Registration Mark tool to manually enter registration 
marks around a graphic for which you intend to print separations. 
Use the Registration Mark tool for the following reasons:

• The size of the graphic occupies the printable area, there-
fore preventing the print separation marks from appear-
ing. 

• You layout different graphics on a single sheet and plan to 
print each graphic individually. 

Define the appearance of the registration marks via the settings in 
the Properties bar. Select the Registration Mark tool to make these 
settings appear.

Placing crop marks
For print production, you can place crop marks around specific 
objects in your document. This is useful when you want to control 
the exact placement of crop marks, or you want to output several 
illustrations with crop marks around each illustration on one page.

Crop marks are short vertical and horizontal lines that indicate the 
border where an illustration or page can be trimmed.

When you use the Crop Marks commands, Canvas draws the crop 
marks as vector lines on the current layer in the document. Each 
crop mark consists of two lines. You can select the lines and per-
form operations on them as you would other vector objects.

To place crop marks
1 Select the objects you want to place crop marks around. You 
can select one or more objects of any type.

2 Choose Object > Options > Crop Marks. 

Size selector (the 
default size is 72 pts)
Minimum size is 8 pts 
& Maximum size is 
288 pts

Appearance options (the default 
appearance is White fill)

Crop marks
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3 The Crop Marks dialog box appears. In the Outset box, enter 
the distance you want the crop boundary to be from the selection. 

• If one object is selected, the selection boundary is the 
object’s bounding box.

• If more than one object is selected, the selection boundary 
is the smallest rectangle that would enclose all the selected 
objects.

4 Select the Use Registration Ink option to assign Registration 
ink color to the crop marks. Registration ink appears black, but it 
prints on all plates when you output color separations. This 
option should be selected if you want the crop marks to print on 
all plates.

5 Click OK to create the crop marks.

Creating calendars with the Calendar tool
To use the Calendar tool, you must define at least a 1-inch x 1-inch 
rectangle. Select the Calendar tool and the cursor changes to a 
crosshair. Drag the crosshair to form at least a 1-inch x 1-inch rect-
angle and the Calendar dialog box opens so you can define your 
calendar.

To create a calendar
1 Enter the starting month and year. The default month is the 
current month and year.

2 Enter the ending month and year. The default month is the 
current month and year.

3 Enter the number of columns; e.g., if your calendar is for 8 
months and you enter 4 in this field, your calendar would have 4 
columns and 2 rows.

Note: Select the Include Lunar Phases checkbox if you want lunar 
phases to appear on your calendar.
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Annotations tools
Use these tools to add labels or callouts to your diagrams or illustra-
tions or even create a dynamic flowcharts. 

When you click in the drawing area with these tools, Canvas creates 
an object shape complete with connector lines. You can even select 
the type of connector line (see “Connecting objects with Smart 
Lines,” page 18.19). The EasyShapes™ tool only creates an object 
shape, but you can combine this tool with Smart Lines to create 
dynamic flowcharts.

When using Annotations tools A-D, you should select the object 
shape from the Label Shape popup palette on the Properties bar 
before you begin designing; however, you can change the object 
shape after it has been drawn, if necessary (see “To change object 
shape” on page 18.19). When you use the EasyShapes tool, you first 
select an object shape from the EasyShapes popup palette.

To add a callout
Depending on your needs, select tools A to C. 

1 Click in the drawing area where you want the first callout to 
appear. 

2 Follow the prompts as indicated.

3 Press Esc when you have finished creating the callout(s). You 
can also double-click after completing the last item.

To use the EasyShapes tool
Draw all kinds of shapes, including arrows, flow chart boxes, dialog 
balloons, symbols, and banners, using EasyShapes™.

1 Select the EasyShapes tool. The EasyShapes popup palette 
appears.

A Basic
B Multiple Sources
C Multiple Notes
D Flowchart 
E EasyShapes

Properties bar - Annotations tools A-C selected

Properties bar - EasyShapes tool selected
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Note: The EasyShapes popup palette is only available if the 
EasyShapes tool is selected.

2 Select an object shape from the palette. The cursor switches to 
a crosshair in the drawing area.

3 Drag the cursor in the drawing area.

Note: You can also create an object shape by entering values in the 
X/Y and width/height fields in the Properties bar and then clicking 
the Create button. By default, the X/Y coordinates are set at 0,0.

To create a chart
You have the choice of using either the EasyShapes tool or Flow-
chart tool. With the Flowchart tool, the object shape and connector 
line are created simultaneously. If you use the EasyShapes tool, you 
will have to create your connector lines afterwards with a Smart 
Lines tool (see “Connecting objects with Smart Lines,” page 18.19). 

1 Select either tool. 

2 Follow the prompts for the Flowchart tool. For the 
EasyShapes tool, select and create an object shape (see “To use 
the EasyShapes tool” on page 18.18).

To change object shape
1 Select the object shape so the Type icon appears in the Prop-
erties bar.

2 Click on the icon to open the Shape popup palette.

3 Select another object shape. The object shape changes imme-
diately.

To change the text
Before you create the annotations object, enter the text in the text 
field in the Properties bar. If you have already created your 
object(s), select the Text tool and click on the text in the object to 
enter text edit mode. Edit the text as needed using the text settings 
in the Properties bar and then exit text edit mode.

Connecting objects with Smart Lines
The Smart Line tool draws dynamic links between objects. Smart 
Lines are useful for creating organizational charts, flow diagrams, 
and other illustrations with linked objects (see “Annotations tools,” 
page 18.18).
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Use Smart Lines to link one or more objects to a single object. Draw 
multiple Smart Lines between objects and link Smart Lines to other 
Smart Lines. Smart Lines change length and angle to maintain con-
nection to the linked objects.

The Smart Line tools consist of the Basic, Kinked, Smooth Kinked, 
Dogleg Connector, and Connection Point tools. 

To use a Smart Line tools
1 Select a Smart Line tool. 

2 Drag from one object to another object. When you release the 
mouse button, Canvas creates the Smart Line.

To change Smart Line type
1 Select the Smart Line with the Selection tool. The Type 
menu appears in the Properties bar.

2 Choose another Smart Line type from the menu. You can 
select Basic, Kinked, Smooth Kinked, or Dogleg. The line 
changes immediately.

To change the position of start and end points
1 Select the Smart Line with the Selection tool. The Properties 
bar displays the X/Y values coordinates for the start and end 
points.

2 Enter new values in these fields and press Enter. The Smart 
Line shifts accordingly.

If the Dogleg Connector or a Kinked or Smooth Kinked Smart 
Line is selected, the Properties bar contains additional information, 
which is not applicable to Basic Smart Lines.

Start Direction For Kinked Smart Lines, select either Auto, Hori-
zontal, or Vertical to change the slope of the Start direction. For 
Dogleg connections, select either Auto, Left Always, or Right 
Always to change the direction of the dogleg portion.

End Direction Select either Auto, Horizontal, or Vertical to change 
the slope of the End direction.

Basic 

Kinked 

Smooth Kinked

Connection Point

Dogleg Connector

Properties for Smart Line
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Tab Length This value refers to the horizontal portion of a dogleg 
connection created with the Dogleg Connector tool. Enter a value 
in this field and press Enter. The angled portion of the connection 
does not change.

• To unsmooth a Smooth Kinked Smart Line: Select the line and 
choose Kinked from the Type menu in the Properties bar. 

• To smooth a Kinked Smart Line: Select the Kinked Smart Line 
and choose Smooth Kinked from the Type menu.

To use the Connection Point tool
This tool is used to move the anchor points of a vector object. You 
can also add and remove anchor points.

1 Select the Connection Point tool. The cursor changes to a 
crosshair.

2 Click the tool on an existing vector object. The anchor points 
should appear as shown to the left. When you place the crosshair 
on an anchor point, the anchor point is emphasized.

3 Click the crosshair on an anchor point and drag it to its new 
location. You cannot move an anchor point beyond an object’s 
bounding box.

• To add an anchor point: Ctrl-click (Windows) or Option-click 
(Mac) the crosshair anywhere within the vector object.

• To remove an anchor point: Press Control+Shift (Windows) or 
Option+Shift (Mac) and click the crosshair on the existing anchor 
point that you want to delete.

Math Expression 2-D Plot commands
Canvas has included commands that can be used to obtain a visual 
representation of an equation. Combine these commands with Can-
vas’ export capabilities to quickly create either a presentation or 
PDF version of technical or scientific reports. You can even export 
as HTML. 

• To open the Math expression 2-D Cartesian Plot dialog box:

Choose Object > Math Expression 2-D Plot > Cartesian.

• To open the Math expression 2-D Polar Plot dialog box: Choose 
Object > Math Expression 2-D Plot > Polar.
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To use the Math Expression 2-D Plot commands
1 Define the mathematical equation using the Categories scroll-
box and their related items.

2 Double-click on an item to make it appear in the Expression 
field.

Note: The lower portion of the dialog box indicates the correct syn-
tax and shows an example of the expression.

3 Enter values in the range fields. The maximum range must 
be greater than the minimum range. You can also enter a value in 
the “1 Unit of” fields to set a scale. 

4 Use the Steps menu to control the quality of the curve.

5 Click OK to create the visual representation.

Menu icon
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• To save an expression: Click on the menu icon and select Save 
expression as. The Save expression as dialog box opens. Enter a 
name for the expression and click OK.

• To load a saved expression: Click on the menu icon and select 
the expression’s name from the list. The equation appears in the 
Expression field.

• To delete a saved expression: Click on the menu icon and select 
Delete expression. The Delete expression preset dialog box 
appears. Select the expression from the Name menu and click OK.

Examples of objects created using the 2-D Polar Plot dialog box

Formula: r=1-sin(θ)
Expression: r=1-sin(x)
x: 0 - 6.29
r: -10 - 10
Counterclockwise
1/1

Formula: r=sin(2θ)
Expression: r=sin(x)
x: 0 - 6.29
r: -10 - 10
Counterclockwise
1/1

Formula: r=θsin2(θ) 
Expression: r=x*(sin(x))^2
x: 0 - 6.29
r: -10 - 10
Counterclockwise
1/3

Formula: r=2θ 
Expression: r=2*x
x: -31.4 - 31.4
r: -50 - 50
Counterclockwise
1/40

Formula: r=sin(6θ)+log(1.5)
Expression: r=sin(6*x)+log(1.5)
x: 0 - 6.29
r: -10 - 10
Counterclockwise
1/1

The visual representation is created as 
a vector object that use the current 
pen and fill inks. You can also apply 
any vector object effect as well as 
change the fill and pen inks.

These objects can also be rendered 
and exported as an image.

Tip
Saved expressions appear at the 
bottom of the menu list.
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19
DRAWING & EDITING PATHS

Path tools let you draw and edit vector object paths of any shape. 
This chapter explains how to draw paths, edit paths, and edit 
curves segments using the control points that define them.

Drawing with the Path tools 
You can use the Curve, Polygon, Smooth Polygon, Freehand, and 
Auto Curve tools to draw vector objects as open or closed paths. 
When you use the Curve, Polygon, Smooth Polygon, and Auto 
Curve tools, you set anchor points to define path segments. With 
the Freehand tool, you simply drag to draw a path. The Reshape 
and Push tools let you edit paths.

The Polygon tool draws paths with straight segments. The Smooth 
Polygon tool draws paths with smooth line segments. The Curve 
and Auto Curve tools can draw paths with straight and curved seg-
ments. Paths drawn with the Freehand tool generally are made of 
curved segments based on the movement of the pointer.

When you draw with the Path tools, Canvas uses the current pen 
ink, fill ink, and stroke settings for the vector objects you create.

Drawing polygons 
When you use the Polygon or Smooth Polygon tool to draw an 
object, you set anchor points that define a path of straight line seg-
ments or smooth line segments, respectively. You can later curve 
the straight segments, as with any path object. For editing informa-
tion, see “Editing object paths” on page 19.7.

1 Select the Polygon tool or Smooth Polygon tool.

2 Click to set the first anchor point, shown as a small square.

3 Click where you want to place the second anchor point.

• You can press the pointer to display the segment, drag to 
position it, and then release the mouse button.

• To constrain placement of a segment to 45° intervals, 
press Shift while drawing the segment.

4 Repeat the last step to draw more segments. 

Path tools 

Curve, Polygon, Smooth Polygon, 
Freehand, Push, Reshape, Auto 
Curve
19.1
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• To remove the last segment you drew: Press Delete.

5 To complete the polygon:

• For an open polygon, after you place the last anchor point, 
press Enter (Mac) or Esc (Windows), or double-click to 
place the last anchor point.

• For a closed polygon, click the starting anchor point, and 
then press Enter (Mac) or Esc (Windows), or double-click 
the starting anchor point.

Smoothing polygons with straight segments
If you created a path object with the Polygon tool, use the Smooth 
command to convert a straight-segment polygon to a path with 
smooth curves. You can smooth any paths made of straight seg-
ments, including rectangles and paths drawn with the Curve tool, 
as long as they have only straight segments. The Smooth command 
is a convenient way for those who haven’t mastered curve drawing 
to create smooth shapes.

Note: If you require that the polygon object have smooth curves, you 
should use the Smooth Polygon tool if you haven’t yet created the 
object.

• To smooth a straight-segment polygon: Select the polygon and 
choose Object > Path > Smooth. Canvas converts the polygon’s cor-
ner points into smooth points, which changes the path’s straight 
line segments into curved segments. For more information about 
editing smooth points and curved segments, see “Reshaping paths 
by editing anchor points” on page 19.21.

Use the Unsmooth command to restore the straight segments of a 
polygon that was smoothed with the Smooth command. However, 
you can use Unsmooth only if the smoothed polygon wasn’t edited 
after it was smoothed.

Click to place first point Click additional points, 
double-click last point

Completed polygon 
(selected)

Polygon finished with solid 
black fill ink 

Polygon

Smoothed
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• To unsmooth a smoothed polygon: Select the smooth polygon 
and choose Object > Path > Unsmooth. Canvas restores the poly-
gon’s straight line segments. 

Drawing freehand paths 
You can draw objects with the Freehand tool by simply dragging 
the pointer. The Freehand tool creates paths with curved segments 
based on the movement of the pointer.

As with any path object, you can later edit the path and reshape its 
segments; see “Editing object paths” on page 19.7.

• To draw a freehand path: Select the Freehand tool in the Path 
Tools toolbar. Position the pointer where you want the path to 
begin. Drag to create a path. To create a closed path, release the 
mouse button when the pointer is on the starting point.

• To set the curve tolerance: You can tell Canvas to use relatively 
more or fewer anchor points to represent a curve. Select the Free-
hand tool and the Set Tolerance box appears in the Properties bar. 
In the text box, type a value from 1 to 5, where a value of 5 tells 
Canvas to use as few anchor points as possible.

If you have difficulty drawing smooth curves with this tool, try low-
ering the speed setting for your mouse (or other pointing device). 
Refer to your system documentation for information on these set-
tings.

Drawing curved paths
The Curve tool is the most versatile of the path tools. You can use it 
to draw precise paths with straight and curved segments. When you 
draw curved segments, you place an anchor point and a tangent 
line at the start of each segment. The position and length of the tan-
gent line controls the shape of the curved segment.

Paths drawn with the Freehand 
tool
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You can also draw straight paths by clicking with the Curve tool, 
similar to the way you use the Polygon tool (see “Drawing poly-
gons” on page 19.1).

To draw a path with curved segments
1 Select the Curve tool.

2 Where you want the path to begin, do one of the following:

• Click to set the anchor point and, before releasing the 
mouse button, drag to position its tangent line.

• Click to set the anchor point without creating a tangent 
line.

When you release the mouse button, the anchor point appears.

3 Where you want the segment to end, do one of the following:

• Drag to simultaneously set an anchor point and position a 
tangent line.

• Click to set the anchor point without creating a tangent 
line.

This finishes the first curve segment.

4 Repeat the previous step to draw additional segments.

5 To complete the path, use one of the following options:

Anchor point

Tangent line

Defining curves

Anchor points determine where path 
segments (A and B) start and end. Tan-
gent lines at each anchor point control 
the shape of curve segments.

A tangent line affects the adjacent seg-
ment. The tangent line of a segment’s 
other anchor point (not shown) also 
affects the segment’s shape.

Handle
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• For an open path, after you place the last anchor point, 
press Enter (Mac) or Esc (Windows). You can also double-
click to place the last anchor point.

• For a closed path, click the starting anchor point, and then 
press Enter (Mac) or Esc (Windows). You can also double-
click the starting anchor point.

Shaping and editing segments as you draw
As you draw with the Curve tool, you can use modifier keys to con-
strain and edit the path segments.

• To place an anchor point at a 45° interval relative to the previous 
one: Press Shift as you set the second anchor point.

• To create a straight segment: Press Option (Mac) or Ctrl (Win-
dows) as you click to set the segment’s endpoint.

• To remove the last segment: Press Delete. You can continue to 
remove segments in the reverse order you created them, until you 
delete the entire object.

• To constrain a tangent line to 45° increments: Press Shift as you 
drag the tangent line.

Drawing auto curves 
The Auto Curve tool draws and edits curved paths. This tool makes 
it easy to draw smooth curves because it automatically curves path 
segments as you simply click or drag the mouse.

When you use the Auto Curve tool, you don’t have to position tan-
gent lines that control the shape of curves. Instead, you simply click 
to set anchor points and smooth curve segments appear. You can 

To draw the curve shown in gray, 
press and drag to set the first anchor 
point and tangent line.

Press and drag to set the next anchor 
point and tangent line. The first seg-
ment (highlighted) grows as you draw 
out the tangent line. 

Press and drag to set the third anchor 
point; the second segment (highlight-
ed) grows as you drag the tangent 
line.
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drag the mouse to see how the path will curve before you set each 
anchor point.

Like the other path tools, you can use the Auto Curve tool to draw 
new paths and to add segments to paths as you edit them. 

To use the Auto Curve tool
1 Select the Auto Curve tool. 

2 Click in the drawing area to set the beginning point of a path. 
If you are editing a path, click to set the path’s next anchor point.

3 Move the mouse and click to set the second anchor point. A 
straight segment connects the first and second points. 

• You can press Shift when you click to snap the first seg-
ment to a 45° angle.

4 To set the third anchor point, do either:

• Click to set the anchor point. This completes a smooth 
curve from the first anchor point to the new anchor point.

• Hold down the mouse button and move the mouse to pre-
view the curve. You can see the segments bend as you 
move the pointer. Release the mouse to set the new anchor 
point.

5 Repeat the previous step to continue adding anchor points to 
the path. You can also select other path tools (Curve, Polygon, 
Push, and Reshape) to continue adding segments to the path.

6 To finish drawing the path, do either:

• Press Esc. 

• Double-click to set the final anchor point. You must dou-
ble-click on the starting point to complete a closed path.

When you finish drawing, the path object is selected. Canvas 
applies the current pen ink, fill ink, and stroke to the path. You can 
use path editing tools and techniques to modify the path.
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Editing object paths 
Most vector objects in Canvas are paths. Whether you draw with 
Path tools (Curve, Freehand, Polygon, Smooth Polygon, Auto 
Curve) or other shape tools (Rectangle, Oval, Line, Arc), you create 
paths, and you can use the same path-editing techniques to modify 
them.

Of course, you can also change a path object by using handles on 
the bounding box when the object is selected (see “To resize an 
object’s bounding box” on page 18.4).

Displaying inks and strokes
Canvas has two display modes you can use when you edit paths. 
You can display the fill inks, pen inks, and stroke on paths, or you 
can hide the attributes while you work in path edit mode.

• To display attributes on paths: Be sure that the command 
Object > Path > Live Curve Editing is selected and has a checkmark 
in the menu. To hide attributes in path edit mode, select the com-
mand again.

You can change the path-editing display at any time. To use the 
Live Curve Editing command, objects do not have to be selected or 
be in path edit mode.

Click1

2

3

4
Click

Click

Drawing Auto Curves

With the Auto Curve tool, click to set 
anchor points 1 and 2 to start a path.

Click to set point 3. The first and sec-
ond segments bend to form a smooth 
curve.

You can click to set more anchor 
points and draw additional curved 
segments. Press Esc to finish the 
path.

Path with pen and fill inks
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Editing paths with the Reshape tool
The Reshape tool provides an easy-to-use, interactive way to edit 
paths. Using the tool is as simple as dragging the mouse. The tool 
will reshape the parts of a path that you drag over. 

To use the Reshape tool
1 Select an object to edit. To use the Reshape tool, one vector 
object can be selected or be in path edit mode.

2 Select the Reshape tool. 

3 Move the pointer close to the path and a reshape symbol (~) 
will appear at the pointer. The symbol indicates that you can drag 
to reshape the path. 

4 Drag to draw a new segment in the shape you want. When 
you release the mouse, Canvas applies the segment you drew to 
the path. 

After you use the Reshape tool, the object remains selected or in 
edit mode. Continue to use the Reshape tool to modify the path.

Reshaping a straight line into a 
curved path

Changing the shape of a curve 
segment 

Dragging to reshape a segment and 
shorten the path
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Reshape techniques
When you drag the Reshape tool, the direction that you drag affects 
the way the tool modifies the path.

If you drag in one direction and finish on the path, the tool will 
reshape the path to match the line that you draw. 

If you finish dragging away from the path, the Reshape tool can cre-
ate a new segment that opens a closed path. If you drag the tool on 
an open path, you can draw a new segment that closes the path. 
You can also drag the tool so it reshapes part of a path and removes 
the rest.

In general, if you drag in one direction along a path, the tool will 
change the shape of a segment without removing the rest of the 
path or opening the path. For example, if you follow the curve of a 
circle as you drag from the top toward the bottom, you can make 
the circle narrower. If you drag from one part of the circle and 
change direction, you can create a segment that changes the circle 
to an open path.

Experimenting with the Reshape tool is the best way to learn the 
various techniques you can use to modify paths.

Editing paths with the Push tool
The Push tool provides an alternative way of editing paths. The 
tool lets you form curves without having to edit anchor points and 
tangent lines. The Push tool is useful for people who are not experts 
at editing paths and who want to simply drag on path segments to 
bend them into shape.

The Push tool bends a path where you “push” (drag) on it. Imagine 
that a rope is laid out straight on a table. If you push your finger 
against the middle of the rope, you form a curve at that point. Using 
the Push tool has a similar effect on a straight segment of a path.

Dragging in one direction reshapes 
the circle

Changing direction adds a 
segment and opens the path

Dragging a path with the Push tool 
bends the path. The Range setting 
controls the width of the effect.
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You can adjust the range of the Push tool effect. A smaller range 
results in sharper bends, and a larger range results in smoother 
bends.

To use the Push tool
1 Select an object to edit. One vector object can be selected or 
be in path edit mode.

2 Select the Push tool. If you want to change the Range of the 
Push tool, enter a value in the text box in the Properties bar.

3 Drag on the path where you want to push a segment into a 
curve shape. When you release the mouse, Canvas reshapes the 
path.

After you use the Push tool, the object remains selected or in edit 
mode. Continue to use the Push tool to modify the path.

Push tool Range 
To change the Range of the Push tool, use the Range settings in the 
Properties bar when the tool is selected. The Range value is 
expressed in the rulers’ measurement units.

To specify the Range value, enter a value in the Range text box. 
You can type an abbreviation for the measurement units following 
the range value; e.g., to set the Range to 10 picas when the ruler 
units are inches, enter “10p” in the text box.

Depending on the Range setting, editing a path with the Push tool 
can add or remove anchor point from the path; e.g., when the 
Range value is low, the Push tool is likely to add anchor points 
where you push a path. However, when the range is high and a path 
is not straight, the Push tool can smooth out a part of the path, 
which can result in fewer anchor points.

Working with objects in edit mode
To edit points and segments of a path, place the path object in edit 
mode. In edit mode, a path’s anchor points appear as small squares 
along the path. Every path has at least two anchor points. 

Range (top to bottom):
3 in., 2 in., 1 in.
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When an object is in edit mode, you can select one or more anchor 
points. You can even select anchor points and segments on more 
than one object at once, as long as the objects are in edit mode.

To place an object in edit mode
Do one of the following to place a path object in edit mode:

• Select the object with the Direct edit selection tool.

• Double-click the object with the Selection tool.

• Select the object and choose Object > Path > Edit Path or 
choose Object > Edit > Object.

• Select the Selection tool after placing an anchor point 
while you are drawing a path.

• To place multiple objects in edit mode: You can place two or 
more objects in edit mode by selecting them with the Direct edit 
lasso selection tool or by selecting them with the Selection tool and 
then choosing Object > Path > Edit Path.

• To return from edit mode: When you finish editing an object, 
click outside the object with either the Direct edit selection tool or 
Direct edit lasso selection tool. You can also double-click outside 
the object with the Selection tool. In addition, you can press the 
Enter key (Mac) or the Esc key (Windows) to leave edit mode.

To edit special vector objects
Some Canvas drawing tools create specialized objects. When you 
double-click one of these objects to place it in edit mode, Canvas 
displays special editing handles or configuration options, rather 
than the anchor points and segments of a regular path object.

Object path drawn with Curve tool Object in edit mode, with anchor 
points visible
Editing object paths 19.11



19
The tools that create special vector objects are the Concentric Cir-
cles, Cube, Polygon, Grid Maker, Multigon, or Spiral. Also, when 
you modify objects with the Envelope or Extrude commands, Can-
vas creates specialized objects.

If you want to use path-editing techniques to modify these objects, 
you can convert them to paths. This usually produces a group of 
objects. After you ungroup these objects, you will have regular 
paths that can be edited using the techniques in this chapter. You 
can also convert text characters to paths so that you can edit the 
shapes of individual characters (see “Converting objects and text to 
paths” on page 19.24).

Editing paths with the context menu
When a path is in edit mode, you can use the context menu to 
quickly add, delete, and change anchor points and tangent lines. To 
see this menu, Control-click (Mac) or right-click (Windows) with at 
least one object in path edit mode. The available options vary 
depending on the location of the pointer. Each option is described 
next.

Delete Point Available when the pointer is on an anchor point and 
appears as a crosshair. Removes the anchor point from the path, 
and connects the adjacent anchor points with a new segment.

Cusp Available when the pointer is on a tangent line handle or an 
anchor point. On anchor points, this option deletes the point’s tan-
gent lines. On tangent line handles, this option makes the path 
either smooth or cornered at the anchor point. To be smooth, the 
anchor point must have both sides of a tangent line. When smooth, 
the halves of the tangent line are always 180° from each other and 
rotate around the anchor point like a propeller. When the anchor 
point is a corner, the tangent line segments can move indepen-
dently around the anchor point, like the hands of a clock.

Smooth available when two or more points of an object are 
selected. You can smooth any paths made of straight segments.

Fillet Available when the pointer is on a corner point (with less 
than two tangent lines between two segments. Fillet creates a radius 
corner between the two segments. When you choose Fillet, a dialog 
box appears. Enter a radius value in the text box and click OK. The 
larger the radius value, the larger the curved segment. A message 
appears if the radius value is too large for the angle of the segments.

Path-editing Context menu
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Add Point Available when the pointer is on a path segment and 
appears as a gray arrowhead. Inserts an anchor point with a tangent 
line where you click.

Break Available when the pointer is a gray arrowhead on a path. 
Splits the path segment at that location, and adds anchor points to 
the ends of the resulting segments.

Join Available when you select two anchor points that are not con-
nected. Connects the selected points with a straight segment.

Delete Handle Available when the pointer is on a tangent line han-
dle and appears as a crosshair. Removes the handle and the effects 
of the tangent line on the path (see “To delete tangent lines,” 
page 19.23).

Add Handle Available when the pointer is on an anchor point and 
there are fewer than two tangent line segments at the anchor point. 
Adds one or two tangent line segment to the anchor point (see “To 
add a tangent line,” page 19.22).

Straighten Available when the pointer is on a path segment and 
appears as a gray arrowhead. Makes the path segment straight by 
removing tangent lines from the segment’s anchor points.

Enable Symmetrical Drag Available when an object is in path edit 
mode. You can easily create a symmetrical design from a circle, 
rectangle, or a complex group of objects (see “To symmetrically 
resize path points,” page 19.28).

Selecting anchor points and segments
When you edit paths, you need to select particular anchor points or 
segments before you can delete, move, or reshape them. Before you 
can select anchor points and segments, a path object must be in edit 
mode (see “To place an object in edit mode” on page 19.11). 

When a path is in edit mode and you point to an anchor point with 
a Selection tool, the pointer becomes a crosshair. When you point 
to a segment, the pointer becomes a gray arrowhead. The Selection 
tools are explained in “Selecting objects with Selection tools,” 
page 17.3.
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You can select points in more than one path. When you move any 
selected point, all points in the selection move the same way. (If all 
the points in a path are selected and you drag one, the entire path 
moves.) This also works for segments belonging to separate paths.

• To select anchor points and segments: With the path object in 
edit mode, click an anchor point or segment to select it. To select 
multiple points or segments, use either the Direct edit selection tool 
or the Selection tool to drag a selection box around them or Shift-
click each point or segment.

• To select all anchor points: With the path object in edit mode, 
choose Edit > Select All.

• To select parts of separate paths: Place the paths in edit mode, 
and Shift-click the point or segments.

When an anchor point is selected, it changes from a solid to hollow 
square. If the anchor point has tangent lines, they appear when the 
anchor point is selected. All tangent lines that affect the segments 
that touch the selected anchor point also appear. When you select a 
segment, the anchor point at each end is selected. 

Adding and deleting points and segments
If a segment’s anchor points are too far apart for you to adjust the 
shape as needed, add more. If you create or add more anchor 
points than you need, delete unnecessary ones.

Keep in mind that the more points on a path, the more complex 
and system resource-intensive it becomes. In particular, too many 
anchor points can cause printing problems. It’s best to use the few-
est possible anchor points placed as far apart as possible to create a 
path.

• To add an anchor point: With an object in edit mode, Ctrl-click 
(Mac) or right-click (Windows) a segment to which you want to add 
an anchor point. In the path Context menu, choose Add Point. You 
can also Option-click (Mac) or Ctrl-click (Windows) a segment to 
add a point.

• To delete an anchor point: With an object in edit mode, Ctrl-
click (Mac) or right-click (Windows) the point you want to delete. In 
the path Context menu that appears, choose Delete Point. You can 
also Option+Shift-click (Mac) or Ctrl+Shift-click (Windows) a point 
to delete it, or select points and press the Delete key.

Use the Selection tool to select 
multiple anchor points.
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• To delete a segment: Select the anchor points at each end and 
press Delete. Deleting a segment of a closed path does not open the 
path; the remaining segments are joined and the path remains 
closed.

To add segments to an open path
Add segments to the end of an open path using the Curve tool or 
Polygon tool.

1 With the object in edit mode, select the endpoint where you 
want to add a segment.

2 Select the Curve tool (to add straight or curved segments) or 
Polygon tool (to add straight segments).

3 Click to add a straight segment beyond the selected endpoint. 
With the Curve tool, add a curved segment by clicking the mouse 
to establish the new anchor point and then dragging to position 
the tangent line.

4 To add additional segments, repeat the previous step. When 
you finish, press Enter (Mac) or Esc (Windows) to leave edit 
mode.

To add points to a curve
Often technical illustrators need to quickly add more editing points 
to a Bézier curve.

1 Select the object.

2 Choose Object > Path > Add Points. This operation will acti-
vate the Add Points dialog box (1), which will allow you to enter 
the number of points that you wish to add to the object. 

3 Click OK to accept your choice.

Tip
If you create the open path with 
the Smooth Polygon tool, use the 
Smooth Polygon tool to add seg-
ments.
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Closing and opening paths
A closed path is one that starts and ends at the same anchor point. 
An open path has separate starting and ending points. You can 
close an open path by letting Canvas create a new segment to join 
the path’s two endpoints. You can open a closed path by breaking 
the path.

• To close an open path: With the path in edit mode and the 
Curve or Polygon tool selected, click one of the endpoints. Canvas 
closes the path by connecting the endpoints with a new segment. If 
the adjacent segments are curved, the new segment follows the 
curve.

• To break a closed path: With the object in edit mode, Control-
click (Mac) or right-click (Windows) an anchor point or segment to 
open the path Context menu. In the menu, choose Break; Canvas 
inserts segment end points to open the object at that location.

Using the Scissors tool to open and divide paths 
Use the Scissors tool to open a closed path and divide a path into 
two objects. Splitting a path opens the path at the point where the 
scissors clip the path. 

1 Select the Scissors tool. The pointer changes to a pair of scis-
sors.

2 Point to the path where you want to split it (you don’t need to 
select the object first). The pointer becomes a crosshair when it is 
on a point or segment that can be split.

Before adding 
points

Enter the number of points that you wish to add. Then click OK

After adding 
points
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3 Click the path when the crosshair is displayed. Canvas adds 
two endpoints where you click the path, and the path opens.

4 If the path is closed and you want to split it into two paths, 
click the path again where you want to split it.

Dividing objects with the Knife tool
Divide vector objects into separate pieces using the Knife tool. 
When you drag the Knife tool, it draws a cutting path. If the cutting 
path divides an object into two parts, the result is two new objects. 
If the cutting path crosses itself, the area inside the path becomes a 
new object.

The Knife is similar to the Scissors tool; both tools divide vector 
objects. The Scissors tool divides an object with a straight line 
between the two points that you click. The Knife tool slices objects 
along a freeform cutting path. Therefore, use the Knife tool to cut 
curved edges.

Use the Knife tool on open and closed vector objects. If you slice 
one or more open paths, the resulting objects are open paths. 

If you slice an open path that crosses itself, the path separates where 
it crosses itself and where you slice it.

• To use the Knife tool: Select the Knife tool. Drag in the docu-
ment to draw a cutting path that intersects the objects you want to 
divide. The cutting path must intersect at least two points on an 
object’s perimeter. To constrain the path of the Knife tool to 45° 
increments, press Shift as you drag. Release the Shift key to drag 
freely.

Partial cuts If you stop dragging before the cutting path intersects 
a second point on an object's perimeter, the cutting path appears 
but the object stays intact. To use this cutting path to divide the 
object, drag a second cutting path so it intersects the perimeter of 
the object and the first cutting path. Or, you can intersect the cut-
ting path with other cutting paths to create a closed shape. The part 
of the object that falls within the closed shape becomes a separate 
object.

Cutting holes Cut out pieces of a vector object by dragging inside 
the object and creating a closed path. The parts of the object that 
fall within the closed cutting path become separate objects. To cre-
ate a closed cutting path, the path must cross itself.

…to slice an object

Drag the Knife tool…
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Gradient inks If an object’s fill ink is a gradient, and the style is 
Radial, Directional, Rectangular, or Elliptical, the gradient remains 
intact across the separated objects. However, if the gradient style is 
Shape, the gradient fills each divided object separately.

Knife tool options
To configure the Knife tool, use the settings in the Properties bar.

Cut Only Selected Objects Select this option to make the Knife tool 
slice only vector objects that are selected and intersected by the cut-
ting path. This setting can prevent unintentional changes to nearby 
objects. 

Cut All Objects Select this option to make the Knife tool slice any 
vector objects that the cutting path intersects, whether the objects 
are selected or not.

Cropping vector & image objects
Canvas contains a Page Crop tool that can be used to crop several 
objects at once. This tool can be used on both image and vector 
objects.

Note: If some vector objects contain SpriteEffects, you should ren-
der those objects before applying the Page Crop tool.

Any objects that are outside of the cropping rectangle will be 
deleted after completing the crop. After applying the Page Crop 
tool, images remain paint objects. Vector objects, however, become 
Bézier curves. The pen stroke, if any, becomes a composite object. 

To use the Page Crop tool
1 Select the Page Crop tool. The cursor changes to a crosshair.

2 Drag the crosshair diagonally across the objects to form a 
cropping rectangle.

3 Move the cropping rectangle, if necessary. Place the cursor on 
the border of the cropping rectangle and a hand appears.

4 Resize the cropping rectangle, if necessary. 

5 Place the cursor within the cropping rectangle and click to 
complete the crop.

Tip
You cannot crop text objects or 
images to which a soft rotate effect 
has been applied. 
If you plan on using or editing the 
original file in the future, ensure 
that you save a copy of the file 
before applying the Page Crop 
tool.
.18 DRAWING & EDITING PATHS



Periodic waveforms
In Canvas, you can easily add a sine wave, sawtooth wave, or square 
wave to a Bézier or polygon segment that is in curve edit mode.

Note: This command can be applied to one segment at a time.

Joining two paths
Use the Join command to create one path from two separate, open 
path objects.

• To join two paths: Select the two open path objects that you 
want to join. Choose Object > Path > Join. Canvas connects the two 
paths by extending the existing segments or creating a new seg-
ment.

To create a waveform

1 Ensure that the Bézier curve or 
polygon is in curve edit mode.

2 Right-click (Windows) or Control-
click (Mac) on the path segment to ac-
cess the context menu.

3 Select one of the wave options: In-
sert Sine Wave, Insert Square Wave, or 

Insert Sawtooth Wave. The Wave 
Configuration dialog box opens.

4 Enter a value for the frequency in 
the # Cycles field.

5 Enter another value for the Ampli-
tude.

6 Click OK.

Waveform examples

Tip
Remember that the object must 
have an open path. If the object’s 
path is closed, you must break it 
(see “Break,” page 19.13).
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To join paths at selected endpoints
Canvas, by default, joins paths at the closest endpoints; however, 
you can select which endpoints to join.

1 Place an open object or multiple open objects in edit mode.

2 Click an endpoint you want to join to another path. The end-
point becomes hollow to indicate that it is selected.

3 Shift-click another endpoint. The endpoint also becomes hol-
low to indicate that it is selected.

4 Choose Object > Path > Join, or Ctrl-click (Mac) or right-click 
(Windows) one of the selected points. In the context menu, choose 
Join.

Moving anchor points and segments
With a path in edit mode, you can move points and segments to 
alter the shape of the path. 

Tip
You can also draw a selection box 
around the object’s endpoints with 
either the Selection tool or Direct 
edit selection tool.
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Drag an anchor point or segment to move it. You can also press the 
keyboard arrow keys to move selected points and segments. Mov-
ing reshapes the segments you drag or the segments attached to the 
points that you move.

When you begin to drag a segment, the anchor points display their 
tangent lines. You can control the movement of the tangent lines by 
using modifier keys when you drag the segment.

Expand or contract curves Press Tab and drag a segment to change 
the length of its tangent lines without changing their angles. This is 
the way that segments could be reshaped (without pressing Tab) in 
Canvas 3.5 and earlier versions.

Reshape adjacent segments To reshape a segment and adjacent 
segments together (if they are joined with smooth anchor points), 
press Command (Mac) or Alt (Windows) and drag the segment.

Reshaping paths by editing anchor points
A path can contain two kinds of anchor points: smooth points and 
corner points. 

Smooth point An anchor point that connects two curve segments 
where the curve flows smoothly through the anchor point without a 
sharp change in direction. Circles and sine waves are examples of 
paths that have only smooth anchor points. 

Corner point An anchor point where the path makes a sharp turn 
at the anchor point. Corner points can connect two straight seg-
ments, two curved segments, or one curved and one straight seg-
ment. 

Tangent lines
All smooth points, and some corner points, have tangent lines pass-
ing through them. Canvas displays the tangent lines when a point is 
selected. 

A corner point can have one, two, or no tangent lines.When you 
select a corner anchor point with two tangent lines, each tangent 
line can move independently. 

Tip
Pressing Shift while dragging 
points or segments will constrain 
their movement to 45° intervals.
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When you create paths with only straight segments, the anchor 
points are corner points. When you draw curved paths with the 
Curve, Freehand, or Auto Curve tools, the anchor points are 
smooth points. Adding anchor points to curved segments produces 
smooth points.

To change a smooth point to a corner point
You can edit, reshape, and resize two adjoining curve segments 
independently by converting their smooth anchor point to a corner 
point.

1 With the object in edit mode, click the anchor point to reveal 
its tangent lines.

2 Press Tab and drag one of the handles to move one of the 
tangent lines. The tangent line pivots at the anchor point and 
affects only one side of the anchor point.

To change a corner point to a smooth point
To smooth out a sharp turn in curved segments, change the corner 
point between them to a smooth point.

Note: The corner point must have two tangent lines for this proce-
dure. If it has fewer than two, first add tangent lines to the point.

1 With the object in edit mode, click the anchor point to dis-
play its tangent lines.

2 Tab-click the handle of the tangent line you want to keep in 
place; the other tangent line snaps into alignment.

Adding and removing tangent lines
An anchor point can have as many as two tangent line segments. 
Corner points can have one, two, or no tangent lines, and smooth 
points must have two. You can quickly convert a smooth point to a 
corner point by deleting one of its tangent lines. Also, to convert a 
corner point with one or no tangent lines to a smooth point, you 
must add tangent lines.

To add a tangent line
1 In path edit mode, select an anchor point with one or no tan-
gent lines. The anchor point cannot be an endpoint with one tan-
gent line, because endpoints can have only one tangent line.

A corner anchor point with 
independent tangent lines

Tab-click a corner point’s 
handle to snap the other 
tangent line into alignment 
and smooth the path
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2 Press Tab and drag away from the anchor point to place a 
new tangent line segment. You can also Ctrl-click (Mac) or right-
click (Windows) and choose Add Handle in the context menu. As 
you do this, the new tangent line begins altering the segment 
based on how you drag to position the tangent line.

3 Repeat the previous step to add a second tangent line.

To delete tangent lines
1 In edit mode, click an anchor point to display its tangent 
lines.

2 Depending on how you want to edit the anchor point, do one 
of the following:

• To delete one tangent line: Control-click (Mac) or right-click 
(Windows) the tangent line handle and choose Delete Handle in the 
context menu. You must use this method for anchor points with 
only one tangent line, and to delete one of two tangent lines 
attached to an anchor point.

• To delete an endpoint’s tangent line: You can also Tab-click the 
anchor point.

• To simultaneously delete both tangent lines of an anchor point:

Tab-click the point.

Straightening curve segments
Straighten a curved segment by selecting it and using the 
Straighten command in the context menu. This command deletes 
the tangent line(s) that curve the segment.

To straighten a segment: 
1 With the object in edit mode, Ctrl-click (Mac) or right-click 
(Windows) the curved segment that you want to straighten. 

2 Choose Straighten in the context menu.

Reshaping curve segments
To adjust the shape of a curve, in addition to moving points and 
segments along the path itself, you can adjust the tangent lines that 
control the curve. The angle of the tangent line affects the curve 
shape, while the length of the tangent line affects the size of the seg-
ment.
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At a smooth anchor point, adjusting the angle of a tangent line 
affects the curves on both sides of the anchor point. At a corner 
anchor point, you can reshape the segments on each side indepen-
dently (see “Reshaping paths by editing anchor points” on 
page 19.21).

To reshape a curved segment
1 With the object in edit mode, click one of the segment’s 
anchor points to display its tangent lines.

2 Drag the handle of the tangent line to change the shape of the 
associated curve. In the case of a smooth point, the tangent line 
affects both adjacent curve segments.

Path editing shortcuts

Converting objects and text to paths
Some vector objects have specialized properties and unique edit 
modes instead of the standard path edit mode; e.g., you cannot 

To do this Shortcut (Mac) Shortcut (Windows)

Add an anchor point Option-click path Ctrl-click path

Delete an anchor point Option+Shift-click anchor point Ctrl+Shift-click anchor point

Change the length of the tangent lines on both sides 
of a smooth anchor point at the same time

Option-drag tangent line handle Ctrl-drag tangent line handle

Constrain tangent line to 45-degree increments Shift-drag tangent line handle

Move tangent line segment independently (change 
anchor point from smooth to cusp)

Tab-drag tangent line handle

Align tangent line segments (change corner point 
with two tangent lines to smooth point)

Tab-drag tangent line handle

Add tangent line to an anchor point Tab-drag an anchor point

Delete an anchor point’s tangent lines Tab-click the anchor point or endpoint

Close an open path Click an endpoint with a Path draw-
ing tool 

Alt-click an endpoint

Reshape a segment without changing the tangent 
line angles 

Press Tab and drag the segment

Reshape A segment and adjacent segments Press Command and drag a seg-
ment

Press Alt and drag a segment
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directly edit the path segments of dynamic objects, concentric cir-
cles, grids, multigons, spirals, and objects modified by the Envelope 
or Extrude commands; however, you can convert these objects to 
paths so you can edit them the same as any other vector object.

If you create paths from a specialized vector object, the new shape 
does not have the same unique editing capabilities as the original; 
e.g., if you convert a Multigon star object to paths, you can no 
longer use the edit handles that let you adjust the depth and twirl of 
the points. Similarly, placed dynamic objects are no longer linked 
to their parent objects in the Personal Library palette after you con-
vert them to paths.

You can also convert text so you can reshape characters as vector 
objects. This has the benefit of making the characters independent 
of their fonts; the font is no longer required to view and print the 
characters properly. However, once you convert text to paths, you 
can no longer perform text operations, such as editing, spell-check-
ing, and formatting, on the text. Also, characters with “holes” in 
them (such as a, b, d, e, g, o, p, r, and q) are converted to composite 
paths, which cannot be extruded.

To convert an object to paths: 
1 Select the object you want to convert. 

2 Choose Object > Path > Convert To Paths. Canvas converts 
the object to one or more paths.

To convert objects to simple paths
This operation facilitates the rapid conversion of vector objects into 
a simple path. Now any Canvas object or a group of objects can be 
converted into simple paths. At the same time, these objects will 
maintain their Canvas inks settings and stroke types. 

The Convert to simple paths command breaks down everything 
Convert to path does not. It also breaks down strokes and inks to 
simple, yet editable, Bézier paths and polygons. 

The object A (below) is an object with a neon stroke.
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1 First select object A.

2 Choose Object > Path > Convert to Simple Paths. 

3 After completing this operation, choose Object > Ungroup. 

At this point, (B) all high level drawing features that are contained 
in the object are reduced to individually editable polygon and Béz-
ier objects. 

Outlining path stroke
An illustrator may find it necessary to outline a path stroke when 
working with logos, intricate artwork, or traced images, etc., espe-
cially if the illustrations will be resized.

• To access this command: Select the vector object and choose 
Object  > Path > Outline Path Stroke.

Note: You can apply this command to more than one selected vector 
object or even a grouped object. 

Illustration with a 
6—point stroke 
resized to be 50% 
smaller

Even when reduced, 
the object maintains 
stroke size

Illustration with a 
converted stroke 
resized by 50%

After conversion, the 
stroke size is no 
longer a factor when 
reducing objects
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To ungroup objects made of multiple paths
When you convert multiple objects, characters, or specialized vec-
tor objects to paths, Canvas creates a separate path for each shape 
and groups them. Choose Object > Ungroup to separate them. 

For example, if you convert a five-letter word to paths, the resulting 
object is a group of five paths. To edit just one of the five paths, first 
choose Object > Ungroup. Or, use the Direct Selection tool to select 
one path without ungrouping.

Binding objects to path
The Bind to Path command is used to bind and align vector objects 
to a selected path.

To bind an object to a path
1 First create the path to which you are going to bind an object. 

Original 
illustration

Illustration with 
outlined path 
stroke

Tip
If you create your object before 
you create the path, any irregular 
object must first be converted to 
paths (Object > Path > Convert to 
Paths) before choosing Effects > 
Bind to Path. This method applies 
to objects created with the Multi-
gon, Polygon, Spiral, Concentric 
Circles, and Cube tools. 
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2 Then create the object and then select both.

3 Choose Effects > Bind to Path to open the Bind to Path dialog 
box.

• Enter number of copies of objects (A).

• Choose alignment of Top, Centers, or Bottom of path (B).

• Rotate Objects to Path (C). When checked, the object will 
rotate based on the direction of the path.

4 Click the OK button to accept.

Making and breaking composite paths
Create openings in a filled path by incorporating multiple paths 
into a single, composite path. Areas between the paths and areas 
where the paths intersect are transparent.

• To create a composite path from multiple paths: Select the paths 
you want to make into a composite path. Choose Object > Path > 
Make Composite.

• To separate a composite path: Select the composite path and 
choose Object > Path > Break Composite.

To symmetrically resize path points
When using the Symmetrical Drag feature, you can easily create a 
symmetrical design from a circle, rectangle, or a complex group of 
objects.

1 Select an object and place it into path edit mode (A). 

2 Right-click (Windows) or Control-click (Mac) to open the con-
text menu.

3 Choose Enable Symmetrical Resize (B). 

4 Release the mouse and select any of the object’s control 
points.

5 Drag to create a new shape for the object.

When you drag the selected control points, notice that the shape is 
resized from the center of the object. 

Tip
You also have the ability to select 
all of the control points, and drag. 
Doing so will allow you to quickly 
resize the object while retaining 
proper object constraints.
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Simplifying vector paths
The Reduce Points command lets you simplify vector paths by 
reducing the number of anchor points in the path. 

Simplifying is a good practice when paths you import or create 
have a very high number of anchor points. These paths can cause 
slow printing or printer errors, especially when memory is limited. 
If you have problems printing a complex vector path, try simplify-
ing it.

Use the Reduce Points command when one vector object is in path 
edit mode, or when one or more vector objects are selected. 

Reduce Points works with objects created with the Curve, Auto 
Curve, Freehand, Smooth Polygon, and Polygon tools. You can 
apply it to objects created with other tools if you use the Object > 
Path > Convert to Paths command to convert the objects to vector 
paths.

Reduce Points is not available when specialized vector objects 
(Concentric Circles, Smart Shapes, Multigons, and similar objects) 
are selected or in edit mode. These objects must be converted to 
paths to simplify them.

To use the Reduce Points command

1 Select one or more vector objects, or place one object in path 
edit mode (select it and choose Object > Edit). In edit mode, you 
can select three or more anchor points and apply Reduce Points.

2 Choose Object > Path > Reduce Points. A dialog box appears. 

3 Drag the slider to set the relative number of anchor points to 
use for the path.

Dragging will resize the object.
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Loose leaves fewer points in the path by tracing the original path 
more smoothly. 

Tight removes fewer points by tracing the original more closely. 
When more points are removed, the change in the path can be 
greater.

4 Click OK to modify the path. 

Converting polygons to Bézier objects
The Fit Bézier command changes a polygon to a Bézier curve path. 
This command can be applied to a single selected polygon that is 
not in edit mode.

Using this command can have varied results, depending on the set-
tings you use. You can convert a polygon without changing its 
shape. Or, use the command to smooth the straight segments of a 
polygon into gentle curves.

Fit Bézier is useful when you want to use handles attached to 
smooth anchor points to “bend” straight path segments into curves. 
Using Fit Bézier adds handles to all the corner points (which do not 
have handles) that define a polygon.

To use the Fit Bézier command
1 Select a polygon (open or closed). 

A polygon can be created with the Polygon tool, Smooth Polygon 
tool, or Curve tool if the path has only corner points, not smooth 
points. Objects created with the Rectangle tool or Line tool can be 
converted to polygons with the Object > Path > Convert to Paths 
command.

2 Choose Object > Path > Fit Bézier. A dialog box with two slid-
ers appears. 

3 Use these to adjust the following conversion settings: 

Loose-Tight Controls how closely the modified path will conform 
to the original path. Tight results in little deviation from the origi-
nal path. Loose allows the modified path to be smoother and devi-
ate farther from the original. 

Round-Sharp Controls how many corners will become rounded in 
the modified path. Sharp preserves corners where segments meet at 
acute angles. Round allows all corners to become rounded.
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These settings can interact and produce similar results at different 
slider positions; e.g., setting one slider at Tight and the other at 
Round can produce a path that closely matches the original, but 
with all corners being rounded. Setting one slider at Loose and the 
other at Sharp can result in a path that overall is smoother, but 
which has some corners that are not smoothed at all.

4 Click OK when you’re done. Canvas modifies the object 
based on the settings you specified.
Converting polygons to Bézier objects 19.31





CHAPTER

20
PRECISION DRAWING & DIMENSIONING

This chapter describes precision drawing tools and techniques that 
can help you create scale drawings, floor plans, architectural 
designs, and other types of technical drawings. This chapter 
explains how to

• display size information as you draw

• set up the scale for scale drawings

• add dimension objects to illustrations

• use Smart Mouse to align objects

Some of the techniques described elsewhere in this book also apply 
to precision drawing. For information on document setup and 
using rulers, see “Document setup,” page 11.1.

Setting up a document’s measurement scale
Canvas offers a variety of options for creating scale drawings. You 
can use the Add unit feature to define a new unit of measurement 
for a particular document or redefine an existing unit (see “Adding 
and modifying units of measurement,” page 11.8). You can also set 
up a ruler to control the scale of an entire document as well as cus-
tomize scale settings for individual dimension objects (see “Setting 
up rulers and the drawing scale,” page 11.7). Other settings affect 
the format of measurement and position data.

The following settings affect the measurement of objects in a docu-
ment:

Rulers Set up a document’s overall drawing scale using the Ruler 
manager and document scale. The document scale affects all object 
measurements, including those made with the Dimensioning tools. 
The document scale also affects data in the Properties bar and 
Object Specs palette (see “Setting up rulers and the drawing scale” 
on page 11.7 and “Using Set Document Scale command,” 
page 11.8).

Number Form A setting in the Ruler manager affects the format of 
data in the Properties br and other displays. This option controls 
the precision of data and the number format (decimal or fractions) 
(see “To set up rulers,” page 11.7).
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Dimensions You can customize individual dimension objects with 
the Dimensioning controls in the Properties bar.

Displaying dimensions as you draw
Canvas can display the horizontal and vertical dimensions of an 
object as you draw it. The Show Size command makes dimensions 
(in scale) appear at the pointer as you drag with any drawing tool. 
These dimensions do not remain in the document. 

• To display dimensions when you use drawing tools: Choose Lay-
out > Display > Show Size. When you select a drawing tool and drag 
the pointer in an illustration, the object’s vertical and horizontal 
measurements appear at the pointer.

Note: The Show Size option can also be toggled in the Display 
Options manager in the Configuration Center.

• To turn off the dimensions display: Choose Layout > Display > 
Hide Size. This command only appears when Show Size is on.

Using the Dimensioning tools
You can easily add formatted dimensions to documents with the 
Dimensioning tools. These tools can measure horizontal, vertical, 
oblique and perpendicular distances; measure diameter, radius, 
angle, area, and perimeter; and mark the centers of arcs and ovals.

The dimensioning tools are grouped in a single palette (see “Tool 
palettes,” page 10.6). The Linear, Chain, and Baseline tools allow 
you to create horizontal, vertical, or oblique dimensions, depending 
on the position of the cursor upon creation. 

Floating point technology

Projects in the scientific, engineering, 
medical, and biotechnology industries 
demand the highest levels of precision.

When working with very small units of 
measure, errors can occur since no 
human system of numeration can give 
a unique representation to every real 
number because there are simply too 
many of them.

To meet the demand for increased 
decimal precision, the Institute of Elec-

trical and Electronics Engineers (IEEE) 
has produced a standard for binary 
floating point arithmetic (IEEE 754-
1985). This standard specifies how 
single-precision (32 bit) and double-
precision (64 bit) floating point num-
bers are to be represented, as well as 
how arithmetic should be carried out 
on them. An application that supports 
this technology will generate a floating 
point number; i.e., the decimal point 
literally “floats,” and, therefore, 
achieves a more precise fractional 
result.

Without installed support for the float-
ing point standard the computations 
within a computer design environment 
will generate only a close approxima-
tion of a requested command. 
Although these calculations may gen-
erate satisfactory results for most pur-
poses, the demands that exist within 
the science, engineering, medical, and 
other related professions dictate that 
only extremely accurate results be 
used within projects. 

Canvas’ drawing engine fully supports 
the IEEE floating point standard. 

When Show Size is active, Canvas 
displays the scaled size of the 
object as you draw.
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In addition, when using the Chain and Baseline Dimensioning 
tools, you define the first two points as you would for a Linear 
dimension. Then, just click on every point you want to add to the 
dimension, and the tool creates the dimension object automatically. 
The result of using the Chain or Baseline Dimensioning tool is one 
single object. The current limit for Chain Dimensions is 16.

Create dimension objects that conform to industry standards, 
including ANSI, DIN and JIS. You can also customize the standard 
settings — the size of lines, gaps, text, and tolerances — and then 
save these settings as new standards (see “Using industry standards 
for dimension objects,” page 20.9).

Dimensioning procedures

To use the Linear Dimensioning tool
1 Select the Linear Dimensioning tool. When you move the 
cursor into the drawing area, a prompt appears. 

Dimensioning tool Prompts Procedure

Linear (Horizontal, Oblique, and Vertical)

Click 1st Point, Click 
2nd Point

Click the start point for the measurement, then click the 
end point and anchor the dimension object.

Baseline and Chain (Horizontal, Oblique, 
and Vertical)

Click 1st Point, Click 
Next Point

Click the start point and then click the end point for the 
first measurement; anchor the first part of the dimension 
object. Click the next measurement point and anchor the 
next part of the dimension object. Continue until finished, 
then press Enter (Mac) or Esc (Windows).

Angle Click 1st Line, Click 
2nd Line

Click the start point for the angular measurement, then 
click the end point.

Perpendicular Click Line, Click Point Click the line to measure from, then click a point anywhere 
to take a perpendicular measurement from the line to the 
point.

Object Side Click Object Side Click the side of the object to be measured.

Radius, Diameter, and Center

Click Arc/Ellipse Click anywhere on the arc or ellipse and then anchor the 
dimension object.

Area and Perimeter

Click Object Click anywhere on the object to be measured and then 
anchor the dimension object.

Tip
Baseline dimensions are a series 
of measurements made from a 
common starting point. Chain 
dimensions are a series of mea-
surements in a row.
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2 Define the first two points of the dimension as indicated by 
the prompt. Depending on the cursor’s position, the type of 
dimension changes according to the mouse movement.

3 Click the third time to create the dimension object. 

To use the Chain and Baseline Dimensioning tools
1 Select either the Chain or Baseline Dimensioning tool. When 
you move the cursor into the drawing area, a prompt appears. 

2 Define the first two points of the dimension as indicated by 
the prompt. Depending on the cursor’s position, the type of 
dimension changes according to the mouse movement.

3 Click the third time to create the first dimension.

4 Click on other points to add them to the dimension object.
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Using the dimensioning settings
You can customize the measurement units, scale, arrow position, 
tolerance text, and other settings for dimension objects. Use the 
Dimensioning settings in the Properties bar. These settings are 
available when you select a Dimensioning tool or have selected a 

Types of dimensioning tools and measurements

Use the dimensioning tools to add 
measurements to illustrations. Different 
tools let you create different types of 
dimension objects.

Baseline and chain dimensioning tools 
create a single dimension object. Base-
line dimensions contain several mea-
surements from a common starting 
point. Chain dimensions are a series of 
measurements.

A Vertical
B Oblique
C Radius
D Diameter
E Vertical Baseline
F Oblique (with aligned text)
G Vertical Chain
H Angle
I Horizontal
Using the Dimensioning tools 20.5



20
dimension object. Depending on the selected Dimensioning tool or 
object, the Properties bar will display various settings (see “Dimen-
sioning settings,” page 20.7).

To change the properties of existing dimension objects
1 Select the dimension object. The settings appear in the Prop-
erties bar.

2 Make any adjustments with the settings.

Note: You can change the properties of multiple selected dimension 
objects as long as the dimension objects are of the same type.

To change the settings for dimensioning tools
1 Select the Dimensioning tool. The settings appear in the 
Properties bar.

2 Make any adjustments to the tool settings and then create the 
dimension object (see “Dimensioning settings,” page 20.7).

Tip
The Properties bar must be dis-
played to view the Dimensioning 
settings. If not open, choose Win-
dow > Show Properties Bar.
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Attributes of dimension objects
When you are using a dimensioning tool, the pen ink of the dimen-
sion object appears black with a 1-pt stroke; however, once you 
complete the object, the pen ink switches to the current ink and 
stroke settings. By default, the dimension text is 10 pt and uses 
Arial (Windows) or Geneva (Mac). In addition, the current stroke 
color is applied to the dimension text.

You can change the current ink, stroke, and text settings for new 
dimension objects, and you can change these settings for existing 
dimension objects.

Dimensioning settings

Prefix. Select a prefix from the menu. 
The available prefixes depend on the 
Dimensioning tool used. You can also 
enter a customized prefix.

Value. Indicates the size of the dimen-
sion object. You can change the text 
value of the dimension object by 
entering a value in this field. The actu-
al object size does not change. If you 
want to change the actual size of the 
dimension object, select the Allow 
Change Size checkbox. Click Reset 
Value to recalculate the measurement.

Units. Select a unit of measurement 
from the menu. If you have several 
dimension objects in a document, 
each dimension object can use its own 
unit of measurement. 

Postfix. Enter a message that is to fol-
low the value; e.g., 10.2 cm R, where 
“R” is the Postfix, indicating a radius 
of 10.2 cm.

Tolerance. Add a tolerance to the end 
of the measure. “None” is the default, 
which means nothing is added; how-

ever, you can choose to add Bilateral 
tolerance “± value” or Unilateral toler-
ance “+ value - value”.

Bilateral prints the tolerance amount 
with “± “ and the dimension text. Uni-
lateral tolerance prints both tolerance 
amounts and the dimension text.

Arrows. This controls the placement 
of the arrows. Select either Inside, 
Outside, None, or Auto (default) (see 
“Style and Text Display settings,” 
page 20.9).

Witness Lines. This controls the 
length of witness lines. Select either 
None, Short, or Long. 

Leaders. This controls the placement 
of the leaders. Select either None, 
Left, Right, or Auto (default).

Display Units. Select this checkbox to 
make the unit of measurement appear 
in the dimension object.

Outside Lines Only. Select this check-
box to keep the dimension object out-
side of the object. This option applies 
to Radius and Diameter objects.

Use Secondary Units. Select this 
checkbox if you want your dimension-
ing object to display two different 
units of measurement; e.g., inches and 
centimeters (cm). Choose the second-
ary unit of measurement from the 
menu.

Text Display. This controls the place-
ment of the dimension text (see “Text 
Display,” page 20.8). 

Standard. Select a dimensioning stan-
dard from the menu: ANSI, BS-380, 
DIN, ISO, or JIS. The Standard refers 
to the length of lines, size of tolerance 
text, placement of the text, placement 
of the arrows, etc.

Add. Click this button to add a custom 
dimension standard (see “New Stan-
dard Definition,” page 20.10).

Edit. Click this button to modify a 
dimension standard (see “New Stan-
dard Definition,” page 20.10).

Remove. Click this button to remove 
the selected dimension standard (see 
“To delete a custom standard,” 
page 20.10).
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• To change the appearance of a dimension object: Select the 
object and use the Presets palette to select ink color, pen size, and 
arrows for the dimension object.

• To change attributes for new dimension objects: Make sure that 
no objects are selected in the document, and then use the Presets 
palettes to change the current stroke and ink settings for new 
objects and text.

To change the text attributes of a dimension object
The Properties bar allows you quick access to text formatting 
options for various dimension objects. 

Text Display Refers to the placement of dimension text in relation 
to the object.

• Horizontal: Text is aligned horizontally in the dimension 
object.

• Aligned: Text is aligned with the angle of the dimension 
arrows.

• Above: Text runs above the dimension arrows.

• Below: Text runs below the dimension arrows.

Font & Size Select a new font and font size for the text from the 
menus. 

Style Click the buttons to apply a style to the text (Bold, Italic, 
Underline, and Frame).

Note: You can also change the font, size, and styles by using the 
Text menu or Type palette.

Important
Dimension objects can still display 
arrows if all the preset arrows have 
been deleted from the Arrow tab 
in the Presets palette.

Tip
You can scroll the Properties bar if 
all the options are not visible. 
Arrows appear on the left and right 
indicating that other options are 
available.
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Linking dimensions to measured objects
Since dimension objects aren’t attached to the objects they mea-
sure, dimensions do not change when you resize objects you have 
measured. However, you can group a dimension object and the 
object that it measures. When you do this and then resize the 
object, the dimension changes accordingly.

• To group an object and a dimension object: Select the dimen-
sion object and the measured object and choose Object > Group.

Using industry standards for dimension objects
If you want to use industry standard settings for dimension objects, 
open the Standards menu in the Properties bar. Select a dimension-
ing standard from the menu: ANSI, BS-380, DIN, ISO, or JIS. The 
Standard refers to the length of lines, size of tolerance text, place-
ment of the text, placement of the arrows, etc.

Choose from five standard measurement systems: 

ANSI American National Standards Institute

DIN Deutches Institut für Normung

BS-380 British Standards Institute

ISO International Organization for Standardization

JIS Japanese Industrial Standard

Style and Text Display settings

Use the following style options in the 
Properties bar to customize the appear-
ance of dimension objects.

A Text Always Centered. Select this 
option to keep the text between the ar-
rows. Must be off to drag dimension text 
outside the witness lines.
B Frame Text. Turn this option on to 
frame the dimension text.
C Use Fill Color for Text. Select this 
checkbox if you want the dimension text 
to use the fill color rather than frame col-
or of the object.

2.75 ft 2.75 ft

2.75 ft2.75 ft

2.75 ft 2.75 ft

Option on Option off
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To add a custom standard definition
1 Click the Add button. The New Standard Definition dialog 
box opens.

2 Use the controls to create and define dimensioning standards 
(see “New Standard Definition,” page 20.10).

• To edit a standard definition: Select a dimensioning standard 
from the menu. Click the Edit button. The Edit Standard Defini-
tion dialog box opens. For an explanation of the various options, 
see “New Standard Definition,” page 20.10).

To delete a custom standard
1 Open the Standards menu.

2 Select the custom standard definition to be removed.

3 Click the Remove button.

Using Smart Mouse for precise alignment
Smart Mouse is a drawing aid that can help you precisely align 
objects. Smart Mouse is particularly useful when creating technical 
illustrations or documents in which micron-precision is paramount 

New Standard Definition

Once defined, custom standards 
appear in the Standard menu in the 
Properties bar.

A Standard Name. Enter a name for 
the new standard.
B Units. Select the unit of measure-
ment that you want to use for all settings 
in the dialog box.
C Extension. Set the length of the wit-
ness lines’ extensions and the center 
line extension.
D Gap. Set the size of the gap be-
tween the witness lines and measure-
ment points on objects; the gap be-
tween the center extension and center 
point mark; and the gap between the di-
mension text and dimension arrows.

E Length. Set the length of the arrow 
lines (applies only when arrows are out-
side the witness lines); the length of 
center extension lines’ leader charac-
ters; and the length of the center exten-
sion line.
F Tolerance Scale. The size of toler-
ance text and space between tolerance 
text, as a percentage of the dimension 
text size and spacing. 
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since it can snap the pointer to the corners (and other points) of 
objects.

• To open the Smart Mouse palette: Choose Layout > Smart 
Mouse or Window > Palettes > Smart Mouse.

Types of Smart Mouse constraints
The Smart Mouse tool has 14 types of constraints for your use. The 
constraints make the pointer (and objects that you draw or drag) 
snap to corners or centers of objects, even divisions (such as the 
midpoints) of object fractions, specified lengths or angles, horizon-
tal, vertical, or diagonal movement, tangential or perpendicular 
alignment with objects, or edges of vector objects.

Relative constraints Indicate the relationship between the begin-
ning position and current position when you draw or drag an 
object. These constraints can display pointers to indicate a con-
straint is met. The relative constraints are: Horizontal, Vertical, 
Diagonal, Angle, Multiple Angle, Length, Parallel, and Tangential 
& Perpendicular.

Absolute constraints Indicate the relationship between the pointer 
and objects. These constraints (except Object Edges) can display 
source lines and pointers to show a constraint is met. The absolute 
constraints are: Object Corners, Object Fractions, Polygon & Bézier 
Anchors, Polygon Fractions, and Object Edges.

Smart Mouse constraints

When this constraint is active Smart Mouse snaps objects and constrains the pointer to

Angle A specified angle

Diagonal Straight diagonal movement — all multiples of 45°

Horizontal Straight horizontal movement— 90° and 270°, or 0° and 180°, depending on the current 
coordinate system

Vertical Straight vertical movement — 0° and 180°, or 90° and 270°, depending on the current 
coordinate system

Length A specified length in points (based on 100% magnification)

Multiple Angle All multiples of the specified angle

Tangential & Perpendicular Movement in a straight line, tangent or perpendicular to vector objects

Object Bounds The bounding box of vector objects

Tip
Turn off Snap To Grid by choosing 
Layout > Snap To > Grid. If there 
is no checkmark, the option is 
already turned off. If Snap To Grid 
is on, the pointer will snap to the 
grid and not to active Smart 
Mouse constraints.
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To add and activate constraints
When you add a constraint, it appears in the Smart Mouse palette. 

1 To add a constraint, select New Constraint from the palette 
or click the New Constraint button (A). The New Constraint dia-
log box opens.

2 Select a constraint from the Constraint type menu. The indi-
vidual constraint settings at the bottom of the dialog box change 
according to the constraint selected in the menu.

Note: All constraints require a Snap Tolerance, which is indicated in 
points. Snap Tolerance is the maximum distance, horizontally or 
vertically, from a target point at which the constraint causes the 
pointer to snap to the target point.

3 Click OK to close the New Constraint dialog box. The con-
straint now appears in the Smart Mouse palette. When a con-
straint is added, the checkbox is automatically selected indicating 
that the constraint is active.

Object Bounds Fractions A specified division of vector objects; e.g., specify 1/2 to snap to the center of objects

Object Points Any anchor point on the paths of vector objects

Object Paths Edges of the paths of vector objects (not their bounding boxes); when Object Paths is 
active, other constraints don’t affect the pointer

Object Paths Fractions Specified divisions of the paths of vector objects; e.g., the pointer snaps to the midpoints 
of paths if you specify 1/2

Parallel Mainly used to facilitate drawing parallelograms. When drawing a polygon, the Parallel 
constraint checks all previously drawn lines and attempts to make the next line parallel 
with some of them.

For this constraint Enter this value

Object Bounds Fractions, 
Object Paths Fractions

Number of divisions; e.g., type 2 if you want the con-
straint to snap to the middle (1/2 point) of an object 
or object path.

Angular Angular measurement in degrees.

Length The distance

When this constraint is active Smart Mouse snaps objects and constrains the pointer to

Constraints are listed at the top of the 
Smart Mouse palette. A checkmark 
indicates active constraints.
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Priority of constraints
When multiple constraints are active, the constraint at the top of 
the constraint list takes precedence. When a new constraint is 
added, it appears at the bottom of the constraint list. To change the 
priority of a constraint, drag it to a new position in the list.

• To activate a constraint: In the Smart Mouse palette, select the 
constraint’s checkbox.

• To deactivate a constraint: In the Smart Mouse palette, deselect 
the constraint’s checkbox.

• To modify an active constraint: Select the active constraint. The 
individual constraint settings appear at the bottom of the palette. 
Make any changes to the constraint and press Enter.

• To remove a constraint: Select the constraint in the palette and 
then click the Trash icon (B). You can also select the constraint and 
choose Remove Constraint from the palette menu. Choose Remove 
All from the palette menu to delete all current active constraints.

Smart Mouse settings
To access these settings, open the palette menu and select Smart 
Mouse settings.

Select the Show Snap Indicators checkbox if you want to show that 
Smart Mouse is active. This setting also indicates that constraints 
are met. If this option is selected, you’ll notice that a small square 
appears by the cursor.

You can also select the range for the snap function.

Option Definition

Within Screen Object must be within the screen area to trigger the con-
straint. This range is useful if layout area contains several 
objects and the zoom in feature is used.

Within Document Object must be within the document area to trigger the con-
straint. 

Within x.xx pixels For absolute constraints only, specifies how close the 
pointer must be to an object for the object to trigger the con-
straint.
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Object path editor
This new function allows you to view as well as edit the X/Y coordi-
nates of each individual point of a basic vector object, polygon, or 
Bézier curve. 

Note: Basic vector objects are rectangles, lines, ovals, and arcs.

To view the points of a single object
1 Select the object. 

2 Open the Object Path Editor palette by choosing Object > 
Object Path Editor. The individual points are listed in the left col-
umn with their corresponding X/Y coordinates in the middle and 
right columns.

To view the points of multiple objects
1 Press Shift and double-click each object to place it in edit 
mode.

2 Open the Object Path Editor (Object > Object Path Editor). 
The Curve menu is now active. 

3 Select the curve whose points you want to appear. The curve 
number in the menu is according to the stacking order. The indi-
vidual points are listed in the left column with their corresponding 
X/Y coordinates in the middle and right columns.

To edit X/Y coordinates
1 Click in the X or Y field of the point to be modified.

2 Enter the new coordinate. 

3 Press Enter.

To copy X/Y coordinates
1 Select the object.

2 Open the menu of the Object Path Editor palette.

3 Select Copy.

4 Paste the coordinates in the other application.

To paste as polygon or Bézier
With the Object Path Editor, you can create a polygon or Bézier 
curve with point values copied from a spread sheet or tab-delimited 
file. 
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1 Copy the point values in the spreadsheet or tab-delimited file.

2 Open the menu of the Object Path Editor palette.

3 Select either Paste As Polygon or Paste As Bézier.

To load polygon or Bézier
With the Object Path Editor, you can create a polygon or Bézier 
curve with point values found in a .txt file.

1 Open the menu of the Object Path Editor palette.

2 Select either Load Polygon or Load Bézier.

3 Navigate to the file and click Open.
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VECTOR EFFECTS

Canvas has several special effects that let you develop complex 
illustrations from basic objects. You can apply the effects described 
in this chapter to any vector object; some can be applied to text 
objects, too (see “Type effects,” page 33.1). These commands help 
save time by quickly generating new objects and letting you easily 
modify the appearance of existing objects.

As you apply effects to objects, keep in mind that some of these 
operations are system memory-intensive and might significantly 
increase the resource and storage requirements of a document.

Perspective effects
Commands in the Object > Path > Perspective menu can be used to 
modify vector objects. The 1 Side, 2 Sides, and Vanishing Point 
commands let you slant the bounding boxes of vector objects to 
align with vanishing points. By applying these commands, you can 
make vector objects appear to be drawn in perspective views. 

About the vanishing point
The Perspective commands apply perspective effects based on a 
vanishing point. There is one global vanishing point in a Canvas 
document. When you use the 1 Side or 2 Sides commands, you set 
the vanishing point by dragging a control handle. When you use the 
Vanishing Point command, you can set the vanishing point by 
clicking in the document or entering coordinates.

Using the 1 Side and 2 Sides commands
The 1 Side and 2 Sides commands let you apply perspective effects 
to vector objects by dragging control handles. To use these com-
mands, select a single vector object or a group of vector objects. 
These commands are not available if multiple objects are selected, 
or if a paint or text object is selected.

To apply perspective with 1 Side or 2 Sides
1 Select a vector object or a group of vector objects.
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2 In the Object > Path > Perspective menu, choose 1 Side or 2 
Sides.

3 Control handles appear at the corners of the bounding box of 
the selected object. Drag any of the handles to apply the perspec-
tive effect. As you drag a handle, guide lines indicate the position 
of the vanishing point, which extend beyond the current view. 

• If you choose 1 Side, the side of the object’s bounding box 
where you drag a handle will slant to a vanishing point. 
You can adjust the object’s sides independently. 

• If you choose 2 Sides, as you drag a handle, the opposite 
sides of the object’s bounding box will slant equally 
toward a vanishing point located along the object’s vertical 
or horizontal center axis.

• When the pointer is on a control handle, a four-arrow sym-
bol indicates that you can drag horizontally or vertically. 
To change directions, point to a control handle until the 
four-arrow symbol appears again.

4 When you finish, press Esc to deselect the object.

Using the Vanishing Point command
The Vanishing Point command applies a perspective effect to one 
or more vector objects. The command slants the bounding boxes of 
selected vector objects so the objects appear in perspective based on 
a vanishing point that you select.

The Vanishing Point command is available when vector objects or 
groups of vector objects are selected. The command is not available 
if a paint or text object is selected.

1 Side perspective 2 Sides perspective

Vanishing point

Vanishing point
.2 VECTOR EFFECTS



To apply perspective using a vanishing point
1 Select one or more vector objects or groups of vector objects.

2 Choose Object > Path > Perspective > Vanishing Point.

3 A dialog box appears. It displays the coordinates of the global 
vanishing point. Change the coordinates to move the vanishing 
point, or click in the document to set the vanishing point.

• To enter coordinates, type coordinate values in the text 
boxes. Coordinates are based on the document’s rulers.

• To set the vanishing point visually, click Choose. Move the 
pointer and click to set the vanishing point. The coordi-
nates of the point you click appear in the text boxes.

• To restore the previous vanishing point coordinates, click 
Reset.

4 Click OK to apply the perspective effect.

Note: The Effects > Remove Effects command will not remove per-
spective effects that have been applied to objects.

Offsetting paths
Use the Offset Path command to create new objects that follow the 
path of a vector object.

An offset object’s path follows the inside or outside of the original 
object’s path. Specify the offset distance and the number of objects 
to create. You can offset one vector object at a time. 

To offset an object
1 Select a vector object and choose Effects > Offset Path.

2 In the Offset Path dialog box, type the offset distance in the 
Distance box. In the Copies box, type the number of copies to 
make. 

3 Click OK to create the offset objects.

Canvas applies the current inks and stroke to offset objects (see 
“Inks: colors & patterns,” page 15.1 and “Strokes: outline effects,” 
page 16.1). The new objects appear in front of the original if they 
are smaller; otherwise, they appear behind it. 

The direction of the offset depends on whether you type a positive 
or negative Distance value.

Tip
Composite objects created by the 
Concentric Circles, Spiral, Cube, 
GridMaker, or Multigon tools can-
not be offset.
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When you offset an object that has an open path, type a negative 
value to offset the new object to the inside of the curve. Type a posi-
tive value to offset the new object to the outside of the curve. 

When you offset an object that has a closed path, type a negative 
number to offset the new object to the inside of the original path. 
Type a positive number to offset the new object to the outside of the 
original path.

An offset object can differ in shape from the original object, if a 
large offset distance makes the path cross itself to follow narrow 
angles or tight curves of the original object.

Using clipping paths
A clipping path is a special object that creates a frame or window 
on an object. You can use text objects and vector objects as clipping 
paths.

You can apply a clipping path to one or more objects. The clipping 
path frames the objects to which it is applied. Anything inside the 
clipping path remains visible, while anything outside the path is 
hidden, or “clipped.”

If you apply an oval clipping path to a photo, for example, the 
photo is visible inside the oval, while any part of the photo outside 
the oval is not visible.

Since clipping paths are vector objects, clipping effects print 
smoothly at maximum resolution on any printer, including Post-
Script and non-PostScript devices.

Clipping paths create hard-edged effects. Clipping paths are often 
used to “cut” photos and illustrations into shapes such as circles or 
curves. Use text as a clipping path to create the effect of text charac-
ters filled with photos or other graphics (see “Using text as clipping 
paths,” page 33.11). 

If you want to create feathered or graduated clipping effects, use 
vector transparency masks and channel masks instead of clipping 
paths (see “SpriteLayer effects” on page 35.1).

To apply a clipping path
1 Position a text or vector object in front of the objects to be 
clipped. (select an object and choose Object > Arrange > Bring to 
Front to put the clipping object in front of other objects.)
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2 Select both the clipping object and objects to be clipped. 

3 Choose Object > Clipping Path > Make to clip the selected 
objects.

If you want to use a special object (such as a star created by the Mul-
tigon tool) as a clipping path, the object must be converted to a vec-
tor path first. Select the object and choose Object > Path > Convert 
to Paths. 

• To hide clipping paths: Choose Object > Clipping Path > Hide. 
Canvas makes the strokes of all clipping paths invisible. 

• To show clipping paths: Choose Object > Clipping Path > 
Show. Canvas shows the clipping paths with a 1-point black stroke.

• To remove a clipping path: Select the clipping path or a clipped 
object and choose Object > Clipping Path > Release. Canvas 
restores the clipped objects to full view, and the clipping path object 
appears with its original attributes.

Editing clipping paths
After applying a clipping path, you can move it and the clipped 
objects independently. Dragging the clipping path frames a differ-
ent part of the clipped objects. Dragging a clipped object changes 
its position inside the frame of the clipping path.

You can apply several effects to a clipping path. Select the clipping 
path and choose Effects > Freeform to display handles that you can 
drag to skew and rotate the clipping path. You can also apply the 
Fractalize, Rotate, and Flip commands to a selected clipping path.

You can reshape a clipping path in several ways. Select a clipping 
path and drag its handles to change the size or shape of its bound-
ing box. To reshape a vector object path, double-click it, or select it 
and press Command+E (Mac) or Ctrl+E (Windows). With the path 

Tip
If a selected object can’t be used 
as a clipping path, the Clipping 
Path > Make command is not 
available.

Text in front of paint object Text clipping path
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in edit mode, use path-editing techniques to move, add, or delete 
anchor points. When you finish editing, press Esc to reapply the 
clipping path.

To edit a text clipping path, use the Text tool or double-click the 
text to put it in edit mode. You can insert and delete characters in 
edit mode. When you finish, press Esc to reapply the clipping path. 

To change the formatting of a text clipping path, select the clipping 
path and use the Text menu or the Type palette to change its font, 
style, size, or other attributes. When a text clipping path is selected, 
you can use the Spell Check Selection command to check its spell-
ing.

Because clipping paths are special objects, they do not display the 
pen inks, fill inks, or strokes of their original objects. Canvas dis-
plays clipping paths with 1-point black strokes (which the Clipping 
Path > Hide command makes invisible).

If you select a clipping path and change its inks or stroke, Canvas 
applies the attributes to the object, but the attributes aren’t visible 
unless you use the Release command to convert the clipping path 
back into a vector or text object. 

Combining objects
The Combine command in Canvas allows you to create new 
objects from the intersection of two or more vector objects. Canvas 
contains a Combine palette that provides a series of visual represen-
tations of the effect before it is applied to a selected group of 
objects. You can outline the overlapping objects, delete all except 
the overlapping area, subtract the overlapping area, and perform 
other combinations.

Combine palette
To open the Combine palette, choose Effects > Combine. To use a 
combine method, each selected object must overlap at least one 
other selected object. Each method is represented by an icon and 
description.

To combine objects
1 Select two or more objects that you want to combine.

2 Select a combine method and the effect immediately hap-
pens.
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Selecting a combine method
The Combine palette contains various methods for combining 
objects. Some methods require that the paths of overlapping objects 
intersect for the effect to be visible or work properly. In addition, 
some methods work only with closed vector objects, and not with 
lines and open curves.

Trim Trims intersecting lines or arcs by shortening them until 
they meet at a vertex. You can trim a line to a line, an arc to an arc, 
or an arc to a line. In each case, Canvas trims the shorter segments 
of the intersecting lines and arcs. Trimmed lines and arcs remain 
separate and retain their attributes.

Trim also trims lines or arcs where they intersect closed vector 
objects. The vector objects do not change. 

If Canvas can’t trim the selected objects, a message tells you that 
the operation requires at least one open path.

Outline Creates one path around the selected objects and fills the 
interior of the new shape with the ink of the front object.

Add Joins two objects where they overlap to create a compound 
path, and fills the new shape with the ink of the front object. Com-
pound paths can include multiple closed shapes that have holes in 
them, unlike objects created with the Outline option.

Original objects Trim applied

Original objects: two 
circles and a rotated 
square

Objects combined 
with the Outline 
method

Outline shape smoothed 
into a heart using path- 
editing techniques
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Intersect Creates a new object from the intersection of all selected 
objects and fills the new object with the ink of the front object. All 
selected objects must be closed paths and share a common area.

Punch Removes the area where selected objects intersect and fills 
the new object with the ink of the front object. If you select more 
than two objects, Canvas starts with the back object and continues 
forward through the stacking order.

Subtract Front Removes from the back object the areas of overlap-
ping objects in front. The back object retains its ink attributes.

You can create a quick illustration of a holly leaf by combining a 
group of circles with a rectangle and then applying the Subtract 
Front command to that selected group of objects.

Subtract Back Removes from the front object the areas of overlap-
ping objects behind it. The front object retains its ink attributes.

Crop Removes areas of objects that are not behind the top object.

With the Add method, Canvas 
merges the cigarrette to the 
prohibited symbol to create a no 
smoking sign.

Combined with Add methodOriginal objects

The Intersect method helps you 
create some useful, basic shapes. 
Here, the intersection of two 
circles (highlighted) results in an 
eye shape.

Create and group objects With objects selected, click on the 
Subtract Front command

Finished object
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Divide Creates new objects where selected objects overlap. This 
option lets you use lines to “cut” other objects in pieces.

Slice Cuts the path of an object where it intersects with objects in 
front of it in the stacking order. The slice method results in two 
closed paths; e.g., slicing a circle in half with a line produces two 
closed semicircles.

Mix Creates new objects where selected objects overlap, similar to 
the Divide option. However, Canvas fills overlapping areas with a 
new color (the original colors must be solid). To determine the new 
color, Canvas compares the CMYK values of all the overlapping 
objects and uses the highest value of each color. (If you are using 
RGB colors, Canvas first converts the colors to CMYK.) For exam-
ple:

Transparency Creates new objects where selected objects overlap, 
and fills overlapping areas with a new RGB color (the original col-
ors must be solid). However, transparency lets you specify the level 
of transparency. When you select the Transparency option, enter a 
percentage in the text box that appears; 100% is completely trans-
parent, and zero is opaque.

Cyan Magenta Yellow Black

Color 1 50 30 25 5

Color 2 25 40 20 0

New Color 50 40 25 5

A symbol-filled oval provides a background Oval used to crop a vector drawing of an airplane
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Note: If multiple overlapping objects are grouped, Canvas treats the 
group as a single object and doesn’t apply the transparency or mix 
effect within the group.

Blending objects
Using the Blend effect, create gradual transitions in shape, color, 
and stroke width between two or more objects. Canvas generates a 
series of objects (from back-to-front through the stacking order) that 
appear to transform one object into another. 

Artists often use blends to create highlights and shadows in vector 
drawings that provide the illusion of roundness and lighting. In 
addition, use blends to copy and evenly distribute objects around 
shapes to create borders.

Using the Transparency method, the artist created the illusion that you can see 
through the cover of the CD case. You can see the bottom of the case through the 
cover.

Tip
Canvas can blend solid color inks 
only. If you blend objects with 
hatches, symbols, textures, or gra-
dients, Canvas generates the 
blend objects but doesn’t fill them 
with an ink.
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Using blends for dimensional effects
By specifying a high number of blend objects, you can create grad-
ual transitions between shapes and colors. With the appropriate set-
tings, colors seem to fade and mix into each other, and the blend 
objects do not appear as distinct objects. This effect is often used to 
add realistic highlights and shadows to objects so they appear three-
dimensional.

When configuring the blend settings, remember that the size of the 
final output affects the number of shapes required to make the 
blend appear smooth. For large posters, you might need to use a lot 
of shapes, but fewer shapes are required for small illustrations.

In addition, objects that you blend must have the same number of 
anchor points for the blend to appear smooth. Canvas uses the 
anchor points to calculate the steps and shapes in a blend; an incon-
sistent number of anchor points can cause unwanted twists and dis-
tortions.

Using blends to create patterns
Although blends are often used to create gradual, smooth transi-
tions between shapes and colors, you can also use the Blend com-
mand to create and evenly space a pattern across a layout. By 
specifying a low number of shapes and widely spacing the front and 

To blend objects

Select two or more vector objects. If 
necessary, choose Effects > Blend. 
Configure the settings and click Apply.

# of shapes. The number of objects 
Canvas creates for the blend. Higher 
numbers result in smoother blends.

Rainbow colors. Creates a rainbow-like 
blend of colors between objects. This 
introduces more color variations than a 
standard blend, which uses only combi-
nations of the original colors. When you 
turn on this option, two buttons appear; 
choose a clockwise or counter-clock-
wise path around the color wheel.

Bind to a path. Select to use the path of 
an object (not in the current selection) 
to arrange blend objects. Click Apply 

and then you have to choose a path. 
Click the object to which you want to 
bind the blend objects.

Point to point. Available when blend-
ing two objects. This option lets you 
rotate blend objects, creating the illu-
sion that one object is twisting into 
another. When you click Apply, Can-
vas prompts you to Choose 1st Point; 
click an anchor point on one object. 
Canvas then prompts you to Choose 
2nd Point; click an anchor point on the 
other object. To reverse the blend 
direction, Option-click (Mac) or Ctrl-
click (Windows) when you choose the 
two points.

Dynamic. Lets you use the Direct 
Selection tool (hollow arrow) to accel-
erate, decelerate, expand, contract, and 

redirect the blend after Canvas creates 
it. Dynamic blends aren’t available for 
specialized objects, such as multigons, 
spirals, concentric circles, and grids.

Tip
To ensure that blended objects 
have the same number of anchor 
points, copy an object, edit its 
shape, and blend between these 
objects. 
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back objects, you can make each blend object a distinct object. This 
effect can be useful for creating borders and other patterns.

Enveloping objects
The Envelope command lets you distort shapes and text, as if an 
illustration was drawn on a rubber sheet and then stretched.

When an object is in envelope edit mode, its bounding box acts like 
the rubber sheet. Canvas includes several envelope styles that offer 
various handles you can use to stretch an object’s bounding box. 
Using this effect, you can create new shapes, add a sense of motion 
to an illustration, arrange text so it appears to be painted on a three-
dimensional object, or distort an image (see “Envelope effect,” 
page 27.20).

The artist created this border by first 
creating a flower-like multigon, copying 
it, and drawing an oval. To distribute the 
flowers evenly around the oval, the artist 
selected the two multigons, turned on 
the “Bind to a path” option in the Blend 
palette, specified a relatively low number 
of shapes (15) for the blend, and chose 
the oval as the binding path. 

The Envelope command distorted the 
type to match the contour of the ship’s 
hull 
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Using envelope templates
Canvas has several envelope templates that you use to instantly dis-
tort shapes. The silhouettes in the template scroll list show the dis-
tortion created by each template.

In addition, you can create your own envelope templates. After you 
apply the envelope effect to an object, you can acquire the shape of 
the envelope as a template.

To apply an envelope template
1 Select a vector object.

2 Choose Effects > Envelope to open the Envelope palette. 

3 In the palette, choose Template in the menu. 

4 Select a preview shape in the scroll list to select it, and click 
Apply. 

To save an envelope as a template
To store an object’s envelope as a template, you must first use the 
envelope effect on the object (see “To apply an envelope effect,” 
page 21.14). You can’t acquire a standard vector shape, such as a 
circle, unless you first apply the envelope effect

1 Select an object that has been edited using the envelope 
effect. The object cannot be in envelope edit mode.

2 Choose Effects > Envelope to open the Envelope palette. 

3 In the menu, choose Template.

4 Click Acquire; a preview of the envelope shape appears in the 
scroll box.

To delete an envelope template
1 In the Envelope palette, choose Template in the menu. 

2 Click a preview shape in the scroll box to select it, and click 
Delete.

Using envelope styles
In addition to envelope templates, Canvas has six envelope styles 
that let you edit shapes in different ways. Each style moves and 
changes the bounding box in a particular way. See “Envelope styles 
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and editing options,” page 21.14 for information on the attributes 
of each style.

To apply an envelope effect
1 Select a vector object.

2 Choose Effects > Envelope to open the Envelope palette. 

3 Choose an envelope style in the menu and click Apply. 

4 Drag the envelope handles that appear on the bounding box 
of the object to edit the shape.

Envelope styles and editing options

Example Style Number of handles Envelope behavior

Warp Enter the number of hori-
zontal and vertical handles 
in the text boxes.

Each handle behaves like a path anchor point and can 
move in any direction.

Distort Four Each side of the envelope edit box is a straight line; han-
dles can move in all directions. This style is useful for cre-
ating perspective.

Straight Line Eight All handles are connected by straight lines. Corner handles 
are constrained to right-angle movements; side handles 
can move in all directions.

Single Cusp Eight Side handles form convex or concave curves between cor-
ner handles. Side handles can move in any direction; cor-
ner handles are constrained to right-angle movements.

Double Cusp Eight Side handles form S-shaped curves between corner han-
dles. Side handles can move in any direction; corner han-
dles are constrained to right-angle movements.

Example of selected envelope style

Select an envelope style

Options for Warp style only
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Extruding objects
The Extrude command lets you create objects that appear to have 
three dimensions. Extrude vector and text objects in parallel style, 
and vector objects in circular and semi-circular (“sweep”) style.

You can rotate and scale extruded objects in three-dimensional 
space. You can set the placement, intensity, and color of a simu-
lated light source for shading extruded objects. Solid color fill inks 
can be applied to extruded objects. Strokes and other inks are not 
supported.

To extrude an object
1 Select an object for the extrusion you want to create:

• For parallel extrusion, select a text or vector object, or a 
group object containing one or both types of objects. 

• For circular or sweep extrusion, select a vector object.

2 Choose Effects > Extrude to display the Extrude palette. 

3 Select a preset or custom extrusion setting:

Using presets From the preset extrusion palettes, select an extru-
sion icon to extrude the selected object. The icons show the angle 
and position of the extruded object. Canvas uses a default extrusion 
depth for parallel extrusions, and a default Steps setting for circular 
extrusions. 

Using custom settings Click the arrow to expand the palette. 
Choose an extrusion style, lighting color, and other options. Click 
Apply to extrude the selected object. 

4 If you select Circular or Sweep style, an extrusion axis 
appears (see “Completing a circular or sweep extrusion,” 
page 21.16).

Bézier Eight All handles behave like smooth anchor points and can 
move in any direction.

Example Style Number of handles Envelope behavior
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Completing a circular or sweep extrusion
When you set up a circular or sweep extrusion, specify the number 
of steps you want Canvas to use. The more steps, the smoother and 
less “blocky” the extrusion appears.

• To specify the number of steps for a circular or sweep extrusion:

In the Extrude palette, enter a number between six and 60 in the “# 
of Steps” text box.

After you apply a circular or sweep extrusion to an object using the 
expanded Extrude palette, you need to set the extrusion axis, which 
is represented by a black bar. A mirror image of the selected object 
shows the extrusion at 180°. 

• To set the extrusion axis: Drag the black bar right, left, up, or 
down, depending on the direction you want to extrude. The mirror 
image of the object moves as you drag the axis. Press Enter or dou-
ble-click to complete the extrusion.

Extrusion palette
A Parallel presets
B Circular presets
C Lighting presets
D Rotate buttons

Click to expand

Original object Axis 

Circular and sweep extrusions

Circular 
extrusion

Axis 180º sweep 
extrusion
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Extrusion options
Use palettes of extrusion and lighting presets in the Extrusion pal-
ette to modify extruded objects. If you expand the Extrude palette, 
you can use options to control lighting and rotation of extrusions. 
You can set these options before you extrude an object, or to edit an 
extruded object. 

• Before extruding a selected object, set up the options you 
want and click Apply to extrude the object. 

• After extruding an object, double-click it, change the set-
tings you want, and click Apply to apply the settings. 

You can control the color and position of the light source to change 
the shading of extruded objects. Canvas uses shades of gray to cre-
ate highlights and shadows. Canvas then mixes the highlights and 
shadows with the color of the light source and fill color of the 
object.

Extrusion styles 
In the expanded Extrude palette, select the extrusion style from the 
pop-up menu. 

Parallel Adds depth to an object, as though the shape were cut out 
of a slab of clay. You can create parallel extrusions with text objects 
and vector objects.

Circular Extrudes a shape in a circular path. You can set the diam-
eter of the extrusion path and number of steps (6-60) in the extru-
sion. You can apply circular extrusions to vector objects, but not 
text.

Sweep Extrudes a shape along a circular path, and lets you specify 
the number of degrees (10 to 360) to extrude. You can also set the 
diameter of the extrusion path and the number of steps (6-60) in the 
extrusion. You can apply sweep extrusions to vector objects, but not 
text. 
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Editing extruded objects
Immediately after you extrude an object, the object is in extrusion 
edit mode. In edit mode, Canvas displays three axes, representing 
the three dimensions. Each axis has a handle, and when you roll the 
pointer over a handle, it changes to an extrusion pointer. Other-
wise, the pointer appears as a rotation pointer.

When an extruded object is selected or in edit mode, the extrusion 
options are available in the Extruded palette as well as in the Prop-
erties bar.

• To exit extrusion edit mode: Double-click outside the object or 
press Esc.

To change the shape of extruded objects
When an extruded object is not in edit mode, you can resize and 
reshape it like other two-dimensional vector objects.

• drag a handle on the bounding box to resize the object

• place the object in Freeform mode to skew the object

Extrude palette options
A Select an extrusion style. For 
Sweep style, also enter the angular 
length, from 10° to 360°.

# of Steps: For Circular or Sweep style, 
number of steps controls the number 
of facets on the surface of the extru-
sion. Enter a value from 6 to 60.

Light color: Choose a light source col-
or from the palette.

Back/Front: Drag the slider to specify 
the depth of the light source in 3D 
space (along the Z axis).

Intensity: Drag the slider to adjust the 
overall brightness of the light source.

B Drag the handle to set the hori-
zontal (X) and vertical (Y) position of 
the light source and preview the effect.

Light Source: Use the handle (B) and 
Back/Front slider, or enter X, Y, and 
Z coordinates to set the position of 
the light source.

Ambient Light: Drag the slider to 
adjust the highlight and shadow con-
trast.

Rotation Angles: Enter X, Y, and Z 
values in degrees to rotate the 
extruded object in 3D space.
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• use the Scale command or Properties bar to resize the 
object

In addition to these two-dimensional editing functions, extruded 
objects have unique, three-dimensional properties. When an object 
is in extrusion edit mode, you can make it thicker, wider, or taller, 
and Canvas redraws the object to account for lighting changes.

To change the color of extruded objects
When you extrude a vector object, Canvas uses combinations of a 
solid-color fill ink, shades of gray, and the light-source color to cre-
ate a three-dimensional appearance. After you extrude an object, 
you can apply solid fill inks and change the color of the light source 
in the Extrude palette or in the Properties bar. When you change 
colors, Canvas redraws the object to show the interaction of the 
new colors with the object’s shape and shading.

To rotate extruded objects
You can rotate extruded objects in several ways:

• Click the rotation buttons on the Extrude palette or Prop-
erties bar.

• Enter values in the Rotation Angles text boxes in the 
expanded Extrude palette.

• Rotate and scale extruded objects interactively. 

To rotate and scale an extruded object, the object can either be 
selected or in extrusion edit mode. 

• To place an extruded object in edit mode: Double-click the 
extruded object with the Selection tool.

HandleEditing extruded objects

When you drag a handle, Canvas 
extrudes the object outward, along 
the corresponding axis; i.e., dragging 
a handle to the right extrudes the 
object to the right and left simulta-
neously.

Extrusion symbol when pointer is 
on an extrusion handle

Rotation symbol when pointer is 
not on an extrusion handle
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To rotate an extruded object interactively
When you first apply the Extrude effect, the object might appear 
flat if it is facing you (with the Z axis pointing directly at you). 

To see all dimensions, rotate an edge of the object toward you. 
With the rotation pointer, drag a side in the direction you want to 
rotate the object. As you drag, Canvas displays a circle to show the 
space in which the object can rotate. Dragging inside the circle 
rotates the object in all three dimensions; dragging outside the cir-
cle rotates the object on the plane that is facing you.

You can also rotate an extruded object in two dimensions, like 
other vector objects, choosing Effects > Rotate or Freeform. The 
object can’t be in extrusion edit mode to use these commands. 
When you use the Rotate and Freeform commands, Canvas does 
not reapply lighting effects as with three-dimensional rotation; i.e., 
the light source appears to move with the object, instead of remain-
ing in the same place as the object rotates.

Colorizing objects
Use the Colorize command to tint vector objects with solid color fill 
or pen inks when you want to mix two colors, or shade one color 
with another. Doing this in the Presets palette can be complicated, 
since you have to create a custom color and set the correct values to 
approximate a two-color mixture. The Colorize command lets you 
simply select two colors and choose the percentage of each.

Rotation pointer appears when an 
object is in extrusion edit mode

Circle appears when you drag 
with the rotation pointer
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To colorize a vector object
1 Select at least one vector object that has a solid color fill or 
pen ink. Colorize has no effect on gradient, hatch, texture, and 
symbol inks. 

2  Choose Effects > Colorize.

3 In the Colorize dialog box, turn on the Fill and Stroke 
options to colorize both, or select the one ink you want to colorize.

4 In the pop-up color palettes, select the colors you want to add 
to the inks of the selected objects.

5 Use the sliders or enter a percentage in the text boxes to set 
the amount of color to mix with the object’s color.

6 Turn on Preview to see the effect or click OK to colorize the 
object.

How colorization works
Canvas uses the specified percentages to determine the new color 
values for the selected object. For each color value (e.g., Red, 
Green, and Blue in the RGB color model), Canvas finds the differ-
ence between the tint and the original color. Then, Canvas multi-
plies the differences by the percentage you specify, and adds these 
values to the original color values.

Fractalizing objects
Fractals are mathematical transformations that simulate the irregu-
larities and patterns in natural shapes, such as coastlines and moun-
tain ranges. When you fractalize a vector object, its outline becomes 
jagged. You can use the Fractalize command to add a fractal effect 
to any vector object except dimension objects and Smart Lines.

Colorization calculations

An object’s color has a red value of 40%. 
To tint 50% with a color that has a red 
value of 100%, Canvas calculates a new 
red value of 70%. The same calculations 
apply to the green and blue values for an 
RGB color.

R=40% R=100% R=70%

Original Tint color Result

Difference in red values: 100 - 40 = 60

Value difference multiplied by tint percentage: 60 * 50% = 30

Original color value plus tint value is new value: 40 + 30 = 70% red
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To fractalize an object
1 Select at least one object and choose Effects > Fractalize. 

2 Enter the Wiggle and Density values, and choose Curves or 
Polygon fractals. 

3 Click Apply to preview the effect. Click OK to apply the 
effect and close the dialog box.

Wiggle The amount a fractalized path can deviate from the origi-
nal path. Enter a number between 0 and 20; higher numbers 
increase the amount of wiggle. 

Density The smoothness of the fractalized path. Enter a number 
between 0 and 5. Higher values increase the number of anchor 
points Canvas add to the path. Lower densities result in sharper 
angles.

Curves or Polygon Polygon fractals can be jagged and use many 
anchor points, while curves fractals are smoother and require fewer 
additional anchor points.

Note: Canvas fractalizes objects by adding several anchor points to 
an object’s path. High wiggle and density settings and polygon frac-
tals can add numerous anchor points, which require more memory 
to print. Lower settings and curves fractals can help to conserve sys-
tem resources and eliminate problems you might have while print-
ing.

Creating shadows for objects
The Shadow command lets you apply two types of offset (“drop”) 
shadows to selected objects. Use the command to apply a shadow 
made of vector objects or an image. Canvas places the shadow 
directly behind the selected object in the stacking order.

Vector objects Fractalized mountains
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You can edit shadow objects independently from the objects they 
are shadowing. Skew them to create oblique shadows and use filters 
to change their appearance. The original object and shadow are not 
grouped, so editing or moving one doesn’t affect the other.

You can apply shadow effects to any vector or text object except 
dimension objects and Smart Lines. If you apply a vector shadow to 
a group of objects, Canvas groups the shadow objects and places 
the shadow behind the original group. If you apply a shadow to a 
paint object, Canvas creates a shadow of the paint object’s bound-
ing box.

To create an offset shadow
1 Select an object and choose Effects > Shadow. 

2 In the Shadow dialog box, select options (see “Shadow 
options,” page 21.24).

3 Click Apply to see the effect. To accept the settings and close 
the dialog box, click OK.

Vector (left) and image type shadows 
with different offsets
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Shadow options
Shadow type Select Object to create a vector object shadow. Select 
Image to create a paint object shadow. A vector shadow has a hard 
edge and can be edited like any vector object. An image shadow 
can be softened using the Gaussian Blur option and can be edited 
like any paint object.

Shadow Color Select the color to apply to the shadow object from 
the color palette. 

Offset Specify the location of the shadow relative to the original 
object. Enter the distance and angular direction to offset the 
shadow in the first text boxes, or enter the horizontal and vertical 
distances to offset the shadow in the second text boxes.

Image Options These options are available when Image is selected. 
Specify the amount of blur in the Gaussian Blur box. Select the 
color mode of the paint object from the Mode menu. Set the image 
resolution in the “Res” box. To apply anti-aliasing, select an option 
from the menu.

Size The value shows the amount of memory required for the 
paint object based on the current Image Options settings.

Binding groups
The Bind Group command lets you align a group of objects to the 
path of a vector object, such as a curve or polygon.

To use the Bind Group command, you must select an object group 
(a set of vector objects that have been united by choosing Object > 
Group). 

To bind an object group
1 Select the object group that you want to bind to a path and 
select the path to which you want to bind the object group. Both 
the object group and the path must be selected.

2 Choose Effects > Bind Group.
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DYNAMIC OBJECTS & CLIPART

You can speed up many projects by taking advantage of reusable 
dynamic objects and ready-made illustrations. This chapter 
describes how to use the Personal Library and Symbol Library.

Working with libraries
Dynamic objects are illustrations that you store in the Personal 
Library palette. You can create a dynamic object from any vector, 
text, group, or paint object. After storing a dynamic object, you can 
use the Personal Library to place copies that are linked to the 
stored dynamic object. If you change the dynamic object in the pal-
ette, all the copies in the document will also change.

Dynamic objects make it easy to place and change frequently used 
illustrations. Save time by creating dynamic objects from elements 
you intend to use repeatedly, such as logos, symbols, and floor 
plans; e.g., after designing a logo, make the illustration a dynamic 
object and retrieve copies from the Personal Library palette. If you 
decide to change the logo, you can change all the copies at once by 
replacing the original dynamic object in the Personal Library pal-
ette.

The Canvas Media kit includes the extensive Canvas Clipart Col-
lection. Subjects range from animals and plants to business images 
and technical symbols. This extensive collection is stored in Canvas 
files on CD-ROM.

These libraries will help speed up projects by taking advantage of 
re-usable objects and ready-made illustrations.

• To open the Personal Library: Choose Window > Palettes > Per-
sonal Library.

• To open the Symbol Library: Choose Window > Palettes > Sym-
bol Library.

Personal Library
Use the Personal Library to store dynamic objects that you fre-
quently require, such as logos and technical symbols.
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You can store two categories of dynamic objects in the Personal 
Library palette:

Document Dynamic objects stored on the Document tab are avail-
able in the current document only.

Application Dynamic objects stored on the Application tab are 
available in all Canvas documents.

To create a dynamic object
1 Create the vector illustration, text object, or image that you 
want to save as a dynamic object.

2 Click on either the Document or Application tab.

3 Drag the object onto the palette. 

4 Enter a name for the object in the dialog box when requested. 
A preview of the dynamic object appears in the palette.

To place a dynamic object
1 Select the preview of the dynic object in the Personal Library 
palette.

2 Move the cursor into the drawing area. The cursor changes to 
a place pointer.

• To place the dynamic object at its original size: Click in the lay-
out area where you want to place the upper left corner.

• To scale dynamic objects: 3Drag the pointer to set the bound-
ing box size. Canvas scales the dynamic object to fit the bounding 
box.

To unlink a copy of a dynamic object
1 Select the copy in the document.

2 Open the menu in the Personal Library palette and select 
Unlink.

To replace a dynamic object
Note: Only dynamic objects stored in the Document tab can be 
replaced.

1 Drag the new object to the Document tab of the palette and 
drop it on the dynamic object that you want to replace.

2 Click Yes to replace the existing dynamic object.

Tip
To constrain the proportions, 
press Shift while scaling.
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To delete a dynamic object from the Personal Library palette
Note: Deleting a dynamic object from the palette does not affect cop-
ies within the document.

1 Select the dynamic object in either the Document or Applica-
tion tab.

2 Open the palette menu and select Delete. The object is auto-
matically deleted from the palette.

To create dynamic object sets
You can define a set of dynamic objects that you use for specific 
projects.

1 Open the palette menu and select Save set. 

2 Enter a name for the set, navigate to the directory to save the 
set, and click Save.

To append a saved set
1 Open the palette menu and select Append Set.

2 Navigate to the directory where the set is saved and click 
Open. The set is appended to the current set.

• To clear all sets from the palette: Open the palette menu and 
select Clear Library palette (Document tab) or Clear Application 
Library Objects (Application tab).

To load a saved set
When you load a set, the current set is replaced. You should save 
the current set before loading a new set.

1 Click on the Application tab.

2 Open the palette menu and select Load Library Object Set. 
The set is loaded into the palette.

To set the size of cells
The palette has two cell sizes: large and small.

1 Click on the menu icon.

2 Select Toggle cell size.
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Symbol Library
Use the Symbol Library to browse through Canvas clip art files, 
select illustrations, and place them in your documents. You have 
the choice of searching locally or online. 

Local tab
Click on this tab if you want to search for illustrations on the Can-
vas Clipart CD.

Note: The term “locally” refers to your computer or within your 
local network.

To search for illustrations locally
Note: To use this function, a Canvas Clipart CD must be available.

1 Click on the Local tab of the Symbol Library palette. Canvas 
will begin retrieving the illustrations from the CD.

2 Click the Find CD button.

3 Search for an illustration using the following techniques:

• Open the illustration categories menu and select a cate-
gory in which to search.

• Enter a keyword in the Search field and then press Enter.

Note: You can also refine your search by adjusting the search param-
eters (see “To change your search parameters,” page 22.5).

4 Select the illustration and then place it in the layout area.

To place illustrations
After finding an illustration, you can place it at its original size or 
scale it while placing.

1 Select the illustration in the Symbol Library palette

2 Move the cursor into the layout area. The cursor changes to a 
place pointer.

• To place the illustration at its original size: Click in the layout 
area where you want to place the upper left corner.

• To scale illustrations: Drag the pointer to set the bounding box 
size. Canvas scales the illustration to fit the bounding box.

A Scroll arrows
B Illustration categories
C Find CD
D Search field
E Search parameters
F Menu icon

Tip
To constrain the proportions, 
press Shift while scaling.
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To search in another directory
1 Click on the menu icon. 

2 Select Open Library. The Open dialog box appears.

3 Navigate to the directory that contains the Canvas Index 
(.ndx) file and click Open. 

To change your search parameters
1 Open the Search parameters menu.

2 Choose either Matches, Contains, Starts with, or Ends with.

Note: You can also select the Search using AND criteria checkbox to 
limit the search results.

3 Click OK to close the dialog box.

To set the size of cells
The palette has two cell sizes: large and small.

1 Click on the menu icon.

2 Select Toggle cell size.

Choose To find

Matches Exact matches of the name you type

Contains Any name that contains the text you type

Starts With Any name that begins with the text you type

Ends With Any name that ends with the text you type

Symbol Library palette menu 
(Local tab)
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Online tab
Click on this tab if you want to search for illustrations via the 
Deneba server or your own server.

To search for illustrations online
1 Click on the Online tab.

2 Search for an illustration using the following techniques:

• Use the predefined search strings in the Presets menu.

• Enter a keyword in the Search field and then press Enter.

Note: You can also refine your search by adjusting the search param-
eters with the Search options.

3 Select the illustration and then drag it into the layout area.

To change server settings
Open the menu and select Change server. The Server settings dia-
log box opens.

• To use the Deneba server: Select the Deneba library server 
radio button.

• To use a different server: Select the Custom server radio button 
and enter the IP or URL in the Address field. You have to define a 
communication port as well.

To use the Download manager
The Download manager contains a list of the illustrations that you 
have downloaded or shows the status of current downloads.

1 Open the palette menu.

2 Select Open download manager.

A Predefined search strings
B Search field
C Search options
D Menu icon

Symbol Library palette menu 
(Online tab)
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• To cancel a download in progress: Select the file in the list and 
click Cancel downloads.

• To clear a file from the list: Select the file in the list and click 
Remove from list.

To modify the online settings
Open the menu and select Settings. The Online settings dialog box 
opens.

To set the size of cells
The palette has two cell sizes: large and small.

1 Click on the menu icon.

2 Select Toggle cell size.

Online settings dialog box
A Download. Designate your down-
load directory.
B History. Adjust or clear your down-
load history.
C Double-click. Define how Canvas 
will react to double-clicking a thumbnail 
image.
D Max. search. Enter a value for the 
maximum number of search results. 
The maximum number is 200.

Display search results immediately. If 
selected, the thumbnails appear indi-
vidually as they are downloaded. If 
deselected, the thumbnails appear all 
at once.

Open download manager automati-
cally. Select this option to view the 
Download Manager when download-
ing a graphic.

Close download manager automati-
cally. Select this option to close the 
Download manager when the graphic 
has been completely downloaded.
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23
PAINTING & IMAGE-EDITING

Canvas provides a full palette of painting tools, including the digital 
equivalents of markers, airbrushes, and paintbrushes, plus tools for 
creating effects like neon and blends. The Painting tools palette 
also provides tools to select, retouch, color-correct, and clone 
images (see “Tool palettes,” page 10.6). This chapter explains how 
to use these painting tools, choose image modes, and convert 
objects into images.

Paint objects and images
A paint object is a Canvas object that contains an image. Paint 
objects are always rectangular and the same size as the images they 
contain. 

Images are pictures defined by pixels. A scanned photo, TIFF, or 
Photoshop (.PSD) file, and pictures you paint in Canvas are all 
images composed of pixels. 

Each pixel in an image is a solid color. Pixels can also be semi-trans-
parent or completely clear. You can adjust the color, opacity, and 
transparency of pixels by using painting tools and commands. 

Creating paint objects
You can make new paint objects containing blank images or con-
vert objects into images by rendering them. 

You can also scan images directly into a Canvas document (see “To 
open or place a file” on page 14.2; “Importing images” on 
page 14.4; and “Using scanners to acquire images” on page 24.1).

About paint objects and images 
in Canvas 

You can perform common object oper-
ations, including move, copy, and dupli-
cate, on paint objects. For details, see 
the chapter titled “Working with 
objects” on page 17.1.

You can create images entirely in Can-
vas by making a new paint object that 
you can paint in, or creating an image 
from vector or text objects, as 
described in this chapter.

Import images into Canvas documents 
using the following methods:

• Place an existing image in a docu-
ment using the Place, Paste, or Acquire 
commands.

• Scan a photo using the Acquire 
command. See “Using scanners to 
acquire images” on page 24.1.
23.1



23
Using the Paint Object Creator tool
The Paint Object Creator tool creates new, blank paint objects. 
This tool lets you set the image mode, resolution, and background 
transparency for new paint objects.

Settings for new paint objects
The Paint Object Creator tool settings for image mode, resolution, 
and background are applied to new paint objects you create with 
the Paint Object Creator tool or any painting tool (excluding Crop 
tool).

• To change settings for new paint objects: Select the Paint Object 
Creator tool icon. The settings appear in the Properties bar. Their 
uses are explained in the following paragraphs.

Note: The The Paint Object Creator tool settings can be changed at 
any time.

Image mode Choose an image mode in the menu. The image 
mode controls the number of colors that can be stored in an image 
(see “Image modes for Canvas paint objects” on page 23.28). 

Resolution Enter a value from 1 to 2,540 pixels per inch and press 
Enter.

Background Choose Opaque Background or Transparent Back-
ground in the menu (see “Paint object backgrounds,” page 23.23). 

• Opaque Background creates an image made of white pix-
els. 

• Transparent Background creates an image made of clear 
pixels. This type of image is transparent, so you can see 
other objects through it.

Auto Create If this option is selected, only the Paint Object Cre-
ator tool can be used to make blank paint objects. If this option, is 
not checkmarked, select any painting tool (except Crop) and drag 
in the document to create a blank paint object.

To create a paint object with a painting tool
1 Select the Paint Object Creator tool or another painting tool 
(see “Auto Create,” page 23.2). 

Paint Object Creator tool

Tip
Use a transparent image like a 
clear overlay; e.g., place a trans-
parent paint object in front of a 
vector graphic, and then paint in 
the image to give the appearance 
of paint strokes on the graphic.
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2 Drag diagonally in the document to create a rectangular 
paint object.

• To constrain the height and width proportionally: Press Shift as 
you drag.

• To constrain the height and width symmetrically from the center:

Press Option (Mac) or Ctrl (Windows) as you drag.

• To constrain the height and width proportionally and symmetrical-
ly: Press Option+Shift (Mac) or Ctrl+Shift (Windows) as you drag.

3 A blank paint object appears in edit mode. Begin painting in 
the image. When you finish, press Esc to end edit mode.

Using the Create command
The Create command creates new paint objects using the mode, 
size, resolution, and transparency settings that you specify. 

Use the Create command to create paint objects that are opaque or 
transparent (see “Create Image options,” page 23.4). 

To create a paint object
1 With no objects selected, choose Image > Area > Create.

2 In the Create Image dialog box, set the image mode, type of 
background, background color (for an opaque image), size, and 
resolution of the image.

3 Click OK. The new paint object appears in the center of the 
view and is selected.

Setting paint object dimensions
When you use the Create command, you can set the dimensions of 
a paint object using relative or absolute values, depending on what 
you choose in the menus next to the Width and Height text boxes.

If you choose pixels to set the dimensions of the paint object, the 
size of the object is relative to its resolution; higher resolution 

Drag any painting tool (except 
Crop) to create a new paint 
object

A paint object in 
edit mode, 
indicated by crop 
marks at each 
corner.
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makes pixels smaller, so the resulting object is smaller at the same 
width and height values. 

If you choose inches, centimeters, picas, or points, enter absolute 
values for the paint object’s dimensions.

To create a paint object with the Properties bar
1 Select the Paint Object Creator tool so the Create Image 
Options appear in the Properties bar. 

2 Enter the dimensions and resolution. 

3 Select the mode and background as explained in “Create 
Image options”. 

Note: You can also specify the X/Y coordinates for the new paint 
object. Click Create.  

Working with painting tools
Apply color, make selections, edit, retouch, color-correct, and clone 
images with Painting tools. For some tools, you can adjust opacity, 
pressure, exposure, or other settings. See the specific tool entries in 
this chapter for details. These tools are located in the Painting tools 
palette.

Create Image options

The Create Image dialog box has 
options for new images.

File Size. The amount of memory 
required by the paint object, based on 
resolution, size, and mode. Black & 
White mode requires the least memo-
ry; CMYK Color requires the most.

Mode. Choose an image mode. See 
“Image modes for Canvas paint 
objects” on page 23.28.

Background. Choose Transparent or 
Opaque (see “Background,” 

page 23.2). For Opaque, you can 
select a color from the color palette.

Transparent creates a clear back-
ground for the image. When you 
choose this option, the color palette is 
not available.

Width and Height. Enter the object’s 
width and height. In the adjacent 
menus, choose pixels or a unit of mea-
surement. 

Res. Enter the image resolution. 
Choose pixels per inch or pixels per 
centimeter in the adjacent menu. 

Auto. Click Auto to calculate the reso-
lution based on halftone screen fre-
quency and image quality.
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These tools can be used to place paint objects into paint edit mode. 
Point to a selected paint object with a painting tool, the pointer 
becomes a hand. Click the cursor on the paint object to enter edit 
mode. 

To use a painting tool
This general procedure applies to all painting tools.

1 Place a paint object in edit mode.

2 Select a foreground or background color for painting (see 
“Selecting colors for painting,” page 23.17).

3 Select a brush shape in the Brushes palette located in the 
Properties bar. You can also choose a mode or other option for 
most tools.

4 Click in the image to apply a spot of color, or drag to paint a 
brush stroke, depending on the tool.

• To constrain a brush stroke to horizontal or vertical: Press Shift 
as you drag.

Paint tool options

Painting opacity
Painting opacity affects the intensity of painting. Adjust this setting 
in the Properties bar for the following painting tools: Eraser, 
Marker, Paintbrush, Bucket, Blend, and Rubber Stamp.

Note: For the other painting tools, Opacity is replaced by either 
Pressure, Glow, or Exposure.

Tip
You can start dragging outside an 
image; a tool’s effect begins when 
the pointer is inside the image.

Selected paint object Paint object in edit mode
Working with painting tools 23.5



23
Painting opacity can be set from 1 to 100%. Higher opacity makes 
the color more opaque. Lower opacity makes color appear more 
transparent. Painting opacity works with painting modes (see 
“Painting modes,” page 23.18). If you use the Paintbrush tool to 
apply black at 100% opacity in Normal mode, black replaces the 
original color wherever you paint. At 50% opacity, the strength of 
the black is reduced, so it mixes with the underlying color. If you 
also use a different painting mode, the strength of the mode’s effect 
is reduced.

To set painting opacity
1 Select a painting tool that uses the opacity setting.

2 Move the Opacity slider or enter a percentage in the text box. 

Canvas remembers each tool’s painting opacity setting; e.g., if you 
use the Blend tool at 30% opacity and then use the Paintbrush tool 
at 100% opacity, the setting changes back to 30% when you select the 
Blend tool again.

Note: The Opacity slider in the Brushes palette affects subsequent 
brush strokes by the current painting tool only. It is not the same as 
the Opacity slider in the Toolbox and the Transparency palette, 
which are linked and control overall opacity of selected objects.

Fade settings
The following tools have Fade settings: Paintbrush, Airbrush, Blur, 
Dodge, Burn, Eraser, Marker, Sponge, Smudge, Sharpen, and Rub-
ber Stamp. 

Select the options you want to use in the Fade area. In the Fade 
within field, enter the distance in which Canvas will complete the 
fade.

• To gradually diminish the brush size as you drag: Select the Size 
checkbox.

• To fade the color to transparent: Select the Opacity checkbox. 
Depending on the selected tool, the checkbox may be labelled as 
Pressure or Exposure. 

Tip
To quickly change the opacity set-
ting, you can press a number key; 
“1” equals 10%, “2” equals 20%, 
“3” equals 30%, etc. “0” equals a 
setting of 100%.
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Pressure Sensitive settings
If you are using a pressure-sensitive, plug-in device, such as a 
Wacom™ tablet, the Pressure Varies options are located within the 
Image/Multimedia managers in the Configuration Center. 

• To access the Pressure Varies options: Double-click on the tool 
icon in the Toolbox to open the tool settings in the Configuration 
Center. You need to use a pressure-sensitive, plug-in device, such as 
a Wacom™ tablet. Use these options to make a pressure-sensitive 
stylus.

Painting with the Paintbrush tool
The Paintbrush tool applies the foreground color. Apply a soft 
(anti-aliased) brush stroke by choosing a soft-edged brush in the 
Properties bar or Brushes palette. Use the settings in the Properties 
bar to configure this tool.

Spraying soft strokes with the Airbrush tool
The Airbrush tool applies the foreground color with a very soft 
(anti-aliased) stroke. The Airbrush tool paints as long as you press 
the mouse. The Pressure setting in the Properties bar and Brushes 
palette controls how fast the Airbrush applies color. Use the settings 
in the Properties bar to configure this tool.

Painting with the Marker tool
The Marker tool paints with the foreground color, applying a hard-
edged stroke. Use the options in the Properties bar to configure the 
Marker tool.

Painting individual pixels with the Pencil tool
Use the Pencil tool to apply the foreground color to a single pixel or 
create a one-pixel, freehand line. If the pixel already uses the fore-
ground color, the Pencil applies the background color instead. You 
can use the Pencil tool for precise image editing at high magnifica-
tions (see “Fat Bits” on page 23.21).

• To paint a straight line: Shift -drag the Pencil to confine the line 
to 90° angles. 

Paintbrush tool

Airbrush tool

Marker tool

Pencil tool
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Painting two-toned “neon” strokes 
 Use the Neon tool to paint a neon-tube stroke, with the foreground 

color inside and the background color outside. Use the Glow setting 
in the Properties bar and Brushes palette to adjust the color ratio. 
Painting modes are not available with the Neon tool. 

Filling areas with color
Use the Bucket tool to pour color on an image. The Bucket applies 
the background color where you click. You can adjust its tolerance 
so the color covers adjacent pixels of the same color only, or adja-
cent pixels of similar colors.

Tolerance
The Tolerance setting is located in the Properties bar. 

• To affect only identically-colored pixels: Type 0 in the Tolerance 
text box. 

• To affect more pixels: Type a larger number.

• To soften the edge of the filled area: Turn on Anti-Aliased.

Painting in the background color with the Eraser tool
Paint with the background color using the Eraser tool. If a paint 
object has a visibility mask, the Eraser clears the pixels it touches, 
revealing a clear background. If the paint object does not have a vis-
ibility mask, the Eraser applies the background color.

Note: Opacity and paint mode options are not available with the 
Eraser.

Painting with the Blend tool
Paint a blend of colors in an image with the Blend tool. The default 
behavior (Foreground To Background) creates a blend of the fore-
ground and background colors. This tool is very useful for creating 
blends from black to white in channels, to make selection masks 
that fade gradually from full selection to no selection.

Neon tool

Bucket tool

Eraser tool

Blend tool
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Set the style and behavior using the settings in the Properties bar.

To create a linear blend Enter a Skew value and select a Behavior. 
Drag in the direction of the blend. Shift-drag to confine the blend’s 
direction to a 90° or 45° angle.

To create a  radial blend Enter both a Skew and Offset value. Drag 
from the center of the image. 

Copying areas with the Rubber Stamp tool
Make a copy (“clone”) of an image area with the Rubber Stamp 
tool. This tool is very useful for retouching scanned photographs, 
removing lines and scratches, as well as hiding seams when com-
positing images. Use the settings in the Properties bar to configure 
the Rubber Stamp tool.

Linear blend Radial blend

Blend options

Style. Choose Radial or Linear. 

Skew. To set the midpoint between 
blend colors, enter a number from 13 
to 87. The default is 50.

Offset. For Radial style, enter a value to 
set the percentage of starting color in 
the blend. To use more of the starting 
color in the blend, enter a number from 
50 to 100.

Behavior. Choose a blending method. 
Foreground and Background refer to 
the current colors in the Toolbox. 
Transparent options fade from the fore-
ground color to transparency. Spectrum 
blends create rainbow blends in a 

clockwise or counter-clockwise direc-
tion around the color wheel.

A Example of a blend used to vignette 
a photograph. The following Blend op-
tions were used:

Radial-style blend
Behavior = Transparent to Foreground
(Foreground color white)
Offset = 10
Skew = 70

Original

Rubber Stamp tool

Cloning styles

The effect of dragging the Rubber 
Stamp tool in an image depends on 
the option you choose in the Style 
menu in the Properties bar.

Clone (aligned). The first time you 
drag the Rubber Stamp tool in the 
image after setting the reference 
point, Canvas establishes a fixed 

direction and distance from the refer-
ence point to the pointer. The Rubber 
Stamp tool copies any area of the 
image that is this distance and direc-
tion from the pointer.

Clone (non-aligned). Dragging the 
Rubber Stamp tool always begins 
copying the image from the same ref-
erence point.

Impressionist This option smears pix-
els to create an impressionistic effect. 
You don’t need to set a reference 
point to use this effect.
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To use the Rubber Stamp tool
1 Configure the tool using the settings in the Properties bar (see 
“Painting opacity” on page 23.5, “Painting modes” on page 23.18, 
and “Cloning styles” on page 23.9).

2 Option-click (Mac) or Alt-click (Windows) in the image to set 
the reference point for sampling an image area.

3 Drag in the image to paint a copy of the sampled area around 
the reference point. 

Smudging colors
With the Smudge tool, pull color from one area of an image and 
drag it into adjacent areas. Use the settings in the Properties bar to 
configure the tool.

To use the Smudge tool
1 Configure the tool using the settings in the Properties bar.

• Select a brush size and shape from the Brushes palette (see 
“Selecting brushes and painting options,” page 23.13). 

• Adjust the Pressure setting. A setting of 1 affects the image 
slightly; 85 drags the color through many pixels.

2  Drag the Smudge tool in the image area you want to edit.

• To smudge the foreground color into the image: Choose the Fin-
ger Painting option.

Rubber Stamp pointer with 
Option (Mac) or Alt 
(Windows) pressed

Rubber Stamp pointer 
without modifier key

Option-click (Mac) or Alt-click 
(Windows) to set the reference point 
for the area you want to clone with 
the Rubber Stamp tool

Clone (aligned) option Clone (Non-aligned) option

Smudge tool
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Lightening (‘dodge’) areas
The Dodge tool lightens specific areas of an image. Use the settings 
in the Properties bar to configure the tool.

To use the Dodge tool
1 Configure the tool using the settings in the Properties bar.

• Select a brush size and shape from the Brushes palette (see 
“Selecting brushes and painting options,” page 23.13).

• Adjust the Exposure setting. Increasing the Exposure 
increases the lightening effect of the tool. Decreasing the 
setting decreases the effect.

• Choose Shadows, Midtones, or Highlights from the Mode 
menu. The Dodge tool lightens pixels that fall within the 
selected range only.

2 Drag the Dodge tool in the image area you want to edit.

Darkening (‘burn’) areas
Darken specific areas of an image by dragging the Burn tool over 
the pixels you want to darken. The tool’s effect can be controlled by 
your selection of brush and adjustment of the tool’s Fade setting. 
Use the settings in the Properties bar to configure the tool.

To use the Burn tool
1 Configure the tool using the settings in the Properties bar.

• Select a brush size and shape from the Brushes palette (see 
“Selecting brushes and painting options,” page 23.13).

• Adjust the Exposure setting. Increasing the Exposure 
increases the darkening effect of the tool. Decreasing the 
setting decreases the effect.

• Choose Shadows, Midtones, or Highlights from the Mode 
menu. The Burn tool darkens pixels that fall within the 
selected range only.

2 Drag the Burn tool in the image area you want to edit.

Blurring areas
Soften specific areas in an image with the Blur tool. The Blur tool 
decreases the contrast between pixels the tool drags over. Use the 
settings in the Properties bar to configure the tool. 

Dodge tool

Burn tool

Blur tool
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Select the Blur tool and click a paint object to put the image in edit 
mode, if necessary.

To use the Blur tool
1 Configure the tool using the settings in the Properties bar.

• Select a brush size and shape from the Brushes palette (see 
“Selecting brushes and painting options,” page 23.13).

• Adjust the Pressure setting. A setting of 1 affects the image 
slightly; 85 softens the image greatly.

• Choose Normal, Darken, or Lighten from the Mode 
menu. The Blur tool darkens pixels that fall within the 
selected range only.

2 Drag the Blur tool in the image area you want to edit. Canvas 
applies the effect to pixels touched by the tool.

Sharpening areas
Increase the contrast between specific pixels in an image with the 
Sharpen tool. Use the settings in the Properties bar to configure the 
tool. 

To use the Sharpen tool
1 Configure the tool using the settings in the Properties bar.

• Select a brush size and shape from the Brushes palette (see 
“Selecting brushes and painting options,” page 23.13).

• Adjust the Pressure setting. A setting of 1 affects the image 
slightly; 85 dramatically sharpens the image.

• Choose Normal, Darken, or Lighten from the Mode 
menu. 

2 Drag the Sharpen tool in the image area you want to edit. 
Canvas applies the sharpening effect to pixels touched by the tool.

Saturating and desaturating colors
With the Sponge tool, add or remove gray content from specific 
areas of an image. Use the settings in the Properties bar to config-
ure the tool.

To use the Sponge tool
1 Configure the tool using the settings in the Properties bar.

Sharpen tool

Sponge tool
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• Select a brush size and shape from the Brushes palette (see 
“Selecting brushes and painting options,” page 23.13).

• Adjust the Pressure setting. Increase the pressure to 
increase the effect.

• Choose Saturate or Desaturate in the Mode menu. Satu-
rate removes gray; desaturate increases the amount of 
gray.

2 Drag the Sponge tool over the image area you want to edit.

Selecting brushes and painting options
The Properties bar contains the Brush icon as well as other options 
for painting and image editing. The Opacity slider lets you adjust 
opacity for painting. The Mode menu lets you choose painting 
modes to control color application and target tonal ranges. Open 
the Brushes palette to select preset brushes and create new brushes. 

Note: The Brush icon appears in the Properties bar when one of the 
following Painting tools is selected: Eraser, Paintbrush, Marker, 
Airbrush, Neon, Rubber Stamp, Smudge, Blur, Sharpen, Dodge, 
Burn, Sponge.

Brush icon
Use the Brush icon to adjust current brush settings or to open the 
Brush palette and select another brush. 

To modify brush settings
You must select a Painting tool, such as the Paintbrush or Pencil 
tool, so the Brush icon is active in the Properties bar. You can edit 
any brush shape. For brush shapes created from selections, you can 
change only the spacing.

1 Click on the Brush icon in the Properties bar to open the pop-
up Brush Options dialog box.

Tip
The Brushes palette contains the 
same painting options as the Prop-
erties bar; e.g., the Opacity slider, 
painting modes, etc.
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2 Make any adjustments to the current brush’s settings (see 
“New brush options,” page 23.16). You can also add the brush to 
the Brushes palette by clicking the button located in the upper 
right corner.

Note: You do not have to add the brush to the Brushes palette to be 
able to use it; however, if you plan on using a brush more than 
once, we recommend that you add it to the palette.

3 Begin painting with the modified brush.

To select brushes from the Brushes palette
1 Click on the arrow that is next to the Brush icon and the 
Brushes palette pops out.

2 Click on a brush shape and begin painting.

While painting, use the context menu to change brushes and select 
painting options ( see “To access the context menu,” page 23.20).

Click this button to add 
the adjusted brush to the 
Brushes palette.

Click on the current brush 
icon to open the Brush 
Options pop-up dialog box.

Tip
You can drag the Brushes palette 
off the Properties bar. The Brushes 
palette has commands for creating 
brushes, saving brushes to a file, 
loading brush files, and deleting 
unused brushes.
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Brushes palette menu
Use the Brushes palette menu to create new brushes, save brushes 
in files, modify existing brushes, and delete brushes.

You can add custom brushes to the list of preset brushes in the pal-
ette. When you exit Canvas, it stores the brush presets. The same 
set of brushes are available whether you work with new documents, 
documents you created, or documents created by another Canvas 
user.

To create a new brush
1 Open the Brushes palette menu and choose New Brush. 

2 In the New Brush dialog box, adjust the settings for the brush 
(see “New brush options,” page 23.16).

3 Click OK after entering the settings you want. The new brush 
shape appears in the Brushes palette.

Click on the frame and drag it 
from the Properties bar.

Select a brush in the 
pop-up palette

Current brush

Brushes palette menu
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To define a brush shape with a selection
You can make a new brush shape from a selection in an image. 
This lets you create non-elliptical brush shapes.

1 Select all or part of an image (see “Selecting pixels in 
images,” page 26.1).

2 Choose Define Brush in the menu. The selection becomes a 
brush in the Brushes palette. Canvas uses the shape and lightness 
values of the selection to define the brush. Brush shapes do not 
contain color.

To delete brushes from the palette
You can permanently remove brush shapes from the Brushes pal-
ette. If you think you might want to use the brush shape again, you 
should first store it in a brushes file so at a later time you can load it 
back into the palette (see “To save brushes in a file,” page 23.16).

1 Select the brush you want to delete. 

2 Choose Delete Brush in the menu. You can also Command-
click (Mac) or Alt-click (Windows) a brush in the palette to delete 
it.

To save brushes in a file

You can save brushes in a file. Saving brushes to disk lets you cus-
tomize the Brushes palette for particular projects or exchange 

New brush options

Create brush shapes by specifying 
diameter, hardness, spacing, round-
ness, and angle. These same options 
are available in the Brush Options dia-
log box.

Diameter. Enter the diameter in pixels 
of the new brush.

Hardness. Enter a percentage to tell 
Canvas how much of the brush shape 
is solid. 

Spacing. This percentage sets the 
amount of brush overlap when you 
drag a painting tool. Turn off Spacing 

to make the brush velocity-sensitive, 
so it skips pixels when dragged fast. 

Roundness. Enter 1 to 100. To cre-
ate a circle, enter 100.

Angle. Enter a number to rotate the 
brush shape.

A Drag to change Roundness.
B Drag to change the Angle.
C Preview of the brush shape.

Select image areas to make 
brushes. This image contains 
rendered vector objects.
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brushes with other Canvas users. The file format that Canvas uses 
to save brushes on disk is also compatible with the file format used 
by the Photoshop image-editing program for saving brushes.

1 In the Brushes palette, add or remove brushes until you have 
the collection you want to save.

2 Choose Save Brushes in the menu. 

3 In the directory dialog box, type a name for the brushes file, 
select a location, and click Save (Mac) or OK (Windows).

To load or append brushes from a file
When you load brushes, you can replace the current set of brushes 
with the file or append the brushes to the current palette.

1 Choose one of the following commands in the menu:

• To replace the current brushes with the file: Choose Load 
Brushes.

• To add the brushes in the file to the current palette: Choose 
Append Brushes.

2 In the directory dialog box, locate the brushes file you want 
to open and click Open (Mac) or OK (Windows).

Selecting colors for painting
Painting tools use the foreground or background color, or both. 
Instead of a pen ink icon for the foreground, a brush icon appears 
when you select a painting tool. The top icon shows the foreground 
color, and the bucket icon shows the background color.

You can use any solid color for painting, including multicolored 
inks, such as gradients, symbols, textures, pattern, or hatch inks. 

Also, if you choose a spot color and edit pixels with a painting tool, 
Canvas converts the spot color to the image color mode; i.e., RGB, 
CMYK, etc. (see “Image modes for Canvas paint objects” on 
page 23.28). 

• To swap the foreground and background colors: Press the “X” 
key while using a painting tool. 

• To set the foreground color to black and background color to 
white: Press the “C” key.

The palette icons when a painting 
tool is selected

Tip
You can arrange paint objects in a 
document with vector and text 
objects that use spot colors, but 
only the vector and text objects 
will produce spot color separa-
tions.
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To select a color for painting
1 Press the foreground or background color icon in the Tool-
box to open the Presets palette with the Inks tab selected. 

2 Click on an ink type and select a cell. If you tear the Presets 
palette away from the Toolbox, it becomes a floating palette you 
can keep open as you work. 

Note: You can also create new colors by using the various Inks man-
agers located in the Attributes palette (see “Creating color inks” on 
page 15.5).

Painting modes
Use various painting modes when you paint and edit images. Paint-
ing modes can create special effects and let you control color mix-
ing and the tonal range affected by painting. 

The Mode menu is in the Properties bar and Brushes palette when 
you use the following tools: Marker, Paintbrush, Airbrush, Bucket, 
Blend, Blur, Sharpen, and Rubber Stamp. Painting modes that are 
available for most painting tools are listed here.

To choose a painting mode
1 Select a painting tool.

2 Open the Mode menu. Not all modes are available for all 
painting tools.

Normal The default painting mode applies color to all pixels uni-
formly. When the painting opacity is 100%, the applied color 
replaces the original color. If you paint in a Black & White or 
Indexed image, Normal mode is labeled Threshold.

Picking colors with the Color 
Dropper tool

Use the Color Dropper tool to pick up 
color from an image or object. The 
color you select becomes the current 
background or foreground color that 
you can use for painting and drawing  
(see “Using the Color Dropper,” 
page 15.24).

While in image edit mode, select the 
Color Dropper by pressing Option 
(Mac) or Alt (Windows); however, you 
won’t be able to pick the background 
color.

To select the background color

1 Select the Color Dropper tool.

2 Click a color in an object or image.

To select the foreground color

1 Select the Color Dropper tool.

2 Option-click (Mac) or right-click 
(Windows) a color in an object or im-
age. 
.18 PAINTING & IMAGE-EDITING



Dissolve This mode applies color with a random diffused pattern 
within the brush shape. The effect is similar to drawing with chalk. 
The diffused effect is stronger when the painting opacity is less than 
100%.

Multiply Darkens all pixels by multiplying the value of the applied 
color and the underlying color. Painting with darker colors intensi-
fies the effect. Painting with black results in black; painting with 
white does not affect the original color. When you apply a color 
with multiple strokes in the same area, the strokes become darker, 
similar to the effect of making multiple strokes on paper with an 
ink marker.

Screen The Screen mode is the opposite of Multiply mode. 
Screen mode lightens all pixels by multiplying the inverse values of 
the applied color and the underlying color. Painting with lighter 
colors intensifies the effect. Painting with black does not affect the 
original image; painting with white results in white. 

Overlay Applies color without destroying the underlying shadows 
and highlights. Overlay mode blends the applied color with the 
underlying color; the amount of blending depends on the lightness 
of the underlying color.

Soft Light Lightens or darkens underlying colors depending on 
the lightness value of the applied color. If the lightness of the 
applied color is less than 50% gray, painting lightens the image. If 
the lightness of the applied color is greater than 50% gray, painting 
darkens the image. Painting with white or black has the most 
intense effect, but does not completely replace the underlying color. 

Hard Light Paints in Multiply or Screen mode, depending on the 
applied color’s lightness value. This mode is similar to Soft Light. 
However, painting with black produces black; painting with white 
produces white.

Darken Compares the underlying color and the applied color, 
and the result is whichever color is darker. In other words, pixels in 
the image will be painted if the paint color is darker, while pixels 
that are darker than the paint color will remain unpainted. 

Lighten The Lighten mode is the opposite of Darken mode. 
Lighten compares the underlying color and the applied color, and 
the result is whichever color is lighter. In other words, pixels in the 
image will be painted if the paint color is lighter; pixels that are 
lighter than the paint color will remain unpainted.

Dissolve mode
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Difference Compares the brightness of the original and applied 
colors, subtracts the brightness value of the darker pixel from the 
lighter one, and applies that value to the original image.

Hue Applies the hue of the paint color without changing the 
brightness and saturation of the underlying image. 

Saturation Changes the saturation of the area painted to match 
the saturation of the applied color, without changing the hue or 
luminance values. Applying gray does not affect the original image.

Color Changes the hue and saturation of the painted area to the 
hue and saturation of the applied color, without affecting the 
shadow, highlights, or midtones of the original image.

Luminosity Changes the lightness of the underlying color to the 
lightness of the applied color, without affecting the hue or satura-
tion of the image.

Painting context menu
When working with a painting tool, use the context menu to gain 
quick access to common commands. The commands that are avail-
able vary, depending on the selected painting tool and whether 
there is a selection in the image.

To access the context menu
1 Select a paint object.

2 Right-click (Windows) or Control-click (Mac) the selected 
paint object.

3 Choose a command when the menu opens. Canvas applies 
the command and hides the menu.

Context menu options
The following commands are available in the painting context 
menu:

Command Use

Next Brush Selects the brush shape in the Brushes palette to the right of 
the current brush.

Previous Brush Selects the brush shape in the Brushes palette to the left of 
the current brush.

First Brush Selects the brush at the upper-left of the palette.

Tip
The context menu contains some 
common commands that are avail-
able from the Menu bar.
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Pointer display
The default pointer for painting is a symbol of the selected painting 
tool. Change the pointer to a crosshair or the current brush size. All 
painting tools use the pointer you select, not just the current paint-
ing tool. To change the pointer, choose an option in the context 
menu.

Fat Bits
When you choose Show Fat Bits, the resolution and magnification 
affect the display. Fat Bits are visible when the magnification-to-res-
olution ratio is about eight to one; e.g., if the image resolution is 
72 ppi, fat bits appear at 600% magnification and higher. If the 
image resolution is 144 ppi, fat bits appear at 1,200% magnification.

• To show fat bits: Press the Plus key or choose Show Fat Bits in 
the context menu to display pixels as individual tiles in a grid.

• To hide fat bits: Press the Plus key or choose Hide Fat Bits in 
the context menu to display pixels without the grid of individual 
tiles.

Adding visibility masks to images
If a paint object has a visibility mask, you can erase to a clear back-
ground. Also, Canvas can protect transparent areas when you paint 
or edit in the image.

Last Brush Selects the brush at the lower-right of the palette.

Standard Pointer Displays the icon of the selected painting tool, which is the 
default pointer (see “Pointer display” on page 23.21). 

Precise Pointer Changes the pointer to a crosshair. The intersection of the 
crosshair is the center of the current brush (see “Pointer dis-
play” on page 23.21).

Brush Size Pointer Changes the pointer to an outline of the current brush (see 
“Pointer display” on page 23.21).

Show/Hide Fat Bits Displays/hides pixels as individual tiles in a grid at high mag-
nifications (see “Fat Bits” on page 23.21).

Show/Hide Trans-
parency Preview

Command Use

Tip
Changing the pointer using the 
context menu is the same as 
changing the pointer in the Paint-
ing manager located in the Config-
uration Center.
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You can add a visibility mask to a paint object that was created with 
an opaque background in Canvas or imported from another appli-
cation. 

Paint objects can look the same whether they have visibility masks 
or not. However, a visibility mask changes the way that the Eraser 
tool works and the effect of deleting or moving a selection (see 
“Painting in the background color with the Eraser tool,” page 23.8).

In a paint object that has a visibility mask, you can erase or delete 
pixels to reveal a clear background; e.g., you can erase at the edge 
of an image to create faded or torn edges. You can delete or move 
selections to create transparent areas. 

If a paint object does not have a visibility mask, areas where you 
drag the Eraser tool and selections you delete or move, become 
filled with the current background color and are opaque, not trans-
parent.

When you create paint objects with painting tools or the Render or 
Create commands, you can select an option to include visibility 
masks.

To add a visibility mask

1 Select a paint object that does not have a visibility mask. 

2 Choose Image > Add Visibility Mask. This command is not 
available if a Duotone, Indexed, or Multichannel image is 
selected.

Adding a visibility mask does not change the appearance of a paint 
object; e.g., white pixels do not become transparent. When a paint 
object has a visibility mask, you can select Preserve Visibility in the 
Channels palette. When this option is selected, Canvas protects 
clear areas from the effects of painting and image editing.

Adding a Quick Mask to objects
Using the Quick Mask feature allows you to easily create a visibility 
mask that can be applied to any selected object, or group of objects.

To add a Quick Mask
1 Select an object(s) and then click on the rectangle, oval, or 
round-rectangle drawing tool in the Toolbox 

White areas of the fish image 
erased to a clear background

Group of objects that have a 
visibility mask applied to them 
using the Quick mask feature.
.22 PAINTING & IMAGE-EDITING



2 Hold down the “ Q” key and drag the mouse over the 
selected object(s). Make certain that this new object is created 
somewhere on top of the selected object.

3 Release the mouse and the selected object(s) will automati-
cally be masked.

Rendering objects and images
Rendering converts objects into paint objects; e.g., you can use the 
Render command to create a paint object from text, and then use 
the Airbrush tool to paint highlights on the image of the text.

You can create paint objects by rendering selected vector objects, 
text objects, and group objects. You can render a paint object to cre-
ate a new paint object that has different characteristics than the 
original.

When you use the Render command, you can create a transparency 
mask or visibility mask for the resulting paint object. 

When you render a vector object, it’s a good idea to select a visibil-
ity mask if you want to isolate an object against a clear background.

A rectangle and text 
are blocked by an 
opaque paint object 
in front

A transparent 
background lets 
objects show 
through it

Paint object backgrounds

You can create a paint object in which the image 
“background” is transparent or opaque. 

An opaque paint object contains opaque pixels. If the 
pixels are white and the paint object is on a white 
background, you won’t notice that the image is 
opaque. Still, the rectangular paint object will block 
objects behind it (A).

A transparent paint object can have a clear back-
ground that does not block other objects (B).

Painting in an opaque image is like painting on a wall. 
Painting in a transparent image is like painting on a 
window. 

Tip
Rendering is also referred to as 
“rasterizing” because the process 
produces a raster image -- an 
image composed of pixels 
arranged in a grid. All paint objects 
in Canvas contain raster, or pixel-
based, images.
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To render objects
1 Select one or more objects and choose Image > Area > Ren-
der. If you select multiple objects, they will be rendered as one 
paint object. 

The Render Image dialog box lets you specify resolution and 
other settings for the resulting paint object.

2 Click OK to render the selection.

Canvas creates a paint object containing an image of the original 
objects. The paint object appears in front. The Render command 
does not change the original selected objects. 

• To see the original objects: Drag the paint object away.

Pasting into images
You can render objects by copying them to the Clipboard and then 
pasting them into paint objects in edit mode. When an image is in 
edit mode and you paste into it, the Clipboard content is rendered 
and appears as a selection in the image.

If you select the “Anti-aliased Clipboard” option in the Configura-
tion Center, Canvas anti-aliases vector and text objects that you 
paste into paint objects (see “Anti-aliased Clipboard,” page 13.8). 

Rendering exported files 
If necessary, Canvas renders selected objects or an entire document 
when you use the Save As command to export to a raster file for-
mat; e.g., if you select vector objects, and then save in GIF format, 
Canvas renders the selected objects because GIF files store raster 
images. 

When Canvas is saving a file, some options might not be available 
in the Render Image dialog box because the file format doesn’t sup-
port them.

Tip
Anti-aliasing blurs edges while 
rendering to make the edges of 
text characters and vector objects 
appear smoother in the resulting 
image.
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Rendering with the Camera tool
You can use the Camera tool to create a paint object from any area 
in a document. The Camera tool renders the area you select. You 
can set the resolution, color mode, and other options for the ren-
dered image. 

Using the Camera tool is like taking a snapshot of the screen. You 
simply use the Camera tool to select a rectangular area for render-
ing. You can include all types of objects and parts of objects in the 
rendering, without selecting the objects first.

Render Image settings

Specify image mode, resolution, and 
other settings in the Render Image dia-
log box.

Dimensions. Displays the width and 
height of the paint object Canvas will 
create.

A Choose the measurement for the 
Width and Height values in the Dimen-
sion area; inches, centimeters (cm), 
points, or picas.

Mode. Choose the color mode for the 
resulting image: Black & White, Gray-
scale, Indexed Color, RGB Color, 
CMYK Color, or LAB Color.

Width and Height. Enter the pixel 
dimensions for the paint object. When 
you change a value, Canvas adjusts the 
others to maintain the size and propor-
tions of the original objects. 

Res. Choose pixels per inch or pixels 
per centimeter in the pop-up menu. 
The value shown after “Size” is the 
amount of data in the image, based on 

the mode, resolution, and dimen-
sions.

Anti-Alias. Blurs edges while render-
ing to make the edges of text charac-
ters and vector objects appear 
smoother in the resulting image. 
Choose Fine, Medium, or Coarse in 
the pop-up menu.

Coarse uses 16 shades for anti-alias-
ing and is the fastest option. Medium 
uses 64 shades for anti-aliasing. Fine 
uses 256 shades for anti-aliasing. Fine 
produces the softest edges and is the 
slowest option.

Mask. Select this option if you want 
the resulting paint object to have a visi-
bility mask or a channel mask. Then 
choose the type of mask.

Transparency creates a channel mask. 
The channel mask is based on the sil-
houette of the rendered objects. In oth-
er words, if there are spaces between 
the objects, the channel mask will cre-
ate transparent spaces.

Visibility creates a visibility mask in the 
paint object. The result is a clear back-
ground in areas not covered by objects. 

If you do not select Mask, areas not 
filled by rendered objects within the 
paint object’s bounding rectangle will 
be white and opaque. If you select 
Mask and either Transparency or Visi-
bility, areas that are not filled by ren-
dered objects will be transparent.
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The Camera tool is useful whenever you need to convert objects to 
an image, such as for creating Web graphics. The Camera tool 
functions like the Image > Area > Render command. The Camera 
tool lets you control the exact area to be rendered, while the Render 
command renders a rectangular area that includes all selected 
objects.

To render with the Camera tool
1 Select the Camera tool.

2 Drag to draw a rectangle around the area you want to render. 
You can view the dimensions and coordinates of the rectangle in 
the Status bar.

3 A bounding box with handles appears around the area you 
selected. Adjust the box to select exactly the area you want to ren-
der.

• Drag a handle to change the size and shape of the area to 
be rendered.

• Drag the border of the box to reposition the box.

4 When the box encloses the area you want to render, click 
inside it.

5 The Render Image dialog box appears. Select the options you 
want to use, and then click OK to render the selected area.

After you click OK in the Render Image dialog box, a paint object 
containing the rendered image will appear in front of the area you 
selected.

Using vector and text tools in paint objects
After placing a paint object in edit mode, use vector tools and the 
Text tool to add shapes and type to an image. 

When you draw or type text within a paint object in edit mode, 
Canvas rasterizes the objects according to the image mode and res-
olution of the paint object, and makes a floating selection in the 
image. 

When you type within a paint object in edit mode, you can modify 
the font, size, and style of the type before Canvas rasterizes it (see 
“To set type within images” on page 23.27).
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To set anti-aliasing for objects placed in images
You can set a preference so Canvas softens the edges of objects you 
draw in an image or paste into an image from the Clipboard (see 
“Painting” on page 13.7). 

1 Choose Canvas > Configuration Center (Mac) or File > Con-
figuration Center (Windows) and select the Painting manager in 
the General settings.

2 Set the preferences you want to apply to objects placed in 
images and click OK.

• To soften selections pasted from the Clipboard: Select “Anti-
Aliased Clipboard.” 

• To soften objects or type created in paint objects in edit mode:

Select “Anti-Aliased Canvas Objects.”

To draw objects within images 
Use any of the drawing tools in a paint object in edit mode to 
“paint” shapes. When you finish drawing the shape, Canvas raster-
izes it, based on its shape and colors.

1 Place the paint object in edit mode, if necessary, and select a 
drawing tool.

2 Select ink and stroke settings (see “Inks: colors & patterns” on 
page 15.1 and “Strokes: outline effects” on page 16.1).

3 Draw in the paint object with the selected tool (see “Drawing 
basics” on page 18.1). The object you draw becomes a floating 
selection and you can change its opacity, set the mode, or apply 
filters (see “Changing the opacity of floating selections” on 
page 26.12 and “Image filters & effects” on page 27.1).

4 Press Esc twice when you finish editing the selection to make 
the selection part of the image. 

5 Press Esc once more to exit edit mode and select the image.

To set type within images
Type text in a paint object in edit mode and then modify the 
attributes before Canvas converts the type to a floating selection.

1 Place the paint object in edit mode, if necessary, and select 
the Text tool.

Tip
Use the Text menu, Type palette, 
or Properties bar to set typograph-
ic attributes.
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2 Click the I-beam pointer in the image and type the text, 
which appears in a white box.

3 Press Esc to make the text a floating selection. You can 
change the opacity, set the mode, and apply filters to the selection 
(see “Changing the opacity of floating selections” on page 26.12 
and “Image filters & effects” on page 27.1).

4 Press Esc twice to make the type selection part of the image.

5 Press Esc again to exit edit mode and select the image.

Image modes for Canvas paint objects
In Canvas, image modes define the color model and number of col-
ors that can be used in images. When you create a new paint object 
in Canvas, you select an image mode: Black & White, Grayscale, 
RGB Color, CMYK Color, or LAB Color. When you select a paint 
object, Canvas displays the image mode in the Properties bar. 

How image modes affect image filters
Filters produce different results depending on the image mode. 
When you paint, the opacity setting of a brush acts differently on 
images in different modes. For the most predictable results with fil-
ters and paint tools, use RGB color mode.

How Canvas assigns image modes
When you import an image from another source either by opening, 
placing, or pasting an image file, Canvas assigns an image mode 
based on the number of colors and the color model used in the 
image. 

Tip
The image mode also appears in 
the Status bar if Object Details has 
been selected to appear in an 
information field.

Posterizing a LAB image 
introduces color to light areas.

RGB image 
posterized 4 levels

Original LAB image 
posterized 4 levels
.28 PAINTING & IMAGE-EDITING



The following table shows the image modes that Canvas assigns 
when you import images in some common image formats.

Changing image modes
You might want to change modes so you can use certain features, 
or reduce memory requirements; e.g., you might want to convert an 
Indexed image to RGB to apply image filters. You might want to 
convert an RGB image to Grayscale mode to save memory when a 
document is printed without color.

To change image modes
1 Select one or more paint objects. 

2 Select the image mode from the Image Mode menu in the 
Properties bar.

Some modes are available only if the object’s current mode is com-
patible; e.g., Black & White mode and Duotone mode are available 
only when Grayscale paint objects are selected.

If the mode you choose does not support an image’s full color 
range, a message asks you to confirm the change. Click OK to pro-
ceed.

If you choose Duotone mode or Indexed mode, select options in a 
dialog box and then click OK to complete the conversion (see 
“Duotone image mode” on page 23.37 and “Indexed image mode” 
on page 23.31).

Imported format Assigned image mode

TIFF RGB Color, CMYK Color, or Grayscale

BMP 256-color image: Indexed
24-bit image: RGB Color

MacPaint Black & White

Photoshop Same as original image mode

Tip
You can access the Image Mode 
menu on the Properties bar or by 
choosing Image > Mode.
Image modes for Canvas paint objects 23.29



23
Black & White image mode
Black & White image mode is used for scanned line art and black-
and-white (“bitmap”) images, which contain only black and white 
pixels. Images in Black & White mode require the least amount of 
memory and disk space.

To convert to Black & White mode
Grayscale mode images and Multichannel mode images are the 
only images you can directly convert to Black & White mode. If an 
image is not Grayscale, convert it to Grayscale mode first if you 
want to convert it to Black & White mode. 

1 Select the paint objects and use the Image Mode menu on the 
Properties bar or choose Image > Mode > Black & White. The 
Select Halftone Method dialog box lets you choose a conversion 
option.

2 Select Pattern Dither, Diffusion Dither, or Threshold, and 
then click OK.

• If you choose Pattern Dither or Diffusion Dither, Canvas 
“screens” the image, rendering its tones as patterns of tiny 
dots. Pattern Dither screens an image using a fixed pattern 
similar to a traditional halftone screen. Diffusion Dither 
screens an image using a process that creates a random 
pattern effect.

• If you choose Threshold, Canvas converts the image to a 
high-contrast, black-and-white image. Pixels of lightness 
values from 0 to 128 become black, and pixels of lightness 
values from 129 to 255 become white.

When you paste a selection into a Black & White image, Canvas 
uses diffusion dither on the selection.

Grayscale image mode
Grayscale mode is appropriate for images scanned from black & 
white photographs or when the image will never be printed in color. 
In Grayscale mode, pixels use 256 brightness levels to represent a 
range of shades from pure black to pure white. Grayscale uses 8 bits 
per pixel and requires less memory than most color modes.

If you convert a color image to Grayscale mode, Canvas discards all 
color information.
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Indexed image mode
Indexed color mode uses a palette of 256 colors for images. Since 
this mode stores fewer colors, it requires significantly less memory 
than RGB and CMYK color modes, both of which support millions 
of colors. Smaller memory requirements make Indexed mode espe-
cially useful for images used on Web pages. 

An Indexed image includes a color table, or palette, of colors used 
in the image. When you convert an existing image to Indexed 
mode, you can specify the number of colors from the image to 
include in the color table.

Most image filters, effects, and opacity controls aren’t available to 
be applied to Indexed images, except the Offset and De-Interlace 
filters, as well as some third-party plug-in filters.

To convert an existing image to Indexed mode
1 Select the paint objects and choose Indexed from the Image 
Mode menu. The Indexed Color dialog box appears. 

2 Choose an option in the Indexed Color dialog box for the 
color table:

3 Depending on which method you select, the Colors area in 
the dialog box displays information about how the color table is 
computed. Choose the option you want, if necessary:

Exact Creates a color table from the colors in the image, if the image con-
tains 256 colors or less; otherwise, this option isn’t available

Uniform/
System

Creates a color table based on the operating system’s palette of 256 
colors (System), or a subset of these colors (Uniform)

Adaptive Creates a color table from the most frequently used colors in the 
image

Custom Lets you create a color table, load, and save color table files.

Previous Applies the last color table used in the Indexed Color dialog box dur-
ing the current Canvas session

Exact If you choose Exact, the Colors area displays the number of colors in 
the selected image

Uniform/ 
System

If you choose System, the Colors area displays the number of colors 
in the operating system’s palette; if you choose Uniform, a pop-up 
menu that lets you select 8, 27, 64, 125, 216, or 256 colors appears
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4 Choose a color-distribution option in the Dither area:

5 Click OK after choosing the settings you want. 

Note: If you select the Custom option, the Color Table dialog box 
appears (see “To create a custom color table for Indexed images,” 
page 23.32).

To create a custom color table for Indexed images
1 Select “Custom” in the Indexed Color dialog box (see 
“Indexed image mode,” page 23.31). 

2 Click OK in the dialog box and Canvas opens the Color Table 
dialog box.

In the Color Table dialog box, you can edit individual colors in the 
palette, create a blend of colors, and select from several preset color 
palettes, including System and Grayscale palettes. In addition, pal-
ettes can be saved or loaded.

Adaptive If you choose Adaptive, the Colors area displays a text box that lets 
you enter a number of colors from 2 to 256

Custom If you choose Custom, the Colors area displays “Custom colors”

Previous If you choose Previous, the Colors area displays the number of colors 
in the last color table created by the Indexed Color dialog box during 
the current Canvas session

None Changes colors to their closest equivalent in the selected color table 
without dithering

Pattern Approximates colors not in the palette by arranging palette color in 
geometric patterns (available for Uniform/System method only)

Diffusion Approximates non-palette colors by randomly dithering available 
colors; creates the most natural effect

Exact If you choose Exact, the Colors area displays the number of colors in 
the selected image

Tip
If the image is already Indexed, 
choose Image > Mode > Color 
Table to open the Color Table dia-
log box. 
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In the Color Table dialog box, a grid of 256 color swatches appears; 
each swatch represents one color in the palette. By default, the Cus-
tom option appears in the Table menu, and the color swatches 
show the last palette used in the dialog box.

The Table menu lets you choose among preset color tables:

You can also create a custom color table (see “To customize indi-
vidual colors” on page 23.34 and “To customize a color table by 
blending colors” on page 23.35).

This color table contains

Black Body a range of sunset-like colors.

Grayscale a ramp from pure black to pure white.

Macintosh System the palette of colors supported by the Mac OS.

Spectrum a set of rainbow colors.

Web Browser a set of 216 colors that can be displayed without dithering 
by nearly all Web browsers operating on Mac OS or Win-
dows. This option is also referred to as a “browser safe” 
palette.

Windows System the palette of colors supported by Windows.

Table menu
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Saving and loading color tables
By using the Load and Save options in the Color Table dialog box, 
you can save color tables to your hard disk or load a saved color 
table file into the Color Table dialog box.

To load a custom color table
1 Click Load in the Color Table dialog box. A Load Settings 
dialog box appears.

2 Locate the color table file you want to load, and then click 
Open. Canvas replaces the current palette in the Color Table dia-
log box with the new palette, and its name appears in the Table 
menu.

To save a custom color table
1 Click Save in the Color Table dialog box. A directory dialog 
box appears (Mac), or a Save Settings dialog box appears (Win-
dows).

2 Enter a name for the table in the Save color table in field 
(Mac) or the File name field (Windows). Before you type the file 
name, Canvas adds the extension .ACT in the field. Keep this 
extension when naming the file.

3 Specify a location on your hard disk to save the color table, 
and then click Save. Canvas saves the color table.

To customize individual colors
After choosing a color table, you can customize individual colors in 
it using a color picker dialog box.

1 Click a color swatch to open a color picker dialog box.

Tip
Save your custom color tables in a 
central location on the corporate 
network and share them with co-
workers. 

Color selector area

Click to choose a color

Color Picker (Mac OS)
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2 In the color picker, select a color to replace the selected 
swatch in the palette, and then click OK.

To customize a color table by blending colors
Canvas lets you create blends of selected swatches in the color 
table. When you do this, the first and last swatches you select don’t 
affect the final blend in the color table. How the blend appears in 
the color table is determined by the two colors you choose in the 
Color Picker in step 2 of this procedure.

1 Drag across multiple color swatches to select them (the more 
you select, the more gradual the blend will be). Selected color 
swatches appear highlighted with a black border, and then the 
color picker dialog box opens.

2 In the color picker, choose the first color, and then click OK. 
The color picker remains open; choose the second color, and then 
click OK. Canvas fills the selected color swatches in the Color 
Table dialog box with a ramp of the two colors.

Original Grayscale palette

Drag to select color swatches to replace with a blend

Color picker (Windows)

Luminosity 
controlClick to select the 

current color

Color selector
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RGB color image mode
RGB color mode is used most often when working with high-qual-
ity full-color images, such as those from color scanners and digi-
tized photographs stored on CD-ROM.

RGB color mode is the most reliable mode to use for images you 
want to modify with painting tools and filters. However, the full 
range of RGB colors exceeds the range that commercial printing 
can reproduce, so you should be aware of the limitations of the 
printing method that will be used. Also, an RGB color image is 
device dependent, which means that the same RGB values can look 
different when displayed on different monitors.

In RGB color mode, each pixel has a red, green, and blue compo-
nent. Each component, referred to as a color channel, has 256 
intensity levels. The combination of the intensity value in each 
channel creates each pixel’s color.

CMYK Color image mode
CMYK color mode is based on the four color inks used in commer-
cial printing (and by some desktop printers): cyan, magenta, yellow, 
and black. Some color scanners can produce CMYK images. 

In a CMYK color image, each pixel has a cyan, magenta, yellow, 
and black component. Each of these color channels has 256 inten-
sity levels. The combination of the intensity value in each channel 
creates each pixel’s color. Because monitors are RGB devices, they 
can’t display CMYK colors directly. However, Canvas attempts to 
display CMYK images as they will appear when printed. 

LAB color image mode
The Commission Internationale d’Eclairage (CIE) developed the 
LAB color mode as an international color standard to overcome the 
device dependency of the RGB and CMYK modes. In a LAB color 
mode image in Canvas, each pixel has one lightness and two color 
components. The Lightness (L) channel has 256 levels of intensity. 
The two color channels, labeled A and B, provide a color range 
from red to green and yellow to blue, respectively. 

Some companies sell collections of images in LAB color mode. 
Editing LAB color mode images with some filters or painting tools 
can have interesting and unpredictable effects. 

Tip
Remember that RGB is used for 
images on the Web and CMYK is 
used for print.
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Duotone image mode
In traditional graphics arts reproduction, a “duotone” is a grayscale 
image printed with black and an additional color. Canvas lets you 
create duotone images, as well as “monotone,” “tritone,” and 
“quadtone” images (printed with one, three, or four colors, respec-
tively).

Printing images as duotones can add interest and increase the tonal 
range reproduced from grayscale photographs, without the addi-
tional expense of printing full-color images. The duotone effect can 
be subtle or striking, depending on the color used and the amount 
added to the image. In any case, the additional colors are used to 
reproduce the gray values in the image, rather than to reproduce 
specific colors.

To create a monotone, duotone, tritone, or quadtone in Canvas, 
you must convert a Grayscale image to Duotone mode. Unlike 
other image modes, once an image is converted to Duotone mode, 
you cannot work with individual image channels. Instead, you can 
adjust curves for each color “channel” in the Duotone Options dia-
log box.

To create a Duotone image
1 Select paint object and choose Grayscale from the Image 
Mode menu to convert to Grayscale mode.

2 Click OK when Canvas prompts to discard color informa-
tion. Then, choose Duotone from the Image Mode menu.

3 Choose Monotone, Duotone, Tritone, or Quadtone from the 
Type menu in the Duotone Options dialog box. Depending on 
the Type setting, the Ink 1, Ink 2, Ink 3, and Ink 4 Curve boxes, 
color menus, and text boxes become available.

4 Choose ink colors by pressing the color palette icons and 
selecting colors in the palettes. Note: You must have already added 
the desired colors to the Presets palette for them to be available in 
the pop-up palette.

• For a monotone image, choose a single color in the Ink 1 
area. For a traditional duotone, leave “Process Black” as 
Ink 1, and choose a second color in the Ink 2 area. For tri-
tones and quadtones, choose additional colors for Ink 3 
and Ink 4.

• Canvas puts the name of the selected ink in the text box. 

Tip
The term “Duotone” refers to the 
Duotone image mode, not just to 
images printed with two inks. In 
Duotone mode, an image can be 
printed as a monotone, duotone, 
tritone, or quadtone.

Tip
You can also select image modes 
by choosing Image > Mode. 

Tip
If you plan to export a duotone 
image to another graphics or page 
layout program, be sure the color 
names exactly match the color 
names in the other application. 
Otherwise, you might produce 
more color separations than nec-
essary.
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• To use process colors: Type the appropriate name (“Process 
Cyan,” “Process Black,” “Process Magenta,” or “Process Yellow,”) 
so colors appear on the correct plates. If you leave the text box 
blank, Canvas prompts you to enter a name for the ink.

• Specify ink colors in descending order of lightness value; 
i.e., darker color inks should appear at the top, and lighter 
color inks should appear at the bottom of the dialog box.

• Assign only solid spot colors or individual process colors 
for duotones. If you assign a color ink made from CMYK 
components, Canvas treats it like a spot color and prints 
only one plate for the color when you output color separa-
tions.

5 If necessary, click the curve boxes to adjust curves for each 
ink color. In the Duotone Curves dialog box, drag the curve to 
adjust it, or enter values in the text boxes to map input values to 
the desired output values, and then click OK.

6 Click OK to apply the Duotone Options dialog box settings.

Duotone Options

You can select and change the follow-
ing ink settings for images in Duotone 
mode.

Type. Choose Monotone, Duotone, 
Tritone, or Quadtone.

A Inks. Click the palette icons and se-
lect colors in the palettes for each ink. 
Type process and spot color names in 
the text boxes.

Overprint Colors. Click to adjust the 
screen display of the Duotone inks. 
Because the appearance of spot-color 
combinations can’t be predicted within 
Canvas, you can do this if you have an 
accurate printed reference for the col-
ors you select. Overprint Colors set-
tings do not affect color separations, 
but will change the appearance of color 

composites printed on desktop color 
printers. In the Overprint Colors dialog 
box, click the color squares to open a 
color selector dialog box. Choose the 

color you want to represent the ink 
combination on screen and then click 
OK.
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To adjust duotone images
After you convert an image to Duotone mode, reopen the Duotone 
Options dialog box to adjust the color curves, change ink colors, as 
well as use the Load and Save options.

To change duotone options
1 Select the paint object you want to adjust and choose Image > 
Mode > Duotone Inks. 

2 Adjust the settings in the Duotone Options dialog box and 
click OK to implement the new settings.

To load and save duotone information
Use the Load and Save buttons in the Duotone Options dialog box 
to work with files of duotone options information. Canvas uses a 
file format compatible with the duotone options files used by the 
Photoshop image-editing program, so you can load files saved from 
Photoshop, and files saved by Canvas can be loaded into Photo-
shop.

• Click Save to save the duotone options settings. In the 
directory dialog box, type a file name and click OK or 
Save.

• Click Load to use settings from a saved duotone options 
file. In the directory dialog box, select a duotone options 
file and click Open. Canvas will apply the ink and curve 
settings saved in the file to the Duotone Options dialog 
box.

Multichannel image mode
Multichannel image mode lets you work with multiple channels of 
grayscale information for a grayscale image. In multichannel mode, 
each channel contains lightness values as in other image modes, but 
the values do not relate to color components. 

When you convert an image to Multichannel mode, the image data 
does not change; e.g., if you convert an RGB Color mode image to 
Multichannel mode, the Red, Green, and Blue channels retain the 
same pixel information, but the channels no longer represent color 
pixels. The channels in Multichannel mode are labeled numerically 
(#1, #2, and so on) in the Channels palette.

The Multichannel mode is not available if you select a paint object 
containing an image in Black & White image mode.
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Removing red eye
Canvas includes an image editing tool that you can use to correct 
red eye in digital images.

What is red eye?
Red eye is a photographic phenomenon caused by light reflecting 
off the interior surface of the eye, which produces a red glare within 
the eye.

To use the Red Eye Reduction tool with Automatic Selection 
method
With the Automatic Selection method, you can correct the red eye 
effect in two ways:

• Click the cursor within the red area of the eye.

• Click-drag the cursor to form a rectangle over the eye area.

1 Place the image into paint edit mode.

2 Magnify the eye area that needs to be retouched, if necessary.

3 Select the Red Eye Reduction tool.

4 Select the Automatic Selection radio button in the Properties 
bar.

5 Choose an intensity, feather radius, mode, and eye color.

6 Correct the red eye effect by clicking the red area or forming 
a rectangle as previously described.

Red Eye Reduction tool

Select the Red Eye Reduction tool and 
the tool options appear on the Proper-
ties bar.

A Method. Select a either the Auto-
matic or Manual Selection method.
B Intensity. Drag the slider or enter a 
percentage to set the intensity.
C Mode. Select either Darken, Hue, 
or Color. 

Darken. Compares the underlying col-
or and the applied eye color, and the 
result is whichever color is darker.

Hue. Applies the hue of the eye color 
without changing the brightness and 
saturation.

Color. Changes the hue and saturation 
of the painted area to the hue and sat-

uration of the applied color, without 
affecting the shadow, highlights, or 
midtones of the original image.

D Feather Radius. Enter a value to 
blend the edge of the adjusted eye.
E Eye Color. Select an eye color from 
this menu.
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To use the Red Eye Reduction tool with Manual Selection 
method
1 Place the image into paint edit mode.

2 Magnify the eye area that needs to be retouched, if necessary.

3 Select the Red Eye Reduction tool.

4 Select the Manual Selection radio button in the Properties 
bar.

5 Choose an intensity, feather radius, mode, and eye color.

Correct the red eye effect by forming an oval as previously 
described.

Original image Enhanced image

Automatic Selection

Click cursor on red eye area or 
draw a rectangle over area.

Manual Selection

Click-drag cursor to form 
an oval within red eye area.
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SCANNING, SIZING & TRACING IMAGES 

This chapter focuses on acquiring and sizing images. You will learn 
how to scan images into Canvas documents, change the image size 
and resolution, and auto-trace images to create vector objects from 
them. This chapter also describes some basics techniques to 
improve scanned images and photographs imported from Photo 
CDs.

Using scanners to acquire images 
You can scan images directly into Canvas documents using most 
types of desktop scanners. Canvas supports scanners that work with 
Photoshop-compatible plug-in acquire modules. It also lets you use 
scanning devices that are compatible with the TWAIN standard.

Using TWAIN-compatible scanners
Scanner manufacturers created the TWAIN interface to standard-
ize interaction between scanners and computer software. Scanners 
that comply with the TWAIN standard provide a “source man-
ager” file, which translates scanner information into data that Can-
vas can use. You must install the TWAIN scanner software on your 
system before you can select the scanner and scan images in Can-
vas.

If you aren’t sure whether a scanner is TWAIN-compatible, consult 
the scanner documentation or contact the manufacturer.

To select a TWAIN scanner
1 Choose Image > Acquire Plug-Ins> TWAIN Select Source. In 
the Select Source dialog box, a scrolling list contains the names of 
all TWAIN scanners for which Canvas can locate a data source.

2 Select the scanner you want to use and click OK. The Select 
Source dialog box closes and the scanner you selected becomes 
the active scanner. 

Tip
Mac users should refer to the Can-
vas “ReadMe” file for Macintosh 
availability.
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To acquire images using a TWAIN scanner
1 When you scan an image, it appears in the active Canvas doc-
ument. Open an existing document or choose File > New to create 
a new document.

2 Choose Image > Acquire Plug-Ins > TWAIN Acquire. A dia-
log box for the scanner you are using appears. Refer to the scan-
ner’s user manual for information on scanner options. 

3 Select the options you want in the scanner dialog box.

• Click Prescan to view a preview of the image. You can ver-
ify that the image is aligned and completely visible and 
reposition it if necessary.

• Depending on the available options, you can adjust scaling 
and brightness of the image.

4 Click Scan to begin scanning. When the scanner finishes, the 
scanned image appears in the active Canvas document. 

Using scanners with plug-in acquire modules
Canvas is a plug-in host program; i.e., you can use scanners that 
work with Photoshop-compatible plug-in acquire modules. You first 
should install the acquire module for your scanner so it is available 
to Canvas. Once Canvas recognizes an acquire module, its name 
appears in the Image > Acquire Plug-Ins submenu.

To locate the plug-ins folder for Canvas
Canvas looks for plug-ins, including acquire modules, in the Can-
vas Tools folder. To tell Canvas to look for plug-ins in another loca-
tion, use the Plug-ins button in the Painting manager in the 
Configuration Center. 

1 Choose Canvas > Configuration Center (Mac) or File > Con-
figuration Center (Windows).

2 Open the General settings and click the Painting option to 
view the Painting manager.

3 Click the Plug-ins button. 

4 Navigate to the folder where plug-ins are stored on your hard 
disk. Click the button labeled Select “folder name” (Mac), or 
select a plug-in module and click Open (Windows).

5 Click OK to close the Configuration Center.
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6 Re-start Canvas to activate the plug-in modules.

Acquiring multi-frame GIF files
When you acquire a GIF file with multiple frames, Canvas displays 
a dialog box so you can choose which frames to acquire. Enter a 
range in the text boxes, and then click OK. Canvas places the speci-
fied frames in the document.

To acquire images using plug-ins
1 When you scan an image in Canvas, the image appears in the 
active Canvas document. Either open the document you want to 
use or choose File > New to create a new document.

2 Choose Image > Acquire Plug-Ins and select a plug-in acquire 
module in the submenu. 

3 After selecting a device, a dialog box with options for your 
scanner appears. Refer to the scanner’s user manual for informa-
tion on these options and information on using the scanner; some 
common settings are described below.

4 Adjust the settings in the scanner dialog box and click Scan. 

Tip
If you do not see your scanning 
device in the menu, ensure the 
acquire module is in the correct 
folder; see “To locate the plug-ins 
folder for Canvas,” page 24.2.

Scanning options

Plug-in acquire modules for scanners 
offer various options. Some standard 
scanning options are described here.

Scan Mode or Color Mode. Choose 
color, black and white, or grayscale. 
These options correspond to the RGB 
Color, Grayscale, and Black & White 
image modes in Canvas. 

Resolution. Specify the scan resolu-
tion in pixels (or dots) per inch. Scan-
ning at higher resolution captures 
more image information and results in 
higher memory and disk storage 
requirements.

Scaling. Enter a scaling percentage to 
reduce or enlarge the image.

A Use the preview area to check the 
image and make sure the area you want 
to scan is positioned correctly. 
B Many scanners let you drag the 
corner of a scan rectangle to select the 
area that will be scanned. The selected 

area determines the size of the image 
object in Canvas.
C Most scanners offer brightness or 
exposure controls. Refer to the scanner 
documentation for more information on 
adjusting exposure settings. 
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Choosing a scanning resolution
Digital images are composed of square pixels, and pixel size is a 
major factor affecting image quality. The resolution of an image is 
expressed as the number of pixels per (linear) inch (ppi), or pixels 
per centimeter. Smaller pixels result in higher image resolution, 
which generally indicates better image quality. With scanned 
images, the resolution is also a measure of how much information 
has been captured from the original artwork.

At relatively low resolution, such as 75 ppi, lines, edges, and charac-
ter shapes in an image can appear jagged (see “About digital images 
and resolution” on page 24.5).

Use the following questions to help you decide an appropriate reso-
lution when you scan images.

Are you scanning line art or text? Line art, such as pen and ink 
drawings, and high-contrast images with sharp edges or type, 
should be scanned at the highest resolution possible. Text scans 
that will be processed with character-recognition software should 
also be scanned at high resolution for accurate translation.

What halftone screen frequency will be used for printing? For con-
tinuous-tone images (photographs), a common rule of thumb is to 
scan at a resolution of 1.5 or at most 2 times the screen frequency. 
For example, for offset printing on newsprint at a screen frequency 
of 85 lines per inch (lpi), an image should be scanned at 128 to 170 
ppi. For images printed at 133 lpi, scanning resolution should be 
200 to 266 ppi. 

Talk with service bureaus and commercial printers about the 
screen frequency used for your projects. With this information, you 
can let Canvas calculate the optimal resolution for an image (see 
“Resampling and sharpening images” on page 24.14).

Will the final image be smaller or larger than the original? If you 
need to enlarge the image, you should scan it at a higher resolution 
to retain the most information when you resize it. If you will reduce 
the size of the image, you can scan it at a lower resolution.

Tip
Because resizing tends to blur an 
image, you can use the Unsharp 
Mask filter to sharpen it. For more 
information, see “Sharpen filters” 
on page 25.21.
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Changing image size 
You can use several methods to resize or scale paint objects and the 
images they contain.

Keep in mind that altering the size or resolution of a paint object 
can degrade the quality of an image. Canvas uses interpolation to 
estimate pixel values when necessary, but this can result in loss of 
sharpness or detail when large scaling factors are applied.

The best way to avoid image degradation is to avoid changing 
image size or resolution.

• If an image is too big for a particular layout, consider crop-
ping the image, rather than resizing or scaling it to fit. 

• If a photographic image requires higher resolution, try re-
scanning the original at a higher resolution, rather than 
increasing the resolution in Canvas.

If you resize, skew, or rotate a paint object, you can restore the orig-
inal shape and resolution by choosing Effects > Remove Effects.

Stretching images with the mouse
You can change the size of a paint object by clicking on it with the 
Selection tool and dragging a selection handle. Stretching an image 
non-proportionately also stretches the pixels, which can cause 
unwanted distortion to the image. 

Scaling images using the Scale command
Change the size of a paint object by selecting it and choosing 
Object > Scale. The Scale command lets you maintain the object’s 
proportions or distort an image by scaling it in one direction. Using 

About digital images and 
resolution

Digital images, also known as raster and 
paint images, are composed of tiny 
square pixels. 

The number of pixels that fit in a linear 
inch or centimeter is the image resolu-
tion. The resolution indicates how much 
information is in the image, indepen-
dent of the resolution used to display 
the image on screen or to print it.

Low-resolution images have larger pix-
els and look more jagged than high-res-
olution images. However, while high-
resolution images look smoother, they 
also require more memory and disk 
space.

300 ppi

72 ppi

600 ppi

Vector

Tip
You can also remove effects via 
the Undos palette or by using the 
keyboard commands: Com-
mand+Z (Mac) or Ctrl+Z (Win-
dows).
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the Scale command does not add or remove pixels from an image. 
For information on using Scale, see “Scaling objects” on 
page 17.31.

Using the Crop command to change image size
Use the Crop command to adjust the overall size of an image.

• When you enlarge an image, Canvas adds white pixels. 

• When you reduce an image, Canvas crops out pixels and 
discards the image data.

To crop an image
1 Select a paint object (not in edit mode) and choose Image > 
Area > Crop. A dialog box displays the current size, width, and 
height.

2 Under New Size, enter the size you want the image to be. Use 
percent, pixel, inch, centimeter, point, or pica values.

3 Click a square in the Placement grid to set the position of the 
resulting image; e.g., to crop the image from the right side and 
bottom, click the upper-left square in the Placement grid. To 
expand the image on all sides, click the center square.

4 Click OK to resize the image. If you are reducing the image 
area, Canvas warns you it will delete pixels; click OK to proceed.

Using the Crop & Scale menu
Canvas features a Crop & Scale menu that you can easily access via 
the Properties bar when an image object is selected. 

When you choose a cropping size from the Crop & Scale menu and 
apply it to a selected image, a cropping rectangle appears on the 
image, just as if you were using the Crop tool. Click inside this rect-
angle and Canvas crops your image. 

Cropping options
Canvas can crop an image in three ways: Soft Crop, Hard Crop, as 
well as Crop and Scale.

Hard Crop Extra pixels are permanently removed.

Soft Crop Extra pixels are temporarily hidden. When the image is 
in edit mode, you can see the hidden pixels.

Specify relative or absolute 
measurements in the 
Image Crop dialog box
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Crop & Scale When applied, a hard crop is performed and the 
resulting image is scaled proportionally.

Apply a cropping size from the Crop & Scale menu to a selected 
image and various cropping options appear in the Properties bar.

To apply a crop command
1 Select the image object. The image should not be in paint 
edit mode.

2 Click on the Crop & Scale menu and select a preset crop size 
or Custom. You cannot manually resize the cropping rectangle 
when using a preset crop size. You have to select another crop size 
from the menu. Select Custom to be able to resize the cropping 
rectangle.

3 Move the cropping rectangle, if necessary. Place the cursor on 
the border of the cropping rectangle and a hand appears.

4 Place the cursor within the cropping rectangle and click to 
complete the crop.

Using the Trim command to remove borders
The Trim command lets you remove same-color pixels that are 
near the edge of the image area. This feature is useful for removing 
unwanted white space or other borders that are not part of the main 
image, e.g., you scan a photo that doesn’t fill the entire scanner 
area, and there is a white border around the photo. The Trim com-
mand identifies the edges of the image, determines which pixels 
around the border match, and deletes the unwanted border.

Tip
The cropping options also appear 
in the Properties bar after clicking 
the Crop tool on an image.

Crop & Scale options
A Width & height of cropping rectan-
gle in pixels. 
B Width & height of cropping rectan-
gle in current ruler units.
C Hard & soft crop options. Select ei-
ther radio button to perform a perma-

nent or temporary crop. The cropped 
image is not scaled with these options.
D Crop & Scale. Select this radio but-
ton to permanently crop and scale an 
image. After cropping, the image is 
scaled proportionally.

Tip
The center of the cropping rectan-
gle is indicated by a square icon.

Tip
Canvas alerts you if the image 
can’t be trimmed because a bor-
der can’t be found.
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To trim an image
1 Select one or more paint objects to trim.

2 Then choose Image > Area > Trim to remove the border.

Using the Crop tool to change image size
Use the Crop tool to select a rectangular part of an image and hide 
the rest, which is called a “soft crop.” When you edit a soft-cropped 
image, the cropped area reappears while the image is in edit mode. 
When you finish editing, Canvas re-crops the image. 

When you use the Crop tool on an image, you have access to the 
Crop & Scale menu in the Properties bar (see “Using the Crop & 
Scale menu” on page 24.6).

• To access “soft crop edit mode”: Select the Crop tool and then 
press Command (Mac) or right-click (Windows).

You can also use the Crop tool to “hard-crop” an image, which adds 
or removes pixels, as an alternative to using the Area > Crop com-
mand. See “To remove pixels when cropping an image” on 
page 24.9, and “To add pixels with the Crop tool” on page 24.10.

To crop without deleting pixels
1 Select the Crop tool and point to the image you want to crop.

2 Click the image with the crop pointer. Canvas displays a rect-
angle with hollow handles. This cropping rectangle defines the 
outside edges of the image after cropping.

3 Position the cropping rectangle to frame the part of the image 
that you want to keep.

• Drag a corner handle to resize the cropping rectangle.

• Drag a side to move the cropping rectangle. The pointer 
changes to a hand when you point to a side.

4 Press Esc to crop the image, or click in the image. Canvas 
hides the part of the image outside the cropping rectangle.

To restore a cropped image
You can select a paint object and choose Effects > Remove Effects 
to remove a soft crop. Or, use the following procedure:

1 Click the image with the Crop tool. Canvas displays the full 
image area and the cropping rectangle. 

 Crop tool 

A gavel appears in crop 
mode when the pointer is in 
the image. Click to complete 
the crop.

This symbol appears if the 
pointer is outside the image 
in crop mode

A hand appears in crop 
mode when you point to a 
side of the cropping 
rectangle. Drag to move the 
rectangle.

Soft crop pointer indicates 
cropping will be temporary

Hard crop pointer indicates 
cropping will be permanent
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2 Drag the corner handles outward so the entire image is inside 
the cropping rectangle, and then press Enter (Mac) or Esc (Win-
dows), or click in the image.

To remove pixels when cropping an image
In hard-crop mode, the Crop tool discards pixels that are outside 
the cropping rectangle.

1 Select the Crop tool and Command-click (Mac) or Ctrl -click 
(Windows) the image you want to crop. Canvas displays a crop-
ping rectangle around the boundary of the image. 

2 Position the cropping rectangle so it frames the part of the 
image you want to keep.

• Drag a handle to resize the cropping rectangle.

• To move the cropping rectangle, point to any side, and the 
pointer changes to a hand. Drag the cropping rectangle to 
reposition it.

3 Press Esc or click in the image to complete the crop.

Cropping an image

Adjust the cropping rectangle 
with the Crop tool by dragging a 
handle. Enclose the area you 
want to keep, and then press Esc 
to hide the cropped part of the 
image.

Cropping rectangle

Tip
Quickly crop or expand a paint 
object using the Selection tool. 
Select the paint object (don’t put it 
in edit mode), then Ctrl-drag a 
handle to crop or add pixels to the 
image. When you drag, the crop-
ping rectangle and handles 
appear. When you release the 
mouse, Canvas applies a hard 
crop.
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To add pixels with the Crop tool
1 Select the Crop tool and point to the image you want to crop.

2 Command-click (Mac) or Alt -click (Windows) the image you 
want to enlarge. Canvas displays a cropping rectangle with hollow 
square handles at the corners.

3 Drag the handles of the cropping rectangle to enlarge it 

4 Press Esc or click in the image to complete the crop.

To quickly crop an image with the Selection tool
1 When a paint object is selected (not in edit mode), point to a 
handle, and then press Ctrl and drag the handle. When you drag, 
a cropping rectangle appears.

2 Drag inward to crop (cut away) part of the object. Drag out-
ward to add pixels and expand the object. Release the mouse to 
complete the operation.

To constrain the cropping rectangle as you drag

• To constrain the height and width of the cropping rectangle pro-
portionally: Release the Ctrl key, and then press Shift while drag-
ging.

• To constrain the height and width of the cropping rectangle sym-
metrically from the center: Release the Ctrl key and then press it 
again while dragging.

Tip
If the paint object you crop is an 
Indexed mode object, the color of 
the added pixels is the last color in 
the color table associated with the 
image, which often is black.

Crop rectangle

Adding a white border

When you press a modifier key and 
click with the Crop tool, you can 
expand a paint object. This adds a 
white border to an RGB Color or 
CMYK Color image.

New border
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• To constrain the height and width of the cropping rectangle both 
proportionally and symmetrically : Release the Ctrl key and then 
press Ctrl+Shift while dragging.

Changing resolution
Change the resolution of paint objects in two ways: 

• If you do not want to change an object’s size, resample the 
image. Resampling merges or divides pixels.

• If you want to preserve all the data in an image, change 
the object’s resolution and allow its size to change.

Decreasing resolution (“down sampling”) decreases file size by dis-
carding data, which can result in lost detail; however, it’s common 
to reduce resolution in some situations. 

Rarely, an image is resampled to increase resolution. This should 
be avoided because additional pixels are created by estimating their 
color values, which does not improve an image.

The Resolution dialog box has compact and expanded states. In its 
compact state, you can easily change the resolution of multiple 
paint objects without needing to specify additional options (see 
“Image resolution settings” on page 24.11).

Image resolution settings
Specify the resolution, width, and height for a selected paint object 
when the Image Resolution dialog box is expanded. Expand the 
dialog box when a single paint object is selected; if multiple objects 
are selected, they must match in size and resolution.

Depending on the options you select, certain settings in the dialog 
box can’t be changed. A bracket and chain icon indicate settings 
that are linked and fixed.

Tip
For Web pages and other applica-
tions where images are displayed 
on a monitor, 72 ppi is the stan-
dard resolution.
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Preserve Data Prevents resampling, or interpolation, when resolu-
tion or size changes. Selecting Preserve Data also selects Preserve 
Proportions, so width and height change only in proportion to each 
other. 

Preserve Data means image resolution and size are relative; chang-
ing the resolution will change the object size, and changing the size 
will change the image resolution. 

If you select Pixels in the Width and Height menus, you cannot 
change these values, because the number of pixels cannot change 
when Preserve Data is selected.

Width and Height Specify a size for the paint object by entering 
values in these text boxes. Select measurement units in the adjacent 
menus. 

The width and height boxes show the size a paint object will 
become if you change the resolution when Preserve Data is 
selected.

Preserve Proportions This option links the Width and Height val-
ues so that changing one value changes the other and maintains the 
original proportions of the paint object. Selecting Preserve Data 
also selects this option. If you want to stretch a paint object in only 
one direction, deselect Preserve Proportions.

Note: When more than one paint object is selected (unless the 
objects are the same size and resolution), the button that displays 
additional options in the Resolution dialog box is not available.

To change resolution by resampling
This procedure reduces resolution of paint objects for use on a Web 
page or in a presentation.

1 Select one or more paint objects. These objects can vary in 
size and resolution.

2 Choose Image > Area > Resolution. The Image Resolution 
dialog box appears in its compact state. 

3 Select pixels per inch or pixels per centimeter and enter the 
resolution value in the text box.

4 Click OK. Canvas changes the resolution of the selected 
objects, which remain the same size.

Expanded dialog box

Compact dialog box
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To change resolution without resampling
Use this procedure to change the resolution of paint objects without 
resampling. This changes the size of objects while preserving the 
image data.

If you reduce resolution, paint objects become larger because the 
individual pixels are larger. If you increase resolution, paint objects 
become smaller because the individual pixels are smaller.

1 Select one or more paint objects and choose Image > Area > 
Resolution.

2 In the Image Resolution dialog box, select Preserve Data. 

3 Enter the desired resolution in the text box and click OK. 
Canvas changes the resolution of the selected paint objects.

To calculate resolution
If only one object is selected, you can calculate an appropriate reso-
lution based on a halftone screen frequency

1 Click Auto in the Image Resolution dialog box.

2 Enter the screen frequency and choose Draft, Good, or Best. 
Canvas calculates the resolution by multiplying the screen fre-
quency by 1 (draft), 1.5 (good), or 2 (best). 

3 Click OK to enter the calculated resolution in the Image Res-
olution dialog box.
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To specify how Canvas approximates new pixels
When increasing image resolution, Canvas uses one of two meth-
ods to calculate color values for the pixels it adds to an image. To 
change the method, use the Interpolation control in the Configura-
tion Center.

1 Choose Canvas > Configuration Center (Mac) or File > Con-
figuration Center (Mac). Select the Painting manager in the Gen-
eral settings. 

2 Select an option under Interpolation and click OK. For more 
information, see “Painting” on page 13.7.

Original 300 ppi Resampled down to 150 ppi

150 ppi image with Unsharp 
Mask filter applied
Amount = 80
Radius = 1.6
Threshold = 0

300 ppi image with Unsharp 
Mask filter applied
Amount = 67
Radius = 1.6
Threshold = 0

150 ppi image resampled up to 
300 ppi

Resampling and sharpening 
images

Resizing and resampling causes 
images to appear softer. However, 
you can apply the Unsharp Mask filter 
to bring soft images back into focus. 
For more information, see “To apply 
the Unsharp Mask filter” on 
page 25.21.
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Auto-tracing images
You can use the Auto Trace command to create vector objects from 
an image. The Auto Trace command traces any channel of an 
image and is available when a paint object is selected (not in edit 
mode). 

Auto-tracing is much faster than tracing an image by hand with the 
Polygon or Curve tool, although you might need to edit the result-
ing vector paths. 

When Canvas auto-traces a channel, it leaves the original image 
unchanged. Canvas applies the current stroke to the resulting vec-
tor objects. When the tracing is complete, you can move the vector 
objects away from the image.

To auto-trace an image 
1 Select a paint object to trace and choose Image > Auto Trace.

2 In the Auto Trace dialog box, choose the channel to trace 
from the Channel menu. The menu lists the channels contained 
in the image, including alpha channels. 

Tip
Canvas auto-traces high-resolu-
tion images better than low-reso-
lution images. Auto-tracing an 
image with a resolution lower than 
300 ppi can produce jagged paths.

Auto-tracing images

Canvas traces an image with curves or 
straight path segments. Auto-tracing 
usually produces several paths that fol-
low various sections of the image.

After tracing, group and edit the result-
ing paths.

Original scan at 600 ppi resolution Paths created with the Auto Trace command

Selection handles 
(highlighted) surround 
the objects produced by 
auto-tracing the sailboat 
image
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3 Select other settings to use for tracing, and then click OK to 
trace the selected channel.

To save custom auto-trace configurations
Canvas provides preset configurations that you can choose from a 
menu in the Auto Trace dialog box. You can also save your own 
tracing configurations so you can use the same settings again.

1 Select a paint object and choose Image > Auto Trace. 

2 In the Auto Trace dialog box, configure the options you want 
to save. 

3 Choose Save Settings in the menu. 

4 Type a name for the configuration in the dialog box and click 
Save. The configuration appears in configuration pop-up menu.

To delete custom auto-trace configurations
1 Select a paint object and choose Image > Auto Trace.

2 In the Auto Trace dialog box, select the configuration you 
want to delete from the configuration menu.

3 Press the arrow pop-up menu and choose Delete Settings. In 
the dialog box, click OK to confirm you want to delete the set-
tings.
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Using Photo CD images in Canvas
Scanned images are available from many sources in Photo CD for-
mat because it’s widely supported, relatively inexpensive, and versa-
tile. 

When you place or acquire Photo CD images, select from a choice 
of standard dimensions. You can choose 192 by 128 pixels (Base/16 
format), 384 by 256 pixels (Base/4), 768 by 512 pixels (Base), or 
1,536 by 1,024 pixels (Base * 4). 

Canvas imports Photo CD images as 72 ppi paint objects in RGB 
Color mode. Use the Resolution command to change a paint 
object’s resolution and dimensions.

To acquire a Photo CD image
1 Choose Image > Acquire > Kodak Photo CD. In the dialog 
box, select the file you want to acquire and click OK. The Kodak 
Digital Science Acquire Module dialog box opens. 

Auto Trace settings

Choose options and preset configura-
tions in the Auto Trace dialog box.

A To use a preset configuration, se-
lect its name in the menu. Preset con-
figurations and those you save appear 
in the menu. 

Channel. Choose a channel of the 
image to trace.

Curves or Polygons. Click an option to 
set the trace method. Curves creates 
paths with smooth anchor points as 
needed. Polygon creates paths with-
out curved segments. Polygon is bet-
ter for tracing straight lines, but can 
make jagged shapes. Curves makes 
segments with fewer anchor points.

Fixed End. Aligns the trace with the 
end points of the image. Available 
when you select the Curves option. 

Corners. Creates corner points that let 
you modify one curve segment with-
out affecting the other. Use the 
Round-Sharp slider to control the cor-
ner sensitivity. Available when you 
select the Curves option.

Smooth. Traces without corner 
points when the Corners option is 
off. If Smooth and Corners are on, 
angles within the specified sharp-
ness are traced as corner points. 
Available when you select the 
Curves option.

Centerline. Traces one line through 
the middle of large solid areas 
instead of tracing along edges. Avail-
able when you select the Curves 
and Polygons options.

Filter. Prevents the tracing of small, 
random elements, such as tiny lines 
and dots. Available when you select 
the Curves and Polygons options.

Invert Map. Inverts lightness values 
(as in a negative image) of the channel 
for tracing. Available when you select 
the Curves and Polygons options

Loose-Tight. Drag the slider toward 
Tight for more exact tracing with more 
anchor points. Drag the slider toward 
Loose for a looser tracing with fewer 
anchor points.

Round-Sharp. Drag the slider toward 
Round to get rounder corners. Drag 

the slider toward Sharp to get sharper 
corners.

B Choose Save Settings to save the 
current settings as a configuration you 
can select later. Choose Delete Settings 
to delete the current configuration. You 
can delete configurations that you save.

Apply. Click to preview the trace.

OK. Click to trace the image.
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2 Use the dialog box to select color correction, resolution, and 
rotation options for importing the Photo CD image. 

• Select source and destination image profiles by clicking 
the Source and Dest buttons. 

• To see details about scanning method and color correc-
tion, click Info. 

• To see a larger preview, click Preview. 

3 Click OK to place the image in the current Canvas docu-
ment.

Improving Photo CD images
Photo CD scans are specifically designed to reproduce photo-
graphic images accurately; however, this means that a Photo CD 
image will exhibit the same problems, such as soft focus and color 
casts, that can be seen in the original photograph. 

Some Photo CD collections provide better quality images than oth-
ers, but you can improve almost all images with a few simple steps. 

Kodak Digital Science Photo CD Acquire Module dialog box
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To apply the Unsharp mask filter to a photo CD image
The following procedure describes how to apply the Unsharp mask 
filter to the Lightness (“L”) channel in LAB Color mode to sharpen 
a Photo CD image.

1 Use the previous procedure to acquire a Kodak Photo CD 
image into a Canvas document.

2 Select the image you just acquired and choose Image > Mode 
> LAB Color.

3 Put the image into edit mode.

4 Choose Image > Show Channels to open the Channels pal-
ette.

5 In the Channels palette, click the Lightness channel to acti-
vate it. For more information, see “Activating channels” on 
page 26.24.

6 Choose Image > Filter > Sharpen > Unsharp Mask. Select the 
preview option and adjust the Amount and Radius until the chan-
nel appears significantly sharper. Click OK.

7 If you plan to use special effect filters, choose Image > Mode 
> RGB Color to convert the image to RGB Color mode.

Note: You can also access the image filters in the Properties bar.

• To apply image filters: Click on the arrow icon of the Filters 
menu. Select a filter from the list.

• To apply adjustment commands: Click on the arrow icon of the 
Adjust menu. Select a command from the list.

Lightness (L) channel selected in 
the Channels palette
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IMAGE ADJUSTMENT & CORRECTION

You can adjust images in Canvas using built-in filters and third-
party plug-ins. For example, you can use the Levels filter to adjust 
image highlights and shadows, and sharpen scanned photos with 
the Unsharp Mask filter.

This chapter describes the commands you can use to adjust image 
color and brightness. It also describes commands for sharpening, 
softening, and refining images. 

Applying image-editing commands
You can apply most image-editing commands to a single paint 
object if it’s selected or in edit mode.You can also apply most com-
mands to multiple selected paint objects. You can set image modes, 
apply filters, and adjust settings for multiple paint objects at the 
same time.

In most cases, a command affects an active selection, or an entire 
image if nothing is selected in edit mode.

Note: When you apply an image-editing command to more than one 
selected paint object, you can’t use the Preview option if the dialog 
box has it. Preview is available when a single image is in edit mode.

You can apply a command by choosing Image > Adjust or by using 
the Adjust menu located in the Properties bar. 

The following summarizes how image-editing commands can be 
applied. 

• Mode commands let you set the image mode for one or 
more selected paint objects.

• You can convert multiple objects to image proxies.

• Crop command and the Proxy Info command can’t be 
applied to multiple objects.
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• Resolution command sets the resolution for one or more 
selected objects.

• Trim command trims one or more selected paint objects. 

• You can apply filters to one or more selected paint objects. 
If a single paint object is in edit mode, a filter applies to 
the entire image or an active selection.

• Image Measurement command can be applied to paint 
objects that are selected or in edit mode.

• Many commands in the Adjust menu can be used to uni-
formly adjust one or more selected paint objects, or a paint 
object in edit mode.

Working with image-adjustment dialog boxes
Some dialog boxes for image-editing commands include histo-
grams and preview options to help you achieve the effect you want.

Using the Preview option
Most dialog boxes for image-adjustment commands include a Pre-
view check box. Select the Preview option to see how settings affect 
the image. Preview is available only when a single paint object is in 
edit mode.

Image Measurement
The Image Measurement dialog box contains a histogram as well 
as information about the selected image or selected regions within 
an image. 

Understanding histograms
A histogram plots the relative number of pixels in each brightness 
level in an image.

Brightness levels

Amount of pixels

Minimum (0) Maximum (255)

More

Fewer
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In the above, shorter bars on the left indicate that the image doesn’t 
contain large areas of very dark pixels. Higher bars toward the right 
of the graph show that the image does contain large areas of 
medium and very bright pixels. 

Image Measurement dialog box
A Channel. Select a channel from the menu. The available 
channels depend on the image mode; i.e., CMYK, RGB, gray-
scale, etc.
B Histogram. A histogram plots the relative number of pix-
els in each brightness in an image (see “Understanding histo-
grams” on page 25.2).
C Properties. This list contains the various image proper-
ties that are being measured. 
D Configure. Click this button to add or remove properties 
from this list.
E Copy. Click this button to copy the image measure-
ments so you can paste them in a spreadsheet or text editing 
application.

Adding properties

Click Configure to see the various image properties that 
can be measured. To include a property in the measure-
ment, select the checkbox. To remove the property, dese-
lect the checkbox.

Area. Total number of pixels in image.

Calibrated area. The area of an image measured in current 
Canvas units.

Mean. Measures the average pixel intensity.

Standard deviation. A numeric value that describes how 
widely intensity values vary.

Median. Middle value in the range of values; i.e.; number of 
pixels with intensity below the median is equal to the num-
ber of pixels with intensity that is above the median.

Center of mass. The x/y coordinates of the image’s center.

Perimeter. Measures the perimeter of the image in pixels.

Calibrated perimeter. The perimeter of an image measured 
in current Canvas units.

Compactness. A numeric measurement of an object’s 
shape. It is defined with the following equation: 

Shape factor. The measurement of an object’s circularity. It 
is defined with the following equation:

Feret diameter. Indicates an object’s theoretical diameter if 
it had a circular shape.

Calibrated feret diameter. Measured in the current Canvas 
units, this indicates an object’s theoretical diameter if it had 
a circular shape.

perimeter2( ) area( )⁄

4 π area( ) perimeter2( )⁄××
Image Measurement 25.3



25
• Toview an image’s image measurement at any time: Choose Fil-
ter > Image Measurement.

Consolidating colors
The Threshold and Posterize commands let you consolidate color 
values in an image or selection. Besides producing interesting 
effects with these commands, you can use them in alpha channels 
to help isolate areas within an image.

If you select an area within an image, Canvas applies the adjust-
ment only to that area. Otherwise, Canvas adjusts the selected paint 
objects.

Setting a brightness threshold
Use the Threshold command to convert any image to black and 
white. The Threshold command compares each pixel’s brightness 
value to a threshold value that you set. It changes brighter pixels to 
white and darker pixels to black. The threshold setting is based on 
a scale of brightness values from 0 (black) to 255 (white). You can’t 
use the Threshold command on images in Black & White or 
Indexed mode.

For example, if you set a threshold value of 128, pixels that are 
brighter than medium gray become white, while pixels darker than 
medium gray become black.

To map an image to black and white
1 Select one or more paint objects to adjust all the images. You 
can select an area in one image in edit mode to adjust the 
selected area only. If you don’t make a selection, the entire image 
is affected.

2 Choose Image > Adjust > Threshold. 

3 Enter the threshold value by dragging the slider or typing a 
number in the text box. If you want Canvas to convert half the 
pixels to black and half to white, click Auto.

4 Click OK after entering the setting you want.

To isolate selections, apply the Threshold command in conjunction 
with the High Pass filter to an image in an alpha channel (see “Iso-
lating areas using the High Pass filter” on page 27.13).
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Creating high contrast ‘posterized’ images
You can condense the brightness variations in an image with the 
Posterize command. If you apply the Posterize command to a pho-
tograph, it creates a high-contrast image by compressing hundreds 
of brightness levels into only a few. You set the number of bright-
ness levels you want to retain, and Canvas reduces each color chan-
nel to that number of values.

The Posterize command’s effect depends on the mode of the image 
you posterize; e.g., if you apply the Posterize command with a set-
ting of 2 levels to a grayscale-mode image, the image becomes black 
and white. If you apply the same setting to an RGB-mode image 
(even if it contains only grays), the command converts each pixel’s 
red, green, and blue value to either zero or full color, reducing the 
image to eight colors — red, green, blue, red-green, red-blue, blue-
green, black, and white. 

To posterize an image
1 Select one or more paint objects to posterize all the images. 
You can select an area in one image in edit mode to posterize the 
selected area only. If you don’t make a selection, the entire image 
is affected.

2 Choose Image > Adjust > Posterize.

3 Enter a level from 2 to 255. Higher numbers produce subtle 
effects. Lower numbers produce high-contrast images.

4 Click OK after you enter the Levels setting.

Original RGB image Posterize 4 levels Posterize 2 levelsPosterize 8 levels

Tip
You can’t use the Posterize com-
mand on images in Black & White 
or Indexed mode.
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Changing color and contrast 
You can use the Invert, Desaturate, and Brightness/Contrast com-
mands to create special effects and correct lightness levels in 
images. These commands apply changes equally to all color values. 

If you select an area of an image, Canvas applies the command to 
that area only. Otherwise, Canvas applies the command to the 
entire image in a paint object.

Inverting colors in images
You can use the Invert command to reverse the colors in an image, 
as in a photographic negative. The command converts each pixel’s 
color to its opposite hue in the color spectrum. It does this by invert-
ing the brightness value of each pixel in each color channel.

For example, if a pixel is pure red, its brightness levels are 255, 0, 0 
in RGB mode. When inverted, this pixel’s brightness values 
become 0, 255, 255, changing it to pure blue-green, its opposite in 
hue.

The Invert command can be particularly useful in channel editing, 
as colored pixels can denote either masked or selected areas.

To invert an image
1 Select one or more paint objects to invert all the images. You 
can select an area in one image in edit mode to invert the selected 
area only. If you don’t make a selection, the entire image in edit 
mode is affected.

2 Choose Image > Adjust > Invert.

Original RGB Inverted RGB Inverted Green 
channel

Green channel 
selected

Tip
You can’t use the Invert command 
on images in Indexed mode.
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Desaturating image colors 
You can use the Desaturate command to remove color from images 
completely, while retaining the relative brightness levels of shad-
ows, midtones, and highlights. The command converts an entire 
image to shades of gray without changing the image mode.

To desaturate an image
1 Select one or more paint objects to desaturate all the images. 
You can select an area in one image in edit mode to desaturate 
the selected area only. If you don’t make a selection, the entire 
image in edit mode is affected. This command works with paint 
objects in RGB Color mode, CMYK Color mode, and LAB Color 
mode.

2 Choose Image > Adjust > Desaturate or select Desaturate 
from the Adjust menu in the Properties bar.

Adjusting brightness and contrast
You can adjust the brightness and contrast of an entire image or 
specific channels with the Brightness/Contrast command. Bright-
ness refers to the lightness of an image. Contrast is the difference in 
brightness between two pixels. 

Because the Brightness/Contrast command adjusts all pixels 
equally, you should avoid using it to lighten an image that appears 
too dark, because the image can lose shadow detail. 

• To preserve shadows or highlights when adjusting the brightness 
of an image: Use the Levels or Curves commands (see “Levels” on 
page 25.8 and “Adjusting brightness curves” on page 25.10).

To use the Brightness/Contrast command
1 Select one or more paint objects to adjust all the images. You 
can select an area in one image in edit mode to adjust the selected 
area only. If you don’t make a selection, the entire image in edit 
mode is affected. This command doesn’t work with paint objects 
in Black & White mode or Indexed mode.

2 Choose Image > Adjust > Brightness/Contrast or select 
Brightness/Contrast from the Adjust menu in the Properties bar. 

3 Enter a Brightness value from -100 to 100. Higher values can 
wash out midtones and shadows. Lower values can dull high-
lights.
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4 Enter a Contrast value from -100 to 100. Increasing contrast 
moves the color values of pixels to the extremes of the brightness 
spectrum. Decreasing contrast moves color values toward 
medium gray.

5 After entering the settings you want, click OK.

Color balance
The Color Balance command lets you adjust color in shadows, mid-
tones, and highlights. You can use it with paint objects in CMYK 
Color or RGB Color modes.

1 Select one or more paint objects to adjust all the images. You 
can select an area in one image in edit mode to adjust the selected 
area only. If you don’t make a selection, the entire image in edit 
mode is affected.

2 Choose Image > Adjust > Color Balance.

3 Click Shadows, Midtones, or Highlights to select the tonal 
range you want to adjust. You can set the color levels indepen-
dently for each tonal range.

4 Drag a slider toward a color label to increase the amount of 
that color. The letters indicate the primary color values: Cyan, 
Red, Magenta, Green, Yellow, and Blue. 

When you increase the amount of a color, you also reduce its 
inverse, which is the color labeled at the other end of the slider.

5 Click Preview to preview the color adjustments. Preview is 
only available if a single paint object is in edit mode.

6 Click OK to apply the settings. 

Levels
You can adjust the brightness of shadows, highlights, or midtones 
by using the Levels command. Brightness values range from 0 
(black) to 255 (white). For colored pixels, brightness is the bright-
ness value in each color channel.

The Levels command works with all image modes except Black & 
White and Indexed.
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To adjust levels
1 Select a paint object to adjust. You can select an area in the 
image to adjust the selected area only.

2 Choose Image > Adjust > Levels.

3 Select a channel or combination of channels in the pop-up 
menu. The Levels command will affect only the specified chan-
nels.

4 Do one or more of the following

Lighten highlights: Enter a positive number less than 255 in the 
right Input Levels box, or drag the white slider under the histo-
gram. Canvas assigns the maximum output level to all pixels on the 
right of the slider.

Lighten shadows Enter a positive number in the left Output Lev-
els box, or drag the black slider under Output Levels to increase the 
minimum output level. This value becomes the darkest value 
allowed in the image.

Darken highlights Enter a positive number less than 255 in the 
right Output Levels box, or drag the white slider under Output 
Levels to set the maximum output value. This is the brightest value 
allowed in the image. You can darken highlights in one color chan-
nel to bring brighter colors back into the printable color range.

Darken shadows Enter a number greater than zero in the left 
Input Levels box, or drag the black slider under the histogram. 
Canvas assigns the minimum output level to all pixels on the left of 
the slider.

Adjust midtones Enter a value in the center Input Levels box or 
drag the gray slider under the histogram. To lighten midtones, 
enter a value from 1.01 to 9.99 or drag the slider to the left. All pix-
els on the right of the slider will be brighter than medium gray. To 
darken midtones, enter a value from 0.1 to 1.00 or drag the slider to 
the right. All pixels on the left of the slider will be darker than 
medium gray.

5 Click OK.

Saving and loading Levels settings
You can save Levels settings on disk to use again. For example, 
after correcting a scanned photo, you can save the settings and use 
them to correct other images scanned from the same source. 
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• To save Levels settings: In the Levels dialog box, click Save. 
Type a name for the settings file, select a location, and click Save.

• To load previously-saved Levels: In the Levels dialog box, click 
Load. A directory dialog box opens. Locate the settings file you 
want to open, and click Open. 

Adjusting brightness curves
You can adjust the tonal range of an image with the Curves com-
mand. Unlike the Levels command, which can set the minimum, 
maximum, and median values, Curves adjusts the entire range of 
values. It lets you map input values to output values according to a 
line (“curve”) on a graph. Curves provides the most control over the 
tonal range of an image.

This command is not available when a paint object in Black & 
White mode or Indexed mode is selected.

Levels dialog box

Use the Levels dialog box to control 
different aspects of brightness levels. 

A Choose an individual color chan-
nel or the composite channel.
B Type values in the Input Levels 
boxes or drag the slider under the histo-
gram to set the minimum input level, 
midtone ratio, and maximum input lev-
el.
C Enter numbers in the text boxes or 
drag the sliders to set the minimum and 
maximum output levels.
D The histogram graphs brightness 
levels for the selected channel.
E Click Auto for Canvas to map the 
darkest values in the selection to black 
and the lightest value to white. 
F Eyedroppers. Click the Set White 
Point eyedropper tool. Click in the im-
age to pick the values you want to as-
sign to the lightest area in the image. 
Click the Set Black Point eyedropper 
tool. Click in the image to pick the val-
ues you want to assign to the darkest 
area in the image.
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In the Curves dialog box, brightness values range from 0 (black) to 
255 (white), or 0 percent (white) to 100 percent (black). To switch 
between these scales, click the grayscale bar under the graph.

A typical setting is a gentle S-curve (or inverted S-curve, depending 
on the scale you use), which adds contrast to an image without 
appearing too harsh.

To adjust brightness curves
1 Select one paint object to adjust. The paint object can be in 
edit mode. You can select an area in the image. If you don’t make 
a selection, the entire image is affected.

2 Choose Image > Adjust > Curves.

3 In the Channel pop-up menu, select the composite channel or 
an individual channel to adjust. To adjust multiple channels, 
select the channels in the Channels palette first.

4 To change the shape of the existing curve, make sure the 
curve button at the bottom-left is selected. 

• Click points that you want to keep the same

• Drag points on the curve that you want to change. Or, 
enter values in the Input and Output boxes. For example, 

Curves dialog box

The graph shows how Canvas maps 
input brightness values to output val-
ues. Select Preview to see the effect on 
the image.

A Choose a channel to adjust.
B The grayscale ramp shows the 
lightness scale, either 0-255 (dark to 
light) or 0-100 percent (light to dark). 
Click the ramp to reverse the scale and 
the curve.
C Type brightness values in the Input 
and Output boxes. Or, drag the pointer 
(circled) to specify brightness values. 
Here, pixels of 157 brightness are light-
ened to 171.
D Click this icon and drag a point on 
the curve to reshape the curve. Click the 
curve to add up to 19 control points. 
Drag points off the curve to delete them.

E To draw a disconnected segment, 
click this icon and drag in the graph.

F With the pencil (E) selected, click 
to smooth the curve.

O
ut

pu
t 

Input

Tip
To redraw the curve completely, 
or to create sharp changes in 
brightness for a tonal range, click 
the pencil and draw a new curve 
or segment.
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to keep midtones the same, click the center of the curve, 
then drag other areas of the curve. To adjust midtones 
without affecting highlights and shadows, click the quarter 
and three-quarter points of the curve, and drag the middle.

5 If you draw disjointed segments with the pencil, you can click 
Smooth to create one continuous curve.

6 Click OK to apply the current settings to the image.

Saving and loading Curves dialog box settings
You can save Curves dialog box settings to use again; e.g., after cor-
recting the brightness curve for a particular Photo CD image, you 
can save these settings and later apply them to other images from 
the same source.

• To save Curves settings: In the Curves dialog box, click Save. 
In the directory dialog box, type a name for the settings file, select a 
location, and click Save.

• To load Curves settings: In the Curves dialog box, click Load. 
In the directory dialog box, locate the settings file and click Open.

Hue/Saturation
You can modify the tint and purity of specific colors with the Hue/
Saturation command. In terms of image editing, saturation refers to 
the amount of gray in colors. 

The Hue/Saturation dialog box varies slightly depending on the 
color mode. For RGB Color and CMYK Color images, you can 
modify red, yellow, green, cyan, blue, or magenta color ranges. For 
LAB mode images, you can modify blue, magenta, yellow, or green 
color ranges. 

The Hue/Saturation command is available when you work with 
CMYK, RGB, or LAB Color mode images. Before choosing the 
Hue/Saturation command, make the composite channel active. For 
more information, see “Activating channels” on page 26.24.
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To adjust the hue of a color range
1 Select a paint object to adjust. You can select an area in the 
image to adjust the selected area only.

2 Choose Image > Adjust > Hue/Saturation.

3 On the left of the dialog box, click the color range to adjust, 
or click Master to affect all colors equally. 

4 To change the selected color, enter the amount of the color 
shift, from -180 to 180°, in the Hue text box. Negative values indi-
cate a counter-clockwise shift around the color wheel; positive val-
ues indicate a clockwise shift; e.g., with the Master option 
selected, setting Hue to 60 changes red to magenta, magenta to 
blue, blue to cyan, and so on.

5 Click OK to apply the current settings to the image.

To adjust the saturation of a color range
1 Select a paint object to adjust. You can select an area in the 
image to adjust the selected area only.

2 Choose Image > Adjust > Hue/Saturation.

3 Click the option button of the color you want to adjust, or 
click the Master option button to affect all colors equally.

4 Enter a value from -100 to 100 in the Saturation text box or 
drag the slider. Positive values decrease the amount of gray in the 
selected colors. Negative values increase the amount of gray.

5 Click OK to apply the current settings to the image.

Hue/Saturation dialog box
A Choose the color to adjust. Click 
Master to affect all colors.
B Enter numbers in the text boxes or 
drag the sliders to adjust hue, saturation, 
and lightness.
C The color wheel illustrates changes 
made in the settings. 
D Turn on to add the same hue to the 
entire image.

Color wheel
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To adjust the brightness of a color range
1 Select a paint object to adjust. You can select an area in the 
image to adjust the selected area only.

2 Choose Image > Adjust > Hue/Saturation.

3 Choose a specific color range or choose Master to affect all 
colors equally.

4 Enter a value from -100 to 100 in the Lightness text box or 
drag the slider. Positive values increase the amount of white in the 
color range. Negative values decrease the amount of white.

5 Click OK to apply the current settings to the image. 

For more control of brightness adjustments, use the Levels or 
Curves command (see “Levels” on page 25.8 and “Adjusting bright-
ness curves” on page 25.10).

To colorize an image
Use the Colorize option in the Hue/Saturation dialog box to tint an 
image. This applies the same hue and saturation to all pixels that 
are not 100% black or white. The Colorize option does not affect 
the lightness levels of pixels.

1 Select a paint object. You can select an area in the image to 
adjust only the selection.

2 Choose Image > Adjust > Hue/Saturation.

3 Select the Colorize option. 

4 Enter a value from -180° to 180° in the Hue text box. Positive 
values shift counter-clockwise around the color wheel, negative 
values shift clockwise around the color wheel. For example, Hue 
120 creates a green-toned image.

5 Enter a value in the Saturation text box or drag the slider. 

6 After entering the settings you want, click OK.

Color Equalization
You can graphically adjust the saturation of different color ranges 
with the Color Equalization command. You can add or remove 
gray from various color ranges in images in RGB Color mode, 
CMYK Color mode, and LAB Color mode.
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To use the Color Equalization command
1 Select a paint object to adjust. You can select an area in the 
image to adjust only the selected area. 

2 Choose Image > Adjust > Color Equalization.

3 Drag the handles in the window to change the saturation of 
color ranges. To increase saturation, drag upward. To decrease 
saturation, drag downward.

4 Click Saturate to increase the saturation of all colors. To 
decrease the saturation of all colors, click Desaturate. Click Nor-
malize to return all colors to their original saturation. 

5 Click OK to apply the settings.

Blur filters 
Blur filters soften images by decreasing contrast between neighbor-
ing pixels. These commands work with all image modes except 
Indexed and Black & White.

Apply the Blur filters by choosing Image > Filter > Blur or by using 
the Filters menu in the Properties bar.

To use Blur and Blur More
Blur slightly modifies an image. Blur More is about four times 
stronger than Blur. Both commands work with all image modes 
except Black & White and Indexed.

1 Select one or more paint objects to blur. You can select an 
area in one image to blur the selected area only. 

2 Choose Image > Filter > Blur > Blur or Blur More.

Gaussian and Average blur
Create a softening effect by using the Gaussian Blur or Average 
blur filters. Their effects are similar, but the Gaussian Blur filter 
creates a more diffused effect than the Average blur filter.

Color Equalization dialog box
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The Gaussian Blur filter changes the color value of each pixel by 
applying a weighted average based on the color values of pixels 
within a specified distance. Color values at the edge of the specified 
distance influence the final color value less than closer pixels. 

The Average filter determines the new color value for each pixel by 
equally averaging all color values within the specified radius. 

To apply Gaussian Blur or Average blur
1 Select one or more paint objects to blur. You can select an 
area in one image to blur the selected area only. 

2 Choose Image > Filter > Blur > Gaussian Blur or Average.

3 Specify a radius value from 0.1 to 250.0 in the Gaussian Blur 
dialog box, or 1 to 16 in the Average dialog box. Smaller radius 
values produce more subtle effects than larger ones.

4 Click OK.

Depending on the size of the radius, applying a Gaussian or Aver-
age blur can take longer than other Blur filters.

Motion Blur
The Motion Blur filter can create the effect of linear movement. 
You can specify the direction and magnitude of the effect. This 
command works with all image modes except Black & White, 
Indexed, and Duotone.

To apply motion blur
1 Select one or more paint objects to blur. You can select an 
area in one image to blur the selected area only. 

2 Choose Image > Filter > Blur > Motion Blur. Adjust the set-
tings in the Motion Blur dialog box, and then click OK to apply 
the filter and close the dialog box. 

Blur Blur More Average Gaussian
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Motion Blur settings
Direction Establishes the angle of the blur and the object “move-
ment.” Enter a value from -90 to 90 degrees. You can drag the slider 
or drag the solid dot inside the circle to set the Direction value. A 
value of 0 degrees creates a horizontal blur; 90 degrees creates a 
vertical blur.

Distance The magnitude of the blur. Enter a number from 1 to 
999, or drag the slider to set the Distance. A lower number creates 
less blurring.

Phase Establishes the apparent direction of movement by creating 
a blurred trail that follows the object. Enter a number from -100 to 
100 or drag the slider to set the Phase. Negative numbers create 
apparent movement up and to the right. Positive numbers create 
apparent movement down and to the left.

Preview Displays the effect of the current settings.

Grayscale paint object Motion Blur: Direction = -7, Distance = 162, 
Phase = -63
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Radial Blur
The Radial Blur filter can create the effect of circular movement in 
an image. This command works with all image modes except 
Black & White, Indexed, and Duotone.

To apply radial blur
1 Select one or more paint objects to blur. You can select an 
area in one image to blur the selected area only. 

2 Choose Image > Filter > Blur > Radial Blur. Adjust the set-
tings in the dialog box, and then click OK to apply the filter.

Drag to set blur 
direction

Original Spin 5 Spin 20 Spin 50

Radial Blur
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Radial Blur settings
Spin Controls the magnitude of the apparent rotation in the 
image. Type a number from 1 to 100 or drag the slider to set the 
value. Or, drag the solid area inside the circle. Drag clockwise to 
simulate slower rotation; drag counterclockwise to simulate faster 
rotation and produce more blurring.

Quality Higher quality creates a smoother image but takes more 
time. The quality differences become more pronounced when the 
image is enlarged or printed on standard size paper.

Select Draft for the fastest redraw. Select Good for average redraw 
speed and quality. Select Best when image quality is most impor-
tant.

Centering options These options let you set the rotation origin. 
Center In Image sets the origin at the center of the image. Center in 
Selection sets the origin at the center of a selection. “Offset from 
Center in Pixels” lets you type values to offset the origin from the 
center of the image or selection. Type vertical and horizontal offset 
amounts in pixels in the text boxes. Negative horizontal offsets 
move the center to the left. Negative vertical offsets move the center 
up. Positive horizontal offsets move the center to the right. Positive 
vertical offsets move the center down.

Preview Displays the effect of the current settings.

Zoom Blur
The Zoom Blur filter can create the effect of movement in an 
image, as if the scene were moving rapidly toward or away from the 
observer. The filter blurs along an axis perpendicular to the image. 
You can specify the depth, direction, and smoothness of the blur 
effect. This command works with all image modes except Black & 
White, Indexed, and Duotone.

To apply zoom blur
1 Select one or more paint objects to blur. You can select an 
area in one image to blur the selected area only. 

2 Choose Image > Filter > Blur > Zoom Blur. Adjust the set-
tings in the dialog box, and then click OK to apply the filter. 
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Zoom Blur settings
Span Sets the depth, (length) of the zoom effect. Type a number 
from 1 to 100 or drag the slider to set the value. A larger number 
simulates a greater zoom depth and a more blurred effect. 

Zoom In/Out Establishes the direction of the blur effect toward or 
away from the viewer. Type a number from -100 to 100 or drag the 
slider to set the value. Negative numbers make the image appear to 
move closer; positive numbers make the image appear to move 
away.

Smoothness Controls the quality of the transition of the blur 
effect. Type a number from 1 to 10 or drag the slider to set the 
value. A smaller number creates a smoother blur with fine color 
blending.

Centering options These options let you set the zoom origin. Cen-
ter In Image sets the origin at the center of the image. Center in 
Selection sets the origin at the center of a selection. “Offset from 
Center in Pixels” lets you type values to offset the origin from the 
center of the image or selection. Type vertical and horizontal offset 
amounts in pixels in the text boxes. Negative horizontal offsets 
move the center to the left. Negative vertical offsets move the center 
up. Positive horizontal offsets move the center to the right. Positive 
vertical offsets move the center down.

Preview Displays the effect of the current settings.

Zoom Blur applied to area selected 
around center

Span: 25
Zoom In/Out: 25
Smoothness: 5
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Sharpen filters
Sharpen filters increase the contrast between adjacent pixels, which 
can make an image appear more distinct. These commands work 
with all image modes except Black & White, Indexed, and Duo-
tone.

Sharpen filter modifies an image slightly. The effect of the 
Sharpen More filter is about four times greater.

Sharpen Edges filter affects only high-contrast areas. 

Unsharp Mask filter provides additional control over the sharpen-
ing effect.

To sharpen an image
1 Select one or more paint objects to sharpen. You can select an 
area in one image to sharpen the selected area only. 

2 Choose Image > Filter > Sharpen, and then choose a filter.

To apply the Unsharp Mask filter
1 Select one or more paint objects to sharpen. Select an area in 
an image to sharpen the selected area only. 

2 Choose Image > Filter > Sharpen > Unsharp Mask.

3 Enter 1 to 500% for Amount. Enter less than 100 percent to 
sharpen the image slightly.

4 Enter 0.1 to 250 pixels for Radius. This is the size of the area 
used to determine new color values for the original pixels. Smaller 
values focus the sharpening effect on high-contrast edges. 

5 Enter 0 to 255 levels for Threshold. Enter 0 to filter all pixels. 
Enter a larger value to filter only high-contrast edges.

Tip
Although the Sharpen and Blur fil-
ters have opposite effects, they do 
not negate each other. To reverse 
the effects of a Sharpen filter, 
choose Edit > Undo.

Original Sharpen More 
applied 5 times 

Sharpen Edges 
applied 8 times 

Unsharp Mask 
Amount = 113
Radius = 4.5
Threshold = 0
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6 Click OK to apply the filter.

Adding and removing noise
In images, “noise” refers to randomly-colored pixels. Noise can be 
good or bad; e.g., you can apply noise to computer-generated graph-
ics to make them appear more photographic. You can also use a fil-
ter that removes noise to minimize the appearance of tiny scratches 
or other artifacts present in the source material or introduced dur-
ing digitizing. Noise commands work with all image modes except 
Black & White and Indexed.

To add noise to selections
1 Select one or more paint objects to adjust. Select an area in 
one image to adjust the selected area only. 

2 Choose Image > Filter > Noise > Add Noise.

3 Enter 1 to 999 for Amount to specify how far the color of the 
noise can vary from the original color. 

4 Choose the Uniform or Gaussian distribution option:

Uniform To apply colors randomly picked within the Amount 
specified. Canvas evenly distributes the color of the noise across a 
range of colors. This option gives the smoothest effect.

Gaussian If you want the noise to favor lighter and darker colors 
within the specified range. This option creates a more pronounced 
effect than Uniform.

5 Select Monochromatic if you want to add noise of different 
brightness levels of the original color. 

6 Click OK to apply the noise settings.

Removing noise from selections
You can remove noise from an image or selection using the 
Median, Despeckle, or Dust & Scratches filters. The Median filter 
removes noise by averaging the color of pixels. The Despeckle and 
Dust & Scratches filters remove noise by selectively blurring 
regions of the selection. 
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To use the Median filter
On a pixel-by-pixel basis, the Median filter applies the median color 
value of all pixels within the specified radius. Although the filter 
ignores extreme values in its computations, higher radius values 
can still wash out an image. 

1 Select one or more paint objects to adjust. You can select an 
area in one image to adjust the selected area only. 

2 Choose Image > Filter > Noise > Median. 

3 Type a value from 1 to 16 in the Radius text box, or drag the 
slider. Smaller radius values produce subtler effects.

4 Click OK.

To use the Despeckle filter 
The Despeckle filter can remove defects such as dust and other 
speckling in images. The filter blends pixels with the lightness val-
ues of neighboring pixels. It’s a good idea to select areas that need 
correction before applying the filter.

1 Select an area in an image to adjust. If you don’t make a selec-
tion, the entire image is affected. 

2 Choose Image > Filter > Noise > Despeckle.

3 Drag the slider or type a number in the text box to set the 
Threshold value. Higher values produce greater blending of pix-
els.

To reduce dust and scratch marks
The Dust and Scratches filter can remove dust specks by replacing 
a pixel’s value with a median value. The filter does not change a 
pixel’s value unless the absolute value of the difference of its gray 
value and the median gray value of its neighborhood is greater than 
the Threshold. Larger numbers of pixels are replaced by the 
median value when the Threshold is low.The practical effect of this 
is that larger pixels regions (larger “specks”) are reduced or 
removed with a lower Threshold. Therefore, you can use the 
Threshold to control the size of the artifacts you want to remove.

1 Select an area to adjust in an image. If you don’t make a selec-
tion, the entire object is affected. 

2 Choose Image > Filter > Noise > Dust & Scratches.
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3 Enter a value from 1 to 16 in the Radius text box. Smaller 
radius values produce a subtler effect than larger ones.

4 Type a value from 0 to 255 in the Threshold text box. After 
entering the settings you want, click OK.

Smoothing video images
Because video images contain two interlaced pictures, you can 
sometimes see a slight banding effect in images acquired from 
video-recording devices. You can correct this by using the De-Inter-
lace filter and then applying the Unsharp Mask filter. De-Interlace 
works with all image modes except Black & White.

To smooth video images
1 Select one or more paint objects to adjust. You can select an 
area in one image to de-interlace the selected area only. 

2 Choose Image > Filter > Video > De-Interlace. 

3 Click Odd fields or Even fields to select bands to eliminate.

4 Choose a replacement method for the eliminated pixels: 

Duplication To fill the area by inserting a copy of an adjacent 
band. 

Interpolation To fill the area by inserting intermediate color values 
based on the color values of neighboring pixels. This option creates 
a smoother, more accurate fill than Duplication.

5 After entering the settings you want, click OK.
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Chapter

26
SELECTIONS & CHANNELS

Canvas gives you several ways to select pixels in an image. When 
you select groups of pixels by area or color, you can use painting 
tools, filters, and special effects to modify the selected pixels with-
out affecting the parts of the image that are not selected. 

This chapter describes how to make selections in images, save selec-
tions in alpha channels, work with color and alpha channels, and 
create channel masks, which can make parts of images transparent.

Selecting pixels in images
When a paint object is in edit mode, any filters, commands, and 
painting tools that you apply can affect the entire image. When you 
have selected pixels in the image, the effect of a tool, filter, or other 
adjustment is confined to the selected pixels.

You can select areas in an image using painting tools or menu com-
mands. For example, you can make rectangular selections by drag-
ging the Marquee tool in an image, and you can use the Color 
Range command to select groups of pixels based on color similar-
ity. 

Selection borders
The selected pixels in an image are referred to collectively as a 
selection. When you make a selection, Canvas surrounds the 
selected pixels with a moving dashed border. You can hide and dis-
play the border without affecting the selection. To hide the border, 
choose Image > Select > Hide Edges. To display the selection bor-
der, choose Image > Select > Show Edges.

Deselecting an image selection
When you use a selection tool in normal mode, making a new selec-
tion replaces any existing selection in an image. To deselect pixels 
without making a new selection, choose Image > Select > None. 
You can also press Enter or Esc (Mac), or Esc (Windows) to deselect 
a selection. If a selection is floating, pressing Esc once defloats the 
selection; pressing Esc again deselects all pixels. 

A dashed border outlines the 
selected area in a photograph
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Selecting all pixels in an image
You can apply painting tools and filters to an entire image without 
first making a selection. But you can also select all the pixels in an 
image when you want to work with them as a selection. 

• To select all pixels, with a paint object in edit mode: Choose 
Image > Select > All. A selection border appears around the entire 
image.

Using pixel selection tools
Use the Marquee, Oval Marquee, Row Selection, Column Selec-
tion, and Lasso tools to select areas in images. 

The Marquee tool selects rectangular areas. The Oval Marquee 
tool selects oval areas. The Column Selection tool selects a single 
vertical column of pixels. The Row Selection tool selects a single 
horizontal row of pixels. The Lasso tools selects odd-shaped areas. 

The Marquee, Oval Marquee, Row Selection, and Column Selec-
tion tools are located in a tool palette within the Painting tool pal-
ette. The Lasso tools are separate icons in the Painting tool palette.    

These selection tools let you select any part of an image, from one 
pixel to all the pixels in the image. By using modifier keys with 
these tools, you can add to and subtract from selections, and select 
the overlapping area of two selections. 

By subtracting a circle from a larger circle, for example, you can 
make a ring-shaped selection with an unselected area inside. See 
“Modifying selections,” page 26.13. 

To select rectangular or oval areas
1 Place the paint object into edit mode.

2 Select the Marquee tool or the Oval Marquee tool.

3 Drag diagonally in the image; a selection rectangle or oval 
expands as you drag away from the starting point. When you 
release the mouse button, a dashed border outlines the selected 
area.

• To make a square selection: If no selection exists, press Shift 
and drag the Marquee tool in an image. If a selection exists in the 
image, pressing Shift adds to the selection. 

A Marquee
B Oval Marquee
C Row Selection
D Column Selection
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• To make a circular selection: If no selection exists, press Shift 
and drag the Oval Marquee tool in an image. If a selection exists in 
the image, pressing Shift adds to the selection.

• To expand a selection marquee from the center: If no selection 
exists, press Ctrl and drag the Marquee or Oval Marquee tool (on 
Mac, press Ctrl after you begin dragging). You can press Ctrl+Shift 
to constrain the selection marquee and expand it from the center.

To select single rows or columns
1 Select the Row Selection tool or the Column Selection tool. If 
the paint object isn’t in edit mode, click it. 

2 Click a single pixel to select all pixels in the same row or col-
umn in the image. A dashed border outlines the selected row or 
column. Or, press and hold the mouse button to see a selection 
outline, and move the pointer to position the selection outline. 
Release the mouse button to set the selection, and a dashed bor-
der outlines the selected row or column.

When working in high-resolution images, you can zoom to 400% 
magnification or higher to see the pixels you want to select.

To select areas with the Lasso tools
1 Place the paint object into edit mode.

2 Select either Lasso tool.

3 Drag in the image to outline a selection. Canvas connects the 
starting and ending points with a straight line. A dashed border 
outlines the selected areas.

Lasso options
To set options before using the Lasso tools, use the settings in the 
Properties bar.

Feather Radius To soften the edge of selections made with the 
Lasso tool, enter the feather range in pixels in the Feather Radius 
box.

Lasso tools
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Anti-Aliased To slightly soften the edge of selection made with the 
Lasso tool, select the Anti-Aliased checkbox.

Omit Color To keep pixels that match the current background 
color from being selected by the Lasso tool, select the Omit Color 
checkbox and then choose Background Color. Select Click Point to 
omit the color where you first click with the Lasso tool.

Modifying selections
After you make a selection using any selection technique, you can 
use modifier keys to alter the selection with the Marquee, Oval 
Marquee, Row Selection, Column Selection, and Lasso tools.

• To add to a selection: Press Shift when you use a selection tool. 
A “+” symbol indicates that the tool will add the new selection to 
the existing selection. 

• To subtract from a selection: Press Command (Mac) or Ctrl 
(Windows) when you use a selection tool. A “-” symbol indicates 
that the tool will subtract the new selection from the existing selec-
tion.

• To select part of a selection: Press Shift+Command (Mac) or 
Shift+Ctrl (Windows) when you use a selection tool. An “x” symbol 
indicates that the area you select in the existing selection will 
remain selected. If none of the new selection is part of the existing 
selection, Canvas deselects all pixels.

You can also use Shift or Ctrl to constrain a selection when you 
add, subtract, or intersect a selection. To do this, press the keys to 
add, subtract, or intersect and begin dragging. While still pressing 
the mouse button, release the keys and then press the constraint 
keys and continue dragging.

Selecting areas based on color
You can use the Wand tool and the Color Range command to 
select pixels in an image according to color. 

• To select a contiguous area of similarly colored pixels: Use the 
Wand tool. 

• To select all pixels of a particular color: Use the Color Range 
command.
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To use the Wand tool
1 Select the Wand tool and point to the object you want to edit. 
If the paint object is not in edit mode, the pointer becomes a hand 
( ). Click the object to put the image in edit mode. The pointer 
becomes a wand.

2 Click the color area you want to select.

• To add to a selection: Shift-click the Wand in the image. The 
pointer displays a ‘+’ to show that it adds to the current selection.

• To subtract from a selection: Command-click (Mac) or Ctrl-
click (Windows) the Wand in the image. The pointer displays a 
wand with a ‘-’ to show that it subtracts from the current selection.

To adjust the tolerance of the Wand tool
You can broaden or narrow the range of colors the Wand tool 
selects by adjusting its tolerance; e.g., a tolerance of zero selects pix-
els that exactly match the color of the pixel you click.

• To configure the Wand tool: Use the settings in the Properties 
bar. In the Tolerance field, enter a tolerance value from zero to 255. 
The Select throughout image option lets you select the chosen color 
in the entire image. To smooth the edges of the selection, turn on 
the Anti-Aliased option. 

Selecting a color range
You can use the Color Range command to select all areas of similar 
color in an image. The command creates a grayscale selection mask 
similar to an alpha channel. 

You can use the Load and Save buttons in the dialog box to work 
with color range selection files. The file format that Canvas uses for 
these files is compatible with Photoshop Color Range files. On Win-
dows, these files use the extension AXT.

To select a color range interactively
1 With a paint object in edit mode, choose Image > Select > 
Color Range.

2 In the Color Range dialog box, choose Sampled Colors in the 
Select menu.

Wand tool
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3 Adjust the Fuzziness setting. To select pixels of exactly the 
same color, set the Fuzziness to zero. Increase the Fuzziness to 
widen the range of colors to be selected.

4 Click a color in the preview image in the dialog box. Canvas 
selects a range of similarly colored pixels, depending on the Fuzz-
iness setting.

• To add colors to the selection, click the ‘+’ dropper icon, 
then click a color in the image in the dialog box.

• To subtract colors from the selection, click the ‘-’ dropper 
icon, then click in the image in the dialog box.

5 To view the selected pixels, click the Selection option. Gray 
areas indicate pixels that the Color Range command selects at a 
reduced opacity. Filters and painting tools affect these areas to a 
lesser degree than areas that are 100 percent selected. Click OK to 
apply the selection to the image.

Color Range options

Use this dialog box to select image 
areas based on color.

A Select. In the menu, choose the 
color (red, green, blue, cyan, magenta, 
yellow), or tonal range (shadows, mid-
tones, highlights) you want to select. 

To select a color interactively by 
clicking in the preview window, 
choose Sampled Colors.

B Fuzziness. When using the Sam-
pled Colors option, enter a low value to 
select a narrow color range; enter a 
higher value to select a wider range. 
C Choose Selection to preview the 
selection, with white representing se-
lected pixels, in the preview window. 
Choose Image to see the actual image 
so you can sample colors with the 
dropper.

D With Sampled Colors chosen (A), 
click the dropper in the preview win-
dow to select colors. Use the ‘+’ drop-
per to add to the selection; use the ‘-’ 
dropper to subtract from it.

E Selection Preview. Choose an op-
tion to preview the selection in the im-
age itself (or choose None for no pre-
view). Grayscale shows the selection 
as it would appear in a channel, with 
white for selected pixels and black 
showing non-selected areas. 

The Matte and Mask options show 
the original colors in selected areas. 
In non-selected areas, Black Matte 
shows black, White matte shows 
white, and Mask shows transparent 
red. 
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Selecting unselected areas
Use the Inverse command to simultaneously select all pixels not in 
the current selection while deselecting the current selection. 

• To select areas not included in the current selection:
Choose Image > Select > Inverse.

Expanding selections with Grow and Similar 
The Grow and Similar commands let you expand selections to 
include similar colors in an image. These commands compare the 
colors outside a selection to the colors in the selection. Colors that 
are in a specified range of similar colors are added to the selection.

The Grow command selects similar colors that are adjacent to the 
current selection. The Similar command selects similar colors 
throughout the image.

Note: The Grow and Similar commands are available for all image 
modes except Black & White. 

To use the Grow command
1 Ensure the image is in image edit mode. 

2 Select the Wand tool and click it on the area that you want to 
select (“To use the Wand tool,” page 26.5).

3 Choose Image > Select > Grow and similar colors that are 
adjacent to the current selection will be selected.

A moving dashed 
edge surrounds the 
parrot, a selected 
area

When the selection is 
inversed, the 
background becomes 
selected

Tip
The range of colors selected by 
Grow and Similar is based on the 
Tolerance setting in the Wand dia-
log box (see “To adjust the toler-
ance of the Wand tool,” 
page 26.5).

Tip
To select similar colors throughout 
an image, you can also use the 
Select throughout image checkbox 
in the Wand dialog box (see “To 
adjust the tolerance of the Wand 
tool,” page 26.5
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To use the Similar command
1 Ensure the image is in image edit mode.

2 Select the Wand tool and click it on the area that you want to 
select (see “To use the Wand tool,” page 26.5).

3 Choose Image > Select > Similar and similar colors through-
out the image will be selected.

You can repeat the Grow and Similar commands to continue 
expanding a selection. As more colors are added to the selection, 
more colors are in the range of colors similar to the selection. 
Therefore, even though the Tolerance doesn’t change, repeating 
Grow or Similar can expand a selection incrementally. 

Grow and Similar can help you isolate elements in an image, such 
as dark objects against a light background. Select part of one dark 
object with the Marquee tool. Choose Grow to expand the selection 
to the entire object. Choose Similar to expand the selection to all 
similar colors in the image.

Converting paths to selections
You can use vector objects and text to make selections in images. 
The Path to Selection command makes a selection in an image 
from the shape of a vector, text, or group object. 

With this command, you can outline irregular areas in images with 
drawing tools to make selections. You can make selections shaped 
like starbursts and other complex shapes that are easy to create 
with drawing tools. You can make selections from text characters 
without first converting the text to paths.

Original image Image after tapping Magic Wand on 
the indicated area and choosing 
Image > Select > Grow

Image after choosing Image > Select 
> Similar.
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The area selected by a vector or text object depends on whether the 
object has a visible fill ink and stroke.

• A filled object will select the area covered by the fill. If the 
object also has a visible stroke, the selection will include 
the area covered by the stroke.

• An unfilled object will select the area covered by just the 
stroke of the object.

• An object without a visible fill or stroke will not select any-
thing.

The type of fill ink or pen ink applied to an object is not significant 
for the selection it will make. However, the shape of the stroke is 
significant. A visible pen, dash, parallel, or neon stroke will affect 
the shape of the resulting selection. Also, the end caps, line joins, 
and arrows applied to a stroke will affect the selection.

To convert a path to a selection
1 Draw or position a vector or text object on a paint object 
where you want to make a selection. 

Note: If you want to preserve the vector or text object, make a copy 
of it; the object will be deleted when it is converted to a selection.

2 Select both the vector object and the paint object.

3 Choose Image > Path to Selection.

4 The vector or text object is replaced by a selection. The paint 
object is in edit mode and the selection is outlined by a dashed 
border.

Converting objects to paths
Most objects drawn with vector tools are paths that can be used to 
create selections in images. However, some objects must be con-
verted to paths first.

If an object does not create a selection when you choose Path to 
Selection, you might need to convert the object to a path by select-
ing the object and choosing Object > Path > Convert to Paths.

Working with image selections
After you make a selection, you can clear it, soften its edges, make 
it floating, move it, and change its opacity. 
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Clearing and copying a selection
You can replace the pixels in a selection with the current back-
ground color by pressing the Delete key, or by choosing Edit > Cut. 
(The Cut command also transfers the selection to the Clipboard.) 
Canvas replaces the selected pixels with the color currently dis-
played in the background color icon. Keep in mind that “deleting” 
a selection doesn’t leave a hole or transparent area in the paint 
object, unless the paint object has a visibility mask, as described 
later in this chapter. 

To place a copy of a selection on the Clipboard without clearing the 
area in the original image, choose Edit > Copy. When a selection 
has been placed on the Clipboard, you can paste it into another 
paint object in edit mode, where it will become a floating selection, 
or paste it into the document to create a new paint object.

Feathering the edges of a selection
You can feather (soften) the edges of a selection so that it blends 
more naturally into the original image. Use the Feather command 
to soften the hard edge of a selection and spread the selection over 
a larger area.

1 With a paint object in edit mode, make a selection and 
choose Image > Select > Feather. 

2 In the Feather dialog box, enter the number of pixels to 
feather the selection in the Radius text box. The larger the Radius 
value, the more Canvas softens the selection edge.

3 Click OK to feather the selection. 

Pasting into selections
The Paste Into command pastes the Clipboard contents into a 
selection in an image. This includes a selection in an image channel 
or a channel mask attached to an object.

The Paste Into command pastes anything that you copy to the Clip-
board, including a vector, text, or paint object, an image selection, 
or a segment of a vector object.

You can use Paste Into to composite images and create effects that 
would otherwise be difficult to produce. For example, to simulate a 
picture on a television screen in a photograph, you can select the 

Tip
If you want Canvas to recall a 
selection, be sure to save it before 
leaving edit mode. See “Saving 
and loading selections in chan-
nels” on page 26.17.
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screen area and paste an image into the selection. You can move 
the pasted image within the selection to adjust the area that you see.

You can paste transparent objects into opaque images, or opaque 
objects into transparent images. The background of the image 
determines the opacity of the pasted selection.

To paste into a selection
1 Place an object or selection on the Clipboard by choosing 
Edit > Copy or Edit > Cut.

2 Make a selection in an image (or a channel mask), and choose 
Edit > Paste Into. The Clipboard contents appear in the selection.

3 You can drag the pasted item or press the arrow keys on the 
keyboard to move it, to display the areas you want to see. When 
you finish adjusting the selection, deselect it to merge it into the 
image.

Floating and moving selections
You can move and manipulate a selection without affecting the 
original image by making it a floating selection. 

When a selection is floating, it sits on an invisible plane above the 
original image. When you type text in an image, or paste an object 
from the Clipboard, Canvas makes the text or pasted item a float-
ing selection. 

Object with a symbol fill ink Feathered selection Object pasted into selection

Tip
To float a selection and fill behind 
it with the background color, hold 
down Option (Mac) or Alt (Win-
dows) and choose Image > Select 
> Float.
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Moving a selection that is part of the original image creates a float-
ing selection, but also leaves behind an area filled with the back-
ground color.

• To float a copy of a selection: Make a selection in an image and 
choose Image > Select > Float. 

Deselecting and defloating selections
Deselecting a floating selection makes it part of the original image. 
To deselect a floating selection, press Esc or Enter twice (Mac) or 
Esc twice (Windows), or choose Image > Select > None.

• To make the floating selection part of the image but still retain the 
selection: Press Esc or Enter (Mac) or Esc (Windows) or choose 
Image > Select > Defloat.

Moving selections 
To move a selection, you can press the keyboard arrow keys or drag 
the selection with the Marquee, Lasso, or Wand tools. If a selection 
is not floating, it becomes floating when you move it. 

To keep the pointer from interfering with your view of a small 
selection, select the Remote Move tool in the Painting tool palette 
and drag it anywhere in the drawing area. Canvas moves the selec-
tion in the direction you move the pointer.

Changing the opacity of floating selections
You can change the opacity of a floating selection and make the 
pixels behind it partially visible. You can also change the mode to 
produce different effects. 

Note: You cannot make selections partially transparent in Indexed 
or Black & White image modes.

1 With a paint object in edit mode, select part of the image.

2 Click on the Background color icon in the Toolbox and select 
a color to use behind the floating selection. This color will start to 
appear when you make the selection transparent.

• To use the Floating Opacity slider in the Channels palette to light-
en a floating selection: Fill behind the selection with white or a light 
color.

Dragging a selection floats it and 
leaves an area filled with the current 
background color (A).

Remote Move tool

Floating Opacity slider in the 
Channels palette
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3 Hold down the Option key (Mac) or Ctrl key (Windows) and 
choose Image > Select > Float. Canvas floats the selection and fills 
behind it with the background color.

4 Choose Image > Show Channels to open the Channels pal-
ette. Set the Floating Opacity value to less than 100 percent to 
make the selection become transparent and reveal the back-
ground color behind the selection.

5 To change the mode, choose a new mode from the Mode 
menu.

Modifying selections
You can use the Expand, Contract, Smooth, and Border com-
mands to modify selections in images. 

These commands make it easy to fine-tune a selection by expand-
ing or contracting the selection border by a specified number of 
pixels, or by adding or subtracting pixels based on color.

Expanding a selection
You can expand a selection by adding a specified number of pixels 
to the selection border.

• To modify an active selection: Choose Image > Select > Modify 
> Expand. Type a value in the Radius text box and click OK. Can-
vas adds the specified area to the selection. 

Contracting a selection
You can shrink a selection by subtracting a specified number of pix-
els from the selection border.

• To modify an active selection: Choose Image > Select > Modify 
> Contract. Type a value in the text box and then click OK. Canvas 
subtracts the specified area from the selection and the dashed bor-
der contracts.

Smoothing a selection
The Smooth command is useful after you have made a color-based 
selection that has left stray pixels inside or outside of the selected 
area. The Smooth command includes or eliminates the stray pixels 
to even out the selection. The value you type in the text box deter-
mines which pixels will be included or excluded in the selection at 
the border.
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• To modify an active selection: Choose Image > Select > Modify 
> Smooth. Type a value in the text box and then click OK. Canvas 
adds or subtracts pixels to the perimeter of the selection based on 
the radius number of pixels you specified.

Bordering a selection
After you define a selection, you can select the area at the border of 
the selection by specifying an offset in pixels from the selection 
edge. 

• To modify an active selection: Choose Image > Select > Modify 
> Border. Type a value in the text box and click OK. Two dashed 
borders indicate the selected border.

Once you make a selection, you can use the Grow command or the 
Similar command to expand the selection to include similar colors.

Creating objects from selections
You can make new paint objects from image selections with the 
New Image from Selection command. This command converts a 
selection in an image into a new paint object in the same position 
on the image you are editing. This can be useful for “layering” 
image compositions.

The result of New Image from Selection is similar to moving a 
selection to a transparent “layer,” a procedure used in some image 
editing programs. In Canvas you can use separate transparent paint 
objects to create “layered” image compositions.

Note: This operation doesn’t affect the Clipboard contents.

• To create a paint object from a selection: With a selection in an 
image, choose New Image from Selection in the context menu. To 
display the context menu, right-click (Windows) or Ctrl-click (Mac) 
within the selection. 

New images from selections and floating selections
When you choose New Image from Selection, Canvas removes the 
selection from the image or deselects the selection in the image. 
The selection appears as a new paint object in the same location. 

Whether a selection is removed from an image depends on whether 
the selection is floating. The opacity of the resulting object also dif-
fers for floating and non-floating selections.
.14 SELECTIONS & CHANNELS



If a selection is not floating, Canvas deselects it but otherwise 
doesn’t change the original image when you create an object from 
the selection. The selected pixels keep their original opacity in the 
new object.

If a selection is floating, Canvas removes the selection. The effect is 
the same as deleting a selection: the background color replaces the 
selected pixels, or, if the object has a visibility mask, a clear back-
ground replaces the selected pixels. In the new object, the pixels are 
opaque, regardless of their original opacity.

Clear backgrounds in new paint objects
A paint object created from a selection always has a clear, rather 
than opaque background, and a visibility mask. 

Paint objects are rectangular. If a selection is not rectangular, Can-
vas places the selection on a clear background. This is why creating 
a paint object from a selection is like transferring the selection to a 
clear overlay on the original image. 

If you select Preserve Visibility in the Channels palette, a visibility 
mask preserves the transparency of all pixels in the image. You can 
paint or use filters without affecting clear areas.

If Preserve Visibility is not selected, you can erase to a clear back-
ground and affect all pixels by painting and editing.

Converting selections to paths
Canvas can trace a selection in an image to create a path (vector 
object) from the selection border. The Selection to Path command 
traces the active image selection border using the settings you spec-
ify. This is useful if you want to convert a selection border to a vec-
tor object that can be used as a clipping path, for example. 

The accuracy of a path made from a selection depends on the set-
tings you specify and the complexity of the selection border. A very 
complex selection border can result in a path with hundreds of 
anchor points, which can cause problems in printing and other 
operations.

Paths created from selections have no fill ink, black pen ink, and 
the current stroke setting.

To convert a selection to a path
1 Make a selection in an image.
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2 Choose Image > Selection to Path.

3 Choose the settings you want and click OK (see “Selection to 
Path options,” page 26.16). The selection in the image is dese-
lected and a new vector object (or group of vector objects) appears 
in front of the paint object.

Selection to Path options
A dialog box presents the following options when you use the Selec-
tion to Path command.

Mask Set Threshold If a selection edge is feathered, this value 
defines the edge of the selection for tracing based on selection mask 
opacity. Enter a value from 1 (nearly transparent) to 255 (opaque). 
These values correspond to the lightness of pixels for a selection 
saved as a mask in a channel.

Pixels in the selection mask that are more opaque (lighter) than the 
threshold value are treated as opaque and part of the selection. Pix-
els that are less opaque (darker) than the threshold value are treated 
as transparent and outside the selection. At a threshold of 1, the 
entire feathered edge will be part of the selection. At 255, only the 
completely opaque part of the selection will be included.

If a selection is not feathered, this value has no effect.

Curves / Polygons Choose Curves to create paths with smooth 
anchor points and curve segments as appropriate. Choose Polygons 
to create paths with straight segments only. The Curves option can 
result in smoother paths with fewer anchor points when the selec-
tion border has curves.

Loose /Tight Drag the slider to set the tolerance for tracing irregu-
larities in the selection border. Loose follows the selection border 
less precisely (more smoothly) and creates fewer anchor points. 
Tight follows the selection border more precisely (less smoothly) 
and creates more anchor points.

Round /Sharp Drag the slider to set the tolerance for tracing cor-
ners in the selection border. Round creates rounder corners, Sharp 
creates sharper corners.
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Saving and loading selections in channels
When you have made a selection in an image, you can create an 
alpha channel from the selection. An alpha channel preserves the 
shape and opacity of a selection, so you can use it to make the same 
selection in the image again.

You can think of an alpha channel as a mask that selects some areas 
and protects other areas from painting and image editing. Because 
alpha channels make precise selections of varying intensities, alpha 
channels let you control which areas in an image will be affected by 
painting tools and filters, and the intensity of the effects.

When you view an alpha channel, you see a grayscale image. When 
the channel is made from a selection, it contains white areas repre-
senting fully selected pixels, black areas representing unselected 
pixels, and gray areas representing pixels that are partially selected, 
with the gray lightness values corresponding to the selection opac-
ity.

This section describes how to save a selection in a channel, and how 
to load a channel to make a selection in an image, using dialog 
boxes. You can also use shortcuts in the Channels palette, as 
described under “Channels palette options” on page 26.21.

To save a selection in a channel
1 With an active selection in an image, choose Image > Select > 
Save.

2 In the Operation area of the Save Selection dialog box, select 
New Channel and click OK.

You can also click the Selection button in the Channels palette to 
save the current selection in a new channel.

To load a selection from a channel
1 With a paint object in edit mode, choose Image > Select > 
Load. 

2 In the Load Selection dialog box, choose a channel name in 
the Channel pop-up menu. To invert the selection, click Invert. 
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3 Choose an option in the Operation area and click OK.

Preserving channels in exported images
Canvas image channels are compatible with the alpha channels 
used in other image-editing programs, including Adobe Photoshop. 
However, you must use the correct procedure to preserve alpha 
channels when you export an image into Photoshop format.

If you want to export an image into Photoshop format and preserve 
the image’s alpha channels, be sure to choose Image > Export, 
rather than the Save As command.

If you use the Save As command and choose Photoshop format, the 
resulting file will not contain the alpha channels associated with the 
image.

To export an image with alpha channels
1 Select the paint object in the Canvas document.

2 Choose Image > Export > Photoshop. A directory dialog box 
appears.

3 Specify a location to save the file, type a file name, and click 
Save to export the selected image as a Photoshop file.

Understanding image channels
Canvas uses up to 24 channels to store the digital information that 
makes up the image in a paint object. 

There are three types of channels: color or image channels, alpha 
channels, and channel masks. All images have at least one channel. 

Option Result

New Selection Removes any current selections and creates a new 
selection

Add to Selection Preserves the current selection and selects additional 
pixels based on the channel

Subtract from Selection Removes pixels from the current selection based on 
the channel

Intersect with Selection Creates a new selection composed of pixels that 
appear in both the current selection and the channel 
you are loading
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An image can also contain one or more alpha channels and a single 
channel mask, if you create them.

The Channels palette displays the channels of an image. Whenever 
an image is in edit mode, you can use the Channels palette to select 
and edit channels. 

• To display the Channels palette: Choose Image > Show Chan-
nels.

Vector objects and text objects do not have color or image chan-
nels. However, you can create a channel mask for any object. If an 
object has a channel mask, you can place the channel mask in edit 
mode, and use the Channels palette to work with the channel mask 
and create alpha channels. Alpha channels are stored with an 
object as long as the object has a channel mask.

Color channels
Images in RGB Color, CMYK Color, and LAB Color mode have 
separate color channels. A color channel stores one component of 
the image; e.g., in CMYK Color mode, the Magenta channel stores 
the magenta parts of the image. This channel contains the image 
that would appear on the magenta plate if you output color separa-
tions.

A paint object’s image mode determines the number of color chan-
nels. RGB Color images have Red, Green, and Blue color channels. 
CMYK Color images have Cyan, Magenta, Yellow, and Black chan-
nels. LAB Color images have Lightness, A, and B channels.

In the Channels palette, a composite channel appears above the 
color channels. The composite channel represents the complete 
image — the composite of the image’s color channels. The compos-
ite channel is labeled RGB, CMYK, or LAB, depending on the 
image mode.

Other image modes do not have separate color channels. Images in 
Black & White, Duotone, Indexed, and Grayscale mode have a sin-
gle image channel.

Alpha channels
Alpha channels are channels you can use to store and edit selec-
tions in any image. Because alpha channels are used for image 
selections, they are also referred to as “selection masks.” 
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After you make a selection in an image, you can save the selection 
in an alpha channel. Later, you can load the channel to make the 
same selection.

An alpha channel is a grayscale channel that is the same size and 
resolution as the paint object in which it is stored. Pixels in alpha 
channels can range in lightness from 0 (black) to 255 (white). The 
lightness levels of pixels in an alpha channel correspond to a range 
of selection levels.

Black pixels in an alpha channel correspond to masked, or non-
selected, pixels in an image. White pixels correspond to selected 
pixels. Gray pixels correspond to various levels of selection, with 
lighter grays corresponding to greater selection than darker grays. 

Note: If you want black pixels to correspond to selected, rather than 
masked pixels, click Selected Area in the New Channel or Channel 
Options dialog box.

Using the Channels palette
The Channels palette displays the channels contained in a paint 
object when the paint object is in edit mode. The palette also dis-
plays the channels contained in any object that has a channel mask 
when you edit the mask.

You can use the palette to create, duplicate, and delete channels; to 
change channel options; and to make selections by loading chan-
nels.

• To open the Channels palette: Choose Image > Show Channels.

Composite channel Select the first channel in the palette to make 
all color channels visible and active. Paint objects in CMYK Color, 
RGB Color, and LAB Color modes have composite channels. The 
channel is labeled “CMYK” for a CMYK Color image, “RGB” for 
an RGB Color image, and “LAB” for a LAB Color image.

Paint objects in Indexed, Grayscale, Black & White, and Duotone 
modes have single channels. A vector object that has a channel 
mask has an “object channel.”

Color channels Color channels appear below the composite chan-
nel in the Channels palette. Color channels store the color data in 
an image. The image mode determines the number of color chan-
nels. CMYK Color images have Cyan, Magenta, Yellow, and Black 
color channels. RGB Color images have Red, Green, and Blue 
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color channels. LAB Color images have “A” and “B” color channels 
and a Lightness channel. Multichannel images have numbered 
channels that contain grayscale pixels only.

Alpha channels Alpha channels contain grayscale pixels which 
can represent a selection. You can use alpha channels to create 
channel masks. Any paint object can have alpha channels. How-
ever, paint objects in Black & White mode must have a channel 
mask before they can contain alpha channels.

Channel mask 
A special channel you can add to any object, a channel mask con-
tains grayscale pixels that represent transparency. Drag a color or 
alpha channel to the channel mask slot to create a channel mask. 
You can drag a channel mask into the channel list to create a new 
alpha channel.

Viewing previews in the Channels palette
To view previews in the Channels palette, choose Palette Options 
in the palette’s pop-up menu. Click the size of the preview you want 
to display, or click None. Click OK to close the dialog box.

Channels palette options

Use the Channels palette to work with 
channels when a paint object is in edit 
mode.

Active channels are shaded. Editing 
affects the active channels only. To 
make a channel active, click the chan-
nel name.

A Composite channel. Select this 
channel to make all color channels visi-
ble and active.
B Color channels. Color channels ap-
pear below composite channels. 
C Alpha channels. Alpha channels 
contain grayscale pixels which represent 
a selection.
D Channel mask. A special channel 
you can add to any object, a channel 
mask contains grayscale pixels that rep-
resent transparency.
E An eye indicates that a channel is 
visible. If a channel is not visible, click or 
drag in the column to make it visible.

F Click to make a new alpha 
channel with default settings. Drag 
an alpha channel here to duplicate it.
G Click to save the current selec-
tion in an alpha channel. Drag a 
channel here to make a selection in 
the image from the channel.

Floating Opacity. If a selection is 
floating, drag the slider to change 
the opacity of the selection.

Mode. If a selection is floating, 
select a mode from the menu. The 
default mode is Normal.

H Drag channels to the trash to 
delete them. You cannot delete color 
channels.

Preserve Visibility. Select this 
option to preserve the transparen-
cy of clear and partially transparent 
pixels when you edit an image.
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Channel palette pop-up menu
The following commands appear in the Channel palette’s menu. 

Palette Options Lets you select the channel preview size.

New Channel Creates a new alpha channel and lets you select 
channel options.

Duplicate Channel Creates a new alpha channel from a single 
active color or alpha channel. This command isn’t available if a 
composite channel or more than one channel is active.

Delete Channel Deletes the active alpha channel. You can’t delete 
color channels or a composite channel.

Channel Options Lets you specify options for the active channel. 
You can change the name, mask tint color, and opacity of an alpha 
channel. You also can double-click a channel to set options for it.

Working with alpha channels
To add to the current selection, Shift-drag a channel to the button. 

To subtract from the current selection, Command-drag (Mac) or 
Ctrl-drag (Windows) a channel to the button. 

To select the intersection of a channel and the current selection, 
press Command+Shift (Mac) or Ctrl+Shift (Windows) and drag a 
channel to the button.

Creating and deleting channels
You can create and delete channels in the Channels palette. Open 
the Channels palette by choosing Image > Show Channels. 

Alpha channel; white 
indicates selected area

Alpha channel loaded as 
selection (in color)

Applied blend affects 
selected area only

Original image
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To create an alpha channel
1 With a paint object in edit mode, choose New Channel in the 
Channels palette menu (see “Channel palette pop-up menu,” 
page 26.22).

2 In the New Channel dialog box, select options for the new 
channel and click OK (see “To specify channel options” on 
page 26.23).

Deleting alpha channels 
Although Canvas can store up to 24 channels in an image, you 
might want to delete unnecessary ones to save memory and disk 
space. You can delete alpha channels and channel masks, but you 
cannot delete color channels.

• To delete an alpha channel: With an object in image edit mode, 
drag the alpha channel you want to delete to the trash can icon at 
the bottom of the Channels palette

Customizing alpha channels
You can change an alpha channel’s name, color indication, and 
mask tint opacity in the Channel Options dialog box. By default, 
Canvas numbers alpha channels, sets the mask tint opacity to 50%, 
and assigns a mask color.

Note: Canvas provides the mask color and opacity settings in the 
Channel Options dialog box as visual aids only. These settings do 
not affect the original image or channel.

To specify channel options
1 With a paint object in edit mode, choose Image > Show Chan-
nels to open the Channels palette.

2 Click an alpha channel and select Channel Options in the pop-
up menu, or double-click the channel you want to edit to open the 
Channel Options dialog box.

3 Enter a new name in the Name field to rename the channel. 

Color Indicates These options control whether white or black pix-
els in the channel will select pixels in the image when you load the 
channel. 

• If you want white pixels in the channel to indicate selected 
pixels, choose Masked Area. 
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• If you choose Selected Area, the normal operation of the 
channel will be inverted, so that black pixels in the chan-
nel will select pixels when the channel is loaded. If you use 
this option, keep in mind that the channel will make selec-
tions that are the inverse of normal channel selections.

• To change the mask tint color for the channel: Select a color 
from the Color pop-up menu. Canvas displays the tint when an 
alpha channel and at least one other channel are visible. 

• To change the opacity of the tint color: Enter a value from 1 to 
100% in the Opacity text box.

4 Click OK after entering the settings you want.

Activating channels
To edit a channel, click the channel name in the Channels palette 
to make it active. Canvas uses shading to indicate that a channel is 
active. 

• You can make more than one channel active by Shift-click-
ing the names of the channels in the palette. 

• To make a channel visible but not active, click the left col-
umn to make an eye icon appear. 

• You can make more than one channel visible by dragging 
in the left column in the Channels palette.

To make all color channels in an image both visible and active, 
click the composite channel in the Channels palette. The composite 
channel always appears first at the top of the Channels palette.

Editing an alpha channel
You can apply painting tools, filters, and effects to the image in an 
alpha channel. By editing the image, you can adjust what the chan-
nel will select when you load it as a selection.

Tip
Painting tools and filters affect 
active channels only.
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1 With an image in edit mode, choose Image > Show Channels.

2 Create a new channel to use as a selection mask by doing one 
of the following:

• If you have a selection in the image that you want to cus-
tomize by editing in a channel, use the Save command to 
create a channel from the selection (see “To save a selec-
tion in a channel” on page 26.17).

• To start with a “blank” alpha channel, use the New Chan-
nel command. Be sure to choose the Masked Area option 
under Color Indicates in the New Channel dialog box.

3 In the Channels palette, click the new channel to activate it. 
The channel appears shaded in the palette and the image changes 
to show only the channel. Now click in the left column of the first 
(composite) channel. The original image appears with a transpar-
ent colored “mask” on the image. The color mask indicates the 
areas that will be masked — not selected — by the channel.

4 Use painting tools or filters to edit the image in the channel. 
The changes you make affect the active channel only. 

5 Load the channel by choosing Image > Select > Load to make 
a selection with the channel. 

6 Choose the channel name in the pop-up menu and then click 
OK.

Channel masks
Channel masks apply transparency effects to objects, including 
paint objects, vector objects, text objects, and group objects. A 
channel mask creates transparency in proportion to the luminance 
of its image. 

A channel mask is a grayscale image channel. Black pixels in a 
channel mask produce 100% transparency in corresponding areas 
of the masked object. White pixels in a channel mask produce 0% 
transparency in the masked object. Gray pixels in a channel mask 
produce partial transparency in the masked object. Darker grays 
produce greater transparency than lighter grays.

Channel masks are powerful because they let you use painting and 
image-editing techniques to create transparency effects, and 
because a channel mask can be applied to any type of object. An 
object’s channel mask is the same size as its bounding box. You can 

Canvas displays a shaded mask 
representing an alpha channel 
when the alpha channel and the 
composite channel are visible

Shaded mask
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detach or delete an object’s channel mask to eliminate the transpar-
ency effect.

Creating channel masks
Use the mouse, New Channel Mask command, Sprite tool, Trans-
parency palette, or Channels palette to make channel masks.

To create a channel mask
Do one of the following:

• Option+double-click (Mac) or Ctrl+double-click (Win-
dows) the object to be masked.

• Select the object to be masked and choose Object > Trans-
parency > New Channel Mask. 

• Click on the object with the Sprite tool.

• Select the object to be masked. In the Transparency pal-
ette, choose Channel in the Mask menu. 

Canvas creates the channel mask and puts the new mask in edit 
mode.

• If the object is a paint object, Canvas creates a channel 
mask with the same resolution as the paint object.

• If the object is a vector, text, or group object, the New 
Mask dialog box appears. Type the resolution you want 
for the channel mask and click OK. Canvas creates the 
channel mask with the specified resolution. 

To use the Channels palette
You can create a channel mask for a paint object from an existing 
alpha channel or color channel.

With a paint object in edit mode, drag an alpha channel into the 
channel mask slot in the Channels palette. If the slot already con-
tains a channel mask, the channel you drag there replaces the exist-
ing channel mask.

Editing channel masks
You can edit an object’s channel mask to change the transparency 
effects it produces. Generally, you can do anything that you can 
when editing a color channel, alpha channel, or grayscale image: 
use painting tools, filters, and image-adjustment commands, make 
selections, and paste selections into a channel mask.
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To edit a channel mask
Do any of the following to place a channel mask in edit mode:

• Option+double-click (Mac) or Ctrl+double-click (Win-
dows) the masked object. 

• Select the masked object and choose Object > 
SpriteLayers > Edit Channel Mask.

• Select the masked object and click Edit in the Transpar-
ency palette.

An eye symbol in the Channels palette appears to the left of a chan-
nel that is visible. The eye symbol disappears if a channel is hidden.

When you edit a channel mask, the top channel in the palette repre-
sents the object itself. For a typical paint object this channel is 
labeled with the image mode, such as RGB or CMYK. For other 
objects, the first channel is labeled “Object” (see “Transparency 
masks,” page 35.5).

The channel mask of an object in edit mode is shown in the Chan-
nel Mask slot, which is below the channel list.

• To view the channel mask only: Click the eye symbol next to the 
object or composite channel at the top of the channel list. This 
hides the object channel so only the channel mask is visible.

• To hide the channel mask: Click the eye symbol next to the 
channel mask. This hides the effect of the channel mask on the 
object.

At least one channel, either the composite/object channel or the 
channel mask, must be visible. If only one is visible, you can’t hide 
it by clicking its eye symbol.

• To display a hidden channel: Click to the left of the channel to 
restore the eye symbol.

Note: When you edit paint objects you can edit pixels in the images 
by selecting channels in the Channels palette. However, when you 
edit other objects, you can’t select the “object” channel. You can 
show or hide the object channel, but you can edit pixels only in the 
channel mask.

When you finish editing a channel mask, press Esc to leave edit 
mode.
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Detaching and deleting channel masks
If an object has a channel mask, the channel mask controls the 
transparency of the object. You might want to detach or delete the 
channel mask to eliminate the transparency effects from the object. 

When you delete a channel mask, it no longer exists in the docu-
ment. When you detach a channel mask, it appears in the docu-
ment as a separate grayscale paint object.

• To detach a channel mask: Select the masked object. Choose 
Object > Transparency > Detach Mask. 

When you detach a channel mask, Canvas removes the channel 
mask from the object and places it in the document as a separate 
grayscale paint object. If the channel mask was detached from a 
vector object, the resulting paint object will contain any alpha chan-
nels that were contained in the vector object.

To delete a channel mask
1 Select the masked object. 

2 In the Transparency palette, choose None in the Mask pop-
up menu.

Note: Deleting the channel mask of a vector, text, or group object 
also deletes any alpha channels that were contained in the object. 
Also, if you ungroup a group object that has a channel mask, Can-
vas deletes the channel mask.

You can delete a paint object’s channel mask when the paint object 
is in edit mode by dragging the channel mask to the trash can icon 
at the bottom of the Channels palette.

Transparency effects with channel masks 
Channel masks let you add transparency to images without altering 
them permanently. A channel mask creates transparency without 
changing any pixels in an image. You can remove a channel mask 
to eliminate the transparency effect at any time.

To make an image transparent
To make parts of an image transparent — to eliminate the back-
ground in a photograph, for example — you can create a channel 
mask from a selection. This procedure explains how to transfer a 
selection into a channel mask to make selected areas transparent. 
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1 Choose Image > Show Channels to open the Channels pal-
ette. Double-click the paint object to put it into edit mode. You 
can use various techniques to select the areas you want to be 
transparent:

• You can click the Wand tool to select similar colors 
throughout the image. If a photograph has a colored back-
ground, for example, click the background to select it. You 
can also use the Color Range command to make a selec-
tion.

• To soften the edges of the selection, you can use the Image 
> Select > Feather command.

2 Click the Selection button in the Channels palette to save the 
selection in a new alpha channel. In the alpha channel, white pix-
els correspond to the selection. (A partial selection produces gray 
pixels in the channel). Black pixels in the channel correspond to 
unselected areas of the image. To create transparent areas from 
the selection, you need to invert the channel.

3 Press Esc to deselect the selection in the image. Then, click 
the alpha channel in the Channels palette to make it active. 

4 Choose Image > Adjust > Invert. This reverses the white and 
black areas in the channel.

5 Drag the alpha channel into the Channel Mask slot in the 
Channels palette. Black areas in the channel mask produce trans-
parent areas in the image. White areas in the channel mask pro-
duce opaque areas in the image. 

6 Press Esc to exit image edit mode. The selection you made is 
now transparent. If you place the paint object on a background in 
your document, the background will be visible through the trans-
parent areas of the image.

To create a transparency fade
You can create a transparent fade effect using a channel mask. This 
procedure explains how to create a blend in an alpha channel, and 
then create a channel mask to make an image fade to transparency.

1 Choose Image > Show Channels to open the Channels pal-
ette. Double-click a paint object to put it in edit mode.

Drag a channel into the Channel 
Mask slot
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2 Click the New Channel button in the Channels palette. A 
new alpha channel appears in the palette. Click the channel to 
make it active. 

3 Select the Blend tool. With the foreground color set to white 
and the background color set to black, drag vertically from top to 
bottom in the channel. This creates a blend from white to black. 

• You can change the distance that you drag the Blend tool 
in the channel to adjust the length and position of the fade 
to transparency.

• You might need to use the Blend settings in the Properties 
bar to select the Linear option for the Blend tool before 
you create the blend in the alpha channel. You can also set 
other options for the Blend tool to fine-tune blends.

4 Drag the alpha channel into the channel mask slot in the 
Channels palette. White pixels at the top of the channel produce 
opaque areas. Black pixels produce completely transparent areas. 
Gray pixels in the channel mask correspond with partially trans-
parent areas in the image.

To create a channel mask by rendering
Canvas can create a channel mask when you render a vector, 
group, paint, or text object. To create the mask, choose the Mask 
and Transparency options in the Render dialog box. Canvas will 
create a channel mask that makes blank areas around and inside 
the objects transparent.

When you make a new paint object by pasting a non-rectangular 
selection copied from an image, Canvas makes a channel mask to 
hide white pixels surrounding the selection.

Channel mask from
alpha channel

VignetteOriginal
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Preserving transparency in images
Select the Preserve Visibility checkbox in the Channels palette to 
preserve transparency when you paint or apply filters to an image. 
The Preserve Visibility checkbox is available when you edit a paint 
object that has a visibility mask. A paint object has a visibility mask 
if it was created with a transparent background, or if you applied a 
visibility mask with the Add Visibility Mask command. 

If a paint object has an opaque background, the Preserve Visibility 
checkbox is disabled. 

To preserve transparency while editing an image
When a paint object is in edit mode, select Preserve Visibility in the 
Channels palette. When selected, you can paint and edit the image 
without affecting clear areas or reducing the transparency of par-
tially transparent pixels.

The Preserve Visibility option affects all aspects of image editing. 
When Preserve Visibility is selected, pasted selections do not affect 
clear areas. Also, a pasted selection will match the transparency of 
the existing pixels when you defloat the selection. 

You must deselect Preserve Visibility to paint in clear areas of an 
image. Then, if you want to edit the painted areas, select Preserve 
Visibility again. 

For example, you can deselect Preserve Visibility and paint air-
brush strokes in a clear image. Then, select Preserve Visibility and 
you can paint over the airbrush strokes to change their color, with-
out losing the soft edge or “spilling” color into clear areas.

When Preserve Visibility is selected and you use the Eraser tool, 
pixels you “erase” are painted with the current background color; 
they are not erased to clear. Also, when you use any painting tool to 
apply color, you cannot make pixels more or less transparent. This 
is why you cannot apply any color in clear areas when Preserve Vis-
ibility is selected. 

When you select Preserve Visibility, you can paint and apply filters 
to modify pixels that are less than 100% transparent. You can 
change the hue, saturation, and intensity of pixels but can’t change 
their transparency.

• To paint or apply filters to an entire image: Deselect Preserve 
Visibility. This turns off the visibility mask and lets painting tools 
and filters affect the entire image.

Tip
If an image is completely clear 
(contains no colored pixels), you 
cannot alter the image when Pre-
serve Visibility is selected.
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IMAGE FILTERS & EFFECTS

Canvas provides commands that you can use to transform images 
for a variety of effects. These commands can be used to alter entire 
images or only selected areas, as well as image channels.

The commands in the Image > Filter menu are often called “filters” 
because they “filter” images or selections pixel-by-pixel. This chap-
ter explains how to use these filters as well as other commands in 
the Image menu.

Note: The Filters menu is also located in the Properties bar for quick 
access to image effects.

Applying effect filters
You can use the Render, Stylize, and Offset filters to transform 
images. The Render filters apply forms or textures to an image. 
The Stylize filters apply a conceptual effect to an image. Stylize fil-
ters include Emboss, Trace Contour, and Solarize. The Offset filter 
shifts the pixels within an image.

Rendering clouds
You can apply texture to areas in an image, such as skies or walls, 
by applying the Clouds filter. The Clouds filter renders soft swirls 
of color using the foreground and background colors. 

Note: The Clouds filter completely replaces the original image or 
selection.

To apply the Clouds filter to an image
1 Select one or more paint objects to adjust all the images. You 
can select an area in one image in edit mode to adjust the selected 
area only. If you don’t make a selection, the entire image in edit 
mode is affected. This filter doesn’t work with paint objects in 
Black & White mode, and Indexed mode. 

Image with translucent clouds
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2 Choose Image > Filter > Render > Clouds or use the Filter 
menu located in the Properties bar. 

Rendering a color wheel 
Fill a selection with a radial blend of colors by choosing Image > Fil-
ter > Render > Wheel. The rendered effect looks like the color 
wheel preview in the Hue/Saturation dialog box. The Wheel filter 
works with paint objects in RGB Color and CMYK Color.

Unless you make a selection in the image, the Wheel filter replaces 
the entire image. If you want to apply a translucent wheel effect, fol-
low the steps for the procedure “Applying Clouds filter to selec-
tions” on page 27.2, but in the seventh step, choose the Wheel 
command. 

Applying Clouds filter to 
selections

1 With a paint object in edit mode, 
choose Image > Show Channels to 
open the Channels palette. 

2 Select a color channel that shows 
the most contrast.

3 Drag the selected channel to the 
new channel button to create a copy of 
the channel. The channel copy is in 
black & white.

4 Select the channel copy in the 
Channels palette and double-click to 
open the Channel Options dialog box.

5 Enter a name for the channel copy 
in the dialog box.

6 With the painting tools, apply white 
to the areas where clouds are to ap-
pear. Apply black to the area where 
clouds won’t appear. 

7 Select the composite channel to 
make it active. 

8 Choose Image > Select > Load. Se-
lect the channel copy that you edited. 
The white area appears as a selection.

9 Select your background and fore-
ground colors in the Inks palette. The 

colors you select determine the cloud 
color. 

10 Choose Image > Filter > Render > 
Clouds to affect the selected area.

Original image Color channel 
selected

Final image

Painted channel 
copy

Composite channel with 
channel loaded 
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Embossing an image
Make an image appear raised with the Emboss filter. This filter 
converts low-contrast areas to gray and accentuates high-contrast 
areas with color (or black and white if the image is Grayscale mode) 
according to the placement of a theoretical light source. The 
Emboss filter doesn’t work with paint objects in Black & White 
mode, and Indexed mode.

To apply the Emboss filter
1 Select one or more paint objects to emboss. To apply the 
emboss filter to a limited area in one image, select the area. 

2 Choose Image > Filter > Stylize > Emboss or use the Filter 
menu in the Properties bar.

3 Enter an Angle from 0 to 360. An angle of 0 is straight right 
with higher numbers going counter-clockwise.

4 Enter a height from 1 to 32 pixels to set the height of the 
effect.

5 Enter a number from 1 to 500 in the Amount text box. To 
retain more color along high-contrast borders, increase this value.

Solarizing images
Create surrealistic effects in an image by applying the Solarize fil-
ter. The Solarize filter mimics a photographic darkroom procedure 
that exposes film to light during development.

Solarize CMYK Color, RGB Color and Grayscale mode images. If 
you make a selection, Canvas filters only selected pixels.

Embossed Angle = 15 Height 
= 8, Amount = 110

Original 

Adjust the Angle, 
Height, and Amount 
individually by 
dragging the 
sliders...

...or drag the handle 
to set the Angle, 
Height, and Amount 
values 
simultaneously
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To solarize an image
1 Select one or more paint objects to solarize. To apply the 
Solarize filter to a limited area in one image, select the area. 

2 Choose Image > Filter > Stylize > Solarize or use the Filter 
menu in the Properties bar. 

Outlining areas based on color value
With the Trace Contour filter, you can outline image areas that 
border a particular color. This filter makes color outlines if you are 
working with a color image, and black outlines if you are working 
with a Grayscale mode image. This command doesn’t work with 
paint objects in Black & White mode, and Indexed mode.

To use the Trace Contour filter
1 Select one or more paint objects to adjust all the images. You 
can select an area in one image in edit mode to adjust the selected 
area only. If you don’t make a selection, the entire image in edit 
mode is affected. 

2 Choose Image > Filter > Stylize > Trace Contour or use the 
Filter menu in the Properties bar.

3 Enter a Level value from 0 to 255. The Trace Contour filter 
uses this color brightness value to determine the areas to trace.

4 Select Upper or Lower in the Edge area. To outline areas 
with higher brightness levels than the one specified, choose 
Upper. Choose Lower to outline areas with lower brightness lev-
els.

5 To see the effect of the settings, turn on Preview. When the 
settings are correct, click OK.

Original Solarized
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Offsetting selections
You can shift an image area with the Offset filter. Canvas fills the 
vacated area with color, duplicated pixels, or parts of the offset 
area.

To offset image areas
1 With an image in edit mode, select an image area. 

2 Choose Image > Filter > Other > Offset or use the Filter 
menu in the Properties bar.

3 Enter horizontal and vertical offset amounts in pixels. Posi-
tive values result in offsets to the right and down; use negative 
numbers (preceded by a minus sign) to offset up and left.

4 Choose an option under Undefined Areas. 

Choose this option For this effect

Set to Background Fills area with the background color 

Repeat Edge Pixels Duplicates edge pixels until they fill the area vacated 
by the offset 

Wrap Around Moves pixels cut off by the offset into the vacated area 

Original Level =169 
Edge = Lower

Level =169 
Edge = Upper

Original Set to Background Repeat Edge Pixels Wrap Around
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5 Turn on Preview to see the effect of the settings. 

6 Click OK when the settings are correct.

Ripple effects
With the Ripple filter, create the impression of ripples in an image, 
like the ripples made by dropping a stone into smooth water. By 
varying the controls in the Ripple dialog box, produce a range of 
effects in an image, from slight rippling to extreme distortion. 

To apply the Ripple filter
1 Select a paint object. To limit the effect to a particular area, 
select the area where you want to apply the filter. If you don’t 
make a selection, the filter affects the entire image.

2 Choose Image > Filter > Other > Ripple or use the Filter 
menu in the Properties bar. 

3 Adjust the settings in the Ripple dialog box, and then click 
OK to apply the settings and close the dialog box. 

Ripple settings
Adjust the following settings in the Ripple dialog box.

Spin The Spin value controls the effect of swirling the image 
around its center point. Type a number from -100 to 100 or drag 
the slider to set the amount and direction of spin. Positive numbers 
generate a clockwise spin; negative numbers generate a counter-
clockwise spin. Larger values (positive or negative) increase the 
amount of swirling. If Spin is zero, the filter creates no ripples in the 
image and none of the other controls produces an effect.

Frequency The Frequency value affects the number of “waves” 
created in the image. Enter a number from 0 to 50. A high number 
creates more small waves; a low number creates fewer large waves. 

Clustering The Clustering option can create interesting interfer-
ence patterns in combination with some Frequency values. In gen-
eral, Frequency values of 15 to 50 and Spin values of 25 and higher 
are most effective. Enter a Clustering value of 0 to 30. The higher 
the Clustering value, the more interference ripples appear between 
the main waves.

Wave Decay The Wave Decay value softens the effect of the Fre-
quency setting by dampening or stretching the waves away from 
the center of the image. The closer a wave is to the center of the 
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image, the less it is stretched. Wave Decay creates the impression of 
blending the waves farthest from the center of the disturbance, 
especially when Include Corners is selected. 

Enter a Wave Decay value of 0 to 100. The higher the value, the 
more the waves appear stretched toward the edge of the image.

High Frequency The High Frequency option causes an approxi-
mate doubling of the effect of the Frequency setting.

Bullseye Mode Selecting Bullseye Mode leaves rings of unchanged 
original image area between the wave distortions. This creates a 
pattern of concentric rings like those surrounding a bullseye. This 
mode can provide a means of integrating a recognizable version of 
the image with its distortion.

Include Corners This option spreads the filter’s effects to the cor-
ners of an image or selection. If Include Corners is not selected, the 
effects are confined to a circular area at the center of the image or 
selection. 

Preview Select Preview to see the effects of the current settings 
before applying the filter to the image.
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Twirl effects
The Twirl filter twists an image around its center to create interest-
ing spiral distortions. 

To apply the Twirl filter
1 Select a paint object. To limit the effect to a particular area, 
select the area where you want to apply the filter. If you don’t 
make a selection, the filter affects the entire image.

Original

Original

Spin = 20
Frequency = 10
Clustering = 0
Wave Decay = 10

Same settings 
(above) with 
Bullseye Mode

Ripple examples

Ripple filter applied in area selected 
with the Oval Marquee tool
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2 Choose Image > Filter > Other > Twirl. Adjust the Angle set-
tings in the Twirl dialog box. The Angle value specifies the direc-
tion and extent of the effect. Type a number in the box or drag 
the slider to set the Angle value. Higher numbers (positive or neg-
ative) create more twists around the center. A positive number 
twirls clockwise. A negative number twirls counter-clockwise. 
Select No Anti-Alias to turn off smoothing of edges in the image. 

3 Select Preview to see the effects of the current settings before 
applying the filter to the image.

4 Click OK to apply the settings and close the dialog box. 

Spherical distortion
The Spherize filter can distort an image to simulate a reflection on 
a curved surface.

To apply the Spherize filter
1 Select a paint object. Make a selection to limit the effect to an 
area. If you don’t make a selection, the filter affects the entire 
image.

2 Choose Image > Filter > Other > Spherize or use the Filter 
menu in the Properties bar. 

3 Adjust the settings in the dialog box and click OK to apply 
the filter.

Original Twirl Angle 90 Twirl Angle 180
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Spherize settings
Amount The extent of the distortion. Type a number from 1 to 10 
or drag the slider. A higher number simulates a stronger curve.

Projection Mode The shape of the distortion. Select Spherical/
Ellipsoid to simulate reflection on a spherical surface like a globe. 
Select Cylindrical to simulate reflection on a cylinder, such as a 
can. Select Horizontal to make cylindrical distortion horizontal. 
Select Vertical to make cylindrical distortion vertical. Select Hyper-
boloid to simulate reflection on a concave hyperboloid surface.

Vignette Isolates the shape of a spherical distortion from the rest 
of the image. If the image has a visibility mask, the areas of the 
image that fall outside of the distorted area will be transparent. If 
the image does not have a visibility mask, the areas are filled with 
the current background color. Use this option when Spherical/Ellip-
soid is selected.

No Anti-Alias Turns off smoothing of edges in the image. Deselect 
this option for a smoother effect. 

Preview Displays the current effect before you apply the filter.

Artistic Effects
The artistic filters, Crystallize, Lens Flare, Oil Painting, and 
Stained Glass, can be applied to images, text, and vector objects. 

For images, access the filters by choosing Image > Filter > Artistic 
or use the Filter menu in the Properties bar. For text and vector 
objects, choose Object > SpriteEffects > Add Effect > Artistic (see 
“Spriteffects,” page 34.1).

Original paint object Spherize: Amount = 5 Vignette option selected
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Crystallize
This filter applies a crystal-like appearance to a selected image. 

Lens Flare
This filter mimics the appearance of a well-known photographic 
effect. It is caused by reflections of light that may occur inside the 
camera lens. A flare can often naturally appear as a source of light 
in a photographic scene or on a highly reflective object. 

Before Crystallize filter

After Crystallize filter is applied

A Crystal Size - The size and saturation of the 
crystals can be adjusted numerically or by moving 
the appropriate slider bar. 
B Crystal Saturation - The color of the back-
ground will influence the appearance of your image. 
C Use White Background - By default, the back-
ground is set to black. You have the option to set 
the background to white. You may do this by 
checking the “Use White Background.”
D Select the Anti-alias Crystals option for Web 
graphics. 
E Check the Preview button if you wish to view 
your changes during adjustment.

Before Lens Flare

After Lens Flare

A Light Source Position - The flare 
may be adjusted by using your mouse to 
move the flare highlight in the preview 
window.
B The flare may also be moved by en-
tering numerical values in the X or Y co-
ordinates box. 
C Zoom and Light Intensity values 
may also be applied to the flare by either 
adjusting the appropriate slider bar or 
by changing the numerical values of the 
effect.
Artistic Effects 27.11



27
Oil Painting
Use the Oil Painting filter to give an object the appearance of hand-
painted artwork. 

Stained Glass
This filter applies a stained-glass appearance to an object. 

Bevel
Use the Bevel filter to give any 2D image a 3D appearance. If you 
are creating Web buttons and want to give the buttons a raised 
appearance, apply the Bevel filter.

When working with images, you can access the Bevel filter dialog 
by choosing Image > Filter > Stylize > Bevel. For vector or text 
objects, choose Object > SpriteEffects > Add Effect > Stylize > Bevel 
(see “Spriteffects,” page 34.1).

Note: For images, ensure you apply a visibility mask to the area of 
the image to which you’ll apply the effect (see “Adding visibility 
masks to images,” page 23.21). If the image has a transparency 

A Brush Size - Adjust the size of the 
brush effect by moving the slider bar.
B You also have the option to enter a 
numerical value in the brush size field.
C If you wish to preview the effects of 
the filter, then select the Preview check-
box. 

After Oil Painting filterBefore Oil Painting

Before Stained Glass

After Stained Glass filter

A Tile Size - Adjust the effect of the filter by 
moving the Tile Size slider or by changing the nu-
merical value in the field.
B Tile Shape - Select either square or hexagon 
tile shapes. 
C Anti-Alias - If your work is for the Web, select 
the Anti-alias Tiles option. 
D Border Thickness - Adjust the size and the 
thickness of the space that separates each piece of 
“stained glass”.

Before Bevel effect

After Bevel effect
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mask, select the area to be beveled with either the Wand tool or 
Marquee tools.

Using the High Pass, Maximum, and Minimum filters
This section describes how you can create selections in alpha chan-
nels and resize bright areas in color channels. Isolate areas in an 
image using the High Pass filter and Threshold command. You can 
use the Maximum and Minimum filters to spread color areas you 
might need to trap for commercial printing. 

Isolating areas using the High Pass filter
The High Pass filter isolates high contrast edges in an image by 
removing low contrast detail. The filter makes pixels located in low 
contrast areas gray. In color images, the High Pass filter outlines 
high contrast edges in color. Otherwise, it outlines these edges in 
dark gray. This command doesn’t work with paint objects in Black 
& White mode, and Indexed mode.

To apply the High Pass filter
1 Select one or more paint objects to adjust all the images. 
Select an area in one image in edit mode to adjust the selected 
area only. If you don’t make a selection, the entire image in edit 
mode is affected. 

2 Choose Image > Filter > Other > High Pass or use the Filter 
menu in the Properties bar.

A Direction of the light source 
can be entered by a numeric val-
ue, slider bar, or preview handle.
B Elevation of light source can 
be entered by a numeric value or 
slider bar.
C Brightness of light source 
can be entered by a numeric val-
ue or slider bar.

D Bevel width can be entered 
by a numeric value or slider bar.
E Edge Smoothness can be 
entered by a numeric value or 
slider bar.
F Corner Smoothness can be 
entered by a numeric value or 
slider bar.
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3 Enter a radius from 0.1 to 250.0 pixels. 

• To retain more of the original image surrounding high contrast 
edges: Enter a high number. If you enter a low number, the filter 
makes more of the image gray. 

Maximizing and minimizing bright areas in an image
Increase or decrease light areas in an image with the Maximum 
and Minimum filters. The Maximum filter adds light to shadows. 
The Minimum filter shrinks light areas.

When you apply these filters, Canvas compares each pixel to its 
neighbors within the radius you specify, then replaces it with the 
lightest or darkest pixel in the group. This command doesn’t work 
with paint objects in Black & White mode, and Indexed mode.

Isolating images with the High 
Pass filter

1 With an image in edit mode, choose 
Image > Select > All. Then choose Edit > 
Copy.

2 Choose Image > Show Channels. 

3 Create a new alpha channel by click-
ing the button in the lower-left corner of 
the Channels palette. 

4 Select the new alpha channel and 
choose Edit > Paste.

5 Choose Image > Filter > Other > High 
Pass and enter a radius value. Click OK.

6 Choose Image > Adjust > Threshold. 
Adjust the threshold until you outline the 
areas you want. Click OK.

7 Paint areas white to include them in 
the selection. Fill the rest of the image 
with black.

8 Click the composite channel. 
Choose Image > Select > Load to load 
the alpha channel and select an area. 

9 In the example, the final image was 
finished by choosing Image > Select > 
Load with Inverse selected. 

10 Then, choose Image > Filter > Blur > 
Gaussian Blur to apply a Gaussian blur of 
3.0 pixels.

Original Image High Pass filter Threshold filter

 Editing with Paint 
tools

Finished alpha 
channel

Isolated subject

Tip
To apply a choke or spread to an 
image manually, use the Maxi-
mum or Minimum filters in a color 
channel.
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To use the Minimum and Maximum filters
1 Select one or more paint objects to adjust all the images. You 
can select an area in one image in edit mode to adjust the selected 
area only. If you don’t make a selection, the entire image in edit 
mode is affected. 

2 Choose Image > Filter > Other > Maximum and enter a 
radius from 1 to 16 pixels to maximize the light areas in an image. 

3 Choose Image > Filter > Other > Minimum and enter a 
radius from 1 to 16 pixels to minimize the light areas in an 
image,.

4 Select Preview to check the settings and then click OK.

Filling selections with color
The Fill command lets you quickly and uniformly fill a selection 
with the foreground or background color, black, white, or gray. In 
addition, select an opacity level and transfer mode for application 
of the color.

To fill a selection with a color
1 With an area of an image selected, choose Image > Filter > 
Other > Fill or use the Filter menu in the Properties bar. The Fill 
dialog box opens.

2 In the Use pop-up menu, choose a fill option. To make the 
color appear transparent, set the Opacity level to less than 100%. 
To use a mode effect, choose an option in the Mode pop-up menu.

3 Click OK to fill the selection.

Creating custom image filters
You can create your own special-effect and image-correcting filters 
using the Custom command. You can also save custom filters and 
use them in future Canvas documents. 

Filters work with an image one pixel at a time. Using a mathemati-
cal formula and the color values of pixels within a specified radius, 

Original Maximum 6 pixels Minimum 6 pixels
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filters assign each pixel a new color value. In a custom filter, you 
supply the numbers the filter uses to calculate the new color values.

The same filter can produce different effects in other images. To 
get the most out of custom filters, spend time experimenting.

To use Custom filters
1 Select one or more paint objects to adjust all the images. You 
can select an area in one image in edit mode to adjust the selected 
area only. If you don’t make a selection, the entire image in edit 
mode is affected. This command doesn’t work with paint objects 
in Black & White mode, and Indexed mode.

2 Choose Image > Filter > Other > Custom. In the Custom dia-
log box, type values from -999 to 999 in the boxes in the grid. Can-
vas ignores blank boxes.

3 Enter a Scale value from 1 to 9,999. To retain the general 
appearance of the original image, the scale should equal the sum 
of the entries in the configuration grid. For example:

Grid entries Sum Scale

2  2  1  -1  -1  3 2+2+1-1-1+3=6 6

-15 7 4 -3 2 8 -15+7+4-3+2+8=3 3

Custom filter Blurred image Custom filter Embossed imageOriginal

These boxes represent the pixels 
surrounding a target pixel

This box represents the target 
pixel in an image
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4 Enter an Offset value from -9,999 to 9,999. Positive values 
increase the brightness of the final outcome while negative values 
decrease the brightness.

5 Turn on the Preview option to check the filter effect. When 
the settings are correct, click OK.

• To save a custom filter: In the Custom dialog box, enter the fil-
ter settings and click Save. Enter a name and location for the filter 
and click Save. 

• To load a custom filter: In the Custom dialog box, click Load. 
In the directory dialog box, select the filter file and click Open. 

Rotating images
Canvas gives you the ability of applying a soft rotate or hard rotate 
to your images. A soft rotate is sufficient if you do not need to 
export the images to another format; however, if you plan on 
exporting your images and need them to remain rotated, then you 
should apply a hard rotate. A hard rotate not only rotates the image 
but also adds white pixels to the bounding box. Soft rotate does not 
add pixels.

Anti-aliasing for rotated bitmaps
Sometimes bitmap images can lose their clarity when they are 
rotated. The anti-aliasing for rotated bitmaps feature addresses this 
issue. 

If you’re rotating a bitmap and select Hard rotate for image in the 
Rotate dialog box, the Anti-alias image checkbox becomes avail-
able. The anti-aliasing option results in a smoother, better quality 
image.

To hard rotate an image with the Rotate dialog box
1 Choose Effects > Rotate Right or Rotate Left > Other. 

2 Make sure you select Hard rotate for image to enable Anti-
alias image.

You can also activate this dialog 
box by using the keyboard 
command Command+ R (Mac) or 
Ctrl+R (Windows). 
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To quickly rotate images at multiples of 90°
If you own a digital camera, you always spend time rotating images 
at 90°. 

1 Select the image.

2 Click on the Rotate button in the Properties bar.

3 Select a hard rotate option in the menu and enter a value of 
90° (or a multiple) in the field and press Enter.

Distorting images
Canvas features an image effect that you can use to warp an image 
so it fits the bounding box of a vector object.

Shape effect
To use this effect, you must first select an image and vector object.

• To apply the Shape effect: Select an image and a vector object 
and choose Image > Image Warp > Shape. 

Note: The Shape command is not available if more than one image 
or vector object is selected.

Original bitmap before 
rotation.

Original bitmap after rotation 
without Anti-aliasing turned on.

Bitmaps will not attain a pixelated 
appearance after rotation if Anti-
aliasing is turned on.

Anti-aliasing - OnOriginal Anti-aliasing - Off
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Shape effect controls
A Control points. Click to add con-
trol points to both the source and tar-
get. Every source point must have a cor-
responding target point. At least 3 
points must be defined to enable the 
Create button.

Control points are saved in relative 
position to object, so if you drag or 
scale an object, the points will be 
scaled correspondingly. Save the doc-
ument after change the control points 
configuration. When exiting the ses-
sion, current point configuration is 
automatically saved.

B Segment points. Click to add seg-
ments to both the source and target. Ev-
ery source segment must have a corre-
sponding target segment.
C Curve points. Click to add curve 
segments to both the source and target. 
Every source curve must have a corre-
sponding target curve.
D End curve points. Click to com-
plete the curve.
E Select all points. Click to select all 
control points.

F Delete has two functions: delete 
current curve, if you are creating a 
curve, or delete selection, if any.
G Save. Click this button to save the 
control points within the source and tar-
get.
H Reload. Click this button to reload 
the saved points.

Pixel resampling. Select a resampling 
method.

• Nearest neighbor. Will remove 
some pixel information from your tar-
get image; however, if used, this set-
ting will be the fastest.
• Bilinear. Will use a bilinear inter-
polation algorithm during downsam-
pling.
• Biquadratic. Estimates the color 
at a pixel in the destination image by 
an average of 9 pixels surrounding the 
closest corresponding pixel in the 
source image.
• Bicubic. Estimates the colour at a 
pixel in the destination image by an 
average of 16 pixels surrounding the 
closest corresponding pixel in the 
source image.

• Polygonal. Every source pixel is 
mapped to a polygon in the target.
• Auto. Canvas selects the most 
appropriate method for resampling.

Show Names. Select this checkbox if 
you want to see labels. Use the Size 
menu to adjust the size of control 
points.

Shape. Select either Circle or Square 
for the control point shape.

Opacity. Adjust the transparency of 
the created object.

Source & Target colors. Select a color 
from the palettes to distinguish the 
source and target. By default, the 
source is red and the target is green.

Create. Click this button to perform 
the effect.

Delete. Click this button to delete the 
created object.

Exit. Click this button to leave the 
warp effect before or after clicking 
Create.
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Envelope effect
The Envelope command lets you distort image objects, as if an 
image was drawn on a rubber sheet and then stretched.

When an image object is in envelope edit mode, its bounding box 
acts like the rubber sheet. Canvas includes several envelope styles 
that offer various handles you can use to manipulate an object’s 
bounding box.

To learn about the envelope styles and their respective uses, see 
“Enveloping objects” on page 21.12).

The image is the Source and the vector 
object is the Target.

Each Source control point has a match-
ing Target control point.

If the vector object contains a fill ink, the 
fill will be removed after the effect is 
applied.

Original image

Enveloped image
.20 IMAGE FILTERS & EFFECTS



Combining image channels
The Calculate Image command lets you combine channels to cre-
ate selection masks for effects like embossing text in an image. By 
adding, subtracting, and multiplying channels, you can also 
enhance shadows and highlights. The Calculate Image command 
combines corresponding pixels from two channels by the method 
you choose. You can place the result in a new or existing channel. 

To combine channels
1 With an image in edit mode, choose Image > Calculate.

2 Choose the first channel in the Source 1 menu. If you want to 
invert the channel, select Invert. For more information, see 
“Inverting colors in images” on page 25.6.

3 In the Source 2 menu, choose the channel you want to com-
bine with the Source 1 channel. If you want to invert the channel, 
select Invert. 

4 In the Blending area, choose an option in the Use menu. See 
“Descriptions of Calculate blending options,” page 27.22 

5 Enter an opacity from 0 to 100 percent for Source 1. Other 
options are available for some Blending methods.

6 If you want to mask Source 1, select Mask in the Blending 
area and choose a channel in the menu. To invert the mask, select 
Invert in the Blending area.

7 Choose the name of a destination channel or choose New in 
the Result menu. If you select an existing channel, Canvas 
replaces the channel with the results of the Calculate Image oper-
ation.

8 Click OK to calculate the channel using the current settings.
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Descriptions of Calculate blending options

You can select various blending meth-
ods in the Calculate Image dialog box. 

Normal. Places Source 1 over Source 
2 at the specified opacity. 100 percent 
opacity replaces Source 2 with Source 
1.

Multiply. Creates a darker channel 
than the source channels. Black areas 
in either source create black areas in 
the resulting channel. White areas do 
not affect the result. 

Screen. Creates a lighter channel than 
the source channels. White areas in 
either source create white areas in the 
resulting channel. Black areas do not 
affect the result.

Overlay. Places Source 1 over Source 
2 without destroying the shadows or 
highlights of Source 2. 

Soft Light. Lightens or darkens pixels 
in Source 2 depending on the bright-
ness value of the corresponding pixels 
in Source 1. Pixels in Source 1 that are 
lighter than 50% black lighten Source 2. 
Pixels in Source 1 that are darker than 
50% black darken Source 2.

Hard Light. Lightens or darkens pix-
els in Source 2 depending on the 
brightness value of the corresponding 
pixels in Source 1. Hard Light works 
similarly to Soft Light. However, black 
in Source 1 produces black in the 
resulting channel and white produces 
white.

Darken. Replaces pixels in Source 2 
with the corresponding pixels in Source 
1, if the pixels in Source 1 are darker.

Lighten. Replaces pixels in Source 2 
with the corresponding pixels in Source 
1, if the pixels in Source 1 are lighter.

Add. Creates a lighter channel than the 
source channels. Add is similar to 
Screen but usually produces a higher-
contrast image. 

If you select the Add option, you can 
enter a Scale value from 1 to 2 with a 
precision of three decimal places. To 
calculate the average brightness value 
of two channels, choose Add and enter 
a Scale of 2.

You can brighten or darken the result-
ing channel by specifying an Offset val-
ue. To lighten the overall image, enter 

an offset from 1 to 255. To darken the 
image, enter an offset from -1 to -255. 

Subtract. Creates a darker channel 
than the source channels. Subtract is 
similar to Multiply. However, corre-
sponding pixels of the same color pro-
duce black in the resulting channel. 

If you select the Subtract option, you 
can enter a Scale value from 1 to 2 with 
a precision of three decimal places. 

You can brighten or darken the result-
ing channel by specifying an Offset val-
ue. To lighten the overall image, enter 
an offset from 1 to 255. To darken the 
image, enter an offset from -1 to -255. 

Difference. Compares the color value 
of each pixel in Source 1 with the corre-
sponding pixel in Source 2, subtracts 
the darker value from the lighter, and 
then uses this difference in the resulting 
channel.
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Examples of Calculate blending options

Source 1 Source 2 Multiply

Screen Overlay Soft Light

Hard Light Darken Lighten

Add Subtract Difference
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IMAGE PROXIES

Proxies are low-resolution images you can use in Canvas docu-
ments. A proxy is a placeholder that is linked to an original image. 
The original high-resolution image is stored in a Canvas Image File 
on disk.

Using proxies
Proxies can significantly reduce the time required to redraw the 
screen while you work. Also, a Canvas document that contains 
proxies requires much less disk storage space than one containing 
high-resolution images (although the space required to store the 
document and the linked image files is approximately the same as 
for the document containing high-resolution images).

Replacing an image with a proxy
The procedure described in this section lets you replace an image 
contained in a Canvas document with a low-resolution proxy. 
When you do this, Canvas exports the original image to a Canvas 
Image File, and links the Canvas Image File to the proxy. 

Tip
Proxies are most useful for con-
serving time and memory when 
you use large, high-resolution col-
or images in documents.

A low-resolution proxy replaces 
the image in a Canvas document. 
The proxy is linked to the Canvas 
Image File.

A high-resolution image 
stored in a Canvas Image 
File on disk.
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If you later double-click the proxy for editing, Canvas loads the 
original image from the Canvas Image File. You can edit the origi-
nal image as you would any other Canvas paint object. When you 
leave image-editing mode, Canvas stores the changes in the Canvas 
Image File and then displays the proxy again.

To create a proxy linked to an image file
1 In the Canvas document, select the image object you want to 
replace with a proxy.

2 Choose Image > Proxy > Make Proxy. A directory dialog box 
appears.

3 Select a file type and location to save the file. 

4 Type a name for the image file that Canvas will create. 

5 Click Save. The Make Proxy dialog box appears.

6 Type a value in the “Make...Times Smaller” box. The larger 
this number, the lower the proxy resolution and the less memory 
required by the proxy in the document. The value must be from 1 
to 1,000.

7 Click OK. Canvas replaces the image with a proxy and cre-
ates a file containing the original image on disk. The proxy is 
linked to the image file on disk. 

If you click Cancel, Canvas closes the dialog box without replacing 
the original image, placing the proxy, or storing the image file on 
disk.

Make Proxy dialog box

You use the Make Proxy dialog box to 
create proxies linked to Canvas Image 
Files.

A Width and height of the image.
B Size of the Canvas Image File you 
are about to create.
C Resolution of the image.
D Memory required by the proxy. The 
memory required changes if you enter 
values in the “Make...times smaller” text 
box.

E Type the proxy reduction factor 
in this text box. The larger this value, 
the lower the proxy resolution and 
the less memory required by the 
proxy.
F Location of the file on disk.
G Click to change the location 
that Canvas will store the Canvas 
Image File.

Click OK to replace the image with 
the proxy and create the Canvas 
Image file.
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Final output with proxies and linked image files
To produce final high-resolution output from a document, you may 
need to copy the Canvas document from your disk to another stor-
age media, such as a Zip disk. When you copy a document that con-
tains image proxies, you need to copy the linked high resolution 
image file also, to be able to print the high resolution images.

Make sure when you copy the documents to another disk, that you 
maintain the original folder structure. It is a good idea to open the 
Canvas document that you copied, and check that the links have 
not been broken (see “To verify proxy links” on page 28.5 for more 
information).

You can also replace a proxy with its linked image to eliminate the 
need to copy the image file. To learn how to do this, see “To replace 
a proxy with its linked image” on page 28.5. 

To create a proxy by acquiring a file
You can use the Import command to create a proxy that is linked to 
a TIFF, JPEG, or CVI file. 

You can edit acquired proxies the same as other proxy images. 
However, some changes you might make, such as adding image 
channels, are not supported by JPEG or TIFF files. 

1 To acquire an image from a file, choose Image > Import and 
choose a file format in the Import dialog box. 

2 In the Import dialog box, select the Acquire As Proxy option. 
Select the image files to import and click Import. 

3 The Proxy Info dialog box appears. Type the proxy resolu-
tion in the “Make…Times Smaller” box. The larger the number, 
the lower the resolution of the proxy image in the document.

4 Click OK. Canvas places the proxy images in the document.
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Editing proxies
Object editing
Changes you make to a proxy when you do not edit the pixels in 
the image are object-level edits. You can skew and scale proxies like 
other objects. Skewing, scaling, and other object-level editing do not 
affect the image file to which the proxy is linked. 

Pixel editing
When you place a proxy object in image-edit mode, Canvas loads 
and displays the linked image file in place of the proxy. If the origi-
nal image has changed, you see the changes.

Changes you make in image-edit mode are saved in the linked 
image file on disk when you exit image-edit mode. Canvas then dis-
plays an updated proxy.

Editing an image linked to a proxy is the same as editing any image 
in Canvas: You can use painting tools and commands to alter pixels 
in the original image.

Displaying proxy information
When you select a proxy object, the information area of the Status 
bar displays the data for the image file to which the proxy is linked 
in italic type. To display information on the proxy object, choose 
Image > Proxy > Proxy Info. The Proxy Info dialog box displays 
the dimensions and resolution of the proxy object and the location 
of the linked original image on disk.

Paint object in image-edit mode

Height of the image
Width of the image

Size of the image file
Resolution of the image

Memory required by the proxyThe factor by which the 
proxy is reduced

Location of the image file 
on disk

Click to link the proxy to 
another image file Click to close the dialog box
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Removing proxies
To remove a proxy object easily, without replacing it with an origi-
nal image, select the proxy object and press Delete, or use the Cut 
or Clear commands in the Edit menu.

To replace a proxy with its linked image
1 Select the proxy you want to replace.

2 Choose Image > Proxy > Unlink Proxy. Canvas asks if you 
are sure you want to remove the link between the image file and 
the proxy.

3 Click OK to replace the proxy and remove the link to the 
image file.

Maintaining proxies
If someone changes the name or location of an image file that is 
linked to one or more proxies, Canvas alerts you that the file could 
not be found when you try to edit, unlink, or update any of the 
proxies.

You can check proxies in a document at any time to verify that the 
links are valid. If Canvas detects unlinked proxies, you can re-link 
them to existing image files.

To verify proxy links
To determine if any proxy links are broken, choose Image > Proxy 
> Check Proxies.

If Canvas finds an unlinked proxy, it displays selection handles 
around the proxy and centers it in the document window. Canvas 
displays a message telling you that the proxy has a problem because 
the image file could not be found. 

Note: When it finds an unlinked proxy, Canvas displays the proxy’s 
name, if you have assigned a name to the proxy object. You can do 
this by typing a name in the Name field on the Data tab in the 
Object Specs palette (Object > Object Specs).

When Canvas tells you that a proxy has a problem, you should fol-
low the procedure “To re-link a proxy,” page 28.6. If a proxy does 
not have a valid link to an image file, Canvas prints the low-resolu-
tion proxy when you print the document.

Important
You should always verify the proxy 
links in a document before final 
output. If you produce final high-
resolution output from a docu-
ment with unlinked or broken 
proxy objects, the associated 
images will not print correctly.

Tip
If you use the Collect for Output 
command (File > Collect for Out-
put), you’ll receive a warning if a 
proxy is not linked to an image file.
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If all proxies in the document have valid links to image files, Can-
vas displays the message: “No problems found.” Canvas also dis-
plays this message if the document contains no proxies.

To re-link a proxy
If you are using the Check Proxies command and Canvas finds an 
unlinked proxy, you can link the proxy to an image file.

1 After Canvas identifies an unlinked proxy, click Fix in the 
message box. The Proxy Info dialog box appears.

• If you click OK, Canvas skips the proxy and continues 
checking other proxies. If you click Cancel, the check 
ends.

2 Click File in the Proxy Info dialog box. A directory dialog 
box appears.

3 In the directory dialog box, select an image file to link to the 
proxy, and then click Open. Canvas returns to the Proxy Info dia-
log box, which shows the path to the linked image file. 

4 Click OK. Canvas closes the Proxy Info dialog box and con-
tinues to check for unlinked proxies.

5 If Canvas finds another unlinked proxy in the current docu-
ment, Canvas again selects the unlinked proxy and displays a 
message that the proxy has a problem. Repeat the procedure from 
Step 1 above to re-link unlinked proxies that Canvas selects.

When Canvas doesn’t find any unlinked proxies, it ends the Check 
Proxies procedure and returns to the document.

To change the file linked to a proxy
Use the following procedure to link a proxy to a different image file.

1 Select the proxy object.

2 Choose Image > Proxy > Proxy Info. The Proxy Info dialog 
box appears. Click File and a directory dialog box appears.

3 Select the image file you want linked to the proxy and click 
Open. The Proxy Info dialog box appears, and shows the new 
path and the name of the linked image file.

4 Click OK to close the Proxy Info dialog box.
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Updating proxies
Use the Update Proxies command to update all proxies in a docu-
ment so they match the image data in their linked image file. 

• To update all proxies in the active document: Choose Image > 
Proxy > Update Proxies. 

• To update a specific proxy: Select the proxy object you want to 
update and choose Image > Proxy > Update Proxy.

Exporting Canvas Image Files
You can export any image from a Canvas document to create a 
Canvas Image File on disk. You can then create proxies linked to 
the Canvas Image File.

This procedure creates a Canvas Image File, but does not link the 
image file to the document, or replace the image with a proxy in the 
document.

To export an image to a Canvas Image File
1 Select the paint object in the document and choose Image > 
Export > Canvas Image File.

2 A directory dialog box appears. Select a location and type a 
name for the image file, and then click Save. Canvas creates a 
Canvas Image File.
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TEXT ENTRY & LAYOUT

Typing text in a document
Canvas has a full range of text and typography features that let you 
integrate text with illustrations and images. You can enter, format, 
edit, and arrange text in Canvas. You can also import text files and 
use Object Linking and Embedding (OLE) to place text in docu-
ments. To help you edit and proof text, Canvas provides spell-
checking and text-searching tools. 

Depending on the circumstance, use either the Text tool or Vertical 
Text tool to type text into a document. 

The Vertical Text tool is designed for Japanese and other lan-
guages with vertical text. For information on the Vertical Text tool 
and other features for working with two-byte languages, see “Tools 
and options for two-byte and vertical text” on page 29.5. Remember 
that the Vertical Text tool does not appear unless “Enable two-byte 
script” is selected in the Configuration Center (see “Type settings” 
on page 13.12). 

Text objects
All text in a Canvas document is contained in objects called text 
objects. Text objects can contain a single character or line of text, 
or thousands of words, sentences, and paragraphs.

Note: Dimension objects contain dimension text (see “Using the 
Dimensioning tools” on page 20.2).
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Text tools
The Text tool palette contains the tools you use to create text 
objects and edit text. 

• Use the Text tool to create text objects and edit text.

• Use the Text Object tool to draw fixed text objects for 
page layouts.

• Use the Path Text tool to type text along a vector path.

• Use the Text Link tool to link text objects to create text 
flows.

• Use the Text Unlink tool to break text object links.

• Use the Text Form Field tool to create form text boxes.

• Use the Text Format Brush tool to copy a text format and 
apply it to other text.

Using the Text tool
Use the Text tool to create new text objects, type text into a docu-
ment, and edit text. 

When you create text objects with the Text tool, you can choose 
whether or not to set the column width before typing. 

• If you set the column width before typing, text wraps to 
the next line when it reaches the right boundary of the text 
object.

• If you don’t set the column width before typing, the right 
margin expands indefinitely to accommodate the amount 
of text you type. This is called a “caption” text object.

Whether you should set the column width before or after typing 
depends on the amount of text you want to type. For short labels 
and callouts, you might find it easier to simply type and let Canvas 
adjust the right margin. However, for paragraphs or newsletter col-
umns, it is probably easier to set the column width before typing.

To type text with the Text tool
1 Select the Text tool. The pointer displays an I-beam when 
moved into the document window.

2 Do one of the following to set the location and type the text:

A Text
B Section
C Path Text
D Text Object
E Text Link 
F Text Unlink 
G Text Info
H Text Form Field 
I Text Format Brush

Tip
You can change the size of the text 
object by selecting it and dragging 
a selection handle.
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• To enter one line of text: Click in the document; an insertion 
point appears where you click. Begin typing and the right margin 
extends to fit the line of text that you type.

• To define a text column: Drag diagonally to create a rectangular 
text object. The object’s width matters, but not its length; Canvas 
contracts or expands the length to accommodate the text you type. 
An insertion point appears at the top of the object. Begin typing, 
and when you reach the right margin, Canvas wraps the text to the 
next line.

3 Press Esc to exit text-editing mode when you finish typing. 
The text object remains selected.

4 Press Esc to deselect the text object or select another object. 
You can also click outside the object.

Attributes of new text
When you type text, Canvas applies the current attributes and the 
current type format settings to the characters you type. For more 
information about changing ink and stroke attributes, see “Text 
inks and strokes” on page 33.1).

Type formatting Canvas applies the current settings for the font, 
style, type size, justification (alignment), leading, and kerning to the 
characters you type. These settings are selected from the Text 
menu, the Properties bar, or with the controls in the Type palette 
(see “Applying text formats” on page 30.3).

Fill inks Canvas applies the current fill ink, if it’s a solid color fill 
ink, to the text characters. 

Pen inks The pen ink for text you type is always 100% black, and is 
not visible until you apply a pen stroke to the text.

Strokes Canvas applies no stroke to text characters you type. This 
means that no outline appears on the characters, and the pen ink 
applied to the text is not visible because the pen ink appears only 
when an object or text has a visible stroke.

Using the Text Format Brush
Use the Text Format Brush to copy text attributes, such as font, 
font style, fill ink, pen ink, as well as pen stroke, so that you can 
apply them to other text. This tool does not copy frame ink, frame 
stroke, or background ink. To apply these items to text, see “To 

Tip
If the current fill ink is a gradient, 
hatch, symbol, or texture, Canvas 
applies 100% black to the text 
characters.
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apply a background ink,” page 33.2, “To apply a frame stroke,” 
page 33.3, and “To apply a frame ink,” page 33.3.

To copy and apply text attributes
1 Select the Text Format Brush tool. The cursor changes to an 
eyedropper.

2 Click on a text object to copy the text attributes.

3 Then, click on the text object to which you want to apply the 
text attributes.

If you want to apply the text attributes to a single character or 
group of characters, drag across the character or characters until 
they are all selected. When you release the mouse, the text 
attributes will be applied.

Creating text layouts
Use the Text Object tool to place text objects, or columns, in page 
layouts. Text objects created with this tool keep their width and 
length, unlike text objects made with the Text tool, which shrink 
and expand in length to fit the amount of text you type. The Text 
Object tool is especially useful for designing templates and master 
pages, because you can set up text columns and add type later.

If you enter text into a text object created with the Text Object tool, 
and there is more text than will fit in the column, an overflow indi-
cator appears at the bottom of the text object (see “Flowing overset 
text into new text columns” on page 29.13).

Note: The Text Object tool doesn’t select text or place a text object 
in edit mode. For these operations, use the Text tool (see “Using the 
Text tool” on page 29.2). 

To create an empty text object
1 Select the Text Object tool. When you move into the docu-
ment window, the pointer is an I-beam with an arrow.

Tip
To hide the bounding boxes of text 
objects, choose Layout > Display > 
Hide Text Boxes. To show them 
again, choose Layout > Display > 
Show Text Boxes.
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2 Drag to set the width and length of a rectangular text object. 

3 Canvas deselects the Text Object tool and either selects the 
Selection tool or Text tool.

4 Double-click in the text object to select the Text tool. The 
new text object is in edit mode with an insertion point at the top 
of the column.

You can begin typing in the new text object immediately. Press Esc 
to exit text editing mode and select the text object. Press Esc to 
deselect the text object.

Positioning text objects
Arrange text objects the same way you arrange other types of 
objects. Drag text objects with the mouse, resize them by dragging a 
selection handle, “nudge” text objects with keyboard arrow keys, 
and set coordinates and dimensions in the Properties bar.

Tools and options for two-byte and vertical text
A special preference, Enable two-byte script, appears in the Type man-
ager of the Configuration Center if your system is capable of using 
two-byte languages (see “Preferences for two-byte text entry,” 
page 13.23). Depending on the amount of text in your documents, 
activating the two-byte text preference might slow down text edit-
ing.

For Mac OS, you must have a two-byte system version, or a soft-
ware package such as the Japanese Language Kit. For Windows 
ME, 2000, and XP, the OS supports almost any language setting, 
including Japanese. 

When you activate the two-byte text preference, Canvas selects the 
metric measurement system by default. Select another system for 
measurement units by choosing Layout > Rulers (see “Setting up 
rulers and the drawing scale” on page 11.7).

The “two-byte” preference also can make available several tools 
and options that let you create vertical text objects (with or without 
two-byte fonts), and use an entry window for typing two-byte char-
acters. These tools and options are described in this section.

Available two-byte text tools and options
When the two-byte preference is active, the following items appear:

Drag the Text Object tool to 
create an empty text object.

Tip
You must quit and restart Canvas 
to activate or deactivate the two-
byte text preference.
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• The Vertical Text tool appears in the Toolbox (see “Using 
Vertical Text tool” on page 29.6).

• The Vertical Text Object tool appears in the Toolbox (see 
“Using Vertical Text Object tool” on page 29.7).

• “Vertical” options appear in the Column Guides dialog 
box and the Type palette (see “Options for vertical text 
and columns” on page 29.7).

• The Inline tab appears in the Configuration Center (see 
“To set inline text-entry preferences” on page 13.23).

Using Vertical Text tool
The Vertical Text tool types text in vertical columns that flow from 
top to bottom and right to left. Create vertical columns of text in 
languages that use vertical text, or when you work on a publication 
in which text runs across a page.

To create empty text objects, such as for a document template, to 
contain vertical text, use the Vertical Text Object tool (see “Using 
Vertical Text Object tool” on page 29.7).

To type vertical text directly
1 Select the Vertical Text tool. The pointer changes to a hori-
zontal I-beam.

2 Click in the document to place the text insertion point, and 
then begin typing. Since the text will flow from top to bottom, 
Canvas expands the bottom of the column to fit the longest line 
you type.

3 Press Esc to exit text edit mode.

To define a column for vertical text
1 Select the Vertical Text tool. The pointer changes to a hori-
zontal I-beam, indicating that text will flow from top to bottom.

2 Drag the I-beam to set the size of the column, and then begin 
typing. As you type, text characters run from top to bottom. When 
the text reaches the bottom edge of the column, it wraps back to 
the top and onto the next line to the left.

3 Press Esc to exit text edit mode.

Tip
If the Vertical Text tool isn’t avail-
able because the two-byte text 
preference isn’t selected, get the 
same effect by rotating text 90° by 
choosing Effects > Rotate.
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Using Vertical Text Object tool
The Vertical Text Object tool lets you create empty text blocks for 
vertical text. Text objects created with the Vertical Text Object tool 
maintain their width and length. 

To create text objects for vertical text
1 Select the Vertical Text Object tool. The pointer changes to a 
horizontal I-beam indicating that text will flow from top to bot-
tom.

2 Drag to define the width and length of the text object. Then 
drag in other locations to create more text objects, or begin typing 
in the new text object.

3 Press Esc to exit text edit mode.

Options for vertical text and columns
A checkbox labeled “Vertical” appears in two places: the Column 
Guides dialog box and Type palette.

In the Column Guides dialog box, create column guides for vertical 
text in Publication documents. In the Type palette, specify horizon-
tal or vertical orientation for text objects.

To use vertical text column guides
Use the Column Guides dialog box to set up horizontal guides for 
columns (text objects) that contain vertical text.

1 Choose Layout > Column Guides. The Column Guides dia-
log box appears.

2 Select the Vertical checkbox. The column guide buttons at 
the top of the dialog box change to vertical orientation.

3 Use the preset column buttons or the other options to specify 
guides for the number of columns that you want to use.

• To use preset column guides: Click one of the buttons. The first 
three buttons are for 1, 2, and 3 text columns respectively. The last 
two buttons are for 2 columns with a wide and narrow column. 

• To set up guides for any number of columns from 1 to 12: Use 
the “Number of columns” text box.

4 Click OK to create guides for the specified number of col-
umns.

Tip
The Vertical options described in 
this section are not related to the 
“Vertical” command that changes 
the alignment of text bound to a 
path. 
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To use the Vertical option for text objects
Use the Vertical option in the Type palette to set up the Text tool 
for vertical text and to orient text objects to contain vertical text.

1 Open the Type palette by double-clicking the Text tool or 
choosing Text > Type.

2 Do one of the following to set up the Text tool, or to change 
the orientation of existing text objects:

• To change the default operation of the Text tool: Make sure that 
no objects are selected in the document.

• To change existing text objects: Select the text objects.

3 Select the Vertical checkbox in the Type palette and then 
click Apply to apply the current settings. Canvas applies the verti-
cal option to the selected text objects or to the Text tool.

To change text orientation to horizontal in an object
1 Open the Type palette.

2 Select a text object containing vertical text.

3 Deselect the Vertical checkbox and then click Apply.

To use vertical text in publication layouts
1 Choose Layout > Column Guides and choose the number of 
columns you want to use.

2 Use the Vertical Text Object tool to click between column 
guides to create a text column sized to fit the column guides.

The column extends from the point you click to the left margin of 
the page. If the column guides are outside the printable area, the 
column text remains inside the printable area (see “Using Vertical 
Text Object tool” on page 29.7).

Tip
When you set the Text tool to cre-
ate vertical text, lines of text that 
you type are vertical, with text 
flowing from top to bottom and 
lines running from right to left. 
This is the same as the orientation 
of text within an existing text 
object when you apply the Vertical 
option.
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Creating column layouts
A section is a rectangular area that arranges text in columns. A sec-
tion is made of column guides, which are non-printing lines that 
define the text columns and gutters (spaces between columns). 

Sections make it easy to arrange and modify text in columns. You 
can place one or more sections on a page. After you place text in a 
section, you can change the number or the size of the columns in 
the section and Canvas will adjust the text to fit.

To create text columns in a document, you could manually arrange 
separate text objects; however, the Section tool and column guides 
automate text layout. This section describes how to work with the 
Section tool and Column Guides to create text layouts.

Creating columns
Create column layouts with the Section tool or Column Guides 
command (Layout > Column Guides). Use the Section tool to place 
multiple sections at specified locations on one or more pages. Use 
the Column Guides command to define sections or change settings 
for existing sections. 

Whether you create or modify sections with the Section tool or Col-
umn Guides command, the Column Guides dialog box is the con-
trol center for configuring sections. 

When you create a section, the section’s column guides appear on a 
guide layer in the document. By default, guide layers are non-print-
ing and have a bright blue override color. Use the Document Lay-
out palette to change the override color or make a guide layer 
printable (see “Guide layers,” page 12.12).

When you add text to a section, Canvas creates a text object in each 
column in the section. The text objects are placed on the current 
layer. 

A 3-column section
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To create sections with the Column Guides command
1 Go to the page where you want to place a new section and 
choose Layout > Column Guides.

2 In the Column Guides dialog box, select a preset column 
arrangement or define custom columns. In the Apply To menu, 
choose where to place the new section. See “Column Guides dia-
log box” on page 29.10.

3 Click OK to create a new section with the current settings.

Column Guides dialog box

This dialog box contains settings to 
help automate column layout:

A Section Name: Canvas applies a 
default name when you create a section. 
Type a new name in the text box to 
change a section’s name.
B Section options menu: Delete sec-
tions, fit sections to a page, or fit sections 
to the top half or bottom half of a page. 
Choose an option from the menu.
C Apply To: Depending on the layout, 
choose from This Page, All Pages, All 
Left Pages, Left Page, Right Page, or All 
Right Pages (see “Apply To menu op-
tions,” page 29.12).
D Preset column guides: Select 1, 2, 
or 3 columns of equal width, or 2 col-
umns with a wider column on the left or 
right.
E Number of Columns: Specify the 
number of columns; it overrides the 
preset column guides. Type the num-
ber of columns. The maximum number 
depends on the width of a section.
F Equal Widths: This option makes 
the column widths equal to the value in 
the Column box, and makes the gutter 
widths equal to the value in the Gutter 
box. Deselect this option to set the width 
of a specific column.
G Fixed Widths: This option prevents 
changes to the width of the columns. 
H Fixed Gutters: This option prevents 
changes to the width of the column gut-
ters. 

If both Fixed Gutters and Fixed Widths 
are selected, you can’t drag the column 
guides in a section to adjust the widths 
of columns or gutters.

Horizontal: This option appears if 
“Enable two-byte script” is selected in 
the Configuration Center. It creates 
horizontal columns for text in a section.

I Text Flow: To change the direction 
of the text flow, click the button that in-
dicates left to right (the arrow points 
right) or right to left (the arrow points 
left).

Size

If Equal Widths is not selected, set 
widths for columns and gutters.

J Column #: Select the column by 
number. The widths of the selected col-
umn and gutter appear below. Columns 
are numbered from left to right.
K Column: Enter the width of the col-
umn specified in the Column # menu. If 
you select a preset column option, the 
Column value can’t be changed unless 
Equal Widths is deselected first. 
L Gutter: Enter the width of the gut-
ter.
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If the document contains no sections, Canvas creates one or more 
new sections, according to the Apply To setting. 

To create a section with the Section tool
1 Select the Section tool. The cursor changes to a crosshair. 

2 Drag the crosshair in the document. The Column Guides dia-
log box opens. 

3 In the Column Guides dialog box, select options for the sec-
tion. Select preset column guides or specify a custom setup (see 
“Column Guides dialog box” on page 29.10). 

4 Click OK to create a new section with the current settings.

Modifying sections with the Section tool
Use the Section tool to move, resize, and modify sections.

Moving sections
To move a section, drag it with the Section tool. When you move a 
section, text objects contained in the section move with the section.

Resizing sections
To change the width of a section, drag one of its sides. To change 
the height of a section, drag the top or bottom border of the section. 
To change both dimensions at once, drag a corner of the section.

To adjust the width of columns in a section, use the Section tool to 
drag column guides. The Fixed Widths and Fixed Gutters options 
in the Column Guides dialog box limit how sections can be resized. 
If both options are selected, you can’t drag the sides, columns, or 
gutters to resize a section; you can drag the top or bottom to make 
it longer or shorter. 

Modifying sections
To change the settings of a section, double-click the section with the 
Section tool to open the Column Guides dialog box. Change the 
settings in the dialog box and click OK to apply the settings to the 
section. 

• To delete a section: Double-click the section with the Section 
tool to open the Column Guides dialog box. Open the Section 
Options menu and select Delete Section. Click Yes in the confirma-
tion message box.

Drag to create a section

Tip
Unlike vector, paint, and text 
objects, you can’t use the Selec-
tion tool to modify a section.
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Applying section settings throughout a document
The Apply To setting controls how Canvas applies the column 
guides settings. When you click OK, Canvas modifies matching sec-
tions and creates new sections as necessary, depending on the set-
ting selected in the Apply To menu.

Apply To menu options

• This Page : Applies the settings to the current page only. In a 
Publication with facing pages, it applies the settings to both (left 
and right) current pages. 

• All Pages : Applies the settings to all pages in the document. 

• All Left Pages : Applies the settings to all left-hand pages in a 
Publication with facing pages.

• Left Page : Applies the settings to the current left-hand page in 
a Publication with facing pages. 

• Right Page : Applies the settings to the current right-hand page 
in a Publication with facing pages.

• All Right Pages : Applies the settings to all right-hand pages in a 
Publication with facing pages. 

Displaying column guides
You can display or hide all the section column guides in a docu-
ment.

• To show column guides: Choose Layout > Display > Show 
Guides when column guides are not displayed. 

• To hide column guides: Choose Layout > Display > Hide 
Guides when column guides are displayed.

Typing text in a section
Use the Text tool to type text in a column in a section. 

To type text in a section
1 Select the Text tool and click at the top of the first column in 
the section. An insertion point appears in the column at the 
height where you clicked. Canvas creates linked text objects in the 
section when you click in the section with the Text tool.
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2 Begin typing. Text will wrap to the next line when it reaches 
the column edge. If you continue typing to the end of the column, 
text will flow to the next column in the section.

If a section has multiple columns, you can skip one or more col-
umns by clicking in the section where you want the text flow to 
begin.

Flowing text from column to column
Create text flows so that text runs from one text object to another. 
You can flow text to a new text object when the text won’t all fit in 

Flowing overset text into new 
text columns

You can flow text when all the text 
won’t fit in a text object. 

An indicator tells you when an object 
has overset text. If you select a text 
object and drag a handle to reduce its 
size so all the text does not fit, the 
overset indicator appears.

Click the flow symbol (A) to change 
the pointer to a text flow pointer (B). 
You can click or drag the pointer to 
create a new column for the overset 
text. 

To flow text into a column with the 
same margins as the original column, 
click the text flow pointer where you 
want the upper-left corner of the new 
column to appear. To flow text into a 
column with different margins than 
the original column, drag the text flow 
pointer to specify the column width.

You can flow text between as many 
columns as you want.

Resizing a text column can 
result in overset text

If you click the flow symbol (A), the 
text flow pointer (B) appears

Clicking with the flow pointer 
creates a new column the same 
size as the original, and flows the 
overset text into it. 

A plus sign replaces the overset 
sign on the first column, indicating 
that text flows to another column.
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an existing text object; the term “overset text” is used to refer to the 
text that doesn’t fit in a text object or column. 

You can also link empty text objects to create a preset text flow 
when you create templates for page layouts.

Flowing overset text to a new object
If you reduce the size of a text object, or change the text formatting, 
and all the text no longer fits in the text object, you can create 
another text object to hold the overset text. Doing this creates a link 
between the first and second text object, as shown in “Flowing over-
set text into new text columns,” above.

Defining text flow bars & flow symbols
A text flow bar is a solid line with a flow symbol. Text flow bars 
appear at the bottom of text objects when they contain overset text 
or are part of text flows. The flow symbol indicates the flow condi-
tion.

• An arrow indicates that a text object contains overset text. 

• A plus sign indicates that text flows to another text object.

• The last object in a text flow does not display a flow bar 
unless text is overset.

• To display text flow bars: Choose Layout > Display > Show 
Text Flow Bars. To hide text flow bars, choose Layout > Display > 
Hide Text Flow Bars.

Linking text objects
After you create text objects with the Text tool or Text Object tool, 
use the Text Link tool to link the objects and create a text flow. 
When text you type or insert fills one object, it flows to the next 
linked text object. The linked text object can be on another page (in 
a Publication document) or another slide (in a Presentation docu-
ment). You can link columns in a chain to create articles in a multi-
page document such as a newsletter. The Text Link tool is espe-
cially useful for creating templates for publications.

Note: Text objects created with the Text tool expand as needed 
when text is added. However, if you use the Text Link tool to link 
objects created with the Text tool, the objects no longer expand or 
contract to hold the text. Instead, they remain a fixed length, the 
same as objects created with the Text Object tool.

Text object has overset text

Text flows to another text object
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To link text objects

You can use this procedure to link an object containing text or an 
empty text object to other text objects.

1 With the Text or Text Object tool, create at least two text 
objects. Select the Text Link tool. The pointer displays the num-
ber “1”.

2 Click the first text object — the object you want to flow from. 
The text link pointer changes to the number “2”.

3 Click the next text object — the object you want to flow to. If 
you click anything but a text object, Canvas cancels the linking 
operation.

4 To link another text object to the chain, repeat the linking 
procedure; i.e., click the object text will flow from, and then click 
the object the text will flow to.

5 Press Esc when you finish.

Unlinking text objects
Use the Text Unlink tool to break the links between text objects 
that have been linked into a text flow. 

• To unlink one text object from the next object in the flow: Select 
the Text Unlink tool and click the first text object. 

Checking text flows
The Link Info tool lets you check text flows in a document. Use the 
tool to display arrows showing the flow of text among linked text 
objects.

To check a text flow
1 Select the Link Info tool. 

2 Point to a text object. Press and hold down the mouse to dis-
play flow arrows. 

If the text object is part of a linked text flow, arrows show the flow 
sequence. Flow arrows are displayed until you release the mouse 
button. If the text object is not linked, no flow arrows appear.

A flow arrow starts at the lower-right corner of the first object in a 
flow, and points to the upper-left corner of the next object in the 
flow, and so on throughout the flow.

Tip
If text boxes aren’t visible, choose 
Display > Show Text Boxes in the 
Layout menu; this makes it easier 
to find and link empty text objects.

A Flow arrow
Flowing text from column to column 29.15



29
Text Form Field tool
The Text Form Field tool is ideal for numerous types of forms and 
documents. This feature is designed to assist you when you need to 
perform repetitive text entry tasks. 

To navigate inside a form, first create the Text Form boxes and 
then place them in the appropriate locations. After placement, you 
can quickly move the cursor to each Text Form box by using the 
Tab key. All text that is entered into the Text Form box may be for-
matted in the same manner as it is in the regular Text box.

The Tab order of the Text Form boxes may be arranged and 
edited using the features of the Document Layout palette (see 
“Using the Document Layout palette,” page 12.2).

To use the Text Form Field tool
1 Create your form.

2 Select the Text Form Field tool (A).

3 Click and drag in the document location to create Form Text 
boxes.

4 You may now jump to each form text object by pressing the 
Tab key. You may Tab in reverse order by pressing Shift-Tab.

To better track the Form Text boxes, we suggest that you apply a 
name to each box (see “Data tab settings” on page 17.34 for more 
information on naming objects in Canvas).

To convert a regular text box to a form text box
1 Select the regular text box and then right-click (Windows) or 
Control-click (Macintosh) to open the context menu. 

2 Select Convert to Form Text. 

Convert Form Text objects to Normal text by opening the context 
menu and selecting Convert to NormalText.
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Chapter

30
FORMATTING TEXT

You can control all aspects of text formatting in Canvas. This chap-
ter explains how to specify font, font styles, type size, character posi-
tion and scaling, kerning, letter and word spacing, paragraph 
alignment and spacing, and hyphenation. This chapter also 
explains how to select text for formatting and how to apply format 
settings.

You can also save format settings as named character and para-
graph styles so you can use them again (see “Working with type 
styles,” page 31.1). 

Selecting text and objects
The following section is a review of some basic selection techniques 
used to format text. 

To select and deselect text objects
Select text objects the same way you select other objects in Canvas. 

• To select a single object: Use a Selection tool to click the text 
object or drag a selection rectangle around the object.

• To select multiple objects: Shift-click text objects with a Selec-
tion tool. You can also drag a selection rectangle around all the 
objects you want to select.

• To deselect one object: Press Shift and click the object. Other 
objects remain selected.

• To deselect all objects: Press Esc or click an area of the screen 
where there are no objects.

To select all text objects
Use the following procedures to select text objects in various docu-
ment types.

Illustration This procedure selects all text objects on the current 
layer. 

Publication This procedure selects all text objects on the current 
page or current two-page spread. 

Tip
To select all text objects with a sin-
gle command, select the Text tool 
and then choose Edit > Select All. 
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Animation This procedure selects all text objects on the current 
layer of the current frame. 

Presentation This procedure selects all text objects on the current 
layer of the current slide. 

To select text within a text object
Before you can select specific characters, words, lines, or para-
graphs, the text object must be in edit mode. 

1 To place an object in edit mode, use one of these methods:

• With a Selection tool, double-click the text object. The 
pointer becomes an I-beam and an insertion point appears 
in the text.

• Select the Text tool. The pointer becomes an I-beam. 
Click the I-beam within the text. An insertion point 
appears.

• For bound text only, click the Path Text tool. The Path 
Text tool is in the Text tools palette (see “Tool palettes,” 
page 10.6).

2 Use one of the following methods to highlight the text you 
want to select.

To Do this

Select a continuous block of text Drag the I-beam over text.

Select all text between the insertion 
point and another location

Press the Shift key and click where you 
want the selection to end.

Deselect text between the insertion 
point and another location within the 
selection

Press the Shift key and click within the 
highlighted text.

Select a word Double-click the word with the I-beam 
pointer.

Select a line of text Triple-click the line with the I-beam 
pointer.

Select all text in the text object Choose Edit > Select All.

Deselect all highlighted text Click anywhere in the text object or lay-
out. Clicking outside the selected text 
object creates another text object at that 
location. Choosing another tool in the 
Toolbox ends text edit mode.
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Working with linked text objects
When you link text objects so text flows from one column to 
another, you can select all of the text in the flow. This lets you apply 
formatting changes and text styles to all the text at once, even if the 
columns are on separate pages or slides.

For information on linking text objects, see “Flowing text from col-
umn to column” on page 29.13.

To select all text in a flow
1 Select the Text tool and click one of the linked text objects to 
place the text object in edit mode and set the insertion point in 
the text. You can also double-click a text object with the Selection 
tool to enter edit mode.

2 Choose Edit > Select All. Canvas highlights all the text in the 
linked text objects.

3 Click outside any text object or press Esc to deselect the text.

Note: When text is highlighted, anything you type replaces the high-
lighted text. If you select a long text flow across several columns, 
and then type a single letter or press the Spacebar, all the high-
lighted text is erased. If this happens, choose Edit > Undo or Win-
dow > Palettes > Undos.

To apply type formatting to a text flow
Once you select the text in a flow, you can apply formatting 
changes using the Properties bar, Type palette, or Text menu com-
mands. Of course, changes that you make to selected text on other 
pages or slides will not be shown until you switch to the other pages 
or slides.

Applying text formats
Canvas provides three ways to format text: the Properties bar, Text 
menu, and Type palette. The Type palette is also used when you 
create and save paragraph and character styles (see “Working with 
type styles,” page 31.1). Both the Properties bar and Type palette 
can be used to apply the paragraph and character styles.

When you use menu commands or the Properties bar to apply for-
matting, the settings you choose affect the document immediately. 
However, with the Type palette, the settings take effect when you 
click Apply. You do not have to click Apply before switching to 

Tip
You must apply or save the new 
settings before clicking the pointer 
anywhere outside the Type pal-
ette. If you don’t, the settings will 
be lost.
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another tab within the Type palette; Canvas remembers all changes 
and applies them simultaneously with one click.

• To apply character formatting to existing text: Select the charac-
ters you want to change. Choose the formatting you want to apply. 

• To apply paragraph formatting to existing text: Select text in the 
paragraph you want to change, or place the insertion point any-
where in the paragraph. Choose the formatting you want to apply.

To establish formatting for new text objects
When you create a new text object, Canvas applies a preset format 
to text you type. You can define the preset format for new text 
objects. To establish or modify the preset, follow these steps:

1 Be sure you have not selected any text or text objects, and no 
text objects are in edit mode. To deselect all objects, press Esc 
twice.

2 Use one of the methods to choose formatting options. If you 
use the Type palette, be sure to click the Apply button after mak-
ing changes.

Canvas uses the specified settings to format new text objects that 
you create.

To change formatting before typing new text
Set the format for text you are about to type — without changing the 
preset format for new text objects. 

1 Place the text object in edit mode (see “To select text within a 
text object,” page 30.2). The pointer should appear as an I-beam 
and an insertion point (a flashing vertical line) should appear in 
the text. 

2 Place the insertion point by clicking the I-beam where you 
want the new formatting to begin.

3 Use one of the methods to choose formatting options. If you 
use the Type palette, be sure to click the Apply button after mak-
ing changes.

4 Begin typing. The text appears with the chosen formatting. If 
you begin typing in the middle of a paragraph, only the new text 
has the new settings.
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Formatting text with the Properties bar
When using various tools to create or select text objects, the text 
formatting options appear in the Properties bar. Format your text 
using the Properties bar options in addition to the Type palette 
(Text > Type) and Text menu commands. The Properties bar also 
displays the paragraph and character styles that you define in the 
Type palette (see “Working with type styles,” page 31.1). 

Specifying fonts
Select a font using any of the methods (see “Formatting text with 
the Properties bar,” page 30.5 and “Using the Type palette,” 
page 30.13). 

To choose a font from the menu
1 Choose Text > Font. A checkmark appears next to the cur-
rent font.

2 Choose a font in the submenu. The font setting changes.

Text formatting options
A Font. Select one from the menu. 
The font applies to selected text ob-
jects, highlighted text, or the next text 
you type.
B Size. Select a size or enter one and 
press Enter. The size applies to selected 
text objects, highlighted text, or the next 
text you type.
C Horizontal alignment. Select left, 
center, right, or justify.
D Leading. Select an option or enter 
a value and press Enter.

E Scaling. Specify percentages (hori-
zontal & vertical) by which you want to 
scale the current type size. 
F Text attributes. Use the pop-up 
palettes to apply a text fill ink, text pen 
ink, background ink, and text frame ink. 
For the text stroke and frame stroke, 
you can also assign a pen width. 
G Styles. If you define any paragraph 
or character styles, apply them to text 
by selecting them from the menus.
H Space. Insert spacing before or af-
ter a paragraph by entering values in the 
fields. 

I Vertical alignment. Select top, bot-
tom, center, or justify.
J Text styles. Click buttons to assign 
standard text styles. 
K Tab. Select left, right, center, deci-
mal, or comma from the menu and then 
click in the ruler to set the tab (see “Po-
sitioning tabs”). 
L Kerning. Select an option from the 
menu or enter a value and press Enter.

Tip
In Windows, the Font menu may 
also be set to display in single or 
multi-column mode (see “Win-
dows-only type preferences,” 
page 13.16).
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To apply font styles using the Type palette
Open the Type palette. Choose Text > Type or Window > Palettes 
> Type.

1 Click the Character tab to bring it to the front.

2 Click the Style buttons to change appearance styles.

3 Choose Upper, Lower, Normal, Title, or Small Caps in the 
Case menu.

4 Choose Normal, Superscript, or Subscript in the Baseline 
menu. If you are applying superscript or subscript, specify the dis-
tance from the baseline (in points) in the text box. Normal base-
line always has an elevation of zero points.

5 Click Apply to implement the font style settings.

The Fonts palette

Use this palette to quickly view and apply fonts, font styles, as well as type size. 

To open the palette, choose Text > Font > View Fonts or Window > Palettes > 
View Fonts. Use the scrollbar to view the available fonts. 

A To select a font, click the font name in the list.
B To apply appearance font styles, click the style buttons. 
C To change type size, enter a size in the field or select one from the menu.

Tip
Clicking the Plain button turns off 
all active appearance styles. Click-
ing an active appearance style but-
ton turns the style off.
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Specifying type size
Choose from standard type sizes using either the Properties bar, 
Text menu, Type palette, or Fonts palette. To reduce or increase a 
font size in 1-point increments, choose Text > Size. You can also 
increase/decrease text size in 1-point increments by using the key-
board commands Ctrl+Shift+< (Reduce) or Ctrl+Shift+> (Increase).

To set type size using menu commands
1 Choose Text > Size. A checkmark appears next to the current 
type size.

2 Choose one of the sizes in the submenu. The size setting 
applies immediately.

Tips for font installation and use

On Mac OS X systems, Canvas uses fonts installed in the /
Library/Fonts/ folder. Fonts should be installed by dragging 
the font files to the Fonts folder.

On Windows systems, Canvas uses fonts installed in the 
Fonts folder. You can access the Fonts folder via the Control 
Panel. Use the Install New Font command in the File menu 
to add fonts to your system. You can also drag and drop font 
files or font file shortcuts to the Fonts folder. To specify that 
you want to see only TrueType fonts in your programs, you 
can use the Options command in the Views menu.

Canvas can use fonts that are properly installed as described 
above. If fonts that you use in another application are not 
available in Canvas, that application probably stores its fonts 
in a different location and has its own font management 
capabilities.

Guidelines for choosing fonts

There are three types of fonts widely available: bit-mapped 
(or screen), PostScript, and TrueType. You can’t distinguish 
the three types in the Canvas menus; however, you should 
be aware of the different types of fonts you have, because 
each font is best suited for particular purposes. 

Bit-mapped fonts are used by your computer to display text 
onscreen. A bit-mapped font is optimized for a particular 
point size and appears jagged at other sizes. These fonts are 
not scalable for printing.

PostScript Type 1 fonts are the standard for imagesetting. 
PostScript produces high-quality printed text. For onscreen 
display, however, PostScript needs screen fonts. If the 
screen font for a particular point size is not installed, the text 
appears jagged onscreen. To compensate for this, you can 
use Adobe Type Manager (ATM) software. If a screen font is 
unavailable, ATM uses the PostScript printer font for both 
screen display and printing. In addition, ATM lets you print 
PostScript fonts to non-PostScript printers.

TrueType fonts are suitable for most desktop publishing pur-
poses when you are printing in-house. TrueType fonts pro-
duce good quality printed text, and the onscreen appearance 
closely resembles the printed output, even when the screen 
font is unavailable.

Text > Size submenu
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Applying font styles
Font styles are different character types, such as bold, italic, or 
superscript, as well as capitalization modes (see “Types of font 
styles,” page 30.8). 

Font styles can be categorized into three groups: appearance, capi-
talization, and baseline position. You can apply multiple appear-
ance styles to the same text; however, you are restricted to one each 
of capitalization and baseline styles.

Types of font styles

Appearance styles
Appearance styles include plain, bold, italic, underline, outline, 
shadow, small caps, and strikethrough. Except for the Plain option, 
use as many of these appearances as you like on the same text. 
Depending on the typeface, using certain styles might not have the 
desired effect, and can even make text appear ugly when printed; 
e.g., applying bold to a heavy weight typeface can make characters 
look too thick. Similarly, applying italic to an already italicized font 
might exaggerate the slant of the characters.

Capitalization styles
Capitalization styles format text as uppercase, lowercase, or title 
(first letter of each word capitalized) styles. Apply one of these capi-
talization styles to the same text: Normal, Upper, Lower, and Title.

Baseline position
The baseline of text is the imaginary horizontal line on which char-
acters sit. To position characters above (superscript) or below (sub-
script) the normal baseline, shift the baseline position.

Tip
Styles can be chosen and applied 
with either the Properties bar, Text 
menu, or Type palette.

UPPERCASE
lowercase

Title
SMALL CAPS

CanvasTM

H20

Appearance styles Capitalization styles Baseline shift: 
“TM” superscripted
“2” subscripted

Tip
Applying the Plain setting removes 
other font styles that have been 
applied to revert text to its stan-
dard appearance. 
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Canvas does not change the type size of superscript and subscript 
text. Unless you reduce the type size of shifted text, the line size 
increases by the amount of the baseline shift. As a result, the line 
spacing might change, depending on the leading setting. If you 
don’t want the line spacing to change, reduce the type size of 
shifted text by the same amount (or more) of the baseline shift, or 
you can specify leading in points (see “Setting line and paragraph 
spacing,” page 30.15).

If you use the Style submenu to change baseline position, you can 
choose either Superscript or Subscript to shift text the baseline by 
roughly 27 to 33 percent of point size of the line; e.g., superscript 
text in a line of 12-point text appears 4.0 points above the normal 
baseline. 

If you use the Character tab of the Type palette to change the base-
line position, you can specify the exact distance (in points) of the 
text above or below the normal baseline.

To apply font styles using menu commands
1 Choose Text > Style to open the Style submenu. Checkmarks 
appear next to the active styles.

2 Choose the font style you want to apply. Choosing an active 
style turns off the style. Canvas implements the setting immedi-
ately.

Specifying spacing between characters
Kerning affects the amount of space to the right of one or more 
characters. Kerning options can be chosen and applied with either 
the Properties bar, Text menu, or Type palette (see “Formatting 
text with the Properties bar,” page 30.5 and “Using the Type pal-
ette,” page 30.13).

Tighten kerning to place characters closer together, and loosen 
kerning to space characters farther apart. Apply kerning settings 
before typing, or change the kerning for one character, a selection 
of text, or an entire text object.
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Canvas can also adjust letter and word spacing for paragraphs fol-
lowing minimum, maximum, and desired guidelines that you set 
(see “Adjusting letter and word spacing” on page 30.22).

Note: Canvas does not apply kerning to text characters based on 
kerning pairs defined in a particular font. Kern individual charac-
ters by placing the insertion point and choosing Text > Kerning or 
using the Kerning controls in the Properties bar or on the Charac-
ter tab of the Type palette.

In the Kerning submenu, you can choose a standard kerning 
amount: Very Tight, Tight, Normal, Loose, and Very Loose.

Kern characters in half-point increments using the Tighten and 
Loosen commands. Also, set a fine kerning amount using the Con-
figure Fine Kern command (see “To set the fine kerning amount,” 
page 30.11). Then, use the Tighten Fine and Loosen Fine com-
mands to kern characters by that specified amount.

To select kerning amount 
1 Choose Text > Kerning and select one of the following 
options:

Option Result

Tight 8% less space than normal between characters

Very Tight 14% less space than normal between characters

Normal Default spacing 

Loose 8% more space than normal between characters

Very Loose 14% more space than normal between characters

Tighten Reduce kerning by 0.5 points. You cannot tighten kerning to 
less than the width of one character

Loosen Increase kerning by 0.5 points

Default kerning

Kerned manually

Headlines often need manual 
kerning for visual balance

Kerning options
.10 FORMATTING TEXT



To set the fine kerning amount
1 Choose Text > Kerning > Configure Fine Kern. The Kerning 
Specifications dialog box opens.

2 Specify the amount of kerning (in points) for the Tighten 
Fine and Loosen Fine commands to apply.

3 Click OK.

Positioning tabs
You can add tabs as well as adjust margins and indents in the docu-
ment ruler while a text object is selected or you are in text edit 
mode. To indicate a selected a text object or text edit mode, the 
ruler turns light blue. Margin icons and preset tabs appear as well.

A new text object has tab stops at half-inch intervals beginning at 
the left border of the text object. You can move the insertion point 
to each of these tab positions by pressing the Tab key. In addition, 
you can edit a default tab by double-clicking it on the ruler.

To set tabs
Setting a tab moves the default tab stops to the right. 

Tighten Fine Reduce kerning by amount specified in the Kerning Specifica-
tions dialog box

Loosen Fine Increase kerning by amount specified in the Kerning Specifi-
cations dialog box

Option Result

Tip
The document ruler shows tab 
positions for one selected object. 
You cannot set tabs for multiple 
selected text objects.

Left margin Right margin

When a text object is selected and the 
rulers are displayed, you can see the 
margins and tabs. The area within the 
margins turns a light blue.

First line indent

L

Tabs can be moved within the ruler. Place the cursor on the 

tab. The cursor changes to , which indicates that you 
can move the tab in either direction.

Defined tab

Preset tabs (  )

In text edit mode, the cursor 
changes to a tab placement 
symbol ( ) when placed 
within the ruler. 

L

Positioning tabs 30.11



30
• To reposition a set tab: Drag the tab marker to a new position.

You have two ways to set a tab position:

• Select a tab definition from the Tab menu in the Properties 
bar and click in the ruler. A new tab applies to selected text 
objects, the current paragraph, or all highlighted para-
graphs.

• Click in the ruler first and then edit the tab definition.

To edit a defined tab
1 Double-click on the defined tab in the ruler. The Tab dialog 
box opens.

2 Define the tab using the Type, Position, and Leader controls.

3 Click OK.

Position Specify the distance between the tab and the left border 
of the text object.

Type Change the alignment setting of a tab by choosing one of 
these options.

Leader Character Use a character to fill tabbed space. To adjust 
the spacing of the leader character, use kerning options. To specify 
a leader character, type a character in the text box.

Tab menu

Left. The left edge of the text is flush with the tab position. 

Center. Text is centered around the tab position.

Right. The right edge of text is flush with the tab position.

Decimal. The first decimal (or period) in a string of text aligns directly under the tab 
position; e.g., if you align “123.45.678” to a decimal tab, the decimal between the “3” 
and “4” will fall under the tab position.

Comma. The first comma in a string of text aligns directly under the tab position.

Double-click on a tab in the 
document ruler. The Tabs dialog 
box opens to edit the tab you 
selected.
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To delete a defined tab
1 Double-click on the defined tab in the ruler. The Tab dialog 
box opens.

2 Click the Delete button.

3 Then click OK.

You can also select the tab in the ruler and drag it off the ruler 
either up, down, left, or right.

Horizontal and vertical text scaling
Canvas provides independent control of horizontal and vertical 
scaling of text. Using this feature, you can stretch characters to cre-
ate extended and condensed letterforms. 

Setting indents

Set the right and left indents of a 
selected text object by dragging the 
Right and Left Indent markers in the 
ruler

To indent the first line of a paragraph, 
drag the First Indent marker to the 
desired position in the ruler.

To set the distance between the left 
border of a text object and the left mar-

gin of a paragraph, drag the Left Indent 
marker.

To set the distance between the right 
border of a text object and the right 

edge of a paragraph, drag the Right 
Indent marker.

Default tabs Right indent

Ruler

First Indent

Left Indent

Using the Type palette

To open the Type palette, choose Text 
> Type. The Type palette contains six 
tabs: Character, Hyphens, Indents, 
Paragraph, Spacing, and Styles. 

When you adjust settings in the Type 
palette, the new settings don’t take 
effect until you click Apply. Be sure that 
you don’t click outside the palette 
before applying the settings, or they will 
be lost.

A Click a tab to bring it to the front.
B Configure the settings you want and 
click Apply to implement them.

For information about creating and 
applying type styles, see “Working with 
type styles,” page 31.1)
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To scale an entire text object, you can also select the text object, 
press Command (Mac) or Alt (Windows), and drag a selection han-
dle. Depending on the direction of the drag, Canvas scales text hor-
izontally or vertically.

To scale characters using the Type palette
1 To specify the vertical and horizontal scale of characters, 
enter percentages in the Scale boxes. To scale proportionately, 
enter the same percentage in both boxes. Canvas applies these 
percentages to the point size displayed in the Size box. 

2 Click Apply to implement the scaling settings.

Canvas doesn’t limit the percentage you can scale characters; how-
ever, extremely high and low settings can distort some fonts and 
make them unreadable. In addition, scaling requires significant 
amounts of memory for text display, which might cause perfor-
mance problems for some systems.

Applying paragraph formatting
In Canvas, you can control paragraph attributes, such as justifica-
tion and leading. Paragraph attributes affect entire paragraphs, 
even if you select a single character, or place the insertion point 
anywhere in the paragraph. If you select text in multiple para-
graphs, all the paragraphs will be affected.

Paragraph-level formatting includes leading and paragraph spac-
ing, indents, tabs, alignment (justification), automatic letter and 
word spacing, hyphenation, and widow and orphan controls.

Horizontally scaled 200%

Horizontally scaled 50%

Vertically scaled 200%

Vertically scaled 50%
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Setting line and paragraph spacing
Using the Text menu, Properties bar, or Type palette, adjust the 
spacing, or leading, between lines of text. You can also insert extra 
space before and after paragraphs using the Type palette.

Canvas provides two methods of specifying leading: ratio (or per-
centage) and point size. 

• Ratio and percentage leading : are based on the normal leading 
of the largest type size in the preceding line. The normal leading is 
usually designed to be slightly larger than the point size of the type; 
e.g., a single line of 12-point text usually occupies about 15 points of 
vertical space when you specify 100% or Single Space leading. 
Therefore, double spaced, or 200%, leading for 12-point text 
increases the line spacing to about 30 points.

• Leading specified in points : is independent of the type size and 
normal leading of the typeface. The space from baseline to baseline 
is exactly the number of points specified, regardless of the size of 
the type. Using point size leading lets you maintain consistent line 
spacing, and fit text to specific space requirements; e.g., you have 
10 lines of text, and exactly 120 points of vertical space to place the 
text. To make the text fit, set the leading to 12 points.

Choose Text > Leading to set Single, 11/2, or Double Space leading. 
You can also choose the Tighten or Loosen commands to fine-tune 
the current leading in 0.5-point increments. You can tighten and 
loosen the leading repeatedly, but the line spacing cannot be less 
than zero. 

The Paragraph tab of the Type palette lets you adjust the leading 
by a specified percentage or point size. You can also add space 
between paragraphs by specifying additional spacing in points on 
the Paragraph tab of the Type palette.

Tip
The text settings in the Properties 
bar provides the same options as 
the Leading submenu. 
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To set leading using menu commands
1 Choose Text > Leading. A checkmark appears next to the 
current leading setting.

2 Choose a standard leading in the submenu, or choose 
Tighten or Loosen. Canvas applies the setting immediately.

To control line breaks 

“Soft” returns are forced line breaks which do not create new para-
graphs.

A page of text with “after 
paragraph” spacing

A page of text that does not have 
paragraph spacing, but uses both 
“before” and “after paragraph” 
spacing for block quotes

To set leading in the Type 
palette

Click the Paragraph tab of the Type 
palette. After configuring the settings, 
click Apply to implement them.

Percentage leading. To set the leading 
using a percentage of the line size, 
choose Percentage in the Line Spacing 
menu and enter an amount in the At 
box. A leading of 100% is the same as 
the Normal setting in the Text > Lead-
ing submenu. Double space is 200%, 
and 1.5 space is 150%. 

Point size leading. To specify leading in 
points, choose Points in the Line Spac-

ing menu and enter an amount in the At 
box. Although each font’s standard 
leading might be different, normal lead-
ing is generally between 110% and 
125% of the largest type size on the 
line; therefore, for 10-point type, nor-
mal leading is approximately 12 points.

Before paragraph. To insert space 
before the first line of a paragraph, 
specify the number of points in the 
Before paragraph box. This option does 
not apply to the first paragraph in a col-
umn.

After paragraph. To insert space after 
the last line of a paragraph, specify the 
number of points in the After paragraph 

box. Canvas inserts space after every 
paragraph, including the last paragraph 
in a column.

Note: Force a line break without creat-
ing a new paragraph by pressing Shift-
Return. See “To control line breaks,” 
page 30.16.
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1 Place the insertion point where you want the soft return.

2 Press Shift+Enter (Windows) or Shift+Return (Mac). Text to 
the right of the soft return moves to the next line.

• To view soft return symbols: Choose Layout > Display > Show 
Text Invisibles. 

• To hide soft return symbols: Choose Layout > Display > Hide 
Text Invisibles.

Setting indents
You can set the amount of space between the left and right borders 
of a text object and the edges of each paragraph using the Indents 
tab of the Type palette or the Properties bar. For text wrapped 
around an object, you can also use the Indents tab to set the dis-
tance between the edge of the object and the text.

Note: The Properties bar shows indent positions for one selected 
object at a time; therefore, you cannot use it to set indents for the 
preset format or for multiple selected objects.

Left 1 in., Right 1 in.Left 1 in. First line 1.5 in., Left 1 in. First line 1 in., Left 1.5 in
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Paragraph alignment 
Canvas aligns text to the indents of a text object. Canvas has four 
alignment, or justification, settings: flush right, flush left, full (flush 
with both right and left indents), or centered. You can set alignment 
in either the Text > Justification submenu, Properties bar, or Para-
graph tab of the Type palette.

 

To set indents on the Type 
palette

Click the Indents tab of the Type pal-
ette.

Left. To specify the distance between 
the left border of a text object and the 
left indent of a paragraph, enter the 
distance in the Left box. 

Right. To specify the distance 
between the right border of a text 
object and the right indent of a para-
graph, enter the distance in the Right 
box.

First Line. To specify a different indent 
for the first line of a paragraph, enter 
the distance in the First Line box. Can-
vas measures the first line indent from 
the left border of the bounding box.

Object Wraps. To specify the distance 
between an object and the edge of 
text wrapped around or inside that 
object, enter the number of points in 
the Object Wraps box.

Click Apply to implement the indent 
settings.

Left-justified Right-justified Full-justified Center-justified
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Note: Full justification may create wide letter or word spacing, espe-
cially in narrow text columns. Other justification settings (without 
hyphenation) might appear too ragged on one or both sides. 

To set justification using menu commands
1 Choose Text > Justification. A checkmark appears next to the 
current justification setting.

2 Choose an alignment option in the submenu. Canvas applies 
the justification setting immediately.

To set justification using the text settings in Properties bar
1 Drag the Text tool in the layout area or select a text object to 
make the text settings appear in the Properties bar.

2 Click a justification button. Canvas applies the justification 
setting immediately.

To set justification using the Type palette
1 Open the Type palette and click the Paragraph tab to bring it 
to the front.

2 Click a Justification button.

3 Click Apply to implement the justification setting.

Using vertical justification
Canvas can align text relative to the top and bottom borders of text 
objects. Canvas has four vertical justification, or alignment, set-
tings: Top, Bottom, Vertical Full, and Vertical Center. 

Vertical justification applies to an entire text object. To change the 
setting, select one or more text objects. Choose Text > Justification 
and choose a vertical justification setting in the submenu. A check-
mark appears next to the selected setting. 

Top vertical justification is the default setting for new text objects. 
Copying or duplicating text objects preserves their vertical justifica-
tion settings; however, if you copy a text selection and paste it into 
another object, the text follows the vertical justification of the text 
object in which you paste it.

Tip
You can set letter- and word-spac-
ing parameters to improve the 
appearance of text (see “Adjusting 
letter and word spacing” on 
page 30.22).

Tip
There must be space in the text 
object to use vertical justification, 
not including space created by 
empty paragraphs. The text 
objects must be created with the 
Text Object tool, not the Text tool.
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Vertical justification settings
Choose vertical justification settings in the Justification submenu.

Top Sets all lines of type starting from the top of a text object. This 
is the traditional vertical alignment for text objects; e.g., if a text 
object contains three lines of type, they appear at the top of the text 
object. Spacing between lines is controlled by the Line Spacing, 
Before Paragraph, and After Paragraph settings of the text.

Vertical Center Sets all lines of type so they are spaced evenly 
above and below the vertical center of a text object. If a text object 
contains three lines of type, for example, the lines appear at the cen-
ter of the text object. Spacing between lines is controlled by the 
Line Spacing, Before Paragraph, and After Paragraph settings of 
the text.

Bottom Sets all lines of type at the bottom of the text object. If a 
text object contains three lines of type, for example, the lines 
appear at the bottom of the text object. Spacing between lines is 
controlled by the Line Spacing, Before Paragraph, and After Para-
graph settings of the text.

Vertical Full Sets all lines of type so they are evenly spaced between 
the top and bottom borders of the text object. If a text object con-
tains three lines of type, for example, one line appears at the top, 
one appears at the center, and one appears at the bottom of the text 
object. Because it distributes type from the top to the bottom of a 
text object, Vertical Full justification can cause very wide spacing 
between lines if a large text object contains a little text. You can 
drag a handle at the top or bottom of a text object to adjust its 
height and alter the spacing between lines of text.

Top Vertical Center Bottom Vertical Full

Text object
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Paragraph rules
Paragraph rules are horizontal lines that Canvas draws above a 
paragraph, below a paragraph, or both. You can select pen type, 
dash, color, length, and offset for paragraph rules.

To apply paragraph rules
1 Place the insertion point or make a selection in the para-
graph. You can highlight multiple paragraphs to select them.

2 Choose Text > Rules. The Paragraph Rules dialog box opens.

3 In the Paragraph Rules dialog box, select Rule Above or Rule 
Below. You can select either or both options. The options for Rule 
Above and Rule Below can be set independently.

4 Select rule options, then click Apply to preview the rules. 

5 Click OK to apply the rules and close the dialog box.

Paragraph Rules options
When you configure a paragraph rule, a preview of the rule appears 
in the box in the Rule Above or Rule Below section of the Para-
graph Rules dialog box.

Rule Above and Rule Below Draws rules above or below selected 
paragraphs. Both can be selected. The size, placement, and 
attributes of rules are based on the settings in the dialog box. If a 
paragraph has rules and you clear the checkboxes, Canvas removes 
the rules.

Length Use the menu to choose an option for the length of para-
graph rules. 

• Indents : sets the rule length based on the values in the From 
Left and From Right boxes. These values set the distances from the 
ends of the rules to the right and left borders of the text object 
(independent of paragraph indents).

• Text: makes the rule length equal to the first line (for rules 
above) or last line (for rules below) of a paragraph. The From Left 

Tip
The Paragraph Rules command is 
not available unless a text object is 
in edit mode. 
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and From Right options are not available when the Text option is 
selected.

Offset Enter a value in points to space the rule away from the 
adjacent line of text. The position for rules above is measured from 
the descenders of the last line of the previous paragraph. For rules 
below, the position is measured from the descenders of the last line 
of the current paragraph. You can enter a minimum value of -10 
points to move the rule closer to the text. You can enter a maxi-
mum value of 72 points to move the rule away from the text. 

Pen Select a stroke for the rule from the Pen pop-up palette. You 
can select a solid pen, neon, or parallel stroke.

Dash To apply a dash to the rule, select a dash style from the Dash 
pop-up palette.

Color Select a color for the rule from the Color pop-up palette.

Adjusting letter and word spacing
Depending on the type of justification you choose, you might want 
to adjust letter and word spacing to reduce raggedness or eliminate 
unusual spacing; e.g., left-justified paragraphs might appear too 
ragged on the right edge, and full-justified paragraphs might have 
large spaces between characters and words. 

You can specify a minimum line width for a paragraph to reduce 
raggedness. In addition, Canvas has letter- and word-spacing 
parameters to let you specify minimum, maximum, and desired 
spacing guidelines.

To adjust letter and word spacing
1 Depending on how you want the letter and word spacing set-
tings to apply, do one of the following:

• To change existing text: Select the paragraphs or text objects. 
To set spacing for only one paragraph, place the insertion point 
anywhere in the paragraph.

• To set the spacing before typing a new paragraph: Place the 
insertion point at the beginning of the paragraph.

• To apply the spacing settings to the preset format: Deselect all 
objects.
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2 Open the Type palette by choosing Text > Type.

3 Click the Paragraph tab to bring it to the front, if necessary.

4 Depending on the type of justification applied to the text, use 
the following options on the Paragraph tab: 

• For right-, left-, and center-justified text: To set the “Mini-
mum line widths,” enter a percentage in the text box. The 
percentage tells Canvas to adjust letter and word spacing 
so that each line is at least as wide as specified; e.g., if you 
create a two-inch wide, left-justified paragraph and set the 
minimum line width to 75%, Canvas adjusts the spacing so 
that each line is at least 1.5 inches wide. Only the last line 
in a paragraph is unaffected by the “Minimum line 
widths” setting.

• For full-justified text: To tell Canvas when the last line of a 
paragraph is wide enough to be justified (flush with both 
right and left margins), enter a percentage in the “Justify 
Last Line Within” box; e.g., you create a two-inch wide, 
full-justified paragraph and tell Canvas to justify the last 
line within 75%. If the last line is less than 1.5 inches wide, 
Canvas does not justify the line. However, if the last line is 
wider than 1.5 inches, Canvas justifies the line.

5 To set letter and word spacing parameters, click the Spacing 
tab to bring it to the front, if necessary. Set the minimum, desired, 
and maximum spacing in the Letter and Word areas. Specify each 
setting as a percentage of the current spacing. The desired spac-
ing must be greater than the minimum and less than the maxi-
mum. The maximum spacing cannot be less than the minimum.

Canvas will try to adjust spacing to the desired percentage, but 
might not be able to depending on minimum line width and justifi-
cation settings. In these cases, Canvas will then try to adjust the 
spacing within the minimum and maximum percentages you spec-
ify. However, if the minimum and maximum spacing parameters 
are still in conflict with minimum line width or full justification set-
tings, Canvas will ignore the spacing parameters.

To change the spacing of a paragraph by a set amount, you can set 
the minimum, desired, and maximum percentages to the same 
value. This has a similar effect to kerning the entire paragraph.

6 Click Apply to implement the settings. 

Spacing settings on the Paragraph tab

Tip
If you applied kerning to charac-
ters within the selection, Canvas 
adjusts the spacing as a percent-
age of the kerning.
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Automatic hyphenation
Canvas can insert a hyphen in the last word of a line to give text 
objects a more balanced, even appearance. You can also control the 
hyphenation properties so that Canvas only hyphenates under spe-
cific circumstances. Hyphenation settings apply to entire para-
graphs. To hyphenate a specific word, you can manually insert a 
hyphen.

Specifying text flow options
You can set text flow options to avoid leaving just a few lines at the 
top or bottom of a column of flowed text. The term widow describes 
the first line of a paragraph that appears at the bottom of a column, 
and orphan refers to the last line of a paragraph that appears at the 
top of a column. Canvas can prevent widows and orphans in a text 
flow by moving the page or column break higher and sending lines 
to the next page or column. In addition, you can specify that all 
lines in a paragraph stay together, or that certain pairs of para-
graphs always remain together in the same column.

To modify a column break in a particular paragraph, keep all lines 
in a paragraph together, or keep two paragraphs together, you 
should change the text flow settings for the specific paragraph only. 
In most cases, you won’t want these settings to apply to every col-
umn break.

Hyphenation settings on the Type 
palette

Click the Hyphen tab to bring it to the 
front. Turn hyphenation on and configure 
the following settings.

After word beginning. Specify the mini-
mum number of letters that must precede 
a hyphen.

Before word ending. Specify the minimum 
number of letters that must follow a 
hyphen.

Smallest word. Specify the minimum 
number of letters that a word must have 
to be hyphenated.

Consecutive line limit. Specify the 
number of consecutive lines that can 
end in hyphens; e.g., if four consecu-
tive lines could end in hyphens but 
the limit is three, Canvas does not 
hyphenate the last word of the fourth 
line.

Skip capitalized words. Turn this 
option on to prevent proper names 
and other words beginning with a 
capital letter from being hyphenated.

Click Apply to implement the hyphen-
ation settings.
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Note: Although you can specify widow and orphan settings for indi-
vidual paragraphs, you should apply these settings to entire objects. 
This way, as you edit and move paragraphs, the location of the col-
umn break can change without causing widows and orphans.

To prevent widows and orphans
1 Open the Type palette and click the Spacing tab. Configure 
the widows and orphans settings (described next).

Setting drop caps
Drop caps are large characters that extend below the normal base-
line of the first line of an opening paragraph. Canvas indents the 
text below the first line to make room for the drop caps. You can 
format drop caps for any selected paragraphs.

To set up a drop cap
1 Depending on how you want the drop cap to apply, do one of 
the following:

To apply to Do this

First paragraph in a text object Select the object or place the insertion point 
anywhere in the first paragraph

All other paragraphs Place the insertion point in a paragraph, or 
select a paragraph. You can also select mul-
tiple consecutive paragraphs

A new paragraph you are about to 
type

Place the insertion point at the beginning of 
the paragraph

Widow and orphan settings

Use the Paragraph area of the Spacing 
tab to configure widows and orphans 
protection properties. If an “X” appears 
in a checkbox, that feature is active.

Widow. Turn on to activate widow pro-
tection. 

Specify the minimum number of lines 
that can appear in the last paragraph of 
a column.

Orphan. Turn on to activate orphan 
protection.

Specify the minimum number of lines 
that can appear at the top of a column 
in a linked flow.

Keep all lines. To prevent Canvas from 
inserting a column break in a para-
graph, turn on this option. This pre-
vents widows and orphans, but might 
leave a lot of blank space at the bottom 
of a column.

Keep with next. To prevent two para-
graphs from being separated by a col-
umn break, turn on this option. This 
option is useful for keeping a one-line 
paragraph, such as a heading, together 
with its section.

Click Apply to implement the text flow 
settings.
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2 Configure the drop cap options described below.

Inserting headers and footers
You can add header and footer text objects using commands in the 
Text > Insert menu. Headers and footers are special text objects 
that can contain codes for the current date, current time, and page 
number, in addition to text you type. Canvas updates the date, 
time, and page number codes each time it redraws the screen.

In Publication documents, Canvas inserts headers at the top of the 
publication layout area (above the page margins) and footers at the 
bottom of the publication layout area (below the page margins). In 
other documents, Canvas places the header in the upper left corner 
of the page and the footer in the lower left corner.

Both types of objects initially span the width of the page, but you 
can resize and move them just like other text objects.

To insert header and footer text objects Choose Text > Insert > 
Header or Text > Insert > Footer. Canvas creates the text object, 
and places it in edit mode.

The preset format Deselect all objects. Canvas will apply drop 
caps to the first paragraph of all new text 
objects you create with the Text tool

To apply to Do this

Drop cap settings

If necessary, open the Type palette by 
choosing Text > Type. Click the Indents 
tab to bring it to the front.

Lines. Specify the number of lines you 
want the drop caps to occupy. This 
determines the vertical height of the 
drop cap.

Characters. Specify the number of char-
acters to enlarge for drop caps. Canvas 
always applies this setting beginning 
with the first character in a paragraph.

Click Apply to implement the drop cap 
settings.

Tip
You can’t add headers and footers 
in edit mode, press Enter (Mac) or 
Esc (Windows) to end text editing.
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Inserting dates, times, and page numbers
Insert date, time, and page number codes in header and footer text 
objects. Canvas will update the values for these codes each time it 
redraws the screen, unless the Date Stamp and Time Stamp com-
mands are used. Canvas uses the date and time as set in the operat-
ing system.

You can insert the current date and time in text objects (see “Text 
objects,” page 29.1); however, Canvas does not update this text 
since it is “stamped” into the document as regular text. You can 
change page number (symbol $P) and total page count (symbol $T) 
displayed by adding a simple formula to them.

You can apply text formatting or Type Styles (see “Working with 
type styles,” page 31.1) to the date, time, and page codes; e.g., 
change fonts, type sizes, and justification, as you would apply for-
matting to normal text with the Text menu, Properties bar, or Type 
palette.

When entering the formula, remember the following:

• The formula can contain only “+” and “-” as operators or 
numbers. Do not use spaces between the characters.

• The formula may be of any length, but it must be in a for-
mula format.

• To insert the date, time, or page number: With a header or 
footer object in edit mode, choose Text > Insert (see “Date and time 
commands” and “Page numbering commands”).

Date and time commands

To insert In this type of object Do this

Updating date code Header or footer Choose Insert > Date, or type $d

Date stamp Any text object Choose Insert > Date Stamp

Updating time code Header or footer Choose Insert > Time, or type $e

Time stamp Any text object Choose Insert > Time Stamp

Tip
Refer to your system documenta-
tion for information on setting the 
current date and time.
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Page numbering commands

Note: If you unintentionally place spaces between the page numbers 
and operators, the page numbering will create errors; e.g., the for-
mula Page $P+4 -8 of $T+4 -8 would appear as Page 6 -8 of 12 -8.

To insert In this type of object Do this

Current page number Header or footer (page count 
is static in normal text 
objects)

Choose Text > Insert > Page #, or type $p

Total page count Header or footer (page count 
is static in normal text 
objects)

Choose Text > Insert > Total Page #, or type $t

Page # of total pages
e.g., Page 2 of 8

Header or footer (page count 
is static in normal text 
objects)

Choose Text > Insert > Page # of Total Page #, or type Page $P of 
$T

Page -# of total pages
e.g., Page -2 of 4

Header or footer (page count 
is static in normal text 
objects)

Choose Text > Insert > Page #+4-8 of Total Page #+4-8, or type 
Page $P+4-8 of $T+4-8
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31
WORKING WITH TYPE STYLES

Define text formatting settings and save them as character and 
paragraph type styles using the Styles tab in the Type palette. Can-
vas stores type styles with documents. When you open a document, 
Canvas loads the associated styles so you can apply them; however, 
Canvas also gives you the option of saving defined styles in a file 
which can be shared with others (see “Saving and loading type 
styles,” page 31.3).

Type styles make it easy to apply formats and maintain consistency 
throughout a document. Base styles on each other to form a “fam-
ily” of styles, so that styles inherit the character and paragraph 
attributes of a parent style. Organizing styles in this manner makes 
global style changes a simple matter of changing the parent style.

• To open the Type palette: Choose Text > Type or double-click 
the Text tool.

Creating new type styles
You can create two kinds of styles, character and paragraph, which 
incorporate different formatting attributes. After establishing char-
acter and paragraph styles, apply them independently to create new 
combinations.

Character style attributes Paragraph style attributes

Font Leading

Type size Indents

Font style Justification

Capitalization style Drop caps

Baseline position Hyphens

Kerning Letter and word spacing

Colors (optional) Text flow settings

Character attributes and colors 
(optional)

Tip
Before you start defining type 
styles, review the chapter “For-
matting text,” page 30.1 to learn 
about fonts, font styles, etc.
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Using style families
When you base a style on an existing style, the new style “inherits” 
the attributes of the parent style. When the parent style changes, 
Canvas also updates all related styles. In addition to inherited 
attributes, the style possesses its own attributes, which you specify.

You create a style, Body2, based on a parent style, Body1. The fonts 
are the same, but the type sizes are different. Body2 uses 10 point 
type, while Body1 uses 12 point. If you change the font for the par-
ent style, the font also changes for Body2. However, if the point size 
changes for the parent style, Body2 does not change, because 
Body2’s own attributes take precedence. To make Body2 always 
use the same point size as Body1, you must set the point sizes equal, 
base Body2 on Body1, and save the style again. 

To create a type style

To save the attributes of existing text 
as a style, place the insertion point in 
the text and open the Type palette. 
You can also create a type style with-
out first applying the text settings to 
text.

Choose settings for a type style on the 
other tabs and then click the Styles tab 
to bring it to the front.

A Example. Displays a sample of text 
with the current formatting settings ap-
plied.
B Description. Lists the current char-
acter or paragraph attributes. The C and 
¶ icons toggle between descriptions of 
character and paragraph attributes.

To save a type style, click Create to 
open the Create Type Style dialog box. 

Create Type Style dialog box

Configure the following style settings.

C Character or Paragraph. Click a 
button to specify what kind of style you 
want to create.
D Based on. If there are existing 
styles, choose a style name on which to 
base the new style. To disable this fea-

ture, choose None (see “Using style 
families,” page 31.2).
E Include. Select the attributes to 
save as part of the style. You can include 
ink settings (fill and stroke attributes that 
have been applied to existing text) in 
character and paragraph styles. These 
inks don’t affect the current inks for vec-
tor objects.

For paragraph styles, you can also 
include font attributes and tab settings.

If a text selection has a frame or back-
ground ink, you can’t include these 
attributes in a style. In addition, when 
text doesn’t have a stroke, you can’t 
include strokes in a style.

F Style name. Type a name for the 
style. Click Save to store the style and 
close the dialog box.

Tip
A style’s own attributes always 
take precedence over attributes 
inherited from the parent style.
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In addition, if you later change Body2’s font, this style will no longer 
inherit fonts from the parent style. Body2’s font will override 
Body1’s font setting.

Careful planning will save you from time-consuming corrections 
when basing styles on each other. In some cases, changing a parent 
style’s attributes may cause unwanted changes throughout the style 
family; e.g., if you base ten styles on Body1, and later decide that 
you want Body1 (but not the whole family of styles) to be double 
spaced, you must first change the leading for Body1, then remove the 
leading setting from each of the other ten styles.

Saving and loading type styles
You can save type styles to files and then load them into other doc-
uments. This feature helps maintain consistency between docu-
ments, and lets you share type styles with other Canvas users on 
both Windows and Mac platforms.

To save a type style to disk
1 Press the menu icon at the bottom of the Styles tab.

2 Choose Save Style in the menu. A directory dialog box opens.

3 Type a file name and specify a location to save the file.

4 Then click Save.

On Windows, the saved file has a .STY extension. On Mac, the 
saved file may not indicate the extension. You must add the .STY 
extension to this file name to share the style with someone using 
Canvas on Windows. 

To load a type style
1 Press the menu icon at the bottom-left of the Styles tab. 

2 Choose Load Style in the menu. A directory dialog box 
opens.

3 Locate and select the styles file.

4 Then click Open.

Copying type styles between documents
Another way to transfer type styles from one document to another 
is to copy text that uses the style and paste the text into a different 
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document. Canvas transfers the style with the text. When you save 
the document, Canvas also stores the transferred style.

A type style based on another style cannot inherit attributes across 
documents; e.g., Body2 is based on a parent style, Body1, and you 
copy only Body2 to a new document. Body2 in the new document 
no longer inherits attributes from Body1, which is still in the origi-
nal document. 

However, if you copy both Body1 and Body2 to a new document, 
the relationship is preserved, and Body2 will inherit attributes from 
its parent style.

If you happen to paste a style that already exists in the other docu-
ment, Canvas modifies the name of the pasted style to avoid over-
riding type styles; e.g., a style named “Body 2” could become “Body 
2 -2” when pasted in the new document.

Using type styles
Once you’ve created your document’s type styles, you can start 
applying them, modifying their attributes, and deleting them from 
the document. All these processes are done with the Type palette.

Applying type styles
You can apply type styles with the Type palette as well as the Prop-
erties bar. Applying type styles with the Type palette is similar to 
applying individual character or paragraph formats; however, 
instead of configuring settings on each of the tabs in the palette, 
simply choose style names from the menu on the Type palette. 

The menu displays the current type style name. The C and ¶ indi-
cate if the style is a character or paragraph style, or both. If “+++” 
appears to the right of a style name, the style has been modified but 
not saved. If you choose a style in the menu when “+++” appears 
next to the current style, you will lose the modifications to the style. 
Therefore, if you want to use the settings again, you must save the 
modified style with a new name before applying other styles.

The type styles are also accessible in the Properties bar while in text 
edit mode or when the Text tool or a text object is selected.

Type style menus
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To apply a style to selected text or text objects with Type 
palette
1 Select the text or text object(s) to which you want to apply a 
style. 

2 Choose a style in the menu on the Type palette.

3 Click Apply to implement the style.

To apply a style to selected text or text objects with Properties 
bar

1 Select the text or text object(s) to which you want to apply a 
style. 

2 Choose a style from either menu on the Properties bar. The 
style is immediately applied.

If the text you selected already had a style applied, Canvas replaces 
the style with the style you choose. In addition, if you apply a para-
graph style with font attributes to highlighted text, the font 
attributes affect the selection only, and the paragraph attributes 
affect the entire paragraph.

To use a type style as the current format setting
Deselect all text objects by pressing Esc, if necessary. 

1 Choose a style in the menu on the Type palette.

2 Click Apply. Canvas formats new text objects with the speci-
fied style.
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Modifying type styles
You can change the attributes of a type style and save the style with 
the same name. When you change a style’s attributes, all styles in 
the family automatically inherit the new shared attributes.

To modify a type style
1 Choose the style you want to edit from the menu.

2 Change the style’s attributes. Canvas displays “+++” after the 
style name to indicate that changes were made to the style.

3 Click the Styles tab and then click Create. The Create Type 
Style dialog box opens (see “Create Type Style dialog box,” 
page 31.2). 

The current style name is in the Based On menu and Style Name 
box. To replace the style, do not change these settings.

4 Select the checkboxes of the attributes that you want to 
include.

5 Click Save. Confirm that you want to replace the existing 
style with the new style. Click OK.

Deleting type styles
To minimize confusion when choosing styles to apply, delete type 
styles you no longer use. Text using a deleted type style retains its 

Tips on using type styles

By putting some forethought into the purpose and design of 
type styles, you ensure that you are using this feature effec-
tively. This planning will be especially useful when editing 
styles and documents, allowing you to make a few modifica-
tions that update entire documents.

Design a template. If several people need to use the styles, 
save the styles in a template document. This way, everyone 
uses a common source for the styles.

Create a “normal” type style. This will make it easy to revert 
formatted text to a basic style. When you apply the normal 
style, it will have the effect of removing or overriding other 
styles.

Name styles by their function; e.g., a heading style might con-
sist of boldface type. Rather than name this style “Bold,” 

name it “Heading,” or something that similarly describes its 
usage. This will make it easier to remember when to use 
which style.

Always apply a style. If you use styles in documents, use 
them throughout. If you apply styles only sometimes, you will 
encounter difficulties maintaining consistency and perform-
ing global style changes.

Create style families when possible. You might want to use 
the Based On feature (see “Creating new type styles” on 
page 31.1) to create style families for styles that share some 
attributes. This will make global changes easier. See “Using 
style families” on page 31.2, for more information. 

Indicates character or 
paragraph style

Style name

Indicates modified style

Tip
The options in the Include area 
change for Character and Para-
graph styles.
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formatting, but no longer has a named style. See the following illus-
tration for other effects of deleting a type style that is part of a style 
family.

To delete a style
1 Click Delete on the Styles tab of the Type palette. The Delete 
Type Style dialog box opens. 

2 Choose the style to delete from the Name menu.

3 Click OK.

Applying character formatting
Canvas gives you precise control over the appearance of each char-
acter. Set the font, type size, font style, kerning, capitalization style, 
scale, and baseline position using menu commands or the Charac-
ter tab of the Type palette.

Character attributes are applied by selecting the specific characters 
that you want to modify. Select any portion of text — from one char-
acter to entire text objects (see “Selecting text and objects,” 
page 30.1).

Deleting parent styles

The diagram shows the results of deleting 
type styles on which other styles are based. 
Arrows indicate relation between styles. 

A Body2 is based on Body1. Deleting Body1 
makes Body2 an independent style.
B Body3 is based on Body2, which in turn is 
based on Body1. Deleting Body2 makes Body3 
based on Body1.

Body1

Body2

Body1

Body1

Body2

Body3

Body1

Body3

Body2

Body2
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Preventing changes to character attributes
On the Character tab in the Type palette, you can lock the current 
font, type size, and font style to prevent accidental changes. This 
feature is especially useful when several people are using the same 
Canvas document. In addition, you can also use this feature to 
selectively exempt sections of text from global formatting changes. 
Once you lock a setting, no one can change it without first unlock-
ing it.

To lock character attributes
1 Click the Character tab on the Type palette.

2 Change any font, size, or style attributes at this time.

3 Click the Lock button to the right of the attribute.

4 Click Apply. Canvas first applies the new font attributes, then 
locks the new attributes.

To set character attributes

The Character tab lets you control all 
character attributes. Some attributes, 
such as type face, type size, font style, 
baseline, and kerning, are also available 
in the Text menu or Properties bar.

Font. Choose a typeface in the menu.

Size. Choose a type size in the menu or 
type a number in the text box.

Style. Click a button to select a font 
style.

Case. Choose a capitalization style in 
the menu.

Baseline. Specify subscript or super-
script settings to one hundredth of a 
point precision.

Kerning. Tighten and loosen kerning by 
hundredths of a point.

Scaling. Specify percentages by which 
you want to scale the current type size. 
Set individual horizontal and vertical 
scaling percentages.

A Locks. To prevent accidental or un-
wanted changes to the type face, type 
size, or font style of specific text, you can 
set these locks. If you want to change 
locked text, you must first unlock the 
text.

Lock button
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32
TEXT EDITING & PROOFING

You can insert, search, replace, move, delete, copy, and spell check 
text in Canvas documents. This chapter describes how to navigate 
through text for editing, make text selections, and use spelling tools 
and the Find feature for text search-and-replace.

Text edit mode
To edit text, put a text object in edit mode. In edit mode, you can 
revise, delete, insert, and select specific text. Only one object is in 
text edit mode at a time. 

Entering text edit mode
Put a text object in edit mode with the Text tool or Selection tool. 
When a text object is in edit mode, the text object becomes opaque, 
the selection handles disappear, and a flashing insertion point 
appears. Also, the Text tool becomes the active tool.

• To enter edit mode using the Text tool: Select the Text tool and 
click in a text object. An insertion point appears where you click, 
and you can begin typing or editing.

• To enter edit mode using the Selection tool: With the Selection 
tool, double-click a text object. If you double-click on a word, the 
word becomes selected and is highlighted. The Text tool is 
selected, and you can begin typing or editing.

• To edit text bound to a path: With the Path Text tool or the 
Text tool, click the text. An insertion point appears in the bound 
text, and you can begin typing or editing.

• To leave text edit mode: Press Esc when you finish text editing. 
Canvas switches to the Selection tool from the Text tool. The text 
object you were editing is selected.

Text selection and navigation 
Move the insertion point and select characters, words, lines, and 
paragraphs using the mouse or keyboard.

In edit mode, an insertion point 
appears in the text object.

Insertion point
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The mouse lets you quickly select text or text objects and move the 
insertion point. However, if you work with a lot of text, you might 
find that the keyboard techniques let you move the insertion point 
more precisely to edit more quickly.

Making text selections
Before you can cut, copy, move, delete, type over, or perform other 
operations on text characters, you need to select the text within a 
text object. You can select text when a text object is in edit mode.

The phrases “selected text,” “text selection,” and “highlighted text” 
all refer to an active selection of characters within a text object. 
Selected text appears highlighted; the highlight color depends on 
your system’s color settings.

Keep in mind that a text selection is not the same as a selected text 
object. When you select a text object, you can move, copy, delete, 
and perform other operations on the entire object. When you make 
a text selection, the editing actions will affect only the highlighted 
characters within the object.

• To deselect all highlighted text: Click anywhere in the text 
object or layout. Clicking outside the selected text object creates 
another text object at that location.

Using the keyboard for text editing
While editing text, use the key combinations listed in the following 
table to move the insertion point and select text. 

Key combinations for text editing 

Press this key and these keys to do this in edit mode

None Up arrow, Down arrow, 
Right arrow, Left arrow

Move insertion point 1 space right or left

Page Up, Page Down Move insertion point 3 lines up at the left margin (Page Up) or 
down at the right margin (Page Down) 

Home, End Move insertion point to the beginning (Home) or end (End) of the 
text object
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Using the mouse for text editing
Using the mouse and modifier keys, you can quickly place the inser-
tion point, select specific words, and select sections of text in edit 
mode. For information on putting a text object in edit mode, see 
“Text edit mode” on page 32.1.

Mouse actions for text editing

Option (Mac)

Ctrl (Windows)

Right arrow, Left arrow Move insertion point to the next word end (Right arrow) or begin-
ning (Left arrow)

Up arrow, Down arrow Move insertion point to the left margin of the line, or up 1 line at the 
left margin (Up arrow), or down 1 line to the left margin (Down 
arrow)

Home, End Move insertion point to beginning (Home) or end (End) of line

Shift Right arrow, Left arrow Extend selection 1 space right or left

Up arrow, Down arrow Extend selection 1 line up or down 

Page Up, Page Down Extend selection 3 lines up or down

Home, End Extend selection to the beginning (Home) or end (End) of the text 
object

Shift + Option (Mac)

Shift + Ctrl (Windows)

Right arrow, Left arrow Extend the selection 1 word right or left

Up arrow, Down arrow, Extend the selection to left margin (Up arrow) or right margin 
(Down arrow). From the margin, extend the selection to the other 
margin, or up or down 1 line

Page Up, Page Down Extend selection 3 lines up or down

To do this in text Do this with the pointer

Select a continuous block of text Drag over the text you want to select

Select all text between the insertion point and another 
location

Press the Shift key and click where you want the selection to end. 
Windows users can use the right mouse button like the Shift key 
(hold down the right button and click with the left).

To deselect all highlighted text Click anywhere in the text object. (Clicking outside the text object 
creates a new text object at that location or puts another text object 
into edit mode.)

Deselect text between the insertion point and another 
location in the selection

Press Shift and click in the highlighted text

Press this key and these keys to do this in edit mode
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Copying, pasting, deleting, and moving text selections
You can cut and copy a text selection, and then paste the selected 
text in the same document, in another Canvas document, or to and 
from a non-Canvas document using the Clipboard. Whether pasted 
text retains its formatting depends on the operating system and the 
source of the text. 

• Text pasted from the Mac OS Clipboard that originated in 
another application will be formatted with the current 
Canvas text formatting when pasted into a Canvas docu-
ment, regardless of the formatting applied in the originat-
ing application. 

• In Windows, text pasted from another application can be 
embedded into a Canvas document, using Object Linking 
and Embedding (OLE) to preserve its formatting. See 
“Embedded text objects and editions containing text” on 
page 32.16.

If you copy and paste selected text (and not an entire text object) 
within Canvas, the text retains its character attributes, but it adopts 
the paragraph formatting of the surrounding text. 

To copy and paste selected text
When you copy selected text, you can create a new text object or 
insert the text into an existing text object.

1 Select the text you want to copy.

2 Choose Edit > Copy to copy the selection to the Clipboard.

3 Depending how you want to paste the selection, do one of the 
following:

• To paste text into an existing text object: Put the insertion point 
in the text where you want to paste the insertion.

• To paste text as a new text object: Be sure no objects are in text 
edit mode by pressing Esc. You can set the width of the new text 
object by selecting the Text tool and dragging. Otherwise, text will 

Select a word Double-click the word

Select a line of text Triple-click the line

To do this in text Do this with the pointer

Tip
To help you in editing text, display 
symbols for spaces, paragraph 
breaks, and tabs. Choose Layout > 
Display > Show Text Invisibles. To 
hide these symbols, choose Layout 
> Display > Hide Text Invisibles.
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be pasted in one long line that might extend off the screen (see 
“Creating text layouts” on page 29.4).

4 Choose Edit > Paste to insert the text from the Clipboard. 

To cut text
1 Select the text you want to cut.

2 Choose Edit > Cut. The text is cut to the Clipboard and is 
ready to be pasted to another area.

To delete text
1 Select the text you want to delete.

2 Choose Edit > Clear, or press Delete. 

• To replace selected text: Begin typing, or use the Paste com-
mand, to replace a text selection with the text you type or paste 
from the Clipboard. This saves the step of deleting the selected text. 

• To replace all text in a text object: Select a text object and begin 
typing. The text adopts the formatting of the replaced text. If multi-
ple text objects are selected, the text you type replaces the text in 
the object that was created first.

Changing text attributes
While a text object is selected, you can change the formatting of all 
the text it contains using the Text menu, Type palette, or Proper-
ties bar.

Finding and changing text
Use the Text tab in the Find palette to search for specific text or 
characters in selected text objects and entire documents. You can 
replace or delete found text selections one at a time or all at once 
(see “Text search options,” page 32.8).

The Text tab also lets you search for text with specific font, size, 
and style attributes, and change the attributes of found text.

To find and change text
1 Choose Edit > Find to open the Find palette. Click the Text 
tab to select it. To search for text, type the text in the Find box or 
select a special text character. Specify that you want to find only 
whole words or text matching the capitalization (case) of the Find 
text. 
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2 If you want to replace found text or characters, type the 
replacement text in the Change To box or select a special text 
character. When the Change To box contains at least one charac-
ter (including a space), the Change All button is available.

3 Click Find to locate the first occurrence of the specified item. 
If one or more text objects are selected, Canvas searches the text 
contained in the first selected object. If no text objects are 
selected, Canvas searches the entire document.

4 If Canvas finds the specified item, it highlights the text or 
character in the document. Click Find to search for the next 
occurrence of the specified text. If the Change To box contains 
replacement text or a special character, the Change button is 
available. Click Change to replace the highlighted item with the 
Change To text or special character.

5 To continue searching, click Find. Repeat the previous step if 
Canvas finds another occurrence of the search item. When Can-
vas completes the operation, it displays a message. Click OK in 
the message box to continue.

Note: You can click Change All to replace all occurrences of the 
Find text or special character with the text in the Change To box, 
without first clicking Find.

Finding and changing text attributes
You can search for and change text attributes (whether or not you 
also search for specific text). The text attributes you can seek and 
change are font, type size, and text style (see “Find Attributes,” 
page 32.8 and “Change Attributes To,” page 32.8). 

To search for text attributes
1 Click the arrow at the bottom-left corner of the Find palette. 

2 In the Find Attributes section, select a font name from the 
font pop-up menu. Type a size (in points) or select a size from the 

Font menu

Style buttons

Type size
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size pop-up menu. Click the style buttons to set the styles you 
want. 

3 In the Change Attributes To section, specify replacement 
attributes in the same way that you specify the Find attributes.

4 Click Change or Change All to replace the attributes speci-
fied in the Find Attributes section with the attributes specified in 
the Change Attributes To section. If you have also typed text in 
the Find box, the replacement text attributes can be applied only 
to text that matches the Find text. 

Clicking the Clear button removes all settings in the Find 
Attributes and Change Attributes To areas. 
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Automatic text correction
Canvas can automatically fix typographical mistakes as you type. 
The Auto Correct manager lets you select several automatic correc-
tion options. It also lets you specify common misspellings, typing 
errors, and abbreviations that you want Canvas to replace as you 
type. 

When any text replacement option is active, Canvas checks each 
word you type. It corrects or replaces text as appropriate once you 
press the Spacebar.

Text search options

The options on the Text tab in the 
Find palette let you specify criteria for 
text and character searching and 
replacement.

Find. Type the text or select the spe-
cial character (1) that you want to find. 
Leave this box blank to search for text 
attributes only.

Change To. If you want to replace 
found text or characters, enter 
replacement text or character (1) 
here. If you want to delete found text 
or characters, leave the Change To 
box empty.

Whole Word. Select Whole Word to 
specify that the Find text is an entire 
word; e.g., if you type “time” and 
select Whole Word, Canvas will not 
find “times,” “untimely,” or “timer.”

Match Case. Select Match Case to 
include the capitalization of the Find 
text in the search criteria; e.g., if you 
type “Time” and select this option, 
Canvas will not find “TIME” or “time.”

Change. If Canvas locates the speci-
fied text and attributes, it highlights 
the text in the document. Click 
Change to replace the highlighted text 
with the Change To text and to apply 
the replacement attributes specified in 
the Change Attributes To section.

Change All. Click to replace all occur-
rences of the text and attributes you 
specified with the replacement text 

and attributes. Canvas makes the 
changes without highlighting found 
text.

Find button. Click to search for the 
next occurrence of text specified in 
the Find text box and attributes 
specified in the Find Attributes 
area.

Find Attributes

The text attributes that you specify 
here tell Canvas what to search for. 

A Click to display Attributes op-
tions. 
B To search for a particular font, 
select the font name from the pop-
up menu.
C To search for a type size, enter 
the size or select the size from the 
pop-up menu.
D To search for a type style, select 
a style button. You can select bold, 
italic, underline, outline, 
strikethrough, and shadow styles.

Change Attributes To

The text attributes that you specify 
here can be applied to text that 
matches the attributes specified in the 
Find Attributes area.

E Select the font from the pop-up 
menu.
F Enter the replacement size (in 
points) or select the size from the pop-
up menu.

G Click style buttons to specify re-
placement styles. You can choose bold, 
italic, underline, outline, strikethrough, 
and shadow.

Clear.  Click to delete all the settings 
from the Find Attributes and Change 
Attributes To areas.
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Auto Correct options 
Use the options in the Auto Correct manager to specify corrections 
you want Canvas to make as you type (see “Auto Correct,” 
page 13.11). 

To set up automatic correction
1 Choose Text > Spell Checker > Auto Correct. 

2 In the Auto Correct manager, select the replacement options 
to use.

3 Click OK to implement the current settings.

Setting up text replacement
Specify abbreviations, common misspellings, and other text that 
you want Canvas to replace as you type. 

Use this feature to expand abbreviations for common phrases and 
long names that you type throughout a document: e.g., if you often 
type “Department of Agriculture,” you can specify that the abbrevi-
ation “DA” be replaced by the full name.

To set up text replacement 
1 Choose Text > Spell Checker > Auto Correct. In the Auto 
Correct manager, be sure Replace Text as You Type is selected.

2 In the Replace box, type text that you want to be replaced. In 
the With box, type the replacement text. Click Add to place the 
text in the scrolling list. 

3 Repeat this procedure to specify more automatic replace-
ments. Add as many items to the scrolling list as you want. When 
you finish, click OK.

Note: Auto Correct does not remove specified text from a document 
if you type nothing in the With box. Also, Auto Correct won’t 
replace spaces with more or fewer spaces (such as replacing two 
spaces with one space); however, you can use the Text tab in the 
Find palette to find and replace spaces.

• To remove replacement entries: Select the entry in the scrolling 
list and click Delete.
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Automatic spelling correction
When you use the Spelling menu (“To use the spelling pop-up 
menu,” page 32.14) to correct a misspelling, Canvas adds the item 
to the Auto Correction list. The misspelled word appears under 
Replace and the correction appears under With. If you make the 
same spelling mistake again and “Replace Text as You Type” is 
selected in the Auto Correct manager, Canvas corrects the error. If 
“Replace Text as You Type” is not selected, Canvas won’t make 
these automatic corrections.

Inserting special characters and graphics in text
Sometimes it is necessary to enter special typographic symbols into 
text. You can insert special characters using the command Text > 
Insert or Keycaps (Mac) and the Character Map (Windows).

To insert a symbol
1 While in text edit mode, place the text I-beam at the location 
in which you wish to insert the symbol. 

2 Choose Text > Insert.

3 Select a symbol from the submenu list and release the mouse. 
The selected symbol will automatically be inserted.

Typographic quotes
You can set a preference so Canvas inserts typographic (“curly”) 
quotation marks in text you type. For more information, see “Use 
Smart Quotes,” page 13.14.

Placing graphics in text objects
Use the Insert Picture command to anchor graphics in a text object. 
This feature lets you use custom bullets, special illustrations for 
drop caps, and small logos within text. An inserted picture behaves 
like a text character.

• Inserted pictures move with the surrounding text.

• Indent and justification settings apply to inserted pictures. 

After using the 
insert symbol 
command.
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• An inserted picture’s baseline and kerning can be 
adjusted.

• An inserted picture rotates and skews with the surround-
ing text.

Some text formatting features do not apply to inserted pictures. 

• If you scale the surrounding text, an inserted picture does 
not distort or scale with the text. 

• Spread and Overprint commands do not affect inserted 
pictures. 

• Strokes or inks applied to the text don’t affect inserted pic-
tures.

• Inserted pictures might not be imported from the Clip-
board by other applications.

Inserting a picture into text
The Insert Picture command is available when any object is on the 
Clipboard and the insertion point is in a text object.

When the insertion point is in a text object and you choose the 
Insert Picture command, Canvas inserts the contents of the Clip-
board as a raster image into the text.

Since Canvas converts the Clipboard contents to a raster image 
when you use Insert Picture, you cannot edit objects that have been 
inserted into text; e.g., if you insert a multigon object into text, you 
can’t use editing handles to reshape or scale it. If you insert text 
characters using the Insert Picture command, the inserted text 
characters are not editable.

To use the Insert Picture command
1 Select the object or objects that you want to insert into text.

2 Choose Edit > Cut or Edit > Copy to place the selection on 
the Clipboard. If you selected multiple objects, they become a sin-
gle composite graphic when inserted into text.

3 Select the Text tool.

4 Click in the text where you want to insert the graphic. An 
insertion point appears where you click.

5 Choose Text > Insert Picture. The Clipboard contents appear 
at the insertion point. 

Text with an inserted picture 

Insertion point
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How inserted pictures affect leading
When you use the Insert Picture command, the leading of the para-
graph might change, depending on the Line spacing method:

• If the Line spacing is defined by Percentage, Canvas 
adjusts the Line spacing to fit the picture based on the 
defined percentage, if necessary. 

• If the Line spacing is defined by Points, the spacing 
between lines stays the same, regardless of the size of the 
picture.

Using dynamic objects for inserted pictures
If you want to be able to edit an inserted picture, you can insert a 
dynamic object into text. A dynamic object is an object linked to an 
editable original in the Personal Library palette. If you change the 
original in the Personal Library palette, the inserted picture 
dynamic object will change to match the original. 

For example, you can use the Insert Picture command to place sim-
ple placeholder dynamic objects (such as small squares) where you 
want finished graphics to appear in text. When the final graphic is 
available, replace the placeholder dynamic object in the Personal 
Library palette with the finished graphic. With this method, you do 
not have to change each instance of a graphic individually or alter 
the publication’s layout.

Line spacing set to 100%

Line spacing set to 12 points
.12 TEXT EDITING & PROOFING



Checking the spelling of text
Canvas can check the spelling of all text in a document, including 
text bound to a path by the Path Text tool or the Bind Text com-
mand. Canvas can check the spelling of specific words, selections 
and entire documents. Canvas can also check the spelling of words 
as you type.

Canvas checks the spelling of text by looking up words in the Can-
vas Dictionary and the User Dictionary. The Canvas dictionary 
contains 100,000 words. You can add words to the User Dictionary 
to stop Canvas from marking unrecognized words that are spelled 
correctly. 

Showing and hiding unrecognized words
Canvas marks words that it can’t find in either the Canvas Dictio-
nary or the User Dictionary with a red wavy underline. Canvas can 
check spelling while you type or after you finish entering text.

When Show Spelling Errors is active, Canvas checks the spelling of 
a word after you type it and press the Spacebar, tab, or deselect the 
text object. Canvas marks an unrecognized word with a red wavy 
underline.

• To mark unrecognized words: Choose Layout > Display > Show 
Spelling Errors. 

• To not mark unrecognized words: Choose Layout > Display > 
Hide Spelling Errors.

Using the spelling pop-up menu
While using the Text tool to edit text, you can choose suggested 
replacements for words marked as unrecognized.

Text with placeholder 
dynamic object inserted

Placeholder dynamic object 
replaced by apple graphicFinal graphic

Placeholder object

Tip
The Canvas dictionary file can’t be 
modified.

Unrecognized words marked
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The spelling pop-up menu lets you choose replacement words. You 
can also use the menu to add unrecognized words to the User Dic-
tionary.

To use the spelling pop-up menu
With a text object in edit mode, point to a word that Canvas has 
marked as unrecognized. Control-click (Mac) or right-click (Win-
dows) the word to open the spelling menu. Do one of the following:

• To replace an unrecognized word with a suggested word: Choose 
the suggested word in the menu.

When you choose a replacement word in the Spelling menu, Can-
vas adds the unrecognized word and the replacement word to the 
Auto Correct manager. The unrecognized word appears in the 
Replace text box and the suggested word appears in the With text 
box (see “Checking the spelling of text” on page 32.13).

• Add Word: To add an unrecognized word to the User Dictio-
nary, choose Add Word. After you choose Add Word, Canvas adds 
the word to the User Dictionary and will recognize any future use of 
the word.

• Ignore Word: To ignore the spelling of the unrecognized word, 
click Ignore Word. If you choose Ignore Word, Canvas will ignore 
the word in any document until you quit Canvas.

• Cancel: To close the spelling menu without making any 
changes, choose Cancel or click outside the menu.

Spell checking a selection or document
Check the spelling of selected text, a selected text object, and an 
entire document using commands in the Spell Checker menu.

• To limit the spell checking to specific text or text object: Select 
the text or text object.

• To spell check an entire document: You don’t have to select 
anything.

To begin spell checking
1 Choose Text > Spell Checker > Spell Check Selection (if you 
selected text or a text object), or Text > Spell Checker > Spell 
Check Document. 

Spelling menu

Suggested 
words
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If Canvas finds an unrecognized word, the Spelling Checker dialog 
box appears (see “Spelling Checker,” page 32.15). Canvas displays a 
message when the spell check is complete. 

2 Click OK to close the message box.

Note: Canvas deselects any selected objects (but not text) when you 
use the Spell Check Selection or Spell Check Document com-
mands.

Continuing a spell check
If you cancel a spell check, chooseText > Spell Checker > Continue 
Spell Check to pick up where you left off. Canvas remembers the 
words you chose to ignore.

Modifying the User Dictionary
In addition to more than 100,000 words in the Canvas Dictionary, 
you can store an unlimited number of words in a personal user dic-
tionary (see “Spell Check Dictionary,” page 13.11). 

To add words to the User Dictionary
1 Choose Text > Spell Checker > Show Added Words. The 
User Added Words manager appears. 

2 Type a new word to add.

3 Click the Add button.

4 Click Done to close the manager.

Spelling Checker

The Spelling Checker dialog box 
appears during spell checking of a 
selection or document if Canvas finds a 
word that isn’t in its dictionaries.

A Canvas displays unrecognized 
words in context. You cannot edit the 
text in this box.
B Type a new spelling in this text box 
or click the down-arrow to choose from 
the list of suggested spellings.
C The highlighted word in this box is 
the unrecognized word.

Replace. Click this button to replace 

the unrecognized word with the con-
tents of the text box (B) and contin-
ue to spell check the document.

Add. If Canvas doesn’t recognize a 
word that is actually spelled correct-
ly, add the word to the User Dictio-
nary so that Canvas recognizes it in 
future documents (see “Modifying 
the User Dictionary” on page 32.15). 
After saving the word, Canvas con-
tinues to spell check.

Ignore. Allows an unrecognized word 
in the current document without add-
ing the word to the dictionary. Canvas 
ignores all instances of the word until 
you close Canvas.

Skip. Allows the current instance of an 
unrecognized word, but Canvas alerts 
you the next time this word occurs.

Cancel. Interrupts the spell check and 
closes the dialog box. 
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To delete words in the User Dictionary
1 Choose Text > Spell Checker > Show Added Words. The 
User Added Words manager appears. 

2 Select a word and then click the Delete button.

3 Click Done to close the manager.

Importing text from other applications
You can import text created in other applications into Canvas. This 
capability is especially useful if you are compiling documents from 
different applications into a Canvas layout; e.g., you might need to 
assemble a publication with contributions from several writers who 
each use different word processors.

Canvas supports several methods for importing text. You can open 
a text file, place a text file, paste text from the Clipboard into a Can-
vas document, and use OLE. 

Opening a text file with the Open command creates a new Canvas 
Publication document for the imported file. Placing, pasting, and 
embedding text inserts the text into the current document. For 
information on pasting text from the Clipboard, see “Copying, past-
ing, deleting, and moving text selections” on page 32.4.

The formatting of imported text might differ from the formatting 
of the original text in its native application. Although some soft-
ware products might have similar capabilities, the methods used 
can vary significantly. It might be necessary to reformat imported 
text using the typographic tools in Canvas.

Embedded text objects and editions containing text
In Windows, use Object Linking and Embedding (OLE) to insert 
text in a Canvas document with the Paste Special command. 

You can add words to the dictionary 
by typing the word in this text box and 
clicking Add

Words you add to the user dictionary 
appear in a scrolling list. To delete a 
word, select the word and click Delete.

Tip
The Import command is used to 
import raster images, not text.
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However, Canvas treats embedded text objects and editions as 
objects, not text. You cannot apply effects, such as wraps or binds, 
to text in these objects. In addition, Canvas cannot spell check, 
hyphenate, or format this text. All formatting and effects must be 
performed in the original application or publisher. For more details 
and procedures, see “Using Object Linking and Embedding (Win-
dows)” on page 14.25.

Placing text in documents
Place text by typing or pasting text from the Clipboard. You can 
also place text by choosing File > Place. 

To place text using the same margins as the original file, click the 
Place icon in the document. If the file you are importing contains 
text only (no images or objects), you can also drag the Place pointer 
to simultaneously import and set margins for the text. However, if 
the file you want to import has images or objects, dragging the 
Place icon scales the text, images, and objects as a group.

To place text into sections
To create sections in a document, see “Creating columns” on 
page 29.9. Use the Place command to place text from a text file into 
a section.

1 Select the Text tool and click at the top of the first column in 
the section. An insertion point appears in the column at the 
height where you clicked. 

2 Choose File > Place. Select the text file you want to place and 
click Place. The text from the text file appears in the section and 
flows from column to column.

If the final column in a section contains overset text, you can flow 
the text into another text object or section, or resize the section to 
contain the overset text (see “Flowing overset text into new text col-
umns” on page 29.13).

To paste text into a section
After you create a section, you can paste text from the Clipboard to 
create text columns (see “Creating columns” on page 29.9).

1 Use the Edit > Copy command to place text on the Clip-
board.

Tip
If you have difficulty opening or 
placing a text document because 
of the formatting, try converting 
the file to plain text before import-
ing the file. 
Also, try copying and pasting the 
text you want to import. This 
removes formatting that Canvas 
doesn’t understand.
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2 Select the Text tool and click at the top of the first column in 
the section. An insertion point appears in the column at the 
height where you clicked. 

3 Choose Edit > Paste. The text on the Clipboard appears in 
the section and flows from column to column. 

If the final column in a section contains overset text, you can flow 
the text into another text object or section, or resize the section to 
contain the overset text (see “Flowing overset text into new text col-
umns” on page 29.13).

Exporting text from Canvas documents
Copy text from Canvas and paste it into other applications using 
the Clipboard. In addition, you can use the Canvas file filters to 
save selections and documents in other file formats (see “File & 
data exchange” on page 14.1). Keep in mind that if you save a docu-
ment containing text and use a format that supports only raster 
images, Canvas rasterizes the text before saving the file, so you 
can’t edit it in the saved file.

Also, several Canvas typographic capabilities aren’t available in 
other applications; e.g., character inks and strokes, text typed on a 
path, and wrapped text are unlikely to convert reliably. In some 
cases, such as rotated text, the export filters might rasterize the 
characters, and you will not be able to edit them as text.

To export text to other file formats
1 Choose File > Save As. 

2 In the File Format (Mac) or Save as type (Windows) menu, 
choose a file format. Type a name for the file, and then click Save.

Note: Canvas warns you that saving files in other formats might 
result in a loss of some information whenever you save using a for-
mat other than Canvas.

Tip
Always save a copy in Canvas for-
mat of files you want to export, in 
case the file conversion doesn’t 
give the results that you expected.
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33
TYPE EFFECTS

This chapter explains how to apply various effects to type. In Can-
vas, you can wrap text inside objects, repel text from objects, bind 
text to the path of an object, and slant the margins of a text object.

Text inks and strokes
You can apply fill inks, pen inks, strokes, frame inks, background 
inks, and frame strokes using the Fill Ink, Pen Ink, and Stroke 
icons in the Toolbox. You can also use the Properties bar that has 
icons and popout palettes that let you apply fill inks, frame inks, 
background inks, and frame strokes (see “Formatting text with the 
Properties bar,” page 30.5).

Current attributes
By using the icons in the Toolbox, you can set the pen ink, fill ink 
and stroke current attributes for text; however, you can’t set frame 
inks, background inks, and frame strokes to be current attributes; 
i.e., you can’t set a frame ink, background ink, or frame stroke that 
will be applied when you create new text objects (see “Attributes of 
new text” on page 29.3).

Ink and Stroke icons

Tip
When you convert text to paths, 
Canvas keeps the pen ink, fill ink 
and stroke, but any background 
inks, frame inks, or frame strokes 
are removed.
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Applying inks and strokes
You can apply the following attributes to one or more text objects, 
and to text selections.

Fill ink An ink applied to the inside, as opposed to the outline, of 
the characters in a text object or text selection. You can also apply a 
fill ink with the Fill Ink icon in the Toolbox.

Background ink An ink applied to the background of a text object 
or a text selection.

Outline ink An ink applied to the stroke of text characters. You 
can also apply a pen ink with the Pen Ink icon in the Toolbox.

Frame ink An ink applied to the stroke on the bounding box of a 
text object, or a box around a text selection. 

Outline stroke The outline of text characters. You can also apply a 
stroke with the Stroke icon in the Toolbox.

Frame stroke A stroke applied to the bounding box of the text 
object, or a box around a text selection. The frame ink appears on 
the frame stroke.

To apply a fill ink
1 Select a text object, text characters, or place the insertion 
point in existing text.

2 Click on the Fill ink icon in the Properties bar and select an 
ink from the popup palette. Or, select an ink from the Fill Ink pal-
ette in the Toolbox.

To apply a background ink
1 Select a text object or text characters.

2 Click on the Background ink icon in the Properties bar and 
select an ink from the popup palette.

If a text selection spans more than one line of text, the background 
ink appears separately on each line of text.

To apply an outline ink
1 Select a text object, text characters, or place the insertion 
point in existing text. 

2 Click on the Outline ink icon in the Properties bar and select 
an ink from the popup palette.

Inks and Strokes icon on the 
Properties bar

A Fill ink
B Background Ink
C Outline ink
D Frame ink
E Outline stroke
F Frame stroke

Background ink

Fill ink
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To apply a frame ink
1 Select a text object or text characters.

2 Click on the Frame ink icon in the Properties bar and select 
an ink from the popup palette.

If a text selection spans more than one line of text, the ink appears 
on boxes around the selected characters on each line of text.

To apply an outline stroke
1 Select a text object or text characters.

2 Click on the Outline stroke icon in the Properties bar and 
select a pen stroke from the popup palette.

To apply a frame stroke
1 Select a text object or text characters.

2 Click on the Frame stroke icon in the Properties bar and 
select a pen stroke from the popup palette.

If a text selection spans more than one line of text, the stroke out-
lines the selection separately on each line of text.

Wrapping and repelling text
Make text flow around or inside objects by using the Text > Wrap 
commands.

Wrapping text inside an object
When you wrap text inside a vector object, Canvas adjusts the text 
object’s margins so that text fits within the shape of the vector 
object. A text object can be wrapped inside only one object at a 
time.

Canvas has two methods of wrapping text inside an object. Select 
an existing text object and a vector object and choose the Text > 
Wrap > Inside Shape. Also, select an existing vector object and sim-
ply begin typing; the text will stay inside the shape of the vector 
object.

If you wrap text inside an open vector object, such as an arc, the 
text wraps between the bounding box and the concave side of the 
arc. If you try to wrap text to a line or a narrow arc, the text will not 
be visible. If this occurs, choose Text > Wrap > Remove Wrap or 
choose Edit > Undo to make the text visible again.

Frame ink and stroke

Tip
You can also wrap text within the 
bounding box of a paint object 
with both methods.
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To wrap existing text inside an object
1 Select a vector object and a text object. 

2 Choose Text > Wrap > Inside Shape. Canvas places the text 
inside the object.

If there is more text than can fit inside the shape, Canvas inserts a 
column break in the text object and displays an overset symbol. 
Resize the object to fit the text or flow the excess text to another col-
umn (see “Flowing overset text into new text columns” on 
page 29.13).

To type new text inside an object
1 Activate the Auto type into object preference (see “Type set-
tings,” page 13.12).

2 Select a vector object.

3 Begin typing. Canvas adjusts margins so that text you type 
remains within the left and right borders of the object.

If the object is too small to contain all the text you type, the text 
object extends below the object. Resize the object to fit the text or 
resize the text object to fit the shape, and then flow any excess text 
to another column.

Vector object with wrapped text

Center-justified text wrapped inside an oval
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Removing wrap effects
Restore text margins to the standard rectangular shape by choosing 
Text > Wrap > Remove Wrap. 

• To remove a wrap effect: Select a wrapped text object. Choose 
Text > Wrap > Remove Wrap.

Repelling text from objects
To make text flow around an object, apply a repel setting to the 
object. You also can set the amount of space between the object and 
text it repels. 

An object with a repel setting repels all text. Move the object and it 
will repel text wherever you place it.

You can apply repel settings to objects before any text has been cre-
ated or placed in a document. You can also apply a repel setting to 
a text object to make it repel the text in other text objects.

An object can repel text that is contained in text objects. A repel set-
ting does not repel text that has been bound to a path with the Path 
Text tool or the Bind Text command.

To make objects repel text
1 Select one or more objects that you want to repel text. 

2 Choose Text > Wrap > Repel. Canvas applies the repel set-
ting. The initial repel amount is zero points.

To set repel space
Use this procedure to set the amount of space between an object 
and text that it repels.

Tip
To remove effects, also use the 
Undos palette or keyboard com-
mands: Command+Z (Mac) or 
Ctrl+Z (Windows).

One object repelling 
text

Two objects repelling 
text

Two objects repelling 
two columns of text

Examples of repelled text
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1 Select the object that has a repel setting and choose 
Text > Wrap > Repel Options.

2 Enter a value from -30 to 30 points in the four boxes. These 
values specify the amount of space between the top, bottom, left, 
and right sides of the object and text that the object repels. 

3 Click Apply to view the effect of the current settings. Click 
OK to apply the settings and close the dialog box.

To remove a repel setting
Select an object that you do not want to repel text. Choose 
Text > Wrap > Remove Wrap. Canvas removes the repel setting 
from the selected object.

Slanting text columns
The Text > Wrap > Slant Margin command lets you change a text 
column’s margins to form a parallelogram.

To slant right and left margins
1 Select a text object. 

2 Choose Text > Wrap > Slant Margin. The text object’s selec-
tion handles change to four corner handles.

3 Drag either of the text object’s top two selection handles hori-
zontally to slant margins away from the bottom line of text. 

Tip
When entering values, you can use 
the Tab key to move between val-
ue fields.

Setting the column angle

When you choose Text > Wrap > Slant 
Margin, drag selection handles to spec-
ify the angle of margins.

A The bottom right handle of the text 
column is dragged to specify the angle of 
the margins (shown by the dashed lines).
B Canvas adjusts the margins to slant 
the text column within the bounding rect-
angle. (The bounding rectangle is repre-
sented by the eight selection handles.)
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4 Drag either of the text object’s bottom two selection handles 
horizontally to slant margins away from the top line of text.

5 Press Enter (Mac) or Esc (Windows) when you are finished.

• To remove a wrap effect: Select a wrapped text object. Choose 
Text > Wrap > Remove Wrap.

Binding text to vector objects
Bind the baseline of text to the path of most types of vector objects. 
Canvas adjusts the vertical orientation of each character to match 
the path.

Depending on how you want to bind text, you can choose Effects > 
Bind Text or the Path Text tool. The Bind Text command lets you 
bind existing text to an object, and the Path Text tool lets you type 
new text directly on the path of a selected object.

Canvas lets you bind multiple text objects to one vector object, but 
a text object can bind to only one vector object at a time. Also, you 
can bind only one text object to a vector object using the Path Text 
tool. To bind additional text objects to the same vector object after 
using the Path Text tool, you must create a separate text object and 
choose Effects > Bind Text.

Position and direction of bound 
text

Whether you use the Bind Text com-
mand or Path Text tool, the location 
where you click the pointer determines 
the alignment position. 

A This text is center-justified. The I-
beam pointer (which appears after 
choosing the Bind Text command or the 
Path Text tool) determines where text 
binds. In the example, the pointer is 
clicked in the upper-right quadrant of 
the oval. The inset shows the bound 
text, centered around the point where 
the pointer was clicked.
B For open-ended objects, such as 
arcs, bound text initially flows in the di-
rection the object was drawn. In this ex-
ample, the arrows indicate the direction 
the arcs were drawn. Text objects 
bound to these arcs follow the direction 
of the arcs.
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To bind existing text using a menu command
1 Select a text object and vector object.

2 Choose Effects > Bind Text. When the pointer is on the edge 
of the selected object, the pointer becomes an I-beam.

3 Click to place the selected text on the path. Text aligns to the 
point where you click; e.g., if the text is center-justified, Canvas 
binds the text so that it is centered around the point you click.

4 To change the alignment and position of bound text, see 
“Working with bound text,” page 33.8

To type on a path using the Path Text tool 
1 Select the Path Text tool. When the pointer is on the edge of 
an object, the pointer becomes a crosshair.

2 Click where you want to start typing on the path. An inser-
tion point appears.

3 Begin typing. The text aligns to the location where you placed 
the insertion point and follows the path of the object.

4 To change the alignment and position of bound text, see 
“Working with bound text,” page 33.8.

Working with bound text
Once you bind text, you can change its starting position, alignment, 
baseline position, and flow direction. In addition, you can edit the 
shape and location of the vector object to which text is bound, and 
Canvas will fit the text to the new path.

You can also edit bound text by selecting the Path Text tool and 
clicking the text object, or by double-clicking a bound text object 
with a Selection tool. However, text editing might be difficult and 
slow while the text is bound to an object; you might want to remove 
the text bind, make changes, and re-bind the text.

Bound text and its binding object move together, just like grouped 
objects. However, unlike grouped objects, you can select and 
change attributes (such as stroke and ink) individually for the text 
and the object.
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To position and align bound text
Canvas has three Bind Position handles that you can drag to place 
text anywhere on, above, or below an object. The handles appear 
when you select a bound text object.

Bind Position handles

Changing the appearance of bound text
Once you bind text to a path using the Path Text tool or Bind Text 
command, use the context menu to change the orientation of the 
text characters relative to the path, and to make the path visible or 
invisible. The bound text commands appear in the context menu 
when a bound text object is selected. 

Handle Description Example

Reverse Flow handle Click to switch the vertical orientation 
of type relative to the object path and 
reverse the flow direction.

Alignment handle Drag to specify the point where you 
want type to align. For example, cen-
ter-justified text will center around 
the location of this handle.

Canvas spreads full-justified text 
along the entire path or object start-
ing at the location of the handle.

Baseline Shift handle Drag to change the elevation of the 
baseline relative to the vector object.

Baseline Shift lets you insert space 
between bound type and the object.

Text is centered around the 
alignment handle
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• To access the context menu: Select an object with bound text 
and Ctrl-click (Mac) or right-click (Windows) (see “Using context-
sensitive menus,” page 10.24).

Bound text commands

• To remove a text bind effect: Select a bound text object and 
choose Effects > Remove Effects. Canvas straightens the text base-
line and separates it from the vector object.

Binding text to a circle
Create circular logos with text on top flowing clockwise and text on 
the bottom flowing counterclockwise. Achieve this effect by binding 
two text objects to a circle and using the Bind Position handles to 
arrange the text. 

Command Description

Show Path / Hide Path Choose Show Path to make the path visible. Choose Hide Path to make the path invisible.

Vertical Text Choose Vertical Text to keep the baseline of the text characters horizontal, rather than per-
pendicular to the path. This also keeps the vertical axis of each character vertical, rather 
than angled to follow a curved path. The Vertical Text command is available when the text 
is bound with the Tangent Text option.

Tangent Text Choose Tangent Text to keep the baseline of the text characters tangent to the path, rather 
than horizontal. This angles the vertical axis of each character away from vertical as needed 
to follow the path. By default, Canvas uses the Tangent Text option when it first binds text 
to a path. The Tangent Text command is available in the context menu when the text is 
bound with the Vertical Text option.
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Using text as clipping paths
Make a pattern, gradient, or image appear to span an entire selec-
tion, rather than begin and end within each character; e.g., instead 
of a gradient completing a blend pattern within each character of a 
word, make a gradient begin a blend in the first character and fin-
ish the blend in the last character.

In Canvas, you create these kinds of “continuous” fills using back-
ground objects and foreground text object clipping paths. The 
intersection of the background and foreground objects provides the 
appearance of a continuous fill. This method lets you use elaborate 
background designs, including paint objects, to fill characters. For 
more information, see “Using clipping paths” on page 21.4.

To use text as a clipping path
1 Position the text object in front of the object to be clipped, 
and then select both objects. 

2 Choose Object > Clipping Path > Make.

To create a circular logo
A Create a circular object using the 
Oval tool and then two text objects. 
B Use the Path Text tool to create 
and bind the first text object. Then cre-
ate the second text object and bind it to 
the vector object by using the Bind Text 
command. One text object is bound to 
the top of the circle, the other to the bot-
tom of the circle. Text initially flows 
clockwise.
C Clicking the Reverse Flow handle 
(highlighted in inset) makes “FACTOR” 
flow counter-clockwise inside the circle.
D Dragging the Baseline Shift handle 
(highlighted in inset) positions “FAC-
TOR” outside the circle. Removing the 
circle completes the design.
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Applying vector effects to type
Apply the following vector effects to text objects: Envelope, 
Extrude, Rotate, Freeform rotate and skew, Flip, Shadow, and Path 
editing.

Use effects to add dimension to text objects and create striking 
designs. This section describes briefly how to apply each of these 
effects (see “Vector effects” on page 21.1).

Before applying vector effects to type
Depending on the number and kind of effects you apply to text, 
you might not be able to edit the text afterwards; e.g., you can edit 
text after rotating and skewing, but if you also extrude the text, 
Canvas converts the text to vector objects. In addition, depending 
on the speed of your system, editing rotated and skewed text might 
be slow. Therefore, you might want to finish all text editing, format-
ting, and layout before applying effects.

Freeform and rotate effects
In Canvas, you can place a text object in freeform mode and then 
drag any of the hollow selection handles of the bounding box to 
rotate and skew text. Choose Effects > Rotate Right/Left > Other to 
perform exact rotations.

• To freeform edit a text object: Select a text object. Choose 
Effects > Freeform. Drag a circular selection handle to rotate the 
text object, or a square handle to skew the text.

• To rotate a text object an exact amount: Choose Effects > Rotate 
> Other to open the Rotate dialog box. Specify the degree and cen-
ter of rotation. Click Apply to see the effect of the settings, or click 
OK to accept the settings.

Clipping path appears filled with image objectText object in front of image object
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Flipping text
You can flip text horizontally, vertically, or both. Choose Effects > 
Flip to create mirror-image copies of text.

• To flip text: Select the text object(s). Depending on the direc-
tion you want to flip text, choose Effects > Flip > Horizontal, Verti-
cal, or Both Axes. Canvas implements the setting immediately.

Shadow effects
In Canvas, when you apply a shadow to text, the shadow is a sepa-
rate object that you can color, edit, and apply effects to indepen-
dently of the original text object. By applying the right combination 
of effects, you can achieve oblique shadows and other lighting 
effects.

Since Canvas creates a separate object for the shadow, changes to 
the original text object do not change the shadow. Finalize text 
before applying shadows to ensure that the text is the same for both 
objects.

This design consists of rotated (black) 
and skewed (color) type. Each word 
was divided into two text objects, which 
were arranged to create the effect.

Original

Vertical flip

Horizontal flip

Both axes
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To create a shadow

1 Select the text object(s) to which 
you want to apply shadows.

2 Choose Effects > Shadow to open 
the Shadow dialog box.

3 Specify Object or Image. Image ac-
tivates the Image Options area.

4 Specify the offset amounts as well 
as a color for the shadow. 

5 In the Image Options area, specify 
Gaussian Blur, mode, resolution, and 
anti-alias.

Canvas creates the shadows and 
arranges them behind the original text 
object(s).

Text shadow effects

Combine Canvas effects to create dif-
ferent types of shadows.

A An object shadow, slightly offset 
and shaded black.
B A black image shadow, slightly off-
set with Gaussian Blur
C The shadow object was skewed to 
create an oblique shadow.

D This example consists of three ob-
jects: the original text object, a slightly 
offset shadow, and an oblique shadow. 
E This example consists of three ob-
jects: the original text object, a slightly 
offset shadow object, and a duplicated 
shadow object. The duplicate has been 
flipped, skewed, and filled with a gradi-
ent ink.
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Envelope text effects
Use the Envelope effect to warp and distort type to create new char-
acter forms and stretch text like rubber. When you apply this effect 
to a text object, you can drag selection handles to reshape text. 
Depending on the type of envelope, text stretches in different ways. 
Using this effect, add perspective to text or simulate stretching type 
around a 3-D object (see “Enveloping objects,” page 21.12 for more 
information about the Envelope effect).

• To edit the envelope of a text object: Select a text object and 
choose Effects > Envelope. Choose a type of envelope effect in the 
pop-up menu and click Apply. Then, drag the envelope handles to 
reshape the text.

Extruding text
Extrude text and add lighting effects to make text appear three-
dimensional. As with vector objects, you can rotate and scale 
extruded text to change the apparent depth, size, and orientation. 
For text, you can only use the Parallel option in the Extrude palette. 

Canvas removes stroke and fill attributes before extruding text 
because they can interfere with the three-dimensional effect. Add 
color to extruded objects by choosing a fill ink from the Presets pal-
ette and a color for the light source in the Extrude palette (see 
“Extruding objects,” page 21.15 for more information about the 
Extrude effect).

Tip
You cannot edit text after applying 
an envelope effect. however, you 
can apply an extrusion to an envel-
oped object.

Tip
You cannot edit text after applying 
an envelope effect.

Extruded text with lighting effects
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To extrude text
1 Select a text object and choose Effects > Extrude to open the 
Extrude palette. 

2 Choose Parallel in the menu

3 Configure the settings and click Apply. 

4 Use the extrusion handles to shape and rotate the text.

Converting text to paths
Canvas can create path outlines of characters so you can edit the 
shape of each character. Once you convert text to paths, Canvas 
treats the paths as objects. You cannot edit the objects as text 
(change font type, type size, or run spell check, etc.).

To convert text to paths
1 Select a text object and choose Object > Path > Convert to 
Paths. If the text object contains multiple characters, Canvas cre-
ates a grouped object. 

2 To ungroup the object and edit individual characters, choose 
Object > Ungroup. You can also use the Direct Selection tool to 
select individual objects without ungrouping.

3 Double-click an object to place it in path edit mode. To put 
several shapes in path edit mode at the same time, select multiple 
objects and choose Object > Path > Edit Path.

4 Use path-editing techniques to change the object, and then 
press Esc to exit edit mode.

Typing text on paths
Use the Path Text tool to type text so it follows the path of a vector 
object, such as a circle, polygon, or open curve. You can also use the 
tool to create text that flows along multiple paths.

To type text on a path
1 Select the Path Text tool. In the document window, the 
pointer is an arrow. The arrow changes to an I-beam when you 
point to a vector object path.

2 Click the path to set the insertion point. Begin typing and the 
text follows the vector path. You can type multiple lines of text. 
To start a new line, press Enter at the end of the previous line. 



3 When you finish typing, press Esc. The text object becomes 
selected.

Flowing text
As you type text on a path, if you reach the end, you can flow text to 
another path. Click the overset symbol at the end of the text object. 
Then, click the next vector path at the point where you want the 
overset text to start flowing. Continue typing to enter additional 
text.

If you don’t want to flow overset bound text, resize the path so that 
all the bound text can flow along it. If no text is overset, the overset 
symbol does not appear at the end of the text object.

To link text to another path with the Text Link tool
1 Select the Text Link tool, and the pointer displays the num-
ber “1.”

2 Click the first text object, and the pointer changes to the 
number “2”.

3 Click the object to which you want the text to flow.

4 Press Esc when you finish.

Adjusting text on a path See the section about adjusting bound 
text, starting with “Binding text to vector objects” on page 33.7, for 
information on changing the text baseline, flipping the text, and 
adjusting the spacing between the text and the path.

Vector path Overset symbol
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34
SPRITEFFECTS

In Canvas, you could always modify objects with image-editing 
techniques — if you converted the objects to images; however, you 
lost the ability to edit vector paths and text. Also, applying filters 
and adjustments would change an image permanently. Canvas’ 
SpriteEffects technology lets you apply image filters and adjust-
ments to vector objects, images, text, and grouped objects. 

You can apply effects temporarily, adjust effects settings, change 
the order of effects, and hide or remove effects individually. You 
don’t have to use Undo or save intermediate versions to preserve an 
original illustration, since objects remain editable. You can still edit 
object paths, insert and delete text, as well as change inks and 
strokes. 

When SpriteEffects are printed or exported to file formats outside 
of Canvas, the effects are rendered as images. This is like taking a 
snapshot of the objects and printing the resulting image. In your 
Canvas documents, the objects keep their original editing features.

Before SpriteEffects, commands such as Blur, Hue/Saturation, 
Invert, Emboss, Twirl, and many others could be applied to paint 
objects (images) only. SpriteEffects technology offers new power 
and flexibility for creative art, technical illustration, and graphics 
production.

Using SpriteEffects
There are two ways to use SpriteEffects: 

• Apply effects directly to objects

• Apply effects to lens objects

Applying effects directly to objects
You can apply image effects and adjustment commands directly to 
vector, text, paint, and group objects. You could apply the Blur 
command to a text object, then use the Hue/Saturation command 
to highlight the text edges with color for example. 

When you apply effects directly, an entire object, including its fill 
ink, pen ink, and stroke, is affected. 
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Applying effects to lens objects
Another way to use SpriteEffects is to create a lens object from a vec-
tor or text object. Then, you apply effects to the lens. The effects 
will appear on objects that are viewed through the lens.

Lenses can magnify objects and view objects in other locations. If 
you move the viewpoint of a lens, whatever is behind the viewpoint 
will appear in the lens. If you move the lens, the viewpoint can 
remain fixed or move with the lens.

Using plug-in filters with SpriteEffects
Plug-ins must be Adobe Photoshop 4.0. compatible and also sup-
port Photoshop Actions to be used with SpriteEffects.

Plug-ins can be installed by copying them to the Plug-ins folder in 
the Canvas Tools folder. For information on settings and options 
for a plug-in, refer to the documentation from the manufacturer.

Note: Effects commands in the Image > Filter and Image > Adjust 
submenus are available for traditional image editing. These com-
mands are not available when other types of objects are selected.

Applying an effect
Because many types of filters and adjustments can be applied 
through SpriteEffects, general procedures are given here. You can 
locate specific information for effects commands by looking up the 
commands in the index.

When a vector or text object is selected, the SpriteEffects icon and 
SpriteEffects menu appears in the Properties bar. 

To apply a single effect
Use this basic procedure to apply one effect using a filter or adjust-
ment command. You can apply an effect by accessing the 
SpriteEffects menu in the Properties bar or by choosing Object > 
SpriteEffects > Add Effect.

1 Select an object. You can select any type of object, including a 
lens.

SpriteEffects icon & menu
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2 Choose the command to apply. If the selected command has 
no options, Canvas applies the command to the object, which 
remains selected. 

3 Do the following if there are options for the command and a 
dialog box appears:

• Choose the settings and options you want to use.

• If there is a Preview option, select it to see the effect of the 
current settings. 

• Click OK to apply the current settings.

• To apply multiple effects: Repeat the procedure above to apply 
more than one effect to an object. 

Using the SpriteEffects palette
All SpriteEffects features are available in the palette, except Attach 
and Detach, which are in the Object > SpriteEffects submenu.

• To display the SpriteEffects palette: Choose Object > 
SpriteEffects > Show Palette. You can also open the palette by click-
ing the SpriteEffects icon in the Properties bar. Keep the palette 
open while you work or dock it on the Docking bar. 

If an object is selected, its SpriteEffects settings are shown in the 
palette. When no object is selected, the controls in the palette are 
not available.

Palette menu

SpriteEffects palette

The SpriteEffects palette is the control center for applying 
effects, creating lenses, and editing effects on objects.

New button
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Using the effects list
When you select an object that has effects, use the list at the top of 
the SpriteEffects palette to arrange the order of effects. You can 
also show or hide effects, and change the mask setting.

Effects that are applied to the selected object are listed in order of 
application, with the first effect at the top. If no effects appear in the 
list, the selected object has none, or more than one object (or no 
object) is selected.

To modify effect’s settings
1 Select the effect name and choose Edit Effect Settings in the 
palette menu. Or, double-click the effect name in the Effects list.

2 Use the dialog box to adjust the settings for the effect.

3 Click OK to apply the current settings.

Some filter and adjustment commands (including Blur, Desaturate, 
Invert, and Sharpen) do not have editable settings, so choosing Edit 
Effect Settings or double-clicking the effect does nothing.

To arrange effects
To change the order in which effects are applied, drag an effect up 
or down and drop it in the list.

To show and hide effects
1 Select the object whose effects you want to hide/show.

2 Click the eye symbol to hide/show the effect.

Hiding an effect temporarily removes the effect from the object. 
Showing an effecting re-applies the effect to the selected object.

To duplicate or remove effects
Use the SpriteEffects palette to duplicate or remove effects that 
have been applied to a selected object. Removing an effect deletes it 
from the Effects list.

1 Select the object whose effects you want to edit.

2 In the SpriteEffects palette, do any of the following:

Duplicate Effect Select an effect in the list and choose Duplicate 
Effect in the palette menu. 

Effects list
A Show effect
B Mask

Tip
If you just want to temporarily hide 
an effect, click the eye symbol in 
the Effects list.
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Delete Effect To remove an effect, select the effect in the list. Click 
the trash can or choose Delete Effect in the palette menu.

Clear All Effects To remove all effects from the selected object, 
choose Clear All Effects in the palette menu.

To add effects
Each effect that you apply appears in the Effects list.

1 Select an object to which you want to apply effects.

2 In the SpriteEffects palette, click the New button or choose 
New Effect in the palette menu. A dialog box appears.

3 Select an effect command from the menu and click OK. If 
there are no options for the command, Canvas applies the effect.

4 If there are options for the command, a dialog box appears. 
Configure the options and click OK.

To save effects

You can save effects that have been applied to an object as a set. 
After saving an effects set, you can apply the set to other objects.

1 Open the SpriteEffects palette.

2 Select an object or lens that has effects you want to save.

3 Choose Save Effects from the SpriteEffects palettes menu.

4 A directory dialog box appears. Enter a name and select a 
location to save the effects set. Click Save to save the set in a file.

To apply saved effects
1 Open the SpriteEffects palette.

2 Select the object you want to apply the effects set to. You can 
select an object with no effects, one that has effects, or a lens.

3 Do either:

• To replace the selected object’s effects with the effects set:

Choose Load Effects in the palette’s menu.

• To add the effects set to the effects on the selected object:

Choose Append Effects in the palette’s menu.

4 A directory dialog box appears. Select an effects set file and 
click Open. Canvas applies the effects to the selected object.

Tip
Select an object that has no 
effects, one that has effects, or a 
lens.
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Pasting effects
You can use the Paste Attributes command to transfer effects from 
one object to another. 

To paste SpriteEffects
1 Copy an object that has effects to the Clipboard. 

2 Select an object to which you want to transfer the effects. 

3 Choose Edit > Paste Attributes. The Paste Attributes dialog 
box opens. 

4 Select the SpriteEffects option and click OK. Canvas will 
apply the effects (except lens settings) to the selected object.

Detaching and attaching SpriteEffects
The Detach and Attach commands transfer filters and adjustments 
between objects and lenses.

Detach removes effects from a selected object and applies the 
effects to a new lens that is the same size as the object’s bounding 
box. 

Attach applies effects from a lens directly to an object. Attaching is 
a way to apply multiple effects to an object at once.

To detach effects
1 Select an object (not a lens) that has effects. 

2 Choose Object > SpriteEffects > Detach.

3 Canvas removes the object’s effects and applies them to a 
new lens, which appears offset from the original object and is 
selected.

To attach effects
1 Select a lens object that has effects you want to apply, and a 
non-lens object to receive the effects. The objects do not have to 
be the same size or overlap and either one can be first in the stack-
ing order.

2 Choose Object > SpriteEffects > Attach. Canvas applies the 
effects, except the lens properties, to the selected object. The orig-
inal lens object is not changed.

Tip
You can also use the Load Effects, 
Save Effects, and Append Effects 
commands in the SpriteEffects 
palette to transfer sets of effects.
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SpriteEffects options
In the SpriteEffects palette, you can set the color mode, resolution, 
and anti-aliasing for the effects applied to a selected object. These 
options control how SpriteEffects are rendered for printing and 
export, as well as the display of SpriteEffects in Canvas. 

When you change a setting, the change is applied immediately to 
the selected object.

Mode
From the Mode menu, select the color mode to use for rendering 
SpriteEffects. 

The Mode option is used for rendering all the effects applied to an 
object; e.g., if you choose Grayscale, the object and effects applied 
to it will appear in gray shades on screen and when the object is 
printed or exported.

Select a mode that is appropriate for the medium you use. RGB is 
best for Web graphics, screen display, and output to a film 
recorder. CMYK is appropriate for process-color printing and color 
separations for commercial printing. Grayscale is appropriate for 
black-and-white publishing.

None is available in the mode menu only when the selected object is 
a lens that has no effects applied to it; however, the lens can have a 
magnification value and remote viewpoint. 

If you select None, the lens object is not rendered for printing or 
export. This can be more efficient and produce better output when 
a lens displays vector objects or high-resolution images. This option 
is useful if you use lenses without effects to show close-ups or call-
outs of diagrams.

Resolution
Enter the resolution in ppi for rendering SpriteEffects. A high reso-
lution makes effects appear smoother; however, higher resolution 
requires more memory and slows down printing. 

For Web graphics and screen display, 72 ppi is recommended. For 
office printing, 100 to 200 ppi is usually sufficient. For commercial 
printing, a range of 150 to 300 ppi is recommended for halftone 
images, depending on the paper and press requirements. 
Using the SpriteEffects palette 34.7
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Anti-Alias
Select this option if you want to smooth the edges of objects in the 
rendering of SpriteEffects.

Selection masks
In the Effects list, a symbol to the left of each effect name shows the 
state the selection mask for the effect. You can click the symbol to tog-
gle the mask on ( ) and off ( ).

An active selection mask defines a selection for an effect. The selec-
tion will include objects, not empty space. The mask can preserve 
transparent areas, such as empty space in a group object, and space 
between text characters. 

When the selection mask is on, the effect is based on the selection 
area. When the selection mask is off, the effect is based on the 
entire bounding box area; e.g., if you apply the Add Noise com-
mand to a circle, the selection includes only the circle, so the noise 
affects only the circle if the mask is on. If the mask is off, the noise 
appears in the entire bounding box area.

For a built-in effect, Canvas uses the best selection mask setting. 
For third-party effects, you might need to change the mask setting 
for the best results.

Blur effects usually require the selection mask to be off, so the blur 
can extend beyond the outline of an object. Other effects look best 
when they are based on a selection; e.g., a flame effect will cover an 
entire bounding box if the selection mask is off. If the mask is on, 
flames will rise from just the objects or text characters in the selec-
tion. This does not mean that flames can’t rise above the selection, 
just that the effect will be based on the selection, not the entire 
bounding box.

Mask offMask on

Noise applied to vector graphic
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When you edit the settings for an effect, Canvas displays a border 
on the selection, the same as the selection border that appears in 
images.

Effects area
When you apply effects to an object, Canvas defines a rectangular 
effects area. Usually, the effects area is slightly larger than the bound-
ing box of the object to which the effects are applied. 

There is one effects area for all effects applied to an object. Canvas 
tries to keep the effects area as small as possible, without cropping 
out any visible objects. 

You can adjust the effects area using the SpriteEffects palette. The 
palette lets you set the effects area manually or automatically.

Modifying the effects area
You might need to enlarge the effects area to see effects that extend 
beyond an object’s edge; e.g., Motion Blur and plug-in effects like 
bevel, glow, and fire usually need to extend beyond an object’s out-
line. Also, if text characters extend outside the text object border, 
an effect applied to the text could be cut off. 

If you make the effects area smaller than an object’s bounding box, 
the object and the effects will be cropped by the effects area border.

To size the effects area automatically
1 Select the object whose effects area you want to adjust.

2 In the SpriteEffects palette, click the smart-crop icon ( ).

3 Click Ok when the prompt appears. Canvas estimates the cor-
rect size of the effects area and makes it as small as possible.

To size the effects area manually
Some effects need to extend far outside an object’s bounding box. 
In these cases, the auto-size option might not extend the effects area 
far enough. If this happens, you can enlarge the effects area your-
self.

1 Select the object whose effects area you want to adjust.

2 Click the crop icon ( ) in the SpriteEffects palette. A box 
appears on the selected object. The box indicates the effects area Effects area box
Effects area 34.9
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and has hollow handles (the object’s bounding box has solid han-
dles). 

3 Drag a handle to enlarge or reduce the effects area. When the 
box is the size you want, click inside it.

To size the effects area precisely
You can enter values to precisely size the effects area.

1 Select the object whose effects area you want to adjust.

2 In the SpriteEffects palette, choose “Size of Effects Area” 
from the palette menu. The Effect Dimensions dialog box opens.

3 Do one of the following:

• Set the size of the effects area by entering the distance 
from the rulers’ zero point to the left, top, right, and bot-
tom sides of the effects area rectangle.

• Click a button to enlarge ( ) or reduce ( ) the size of 
the effects area. When you click a button, the distance val-
ues in the text boxes show the new effects area size.

4 Click OK to apply the settings.

Lens effects
You can apply effects to a lens the same as you apply effects to 
other objects (see “Applying an effect” on page 34.2). You also can 
set a magnification value and viewpoint location. These options are 
available in the SpriteEffects palette or after you create a lens with 
the Object > SpriteEffects > Convert to Lens command.

Creating a lens 
You can create a lens from any object (except a lens). If you want to 
preserve an object, make a copy and convert the copy to a lens.

Lens options
A Select to create a lens
B Magnification percentage
C Freeze lens view
D Viewpoint settings
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To make a lens
1 Select one object. You can select any type of object.

2 Choose Object > SpriteEffects > Convert to Lens or select the 
Lens option in the SpriteEffects palette. The object becomes a 
lens and remains selected.

Fill inks are removed when vector or text objects are converted to 
lenses. The stroke on a lens is not affected by the effects applied to 
the lens.

The default lens effect is normal (100%) magnification. To add addi-
tional effects, see “Applying an effect” on page 34.2.

To copy lenses
You can create copies of lenses the same ways that you copy other 
objects. 

1 Select the lens object to be copied.

2 Choose either Edit > Copy or Edit > Duplicate.

3 Choose Edit > Paste to paste the copy if you choose Copy.

Setting lens magnification
You can set the magnification level of a lens so objects appear mag-
nified (or reduced) in the lens. You can set the magnification level 
with or without other effects applied to a lens.

Magnification affects the view through the lens to the lens view-
point. If the default viewpoint (at the center of the lens) is used, the 
lens displays a magnified view of objects behind the lens. If the 

Viewpoint

Basic lens

With the magnification set to 300% and its viewpoint set about 
2 inches to the right, a lens made from a circle shows a detail 
view of an illustration.
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viewpoint has been moved, the lens shows a magnified view of 
objects behind the viewpoint (see “Setting a lens viewpoint” on 
page 34.12).

To set magnification
1 Select a lens object (see “To make a lens” on page 34.11).

2 Enter the magnification value in the Mag text box in the 
SpriteEffects palette. You can set magnification from 4 to 3,200%.

When you change the magnification value, the lens view changes, 
unless the Frozen option is selected in the SpriteEffects palette (see 
“Freezing a lens,” page 34.14). When Frozen is selected, the lens 
view does not change until you deselect the Frozen option.

Setting a lens viewpoint
The viewpoint of a lens is a point in the document that appears in 
the lens. The default viewpoint is at the center of the lens, so the 
lens displays whatever is directly behind it.

You can move the viewpoint of a lens to make any location appear 
in the lens, which is useful for displaying close-ups of illustrations.

The center of a lens is focused on the lens viewpoint. If you move 
the viewpoint, the new location appears centered in the lens object.

The viewpoint of a lens can be set anywhere on the same page, 
slide, sheet, or frame as the lens object. Lenses can display objects 
on all visible layers on the same page, sheet, slide, or frame. Lenses 
do not display objects on other pages, sheets, slides, or frames.

To set a viewpoint visually
Use this procedure when you want to click in the document to set 
the viewpoint for a lens. 

1 Select the lens object.

2 Select Relative or Absolute in the SpriteEffects palette (see 
“Absolute and relative viewpoints” on page 34.13).

3 Click Choose.

4 Move the pointer in the document and click to set the view-
point. The area you click appears centered in the lens.

To set a viewpoint precisely
Use this procedure to enter values to position a viewpoint. 

Tip
The Frozen checkbox is only avail-
able if you select Grayscale, RGB, 
or CMYK from the Mode menu. If 
None is selected, the Frozen 
checkbox is not available.
.12 SPRITEFFECTS



1 Select a lens object.

2 Use one of the following options:

Absolute position Select Absolute and enter horizontal (X) and 
vertical (Y) distances from the rulers’ zero point to the viewpoint; 
e.g., enter 0 in the X and Y boxes to set the viewpoint at the zero 
point. The viewpoint does not move if you move the lens.

Relative position Select Relative and enter horizontal (X) and verti-
cal (Y) distances from the center of the lens to the viewpoint. Posi-
tive values move the viewpoint down and right of the lens center. 
Negative values move the viewpoint up and left of the lens center; 
e.g., to set the viewpoint 1 ruler unit left of the lens center, enter -1 
(X) and 0 (Y). The viewpoint moves if you move the lens.

To reset a viewpoint
1 Select a lens.

2 Click the Reset button in the SpriteEffects palette to reset the 
viewpoint to the center of the lens object. 

This resets the location values to 0, 0 if Relative is selected. If Abso-
lute is selected, the location is measured from the rulers’ zero point 
to the lens center. 

Lens Lens 

Absolute viewpointRelative viewpoint
To set the relationship of 
the viewpoint to a lens 
object, select Absolute or 
Relative in the SpriteEffects 
palette.

Absolute and relative viewpoints

An absolute viewpoint is set at a specific location in a document and does not move. The lens shows the same absolute point 
no matter where the lens is placed on the page.

A relative viewpoint is set at a specific distance from the center of the lens. If you move the lens, the viewpoint moves the same 
distance and direction. When Frozen is selected, the view in the lens does not change; if you deselect the Frozen option, the 
view then changes to the current viewpoint. 
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Lenses and stacking order
The view through a lens depends on the stacking order of the lens, 
as well as the position of the viewpoint.

Only objects that are behind a lens in the stacking order can be seen 
through the lens. A lens and its viewpoint are at the same level in 
the stacking order. 

Due to the stacking order, objects that you create after you create a 
lens cannot appear in the lens. Also, objects that you move to the 
front of the stack after you create a lens cannot appear in the lens.

You can use a lens to display layered views; e.g., you can draw a 
map and create a lens to show a close-up of an area. If you add text 
after you create the lens, the text is higher in the stacking order. 
The text will not appear in the lens close-up of the map.

Freezing a lens
Select the Frozen option in the SpriteEffects palette to freeze the 
lens’ current view; i.e., the view won’t change unless you deselect 
the Frozen option. If you change the fill color of an object, the lens 
will not show the change. Deselect the Frozen option and Canvas 
updates the lens view.

Selecting Frozen overrides a lens relative viewpoint; the lens will 
show the same view after being moved. If you deselect Frozen, the 
lens will display the new viewpoint location.

To freeze a lens
1 Select a lens.

2 Select the Frozen checkbox.

3 Deselect the Frozen checkbox to show the new viewpoint.

Sharing documents with SpriteEffects
Since SpriteEffects are “live” effects that can be edited and 
updated, there are a few issues to consider if you plan to share doc-
uments that contain SpriteEffects.

Effects that are applied to an object need to be available to other 
Canvas users if they share the document and need to edit the 
effects. If you use only built-in Canvas effects, this is not a problem. 
If you use third-party plug-ins to apply effects, other users must 
have the same plug-ins installed. Without the plug-ins, they cannot 

Tip
Use the stacking order to change a 
lens view. Send a lens to the back 
of the stack so nothing appears in 
it. Bring it to the front so all the 
objects at the viewpoint appear in 
the lens.

Tip
Freezing a lens can avoid slow 
performance when you edit 
objects shown in a lens. When you 
finish editing, select the lens and 
deselect the Frozen option to 
update the viewpoint.
.14 SPRITEFFECTS



edit effects applied in a Canvas document (see “Using plug-in filters 
with SpriteEffects,” page 34.2).

If you export a document using an image file format, the effects will 
be rendered into an image (as described below), and the effects 
plug-ins will no longer be needed. Rendering is necessary because 
other file formats do not support SpriteEffects on objects.

Platform considerations
When it comes to using effects plug-ins, you should not have a prob-
lem when sharing documents on the same platform (Mac OS or 
Windows), as long as everyone who views the document has the 
same plug-ins installed. 

If you share documents across platforms, however, compatibility 
among third-party plug-ins — even ones with the same names — is 
not guaranteed.

Printing effects
When you print from Canvas, preserving effects should not be a 
problem, as long as effects plug-ins are available in Canvas when 
the document is printed. Whether you print directly to an output 
device or to a PostScript file, Canvas renders effects before printing. 
This is true unless, in the Print dialog box, you set Transparency 
Rendering to “Don’t Render Transparent Objects.” When this 
option is selected, the only SpriteEffects that will be printed are lens 
objects that have no effects except magnification and viewpoints. 

Rendering effects
Preserve the appearance of effects by rendering objects before shar-
ing a Canvas document. Rendering converts SpriteEffects and 
objects into static images. 

You can use several methods to render SpriteEffects:

• Use the Camera tool to select an area of an illustration to 
render.

• Select objects that have effects, including lenses, and 
choose Image > Area > Render. 

• Save a document in an image file format, such as BMP, 
GIF, JPEG, PCX, or TIFF. Canvas renders the document 
as an image before saving the file. 

Tip
Effects and objects are not edit-
able after conversion to images.
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SPRITELAYER EFFECTS

SpriteLayer effects let you apply transparency to objects and text. 
You can use SpriteLayer transparency to create collages, Web 
graphics, layered illustrations, “ghosted” text, vignettes, and textur-
ing.

Using the Transparency palette
The Transparency palette is a control center for SpriteLayer effects. 
The palette includes controls and options for opacity, masks, trans-
parency scope, and transfer modes. 

• To open the Transparency palette: Choose Window > Palettes > 
Transparency or Object > SpriteLayers > Show Palette.

• Use the Opacity slider to set the opacity of a selected 
object. The effect is the same as using the Opacity slider in 
the Properties bar (see “Opacity effects” on page 35.2).

• Use the Scope options to control transparency effects in 
vector objects (see “Controlling the scope of transparency 
effects” on page 35.4).

• Change the transfer mode of a selected object using the 
Transfer Mode menu (see “Using transfer modes” on 
page 35.18).

• Apply channel masks and vector masks using the Mask 
menu (see “Transparency masks” on page 35.5).

You can also quickly apply SpriteLayer effects by using the controls 
in the Properties bar.

Note: You must the Transparency palette to access the Mask menu.

Tip
The palette works with a single 
selected object. The controls in 
the palette are not available when 
more than one object is selected.

SpriteLayer effects
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Opacity effects
Opacity is a basic transparency effect that can be applied to any 
object. 

When an object’s opacity is less than 100%, the object appears partly 
transparent. You can reduce the opacity of a text object, for exam-
ple, so a background image is visible through the type.

You use the Opacity slider to set the opacity of objects. The Opacity 
slider is available in the Properties bar and the Transparency pal-
ette. The slider in the Properties bar will set opacity for one or more 
selected objects. The slider in the Transparency palette is available 
only when a single object is selected.

Opacity affects the overall transparency of an object, so the Opacity 
slider is a master control for all transparency effects applied to an 
object. 

For example, you can use a channel mask to make an oval vignette 
from a photograph. At the edge of the oval, the photograph 
becomes completely transparent. If you then reduce the opacity, the 
visible part of the image becomes partly transparent.

When an object’s opacity is less than 100%, anything in the back-
ground, including the illustration area, can affect the object’s 
appearance. The appearance of colors in an object can also be 
affected by the object’s transfer mode (see “Using transfer modes” 
on page 35.18).

Transparency palette options

Options for opacity, transfer mode, 
scope, and masks appear in the Trans-
parency palette. When an object is 
selected, the Transparency palette dis-
plays the object’s opacity and transfer 
mode.

Opacity. Drag the slider or enter a per-
centage to set the opacity of a selected 
object.

Scope. Set the transparency scope for 
a selected vector object.

A Click to show or hide the mask op-
tions.

B Choose Channel to create a 
channel mask. Choose a vector 
mask style to create a vector mask. 
If the object has a mask, the menu 
shows the type of mask. Choose 
None to remove the object’s mask.

Edit. When a selected object has 
a channel mask or vector mask, 
click Edit to edit the mask.

C When a masked object is se-
lected, mask options appear in this 
area.
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To set the opacity of an object
You can use either the Opacity slider in the Properties bar or 
Transparency palette.

1 Select the object whose opacity you want to change.

2 Drag the Opacity slider to the left to decrease opacity; drag to 
the right to increase opacity. The opacity percentage appears at 
the right of the slider.

Defining opacity

“Transparency” and “opaci-
ty” are opposite terms that 
describe the ability to see 
through an object. 

Greater transparency means it 
is easier to see through some-
thing; greater opacity means it 
is harder to see though it.

In percentages, 100% opacity 
equals 0% transparency. 
Those values describe objects 
you can’t see through. 1% 
opacity equals 99% transpar-
ency. Those values describe 
almost completely clear 
objects.

All Canvas objects have an 
opacity. You can set opacity 
from 1% to 100% in 1% incre-
ments. The opacity of a new 
object is 100%. When you 
copy an object, the copies 
have the same opacity as the 
original object.

In this manual, the word 
“transparency” is often used 
as a general term for several 
related effects. The word 
“opacity” is used to refer to a 
specific effect and a specific 
property of objects. 

In other words, an object’s 
“transparency” can result 
from various factors, including 

ink settings, the transfer 
mode, a channel mask, or 
another effect. An object’s 
“opacity,” on the other hand, 
is a specific setting controlled 
by the Opacity slider.

Drag the Opacity slider in the Properties bar or Transparency palette to set the opacity of selected objects
Opacity effects 35.3
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Setting opacity for multiple objects
Use the Opacity slider in the Properties bar to set the opacity for 
more than one object. Each selected object will have the same opac-
ity setting.

• To adjust the opacity of a group object: Use the Opacity slider in 
the Properties bar or in the Transparency palette, since a selected 
group object is considered a single object. When a group object is 
selected, changing the opacity applies to the group as a whole. 
Objects that were opaque do not become transparent to other 
objects in the group if you reduce the opacity of the group object. 

Consider a group of three objects whose opacities are 30%, 60%, and 
100%. If you set the opacity of the group object to 50%, the opacities 
of the individual objects will appear to be 15%, 30%, and 50% relative 
to the background. If you ungroup the objects, their opacities will 
be restored to 30%, 60%, and 100%.

Controlling the scope of transparency effects
All vector objects have scope settings that control what parts of the 
objects are affected by transparency. 

The scope setting can limit transparency to an object’s fill ink only. 
Or, it can apply transparency to the fill ink and the pen ink on the 
object’s stroke. 

The scope setting controls all transparency effects applied to vector 
objects, including opacity, channel masks, vector masks, and trans-
fer modes. 

Each vector object has a scope setting. Scope settings do not affect 
text objects, paint objects, or group objects.

You can change the scope setting of a selected vector object by 
using the Scope controls in the Properties bar or the Transparency 
palette (see “Using the Transparency palette” on page 35.1).

The scope setting can affect the time needed to print an object. 
When an object has a reduced opacity setting (but no other trans-
parency effects) and the scope is Fill, Canvas can print the object on 
PostScript printers without rendering. If the scope is Fill & Stroke, 
Canvas renders the object and prints it as an image. An image usu-
ally contains more data than a vector object, so this can increase the 
time required to print an object.

Tip
If you ungroup an object, the 
group opacity setting is removed 
and the opacity of each separate 
object is restored.

Fill

Fill & Stroke
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To set an object’s transparency scope
1 Select a vector object.

2 Select a Scope option in the Properties bar or Transparency 
palette:

• To apply transparency effects to the entire object: Select Fill & 
Stroke. 

• To apply transparency effects to the object’s fill ink only: Select 
Fill. 

Transparency masks
Transparency masks let you create complex transparency effects. 
You can use transparency masks with vector, paint, text, and group 
objects.

Channel masks and vector masks are the two types of transparency 
masks available. You can apply either mask type to vector, text, 
paint, and group objects. 

• Channel mask: Creates transparency based on a grayscale 
image. A channel mask is part of an object, the same way an image 
channel is part of a paint object. You can use painting tools and 
image-editing techniques in a channel mask.

• Vector mask: Creates transparency based on a vector gradient 
or the colors of a vector object. Vector masks can produce gradual 
transparency changes the same way that gradient inks produce 
gradual color changes. You can drag a tool to create radial, linear, 
elliptical, and rectangular vector masks, or you can use an object as 
a vector mask.

Changing the transparency preview
When you edit paint objects or channel masks, Canvas previews 
transparency effects according to a preference setting. You can tem-
porarily change the preview when you are in channel mask edit 
mode. 

When you edit a channel mask with no preview, a checkerboard 
pattern lets you focus on the transparent object. The checkerboard 
hides objects behind the transparent object, while showing the 
transparent areas in the object you are editing.

Scope options

Tip
An object can have only one mask, 
but it can have a mask along with 
other effects such as opacity and 
transfer mode.
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Note: In Total Preview mode, Canvas shows objects that are in front 
and in back of a paint object or channel mask you are editing.

• To turn off the transparency preview: Press the Asterisk (*) key, 
or choose Hide Transparency Preview in the context menu. 

• To restore the transparency preview: Choose Show Transpar-
ency Preview in the context menu. If you don’t choose the com-
mand, Canvas restores the preview setting each time you leave edit 
mode.

• To set the Transparency preview: Choose Canvas > Configura-
tion Center (Mac) or File > Configuration Center (Windows). Open 
the Screen Rendering manager and select an option in the Trans-
parency area. Click Background Preview to preview background 
objects only. Click Total Preview to preview background and fore-
ground objects. Click No Preview to display transparent objects 
against a checkerboard pattern for editing. 

Note: If you select the No Preview preference, you can’t use the con-
text menu to change the preview while you edit an object.

The preview preference affects what you see when you paint in a 
transparent paint object or edit any paint object. If objects are in 
front of the paint object, you can see the objects while editing if you 
select Total Preview. If you select Background Preview or No Pre-
view, foreground objects are not displayed when you edit a paint 
object or a channel mask.

Channel masks
A channel mask is a special channel that defines transparency in an 
object. While channels are typically associated with paint objects, 
you can apply a channel mask to any type of object.

Transparency effect Channel mask Object with symbol ink
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Like an alpha channel in a paint object, a channel mask is basically 
a grayscale image. Channel masks can be edited using image-edit-
ing tools and techniques, similar to alpha channels.

You can think of a channel mask as a template for transparency. 
The channel mask is the same size as the masked object and is 
aligned with it. In the case of a paint object, the channel mask has 
the same resolution and number of pixels as the paint object.

Channel masks, like grayscale images, contain pixels that are 
assigned 256 possible lightness levels, or luminance values. Lumi-
nance values in a channel can range from 0 (black) to 255 (white). 

In an alpha channel, luminance corresponds to selection intensity. 
In a channel mask, luminance values correspond to 256 levels of 
transparency, from 100% to 0% transparency, in the masked object. 
Black pixels (0 luminance) produce 100% transparency, while white 
pixels (255 luminance) produce 0% transparency. 

Therefore, when you paint in a channel mask, painting with black 
produces clear areas and painting with white produces opaque 
areas in the masked object. Painting with gray produces partial 
transparency relative to the gray value, with darker grays producing 
greater transparency than lighter grays.

Keep in mind that an object’s appearance can be affected by its 
transfer mode, scope setting, and opacity, in addition to a channel 
mask. Changing the transfer mode can completely change the 
appearance of an object that has a channel mask (see “Using trans-
fer modes” on page 35.18).

Black in a channel mask (left) 
produces 100% transparency

A feathered edge produces par-
tial transparency

Channel mask and paint object Masked object
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Creating channel masks
You can create a blank channel mask, or create a channel mask 
from a paint object. You create a channel mask when you render 
objects (see “Rendering objects and images” on page 23.23).

You can use the Transparency palette, Sprite tool, or the Channels 
palette to create blank channel masks (see “Channel masks,” 
page 26.25 for more information about the Channels palette). In 
the Transparency palette, the Mask menu shows “Channel” when a 
selected object has a channel mask.

To create a channel mask
This procedure creates a blank channel mask for an object.

1 Select a text, paint, vector, or group object to mask. 

2 Select Channel from the Mask menu on the Transparency 
palette or press Option (Mac) or Ctrl (Windows) and double-click 
the object.

• If the object to be masked is not a paint object, a dialog 
box asks you to set the resolution of the mask. Enter a res-
olution from 1 to 2,540 ppi and click OK. 

• If the object is a paint object, the channel mask’s resolu-
tion will be the same as the paint object’s resolution.

3 The object appears in channel mask edit mode, with the 
object visible and the channel mask selected. You can edit the 
channel mask with painting tools (see “Editing channel masks” on 
page 35.9).

4 Press Esc to leave edit mode when you finish.

When you create a new channel mask, the channel is filled with 
white pixels. At this point, the channel mask produces no transpar-
ency because white pixels in the channel mask produce 0% transpar-
ency in the masked object. As you edit the channel, painting with 
gray produces partial transparency, and painting with black pro-
duces 100% transparency.

Tip
You can also choose Object > 
SpriteLayers > New Channel 
Mask.

To create a channel 
mask with the Sprite tool 

Use the Sprite tool to apply a channel 
mask to a text, vector, or image object.

1 Select the object to which you want 
to apply the mask.

2 Select the Sprite tool and click on 
the selected object. The object switch-
es to image edit mode.

Once masked, apply transparency 
effects to the mask with Painting tools.
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To set the channel mask scope
When you apply a channel mask to a vector object, the channel 
mask affects the vector object’s fill ink or fill ink and stroke (pen 
ink). To change the effect, change the Scope option in the Proper-
ties bar or Transparency palette (see “Controlling the scope of 
transparency effects” on page 35.4).

Masking with a paint object
You can create a channel mask by attaching a paint object to 
another object. If you have an existing paint object that you want to 
use as a channel mask, it’s quicker to use this procedure than to use 
the Channels palette to place the paint object in a channel mask.

To attach a channel mask
1 Place a paint object to use as a mask in front of the object to 
be masked. The two objects do not have to overlap or touch, but 
the paint object must be in front of the other object in the stacking 
order.

2 Select both objects.

3 Choose Object > SpriteLayers > Attach Mask. Canvas creates 
a channel mask and both objects remain selected. The original 
paint object is not changed.

If the paint object and the object to be masked aren’t the same size, 
Canvas scales the image of the paint object to fit the masked object.

A channel mask created from a paint object is the same as any 
channel mask. You can edit it the same as if you created a blank 
channel mask.

Like any other channel mask, a channel mask created from a paint 
object produces transparency relative to its gray values. If the chan-
nel mask is solid white, it creates no transparency; if it is solid black, 
it creates 100% transparency and makes the masked object invisible.

Editing channel masks
You can use painting tools, filters, and image-editing commands to 
modify the effect of a channel mask. 

• To edit a channel mask: Place the masked object in channel 
mask edit mode.
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Editing a channel mask is similar to editing a channel in a paint 
object. You can paint in the channel mask with shades of gray. You 
can make selections with selection tools, commands, and alpha 
channels. You can apply image-adjustment commands and filters to 
the entire channel mask or to just the selected areas.

Options for channel mask editing
You can enter channel mask edit mode using any of the following 
methods.

With the mouse Press Option (Mac) or Ctrl (Windows) and dou-
ble-click a masked object. 

Note: If the object doesn’t have a channel mask, this creates a chan-
nel mask and puts the object in channel mask edit mode.

In the Transparency palette Click the Edit button when a masked 
object is selected. This places an object with a channel mask in 
channel mask edit mode. If the object has a vector mask, it places 
the vector mask in edit mode.

In the Channels palette When a paint object is in edit mode, click 
the channel mask to select it for editing. When any other object is in 
channel mask edit mode, the channel mask is the only channel that 
can be selected.

To edit a channel mask
1 Select the masked object. 

2 Choose Object > SpriteLayers > Edit Channel Mask. The 
masked object appears in channel mask edit mode. 

In this mode, the channel mask is active and the object is also visi-
ble. You can paint in the channel or modify it to change the trans-
parency of the underlying object.

3 Press Esc to leave edit mode when you finish editing. The 
object remains selected.

Selecting views for channel mask editing
You have a choice of view when you edit an object’s channel mask. 
You can display the object and the channel mask together, which 
shows you the overall effect of the mask as you edit it. Or, you can 
hide the object to concentrate on the channel mask alone.
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For information on selecting views with the Channels palette, see 
“Editing channel masks,” page 26.26).

Selecting views in the Transparency palette
You can use the Transparency palette to change your view when 
you edit a channel mask. In channel mask edit mode, two buttons 
let you select editing views. Click the triangle at the lower left to 
expand the palette if necessary to display the buttons.

• To view the channel mask only: Click “Channel Mask Only” in 
the Transparency palette. This is the same as hiding the “object 
channel” in the Channels palette.

• To view the object and channel mask: Click “Image and Chan-
nel Mask.” This is the same as making the “object channel” and the 
channel mask visible in the Channels palette.

To remove a channel mask
Removing a channel mask from an object removes the transpar-
ency effect produced by the channel mask.

1 Select the masked object. 

2 Choose Object > SpriteLayers > Detach Mask. Canvas 
removes the channel mask from the selected object. 

When you detach a channel mask, Canvas converts the channel 
mask to a paint object and places it in the document. The paint 

Click the eye symbol to hide the 
object or channel mask 

A Click to show the mask effect on the object
B Click to show the channel mask alone

Use the Transparency and Channels palettes 
to change your view when you edit a channel 
mask 

Click to show options
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object includes the alpha channels from the masked object if it had 
alpha channels.

Vector masks
A vector mask creates a transparency effect based on a style of gra-
dient ink, such as radial or rectangular. You can choose the style 
when you apply a vector mask, or you can apply an existing vector 
object as a vector mask. 

A vector mask can be applied to any type of objects, including vec-
tor, paint, text, and group objects.

It’s easy to apply vector masks. You can drag a vector transparency 
tool to apply radial, directional, elliptical, or rectangular style 
masks. If you want to use precise values for position and transpar-
ency levels, you can enter numbers in the Transparency palette. 
You can apply a mask quickly by selecting an object and choosing 
Object > SpriteLayers and selecting a vector mask style in the sub-
menu.

The styles of vector masks applied by the Vector Transparency 
tools are related to vector gradient styles. You can think of these 
tools as applying a hidden gradient to a masked object. The trans-
parency effect is based on the hidden gradient; the transparency 
level is relative to the lightness of the gradient shading.

For example, a linear vector gradient blends colors along a straight 
axis. A directional vector mask fades from opaque to transparent 
along a linear axis. For linear vector gradients and directional vec-
tor masks, you can specify the length and angle of the axis.

The relationship between vector gradients and vector transparency 
masks can be seen if you detach a vector transparency mask. With a 
masked object selected, choose Object > SpriteLayers > Detach 
Mask. Canvas removes the vector mask and places it in the docu-
ment as a separate vector object. If you examine this object, you see 

Vector mask styles

(Left to right) Radial, Directional, 
Rectangular, Elliptical
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that it has a vector gradient. The gradient style is similar to the vec-
tor mask style. The vector gradient fades from black to white in the 
same way that the vector mask caused the masked object to fade 
from transparent to opaque.

The relationship between vector masks and vector gradients also 
works in reverse; use a vector gradient-filled object as a vector mask 
(see “Masking with a vector object” on page 35.14).

Applying vector masks
You can apply a vector mask using the Vector Transparency tools. 
When an object is selected, you can drag one of these tools near or 
over the object to apply a transparency effect. 

The Vector Transparency tools provide the easiest way to create 
transparency effects such as vignettes (image that appear in ovals 
and other shapes) as well as linear, radial, or rectangular fades.

You can use the Transparency palette to apply vector transparency 
effects. When you use the Transparency palette, you can specify val-
ues for the position and intensity of the effect.

In the Transparency palette, the Mask menu shows the vector mask 
style when a selected object has a vector mask.

A vector mask is related to a vec-
tor gradient

If you detach a vector mask, you 
get an object with a gradient. The 
grays in the gradient correspond 
to transparency levels in a 
masked object.

Masked objectDetached mask Original object
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To create a vector mask
1 Select a text, paint, vector, or group object to mask. 

2 Select a Vector Transparency tool. These tools are in the 
Transparency tools palette. Select the tool for the style of vector 
mask you want to apply: Radial, Directional, Rectangular, or 
Elliptical.

3 Drag the tool near or over the selected object. 

4 To adjust the effect, drag a handle to reposition the transpar-
ency vector. 

5 Press Esc to leave edit mode.

To use the Transparency palette
You can use the Transparency palette to apply a vector mask. To 
open the Transparency palette, see “Using the Transparency pal-
ette” on page 35.1.

1 Select an object to mask. 

2 In the Transparency palette, choose a mask style in the Mask 
menu. 

Note: You can’t select “Object” in the menu. To use an object as a 
vector mask, see “Masking with a vector object” on page 35.14.

3 To adjust the effect, drag the handles to reposition the trans-
parency vector. When you finish, press Esc to leave edit mode.

To set the vector mask scope
When you apply a vector mask to a vector object, the mask affects 
the vector object’s fill ink or its fill ink and stroke (pen ink). To 
change the effect, change the Scope option in the Properties bar or 
Transparency palette (see “Controlling the scope of transparency 
effects” on page 35.4).

Masking with a vector object
Create a vector mask by attaching a vector object to another object. 
Like other vector masks, a vector mask created from a vector object 
produces transparency relative to its color values; e.g., if the vector 
object that you attach is solid white, it creates no transparency; if it 
is solid black, it creates 100% transparency, making the masked 
object invisible.

Vector Transparency tools: Radial, 
Directional, Rectangular, Elliptical

As you drag, a vector line or shape 
appears, which represents the 
position of the vector transparency 
effect.
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To attach a vector mask
1 Place a vector object to use as a mask in front of the object to 
be masked. The two objects do not have to overlap or touch, but 
the vector object must be in front of the other object in the stack-
ing order.

2 Select both objects.

3 Choose Object > SpriteLayers > Attach Mask. Canvas creates 
a vector mask and both objects remain selected. The original vec-
tor object is not changed.

If the vector object and the object to be masked aren’t the same 
size, Canvas scales the vector object to fit the masked object.

Editing vector masks
You can edit vector masks that have been applied with the Vector 
Transparency tools, and masks created by attaching gradient-filled 
vector objects. Editing lets you change the boundary of the opaque 
and transparent areas of a mask. You can also add nodes for finer 
control of transparency levels.

To edit a vector mask
1 Select the object and click Edit in the Transparency palette 
(see “Using the Transparency palette” on page 35.1). Or, select 
the Vector Transparency tool that was used to apply the mask.

2 Drag the vector mask editing handles to adjust the position 
and boundaries of the vector mask.

3 Press Esc when you finish editing.

Editing values in the Transparency palette
Change values in the Transparency palette to make precise changes 
to a vector mask. When you change the mask settings, Canvas 
updates the mask handles to match the current position values.

To edit a vector mask via the Transparency palette
1 Select the masked object and click Edit in the Transparency 
palette.

2 Change the following values to modify the effect of the vector 
mask.

The handles correspond to the 
values in the Mask area in the 
Transparency palette. When you 
drag a handle, the values are 
updated to match the new position.
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Transparency Start: The transparency percentage at the edge of the 
vector effect. If this value is 100%, the object appears completely 
transparent beyond this point. When you first apply a mask in rect-
angular or elliptical style, this point is represented by the handle at 
the edge of the object.

Transparency End: The transparency percentage at the end of the 
vector effect. If this value is 0%, for example, the object is not trans-
parent at this point. When you first apply a mask in the rectangular 
or elliptical style, this percentage corresponds to the area enclosed 
near the center of the object, which is 0% transparent. For radial 
style, the start point is the handle on the perimeter of the circle. The 
end is at an opposite point on the circle.

Left. The distance of the first handle from the left edge of the object, 
measured as a percentage of the object’s width.

Top. The distance of the first handle from the top edge of the 
object, measured as a percentage of the object’s height.

Width. The horizontal distance to the second handle from the first 
handle, measured as a percentage of the object’s width.

Height. The vertical distance to the mask’s second handle from the 
first handle, measured as a percentage of the object’s height.

Adding nodes
The default handles that appear in vector mask edit mode indicate 
the start and end points of the transparency gradient. For a direc-
tional mask (the most basic style), a hollow handle represents the 
point of 100% transparency, and the solid handle represents the 
point of 100% opacity.

When a vector mask is in edit mode, you can add nodes to set addi-
tional opacity levels. The default mask has a start and end point, 
with a smooth transition from opacity to transparency between the 
start and end point. When you add nodes, set the opacity level at 
each node.

To add a node
1 Select the masked object and then click the vector transpar-
ency tool for the mask style to enter edit mode. 

2 Point to the vector mask and press Ctrl+click (Mac) or right-
click (Windows). An opacity slider appears. 

Nodes (small circles) let you set 
several opacity levels in a 
directional vector mask
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3 Use the slider to set the opacity level of the new node; i.e., 100 
makes the mask opaque at the node, whereas 0 makes the mask 
completely transparent at the node. 

4 Select a value between 0 and 100 to make the mask semi-
transparent at the node.

When you edit rectangular or elliptical vector mask styles, add 
nodes to the horizontal vector that joins the inner box (which repre-
sents the area of 100% opacity) to the object’s bounding box. When 
you edit radial mask styles, you can add nodes to the circle, which 
represents the 360° sweep of the mask.

Removing a vector mask
Removing a vector mask from an object removes the transparency 
effect produced by the mask.

1 Select the masked object. 

2 Choose Object > SpriteLayers > Detach Mask. Canvas 
removes the vector mask from the selected object. 

When you detach a vector mask, the former mask appears in the 
document as a separate vector object filled with a grayscale gradi-
ent.

Vector masks in paint edit mode
If a paint object has a vector mask, Canvas temporarily represents 
the vector mask as a channel mask if you edit the paint object. 

In paint edit mode, a temporary channel mask that represents the 
object’s vector mask appears in the Channel Mask slot in the Chan-
nels palette. The temporary mask lets you see the effect of the vec-
tor mask as you edit the paint object.

Use the pop-up opacity slider to set 
the opacity level of a node. You can 
add a series of nodes for additional 
control of a transparency mask.

Setting node opacity Directional Rectangular
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If you click in the Channel Mask slot to try to select the temporary 
channel mask for editing, Canvas asks if you want to convert the 
vector mask to a channel mask. 

• Click Cancel to return to editing the paint object without 
destroying the vector mask. 

• Click Yes if you want Canvas to convert the vector mask to 
a channel mask that can be edited with painting tools (see 
“Editing channel masks,” page 26.26).

Using transfer modes
All objects — vector objects, text objects, paint objects, and group 
objects — have a transfer mode, which are like invisible filters that 
affect the appearance of colors. When objects overlap, the transfer 
mode of the front object can change the appearance of the back 
object. 

Transfer modes work with transparency effects, including opacity 
and transparency masks; however, transfer modes can make objects 
appear to be transparent without reduced opacity or transparency 
masks; e.g., Multiply mode lets underlying colors show through an 
object.

The default transfer mode is Normal; i.e., the colors of overlapping 
objects do not mix unless the front object is partially transparent.

In addition to interacting with background objects, transfer modes 
can interact with the document’s white background. When an 
object’s transfer mode is Screen, anything white replaces the 
object’s color, so the document’s white background can make the 
object seem to be invisible.

To change an object’s transfer mode
1 Select an object and choose a mode in the Transfer Mode 
menu in the Properties bar or Transparency palette. 

2 For vector objects, select a Scope option for either the Fill or 
Fill & Stroke.

Available transfer modes
The following descriptions are based on objects with RGB colors 
with no other transparency effects. Each mode is described in terms 
of the front object when the back object’s transfer mode is Normal.

Tip
For vector objects, apply transfer 
modes to fill inks alone or to fill 
inks and strokes together.

Transfer Mode menu
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Normal IColors do not blend; the color of a front object hides the 
colors of all objects behind it.

Multiply IOverlapping colors become darker. Black produces 
black. White has no effect, the same as if a white object were not vis-
ible. White text, for example, reveals the background.

Screen Overlapping colors are lightened. Objects with lighter col-
ors increase the effect. White produces white. Black has no effect, 
the same as if a black object were not visible. Black text, for exam-
ple, reveals the background. 

Overlay A front object’s color overlays colors in the background, 
while preserving highlights and shadows. White and black in the 
background are not affected.

Soft Light Underlying colors are lightened or darkened depending 
on the brightness of the front color. Colors in front that are lighter 
than 50% gray lighten the underlying object. Colors in front that are 
darker than 50% gray darken the underlying object.

Hard Light Underlying colors are lightened or darkened depend-
ing on the brightness value of the front color. Hard Light mode is 
similar to Soft Light. However, black in the front object produces 
black; white in the front object produces white.

Darken The color values of the front color replace the underlying 
color values if the front color value is darker than the back color 
value. Black in the background appears unchanged; the front color 
appears in place of white in the background.

Lighten The color values of the front color replace the underlying 
color values if the front color value is lighter than the back color 
value. White in the background appears unchanged; the front color 
appears in place of black in the background.

Difference The color value of the front and back colors are com-
pared and the darker value is subtracted from the lighter value. If 
the front and back colors are identical, the result is black. If the 
front or back color is black, the other color does not change. If the 
front or back color is white, the other color is inverted.

Dodge Dodge mode compares the lightness values in each chan-
nel of the front and back colors, and uses the lighter value from 
each channel for the result color. However, black is not replaced by 
a lighter color. White in the front replaces all colors except black.
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Burn Burn mode compares the lightness values in each channel of 
the front and back colors, and uses the darker value from each 
channel for the result color. However, white is not replaced by a 
darker color. Black in front replaces all colors except white.

Color modes
Canvas calculates transfer mode effects by applying formulas to 
color values. Canvas performs these calculations using RGB color 
values or CMYK color values.

For example, the formula for Multiply mode is Color 1 multiplied 
by Color 2. Canvas applies the formula separately to each value 
that defines a color. In the case of RGB colors, Canvas applies the 
formula separately to the red, green, and blue values. For CMYK 
colors, Canvas calculates the effect on cyan, magenta, yellow, and 
black values.

The significance of the color space calculation is that the effect you 
see on screen could appear completely different if the effect is 
printed in a different color space.

In particular, you must display transfer mode effects in CMYK if 
the document will be separated for printing with process (CMYK) 
colors. Otherwise, the color separations could produce colors that 
are completely different from the colors you see on screen.

For an example of this effect, draw several overlapping objects with 
different colors. Set the transfer mode of the front object to Differ-
ence (see “Available transfer modes,” page 35.18). Choose Layout > 
Display Options. In the Display Options manager, change the 
Mode from RGB to CMYK. Click OK to close the manager. To 
refresh the screen, press Command+K (Mac) or F5 (Windows). You 
will probably see a significant change in colors when you switch 
from RGB to CMYK mode.

To set the color mode for screen compositing
1 Choose Layout > Display Options.

2 Select Grayscale, RGB, or CMYK in the Mode menu in the 
Display Options manager. Choose RGB for effects that will dis-
played in RGB colors. Choose CMYK if you are using CMYK col-
ors in a document that will be printed with process colors.

Tip
Select Grayscale from the menu to 
lessen the required memory if 
working on complex graphics or 
editing images. In Grayscale 
mode, your screen redraws faster 
than in CMYK or RGB.
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Transparency and printing
You can use transparency effects to create stunning images and 
complex illustrations. As with any graphic effects, however, images 
that appear perfect on screen can cause problems or produce unex-
pected results when you print a document. This section discusses 
some issues you should keep in mind to help ensure that your docu-
ments print successfully.

Canvas uses special techniques to print some transparency effects. 
Canvas can send an instruction to print an opaque rectangle, for 
example, to most printers; however, to print a transparent rectan-
gle, Canvas usually converts the object to an image. This process is 
called rasterizing or rendering. Canvas then sends the image data 
to the printer.

In the Print dialog box, you can select options for printing objects 
and colors. The options can affect the time required to print a docu-
ment, and how well colors match among objects (see “Transpar-
ency Rendering” on page 9.15).

Output resolution of transparency effects
You can specify an output resolution for a transparent object. If you 
don’t specify the resolution, Canvas selects the resolution based on 
the following guidelines:

• If a transparent paint object overlaps other paint objects, 
Canvas rasterizes all the objects at the same resolution as 
the paint object that has the highest resolution.

• If a vector object is transparent or is behind a transparent 
object, Canvas rasterizes the vector object at the resolution 
specified for printing. You can set the resolution for print-
ing in the Output Settings manager in the Configuration 
Center (see “Printing settings,” page 13.16).

To set the output resolution of an object
1 Select the object whose resolution you want to specify.
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2 Choose Object > SpriteLayers > Output Resolution to open 
the Output Resolution dialog box.

3 Do one of the following and then click OK:

• Select the Maximum Resolution checkbox to specify that 
the object should be rendered at the maximum resolution 
of the output device.

• Deselect the Maximum Resolution checkbox and enter 
the resolution you want Canvas to use. You can set the res-
olution from 1 to 2,540 dpi.

To set the maximum output resolution
You can specify a maximum resolution for Canvas output. The res-
olution you specify in the Output Settings manager affects output 
of all objects and rasterizing of transparency effects. This setting 
overrides settings you apply to objects with the Output Resolution 
command (see “Output to maximum resolution,” page 13.17).
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Chapter

36
DESIGNING FOR THE WEB

Canvas is an ideal tool for creating graphics and layouts for the 
World Wide Web. This chapter explores how to prepare graphics 
and documents for publishing on the Web or an Intranet. It 
includes information on hyperlinks, slices, animations, Web but-
tons, and exporting to PDF and Flash.

About hyperlinks and hypertext
After you create illustrations and text for a Web page in Canvas, 
use the Link Manager palette to link items to other Web pages and 
resources on the Internet. 

Graphics, such as buttons or images, that lead to other Web pages 
are called hyperlinks. Text that contains a hyperlink is called hypertext. 
Click a hyperlink on a Web page to jump to another page or a dif-
ferent site altogether. The Web browser searches the Internet for 
the address associated with the hyperlink. 

You can make hyperlinks by assigning URLs to any page element, 
including the following:

• vector objects, such as small illustrations 

• image objects, including photos and painted images

• text selections and entire text objects 

• buttons and animations

Note: To prevent unintended changes, you can’t assign URLs to 
objects on locked layers, pages, or slides. You must unlock prior to 
making changes.

Tip
An Internet address is referred to 
as a URL, an abbreviation of Uni-
form Resource Locator.

Hypertext Hyperlinked image

Examples of hyperlinks

Hyperlinked object

Tip
To create invisible “hotspots,” you 
can assign URLs to objects that 
don’t have visible strokes or fill 
inks. This lets you designate any 
area of a Web page as a hyperlink.
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Using the Link Manager palette
With the Link Manager palette, you can assign hyperlinks to page 
elements so they jump to files or Web pages on the Internet, a local 
hard drive, or an Intranet. In addition, create e-mail links by using 
the mailto: command or define anchors with the Anchor function.

Creating hyperlinks and anchors
Before assigning links to elements, you should understand the vari-
ous hyperlink commands and their respective uses. Also, when link-
ing to Web pages or files, you need to consider how the linked item 

Link Manager palette
A Link. Enter a URL and then click the 
Link button. To link to another file, open 
the menu and select Browse. Select the 
file and then click the Link button. 
B Title. Enter a descriptive title for the 
link. Once published online, when a visi-
tor places the mouse over the link, the Ti-
tle appears like a tooltip.
C Target menu. Decide how the link 
will appear in the browser window (see 
“Targets” on page 36.3). The Width and 
Height options become available for the 
popup option.
D Style. Define the text properties for 
the hypertext. 
• None assigns no style. 
• Default uses the browser settings.
• Explicit. Use the text format 
options and color pop-out palette to 
define the link. Your settings will over-
ride the browser settings.
E Available Links. Click on the radio 
buttons to see the links within the various 
categories (see “Available Links” on 
page 36.2).

Link button: Click to assign the URL in 
the Link field to a selected object.

Unlink button: Click to remove the link 
from the selected object. 

Anchor button. Click to define the 
selected page element as an anchor 
(see “To define an anchor” on 
page 36.4). 

Link Manager menu: Open this menu 
to select a URL format, such as http://, 
ftp://, mailto:, etc. 

Available Links

Pages. Select the radio button to view 
the various page links and navigation 
controls (see “To insert page and site 
navigation controls” on page 36.6).

Anchors. Select the radio button to 
view the defined anchors within the 
present document (see “To define an 
anchor” on page 36.4).

Favorites. Select the radio button to 
view your list of Favorite links (see 
“Favorite links” on page 36.8).

User defined. Select the radio button to 
view the links that have been used in 
this document (see “User defined 
links” on page 36.7).

Remove. Select a link in the Favorites 
list and click this button to delete it 
from the list.

Add to Favorites. Define a link and click 
the Link button. Then select the User 
defined radio button. Select a link in the 
list and click Add to Favorites.

Refresh. Click this button to refresh the 
User defined list after removing links.

Link button

Unlink button

Menu

Color 
pop-out 
palette

Anchor
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will be displayed; i.e., in a new browser window, within the current 
window, etc. (see “Targets” on page 36.3).

Protocols and commands
All links start with a protocol or command that identifies the type 
of resource or action. Open the Link Manager menu to select a 
hyperlink protocol or command instead of typing it in the field.

http:// Hypertext Transfer Protocol. A Web address starts with http, 
followed by the Internet address, path, and name of a Web page; 
e.g., http://www.acdsystems.com/English/index.htm

ftp:// File Transfer Protocol. A file’s URL can start with ftp followed 
by the Internet address, path, and name of a file; 
e.g., ftp://ftp.deneba.com/public/Guide.pdf

mailto: An e-mail link starts with mailto followed by a username, @ 
symbol, and domain name; e.g., mailto:support@acdsystems.com

Targets
The target is the frame in which the linked content will open. The 
following options are available:

_top The linked document loads in the full browser window. All 
frames are removed.

_parent The linked document loads in the parent frame or parent 
window of the frame containing the link. If that frame is not nested, 
the linked document loads in the full browser window.

_self This is the default target. The linked document loads in the 
same frame or window as the link.

_blank The linked document opens in a new browser window. 
The current browser window is kept available.

_popup The linked document loads in a popup window. The 
Width and Height fields are available with this selection.

Relative paths Create hyperlinks to Web pages by typing relative 
paths, rather than complete URLs, in the Link Manager palette. 
Canvas specifies links this way when you select local files by using 
the Browse function in the Link Manager palette (see “To use 
Browse to link to a local Web page” on page 36.7).

To assign a URL to an element
Use these steps to create hyperlinks with the Link Manager palette. 

Link Manager menu
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1 Select the element that will contain the hyperlink. Elements 
include text as well as vector and image objects.

2 Enter the hyperlink in the Link field. You can also use the 
browse command in the menu to search for a file.

3 Add some descriptive information in the Title field.

4 Select the appropriate target frame (see “Targets” on 
page 36.3).

5 Make any style changes, if needed, for a hypertext link.

6 Click the Link button to assign the link.

Note: When creating hyperlinks, ensure to respect the case of the 
domain name or file name due to case-sensitivity; i.e., if a document 
uses uppercase in its name, use uppercase and vice-versa.

To remove an assigned hyperlink
1 Select the element that has an assigned hyperlink that you 
want to remove. The hyperlink appears in the Link field.

2 Click the Unlink button.

To define an anchor
You can define anchors with various page elements, including text 
as well as vector and image objects. Use these steps to define 
anchors with the Link Manager palette.

1 Select the object to which you want to assign the anchor.

2 Click the Anchor button. The Anchors dialog box opens.

3 Enter a name for the anchor in the Define a new Anchor 
field.

4 Click OK to close the dialog box. The defined anchor should 
now appear in the Available Links section of the Link Manager 
palette when the Anchors radio button is selected.

Tip
You can’t assign a URL or action 
to objects on layers, pages, or 
slides that are locked.

Absolute paths & relative paths

An absolute path provides the complete URL of the linked 
document, including the protocol; i.e., http://. An example of 
an absolute path is http://www.deneba.com/community/
howto/default.html. You must use an absolute path to link to 
a document on another server. 

Relative paths are the recommended paths for local links. 
The basic concept behind relative paths is to omit the part of 
the absolute path that is common to both the current docu-
ment and the linked document, providing only the portion of 
the path that differs. The protocol is excluded from relative 
paths. Canvas specifies links this way when you select local 
files by using the Browse command in the Link Manager 
menu.
.4 DESIGNING FOR THE WEB



Note: If you redefine an anchor, make sure you select the Replace 
existing anchor checkbox. If it is deselected and you use the name 
of an existing anchor, a warning dialog box will appear.

To create links to anchors
You can assign anchor links to various page elements, including 
text as well as vector and image objects. Use these steps to link to an 
anchor with the Link Manager palette.

1 Select the element.

2 Click the Anchors radio button. The defined anchors appear 
in the list.

3 Select the anchor. You can enter a descriptive title as well as 
use the Target and Styles controls as you would with a hyperlink.

4 Click the Link button.

• To remove an anchor link: Select the element that contains the 
link to the anchor and click the Unlink button.

To create links between pages
After you link pages, you will want to export each page as a sepa-
rate Web page (see “HTML options” on page 36.26). Using this 
technique, you can easily convert a single Canvas document into a 
hyperlinked Web site.

1 Select the element that will contain the link.

2 Click the Pages radio button. The various page links appear 
in the list. 

3 Select the page to which you want to link. You can enter a 
descriptive title as well as use the Target and Styles controls as 
you would with a hyperlink.

Note: With page links, you would generally select _self for the Tar-
get since internal links should open in the current window.

4 Click the Link button and click OK.

Tip
Use the Document Layout palette 
to assign meaningful names to 
pages before you create links to 
them using the Link Manager pal-
ette.
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• To remove a page link: Select the element that contains the link 
and click the Unlink button.

Format of hyperlinks
Canvas creates links among pages using only file names, not com-
plete URLs. Therefore, when you create a series of linked Web 
pages from a Canvas document, be sure to keep the resulting files 
together in the same folder or directory on the Web server so the 
links among the pages function correctly.

To insert page and site navigation controls
Similar to the page links described previously, these controls are 
used to easily move around a Web page and jump between pages of 
a Web site.

1 Select the page element to contain the link. 

2 Choose from [page-top], [page-bottom], [first page], [previous 
page], [next page], [last page], or {Sheet #1}. You can enter a 
descriptive title as well as use the Target and Styles controls as 
you would with a hyperlink.

Note: With page and navigation controls, you would generally select 
_self for the Target since internal links should open in the current 
window.

3 Click the Link button and then click OK.

• To remove a navigation control: Select the element that contains 
the link and click the Unlink button.

This navigation control does this

[page-top] Jumps to the top of the current page

[page-bottom] Jumps to the bottom of the current page

[first page] Jumps to the first page

[previous page] Jumps to the page before the current page

[next page] Jumps to the following page

[last page] Jumps to the last page

{Sheet #1} Jumps to the specified page, sheet, frame, or slide.

Tip
An example of page navigation can 
be seen on any Canvas How-to 
tutorial (www.deneba.com/com-
munity/howto/default.html).
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Invalid characters in page names
Since some special characters are invalid in URLs, Canvas converts 
these characters if they are in a page or slide name that you select in 
the Link Manager palette.

If invalid characters appear in a page name, Canvas replaces the 
characters with underscores when Canvas assigns a URL. Invalid 
characters include a blank space and the following characters:

To use Browse to link to a local Web page
Use the Browse function in the Link Manager palette to create links 
to existing Web pages. Creating links to Web pages depends on 
their location in a directory structure.

1 Open the palette menu and select Browse. A dialog box 
opens.

2 Navigate to the file to which you want to link.

Note: By default, files that do not have an htm extension do not 
appear in the file list. To link to Web pages, be sure to select files 
that have the htm extension.

3 Click the Link button. Canvas makes the link based on the 
file’s location in the directory structure.

User defined links
In the Available Links section of the Link Manager palette, there is 
a radio button labeled User defined, which refer to any defined link 
that is outside of the local document; i.e., the link is not a page link 
or anchor. User defined links are document specific; i.e., when you 
close a document, the User defined links are not available in the 
new document.

• To view the User defined links: Select the User defined radio 
button and the list appears.

Invalid characters in assigned URLs

!
@
#
$
%
^

&
*
(
)
+
=

[
]
{
}
|
tab

` (grave accent)
~
<
>
?
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• To create a link using the User defined list: Select the element 
that will contain the link. Click on the User defined radio button 
and the list will appear. Select a link and click the Link button.

Favorite links
The Link Manager has a button that will definitely save you time if 
you use a specific link often: Add to Favorites. Rather than re-enter-
ing the link information over and over, you would simply select the 
link from your Favorites list and click the Link button.

• To add a link to the Favorites list: Select a link from the User 
defined list and click the Add to Favorites button.

• To create a link using the Favorites list: Select the element that 
will contain the link. Click on the Favorites radio button and the list 
will appear. Select a link and click the Link button.

• To remove a link from the Favorites list: Open the Favorites list 
and select the link. Click the Remove button.

Attaching hyperlinks to text
Select any amount of text — from one character to whole para-
graphs or entire text objects — and use the Link Manager palette to 
make the text selection a hypertext link to a Web page, ftp address, 
or e-mail address.

Tip
The Favorites list is not document 
specific so you can access your list 
when you open a new document.

Testing hyperlinks or 
commands

If you have attached 
hyperlinks or mailto 
commands to objects 
in your Canvas docu-

ment, you can now test or follow these 
links with the Hyperlink pointer.

Select the Hyperlink pointer from the 
Toolbox. Move the cursor over an 
object that contains a hyperlink. The 
cursor changes to a hand. Click the 

hand on the object and the associated 
program launches; e.g., Web browser, 
e-mail program. 
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Hypertext styles Many Web browsers indicate hypertext by under-
lining or coloring the text. Use the Link Manager palette to apply 
styles and colors when you create hypertext.

Text in images Making hypertext links in Canvas lets you design 
the equivalent of image maps that can be easily edited. To do this, 
place text on images (or vector objects), and then assign the appro-
priate hyperlink to the text. Later, if you want to change the illustra-
tion, you can edit the text, images, and objects separately in the 
original Canvas document. 

To create a hypertext link
1 Open the Link Manager palette.

2 Select text in the Canvas document. 

3 Enter the hyperlink in the Link field. You can also use the 
browse function to search for a file (see “Creating hyperlinks and 
anchors,” page 36.2).

4 Add some descriptive information in the Title field and select 
the appropriate target frame (see “Targets” on page 36.3).

5 Use the formats in the Style section to define the text proper-
ties for the hypertext.

6 Click the Link button to assign the link.

About file locations and URLs
In most cases, Web files are created on one computer and trans-
ferred to a Web server that is connected to the Internet. You might 
create Web pages on your home or office computer, then transfer 
the files over a network or the Internet to a Web server.

Web pages often contain links to other Web pages on the same 
Web server. Because these links are based on the names and loca-
tions of the files on the Web server, changing file names or loca-
tions can break the links among the pages.

Anti-aliased 
vector objects 
and text 

Hyperlinked 
image

Hyperlinked 
invisible 
object

Hyperlinked 
vector and text 

None assigns no style.

Default uses the browser settings.

Explicit. Use the text format options 
and color pop-out palette to define the 
link. Your settings will override the 
browser settings.

Text styles

Color palette

Click style buttons to apply text styles. 

Select a solid color ink from the color palette.
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To successfully create hyperlinks among Web pages on your site, 
you should understand how to use relative directory paths, absolute 
directory paths, and Internet URL addresses.

Absolute paths An absolute path specifies a file’s location starting 
at the top, or root, of the directory structure in which the file is 
stored; e.g., if a file named “Calendar.html” is stored in a folder 
named Events, inside a folder named Public, which is inside a 
folder named Home at the root of the hard drive, the path to the 
file is: /Home/Public/Events/Calendar.html

Relative paths A relative path specifies the location of a file rela-
tive to the location of another file in the same directory structure. 
Rather than starting at the root of the directory structure, a relative 
path starts at the location of one file or folder and lists the relative 
steps needed to get to the specified file. In a relative path, the sym-
bol ../ (two periods and a slash) signifies a move up one step toward 
the root level in the directory structure. 

Complete URLs Like an absolute path, a complete URL lists the 
directory path starting at the root to the location of a Web page on a 
server. In addition to the path and file name, a complete URL 
includes a protocol (http or ftp) and a domain name (see “Protocols 
and commands” on page 36.3.

Directory paths

In the directory diagram shown here, the relative path from 
the file “Local.html” in the Maps folder to the file “Calen-
dar.html” in the Events folder is:

../../Public/Events/Calendar.html

In this case, the relative path starts on one branch of the 
directory tree, moves to the root, and then back down 
another branch. 

If two files are on the same branch of a directory, the rela-
tive path can be much shorter than the absolute path. For 
example, the relative path between the file “Calendar.html” 
in the Events folder and a file named “Schedules” in the 
Public folder (one level above Events) is: ../Schedules.html

The absolute path to the same file is:
/Home/Public/Schedules.html

Calendar.htmlLocal.html

PublicOffices

Maps Events

Home
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In the “Directory paths” diagram on page 36.10, if the folder 
named Home is the root folder of a Web site, the URL for the “Cal-
endar.html” page is:

http://www.domain.com/Home/Public/Events/Calendar.html

Entering file names and URLs When you create hyperlinks, you can 
specify the target as a relative path or a complete URL. 

• If the two pages are in the same folder or directory, the rel-
ative path is simply the name of the target file.

• A complete URL specifies the actual location of the file on 
a Web server on the Internet. 

You can enter a relative path or a complete URL in the Link field.

When you use the Browse button in the Link Manager palette, Can-
vas can enter a relative path or a complete URL.

Pixel Mode
The Pixel Mode setting allows users to view graphics at 72 ppi 
before they are rendered. At the same time, all of your graphics will 
remain fully editable. Pixel Mode also prevents pixel shifting, 
which sometimes occurs when objects are exported to the Web.

• To turn on pixel mode: See “Alert and preview options,” 
page 13.3.

Creating Slices
Professional Web designers will confirm that a fast download time 
versus a slow one can spell the difference between commercial suc-
cess and failure. A visitor may quickly loose patience and hit the 
dreaded Back button if forced to wait too long for a Web page to 
load. Slicing large images into small, faster-loading pieces is one of 
the Web design tricks most often used.

http://www.acdsystems.com/default.html

Protocol Domain 

Root of directory

File name

A complete URL for a Web page
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A slice is a rectangular area of an image that becomes a cell in an 
HTML table. The HTML table is then exported to be placed onto 
a Web page. 

We suggest that you preview your work in a browser to ensure that 
your document will appear correctly. Also, remember that an 
image may appear differently when it is viewed on other platforms.

The tools that you need to use are the Slice Creator and the Slice 
Selector. The creation and manipulation of slices can only be 
accomplished when either of these two tools are activated.

The slicing tools lets you optimize and export any Canvas object 
for use on the Web. In addition, you can assign a URL to a specific 
slice (see “About hyperlinks and hypertext” on page 36.1). 

If you are new to slicing, then you need to know that Canvas con-
tains default settings that allow you to quickly perform the slicing 
function. In other words, you may immediately begin slicing an 
image and Canvas will assign default settings; however, so that you 
can achieve the optimal results, we suggest that you review Slicer 
Preferences (see “Slicer Preferences” on page 36.13). 

By using the Slicer Preferences prior to exporting an HTML table, 
you can efficiently manage your slices and significantly reduce the 
likelihood of potential problems. The procedure for properly set-
ting up the export of your slices into an HTML table is detailed 
later in this section.

Tip
You can import the table into an 
HTML editor for further editing. 

Slice Creator

Slice Selector
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Slicer Preferences

Double-click the Slice Creator icon or 
Slice Selector icon to open the Slicer 
Preferences in the Configuration Cen-
ter.

A General options
• Name template - Assign a name 
to the slice template. This default 
name is shared by all of the slices. The 
name specified here must always use 
one of the formatting marks (either “# 
” for numbers or “&” for a letter). If 
these marks aren’t used, then the 
application automatically adds a (#) 
to the end of the name. Other format-
ting keywords, such as [document] 
and [page] or a combination of these 
keywords, could be used together 
with the formatting marks. Additional 
naming information will be provided 
later in this section. A default name is 
automatically applied to a template if 
you don’t enter one; however, if a 
Web page is going to have more than 
one HTML table (which will contain a 
sliced image), then it’s a good idea to 
assign a unique template name before 
exporting the slices.
• Split preference - Choose a way 
of splitting overlapped slices. By 
default, slices are split without any 
preference. In that case, Canvas auto-
matically designates where or how to 
split an overlapping slice. 

You may edit the default by select-
ing either vertical or horizontal as 
your choice. The Splitting prefer-
ence remains in effect for all over-
lapping slices.

Note: Changing this preference 
affects all existing (overlapping) slic-
es, but not those that are hard-split 
using the Split command.

B Default image options

Image format

• Automatic — Canvas chooses 
the file format for images (see “How 
images are handled” on 
page 36.27). 
• JPEG or GIF — Select either 
option to save all images in one for-
mat or the other.

JPEG Quality - Four JPEG quality lev-
els are available:

• Best - least compression (100% 
quality). 
• Fine - 90% quality. 
• Good - 75% quality. 
• Draft - most compression (50% 
quality).

Anti-aliasing - Smoothes the edges of 
rendered vector objects and text 
objects.

• Finest uses up to 256 shades 
between each pair of colors. Images 

with more than 256 colors should be 
saved in JPEG format to preserve the 
full range of shades. If necessary, Can-
vas uses JPEG format if you select the 
Automatic Image Format option.
• Fine uses 64 shades per pair of 
colors. Medium uses 16 shades per 
color pair. Coarse uses four shades 
per color pair. 
• None - no anti-aliasing.
C Select Save these settings as the 
default to make these settings your de-
fault slicer preferences.

Click OK to save your Slicer prefer-
ences.
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Using the Slice Creator
The Slice Creator tool gives you the ability to actually create a rect-
angular (horizontal or vertical) Slice box; i.e., you can define the 
area of the object that is to be sliced.

All slices are automatically created inside a Slice layer. Specifically, 
this means that no matter which layer you were originally working 
in, the Slice operation will take place inside its own layer.

We suggest that you refer to the Document Layout palette during 
the first few times that you create slice (see “Using the Document 
Layout palette” on page 12.2). Doing so will better illustrate how 
your slices are handled by Canvas.

When creating a new slice, the cursor will automatically snap to an 
existing slice or a grid (in that order) (see “Drawing grids” on 
page 18.13 to learn how to create a Grid). 

Another way to ensure precision is to create and place alignment 
guides around and over the object. If you are unfamiliar with this 
process, then we suggest that you read “Using alignment guides” on 
page 11.12. 

Snapping to an existing slice is absolute. The cursor automatically 
snaps to a grid within a 3-pixel range of an existing slice.

Note: Other Canvas operations are not allowed during the Slice Cre-
ator mode. You can only create slices.

A Select the Slice Creator icon. Slice 
Creator cursor appears as a (+) plus 
sign. At this point, manually slice each 
desired area by clicking and dragging 
your mouse over the image. 
B The Slice box contains a yellow 
transparent fill and has a red outline.

To slice an image

1 Click on the Slice Creator icon.

Note: The cursor turns into a (+) sign when 
the Slice Creator function is active. 

2 Then, click-and-drag over the section of the 
image to be sliced.

Each yellow-shaded box represents a sliced 
area.
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Using the Slice Selector 
Once you have sliced the image, you may need to edit and move it. 
To do this, select the Slice Selector tool (A).

The Slice Selector tool allows you to select, move, resize, copy, or 
delete the slice. You also have the option to both Undo and Redo 
any of the previously mentioned procedures. 

Note: Slices can’t be rotated or skewed. Additional slice-related com-
mands are available through a context menu (see “Slice operations 
context menu” on page 36.16). 

To view slice properties
1 Select the slice with the Slice Selector tool.

2 Right-click (Windows) or Control-click (Mac) to open the con-
text menu.

3 Select Properties to open the dialog box.

Note: Certain slice properties are available in the Properties bar 
when a slice is selected. 
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Slice operations context menu
The context menu can only be accessed if the Slice Selector tool is 
selected. Some of the commands are available only if they are rele-
vant to the context of the current situation.

Slice Properties
A Change slice’s index to - change 
the index of any selected slice. This 
function could be necessary if the index 
is part of the slice’s name when using ei-
ther the ‘#’ or ‘&’ formatting symbol. It is 
available only if one slice has been se-
lected.

First select the Change slices index to 
box. Enter either a number or choose 
one of the existing indices available in 
the menu.

B Naming

Slice name - Enter the name of the 
slice or choose one of the values from 
the menu. [current] indicates that the 
name won’t be changed. [default] 
means the default name is used. [doc-
ument] is the current document’s 
name. This keyword can be combined 
with the [page] keyword and with (&) 
or (#) formatting marks or with other 
text. Names like [docu-
ment]_[page]_slice_## are legal and 
may be used. [page] represents the 
current page name. This keyword can 
be combined with the [document] key-
word and with (&) or (#) formatting 
marks.

# denotes the index of the slice. By 
using this setting, the index will be for-
matted as a number. More than one of 
these marks may be used; e.g., if you 
type “Image_###” and the index of the 
image is 7, then the name of the image 
would be “Image_007.” Otherwise, if 
only one mark is used, then the name 
would be “Image_7.” This mark (or a 
set of them) can be used only once in 
the name and it is mutually exclusive 
when using the (&) as a formatting 
mark.

& represents the index of the slice, 
but it is formatted as a letter. More 
than one of these marks may be used 
to format a text designation that con-
tains more than one letter; e.g., if you 
type “Image_&&&” and the index of 
the image is 7, then the name of the 
image is “Image_aag.” Otherwise, if 
only one mark is used, then the name 
would be “Image_g.” This mark (or a 
set of them) can be used only once in 
the name and it is mutually exclusive 
when using the (#) as a formatting 
mark.

Note: If more than one slice is select-
ed, then a name with either (#) or (&) 
formatting mark is required since 
each slice must have a unique name.

Use ASCII characters only and ensure 
that the name doesn’t contain a space 
between the characters. 

Alt text - assigned alternative text 
won’t take effect until it is exported to 
HTML. Some browsers display alter-
native text by default while the image 
is being downloaded. Alt text may have 
up to 64 characters and does not have 
to be in ASCII format. 

Image title - A title will take effect only 
if it is exported to HTML. By default, a 
browser will display the title as either a 
tool tip or on the status bar when you 
move the cursor above the image. The 
image title message may contain up to 
64 characters. These characters do not 
necessarily need to be in ASCII format. 

C Image Options

Setting mode

Default options - The slice(s) will share 
the Slicer’s default setting. 

Optimized - When checked, the stan-
dard dialog for image optimization will 
show up. You can set any combination 
of image parameters. After you close 
the dialog, a summary of the settings 
will be displayed along with a small 
button. Clicking the button will reopen 
the optimizing dialog. For more infor-
mation on how to optimize an image’s 
parameters, see “Saving Web graphics 
(GIF/JPEG)” on page 14.15.

Note: Although it is possible to select a 
transparent color (or colors) when 
optimizing GIFs, such settings will be 
lost after returning to the Slice Prefer-
ences dialog.

Simple setting - Using this mode, you 
can choose the desired options for 
anti-aliasing, image format, and JPEG 
output quality. 

Anti-aliasing, Image format and JPEG 
quality image options are the same as 
the ones that appear in “HTML 
options” on page 36.26.
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• To open the slice operations context menu: Right-click (Win-
dows) or Control-click (Mac) the Slice Selector tool on a slice.

Select this slice selects the slice at the cursor’s current position.

Deselect this slice Deselects a slice if it is the only one selected.

Remove from selection Removes the slice at the cursor position 
from the selection set.

Select/Deselect all slices Selects or deselects all slice objects.

Delete slice(s) Deletes all currently selected slices.

Divide slice Allows you to divide a slice horizontally and/or verti-
cally into smaller slices. When choosing this command, the Slice 
divider dialog box appears with two options: 

Split slice Splits all selected slices that are overlapped by other 
slices. Slices are sliced along the soft slice-lines. This operation sepa-
rates the image into individual slices. These slices will have the par-
ent slice’s parameters by default, but the parameters can be 
modified. 

Export slice Exports slices as images. It can also create an HTML 
file with a table that will contain all of your image slices (see 
“Exporting Slices” on page 36.17).

Arrangement commands Will arrange selected slices in a certain 
order: Shuffle Up, Shuffle Down, Bring to Front, Bring to Back (see 
“Arranging objects in the stacking order” on page 17.21).

Exporting Slices
Once you have finished slicing your work, you can export the 
images (GIFs or JPEGs). You can also create an HTML file with a 
table that contains all of the images. The options to perform these 
functions are available in the Slicer Export Options dialog box. 

Slice divider dialog box
• Horizontally - specifies how many 
horizontal portions in which the slice will 
be divided. To prevent horizontal division 
of the slice, a value of 1 can be specified.
• Vertically - specifies how many verti-
cal portions in which the slice will be 

divided. To prevent vertical division of the 
slice, a value of 1 can be specified. 

Note: Using this method, a slice that over-
laps another slice cannot be divided.
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Assigning URLs to slices
Selected individual slices or groups of slices can be assigned a URL 
by using the Link Manager palette. Choose Object > Options > 
Link Manager to open the palette. The process is the same as 
assigning a URL to an ordinary object; however, the slice or slices 
must be selected with the Slice Selector (see “Using the Link Man-
ager palette” on page 36.2).

Using Web buttons
If you plan to export your Canvas document to the Web, you may 
want to add some interactive elements such as Dynamic Web but-
tons. Web buttons can lead visitors to another page within a site or 
link to a different URL altogether.

The Web Button tool opens the Web Buttons palette and places 
buttons in documents. 

Slicer Export Options

To open this dialog box, select Export 
Slices from the Slice Operations 
menu.

A Replace existing images - Select-
ing this item automatically replaces ex-
isting images that have the same file 
name and location. If deselected, a dia-
log box will warn you when a slice is 
about to be replaced.
B HTML Export options creates an 
HTML file that will contain the images 
to be exported. The file will contain one 
table that will link with all of the images. 
These settings can affect how the 
HTML table will be designed.

Render empty slices If checked, all 
empty spaces (within the rectangle 
that determines the boundary of all of 
the selected slices) will be rendered. If 
not checked, the cell in the table will 
appear to be empty. For rendering the 
empty slices, default image options 
will be used.

Use spacing GIFs - When working 
with complex tables, it may be neces-
sary to use a one-pixel wide transpar-
ent GIF image as a spacer. These 

spacers force a Web browser to accu-
rately display a complex HTML table. 
Choose a predefined name or enter 
your own spacer name with only 
HTML-safe characters.

Images to subfolder allows you to 
name a subfolder to which all images 
will be exported. If not checked, then 
images will be created in the same 
folder where the HTML file is being 
exported. The name of the subfolder 
should contain HTML-safe characters 
only.

Text encoding - If activated, all text 
(i.e., alternative texts and image titles) 
will be encoded using the specified 
encoding. Also, the information about 
which encoding is used will be 
declared in the HTML file’s header. 
Western (ISO) is best used for the 
western Latin alphabet. Unicode 
(UTF-8) is best used for other alpha-
bets (central European, Cyrillic, Asian) 
or mixed alphabets.

If no encoding is required, then all of 
the text is exported as is. Only invalid 
characters are encoded so that the 
HTML output will always be valid. 

C Force default image options - If this 
option is turned on, then the individual 
image parameters will be overwritten 
by the Slicer’s default options. This im-
age setting is temporary and will not af-
fect parameters of individual slices. 

See “HTML options” on page 36.26 
for the image options, which are 
Image format, JPEG quality, and Anti-
aliasing.
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Understanding the button states
These buttons are called dynamic because they change their behav-
ior, or state, according to the user’s actions. Dynamic Web buttons 
have a total of 3 states:

When you create a button, you can use a separate object or image 
for each of the button’s states.

Note: All vector or text objects to be used as Web buttons must have 
a pen ink and fill ink. Objects that have the pen and fill inks set to 
“none” can’t be dragged into the Web Buttons palette. 

State Explanation Example

Up This is the default, or normal, state of the button. The mouse is not 
over the button area.

Over This is the state when the mouse is moved over the button area.

Down This is the state when the mouse clicks the button area.

Tip
Dynamic Web buttons may also 
be referred to as rollovers.
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To test Web buttons
Before storing a new button, test it in the Web Buttons palette (see 
“Web Buttons palette” on page 36.20). As indicated previously, the 
Up state is the default state (see “Understanding the button states” 
on page 36.19). Move the cursor over the Preview box to see the 
Over state and then click to see the Down state.

If you’ve already placed the Web button but want to see their 
appearance before exporting to HTML, use the Play feature on the 
Web Buttons palette.

Click the Start Play Mode button and the placed Web buttons go 
into play mode. Move the cursor over the buttons and click them to 
see the 3 states. When you finish, click End Play Mode.

Web Buttons palette

Double-click the Web Button tool to 
open the Web Buttons palette.

A Button state boxes - Drag the imag-
es, text objects, or vector objects into 
each state’s respective box. 

Remember that the Up state is the 
default state.

B Preview box - If you’ve defined all 3 
states, you’ll see the Over state when the 
mouse passes over the box. Click the 
mouse on the box to see the Down state.
C Storage box - Drag the defined but-
ton from the Preview box to this box (see 
“To store a Web button” on 
page 36.20).

D Web Buttons palette menu - Open 
this menu to load, append, save, or clear 
buttons (see “Saving and clearing Web 
buttons” on page 36.21 and “Loading 
and appending Web buttons” on 
page 36.21).

To create a Web button

Note: You can drag objects into the 
boxes in any order.

1 Drag the object for the Up state into 
the Up box.

2 Drag the object for the Over state 
into the Over box.

3 Drag the object for the Down state 
into the Down box.

To store a Web button

Drag the completed button from the 
Preview box to the Storage box.

To delete a Web button

Drag the button you want to delete to 
the trash can icon in the palette.

To modify a Web button’s 
state(s)

Note: You can’t edit a button’s 
attributes, such as pen ink, fill ink, and 
stroke.

Drag the object from the Up, Over, or 
Down box into the document. Modify 
the object and drag it back into its 
respective box. Store the updated but-
ton and place a copy in your docu-
ment.

Tip
Don’t work in Canvas while play 
mode is active. Click End Play 
Mode before starting other work.
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To place Web buttons in a document
Use this procedure to place Web buttons in a Canvas document. 

1 In the Storage box, select the button that you want to place. 
The selected button appears in the Preview box. 

2 Move the cursor into the document area. The cursor changes 
to a placement icon.

3 Do one of the following to place the button:

• Click to place the button. 

• To scale the button, drag to create a bounding rectangle.

Note: When the Web Buttons palette is closed, you can use the Web 
Button tool to place the last selected button.

To place additional Web buttons To place copies of the same but-
ton, use the Web button tool again or select the first button and 
choose Edit > Duplicate to create duplicates.

To resize Web buttons Select the placed Web button and drag a 
handle to resize its bounding rectangle. 

To attach a URL to a Web button Use the Link Manager palette to 
link buttons to other HTML files or URLs (see “Using the Link 
Manager palette” on page 36.2).

Saving and clearing Web buttons
When you save a Web button in the palette, it’s available in all Can-
vas documents.

To save buttons
In the palette’s menu, choose Save Buttons. Select a directory in 
which to save the file. Enter a name for the file and click Save.

Note: Web button files can be used on both Windows and Mac.

• To remove all buttons from the Web Buttons palette: Choose 
Clear Buttons from the palette’s pop-up menu.

Loading and appending Web buttons
When you load a Web button file, the buttons currently in the pal-
ette are replaced by the button file. If you don’t want to lose the cur-
rent buttons, you should save the current buttons in a button file 
(see “To save buttons” on page 36.21).

Tip
If you want to place multiple cop-
ies of the same button, use this 
procedure once, and then see “To 
place additional Web buttons” on 
page 36.21.

Tip
Save the Web buttons on the net-
work so your co-workers can use 
them as well.
Using Web buttons 36.21



36
When you append a button file, the current buttons are not 
replaced. Instead, the buttons in the file are added to the end of the 
palette.

• To replace all buttons in the palette with those in a button file:

Choose Load Buttons in the menu. Select a button file and click 
Open. 

• To add buttons to the palette: Choose Append Buttons from 
the menu. Select a button file and click Open.

Working with animated GIFs 
Animations are an attractive visual element that can be added to a 
Web site. Canvas’ flexibility allows you to both create animated 
GIFs and place animated GIF files that were previously created. 

Placing animations
Use the Animated GIF tool to insert animated GIF files in your 
Canvas documents. When you finally export your document to 
HTML format, animations are exported and appear on the Web 
page.

To place an animation
1 Select the Animated GIF tool, which is in the Object Tools 
palette.

2 Click in the document where you want to place an animation.

3 A directory dialog box appears. Select the animated GIF file 
and click Open. Canvas inserts the file as an animation object.

• To preview an animation: Double-click the animation object 
after placing it within the document. 

You can select, move, cut, copy, duplicate, rotate, and flip animated 
GIFs that you insert in your document. 

Creating animations
Create animated GIFs in Canvas by assembling images within an 
Animation document and then saving the file as an animated GIF. 
This animation format is extremely popular among Web designers 
since it is supported by nearly all Web browsers. 

Tip
Effects like Envelope and Extrude 
cannot be applied to placed ani-
mated GIFs. Scale and Shadow 
effects only affect the bounding 
box, not the objects in the anima-
tion.
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Animation documents consist of a series of frames, with each frame 
being a still image. Displaying frames in quick succession creates 
the illusion of motion.

Use the Document Layout palette to arrange the frame sequence 
and set their individual duration (see “Using the Document Layout 
palette” on page 12.2).

Exporting an Animated GIF
Once you’ve created your animation, it is time to export it as an ani-
mated GIF. 

To save as animated GIF
1 Choose File > Save As.

2 Select GIF Animated as the file type. 

3 Enter a name for the file.

4 Click Save. The Animated GIF Options dialog box opens.

Tip
The more frames per second (fps), 
the smoother the motion appears. 

All about onion skinning

In Animation documents, you can dis-
play more than one frame at a time. 
Onion skinning is the term for display-
ing multiple frames as if they are on 
tracing paper. Onion-skinning is useful 
for positioning objects across frames 
of an animation.

The onion-skinning icon is located on 
the Document Layout palette (see 
“Using the Document Layout palette” 
on page 12.2). Click this icon to open 
the menu. 

No Onion Skinning - Choose this 
option to show just the current frame.

Next Frame displays the current frame 
and the frame after the current frame.

Previous Frame displays the current 
frame and the frame before the cur-
rent frame.

Next & Previous displays the current 
frame and one frame before and after 
the current frame. 

Custom - Choose this option to dis-
play any number of frames adjacent to 
the current frame. Enter the number of 
frames to display.

When onion-skinning is active, names 
of the displayed frames are tinted in 
the layout list.

Onion-skinning icon

Tip
You should save your file first in 
Canvas format (.CVX).
Working with animated GIFs 36.23



36
Editing animations
Use the Open command to import an animated GIF file for editing. 
You can edit the frames and then export the file again as an ani-
mated GIF.

To import animated GIFs
1 Choose File > Open. 

2 Select the animated GIF file and click Open. A dialog box 
appears. 

3 Enter the first and last frames to import. 

4 Click OK to import the frames into a new Animation docu-
ment.

Animated GIF Options

When you choose animated GIF as 
the file format, this dialog box opens.

A Transparent Background — 
Makes the background transparent.
B Auto Crop — Optimizes the size of 
each frame and the document. The 
Auto Crop feature will create the mini-
mum size needed to accommodate all 
of the objects in the document. 
C Interlaced — The image will load 
into a browser a little bit at a time. Acti-
vating this feature creates the effect of 
improving an image over a slow con-
nection. 
D Anti-aliasing — Objects from the 
Canvas document will be rendered with 
an overall softened effect.
E Individual Palette Per Frame — If 
selected, each GIF frame will contain its 
own palette. This will create a larger 
GIF image; however, this setting is sug-
gested if you are creating complex and 
colorful animations. If this option is not 
checked, then all frames will have a 

common palette. The color palette 
maximum is 256 colors.
F Erase Previous Frame — Each 
frame will be erased and the area will 
be restored to the background before 
the next frame is displayed during play-
back.
G Optimize frames — This feature 
minimizes the size of a file that will be 
created. We recommend this setting if 
you are working with colorful GIFs or 
pictures. The Optimize frame setting 
has no effect on simple graphics, like 
rectangles, ovals etc.
H Differential frames — This option 
searches for the smallest frame possi-
ble in the set that contains all of the 
changes from a previous frame. After 
the search, it creates a new rectangle 
which becomes the new frame. Note: If 
the option “Erase Previous Frame” is 
checked, then this particular option will 
be unavailable. For more information 
on using animated GIF options, see 
“Working with animated GIFs” on 
page 36.22.

I Infinite Loop — Activating this op-
tion will cause your animation to run 
(loop) continuously. 

Note: You may specify the number of 
times that your animation will run. To 
do this, simply enter the number of 
times to “loop” your animation in the 
Times box.
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Creating Web pages from Canvas documents
Any document that you create in Canvas can be exported for the 
Web in a matter of seconds. To export a document as one or more 
Web pages, save the document in HTML format.

Canvas does not support opening and editing of HTML Web 
pages; therefore, always save your documents in Canvas format 
(.CVX) before you export Web pages. Saving in Canvas format 
means you can edit the original and export again in HTML. 

To save a document in HTML format
1 Open the Canvas document that you want to save as one or 
more Web pages, and then choose File > Save As.

2 In the directory dialog box, select HTML file format. 

3 Select a location to save the files, enter a file name, and click 
Save. The HTML Options dialog box opens. 

4 Select options for saving the Web pages (see “HTML 
options” on page 36.26). 

5 Click OK to save them.
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HTML options 
A General options

Create new folder - organizes files for a 
Web page by placing them in a new 
folder in the specified location. The 
name that you enter when you are sav-
ing a Web page is used for the folder’s 
name.

Put images in subfolder - creates a 
subfolder for the image files . 

Separate pages - available for multi-
page Canvas documents; creates a 
Web page from each page. Page 
names will become the file names. If 
you do not select this option, then 
Canvas exports all pages as one HTML 
file.

Generate navigation file - if you select 
Separate pages, you may wish to acti-
vate this option; generates navigation 
aids placed on the top and left side of 
each Web page. These links are creat-
ed from the index name of each Web 
page.

Use external style - Select this option 
to create an external style sheet for 
Web pages that you are saving. An 
external style sheet can make it easier 
to edit styles manually and can also 
reduce the size of individual HTML 
files because the complete style infor-
mation is not included in each Web 
page file. 

Note: Not available if Table Layout is 
active since Table Layout doesn’t use 
global CSS definition.

B File format - Two types available: 
HTML 4 and XHTML, with only a few 
differences between them. XHTML doc-
uments differ in the document’s header 
and have some additional tags in the 
data stream (such as end-tags for image 
objects).
C Layout mode - Three modes are 
available for both file formats.
• CSS2 (Cascading Style Sheet) - 
Graphics and text objects will be posi-
tioned using the “absolute position” 
property (defined by the CSS2 specifi-

cation). In this mode, objects can over-
lap each other without the need for 
you to render them. Some browsers 
have problems dealing with CSS2 for-
mat. Only Internet Explorer 4.x + (as 
well as AOL 4+) and Netscape Naviga-
tor 6.x can support CSS2 layout with-
out problems. 
• Table Layout - Allows all Canvas 
objects to be organized into cells of an 
HTML table. All overlapping objects 
are rendered and exported as bitmaps. 
Although table mode may produce less 
efficient HTML output, it is accepted 
by all major browsers. Note: CSS prop-
erties are also used in the Table Layout 
but only for text formatting not for 
positioning. 
• Table Layout Centered - HTML 
output is the same as the standard 
“Table Layout”; however, table is cen-
tered in a browser.
D Text options 

Render Text - Rendering converts text 
objects to images to ensure that text 
appears the same on the Web. Ren-
dered text can’t be selected as text on 
a Web page. 

• Automatically - Canvas decides 
when to render text. 
• Always. 
• Never- preserve all text as text 
objects.
E Image Options

Image Format 

• Automatic — Canvas chooses the 
file format for images (see “How imag-
es are handled” on page 36.27). 
• JPEG or GIF — Select either 
option to save all images in one format 
or the other.

JPEG Quality - Four JPEG quality levels 
are available:

• Best - least compression (100% 
quality). 
• Fine - 90% quality. 
• Good - 75% quality. 
• Draft - most compression (50% 
quality).

Anti-aliasing - Smoothes the edges of 
rendered vector objects and text 
objects.

• Finest uses up to 256 shades 
between each pair of colors. Images 
with more than 256 colors should be 
saved in JPEG format to preserve the 
full range of shades. If necessary, Can-
vas uses JPEG format if you select the 
Automatic Image Format option.
• Fine option uses 64 shades per 
pair of colors. Medium uses 16 shades 
per color pair. Coarse uses four shades 
per color pair. 
• None - no anti-aliasing.
F Select Save this setting as default to 
save the current settings in the dialog 
box for all documents. Otherwise, Can-
vas saves the settings for the current 
document only.
G Default - If you have never selected 
the save settings option, clicking Default 
will switch the dialog box settings to the 
Canvas default.
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Metatags
When Canvas creates an HTML file from a document, it uses 
metatags in the HTML file header to include data entered in the 
document Properties dialog box. This data includes information 
such as Title, Subject Keywords, Author, and Category from the 
fields on the Summary tab in the Document Properties dialog box. 

• To add metatags to a document: Choose File > Properties and 
click the Summary tab. Enter any keywords in the fields.

How images are handled
Canvas uses compression and color reduction to optimize images 
for faster display on Web pages. All graphic objects are exported as 
RGB images in GIF or JPEG format. You can choose the image for-
mat or allow Canvas to decide this option for you (see “Image 
Options” on page 36.26). 

When you select Automatic from the Image format menu, Canvas 
exports RGB Color and CMYK Color images as RGB (24-bit) 
images using JPEG compression. Indexed mode images, which use 
a maximum of 8 bits of color information per pixel, are exported in 
GIF format. Black and White images are exported as Indexed 
images (8-bit). Canvas exports Grayscale images as Indexed images 
(8-bit) or JPEG-compressed RGB images, using the format that it 
determines will produce the best results.

How slices are exported
If slices are available in the Canvas document at the time of HTML 
export, then Canvas will design the document layout to conform to 
the slices. Canvas will also accept an individual slice’s setting when 
it renders and names the images (see “Exporting Slices” on 
page 36.17 and “Slicer Export Options” on page 36.18). 

Note: Slices are used only when Table Layout is activated.

How animated GIFs and Web buttons are handled
When exporting animated GIFs, one GIF file will be produced for 
each animated GIF. 

Regarding Web buttons, one image for each Web button’s state will 
be exported. This group of images will be linked together using 
Java scripting. 
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You cannot overlap these objects in Table Layout mode. If that 
happens, then an Animated GIF or Web button will be rendered 
and exported as a simple image. You can overlap the objects in CSS 
Layout mode only.

EXIF extension (JPEG)
EXIF is the abbreviation for Exchangeable Image File, a format 
that is a standard for storing interchange information in digital 
images using JPEG compression. Almost all new digital cameras 
use the EXIF annotation, storing information on the image such as 
shutter speed, exposure compensation, F number, what metering 
system was used, if a flash was used, ISO number, date and time 
the image was taken, whitebalance, auxiliary lenses that were used, 
and resolution. 

Canvas allows digital photographers quick and easy access to most 
of the information that is attached to these images. After being 
imported into Canvas, the attached data may be viewed by choos-
ing Image > DCS information (EXIF). This command is disabled if 
the image does not contain EXIF data.

You can also view the EXIF data via a context menu. Select the 
image and right-click (Windows) or Control-click (Mac) to open the 
menu. This command will not appear if the JPEG file does not con-
tain EXIF data.

Note: An option to include or remove EXIF data when exporting 
JPEG images has also been included in the Export Preview.
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Exporting as a Flash file
Canvas now provides compatibility for designing Web content to 
be used in a Flash®-enabled Web site. As a result, all Canvas docu-
ments can be saved in the .SWF format.

After completing your document, choose File > Save As. In the 
Save As dialog box, select the Macromedia Flash (.SWF) option. 
Click the Save button and the Flash Options dialog box opens. 

The EXIF option is available from the Export Preview window. If an image does not contain EXIF data, then the 
option is grayed out as shown in this example.
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Exporting as PDF
You can export Canvas documents to the Portable Document File 
(PDF) format. Canvas has the ability to embed Type1 fonts, True-
Type fonts, and halftone settings. A specific color mode is also 
available so that it may be applied to all PDF objects. Also, the 
whole file can be compressed by the PDF export filter. 

• To export to PDF: Choose File > Save As. Select PDF - Acro-
bat™ files as the format. Enter a name for the file and click Save. 
The PDF Options dialog box appears. 

Flash Options dialog box
A General options

Export mode - Choose between SWF 
Player or SWF Editor.

• SWF Player - Creates an .SWF 
file for use in Macromedia Flash play-
er or a Flash-enabled Web browser. 
• SWF Editor - Generates the .SWF 
file for import into Macromedia Flash.

Note: Exporting an .SWF file for use in 
an .SWF player doesn’t automatically 
mean that the file can’t be imported 
into a .SWF editor or vise-versa. How-
ever, to reduce possible problems, we 
suggest that you export your Canvas 
file using a mode that matches your 
specific Flash export needs.

Page export - This feature allows you 
to have the option to save a multipage 
document either as a single multi-
frame .SWF file or as a set of individu-
al .SWF files:

• File with Frames - enables a 
multi-page Canvas document to be 
exported as a single multiframe .SWF 
file.
• Individual Files - allows a multi-
page Canvas document to be export-

ed as separated SWF files. One will be 
created for each page in a Canvas 
document.

Accurate strokes - enables exporting 
graphics that contain either calligraph-
ic strokes or strokes that use texture, 
gradient, or hatch patterns. 

Note: This option may make the 
export process more time consuming.

B Image Options

This feature allows you to choose an 
image format that will be applied to 
the original Canvas file when exported 
as an .SWF file.

Image format 

• JPEG — produces well com-
pressed images. Loss of data may 
have an impact on image quality.
• LossLess — does not affect the 
quality, but the compression ratio is 
usually lower than using .JPEG.

JPEG quality - This option is only avail-
able if the lossy (JPEG) compression 
has been selected. Four JPEG quality 
levels are available: 

• Best - 100% of quality is pre-
served

• Fine - 90% of quality is preserved
• Good - 75% of quality is pre-
served
• Draft - 50% of quality is pre-
served

Best should be chosen if a detailed 
image is desired and file size is not a 
concern. Draft can be selected if you 
need a small file for transmission and 
image quality is not an issue. Usually 
the Fine quality option provides the 
optimal quality-to-size ratio.

C Save these settings as default. Se-
lect this option if you wish to save these 
settings as the default for all subsequent 
SWF files. 
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PDF Options

Use this dialog box to apply settings to 
your PDF file.

A General options
• Compress text and vectors - All 
vector graphics, including a stream of 
text data, is compressed when this 
option is activated.
• Apply 7-bit ASCII encoding - If 
activated, all binary data is filtered 
through an ASCII filter, which converts 
a file so it can pass through a data 
channel that supports 7-bit data only 
(e.g., e-mail servers). ASCII encoding 
increases data size to an approximate 
ratio of 5 to 4. 
• Embed font subsets - Subsets of 
all TrueType and PostScript (Type1) 
fonts are embedded if this option is 
checked. The creation of subsets 
means that only characters used in the 
document are embedded.

This setting ensures the safe electronic 
transfer of a document between differ-
ent platforms, machines, or offices; 
however, embedding the fonts could 
dramatically increase the size of the 
resulting PDF document.

• Optimize text output - Optimizes 
text and exports it in a compact 
stream. All individual characters are 
put together to form words and sen-
tences. If this option isn’t used, the text 
characters are exported as separate 
text objects with specific positions 
within a text stream. Non-optimized 
text produces larger PDF files; howev-
er, this choice may be desired if pre-
cise character positioning is needed; 
e.g., since PDF doesn’t support implicit 
font kerning, optimized PDF text may 
not accurately represent your Canvas 
document when the exported file is 
displayed as a PDF. The text lines of 
optimized text would loose implicit text 
kerning and appear slightly wider than 
normal. If your document contains 
right or fully justified paragraphs, then 
we suggest that text should be export-
ed as not-optimized.

• Convert all colors to - If activated, 
the color of all vector, text, and image 
objects is converted into either RGB or 
CMYK. If not selected, all objects 
retain their original color mode.
B Images - Set resolution, compres-
sion, and JPEG quality options of the 
PDF files prior to being exported.
• Resolution - Affects how bitmaps 
are rendered. Default settings are 
either 72 or 96 dpi. The chosen resolu-
tion is applied to all images. We rec-
ommend either 72 or 96 dpi for online 
documents. A document that is printed 
should have a resolution of 150 or 300 
dpi resolution. You may choose a high-
er value; however, resolutions higher 
than 300 dpi produce a large file size.
• Compression - Bitmaps are com-
pressed during export. Choose lossless 
(ZIP) or lossy (JPEG) compression. 
Lossless is appropriate for technical 
drawings, illustrations, or cartoons, 
while JPEG compression is best for 
photographs.

JPEG quality - Only active if the lossy 
(JPEG) compression has been select-
ed. Four quality levels are available: 
Best, Fine, Good, and Draft. These 
options are the same as the ones for 
Flash Export (see “Flash Options dia-
log box” on page 36.30). 

C Transparency - Render mode and 
Color mode dictate how colors of a 
transparent object are rendered. 

Render mode - Specify which area of a 
transparent object is rendered.

• Smallest area — Only objects that 
contain a transparency are rendered. 
This option can be safely used if there 
are objects using only one color space 
on the page. It can also be used if the 
transparent objects don’t interfere with 
other color objects.
• Complete area — Renders trans-
parent objects and all of the objects 
that touch them. We suggest this set-
ting when the transparent objects 
interfere with other non-transparent 
objects that use different color modes.

• Entire page — This setting renders 
the entire page if it contains any trans-
parent objects.

Color mode - This option specifies the 
color space that is used when render-
ing transparent areas. 

Note: This feature is not available if 
Convert all colors to is activated. If 
Convert all colors to is active, then the 
global color mode is used.

D Halftone settings - Select halftone 
information to store inside the PDF. If 
you don’t specify these settings, custom 
halftone information isn’t applied to a 
document. The halftone setting of the 
output device isn’t used when printing 
your PDF (see “Halftone settings” on 
page 36.32). 
E Save these settings as default - If 
selected, the settings will be the default 
settings for each new PDF. 

Click the Default button to restore the 
default settings file.
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Halftone settings
Note: Some output devices may override these settings with their 
own default settings. Contact the device’s manufacturer to learn 
how to disable this option for the device that you are using. Doing 
so will ensure that your custom PDF options are used.

Shape Specifies the shape of the halftone dots. Each shape is 
defined by a simple function as is described in the PDF (and Post-
Script) documentation.

LPI and Angle Specifies the halftone grid. Lines Per Inch (LPI) 
defines the density of the grid, while Angle defines orientation of 
the grid.

To export transition effects into a PDF
Canvas can embed presentation slide transition effects within PDF 
files. Since a one-to-one conversion between Canvas transition 
effects and those available within Acrobat don’t always exist, the 
export filter maps effects that don’t correlate directly as follows:

1 Effects that are the same or almost the same

2 Similar effects

Canvas Acrobat

NO DISSOLVE Replace (i.e. 'no effect')

SLIDES Wipe

VENETIAN BLINDS Blinds

HORIZON Split (horizontally)

DOORS Split (vertically)

SHRINK BOX Box (closing)

GROW BOX Box (opening)

DISSOLVE Dissolve

Canvas Acrobat

SWITCHER Wipe

STRETCH OUT Split (horizontally)

IRIS IN Box (closing)

Tip
See the Adobe® Acrobat® docu-
mentation for more information on 
Acrobat transition effects.
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3 Other effects

Timing
In Canvas, the duration of an effect can be set on a scale that goes 
from ‘min’ to ‘max’. That settings will be used in a PDF as a time 
that goes from 0.5 seconds up to 4.0 seconds.

Since there is no option for setting the length of time an individual 
slide will stay visible during a slide show, a default time of 15 sec-
onds will be used; i.e., if the user doesn’t go to the next slide, the 
next slide will come up automatically after 15 seconds.

To export hypertext links and URLs
The PDF Export filter now supports all links that have been set 
through the Link Manager (see “Using the Link Manager palette” 
on page 36.2). Links to individual pages of a multi-page document 
will result in the creation of hypertext links within the PDF. Links 
to external HTML or PDF files are also supported.

It should be noted that PDF supports rectangular (orthogonal) hot-
spots only; i.e., if a URL is assigned to a rotated text object, the 
bounding box of the text will be defined as the hot-spot area. This 
should not be a problem if there is just one such link on a page. 

IRIS OUT Box (opening)

CORNERS Box (opening)

JAIL BARS Blinds (vertical)

CHECKERS Glitter (0 degrees)

CASCADE Glitter (270 degrees)

CROSS CUT Glitter (315 degrees)

Canvas Acrobat

CLOCK Dissolve

BUBBLES Dissolve

SPEED BOX Dissolve

STAR BURST Dissolve

Canvas Acrobat
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However, be aware that if more than one rotated text (or other non- 
rectangular objects) with a URL are used on a page, their bounding 
boxes may intersect. This may cause links that are located beneath 
another’s bounding area to not work as expected.

Default bookmarks of a multi-page document
When exported, a document containing more than one page will 
link to each individual page of the document. Names of each page 
are used as titles for the bookmarks. Because they are exported as 
Unicode text each title may contain any letter that is supported by 
your current locale.

Using Multiple Master PostScript Fonts
The PDF Export filter can’t embed Multiple Master fonts. If a Mul-
tiple Master font is used in a document, the PDF filter exports all 
standard properties of the font; however, it will not embed the 
actual data of the font, regardless of the current setting in the PDF 
Export dialog box.
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37
PRESENTATIONS

You can create Canvas presentations or slide shows for use on both 
Mac OS and Windows platforms. 

Creating slide shows
When creating a presentation in Canvas for Mac, save the presenta-
tion document as a Canvas file (.CVX). You can then send the Can-
vas file to another Canvas user (either Mac or Windows), and they 
can open the file and view the presentation (see “Viewing slide 
shows,” page 37.5) within Canvas.

When creating a presentation in Canvas for Windows, you can save 
the presentation in two ways:

• Canvas file (.CVX): If you save it as a .CVX file, the presenta-
tion can be opened in Canvas on both platforms; i.e., Windows or 
Mac. 

• Canvas Slide Show (.EXE): An .EXE file is a self-running appli-
cation that can only be executed on a Windows platform. You don’t 
need Canvas to run this file (see “To play the slide show in Win-
dows (.EXE),” page 37.6). 

To create a slide show
1 Choose File > New and select Presentation as the Type of 
Document. 

2 Use the Document Layout palette to add slides, layers, and 
specify various options that affect how the slide show is played 
(see “Using the Document Layout palette,” page 12.2 and “Slide 
options,” page 37.4).

3 Open the Slide Show palette by choosing Layout > Slide 
Show (see “Slide Show palette” on page 37.2).

Tip
Remember to first save your pre-
sentation as a Canvas file so you 
can make changes to the original 
file and view the presentation on 
either platform.
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Slide Show palette
You’ll need to access the Slide Show palette if you want to build a 
slide show or view a slide show. Choose Layout > Slide Show to 
open the palette. This is a floating palette that can be kept open to 
create, configure, and play slide shows.

You can select the following options in the Slide Show palette:

Fit to screen Reduces or enlarges the document’s slides so they fit 
within the screen area of the system used to play the slide show. 
Canvas calculates a scaling factor based on the size of the system’s 
monitor and the resolution setting.

Loop Causes the slide show to play continuously until you inter-
rupt it. When Canvas reaches the end of the document, it begins 
the slide show from the first slide.

Show Pointer Displays a pointer on screen during playback. Select 
this option and then select the pointer from the pop-up menu. You 
can control the pointer with the mouse during the slide show, so 
you can indicate important items in the presentation.

Auto Play QuickTime movies (Mac only) Causes any QuickTime 
movie files that have been placed in the Presentation document to 
begin playing automatically. When a slide containing a movie is 
played, Canvas loads the movie and begins playing it if this option 
is selected. QuickTime is not currently supported in Canvas for 
Windows.

Advance Every _ Seconds Makes the slide show self-running by 
advancing from one slide to another after a specified interval, with-
out any intervention from the operator. Enter the number of sec-
onds in the text box. The exact timing between slides depends on 
the speed of the system used for playback and the complexity of the 
illustrations.

Progressive Build (Windows) The Progressive Build option in this 
palette will allow you to play a self-running slide show either layer 
by layer or slide by slide. While playing your self-running show, you 
also have the option to control the progression of each slide in the 
show. (see “To play the slide show in Windows (.EXE)” on 
page 37.6).

Anti-Aliased Play Quality Select this option to anti-alias (smooth) 
vector and text objects during playback. If you select “Vector Qual-
ity: Anti Aliased” in the Configuration Center, Canvas will anti-
alias objects in your documents except when playing slide shows.

Slide Show palette
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Build Slide Show (Windows) Opens the Save As dialog box. Enter 
the name of the document in the file name field. Ensure that the 
(.EXE) extension is kept.

Note: Another way to begin this process is to choose File > Save As. 
If you choose this method, then your presentation will use the 
options that have been set in the Slide Show palette.

Adding speaker notes
If you are presenting a slide show, speaker notes can help you 
remember important points of discussion. You can also create these 
notes for your audience. Each slide can have its own set of speaker 
notes.

Note: To view the speaker notes while showing the slide show, your 
presentation must be in .CVX format. You must also select Show 
Speaker Notes in the Slide Show palette.

To create speaker notes

1 Select the Speaker Notes tool. The cursor changes to a 
crosshair. 

2 Click the crosshair in the slide area. A Speaker Notes object 
appears with a gray circle that indicates that no notes have been 
entered.

3 Double-click on the Speaker Note graphic to open the 
Speaker Note dialog box. 

4 Enter the text in the dialog box and click OK when you have 
finished. The circle turns green indicating that the Speaker Note 
contains text.

Note: You can also enter text in the field that appears in the Proper-
ties bar when the Speaker Notes tool is selected. Click Create. The 
Speaker Notes object appears in the upper left corner of the layout 
area.

You can update or delete the text at any time by selecting the 
Speaker Notes object and updating the text in the field that appears 
in the Properties bar. Click in the layout area to deselect the 
Speaker Notes object. The text is updated. 

To play a slide show that contains speaker notes
1 Choose Layout > Slide Show to open the Slide Show palette.

Tip
The Build Slide Show option only 
applies to Canvas for Windows. 

Tip
To create a slide show and have 
access to the Slide Show palette, 
ensure that you select Presenta-
tion as the document type.

Tip
If you delete the Speaker Notes 
object, any text that it contains will 
be deleted.
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2 Deselect the Fit to screen checkbox. If this option is selected, 
the Speaker Notes will not be visible.

3 Click the Play button. The slide show appears on the left side 
of the screen and the Speaker Notes on the right side.

Displaying a slide show on two monitors
In order to use this function, you must have the necessary hardware 
to support two monitors. Refer to your system documentation.

If using two monitors, Canvas displays the slide show on the full 
screen of the primary monitor. The slide show and speaker notes 
are shown in normal view on the secondary monitor.

Note: If you do not know which monitor is primary and secondary, 
use the Display Options in the Control Panel (Windows) or System 
Preferences (Mac OS X). 

Slide options
In the Options dialog box, you can define slide properties such as 
names and transitions. To access the Options dialog box, open the 
Document Layout palette (Layout > Document Layout). Then open 
the palette menu and select Options. 

To set slide transitions
You can set transitions for the current slide or multiple slides. To 
apply a transition effect to multiple slides, select the slides in the 
Document Layout palette and open the Options dialog box as pre-
viously explained.

Document Layout palette menu

Transition Options dialog box
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1 To use a transition effect (such as Dissolve or Iris In), select 
Transition to next slide (A). If you do not select this option, the 
slides simply appear in sequence.

2 Select a transition effect in the pop-up menu (B). If there are 
options for the transition effect, the Options button (C) is avail-
able. Click the button to open the Transition Options dialog box.

3 In the Transition Options dialog box, drag the slider (E) to 
adjust the transition speed from Min (slowest) to Max (fastest). 
Select a Direction (F) (if available) and then click OK to return to 
the Options dialog box. 

4 To preview the transition effect, click Try (D).

5 Click OK in the Options dialog box to apply the settings to 
the selected slides.

6 Once you have finished setting your options, you are ready to 
save your presentation as either a Canvas file (.CVX) or Canvas 
Slide Show (.EXE). Choose File > Save As to open the Save As dia-
log box.

Viewing slide shows
Canvas Presentations that are saved as Canvas files (.CVX) can be 
viewed within Canvas on both Mac and Windows. When you play a 
Canvas Presentation, Canvas displays the document’s slides in 
order, using the specified transition timing and effects.

A presentation slide show can be set to automatic mode, in which 
the slide show plays once and stops or repeats continuously. Slide 
changes also can be controlled by an operator. Canvas can show 
slides using a time interval that you specify, or you can control the 

Transition Options dialog box

Tip
Remember to first save your pre-
sentation as a Canvas file so you 
can make changes to the original 
file and view the presentation on 
either platform.

A File Name field
B Slide Show .exe format
C Save button

Save As dialog box
Creating slide shows 37.5



37
pace by clicking the mouse to switch to the next slide whenever you 
are ready.

To play a slide show in Canvas (.CVX)
1 Choose File > Open and find the Canvas Presentation docu-
ment (.CVX).

2 Choose Layout > Slide Show to view the Slide Show palette.

3 Click Play on the palette. If “Advance Every _ Seconds” is 
selected, Canvas changes slides at the specified interval. Other-
wise, click to change slides. Ctrl-click to go back one slide.

4 To stop the slide show, press Esc (Mac) or right-click (Win-
dows).

Note: While playing a Slide Show within Canvas, you may view each 
layer in reverse order. To do this, you must press Ctrl+Shift and 
click the mouse. 

To play the slide show in Windows (.EXE)
If the slide show was created in Windows and saved as an .EXE file, 
you can view it as a self-running application on a Windows plat-
form. 

1 To run the program, locate the application (.EXE).

2 Then double-click the icon or right-click and select Open 
from the context menu. The slide show will open.

3 Now right-click (Windows) on the screen to access the Slide 
Player menu. This gives you various options for playing back your 
slide show using your mouse and keyboard.

Quit Exits the slide show.

Next Slide — Advances to the next slide.

Previous Slide Goes back one slide.

First Slide Goes to the beginning of the slide show.

Last Slide Goes to the end of the slide show.

Toggle Playing Alternates between playing the slide show or paus-
ing the slide show.

Toggle Full Screen Alternates between a full-screen presentation 
and a window-sized presentation. 

Slide show .exe icon

Slide Player menu

Tip
To view the slides in reverse order, 
Ctrl-click the mouse. To advance 
the viewing of the show, Alt-click 
the mouse.
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Slide Show menu bar
If you choose to view a window-sized presentation, at the top of the 
window is a menu bar that basically has the same functions as the 
Slide Player menu, except for the Slide Show Properties and 
Thumbnails option.

Click on the Slide Show Properties button to open the Slide Show 
Properties dialog box. Use these options to control how the slide 
show is presented.

Show controls Toggle Full Screen

Toggle Slide/ThumbnailsSlide Show Properties

Tip
If you want the slide show to loop 
while playing, you must select 
both Play in loop and Auto 
advance every _ sec and enter a 
number in the field. Otherwise, 
you’ll have to click the mouse to 
advance the slides.
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38
SEQUENCES

The Sequence feature allows you to build and efficiently maintain a 
complete library of your Canvas-created design effects. When you 
create a Sequence, you will record all of the operations that were 
used to build an object. Once the Sequence is recorded, you can 
then reproduce that object quickly and accurately at a later date by 
playing the Sequence.

What is a Sequence?
A Sequence consists of a group of Canvas operations, which can be 
easily applied to a selected object or group of objects. A Sequence is 
a very versatile and easy-to-use feature that allows you to 

• Record and reuse the process of creating a design effect.

• Apply a design effect to another object or group of objects.

• Save it as a separate file and then share it with co-workers.

• Selectively enable or disable any effect during playback.

• View or modify the process at anytime, even during play-
back.

• Precisely recreate a recorded object.

Sequences palette
To view the Sequences palette, choose Edit > Sequences.

This comprehensive and adjustable palette provides a tree view of 
all Sequence Sets and the individual Sequences that are available. 
Since the Sequence palette floats, you can place it anywhere on the 
screen or it may be docked in the Docking Bar. You can create an 
unlimited number of Sequences or Sequence Sets.

Sequences palette controls
The controls that are located at the bottom of the palette allow you 
to create, enhance, edit, record, or play a Sequence.

1 Create a new Sequence Set.

2 Create a new Sequence.

3 Start recording a Sequence.

Sequences palette controls

1 2 3 4 5 6
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4 Stop recording/playing a Sequence.

5 Play a Sequence.

6 Delete a Sequence.

Viewing Sequences
A Sequence or the contents of a Sequence Set may be viewed by 
clicking on the “+” that appears next to it. If you wish to select more 
than one Set or Sequence, then you may hold down the Shift key as 
you click on each item. You also have the option to hold down the 
Ctrl key and click to select the Sequence. 

Once the Sequence is open, you will see every command contained 
in that Sequence. Via the Sequences palette, any of these com-
mands may be enabled, disabled, rearranged, or deleted. Any 
change to a Sequence results in the creation of a different design 
effect.

You also have the freedom to change the settings in the dialog box 
as the various operations play. Any Canvas operation that has an 
associated dialog box may be set to display its dialog box while the 
Sequence is running. Selecting the User Interface checkbox (A) 
ensures that the dialog box displays during playback of the 
Sequence.

Options Column

The Options Column contains all 
of your Sequences and Sequence 
Sets.

Toggle Sequence 
on / off

Click to view user interface
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Sequence Set
A Sequence Set is similar to a file folder that may contain one or 
several Sequences. You can easily share your Sequence Sets and 
Sequences with co-workers.

To maintain a consistent look for an individual client, you may cre-
ate a number of specific Sequences. Once created, you may save 
these “client-specific” Sequences into a personalized Sequence Set.

Note: Canvas will remind you to save a new Sequence Set upon clos-
ing if the Set has not been previously saved.

A Sequence Set can be played back as well. Doing so will play each 
of the Sequences within the Set. The order in which all operations, 
sequences, and sets appear can be changed and rearranged. Simply 
select the Sequence Set, Sequence, or command and drag it to the 
desired location.

To create a sequence set
1 Click on the New Sequences Set button. The Sequence Set 
dialog box opens.

2 Enter a name in the Name field (A).

3 Click OK.

To create a new sequence
1 To create a new Sequence, click on the New Sequence but-
ton. The User Sequence Options dialog box opens.

2 Enter the name for the new Sequence (A).

3 Choose the Sequence Set in which you want to store this new 
Sequence from the Sequence menu (B).

4 Click OK.

Tip
A Sequence Set or Sequence can 
be renamed by double-clicking on 
the name. Enter the new name in 
the Name field.

New Sequences Set

Sequence name

Select Sequence Set
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Sequence Options menu
You will find the Sequence Options menu at the bottom right-hand 
corner of the Sequence palette. Click to view the pop-up menu. This 
will bring up the following options:

Play Options
This dialog box allows you to select one of three modes to use when 
playing a Sequence.

• No Feedback: plays the whole Sequence without refreshing the 
screen while playing. This mode is the default setting and allows for 
fastest operations; however, a single operation can’t be seen during 
play. Only the end result of the Sequence will be visible.

• Refresh After Sequence: “refreshes” the screen after each oper-
ation. This mode forces the redrawing of the screen, but all of the 
operations can be distinguished.

• Pause After Sequence: will pause the play of the Sequence for a 
selectable amount of seconds after each operation. This setting is 
very useful because it allows you to verify each step of a Sequence.

• Update Sequence Settings: permanently stores all changed val-
ues in a dialog box that is being applied in the Sequence. When 
unchecked, the changed value will apply only once.

Insert Stop
This option allows you to place a Stop command at any point in a 
Sequence. To place a Stop command in a Sequence, do the follow-
ing:

1 Open the Sequence and select the location where you wish to 
place the stop.

2 Open the Sequence Options menu and select Insert Stop.

3 A dialog box opens in which you can enter a text message. 
This short description will be displayed during play back.

This short description can help you organize your work. You may 
also check the With Continue box if you wish the Sequence to con-
tinue playing after the text box is displayed. Click Cancel to reject.

Insert Script
This option allows you to insert a script at any point in a sequence. 

Sequence Options menu

Tip
If the User Interface for the stop is 
activated, then a message box 
pops up with a pre-entered text 
message. You can choose to con-
tinue or to stop. A Stop with text 
can display messages as the 
Sequence plays back. A Stop with-
out text simply discontinues the 
Sequence.
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1 Open the Sequence and select the location where you wish to 
place the script.

2 Open the Sequence Options menu and select Insert Script.

3 Navigate to the folder that has the script. Mac OS uses Apple-
Script and Windows uses Visual Basic scripts. 

A Script Notes dialog box opens in which you can enter a text mes-
sage. This short description will be displayed during play back.

Info
You can attach a short text message to any Sequence.

Duplicate
This option will create a precise copy of any Sequence, Sequence 
set, or command. A duplicated Set appears at the bottom of the 
Sequences palette with the word “copy” inserted in the Sequence 
name. The duplicated Sequence or command appears after the 
original Sequence or command.

Save Sequences Set
This option allows you to save a selected Sequence Set to another 
location on your computer or network. This command can only be 
applied to one Sequence Set at a time. The Save Sequences Set 
command should also be performed if you have edited an existing 
Sequence within a Set. Each Sequence set file will be assigned a 
.CVA extension.

When quitting, Canvas will prompt you to save any new or modi-
fied Sequence Sets that have not already been saved.

Load Sequences Set
Saved Sequences can be installed for use in Canvas. These Sets 
may be your own or they can be Sets that are sent to you by other 
Canvas users.

Clear All
Clear All immediately erases all Sequence Sets and Sequences from 
the Sequences palette. Care should be exercised when using this 
command. If activated, you will need to use Load Sequences Set to 
reinstall your saved set.
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Using Sequences
The following demonstrates the use of the Gear Golden Sequence:

1 Choose Gear Golden (A) from the Sequence list in the 
Sequences palette.

2 Click on the plus icon to view or edit any of the commands 
that are contained within the Sequence.

Note: If you want to view the Sequences related dialog boxes, select 
the User Interface checkbox before playing the Sequence. When 
the User Interface is activated, you will have the ability to view and 
edit all of the commands that are applied to a Canvas object.

3 Select the object in the Canvas document to which you wish 
to apply the Sequence.

4 Once the object is selected, activate and apply the series of 
operations to the object by clicking once on the Play Sequence 
button (see “Sequences palette controls,” page 38.1).

The Sequence operation will now apply all of the commands that 
are contained in the Gear Golden Sequence to the object.

Recording the Sequence
All controls for recording, playing, and editing a Sequence can be 
located at the bottom of the Sequences palette (see “Sequences pal-
ette controls,” page 38.1).

Before Sequence After the Sequence is played
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You can record several different types of Sequences to perform 
many different tasks. As mentioned previously, you can create a 
Sequence that will apply a design effect or you can use the 
Sequence feature to create an object.

To record a Sequence
You need to first open the Sequences palette so that all controls are 
accessible. Decide where you wish the Sequence to be located and 
select the appropriate Sequence Set where the new Sequence will be 
stored. Remember that you may move the Sequence inside another 
Sequence Set after it’s recorded.

1 Click on the Create a New Sequence button (A).

2 Enter a name for the Sequence in the User Sequence Options 
dialog box (B). This Sequence will contain all of the commands 
that you record. Click OK in the User Sequence Options dialog 
box to accept your settings.

3 Select the object (C) and then click on the Record Sequence 
button (D) to begin recording the commands that you’ll use to cre-
ate the effect. If you want to create an object with a Sequence, 
ensure to click the Record Sequence button and then create the 
object so it’s included in the Sequence.

4 Click on the Stop Recording button (E) when you are fin-
ished.

5 The Sequence may be applied to other objects. To do so, 
select another object and then click the Play Sequence button (F).

Sequences can record the selection of objects with certain limita-
tions. Only the following types of objects can be selected and, there-
fore, included in the recording of a Sequence:

• objects which are created during the recording process.

• objects that are selected and defined via the Object Specs 
palette when the recording starts.

Note: When you create an object in Canvas, it will automatically be 
assigned a number by default; however, for the object to be 
included in a Sequence, you must define it with the Object Specs 
palette (see “Using the Object Specs palette,” page 17.32). Objects 
that do not follow these guidelines will not be included during the 
recording process.

Tip
Refer to the ReadMe file for a list 
of commands that can be record-
ed in a Sequence.

Before Sequence is applied

After Sequence is applied
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39
WRITING SCRIPTS FOR CANVAS

Canvas is now a scriptable application. Scripting gives you the abil-
ity to execute a wide range of functions outside of Canvas. Now you 
can create and edit a host of scripts that can save you time and 
money. Briefly, a script is a succession of commands that Canvas 
can execute automatically. The script can be simple and affect only 
a single item in a current document. It can also be very complex to 
the extent where it could affect all of your Canvas documents. 

For example, you can execute a script that will open Canvas and 
perform all the tasks needed to prepare a set of files for your service 
bureau.

What is Scripting?
Scripting is a programmable feature that can execute tasks that are 
too difficult or time consuming to do manually. 

Designers and technical illustrators can activate a script to automat-
ically create a complex piece of line art from a combination of other 
Canvas objects. Photographers can create a script to apply a specific 
imaging or resizing function to a set of images. An engineer can eas-
ily create a drawing of an often-used engine component by execut-
ing a script.

In short, any repetitive task is a good candidate to become a script-
able function. Once created, a script will perform any task without a 
need for you to intervene.

• Import a list of images into Canvas, change resolution, 
adjust size, and export each of them into an HTML docu-
ment to create a presentation.

• Automatically connect Canvas to other scriptable applica-
tions and exchange content.

• Download a file from Internet Explorer and automatically 
open it in Canvas.

• Prepare files for use by your service bureau.

• Search for and place images into a Canvas document.

• Perform operations while you are away from your desk or 
at home.
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Think of a script as an unpaid assistant that can be set to perform 
all of the boring, time-consuming tasks that normally you would 
have to do manually. Scripting will provide you with additional 
time and allow you to better manage your workflow. A script can 
execute a complex series of tasks in the background or while you 
are away from your office.

Writing Scripts
Scripts can be written using various applications. The choice of an 
editor will depend on the operating system that you're using. Apple-
Script should be used for the Mac OS while Visual Basic should be 
used for Windows. Although different in their functionality, these 
scripting systems are still very similar to one another. To start you 
off, we have created a few scripts that will work with Canvas. You 
can locate them by visiting: www.deneba.com.

Script System Requirements

Windows 2000/XP
To create a script for use in Windows, you will need access to an 
application that contains a Visual Basic editor. Microsoft Word, 
Excel, and Visio are examples of the more popular programs that 
support the Visual Basic for Applications (VBA) language and con-
tain a ready-to-use, built-in editor. As you gain more confidence and 
create more complex scripts, you will need a more robust develop-
ment environment. When your skills reach this level, you should 
move up to Microsoft Visual Basic as your primary development 
environment. This package will provide you with everything 
needed to quickly create and easily debug very complex scripts that 
will work with Canvas.  

Mac OS
AppleScript is required to create and edit scripts for Canvas (Mac 
OS). 

Scripting hierarchy
The scriptable functionality of Canvas is presented in a hierarchical 
structure as it is common for Automation on Windows. A similar 
hierarchy is used by Apple Computer’s AppleScript. The hierarchy 
is organized in a way that mirrors the layout of Canvas. Objects in 
the scripting hierarchy represent items of Canvas. The application 
object is on the highest level. Objects for open documents, which 
.2 WRITING SCRIPTS FOR CANVAS
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contain page objects, are below the application object. The page 
objects hold layer objects, which contain the drawing objects that 
are present in Canvas.

A script’s hierarchy is a snapshot of the current state of Canvas. 
Each object in the hierarchy provides a certain functionality of Can-
vas that is associated with a particular item. For example, the layer 
object has functionality for setting and retrieving its name, access-
ing the drawing objects that reside on it, retrieving the page object 
it resides on, etc. The user can use this functionality to control Can-
vas through a scripting language. For example, that user could go 
to the fifth layer and change its name. 

Methods and properties
Each object in the scripting hierarchy has properties and methods. 
A property represents a certain characteristic of the object and has 
a specific type; e.g., Integer or String). A property can be set by 
assigning it a value. It can also be accessed to check its current state; 
e.g., Width is a property of drawing objects. You can set it to 144 
pixels (all distances in scripting for Canvas are measured in pixels):

drawingObject.Width = 144

or you can check whether it is wider than 72 pixel:

if (drawingObject.Width > 72) Then

...

End If

Methods represent operations that can be performed with the 
object. They can have multiple parameters as input. In addition, 
methods can produce multiple output values. For example, moving 
a drawing object is an operation performed by the Move method. 
Move takes the x and y offsets as parameters. The following line 
moves a drawing object by 300 pixels over to the right and by 90 
pixels down:

drawingObject.Move 300, 90

Collections
Often a document contains multiple objects of the same type; e.g., a 
Document object contains multiple Page objects. In scripting, 
this relationship is expressed by a Collection object. A Col-
lection object has methods and properties that count the objects 
in the collection, add a new object or remove an object from the col-
lection, and access a specific object in the collection. 
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Collection objects are often named in the plural of the type of 
the objects that they hold. For example, a Document object con-
tains the Collection object Pages, which hold all the Page 
objects of the document.

Scripting for Windows

Creating a sample script in Visual Basic & VBScript
Scripts can be written in any language that supports scripting on 
Windows such as Visual Basic, VBScript, or JavaScript. This sec-
tion walks you through the creation of an example script in both 
Visual Basic and VBScript. To open and run the Visual Basic 
example, you need to have the Visual Basic development environ-
ment installed. The VBScript example is a plain text file and can be 
viewed in any editor. It executes on any Windows 2000 system that 
has the Windows Scripting Host (WSH) installed. The WSH is 
installed by default on any of these systems. We recommend read-
ing both sections even if you don’t have the Visual Basic environ-
ment since a lot of general issues are explained in them as well.

The example script has the function of downsampling all JPEG 
images in a chosen source folder to a resolution of 72 ppi and then 
saving them to a chosen destination folder. The script achieves this 
task by taking each of the JPEG images from the source folder. 
Next, it automatically opens Canvas, changes the resolution of the 
image to 72 ppi, and then saves it to the destination folder under a 
slightly different name. A person who has to perform this task 
would normally have to do all of those steps for each image manu-
ally; whereas, a script will perform this process automatically.

Scripting can perform complex functions without your personal supervision. Here we have created a script that will 
automatically convert high resolution images to a lower, web-friendly resolution. Next, it will then rename and save 
the resulting files in a different directory. 

High Resolution Images Low Resolution Images
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Visual Basic
The Visual Basic language version of the example script displays a 
window when it is run. In this window, the user can select a source 
and a destination folder from two directory list boxes and start the 
downsampling process by pressing a button. To view the Visual 
Basic language example script, start your Visual Basic application 
and open the VB project file from: ExampleScripts\Down-
sample\VB\dwnsmpl.vbp. 

To see the user interface, select the MainWin form of the project 
and choose Object from the View menu. To see the scripting code 
that is executed, choose Code from the View menu. The following 
sections describe how this script was created.

Setting up the project and laying out the user interface
The project is a Standard EXE project called “dwnsmpl.” It con-
tains one form with the name MainWin and caption “Downsam-
ple.” Added to the form are two frames named SrcFrm and 
DstFrm. Their captions are “Source” and “Destination” respec-
tively. These frames group together the user interface elements 
related to choosing the source and destination folders. To pick 
these folders, a drive list box and a directory list box are needed for 
each of them. These list boxes are called SrcDrv and SrcDir for 
the source and DstDrv and DstDir for the destination folder. 
The form also contains a command button that starts the process of 
downsampling the images. The name of the button is SampleBtn 
and its caption is “Downsample”.

Sample script done in Visual Basic. This script 
automatically converts all of the images in a se-
lected file from their present resolution to 72 
dpi.
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Type libraries
Visual Basic has to know about the type and properties of the 
objects that are used in the project. If this information is missing, 
then Visual Basic will not provide code. As a result, you will receive 
error messages that will notify you of unknown objects and types 
when the script is executed. 

Information about objects and types is provided in type libraries. 
The type library that provides the Canvas scripting functionality is 
called Canvas.tlb. It is installed in your Canvas folder. The Down-
sample script also uses objects from another type library that pro-
vides file system operations such as opening files and accessing 
folders. This type library is called Microsoft Scripting Runtime. 

Loading the two type libraries 
Choose References from the Project menu to access the two type 
libraries. In the pop-up dialog, scroll down to the Canvas 1.0 Type 
Library entry and place a check mark next to it. Do the same for 
the Microsoft Scripting Runtime entry.

Once a type library is loaded, it can be viewed with the Visual Basic 
Object Browser. Choose Object Browser from the View menu to 
activate it. In the list box at the top, you can choose which library 
you want to view. Select Canvas and make yourself familiar with its 
functionality.

Writing the script code
As explained in the previous section, the scripting functionality in 
Canvas is organized in a hierarchy that reflects the structure of 
Canvas itself (see “Scripting hierarchy,” page 39.2). The Appli-
cation object is at the top of the hierarchy. Scripts have to create 
a Canvas Application object in order to to access other parts of 
the hierarchy. In the Downsample script, you create the Canvas 
Application object when the script is started. First, define the 
global variable cvApp as Canvas.Application. In the proce-
dure Form_Load, you then create a new Canvas Application 
object and assign it to cvApp.

Dim cvApp As Canvas.Application

...

Private Sub Form_Load()

Set cvApp = New Canvas.Application

End Sub
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Creating a Canvas Application object starts Canvas in the 
background. In other words, the user interface will not be visible. 
Canvas is automatically shut down when the Application 
object reference in the script becomes invalid. In the Downsample 
script, the variable is globally accessible so it is valid until the script 
quits or Nothing is assigned to it. Next, you set cvApp to Noth-
ing in the Form_Unload procedure, which is executed when a 
script quits. It is good practice to assign Nothing to Applica-
tion object references. This ensures proper shutdown of the appli-
cation when the references become obsolete.

Private Sub Form_Unload(Cancel As Integer)

Set cvApp = Nothing

End Sub

Most operations of the Downsample script happen in the 
SampleBtn_Click procedure, which is executed when the 
“Downsample” button is pressed. First, set the mouse pointer to 
look like an hourglass. This will signal to the user that the script is 
busy. At the end of the procedure when the downsampling process 
is finished, the mouse pointer is reset to its default look.

Screen.MousePointer = vbHourglass

...

Screen.MousePointer = vbDefault

Next, create a new illustration document in Canvas. Remember 
that Canvas got started at the beginning of the script. A new docu-
ment can be created by calling the Add method of the Documents 
collection in the Canvas Application object. To create an illus-
tration document, the parameter of the Add method must be set to 
cvsIllustrationDocument. The result is a reference to the 
created Document object. You then assign the result to the vari-
able obj of type Canvas.Document for later use.

Set doc = cvApp.Document.Add

(cvsIllustrationDocument)

Now the script has to loop over all of the files that are in the 
selected source folder. The FileSystemObject object of the 
Microsoft Scripting Runtime type library provides functionality for 
file access. Next, you create a FileSystemObject object, loop 
over the files in the source folder, and store each File object in the 
srcFile variable.

Dim fso As New Scripting.FileSystemObject
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Dim srcFile As Scripting.File

...

For Each srcFile In fso.GetFolder(SrcDir-
Path).Files

...

Next

The GetFolder method of FileSystemObject returns a 
Folder object for the folder whose path is passed as a String 
parameter. The For Each loop takes one file after another from 
the Files collection of the Folder object and assigns that File 
object to the variable srcFile.

Now you need to check whether or not the current file is a JPEG 
file. This is done in a separate procedure that takes the file name as 
a parameter, converts it to uppercase, and then checks if the name 
contains the substring “.JPG”.

If the file is a JPEG file, then it is placed in the created illustration 
document. The Place method of the Document object takes the 
path of the file as a parameter and places it on the currently active 
layer of that document. The position of the placed file can option-
ally be specified as a parameter; however, the default position here 
of (0, 0) is sufficient. The result of the Place method is the draw-
ing object that Canvas created for the placed file. A reference to this 
DrawObject object is stored as Canvas.DrawObject.

Dim obj as Canvas.DrawObject

...

Set obj = doc.Place(srcFile.Path)

You then check to see whether the placed object is a CVImage 
object. If it is, then you keep a reference to it.

Dim img As Canvas.CVImage

...

Set img = obj.Image

One property of CVImage objects is their resolution. Accordingly 
you compare the value of the Resolution property to 72ppi. If it 
is larger, then you set it to 72ppi by calling the SetResolution 
method of the CVImage object. The second parameter of Set-
Resolution is set as False in order to keep the dimensions of 
the image fixed. Setting it to True would keep the file size of the 
image fixed and, therefore, change the dimensions of the image. 
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If (img.Resolution > 72) Then

img.SetResolution 72, False

...

End If

The modified images now have to be saved back to the destination 
folder. Enter the prefix “ds_” in front of the file name. “ds_” stands 
for downsampled. Appending the destination file name to the desti-
nation folder yields the full destination path, which is passed as the 
first parameter to the SaveAs method of the Document object. 
The second parameter indicates to save the image as a JPEG file.

dstPath = DstDir.Path + "\" + "ds_" + src-
File.Name

doc.SaveAs dstPath, cvsJPEGFormat

Before continuing to downsample the next file in the source folder, 
delete the CVImage object that just got downsampled.

obj.Delete

VBScript
Scripts written in VBScript are plain text files that can be viewed 
with any text editor. They can be executed on any Windows system 
that has the Windows Scripting Host (WSH) installed. The WSH is 
installed by default on Windows 98/NT 4 and later versions. 
VBScript files have the extension “.vbs”.

Executing a VBScript
To execute a VBScript script, you have three options:

1 Double-click on the VBScript file.

2 On the command line, type the full file path followed by the 
scripts command line parameters.

3 In the Windows Run dialog, type “cscript” with a space 
behind it followed by the full file path of the script and its com-
mand line parameters. CScript is a program that executes script-
ing files.

VBScript scripts can only have very simple dialogs as the user inter-
face. Since our example script needs the source and destination 
folders as input from the user, you have to supply them as com-
mand line arguments. The first argument specifies the source 
folder and the second argument specifies the destination folder for 
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the downsampled images. Since double-clicking on a scripting file 
does not support arguments, we have to use either option 2 or 
option 3 to execute the script.

To view the VBScript version of the Downsample script, open the 
file ExampleScripts\Downsample\VBScript\dwnsm-
ple.vbs. with any text editor. Let’s assume that you copied this 
script to the following location:

C:\VBScripts\dwnsmpl.vbs

Let’s further assume that you have some JPEG files at: 
C:\JPEGs\

Let’s also assume that the following destination folder exists:

C:\ds_JPEGs\

You can execute the script now in two ways:

• Open a Command Prompt window and type the line : 
C:> C:\VBScripts\dwnsmpl.vbs C:\JPEGs 
C:\ds_JPEGs

• Open the Windows Run dialog and type the following line: 
cscript C:\VBScripts\dwnsmpl.vbs 
C:\JPEGs C:\ds_JPEGs

Writing the script code
A major difference between VBScript and Visual Basic is that 
VBScript does not use types for variables. You can assign any kind 
of value to a variable. When an operation is performed on that vari-
able, the scripting environment checks whether or not the opera-
tion is allowed for the kind of data that the variable contains.

Another difference of Visual Basic is that type libraries are not 
accessible to VB Scripts. For example, the constant cvsIllus-
trationDocument represents 1 and cvsImage represents 8. 
VBScripts scripts have to use the pure values that these constants 
represent.

At the beginning of the Downsample script, some constants are 
defined to make the use of pure values more readable as below.

Const cvsIllustrationDocument = 1

Const cvsImage = 8

Const cvsJPEGFormat = 10
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The following are some examples of declarations for variables used 
in the script. Note that none of the declarations specify a type.

Dim args

Dim srcDir, dstDir, dstPath

Dim cvApp

Dim doc

Dim obj

Dim img

Dim fso

Dim srcFile

The next few lines access the arguments passed to the script. In this 
case, you check to see if exactly two arguments were supplied and if 
those arguments are strings. To do this, you need to use the first 
argument as the source directory and the second as the destination 
directory.

Set args = WScript.Arguments

If (args.Count = 2) Then

srcDir = args.Item(0)

dstDir = args.Item(1)

If (VarType(srcDir) = vbString And

VarType(dstDir) = vbString) Then

...

End If

End If

As explained for the Visual Basic version of the Downsample 
script, Canvas is started when a Canvas Application object is 
created. The CreateObject function is used in VBScript for cre-
ating objects. The type of the object is passed as a string parameter.

Set cvApp = CreateObject("Canvas.Application")

Now, you create a new illustration document in Canvas. This is 
exactly the same as in the VB example.

Set doc = cvApp.Documents.Add(cvsIllustra-
tionDocument)

For operations on files and folders, we have to create a FileSys-
temObject object and use its GetFolder method to access the 
files in the source directory. Each of the files is examined to see if it 
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is a JPEG file. The test condition for JPEG files is a “.JPG” exten-
sion. If the file name contains a “.JPG” substring, then we assume it 
is a JPEG file.

Set fso = CreateObject("Scripting.FileSystemOb-
ject")

For Each srcFile In fso.GetFolder(srcDir).Files

If (InStr(UCase(srcFile.Name), ".JPG")) Then

...

End If

Next

You need to place the JPEG file in the created illustration docu-
ment and obtain a reference to the resulting drawing object. If the 
drawing object is a CVImage object, then we get a reference to it.

Set obj = doc.Place(srcFile.Path)

If (obj.Type = cvsImage) Then

Set img = obj.Image

...

End If

Next, you call the Resolution property of the CVImage object 
to check whether or not the resolution of the image is higher than 
72ppi. If it is higher, then you use the SetResolution method to 
set it to 72 ppi.

If (img.Resolution > 72) Then

img.SetResolution 72, False

...

End If

The full destination file path is constructed from the destination 
directory and named with a “ds_” prefix. The SaveAs method call 
saves the downsampled image as a JPEG file to the destination file 
path.

dstPath = dstDir + "\" + "ds_" + srcFile.Name

doc.SaveAs dstPath, cvsJPEGFormat

Before continuing with the next file in the source folder, you have 
to delete the DrawObject object created by the Place operation.

obj.Delete
.12 WRITING SCRIPTS FOR CANVAS



After downsampling all of the files, you shut down Canvas by 
assigning Nothing to the object reference.

Install these scripts on your machine and take them for a test drive. 
You can learn more about scripts by visiting our Web site. Make 
sure that you visit frequently to obtain new scripts as they become 
available. 

Scripting for Mac

Creating an sample script in AppleScript
AppleScript for the Mac OS is required to create and edit scripts 
for Canvas for Mac OS. 

To demonstrate Canvas’ scripting abilities for Mac, a sample script 
entitled Downsample will be used. The sample script downsamples 
all high resolution images in a designated source folder to a resolu-
tion of 72 ppi and then saves them to a defined destination folder. 
For this example, two folders were created, Downsampling 1 and 
Downsampling 2. Downsampling 1 contains four images.

After you run the script, your folders should appear somewhat like 
the following graphic. 

Source folder with high 
resolution images

Destination folder with low 
resolution images
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Launching Script Editor
Locate the AppleScript folder and open Script Editor. Choose File 
> Open Script. Search for the Canvas folder and then the Scripts 
subfolder. Within the Scripts subfolder, open the script entitled 
Downsample. The script will appear in the bottom pane of the 
Script Editor.

The first line of the script indicates its purpose:

-- This script will downsample a file containing 
a high resolution image to 72.

In AppleScript, a command or a set of commands for a specific 
application begins with the word tell and ends with end tell. 

The first command launches Canvas and opens a new illustration 
file:

tell application "Canvas™"
make new document with properties {document 
type:illustration}
end tell

The next command launches Finder so you can select the source 
and destination folders. Also, the number of files in the source 
folder are counted:

tell application "Finder"
set myFolder to choose folder with prompt 
"Select source folder:"
set myResults to choose folder with prompt 
"Select destination folder:"
set nFiles to count folder myFolder each file
end tell

The following command begins with repeat since it is to be repeated 
on each file that is found in the source folder.

This command indicates that Canvas is to open each image file in 
the source folder, set the image resolution to 72 ppi, rename the 
file, and save it to the destination directory. 

repeat with i from 1 to nFiles
tell application "Finder"
set f to file i of myFolder
set fName to get name of f
end tell
tell application "Canvas™"
set obj to place (myFolder as string) & fName 
into document 1 at position {100, 100}

Scripts
folder

Canvas
folder
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set oType to get object type of obj
if oType = "Image" then
set img to convert obj to image
if get resolution of img > 72 then
set image resolution of img to 72 without pre-
serving data
save document 1 in (myResults as string) & "new_" 
& fName as jpeg with useSelection
end if
end if
delete obj
end tell
end repeat

To run the sample script
At the top of the Script Editor window are the control buttons used 
to execute or stop a script. To execute the downsample script, click 
Run. Click the Stop button to stop the script.

Note: If you click the Stop button before the script is finished, your 
results will be incomplete. 
Scripting for Mac 39.15





X
GIS MAPPING EDITION





Chapter

40
GIS POSITIONING

Canvas has various GIS-based tools and commands that allow you 
to open Shapefiles, import GeoTIFFs, or define a map projection 
area and then strategically move or position objects according to 
their latitude and longitude coordinates. 

What is GIS?
GIS, the abbreviation for Geographic Information System, can be 
used in a variety of fields such as engineering, resource manage-
ment, public utility management, business, town planning, etc.

You should become familiar with the following terminology:

Latitude The angular distance of a point on the earth's surface 
along a meridian north or south of the equator.

Longitude The angular distance of a point on the earth's surface 
east or west of an arbitrarily defined meridian, usually the Green-
wich meridian (Greenwich, England).

Projection A mathematical technique that converts and portrays 
features from a spherical surface onto a 2-D plane.

Graticule A grid of lines that display meridians of longitude and 
parallels of latitude.

GIS manager
If working with a file that has georeferencing information, such as 
Shapefiles, you will use the GIS manager. You can also use the GIS 
manager to establish georeferencing information for a new docu-
ment. You must use an Illustration document and select the GIS 
document checkbox.

• To open the GIS manager: Choose File > Configuration Center 
(Windows) or Canvas > Configuration Center (Mac). Open the 
General settings and select GIS.

Note: If you are opening a Shapefile or select the GIS document 
option, the GIS manager automatically opens before fully loading 
the file.
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Using the GIS palette
Perhaps you work in the oil industry and need to accurately plot the 
coordinates of existing wells on a map. You could then take this 
information and combine it with Canvas’ export capabilities to 
quickly create a presentation or publish it online in either PDF or 
HTML.

• To open the GIS palette: Choose Object > GIS Positioning.

GIS manager
A Document. This section contains 
the scaling information as well as the 
minimum/maximum latitude and longi-
tude.

Enter a scale or select the Auto check-
box. When you select Auto, you can 
enter the coordinates in the Min/Max 
fields. If you choose Auto, the scale will 
change automatically according to the 
information selected in the Coordi-
nate Reference System section. 

B Coordinate Reference System. In 
this section, select the Projected Coor-
dinate Reference System. Choose 
None, Predefined, or Custom. 

If you select None, the Map Projection 
and Geographic Coordinate Refer-
ence System sections are disabled.

When you select the Predefined radio 
button, the Projected Coordinate Ref-
erence Systems dialog box opens. 
Select an option from the list. The 
related property and parameter values 
are displayed on the right. Click OK.

C Map Projection. If you selected 
Custom for the CRS, you will have to 
choose a Map Projection. When you se-
lect the Predefined radio button, the Se-
lect Map Projection dialog box opens. 
Select one from the list. The related 
property and parameter values are dis-
played on the right. Click OK.

If you select Custom, click the Edit but-
ton to open the Map Projection dialog 
box. You can select a Map Projection 
and define its parameters.

D Geographic Coordinate Reference 
System. In this section, you can select 
the earth model and Angular units. The 
default earth model is WGS 1984.

To modify a predefined 
reference system

Click the Select button. When the Pro-
jected Coordinate Reference System 
dialog box opens, choose another 
Coordinated Reference System.

Click to expand the palette

Bounding box icon
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To configure the palette settings
Before using the GIS palette to place objects, you must first config-
ure the GIS settings and select a reference point.

1 Open the GIS palette menu. 

2 Select GIS Document Settings and the Configuration Center 
opens with the GIS manager shown (see “GIS manager,” 
page 40.1).

3 Open the palette menu again and select Choose Reference 
Point. A prompt appears when you move the cursor into the draw-
ing area.

4 Click the cursor to define the reference point. The GIS Refer-
ence Point dialog box opens with the X/Y fields as well as Lati-
tude/Longitude fields filled. 

Note: You can manually change the reference by selecting a handle 
in the bounding box icon. By default, the center anchor point is 
selected for the reference point. You can also enter values in the X/
Y and Latitude/Longitude fields.

5 Click OK.

Graticule settings

Open the palette menu and select Cre-
ate graticule.

Use the Graticule settings dialog box to 
create a grid of lines that display 
meridians of longitude and parallels of 
latitude.

The grid’s appearance is directly 
affected by the selected projection.

Latitude start/end. Enter the values 
that the parallels of latitude should 
span.

Longitude start/end. Enter the values 
that the meridians of longitude should 
span.

Spacing. Define the spacing between 
graticule lines. The latitude and longi-
tude spacing do not have to be the 
same.

Create on guide layer. Select this 
checkbox to place the Graticule on 
the guide layer.
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To position objects with the GIS palette
Before being able to strategically place objects, you must first con-
figure the GIS settings (see “To configure the palette settings,” 
page 40.3).

Note: For the objects, you can use Canvas’ tools to create them or 
import them with the Place or Import commands.

1 Select the object to be positioned. The object’s current coor-
dinates appear in the Latitude and Longitude fields at the top of 
the palette. 

Note: These coordinates are based on the object’s selected handle. 
By default, the center handle is the reference point when the object 
is first selected.

2 Select a handle in the bounding box icon and then enter the 
new latitude and longitude values. The object moves to the 
defined coordinates.

When expanded, the percentage of error is indicated at the bottom 
of the palette. The distortion percentage is calculated by comparing 
the document’s reference point (document center) to the world.

To manually position center reference point
1 Select the object and click once more. The object’s handles 
appear.

2 Notice that the center reference point contains a crosshair.

3 Move the cursor over the center reference point. The cursor 
changes to a crosshair. 

Bounding box 
icon

real-world 
distances

Positioning replicates 

If you have to create several 
replicates of an object and 

then place each of them according to 
their latitude and longitude, Canvas’ 
Replicate and Position abilities will be 
of benefit to you (see “Replicating & 
positioning,” page 17.18).

The GIS component of the Replicate 
and Position dialog box is enabled 

once you have configured the GIS set-
tings with the GIS manager (see “GIS 
manager,” page 40.1).

To use the Replicate and 
Position dialog box

1 Select the object to be replicated.

2 Choose Object > Replicate and Po-
sition.

3 Click the GIS radio button. 

4 Enter the latitude and longitude co-
ordinates for each replicate.

5 Click OK to create and position the 
replicates.

Selected handle 
indicated with a 
crosshair.
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4 Click the crosshair on the selected handle and move the han-
dle to another position. The object’s latitude and longitude 
update after you release the cursor.

Warping images
Canvas features new image effects that you can use to warp images.

Coordinates
With the Coordinates command, you can place control points 
within a selected image and warp it according to those points.

• To make the Coordinates controls appear in the Properties bar:

Select the image and then choose Image > Image Warp > Coordi-
nates. 

Free effect
With the Free command, you can georegister an image or drawing 
to the geographic location of a “known good” reference image. The 
image or drawing used as a reference is called the target. The image 
that you are adjusting to the target is called the source.

Note: If both selected objects are images, the first selected image is 
the source and the second image is the target. If you select one 
image and one vector object, the image is the source and the vector 
object is the target.

• To make the Free effect controls appear in the Properties bar:

Select two objects, one of which must be an image, and then choose 
Image > Image Warp > Free.

For GIS Coordinates 
option.

Coordinates controls

A click inside the image will add a con-
trol point; however, the point can be 
dragged outside the image. Press 
Delete key to remove selected 
point(s).

A Coordinates. Indicates the position 
of the defined control point.
B Coordinate system. Select either 
Document or GIS. Document uses an 
X/Y control point system and GIS refers 

to latitude and longitude. To use the 
GIS option, you must have the GIS 
Mapping Edition.
C Shuffle arrows. Click these arrows 
to select defined control points. Once a 
control point is selected, you can move 
it to another location.

D Fixed Frame. Select this checkbox 
to maintain the form of the bounding 
box. If this option is deselected, the 
bounding box is warped.
E Create. Click this button to per-
form the warp. At least three control 
points must be defined to create a warp.
Warping images 40.5



40
Working with GIS Shapefiles
Canvas will open or place Shapefiles. Shapefiles consist of the fol-
lowing three separate files entities:

• the main file, a Shape file (.shp), which contains geo-
graphic objects,

• an index file (.shx), which contains an I’th record. The I'th 
record in the .shx file stores the offset and content length 
for the I'th record in the main file (.shp).

• a dBASE table (.dbf), which contains attribute information 
about the geographic objects found in the Shapefile.

Free effect controls
A Control points. Click to add con-
trol points to both the source and tar-
get. Every source point must have a cor-
responding target point. At least 3 
points must be defined to enable the 
Create button.

Control points are saved in relative 
position to object, so if you drag or 
scale an object, the points will be 
scaled correspondingly. Save the doc-
ument after change the control points 
configuration. When exiting the ses-
sion, current point configuration is 
automatically saved.

B Segment points. Click to add seg-
ments to both the source and target. Ev-
ery source segment must have a corre-
sponding target segment.
C Curve points. Click to add curve 
segments to both the source and target. 
Every source curve must have a corre-
sponding target curve.
D End curve points. Click to com-
plete the curve.
E Select all points. Click to select all 
control points.
F Delete has two functions: delete 
current curve, if you are creating a 
curve, or delete selection, if any.

G Save. Click this button to save the 
control points within the source and tar-
get.
H Reload. Click this button to reload 
the saved points.

Pixel resampling. Select a resampling 
method.

• Nearest neighbor. Will remove 
some pixel information from your tar-
get image; however, if used, this set-
ting will be the fastest.
• Bilinear. Will use a bilinear inter-
polation algorithm during downsam-
pling.
• Biquadratic. Estimates the color 
at a pixel in the destination image by 
an average of 9 pixels surrounding the 
closest corresponding pixel in the 
source image.
• Bicubic. Estimates the color at a 
pixel in the destination image by an 
average of 16 pixels surrounding the 
closest corresponding pixel in the 
source image.
• Polygonal. Every source pixel is 
mapped to a polygon in the target.

Auto. Canvas selects the most appro-
priate method for resampling.

Show Names. Select this checkbox if 
you want to see labels. Use the Size 
menu to adjust the size of control 
points.

Shape. Select either Circle or Square 
for the control point shape.

Opacity. Adjust the transparency of 
the created object.

Source & Target colors. Select a color 
from the palettes to distinguish the 
source and target. By default, the 
source is red and the target is green.

Fixed Frame. Select this checkbox to 
maintain the form of the bounding 
box. If this option is deselected, the 
bounding box is warped.

Create. Click this button to perform 
the effect.

Delete. Click this button to delete the 
created object.

Exit. Click this button to leave the 
warp effect before or after clicking 
Create.
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Note: To open or place a Shape file into Canvas, all three files must 
be located in the same directory.

Shapefiles generally do not contain information about projection, 
earth model, or projection parameters. If the Shapefile creator pro-
vided this information to you, you can enter it in the File Coordi-
nate System dialog box (see “GIS manager,” page 40.1). If it was 
not provided, you must know these settings so the Shapefile 
appears correctly once opened in Canvas. 

Opening or placing Shapefiles
Canvas has the capability of either opening or placing Shapefiles. 
Whether you choose Open or Place, you will be presented with the 
same dialog boxes.

To open or place Shapefiles
1 Select .shp as the file type. 

2 Navigate to the .shp file in the Open or Place dialog box and 
click Open or Place. The Additional Files/Layers dialog box 
opens (see “Additional Files/Layers dialog box,” page 40.8).

3 Click Next and the Document GIS Settings dialog box opens 
(see “GIS manager,” page 40.1).
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Additional Files/Layers dialog 
box
A File name. Lists the name of the file 
being opened. 
B Projection. Indicates the file’s pro-
jection. Geodetic Lat/Long is the de-
fault. Select a row and click Projection 
to select another projection.
C Type. Indicates the object type. 
Shapefiles consist of either polygons, 
lines, or points.
D Colorization. By default the fill col-
or is set to black in the Colorization col-
umn. To change the fill color and style, 
select the row and click Colorization to 
open the Colorization dialog box.
E Options. For polygons, select ei-
ther Outline or No Outline. For points, 
select the shape: Circle, Rectangle, or 
Triangle.
F Size. Refers to point size. Select 
from Tiny, Small, Medium, or Large.
G # Objects. Indicates the number of 
objects contained in the file. 
H DBF. Choose to import or not im-
port object attibrutes by selecting or 
deselecting the DBF checkbox.

Add. To open more files, click this but-
ton and find the file. Note that the first 

file in the list is the bottom layer and 
the last is the top layer once opened in 
Canvas.

Remove. To remove a file from the list, 
select the row and click this button.

Clear. Click this button to remove all 
files from the list.

Move Up/Move Down. Shuffle the 
files by selecting a file in the list and 
then clicking either button.

Colorization. Select a row and click 
this button to open the Colorization 
dialog box.

Projection. Click this button to view 
the File Coordinate System dialog box. 
This dialog box indicates the file’s 
present projection and also allows you 
to select another projection similar to 
the GIS manager (see “GIS manager,” 
page 40.1).

Once you have completed any chang-
es, press Next to move to the Docu-
ment GIS Settings dialog box, which is 
identical to the GIS manager (see “GIS 
manager,” page 40.1)

Colorization dialog box

Method. This option refers to the fill 
color of the objects.Open the menu 
and select either No Fill, Solid Color, 
Color Range, or Color Array. Your 
choice affects the Color option.

Color. Open the pop-out palette and 
select the color. Solid Color consists of 
one solid fill color. For Color Range, 
you select two colors to be used indi-
vidually as fill colors. For Color Array, 
you select a multitude of colors that 
are used individually as fills.
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Working with DAT ASCII files
Canvas will open or place DAT ASCII files. These files contain geo-
graphic coordinates that form polygons when opened.

DAT ASCII file format
These files are represented in the following format:

ID is a unique polygon identification number.

LON/LAT is a longitude/latitude coordinate internal to the poly-
gon.

LONn/LATx is a sequence of longitude/latitude coordinate pairs 
defining the polygon vertices, with matching first and last vertices.

An END statement indicates the termination of each polygon, and 
a final END statement indicates the termination of the polygon file. 
Islands or exclusions within a polygon are flagged with an ID num-
ber of -99999. 

Opening or placing DAT files
Canvas has the capability of either opening or placing DAT files. 
Whether you choose Open or Place, you will be presented with the 
same dialog boxes.

ID LON1 LAT1

LON2 LAT2

... ...

LONx LATx

END 

ID LON1 LAT1

LON2 LAT2

... ...

LONx LATx

END 

END 
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To open or place DAT files
1 Select .dat as the file type. 

2 Navigate to the .dat file in the Open or Place dialog box and 
click Open or Place. The Additional Files/Layers dialog box 
opens (see “Additional Files/Layers dialog box,” page 40.8).

3 Click Next and the Document GIS Settings dialog box opens 
(see “GIS manager,” page 40.1).

Working with GeoTIFFs
GeoTIFF is a format in which an image that originates from satel-
lite imaging systems, scanned aerial photography, scanned maps, 
digital elevation models, or as a result of geographic analyses is 
related to a known model space or map projection.

Opening, placing, or importing GeoTIFFs
Canvas will open, place, or import TIFF files that contain GIS data. 
Whether you choose Open, Place Image, or Import, you will be pre-
sented with the same dialog boxes.

To open, place, or import a GeoTIFF
1 Select TIFF as the file type.

2 Navigate to the file in the Open, Place, or Import dialog box 
and click Open, Place, or Import. A warning message appears 
indicating that the file contains GIS data. Click OK to open the 
Geo TIFF options dialog box.



3 Click Next and the Document GIS Settings dialog box opens. 

Geo TIFF options dialog box

In the top portion of the dialog box, the 
GeoTIFF’s meta data is indicated.

Import options

Scale and Rotate only. Select this option 
to perform an affine transformation on 
the image. The image will be scaled, 
rotated, and skewed according to three 
points, of which the most accurate is the 
top right corner. When selected, images 
load quickly.

Perform Warp distortion. Select this 
option to calculate the exact position of 
every pixel in the image. This option is 
very precise; however, some images may 
take time to open due to the exactness of 
the calculation.

Click Next and the Document GIS Set-
tings dialog box opens. This dialog box 
has the same options as the GIS manager 
(see “GIS manager,” page 40.1).
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41
DATA ACQUISITION, VISUALIZATION & 
ANALYSIS

Canvas has the ability to accurately measure, analyze, and export 
digital images that may contain up to 32 bits per channel of data. 

Specialized imaging instrumentation within the medical, geologi-
cal, and other related scientific industries often creates image or 
data files that may contain more than 16 bits of data per grayscale 
channel. Canvas now combines its professionally engineered tech-
nology core with a number of new interface improvements that tar-
get the need to study and analyze this information. 

DICOM file format
Commonly used in medical imaging, DICOM (DIC) files can be 
imported into Canvas for further study. Combine the DICOM 
import filter with Canvas’ tools, various image filters and adjust-
ments along with its slide show capabilities to create dynamic medi-
cal presentations. You can even export your findings to HTML.

DICOM import options
A DICOM file may consist of one or many images. Canvas can 
read DICOM files as follows:

• RGB images are imported as RGB and grayscale are 
imported as grayscale.

• Indexed images are converted to RGB.

• Depending on the image’s range, it will be converted to 
8 bit, 16 bit, 32 bit, or 64 bit images.

To import DICOM files
If the DICOM file contains more than one image, the DICOM 
Import Options dialog box opens.

Distribute among layers Select this option to place each image on a 
separate layer in the same document.

Stack together Select this option to place the images on top of each 
other.

FP-32 images
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Create spreadsheet Select this option to create a matrix of the var-
ious images. Define the number of rows and columns.

Create animation / slide show Select this option if you want to cre-
ate a presentation or export as an AVI file or QuickTime Movie.

RAW file format
RAW format is a flexible file format for transferring documents 
between different applications and computer platforms. It is basi-
cally an import/export format rather than a storage format. 

A RAW file has no predefined format, not even for image width 
and height, palettes, etc. RAW format consists of a stream of bytes 
describing the color information in the file. 

Exporting RAW files
You have two options when exporting to RAW format: binary 
(.raw) or text (.txt).

To export to RAW format (binary)
1 Choose File > Save As.

2 Select RAW Image (binary) as the format.

3 Click Save. The Raw Image Export Options (binary) dialog 
box opens.

Raw Image Export Options 
dialog box (binary)
A Image Specs — This section indi-
cates the color mode, image size, and 
color depth. 
B Binary options

Output. For 8-bit and 16-bit images, 
this menu is disabled and only indi-
cates the color depth shown in the 
Image Specs section. For images with 
a color depth of FP-32 bits/channel, 
you can select the output depth.

Channels order. Select either Inter-
leaved or Planar. These options are 
disabled if grayscale is selected as the 
color mode. 

Interleaved refers to an image having 
the pixels stored contiguously; i.e., 

rgbrgbrgb. Planar means the color 
data is stored in separate 8-bit planes.

Byte order. For 8-bit images, this 
option is disabled. Select whether the 
byte order is for PC or Mac.

Alignment. Refers to the alignment of 
image data in file. Each row ends at a 
location, which is a multiple of 8 bits, 
16 bits, 32 bits, or 64 bits.

Header. Enter the number of bytes in 
the file before the first byte of image 
data.

BGR (Reverse Colors). Select this 
checkbox to reverse the color order.

Click OK to export the file.
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To export to RAW format (text)
1 Choose File > Save As.

2 Select RAW Image (text) as the format.

3 Click Save. The Raw Image Export Options (binary) dialog 
box opens.

Importing RAW files
You have three options when importing RAW files: binary (.raw), 
text (.txt), or comma separated values file (.csv).

Binary (.raw) is the most common selection since devices, like 
microscopes or various measuring equipment, produce binary 
(.raw) files. 

To import RAW files
1 Choose File > Open.

2 Select Raw Image as the format and navigate to the file.

3 Click Open. The Raw Image Import Options dialog box 
opens.

Raw Image Export Options 
dialog box (text)
A Image Specs — This section indi-
cates the color mode, image size, and 
color depth. 
B Text options

Format. Select from Comma delimit-
ed, Tab delimited, Space delimited, 
Colon delimited, or Semicolon deli-
meted.

Output. For 8-bit and 16-bit images, 
this menu is disabled and only indi-
cates the color depth shown in the 
Image Specs section. For images with 
a color depth of FP-32 bits/channel, 
you can select the output depth.

Channels order. Select either Inter-
leaved or Planar. These options are 
disabled if grayscale is selected as the 
color mode. 

Interleaved refers to an image having 
the pixels stored contiguously; i.e., 
rgbrgbrgb. Planar means the color 
data is stored in separate 8-bit planes.

BGR (Reverse Colors). Select this 
checkbox to reverse the color order.

Click OK to export the file.
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Image types & filters
Canvas supports 8-bit, 16-bit, and floating point (32-bit) images. All 
image filters are available for 8-bit images. For Binary filters, the 8-
bit image must be grayscale (see “Binary filters,” page 41.5). 

Regarding 16-bit and floating point (32-bit) images, various image 
filters and adjustment commands are available (see “Available fil-
ters and adjustment commands,” page 41.5). 

Image modes
If you are working with various image types and need to determine 
or convert images, choose Image > Mode. 

8 Bits/Channel
Indicates an 8-bit image. If working with 16-bit or 32-bit images, 
select this option to convert to an 8-bit image.

Raw Image Import Options 
dialog box
A Input Data. Canvas normally de-
tects the appropriate option. You can 
select either radio button.
B Image specs. 

Mode. Select the color mode for the 
image: Grayscale, RGB, BGR, CMYK, 
LAB, or Multichannel.

Source. Select the source image type: 
8 Bits/Channel, 16 Bits/Channel, 16 
Bits/Channel signed, or Float-32 Bits/
Channel.

Target. Select the target image type: 8 
Bits/Channel, 16 Bits/Channel, or 
Float-32 Bits/Channel.

Height & Width. You must know these 
specifications to properly import the 
raw image.

Channels. The number of color chan-
nels depends on the image’s color 
mode.

Resolution. Set the resolution for the 
image. Use either pixels/in or pixels/
cm.

Quantity. Indicates the number of 
images stored in the file. 

Gap. Indicates the number of bytes 
from the end of one image to the 
beginning of the next. 

Channels order. Select either Inter-
leaved or Planar. These options are 
disabled if grayscale is selected as the 
color mode. 

Interleaved refers to an image having 
the pixels stored contiguously; i.e., 
rgbrgbrgb. Planar means the color 
data is stored in separate 8-bit planes.

C Binary options

Byte order. Indicates whether the file 
originates from a PC or Mac.

Header. Enter the number of bytes in 
the file before the first byte of image 
data.

Alignment. Refers to the alignment of 
image data in memory. Each row ends 
at a memory location, which is a multi-
ple of 8 bits, 16 bits, 32 bits, or 64 
bits. 

Click OK to import the file.
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16 Bits/Channel
Indicates a 16-bit image. Select this option to convert to a 16-bit 
image if working with another image type.

FP-32 Bits/Channel
Indicates a floating point (32-bit) image. A floating point image 
refers to any array of data that is visualized. Select this option to 
convert to a 32-bit image if working with another image type. 

Note: You must convert an 8-bit or 16-bit image to grayscale to 
enable the FP-32 Bits/Channel option.

The following table indicates the filters that can be used with each 
type:

Binary filters
These commands can be applied to 8-bit grayscale images. For the 
Dilate, Erode, Open, and Close commands, you must specify the 
number of iterations in a dialog box. Iterations refer to the number 
of repetitions of a chosen filter. 

Dilate
The Dilate command enlarges objects that are darker than the 
background adding pixels to the edges of black objects.

Image type Available filters and adjustment commands

16-bit Average blur, Gaussian blur, Add Noise, Despeckle, Dust & 
Scratches, Median, High Pass, Maximum, Minimum, Arithmetic, 
Binary Logic, Expression, Image Math, Colorize, Invert, Levels, 
Curves, Brightness/Contrast, Convolve, Hue/Saturation (RGB 
only), Color Balance (RGB only)

FP (32-bit) Average blur, Median, Minimum, Maximum, Arithmetic, Expres-
sion, Image Math, Convolve, Colorize

Original image Image with Dilate filter applied
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Erode
The Erode command reduces the size of objects that are darker 
than the background.

Make Binary
The Make Binary command converts a grayscale image, or the cur-
rent selection, to values of either 0 or 255 so that you can apply a 
binary command to the image.

Close
The Close command is a combination of the Dilate and Erode com-
mands. When selected, the filter first performs a dilation and then 
the erosion. The goal of the filter is to smooth objects by filling in 
gaps in the image.

Open
The Open filter, a combination of the Erode and Dilate commands, 
is used to smooth objects and eliminate isolated pixels. When 
applied, the Erode filter is first performed, followed by the Dilate 
command.

Original image Image with Erode filter applied

Original image Image with Close filter applied
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Outline
Select this command and all black objects will be represented by a 
one-pixel wide outline. 

Skeletonize
When this command is applied to 8-bit grayscale images, pixels are 
removed from the edges of objects until the edges consist of single 
pixel-wide skeletons. 

Original image Image with Open filter applied

Original image Image with Outline filter applied

Original image Image with Skeletonize filter applied
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Distance Map
When applied, this filter creates an Euclidean distance map (EDM). 
The result of the command is that every black pixel is replaced with 
a gray value that is equivalent to the black pixel’s distance from the 
closest white pixel.

Ultimate Points
This filter is used on images to which the Distance Map filter has 
been applied to find the Ultimate Eroded Points (UEPs) of the Dis-
tance Map.

Scientific filters
Canvas features scientific filters that can be used to analyze 8-bit, 
16-bit, and floating point (32-bit) images. See “Available filters and 
adjustment commands,” page 41.5 to verify which scientific filter is 
available for the various image types.

• To access the Scientific filters: Choose Image > Filter > Scien-
tific.

Original image Image with Distance Map filter applied

Image with Distance Map filter 
applied

Image with Ultimate Point filter 
applied
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Arithmetic
The Arithmetic Filter contains commands that add (subtract, mul-
tiply, etc.) a value to each pixel in the active image or selection. 
When the result value is above or below the legal range of the 
image's data type, the value is reset to the maximum/minimum 
value. 

To apply an Arithmetic filter
1 Select the image object (or part of it with a Marquee tool) or 
place it in edit mode.

2 Open the Operation menu to choose a command.

3 Enter a value in the Value numeric field.

4 Click OK.

The Operation menu contains the following commands:

Operation Explanation

Add Adds a value to the image. With 8-bit images, results greater 
than 255 are set to 255. 

Subtract Subtracts a value from the image. With 8-bit and 16-bit 
images, results less than 0 are set to 0. 

Multiply Multiplies the image by the specified real value. With 8-bit 
images, results greater than 255 are set to 255. With 16-bit 
signed images, results greater than 65,535 are set to 65,535. 

Divide Divides the image by the specified real value. Attempts to 
divide by zero will be ignored. 

Minimum Pixels in the image with a value less than the specified value 
are replaced by the value. 

Maximum Pixels in the image with a value greater than the specified con-
stant are replaced by the value. 

Square root Destination pixel is equal to the square root of source pixel.

Square Destination pixel is equal to the square of source pixel.

Gamma Applies the function f(p) = (p/255)^gamma*255 to each pixel 
(p) in the image or selection, where 0.1 <= gamma <= 5.0. For 
RGB images, this function is applied to all three color channels. 
For 16-bit images, the minimum and maximum are used for 
scaling instead of 255. 

Tip
Select the Preview checkbox 
so you can see the result before 
clicking OK.
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Binary Logic
The Binary Logic Filter contains commands that perform bitwise 
operations or shift bits accordingly within a pixel.

The Operation menu contains the following commands:

Colorize
The Colorize filter is used to assign colors or gradients to a chosen 
range of values. Depending on the image type, 8-bit, 16-bit, or float-
ing point (32-bit), you can use either absolute values or percentages.

For floating point (32-bit) images, the Absolute values checkbox is 
automatically selected so you will use Absolute values.

Log Applies the function f(p) = log(p) * 255/log(255) to each pixel 
(p) in the image or selection. For RGB images, this function is 
applied to all three color channels. For 16-bit images, the mini-
mum and maximum are used for scaling instead of 255. 

Operation Explanation

Or Performs a bitwise OR operation on a source pixel and an 
argument.

And Performs a bitwise AND operation on a source pixel and an 
argument. 

Xor Performs a bitwise XOR operation on a source pixel and an 
argument. 

Left Shift / Right 
Shift

Performs a logical shift; it shifts all the bits in the pixel left or 
right according to the value specified in edit box and inserts 0.

Operation Explanation
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Using the Colorize filter
A New filter. Click on this icon to start 
a new filter. The default values are 0 to 
100 
B Value range. Enter the minimum 
and maximum in the scroll boxes. Dese-
lect the Absolute values checkbox to use 
percentages for the range. Select it for 
actual values (floating point 32 images).
C Color palette. Assign a color to the 
value range. Select the Gradient option 
to access both color palettes and view 
the distribution of the minimum/maxi-
mum range.
D Edit box. All defined filters are 
stored in this area.

Select the Preview checkbox if you 
want to see the results before clicking 
OK.

To modify a filter

1 Select the filter in the edit box.

2 Make any necessary changes.

To delete a filter

1 Select the filter in the Edit box.

2 Click the trash can icon.

To save a setting

1 Define the filters as indicated previ-
ously.

2 Click on the menu icon.

3 Select Save settings. A dialog box 
opens in which you enter a name for the 
setting.

You can save an unlimited number of 
settings.

To load a setting

1 Click on the menu icon.

2 Select Load settings.

3 Choose a setting. Menu icon
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Image Math
This filter performs an arithmetic and logical operation between 
two color channels and applies the result to another color channel.

The Operation menu contains the following commands:

The chosen operation is performed, and the result is multiplied by 
the Scale factor. The Offset value is then added. The final result is 
applied to the color channel selected from the Result menu.

Operation Explanation

Add Adds a value to the image. With 8-bit images, results greater than 
255 are set to 255. 

Subtract Subtracts a value from the image. With 8-bit and 16-bit images, 
results less than 0 are set to 0. 

Multiply Multiplies the image by the specified real value. With 8-bit 
images, results greater than 255 are set to 255. With 16-bit 
signed images, results greater than 65,535 are set to 65,535. 

Divide Divides the image by the specified real value. Attempts to divide 
by zero will be ignored. 

Minimum Pixels in the image with a value less than the specified value are 
replaced by the value. 

Maximum Pixels in the image with a value greater than the specified con-
stant are replaced by the value. 

Or Performs a bitwise OR operation on a source pixel and an argu-
ment.

And Performs a bitwise AND operation on a source pixel and an argu-
ment. 

Xor Performs a bitwise XOR operation on a source pixel and an argu-
ment. 

Average Applies the function Result = (img1+img2)/2 to each pixel in the 
image or selection.

Difference Applies the function Result = |img1-img2| to each pixel in the 
image or selection.
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To apply the Image Math filter to multiple images
1 Select the images.

2 Apply the filter by choosing Image > Filter > Scientific > 
Image Math. The Filter operation mode dialog box opens.

3 Choose an option in the dialog box depending on your needs.

4 Press OK.

Expression
The Math Expression filter can be used to perform mathematical 
equations on a color channel. 

1st operand: Green

Operation: Xor

2nd operand: Red

Scale: 2.0

Offset: 0.0

Result: Green
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To use the Math Expression filter
1 Select the color channel from the Target menu. The available 
color channels depend on the image mode; i.e., CMYK, RGB, etc.

2 Define the mathematical equation using the Categories scroll 
box and their related items.

3 Double-click on an item to make it appear in the Expression 
field.

Note: The lower portion of the dialog box indicates the correct syn-
tax and shows an example of the expression.

4 Click Apply to see the effect. Clicking Revert stops the effect 
on the color channel.

5 Click OK to permanently apply the effect to the channel.

To apply the Math Expression filter to multiple images
1 Select the images.

2 Apply the filter by choosing Image > Filter > Scientific > 
Expression. The Filter operation mode dialog box opens.

Expression field

Channel on which equation 
will be performed

Example of syntax and use

Menu icon
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3 Choose an option in the dialog box depending on your needs.

4 Press OK.

Convolve
The Convolve filter can be used to apply a spatial convolution on 
an image or selected image area. The convolution is performed 
according to a kernel, which is basically a matrix whose size you 
define in terms of width and height in pixels. Note that only odd 
numbers can be used to define the size of the kernel. The maxi-
mum is 11 pixels and the minimum, 3 pixels. 

The Convolve filter is applied to every pixel in an image. The cen-
ter of the matrix matches the source pixel and the other matrix 
components relate to the surrounding pixels. 

The resulting pixel is calculated by multiplying the value of each 
source pixel by the corresponding value in the kernel and then add-
ing the results.

To preserve image brightness
1 Select the Normalize kernel checkbox. This option causes 
each matrix value to be divided by the sum of the values. 

2 Click Apply to see the filter effect on the image. If the convo-
lution is not appropriate, click Revert and try another one.

3 Click OK to apply the filter and close the dialog box.

Center of matrix
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To save a kernel
1 Define the kernel.

2 Click on the menu icon and select Save kernel as. The Save 
kernel as dialog box opens.

3 Enter a name for the kernel and click OK.

Note: Saved kernels appear at the bottom of the menu when you 
click the menu icon.

To delete a kernel
1 Click on the menu icon and select Delete kernel. The Delete 
kernel preset dialog box opens.

2 Select the kernel to be deleted and then click OK.

To load a kernel
1 Click on the menu icon.

2 Select the kernel that you want to apply.

To paste a kernel
Before pasting a kernel, ensure there is a space between the values.

1 Copy the kernel from its source (e.g., Notepad).

2 Click the Paste icon.

Menu icon

Kernel definition 
area (matrix) Matrix center

Copy Paste
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Accessing image data
Canvas contains two important features that allow you to analyze 
an image’s pixel values and measure various image properties: 
Image Data Viewer tool and Image Measurement command. 

Image Data Viewer tool
It is now possible to quickly obtain raw data by using the Image 
Data Viewer tool. 

This tool is designed so you can quickly view raw data “on the fly”. 
In addition, you can copy this data to a .txt file or spreadsheet appli-
cation for further analysis.

• To use the Image Data Viewer tool: Select the tool from the 
Toolbox and drag it across the image. The Image Data Viewer dia-
log box opens showing the individual pixel values for the selected 
area.

Original image Image with Convolve filter applied
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Note: An alternative method to using the Image Data Viewer tool is 
to export the image as a .txt file using the RAW file export filter 
(see “Exporting RAW files,” page 41.2). However, although effec-
tive, the RAW export method may be time-consuming if analyzing 
several images and data is required immediately.

Image Data Viewer dialog box
A Display. Select either Hexidecimal, 
Signed decimal, Unsigned decimal, FP 
2-Decimal, FP 4-Decimals, or FP 8-
Decimals.

Hexidecimal. Refers to the base-16 
number system, which consists of 16 
unique symbols: the numbers 0 to 9 
and the letters A to F. 

Signed decimal. Integer value which 
can have both positive and negative 
values.

Unsigned decimal. Integer value with 
value of zero or greater (no negative 
numbers).

FP 2-Decimal. Refers to a floating 
point value with 2 digits following the 
decimal.

FP 4-Decimals. Refers to a floating 
point value with 4 digits following the 
decimal.

FP 8-Decimals. Refers to a floating 
point value with 8 digits following the 
decimal.

B Channel. Select a color channel 
from the menu. The available channels 

depend on the image mode; i.e., RGB, 
grayscale, CMYK, etc.
C Copy Data To Clipboard. Click this 
icon to export the data to a spreadsheet 
or other file for analysis.
D Refresh Data. Click this icon to up-
date the data.
E Lock. Click this icon to lock the di-
alog box and save the data view. Once 
locked, you can take the Image Data 
Viewer tool and select another data 
sample. Another dialog box will open so 
you can compare data.

F Left. Indicates the position of the 
first pixel in relation to the left side; i.e., 
43 would be the 43rd pixel from the 
left.
G Top. Indicates the position of the 
first pixel in relation to the top; i.e., 29 
would be the 29th pixel from the top.
H Width. Indicates the width of the 
selected area in pixels.
I Height. Indicates the height of the 
selected area in pixels.
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GLOSSARY

ACTIVATE To make a window active by clicking anywhere in it.

ACTIVE WINDOW The window with the program’s focus, usually in 
front. Tools and commands work in the active window.

ALPHA CHANNELS A grayscale duplicate of an image on which you 
can store masks and selections.

ALT KEY The Alternate key, usually marked “Alt” on a Windows 
keyboard, that modifies an action when pressed.

ANCHOR POINT The starting or ending point of a path segment. 
Anchor points appear only when an object is in edit mode. When 
selected, anchor points of curve segments display one or two direc-
tion lines.

ANSI  American National Standards Institute; one of the standards 
available to specify dimension object properties. 

ANTI-ALIAS To soften the edges of an applied brush stroke, effect or 
selection. When something is anti-aliased, the color on the edges 
fades to transparency instead of stopping abruptly. 

APPLESCRIPT A scripting language developed by Apple Computer 
that is integrated into the Mac OS. AppleScript provides an easy 
way to automate common tasks. AppleScript is also powerful 
enough to automate complex tasks and to customize the way appli-
cations behave. 

ASCII American Standard Code for Information Interchange (pro-
nounced “ASK-ee”); used for representing text inside a computer 
and for transmitting text between computers.

BASELINE An imaginary line on which a line of text rests. The 
descenders of characters such as g, j, p, and q extend below the base-
line.

BEVEL JOIN A style of connection between two segments in a vector 
object, in which the stroke lines appear to be trimmed diagonally.

BÉZIER CURVE A curve, named after French mathematician Pierre 
Bézier, defined by the position of anchor points and tangent lines.
BICUBIC An appropriate setting for image interpolation if you 
work primarily with photographs.

BILINEAR An appropriate setting for image interpolation if you 
work with line art. It may be applied to some photographic images.

Anchor point

Anti-aliased line

b a s e l i n e  e x a m p l e

Bevel join
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G.2
BIND To align the baseline of text so it follows the contours of a 
path.

BITMAP A digital image composed of pixels (.bmp); technically, an 
image containing only black and white (see also “image,” page G.7).

BITMAPPED FONT A font made up of characters composed of pix-
els, rather than vector data. Fonts displayed on a computer screen 
are bitmapped fonts, for example, and usually aren’t suitable for 
printing.

BLACK AND WHITE A method of digital imaging that uses pure 
black and pure white pixels. The frequency of black or white pixels 
create the illusion of shades.

BLEND A smooth transition of shape and color between two vector 
objects through intermediate objects created by Canvas.

BOUNDING BOX An invisible rectangle that defines the boundaries 
of an object. Canvas displays an object’s bounding box when the 
object is selected.

BULLET A special text character, usually a filled circle (•), available 
in many fonts, especially symbol fonts.

BUTTON A pushbutton-like image in dialog boxes where you click 
to designate, confirm, or cancel an action.

CANVAS TEMPLATE A Canvas document that includes options and 
settings and is used as the basis for new documents. 

CCITT Consultative Committee on International Telegraphy and 
Telephony; its standards include data transmission formats.

CENTER EXTENSION The distance that Center dimension lines 
extend beyond the dimensioned object.

CENTER GAP The space between a Center dimension crosshair and 
the lines that extend from it.

CENTER LENGTH The Center dimension crosshair length.

CHANNEL In digital images, a layer of primary color in a full-color 
image. For example, an RGB image has at least three color chan-
nels (one each for red, green, and blue) and a composite channel, 
which adds the three channels together to create a full-color image.

CHANNEL MASK A channel that creates transparency based on the 
the luminance of pixels in the channel. It can be applied to any type 
of object.

CHARACTER Any symbol, such as letters, numbers, and punctua-
tion, that can convey information. Some characters can be dis-
played on the monitor screen and printed on a printer.

CHARACTER STYLE A set of attributes, such as color, typeface, and 
style, that can be applied as a group to text characters.

Vector (left) and bitmapped fonts

R

A bounding box of a circle

A Center length
B Center gap
C Center extension
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CLICK (v.) To position the pointer on something, and then press 
and quickly release the mouse (or other pointing device) button. (n.) 
The act of clicking.

CLIP ART Electronic pictures that you can use in documents. The 
term comes from using scissors to clip pictures on paper.

CLIPBOARD A holding place in system memory for the last infor-
mation cut or copied from a document. You can paste information 
from the Clipboard into a document. Information remains on the 
Clipboard until replaced by another cut or copied selection.

CLIPPING PATH A vector or text object used to “clip” (hide) areas of 
another object that are outside of the clipping path.

CLOSED PATH A vector path that does not have separate starting 
and ending points.

CMYK COLOR A color system based on the four colors used in color 
printing: cyan, magenta, yellow, and black. Also, a color mode used 
to define colors in a digital image (see “process color,” page G.11).

COLOR PALETTE A collection of colors used in a document, from 
which you can select colors to apply.

COLOR SEPARATIONS Computer files, printed output, or film, in 
which the colors in a document are divided into their primary or 
custom color components. Color separations are used to produce 
printing plates for commercial color printing (see “process color,” 
page G.11 and “spot color,” page G.13).

COLOR WHEEL A two-dimensional view of color showing hue and 
saturation. Hue is the position of a color on the circumference of 
the wheel. Moving clockwise and starting at twelve o’clock, the col-
ors are yellow, red, magenta, blue, cyan, and green. Colors toward 
the center of the wheel have more gray than those near the edge.

COLUMN GUIDES Non-printing lines that define text columns and 
gutters in a section.

COMBINE A command used to create new objects from the inter-
section of two or more vector objects.

COMMAND KEY On Mac OS system keyboards, a key (usually with 
a propeller symbol and sometimes labeled “Command”) that modi-
fies an action when pressed.

COMPOSITE CHANNEL The combination of all color channels in an 
image. In the Channels palette, the first channel listed, identified by 
RGB, CMYK, LAB, or Black, depending on the image mode.

CONTROL KEY A keyboard key, usually marked “Ctrl” (Windows) 
or “Control” (Mac), that modifies an action when pressed.

Text used as a clipping 
path on a photo 
CLICK / CONTROL KEY G.3
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CONTROL PANEL A Windows system program that lets you change 
features of the operating system, such as settings for the display, 
keyboard, and networking.
In Mac OS X, see “system preferences,” page G.13.

CORNER POINT An anchor point where path segments meet at an 
angle, rather than with a smooth transition.

CROP To trim an image to a specified rectangular area.

CROP MARKS Small lines placed at the page edge that mark where 
printed material will be trimmed.

CURRENT INK The ink, or color, that applies to new objects you 
draw, set by applying an ink when no objects are selected. This set-
ting does not change when you set the ink for a specific object; e.g., 
if you set the current fill ink to red, new objects you draw will be 
filled with red. You can then change an object’s color from red to 
green; however, the current ink remains red.

CURRENT STROKE The stroke that applies to new objects you draw, 
set by applying a stroke when no objects are selected; this setting 
does not change when you set the stroke for a specific object; e.g., if 
you set the current stroke to a 5-pt pen, new objects you draw will 
have a 5-pt pen width; however, if you then change an object’s 
stroke from 5 to 10 pts, the current pen width remains 5 pts.

CUSTOM VIEW A recording of a screen position and magnification 
level in a Canvas document. 

DECIMAL TAB A tab, represented by a decimal tab marker, that 
aligns columns of numbers at the decimal point position.

DESATURATE To increase the gray content of a color.

DIALOG BOX A box that an application displays to request informa-
tion or to report that it is waiting for a process to complete. 

DIMENSION OBJECT Object created with the Dimensioning tool.

DIMENSION TEXT GAP The space between the dimension text and 
arrow.

DIN STANDARD Deutches Institut für Normung standard; one of 
several used to specify the properties of dimension objects.

DIRECTORY DIALOG BOX A type of dialog box you use to navigate a 
computer file system when you save or open a file (refer to system 
documentation for specifics).

DITHER To arrange pixels of several colors into patterns to give the 
appearance of a broader range of colors.

DOCUMENT The container for information and objects you work 
with in Canvas. Canvas has four types of documents — Illustration, 
Presentation, Publication, and Animation.

Corner point

 0.37 ' 

 1.00 ' 

Dimension objects
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DOT GAIN In commercial printing, the amount of size increase of 
halftone dots caused by ink spreading on the printed medium.

DOUBLE-CLICK (v.) To press and release the button on a mouse (or 
other pointing device) twice in quick succession.

DPI Dots per inch; the unit of measurement of the resolution of a 
printing device.

DRAG To press and hold down the button on a mouse (or other 
pointing device), move the device, and then release the button.

DYNAMIC OBJECT A vector object that can be used to place copies 
of itself in documents; the copies remain linked to the original.

EMULSION Photosensitive coating on film or paper.

ENCAPSULATED POSTSCRIPT (EPS) A format for storing graphics 
and text in a file using the PostScript language. An EPS file can 
include a preview image (see “PostScript®,” page G.11).

ESC KEY A keyboard key that lets you stop a procedure. 

EXIF EXTENSION Short for Exchangeable Image File, a format that 
is a standard for storing interchange information in digital photog-
raphy image files using JPEG compression. 

EXTERNAL TOOLS Individual program modules that provide fea-
tures, tools, and commands in the Canvas program.

FADE Gradual decrease of a painting tool effect until there is no 
noticeable change in the image; e.g., if “Fade Size within 32 steps” 
is selected in the Properties bar, the brush becomes smaller as you 
drag. 

FILE Any named, ordered collection of information stored on a 
disk.

FILL INK The ink that Canvas applies to the inside, as opposed to 
the outline, of objects and text.

FILTERS A filter is an effect that can be applied to a paint image. 
Some filters mimic conventional photographic filters, but many 
transform images in unusual ways; e.g., the Oil Painting filter can 
make a digitized photograph look like an oil painting.

FLASH A bandwidth friendly and browser independent vector-
graphic animation technology. As long as different browsers are 
equipped with the necessary plug-ins, Flash animations will look 
the same (see “.swf,” page G.13).

FLAT END CAP A style of stroke end in which the stroke end is 
squared off, perpendicular and flush to the end of the stroke.

Flat end cap
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FLOATING SELECTION An image area that “floats” above an image. 
You can move and edit the floating selection without changing the 
underlying image until you defloat, or “drop,” the selection on the 
image.

FOLDER A container for documents, applications, and other fold-
ers in the Mac OS and Windows file systems.

FONT A complete set of characters in one design, size, and style. In 
typography, a font can be restricted to a particular size and style 
(such as 10-point Helvetica) or can comprise multiple sizes, or mul-
tiple sizes and styles, of a typeface design.

FOOTER One or more lines of text that appear at the bottom of 
every page of a document. Once you specify the text that should 
appear in the footer, the application automatically inserts it.

FRAME (1) One illustration “page” in an animation. An Animation 
document contains a series of frames which are displayed in 
sequence to make an animation. (2) A technical term for the outline 
of an object or text, to which Canvas applies stroke settings, such as 
dashes.

FTP Abbreviation of File Transfer Protocol, the protocol used on 
the Internet for sending files.

GAMUT The range or extent of a color model’s spectrum. 

GIF Abbreviation for graphics interchange format, a bit-mapped 
graphics file format used primarily on the Web. GIF supports color 
and various resolutions. It also includes data compression, making 
it especially effective for scanned photos. 

GRADIENT A gradual transition or blend between two or more col-
ors. The direction and shape of a gradient can be radial, linear, 
elliptical, or shape-derived.

GRATICULE A grid of lines that display meridians of longitude and 
parallels of latitude.

GRAYSCALE An image mode that uses eight bits of information per 
pixel for up to 256 brightness levels, from black to white through 
shades of gray.

GROUP (v.) To associate two or more objects so they behave as a 
unified object; (n.) the resulting object.

GUIDES Non-printing lines to which objects can be aligned or even 
snapped.

HALFTONE A pattern of tiny black and white dots that appear to 
the human eye as shades of gray; a photograph or other image con-
verted to such a pattern for commercial printing.
FLOATING SELECTION / HALFTONE



HANDLES (1) Small squares, usually at the corners and midpoints 
of an object’s bounding box, displayed when an object is selected; 
you can drag handles to resize the object. (2) Small circles at the 
ends of tangent lines; you can drag a handle to change the length or 
angle of a tangent line.

HATCH PATTERN Object-based fill pattern made of line groups.

HEADER One or more lines of text that appears at the top of each 
page of a document. Once you specify the text that should appear 
in the header, the text is automatically inserted. 

HIGHLIGHT To make something visually distinct. For example, 
when you select a block of text in Canvas, the selected text appears 
against a colored background.

HOTKEYS Single-letter keyboard commands that can be used while 
in image editing mode or vector editing mode

HTML Abbreviation for HyperText Markup Language, the author-
ing language used to create documents on the Web. 

HUE A color’s main characteristic; its name, as in blue, red, or 
orange, defined by its position on the color wheel.

I-BEAM A type of pointer shaped like the capital letter “I.” 

IMAGE A picture composed of pixels; referred to as a “raster 
image,” “paint image” or “bitmap” (see “image mode,” page G.7).

IMAGE MODE The system used to define colors in an image. Can-
vas image modes include Black and White, RGB Color, CMYK 
Color, Grayscale, Indexed, and LAB Color.

IMPORT To use any of several techniques to move graphics or text 
from another program into a Canvas document.

INDEXED A digital image mode that lets you specify a palette of up 
to 256 colors used in the image. Usually used for on-screen display 
and electronic distribution of images, because it requires less mem-
ory than RGB or CMYK color modes.

INK Colors, symbols, hatch patterns, textures, and gradients that 
can be applied to objects.

INSERTION POINT A blinking vertical line where text you type will 
appear in a text object or dialog box.

ISO STANDARD International Organization for Standardization; 
one of several standards used to specify the properties of dimension 
objects.

JIS STANDARD Japanese Industrial Standard; one of several used to 
specify the properties of dimension objects.

Tangent line handles

Insertion point
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JPEG The abbreviation for Joint Photographic Experts Group. 
JPEG is a lossy compression technique for color images. Although 
it can reduce files sizes to about 5% of their normal size, some detail 
is lost in the compression.

JUSTIFICATION The method used to align paragraphs of text within 
a text object’s margins, either left, right, center, or full.

KERNING Adjusting the normal space between characters in text; 
also, the amount of the adjustment.

LAB COLOR An image mode in which the color components are 
divided into a lightness channel and A and B color channels.

LANDSCAPE Orientation of an illustration or page that is wider 
than it is tall.

LATITUDE The angular distance of a point on the earth's surface 
along a meridian north or south of the equator.

LAYER A level in a Canvas document used to organize parts of 
illustrations so they can be easily selected.

LAYOUT AREA The rectangular area on screen in a Canvas docu-
ment, which represents the extent of the layout and may cover mul-
tiple printed pages, depending on the size of paper used for 
printing.

LEADER CHARACTER A character, usually a period (“.”) used to fill 
space between the character before a tab space and the character 
immediately following the tab space.

LEADER CHARACTER LENGTH The length of the horizontal portion 
of the witness line of a dimension object.

LEADING Space between lines of text, measured in points from the 
baseline of one line to the next.

LENS A special object which applies effects such as filters and mag-
nification to an area in a document.

LIGHTNESS The amount of black or white in a color.

LINE GROUP A set of parallel lines in a hatch pattern that have iden-
tical properties.

LINE CAP The shape of the end of a pen stroke.

LINE JOIN The shape of the pen stroke where two path segments 
meet. 

Left alignment Right alignment

Text without kerning (top) and 
with kerning applied (bottom)

 2.30  pica 
Leader character length
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LONGITUDE The angular distance of a point on the earth's surface 
east or west of an arbitrarily defined meridian, usually the Green-
wich meridian (Greenwich, England).

LPI Lines per inch; a measure of halftone screen resolution.

MAC OS The Apple Computer operating system used on Macin-
tosh and on compatible personal computers. Mac OS X, which is 
based on Unix, is Apple’s most recent operating system. Canvas 
currently runs on Mac OS X (10.2+).

MARQUEE A selection in an image defined by a rectangular flash-
ing border; also, the tool used to make a marquee selection.

MASTER PAGE A special page in a Publication, Presentation, or 
Animation document. Items on the master page, slide, or frame are 
visible and print on every page in the document.

MASK A general term for objects or channels that limit that visibil-
ity of other objects, or that protect areas in an object or image from 
changes.

MASTER SLIDE A special slide in a Presentation document. Items 
on the master slide are visible and print on every slide in the docu-
ment.

MEGABYTE (MB) A unit of measurement equal to 1024 Kilobytes, or 
1,048,576 bytes.

MEMORY A hardware component of a computer system that can 
store information for later retrieval.

MITER JOIN A style of connection between two segments in a vector 
object in which the stroke lines come together at a point.

MODIFIER KEY A general term for a key that changes the meaning 
of other keys or mouse actions; for example, Command, Control, 
Option, and Shift.

NTSC National Television Standards Committee; also, the stan-
dard video format defined by the NTSC, also called composite 
because it combines all the video information, including color, into 
a single signal.

OBJECT A discrete vector path, block of text characters, or raster 
image, contained within an invisible rectangular frame. You can 
select an object and perform standard operations on it, including 
move, copy, delete, cut, rotate, flip, and skew.

OBJECT PROPERTIES You can assign specific information to each 
component of a complex object. The properties of an object can 
include information that will allow you to efficiently track cost, 
inventory, location, and availablity.

Oval used as a lens

Marquee tool

Miter join
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OPACITY An attribute of all objects. Opacity with a value of 100% is 
non-transparent. Opacity values can be set from 1 to 100%.

OPEN PATH A path defined by separate starting and ending points.

OPTION KEY A Mac OS keyboard modifier key, usually labeled 
“Option.”

OUTSIDE LINE LENGTH Dimension object arrow length, when the 
Arrows Inside option is not selected.

OVERPRINT A technique where two or more colors are printed on 
top of each other. For example, if you overprint yellow on blue, the 
combination appears green.

PAINT OBJECT An object that contains a raster image. The term is 
synonymous with image object.

PAINTING TOOL Any of several tools used to create or edit a paint 
object.

PALETTE A type of dialog box that can remain open on screen. A 
palette contains tools, attributes, or options for commands.

PALETTE ICON A Toolbox icon that opens a palette.

PARAGRAPH STYLE A set of attributes, such as font, leading, 
indents, and tab settings, that can be applied to a paragraph of text.

PATH One or more connected segments, generally created with a 
drawing tool, within a vector object. The path itself is invisible 
unless it has visible fill ink, or pen ink and stroke, applied to it.

PDF Abbreviation for Portable Document Format, a file format 
developed by Adobe Systems; PDF captures formatting informa-
tion from a variety of desktop publishing applications, making it 
possible to send formatted documents and have them appear on 
the recipient's monitor or printer as they were intended. Canvas has 
PDF export capabilities.

PEN INK The colors and patterns applied to an object’s stroke.

PICA A unit of measurement equal to 12 points or 1/6 of an inch, 
abbreviated “pc.”

.PCT Abbreviation for Macintosh bitmap graphics (b&w PICT1 - 
color PICT2)

PIXEL Short for picture element; a single tiny dot of a raster image or 
a computer display.

PIXEL MODE This setting allows you to view graphics at 72 ppi 
before they are rendered. This gives you an exact preview of what 
the graphics will look like when they are rendered.

PLUG-IN A program module that can be used by Canvas to pro-
vide an additional image-editing function.

 0.50 ' 

Outside line length
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.PNG Abbreviation for Portable Network Graphics; for the Web, 
PNG really has three main advantages over GIF: alpha channels 
(variable transparency), gamma correction (cross-platform control 
of image brightness), and two-dimensional interlacing (a method of 
progressive display). For image editing, either professional or other-
wise, PNG provides a useful format for the storage of intermediate 
stages of editing. 

POINT A unit of measurement for type equal to 1/72 inch; abbrevi-
ated “pt.”

POINTER A small shape that follows the movement of the mouse 
on screen or shows where your next action will take place. The 
pointer can be an arrow, an I-beam, or other shapes.

POLYGON A figure that has more than 4 sides. The Polygon and 
Smooth Polygon tools are used to create polygons in Canvas.

PORTRAIT The orientation of a page or illustration so that the 
height is larger than the width.

POSTSCRIPT® (1) An Adobe Systems, Inc. computer language that 
defines the appearance of printed type and images. (2) A type of 
font that relies on PostScript to be printed.

POSTSCRIPT PRINTER DESCRIPTION (PPD) A text file that provides 
information about a specific printer to the operating system and 
application programs (refer to operating system documentation for 
specifics).

PPI Pixels per inch; a measure of the resolution of an image.

PREFERENCES Preferences are options that let you customize the 
display, tools, and commands. 

PRESS (1) To point to an item on screen and press and hold down 
the mouse button without moving the mouse. (2) To push a key 
down and then release it; you hold a key down only when using a 
modifier key with another key, for example, when instructed to press 
Ctrl+A.

PRINTER DRIVER A program that controls the exchange of informa-
tion between the computer and a specific type of printer (refer to 
operating system documentation for specifics).

PROCESS COLOR The method for printing a full range of colors 
using only cyan, magenta, yellow, and black; also, any one of these 
colors. Compare to “spot color,” page G.13.

PROJECTION A mathematical technique that converts and portrays 
features from a spherical surface onto a 2-D plane.

PROPERTIES BAR The area below the Menu bar that displays infor-
mation on tools, document setup, and selected objects. You can 
also apply effects and filters via the Properties bar.

Polygon tool
.PNG / PROPERTIES BAR G.11
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.PSD Extension used for Photoshop graphics files; Canvas can 
import .PSD files as well as export to that format.

RANDOM-ACCESS MEMORY (RAM) The part of the computer’s mem-
ory that stores information temporarily while you’re working.

RASTER IMAGE A picture made up of a matrix of pixels, created by 
digitizing or scanning an image, which is contained in a paint 
object (see “bitmap,” page G.2).

REGISTRATION MARK A small mark, several of which are used 
together to align films and plates for commercial printing.

RGB COLOR Method of defining colors, based on combinations of 
the primary colors red, green, and blue. Also, a color mode for digi-
tal images.

RESOLUTION A measure of the amount of information in a digital 
image, expressed in pixels per inch (ppi); also, a measure of the 
smallest dot or pixel that can be used by a computer display or out-
put device, expressed in dots per inch (dpi).

ROUND END CAP A style of stroke end, in which the end of the 
stroke is capped with a semicircle.

SATURATE To increase color intensity by removing gray.

SCANNER Any input device that converts printed matter, such as a 
photographic print or transparency, into digital data.

SCRIPTING A script is a succession of commands that Canvas can 
execute automatically. Scripting is available for Windows and Mac.

SECTION A rectangular area that arranges text in columns.

SEQUENCES An automated feature allows you to build and effi-
ciently maintain a complete library of your Canvas-created design 
effects.

SHIFT KEY A key that, when pressed, causes the subsequent letter 
you type to appear in uppercase or the top symbol on a two-charac-
ter key to be produced. The Shift key can also modify mouse 
actions.

SEGMENT A line or curve between two endpoints in a path.

SELECTION The information or items that will be affected by the 
next command, including objects or a series of characters.

SELECTION BOX A dashed rectangle that appears as you drag a 
Selection tool over objects to select them.

SEPARATIONS See “color separations,” page G.3.

SLICE A slice is a rectangular area of an image that becomes a cell 
in an HTML table. The HTML table is then exported to be placed 
onto a Web page.

Registration mark

Round end cap

Sequences 
palette

Segment
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SLIDE SHOW The display of different screens of information — 
“slides” — in sequence. Canvas changes the screens after a set time 
interval or when you click the mouse. You can also create self-run-
ning slide shows for the Windows platform (.EXE).

SMART POINTER A pointer symbol representing the Smart Mouse 
constraint that is in effect.

SMOOTH POLYGON A polygon with rounded segments and corners 
(see “polygon,” page G.11).

SNAP GRID A grid of horizontal and vertical lines you can display. 
The pointer can snap into alignment with the snap grid.

SPACEBAR The long, unlabeled bar in the bottom row of keys on a 
computer keyboard that you press to insert space between charac-
ters.

SPACING .GIF A one-pixel wide transparent GIF image used as a 
spacer to be used to fill all empty cells in a HTML table.

SPOT COLOR Customized color representing a particular ink that 
will be used to print the color (see “process color,” page G.11).

SPRITEEFFECTS A Canvas technology that lets image-editing 
effects, such as blur and curves, be applied to any type of object.

SPRITELAYER A Canvas technology that provides transparency 
effects, including opacity and transparency masks.

SQUARE END CAP A style of stroke end, in which the end of the 
stroke is squared off and extends half the line width beyond the 
endpoint of the path.

STATUS BAR The area at the bottom of the Canvas window or the 
screen that displays information on tools, the position of the 
pointer, and selected objects.

.SWF Extension for Flash files; you can create an .SWF file that 
you can edit in the Macromedia Flash application or that you can 
use in a Macromedia Flash player or compatible browser.

SYMBOL INK A repeating pattern, created from vector objects, that 
can be applied to vector objects and text as a fill ink or stroke ink.

SYMMETRICAL DRAG Enables you to drag selected control points of 
an object and resize the object’s shape from its center. 

SYSTEM PREFERENCES An application in Mac OS X that lets you 
change features of the operating system, such as settings for the dis-
play, docking bar, startup disk, etc. 

TAB KEY A keyboard key that moves the insertion point to the next 
tab marker, or to the next place to enter information in a dialog 
box. The Tab key is also used as a modifier key.

Square end cap
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TANGENT LINE Line passing through an anchor point on a vector 
path; visible when the path is in edit mode and an anchor point 
with tangent lines is selected. Its angle and length affect the shape 
of adjacent segments.

TEMPLATE See “Canvas Template,” page G.2.

TEXT BACKGROUND INK An ink applied to the background of a text 
object or text selection.

TEXT ENCODING When exporting Canvas files that contain text to 
HTML, text can be encoded so that the HTML output is always 
valid. Choose between Western and Unicode encoding.

TEXT FRAME INK An ink applied to the bounding box of a text 
object or a box around a text selection.

TEXT FRAME STROKE A stroke applied to the bounding box of a text 
object or a box around a text selection. The text frame ink appears 
on the text frame stroke.

TEXT OBJECT An object containing text.

TEXT BOX A place in a dialog box where you can type information.

TEXT FILE A file that contains information stored in the form of 
readable characters encoded in ASCII format.

TEXTURE INK A repeating pattern, created from a raster image, that 
can be applied as a fill ink or pen ink.

.TIFF Acronym for Tagged Image File Format (also .TIF); these 
graphics can be any resolution, and they can be black and white, 
grayscale, or color.

TILING Dividing a large illustration into multiple pages, or “tiles,” 
for printing on a desktop printing device.

TOLERANCE In image editing, a value that sets the threshold for 
similarity between colors before an effect occurs; e.g., if the Wand 
tool tolerance is set to 0, it selects only pixels of the exact same 
color. If the tolerance is set higher, the tool selects pixels of similar 
colors.

TOLERANCE SIZE SCALE  Size of tolerance text in a dimension in 
proportion to the dimension text.

TOLERANCE SPACE SCALE Amount of space (leading) between toler-
ance text in dimensions with two tolerance measurements.

TRANSFER MODE Method by which a color blends with a back-
ground color. Transfer modes, found on the Transparency palette, 
include Normal, Multiply, Screen, Overlay, Soft Light, Hard Light, 
etc.

Tangent lines

Tiling

Rectangle with an Overlay 
Transfer Mode
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URL Abbreviation of Uniform Resource Locator, the global 
address of documents and other resources on the Web. The first 
part of the address indicates what protocol to use, and the second 
part specifies the IP address or the domain name where the 
resource is located. 
An example of a URL is http://www.acdsystems.com.

VBSCRIPT Abbreviation for Visual Basic Scripting Edition, a script-
ing language developed by Microsoft and supported by Internet 
Explorer. VBScript is based on the Visual Basic programming lan-
guage, but is much simpler. In many ways, it is similar to JavaS-
cript. VBScript enables Web authors to include interactive controls, 
such as buttons and scrollbars, on their Web pages. 

VECTOR MASK A SpriteLayer effect that applies transparency to an 
object based on a gradient from opaque to transparent.

VECTOR OBJECT An object defined by anchor points and a path. 
The Line, Rectangle, Oval, Arc and similar tools draw vector 
objects. 

WINDOWS (1) The brand name of a family of Microsoft operating 
systems, including Windows ME, 2000, and XP. (2) The separate 
areas on screen in which programs display information.

WITNESS EXTENSION Part of the witness line that extends beyond 
the dimension arrows.

WITNESS GAP Space between an object and dimension witness 
lines.

WRAP To change text margins so text flows around or remains 
inside a vector object.

X-HEIGHT The height of a lowercase x in a given font; the height, 
measured from the base line, of the main portion of most lowercase 
letters in a font, excluding ascenders and descenders.

ZOOM To increase or decrease the magnification of a document.

Elliptical vector mask applied to an 
oval

 0.38 ' 

 0.80 ' 

A Witness extensions
B Witness gap

A

A

B
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dictionary  . . . . . . . . . . . .  32.13

drawing format (OLE). .  14.26
exporting image files. . . . . 28.7
settings file . . . . . . . . . . . . . 15.2
tools folder . . . . . . . . . . . . . 24.2

Canvas 6-style object locking ..  13.6
capitalization style.......................  30.8
Cartesian..................................... 18.21
Center Dimensioning tool.........  20.3
center justification .................... 30.18
center of rotation ...................... 17.29
center reference point ...............  40.4
center snap option......................  18.8
center, drawing objects from ...  18.1
centerpoint, skewing ................ 17.26
CGM*PIP import options dialog box 
14.8
Chain Dimensioning tool. 20.3, 20.4
changing

brush settings  . . . . . . . .  23.13
color settings . . . . . . . . .  13.21
current inks  . . . . . . . . . .  15.24
current pen width . . . . . . . 16.6
document type. . . . . . . . . . 13.5
image mode . . . . . . . . . .  10.13
image resolution . . . . . .  10.13
object dimensions . . . . .  10.11
object opacity  . . . . . . . .  10.12
object position . . . . . . . .  10.11
object transfer mode  . .  10.12
zero points . . . . . . . . . . .  11.10

channel mask scope...................  35.9
channel masks ....  6.7, 26.25–26.28, 
35.6
channels

activating  . . . . . . . . . . . .  26.24
alpha . . . . .  26.19, 26.21, 35.7
auto tracing  . . . . . . . . . .  24.15
calculations with . . . . . .  27.21
channel masks. .  26.21, 26.28
color . . . . . . . . . .  26.19, 26.20
composite  . . . . . . . . . . .  26.20
composite channels  . . .  26.19
creating. . . . . . . . . . . . . .  26.22
deleting. . . . . . . . . . . . . .  26.22
display options. . . . . . . . . . 13.8

displaying a single channel . . .  
26.24

isolating a selection . . . .  27.14
mask options  . . . . . . . . .  26.23
options. . . . . . . . . . . . . . .  26.23
renaming . . . . . . . . . . . . .  26.23
saving selections in  . . . .  26.17

channels palette ..  6.7, 26.20, 26.22
character attributes.....................  31.8
character formatting

font styles  . . . . . . . . . . . . .  30.8
fonts . . . . . . . . . . . . . . . . . .  30.5
horizontal and vertical scaling   

30.13
kerning. . . . . . . . . . . . . . . .  30.9
preventing changes to . . .  31.8
special characters  . . . . .  32.10
type size. . . . . . . . . . . . . . .  30.7
type styles . . . . . . . . . . . . .  31.1

character spacing .....................  30.10
check document command ........  1.5
check proxies command............  28.5
Chinese fonts ............................  13.15
choke trap ..................................  17.37
choosing document type ...........  11.2
choosing reference point ...........  40.3
Circle 3 Points tool .....................  18.3
Circle Radius tool........................  18.3
circles, drawing ............................  18.2
classic arrows

bottom . . . . . . . . . . . . . . .  16.18
editing . . . . . . . . . . . . . . .  16.18
full  . . . . . . . . . . . . . . . . . .  16.18
hollow  . . . . . . . . . . . . . . .  16.18
top . . . . . . . . . . . . . . . . . .  16.18
witness. . . . . . . . . . . . . . .  16.18

clean up by name command .  10.15
clean up command ..................  10.14
clean up palettes command......  10.8
clear command ............................  17.6
clear font history.......................  13.15
clearing customized settings..  13.25
clearing inks..................................  15.2
clearing print area .......................  9.11
clipart
INDEX I.3



I.4
placing  . . . . . . . . . . . . . . . . 22.4
clipboard

copying objects to . . . . . . . 17.7
definition & use . . . . . . . . . 17.6
OLE. . . . . . . . . . . . . . . . .  14.26
pasting into selections .  26.11

clipping paths
applying effects to . . . . . . . 21.5
creating. . . . . . . . . . . . . . . . 21.4
definition  . . . . . . . . . . . . . . 21.4
editing. . . . . . . . . . . . . . . . . 21.5
from text. . . . . . . . . . . . .  33.11
removing  . . . . . . . . . . . . . . 21.5
showing and hiding . . . . . . 21.5

cloning options
see Rubber Stamp tool . . . 23.8

close filter .....................................  41.6
closed paths...............................  19.16
closing

documents . . . . . . . . . . . . . 9.16
palettes. . . . . . . . . . . . . . . . 10.8

clouds (render) filter ..................  27.1
CMYK color .......................  15.3, 15.7
CMYK color mode.......  23.36, 26.19
color

applying  . . . . . . . . . . . . .  15.24
blends . . . . . . . . . . . . . . . . . 15.9
calibration  . . . . . . . . . . .  13.20
CMYK. . . . . . . . . . . . 15.3, 15.7
Color Dropper tool 15.24, 23.18
color editor. . . . . . . . . . .  15.10
color range files . . . . . . . . . 26.5
color spectrum strip . . . . . 15.5
color systems. . . . . . . . . . . 15.7
custom colors  . . . . . . . . . . 15.9
defining. . . . . . . . . . . . . . . . 15.7
dither colors preference . . 13.5
gamut warning. . . . . . . . . . 15.6
gradient inks  . . . . . . . . .  15.11
grayscale  . . . . . . . . . . . . . . 15.7
HSL . . . . . . . . . . . . . . . . . . . 15.7
identifying inks. . . . . . . . . . 15.3
inks . . . . . . . . . . . . . . . . . . . 15.1
Kodak ICC profiles . . . .  13.21
management . . . . . . . . .  13.20

mixing two colors . . . . . .  21.20
mode . . . . . . . . . . . . . . . .  35.20
models. . . . . . . . . . . . . . .  23.28
of layout area  . . . . . . . . . .  10.4
outside of Canvas. . . . . .  15.26
painting with . . . . . . . . . .  23.17
pen inks . . . . . . . . . . . . . .  15.23
printing options  . . . . . . . .  9.14
registration ink . . . . . . . .  18.17
RGB . . . . . . . . . . . . . . . . . .  15.7
saturation  . . . . . . . . . . . .  25.14
selecting  . . . . . . . . . . . . .  15.24
selecting in images. . . . . .  26.7
separations . . . . . . . . . . .  17.36
settings command . . . . .  13.21
spot color option  . . . . . . .  15.8
tints  . . . . . . . . . . . . . . . . . .  15.8
wheel . . . . . . . . . . . . . . . .  25.13

color array.....................................  40.8
color balance command ............  25.8
color channels.................  13.8, 26.19
Color Dropper tool ...... 15.24, 23.18
color editor dialog box ............. 15.10
color equalization command .. 25.14
color icons

displaying  . . . . . . . . . . . . .  15.3
hiding . . . . . . . . . . . . . . . . .  15.3

color management .................... 13.20
color manager ..............................  15.5
Color Profiles folder ................. 13.20
color range....................................  40.8
color range command ....  26.1, 26.4, 
26.7
color separations, previewing...  9.11
color settings

CMYK . . . . . . . . . . . . . . .  13.22
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colorize filter ..............................  41.10
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width . . . . . . . . . . . . . . . .  30.23

combine
add  . . . . . . . . . . . . . . . . . .  21.7
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comments . . . . . . . . . . . .  17.41
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copy to layers. . . . . . . . .  17.21
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display options. . . . . . . . . . 13.3
dock all palettes  . . . . . .  10.14
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edit  . . . . . . . . . . . . . . 17.4, 17.5
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embed EPS  . . . . . . . . . . . . 17.8
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find  . . . . . . . . . . . . . . . . . . . 17.5
fit Bézier . . . . . . . . . . . . .  19.30
fit to objects . . . . . . . 2.5, 10.20
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fit to window . . . . . . 2.5, 10.20
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Gaussian blur . . . . . . . . .  25.15
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guides  . . . . . . . . . . . . . . .  11.12
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hide page breaks  . .  11.5, 11.7
hide rulers . . . . . . . . . . . . .  11.7
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hide spelling errors  . . . .  32.13
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horizontal (flip) . . . . . . . .  33.13
horizontalize . . . . . . . . . .  17.26
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image measurement  . . . .  25.2
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in context menus . . . . . .  10.24
increase (text size) . . . . . .  30.7
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insert object  . . . . . . . . . .  14.26
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inside shape (wrap) . . . . .  33.4
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I.6
loose (kerning)  . . . . . . .  30.10
loosen (kerning)  . . . . . .  30.10
loosen (leading). . . . . . .  30.15
loosen fine kerning . . . .  30.10
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math expression 2-D plot 18.21
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object specs. . . . . . . . . .  17.32
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posterize. . . . . . . . . . . . . . . 25.5
print  . . . . . . . . . . . . . 9.11, 9.16
print preview . . . . . . . . . . . 9.11
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reduce (text size) . . . . . . .  30.7
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refresh . . . . . . . . . . . . . . .  10.18
remove effects  . .  17.25, 21.3, 
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remove wrap. . . . . . . . . . .  33.3
render  . . . . 6.12, 23.23–23.24
repeating
repel options. . . . . . . . . . .  33.5
replicate. . . . . . . . . . . . . .  17.13
resolution  . . . . . . . . . . . .  24.11
revert . . . . . . . . . . . . . . . . . .  9.7
ripple . . . . . . . . . . . . . . . . .  27.6
rotate . . . . . . . . . .  17.29, 33.12
rulers . . . . . . . . . . . . . . . . .  11.7
save . . . . . . . . . . . . . . .  2.7, 9.5
save (image selection) . .  26.17
save as . .  2.7, 9.5, 13.29, 14.2, 

26.18
save to web . . . . . . . . . . . . .  8.8
scale. . . . . . . . . . . .  17.31, 24.5
select . . . . . . . . . . . . . . . . .  17.4
select all  . . . . . . . . . . . . . .  17.2
selection to path. . . . . . .  26.15
send to back . . . . . . . . . .  17.21
send to guide layer. . . . .  11.13
send to layers . . . . . . . . .  17.21
set document scale  . . . . .  11.8
set tab length  . . . . . . . . .  10.15
shadow  . . . . . . . .  21.22, 33.13
sharpen . . . . . . . . . . . . . .  25.21
sharpen edges  . . . . . . . .  25.21
sharpen more . . . . . . . . .  25.21
show (SpriteEffects) palette . .  

34.3
show added words. . . . .  32.15
show channels  . . . . 6.7, 26.19, 

26.20, . . . . . . 26.29
show clipboard . . . . . . . . .  17.6
show grids . . . . . . . . . . . .  11.11
show page breaks  .  11.5, 11.7

show rulers. . . . . . . . . . . .  11.7
show size . . . . . . . . . . . . .  20.2
show spelling errors . . .  32.13
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show toolbox . . . . . . .  2.2, 10.5
show/hide docking bar .  10.13
show/hide guides  . . . . .  11.12
show/hide status bar  . .  10.16
show/hide text flow bars 29.14
show/hide toolbar . . . . . .  10.9
show/hide transparency preview 
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slant margin . . . . . . . . . . .  33.6
Smart Mouse . . . . . . . . .  20.11
smooth . . . . . . . . . . . . . .  26.13
smooth (paths)  . . . . . . . .  19.2
solarize . . . . . . . . . . . . . . .  27.3
spell check document. .  32.14
spell check selection. . .  32.14
spherize  . . . . . . . . . . . . . .  27.9
spread. . . . . . . . . . . . . . .  17.38
stack windows . . . . . . . . . . . 9.8
stained glass  . . . . . . . . .  27.12
threshold  . . . . . . . . . . . . .  25.4
tight (kerning)  . . . . . . . .  30.10
tighten (kerning) . . . . . .  30.10
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tighten fine kerning . . . .  30.10
tile . . . . . . . . . . . . . . . . . . . . . 9.8
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tile down. . . . . . . . . . . . . . . . 9.8
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total page count. . . . 7.5, 30.28
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twirl . . . . . . . . . . . . . . . . . .  27.8
type . . . . . . . . . . . . . . . . .  30.13
uncache object  . . . . . . . .  13.5
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unlink proxy  . . . . . . . . . . .  28.5
unlock . . . . . . . . . . . . . . .  17.22
unsharp mask . . . . . . . . .  25.21
unsmooth (paths). . . . . . .  19.2
update proxies . . . . . . . . .  28.7
vanishing point . . . .  18.8, 21.1
vertical (flip) . . . . . . . . . .  33.13
very loose (kerning) . . . .  30.10
very tight (kerning). . . . .  30.10
view fonts  . . . . . . . . . . . . .  30.6
wireframe . . . . . . . . . . . . .  13.3
zoom blur  . . . . . . . . . . . .  25.19
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commands, choosing....................  1.3
comments command...............  17.41
comments palette.....................  17.41
Commission Internationale 
d’Eclairage (CIE).......................  23.36
composite channels ....  26.19, 26.20
composite paths .......................  19.28
Computer Graphics Metafile (CGM) 
format............................................. 14.7
concentric circles

converting to paths  . . . .  19.24
drawing . . . . . . . . . . . . . .  18.10

Concentric Circles tool ...........  18.11
Configuration Center 2.7, 13.1, 13.2
Configuration Center command 13.1, 
..........................................................13.2
configure fine kerning command ......  
30.10
configuring GIS palette .............. 40.3
Connection Point tool.  18.20, 18.21
constraints

see also snap options
context menu..... 10.24, 17.4, 19.12, 
23.14, .............................................35.6
continue spell check command 32.15
contract command ...................  26.13
contrast

adjusting . . . . . . . . . . . . . .  25.7
creating high-contrast images   

25.5

Control key ...................................... 1.2
convert curve to simple paths  19.25
convert to lens command 5.4, 34.11
convert to paths command.... 17.30, 
19.11, .............................19.24, 33.16
convolve filter............................. 41.15
coordinates command ...............  40.5
copy as image command  17.8, 17.9
copy at 4X command .................  17.9
copy at 8X command .................  17.9
copy command...............  17.6, 17.13
copy options command .............  17.7
copy to layers command ......... 17.21
copy with EPS command ..........  17.9
copying
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by dragging. . . . . . . . . . .  17.20
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objects  . . . . . . . . . . . . . . . . 17.6
objects to layers  . . . . . .  17.21
text objects. . . . . . . . . . . . . 32.4
with PostScript information . . .  

17.8
copying lenses ........................... 34.11
corner anchor points ... 19.12, 19.21
corner radius, rounded rectangle ...... 
18.6
create backup when saving ......  13.6
create brushes ........................... 23.14
create command .........................  23.3
create image dialog box ............  23.4
creating........................................ 15.21

animated GIFs . . . . . . . .  36.22
attribute style. . . . . . . . .  17.39
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callouts . . . . . . . . . . . . . .  18.18
channel masks. . .  26.26, 35.8
channel masks from selections  

26.28
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composite paths . . . . . .  19.28
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dimension objects  . . . . . .  20.2
dynamic objects . . . . . . . .  22.1
flowcharts . . . . . . . . . . . .  18.18
forms . . . . . . . . . . . . . . . .  29.16
keyboard shortcuts  . . . .  13.26
lenses. . . . . . . . . . . .  5.4, 34.10
new channels  . . . . . . . . .  26.22
new documents  . . . . . . . .  11.1
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objects from selections .  26.14
paint objects .  23.1, 23.2, 23.3
pattern inks . . . . . . . . . . .  15.23
proxies . . . . . . . . . . . . . . . .  28.1
quick mask . . . . . . . . . . .  23.22
sample script for Windows 39.4
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shadows  . . . . . . . . . . . . .  33.14
slices  . . . . . . . . . . . . . . . .  36.11
Smart Lines . . . . . . . . . . .  18.20
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symbol inks . . . . . . . . . . .  15.20
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transparency effects. . . .  26.25
transparency fades . . . . .  26.29
VBScript  . . . . . . . . . . . . . .  39.9
vector masks. . . . . . . . . .  35.14
vector objects . . . .  17.33, 18.1
Visual Basic script  . . . . . .  39.5

crop command.............................  24.6
crop marks .................................  18.16
Crop tool ....................  6.3, 24.7, 24.8
cropping

constraining  . . . . . . . . . .  24.10
images . . . . . . . . . . . . . . . .  24.6
paint objects . . . . . . . . . .  10.13
vector objects . . . . . . . . .  19.18
with the selection tool . .  24.10

cropping images .......................... 24.6
crystallize effect ........................  27.11
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Cube tool....................................  18.12
cubes, drawing..........................  18.10
current inks................................  15.24
current inks and stroke ................  3.9
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current strokes ..................  16.2, 16.6
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curves

adding anchor points  . .  19.14
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deleting segments . . . . .  19.14
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general. . . . . . . . . . . .  5.1, 34.1
lens area . . . . . . . . . . . . . . .  5.4
lens magnification  . . . . .  34.11
lens viewpoint. . . . . . . . .  34.12
lenses. . . . . . . . . . . . . . . .  34.10
mode . . . . . . . . . . . . . . . . .  34.7
modifying effects area . . .  34.9
palette . . . . . . . . . . . . . . . . .  5.4
pasting . . . . . . . . . . . . . . . .  34.6
printing  . . . . . . . . . .  9.15, 34.7
removing . . . . . . . . . . . . . .  34.4
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saving and loading. . . . . .  34.5
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selection mask. . . . . . . . .  34.8
selection masks . . . . . . . .  34.8
sharing documents . . . .  34.14
smart-crop icon . . . . . . . .  34.9
transferring. . . . . . . . . . . .  34.6
transferring between objects . .  

17.13
SpriteEffects palette.................  10.11
SpriteLayer effects

properties bar  . . . . . . . . .  35.1
transparency palette . . . .  35.1

SpriteLayers
printing . . . . . . . . . . . . . . .  9.15
selecting . . . . . . . . . . . . . .  17.5

square end caps........................  16.15
square wave...............................  19.19
squares, drawing.......................... 18.2
stacking command ........................  9.8
stacking lenses ..........................  34.14
stacking order............................  17.21
stained glass effect...................  27.12
stars, drawing ............................  18.10
starting Canvas............................. 10.1
status bar....................  6.4, 9.7, 10.16
straightening curves ....  19.13, 19.23
strikethrough font style .............. 30.8
strokes.................................... 3.8, 7.14

applying custom settings 16.11
applying tapered ends  .  16.10
arrow tab  . . . . . . . . . . . .  16.17
arrows. . . . . . . . . . . . . . . .  16.7
colors  . . . . . . . . . . . . . . . .  16.6
customizing  . . . . . . . . . .  16.12
dash tab . . . . . . . . . . . . .  16.19
dashes. . . .  16.8, 16.19, 16.20
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deleting presets . . . . . . . .  16.4
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no stroke settings . . . . . .  16.9
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tapered ends. . . . . . . . . .  16.11
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strokes, outline path ................  19.26
styles command (font styles) .... 30.8
styles, text

applying to text . . . . . . . . .  31.5
basing styles on others  . .  31.6
character styles  . . . . . . . .  31.1
copying from other documents  

31.3
deleting . . . . . . . . . . . . . . .  31.6
finding and changing . . . .  32.8
modifying. . . . . . . . . . . . . .  31.6
paragraph styles . . . . . . . .  31.1

stylize filter .................................... 27.1
submenu commands ....................  1.3
subscript character style ............ 30.8
subscript command .................... 30.8
substituting fonts ...........................  9.2
superscript character style ........ 30.8
superscript command................. 30.8
SVG options

create new folder . . . . . .  14.24
put images in subfolder.  14.24

symbol ink manager.................  15.20
symbol inks

creating . . . . . . . . . . . . . .  15.20
definition . . . . . . . . . . . . .  15.19

symbol library palette
download manager  . . . . .  22.6
switching directories . . . .  22.5

symmetrical drag ......................  19.28
system requirements, script...... 39.2

T
tab dialog box............................  30.12

tabs
center . . . . . . . . . . . . . . .  30.12
comma . . . . . . . . . . . . . .  30.12
decimal . . . . . . . . . . . . . .  30.12
editing. . . . . . . . . . . . . . .  30.12
left . . . . . . . . . . . . . . . . . .  30.12
right. . . . . . . . . . . . . . . . .  30.12
tab menu  . . . . . . . . . . . .  30.12

Tag Image File Format (TIFF)  14.23
tangent lines

adding and removing  . .  19.13, 
19.22

definition  . . . . . . . . . . . .  19.21
tangent snap option....................  18.8
tapered end controls ................ 16.11
tapered strokes.......................... 16.13
target

_blank . . . . . . . . . . . . . . . . . 36.3
_parent . . . . . . . . . . . . . . . . 36.3
_popup . . . . . . . . . . . . . . . . 36.3
_self  . . . . . . . . . . . . . . . . . . 36.3
_top. . . . . . . . . . . . . . . . . . . 36.3

tear-off rulers ............................. 11.11
templates

Canvas documents . . . . . . 11.3
creating. . . . . . . . . . . . . .  13.28
envelope effect  . . . . . . .  21.13

testing hyperlinks ........................  36.8
text

alignment . . . . . . . . . . . .  30.18
apostrophes . . . . . . . . . .  13.14
as clipping paths . . . . . .  33.11
attributes  . . . . . . . . . 7.10, 30.5
background color  . . 7.10, 30.5
baseline position . . . . . . . . 30.8
binding to a circle . . . . .  33.10
binding to paths. . . . . . . . . 33.7
binds, removing . . . . . . .  33.10
capitalization styles . . . . . . 30.8
changing . . . . . . . . . . . . . . . 32.6
changing attributes . . . . . . 32.6
character attributes  31.7–31.8
character styles . . . . . . . . . 31.1
checking text flows . . . .  29.15
color . . . . . . . . . . . . . 7.10, 30.5

column breaks  . . . . . . . .  30.25
column width  . . . . . . . . .  30.23
columns. . . . . .  7.6, 29.4, 29.9
converting to paths  . . .  19.24, 

33.16
copying  . . . . . . . . . . . . . . .  32.4
copying text objects . . . . .  32.4
default inks . . . . . . . . . . .  15.24
deleting . . . . . . . . . . . . . . .  32.4
drop caps  . . . . . . . . . . . .  30.25
edit mode . . . . . . . . .  2.4, 32.1
editing . . . . . . . . . . . . . . . .  32.1
envelope effect . . . . . . . .  33.15
exporting . . . . . . . . . . . . .  32.18
extrude effect . . .  33.15, 33.16
finding . . . . . . . . . . . . . . . .  32.5
flipping. . . . . . . . . . . . . . .  33.13
flow  . . . . . . . . . . . . . . . . .  29.10
flow symbol. . . . . . . . . . .  29.13
flow symbols . . . . . . . . . .  29.14
flowing . . . . . . . . . . . . . . .  33.17
font styles  . . . . . . . . . . . . .  30.8
fonts . . . . . . . . . . . . .  7.10, 30.5
fonts, specifying . . . . . . . .  30.5
foot and inch marks . . . .  13.14
footers . . . . . . . . . . . . . . .  30.26
formatting . . . . . . . . . . . . .  30.3
formatting options . 7.9, 10.13, 

30.5
formatting text flows  . . . .  30.3
frame inks . . . . . . . .  7.10, 30.5
freeform mode . . . . . . . .  33.12
greeking preference . . . .  13.15
headers . . . . . . . . . . . . . .  30.26
horizontal and vertical scaling   

30.13
hyphenation  . . . . . . . . . .  30.24
importing . . . . . . . . . . . . .  32.16
in dimension objects . . . .  20.8
in layouts . . . . . . . . . . . . . .  29.4
in symbol inks . . . . . . . . .  15.19
indents. . . . . . . . .  30.11, 30.17
inks. . . . . . . . . . . . . .  7.10, 30.5
inks and strokes . . . . . . . .  33.1
insertion point. . . . . . . . . .  32.1
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I.26
justification.  7.10, 30.5, 30.18, 
30.23

justifying last line of paragraph  
30.23

kerning . . . . . .  7.10, 30.5, 30.9
layout  . . . . . . . . . . . . . . . . . 29.9
leader characters. .  7.10, 30.5, 

30.12
leading . . . .  7.10, 30.5, 30.15
letter spacing . . . . . . . . .  30.22
linked flows . . . . . . . . . .  29.13
lowercase . . . . . . . . . . . . . . 30.8
moving insertion point . . . 32.1
overset text  . . . . . . . . . .  29.14
page numbering  . . . . . .  30.27
paragraph attributes . .  30.14–

30.26
paragraph rules . . . . . . .  30.21
paragraph spacing. . . . .  30.16
paragraph styles  . . . . . . . . 31.1
pasting  . . . . . . . . .  32.4, 32.17
pasting attributes  . . . . .  17.12
Path Text tool  . . . . . . . . . . 29.2
pen size  . . . . . . . . . . 7.10, 30.5
placing  . . . . . . . . . . . . . .  32.17
positioning text objects  . . 29.5
preferences  . . . . . . . . . .  13.12
preset formats . . . . . . . . . . 30.4
preventing format changes 31.8
Properties bar . . . . . . . . . . 33.1
quotation marks  . . . . . .  13.14
repelling . . . . . . . . . . . . . . . 33.5
replacing. . . . . . . . . . 32.5, 32.6
resizing text objects  . . . . . 29.5
rotating . . . . . . . . . . . . . .  33.12
scaling. . . . . . . . . . . . . . .  17.31
searching . . . . . . . . . . . . . . 32.6
sections  . . . . . . . . . . . . . . . 29.9
selecting . . . . .  17.2, 30.1, 32.1
selecting linked text  . . . . . 30.3
setting indents . . . . . . . .  30.18
setting tabs. . . . .  30.11–30.12
shadow effects. . . . . . . .  33.13
skewing  . . . . . . . . . . . . .  33.12
slanting margins  . . . . . . . . 33.6

special characters  . . . . .  32.10
spell checking . . . . . . . . .  32.13
strokes . . . . . . . . . . . . . . . .  16.2
styles . . . . . . .  7.10, 7.11, 30.5
subscript . . . . . . . . . . . . . .  30.8
superscript  . . . . . . . . . . . .  30.8
tab position . . . . . . .  7.10, 30.5
tab types . . . . . . . . .  7.10, 30.5
Text Form Field tool. . . . .  29.2
Text Format Brush tool . .  29.2
Text Link tool . . . . . . . . . .  29.2
text menu commands . . .  30.3
Text Object tool . . . . . . . .  29.2
Text tool  . . . . . . . . . . . . . .  29.2
Text Unlink tool . . . . . . . .  29.2
trapping selected . . . . . .  17.38
type palette . . . . . . . . . . . .  30.3
type size. . . . . . . . . . . . . . .  30.7
typing on paths . . . . . . . .  33.16
using Text tool  . . . . . . . . .  29.2
vector effects  . . . . . . . . .  33.12
vertical justification  . . . .  30.19
vertical option. . . . . . . . . .  29.7
Vertical Text Object tool .  29.7
Vertical Text tool  . . . . . . .  29.6
word spacing  . . . . . . . . .  30.22
wrapping inside objects. . 33.3, 

33.4
wraps, removing . . .  33.5, 33.7

text file format............................ 14.25
text fill ink icon.............................  7.11
text flow bars.............................. 29.14
Text Form Field tool ......  29.2, 29.16
Text Format Brush tool .... 29.2, 29.3
Text Link tool .....  29.2, 29.14, 33.17
Text Object tool................. 29.2, 29.4
text objects .....................................  2.3
text shadow effects ................... 33.14
Text tool ................................  7.7, 29.2
Text Unlink tool ..............  29.2, 29.15
texture inks ................................. 15.21
three-dimensional effects........ 21.11
threshold command ...................  25.4
thumbnail previews, printing ....  9.13
tighten (kerning) command .... 30.10

tighten (leading) command....  30.15
tighten fine kerning command 30.10
tile across command.....................  9.8
tile command..................................  9.8
tile down command ......................  9.8
tile option ...................................... 9.11
time command ..........................  30.27
time stamp command .............  30.27
time, inserting in documents .  30.27
tints ................................................. 15.8
title command .............................. 30.8
tolerance, dimension text .......  20.10
tool palettes .................................. 10.6

docking . . . . . . . . . . . . . . .  10.5
locking  . . . . . . . . . . . . . . .  10.5
unlocking . . . . . . . . . . . . .  10.5

toolbar
adding buttons. . . . . . . .  13.27
arranging buttons  . . . . .  13.27
customizing  . . . . . . . . . .  13.24
general . . . . . . . . . . . . . . .  10.8

toolbox .............................................  2.2
tools

Airbrush . . . . . . . . . . .  6.8, 23.7
Angle dimensioning  . . . .  20.3
Animated GIF  . . . . . . . .  36.22
annotations  . . . . . . . . . .  18.18
Arc. . . . . . . . . . . . . . . .  3.4, 18.2
Arc 3 points . . . . . . . . . . .  18.3
Arc Radius . . . . . . . . . . . .  18.3
Area dimensioning  . . . . .  20.3
Auto Curve . . . . . . . . . . . .  19.5
Baseline Dimensioning . .  20.4
Baseline dimensioning . .  20.3
Basic Smart Line . . . . . . . . . 4.5
Basic Smart Lines . . . . .  18.20
Blend. . . . . . . . . . .  23.8, 26.30
Blur . . . . . . . . . . . . . . . . .  23.11
Bucket. . . . . . . . . . . . . . . .  23.8
Burn  . . . . . . . . . . . . . . . .  23.11
Camera. . . . . . . . . . . . . .  23.25
Canvas tools folder . . . . .  24.2
Center dimensioning  . . .  20.3
Chain Dimensioning . . . .  20.4
Chain dimensioning  . . . .  20.3
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Circle 3 Points  . . . . . . . . .  18.3
Circle Radius  . . . . . . . . . .  18.3
Color Dropper  . .  15.24, 23.18
Column Selection. . . . . . .  26.3
Concentric Circles . . . . .  18.11
Connection Point 18.20, 18.21
Crop. . . . . . . . . . . . . .  6.3, 24.8
Cube  . . . . . . . . . . . . . . . .  18.12
Curve . . . . . . . . . . . .  19.1, 19.3
Diameter dimensioning . .  20.3
dimensioning  . . . . . . . . . .  20.3
Direct Selection . . . . . . . .  17.3
Dodge . . . . . . . . . . . . . . .  23.11
Dogleg Connector Smart Lines  

18.20
Eraser  . . . . . . . . . .  23.8, 26.31
Freehand . . . . . . . . .  19.1, 19.3
Gradient Vector . . . . . . .  15.12
Hand  . . . . . . . . . . . . . . . .  10.17
Horizontal dimensioning .  20.3
Hyperlink pointer . . . . . . .  36.8
Kinked Smart Lines . . . . . .  4.5
Kinked Smart Lines tool  18.20
Knife. . . . . . . . . . . . . . . . .  19.17
Lasso . . . . . . . . . . .  17.27, 26.3
Line  . . . . . . . . . . . . . .  3.1, 18.2
Linear dimensioning  . . . .  20.3
Linear Dimensioning tool   20.3
Link Info  . . . . . . . . . . . . .  29.15
Magnifying Glass . .  2.4, 10.18
Marker. . . . . . . . . . . . . . . .  23.7
Marquee . . .  17.27, 26.1, 26.2
Multigon . . . . . . . . . . . . .  18.14
Neon  . . . . . . . . . . . . . . . . .  23.8
Object Side Dimensioning 20.3
Oblique dimensioning . . .  20.3
Oval . . . . . . . . . .  3.3, 4.2, 18.2
Oval Marquee. . . . . . . . . .  26.2
Page Crop . . . . . . . . . . . .  19.18
Paint Object Creator . . . .  23.2
Paintbrush. . . . . . . . . . . . .  23.7
palettes . . . . . . . . . . . . . . .  10.6
Path Text . . .  7.13, 29.2, 33.16
Pencil . . . . . . . . . . . . . . . . .  23.7
Perimeter dimensioning  .  20.3

Perpendicular dimensioning  . .  
20.3

Polygon. . . . . . . . .  19.1, 19.30
Push  . . . . . . . . . . . . . 19.1, 19.9
QuickTime . . . . . . . . . . .  14.21
Radius dimensioning  . . . . 20.3
Rectangle . . . . . . . . . .  3.2, 18.2
Red Eye Reduction . . . .  23.40
Remote Move . . . . . . . .  26.12
Reshape . . . . . . . . . . 19.1, 19.8
Rounded Rectangle  . . . . . 18.2
Row Selection . . . . . . . . . . 26.3
Rubber Stamp . . . . . .  6.9, 23.9
Scissors  . . . . . . . . . . . . .  19.16
Section . . . . . . . . . . . 7.6, 29.11
Selection. . . . . .  2.3, 17.3, 24.5
Sharpen  . . . . . . . . . . . . .  23.12
Slice Creator  . . . . . . . . .  36.12
Slice Selector . . . . . . . . .  36.12
Smart Lines . . . . . . . . . .  18.19
Smooth Kinked . . . . . . .  18.20
Smooth Polygon  . . . . . . . . 19.1
Smudge  . . . . . . . . . . . . .  23.10
Speaker Notes . . . . . . . . . . 37.3
Spiral. . . . . . . . . . . . . . . .  18.12
Sponge . . . . . . . . . . . . . .  23.12
Sprite  . . . . . . . . . . . . . . . . . 35.8
Sprite tool. . . . . . . . . . . .  26.26
Text . . . . . . . . . . . . . . .  7.7, 29.2
Text Form Field . .  29.2, 29.16
Text Format Brush  . 29.2, 29.3
Text Link. .  29.2, 29.14, 33.17
Text Object  . . . . . . . 29.2, 29.4
Text Unlink. . . . . .  29.2, 29.15
Vector Transparency. . .  35.13
Vertical dimensioning . . . . 20.3
Vertical Text. . . . . . . . . . . . 29.6
Vertical Text Object  . . . . . 29.7
Wand  . . . . . . . . . . . . . . . . . 26.4
Web Button . . . . . . . . . . . . .  8.1

tooltips...........................................  10.9
total page count command 7.5, 30.28
trace contour command............  27.4
tracking

see letter spacing

transfer modes
applying . . . . . . . . . . . . . . .  35.1
burn . . . . . . . . . . . . . . . . .  35.20
darken . . . . . . . . . . . . . . .  35.19
difference  . . . . . . . . . . . .  35.19
dodge. . . . . . . . . . . . . . . .  35.19
hard light . . . . . . . . . . . . .  35.19
lighten . . . . . . . . . . . . . . .  35.19
multiply . . . . . . . . . . . . . .  35.19
normal . . . . . . . . . . . . . . .  35.19
overlay . . . . . . . . . . . . . . .  35.19
properties bar . . . . . . . . .  10.12
screen  . . . . . . . . . . . . . . .  35.19
soft light. . . . . . . . . . . . . .  35.19

transferring attributes
see paste attributes  . . . .  17.11

transformed dimensions.........  17.27
transforming

objects . . . . . . . . . . . . . . .  17.16
transform command  . . .  21.21

transparency..............................  10.12
channel masks . . . 35.6–35.12
combining objects . . . . . .  21.9
defined. . . . . . . . . . . . . . . .  35.3
opacity . . . . . . . . . . . . . . . .  35.2
paint object background .  23.2
preserving in images  . . .  26.31
preserving visibility. . . . .  26.31
preview . . . . . . . . . . . . . . .  35.5
printing  . . . . . . . . .  35.4, 35.21
printing options  . . . . . . . .  9.15
scope . . . . . . . . . . . . . . . .  35.14
scope setting. . . . . . . . . . .  35.4
select scope  . . . . . . . . . .  35.18
SpriteLayer effects 35.1–35.22
transfer modes .  35.18–35.20
vector masks. . .  35.12–35.18
visibility masks . .  23.21, 26.31

transparency palette ......  26.26, 35.1
transparency preview .................  35.6
trap object option.....................  17.38
trapping

limitations . . . . . . . . . . . .  17.38
options. . . . . . . . . . . . . . .  17.36
trap size . . . . . . . . . . . . . .  17.38
INDEX I.27



I.28
trim command.....................  6.3, 24.7
trimming objects .........................  21.7
tritone image mode..................  23.37
TrueType fonts ............................  30.7
TWAIN

acquire command . . . . . . . 24.2
acquiring from . . . . . . . . . . 14.5
devices . . . . . . . . . . . . . . . . 24.1
select source command . . 24.1

twirl filter.......................................  27.8
two-byte fonts............................  13.15
two-byte fonts and text..............  29.5
two-sided documents

see facing pages
type

command . . . . . . . . . . . .  30.13
hyphenation . . . . . . . . . .  30.24
leading . . . . . . . . . . . . . .  30.16
size  . . . . . . . . . . . . . . . . . . . 30.7
special characters . . . . .  32.10
type libraries (scripting) . . 39.6
type palette  . . . . . . . . . .  30.18
type styles  . . . . . . . . . . . . . 31.1
vertical option . . . . . . . . . . 29.8

type preferences
auto word select . . . . . .  13.16
clear font history . . . . . .  13.15
drag & drop text  . . . . . .  13.15
draw text as Béziers . . .  13.16
enable two-byte script . . . 29.5
multi-column font menu  13.16
pasted text box size  . . .  13.15
replace selection on paste . . . .  

13.15
smart copy . . . . . . . . . . .  13.15
use greeked text . . . . . .  13.15
use smart quotes. . . . . .  13.14
when typing into document . . .  

13.12
Windows only . . . . . . . .  13.16

types of objects ...........................  17.1

U
Ultimate Points filter ..................  41.8
uncache object command ........  13.5

underline font style .....................  30.8
undo command .............................  2.7

definition . . . . . . . . . . . . . . .  9.6
number of undo levels . . .  13.7
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